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Getting Started With PowerWorld 

Chapter 1 : Getting Started With PowerWorld 

This chapter provides the essential information you need to start using PowerWorld Simulator.   

The following material is included: 

• Introduction to PowerWorld Simulator 

• About this Manual 

• Windows Basics 

• What’s New in Version 10.0 

• PowerWorld Simulator: Getting Started 

• Using the Toolbars 

• Edit and Run Mode 

• Message Log 

• Web Publishing 

• How to Get Help 
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About this Manual 

In addition to this manual, PowerWorld Simulator includes comprehensive, context-sensitive on-line help.  In fact, most 
of this manual is derived from the on-line help.  We would strongly recommend using the on-line help since it provides 
features not available in a printed manual, such as the ability to jump to another topic simply by double-clicking on it.  
Furthermore, the on-line help is likely to be the more up-to-date reference as program updates are issued. 
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Introduction to PowerWorld Simulator 

PowerWorld Simulator (Simulator) is a power system simulation package designed from the ground up to be user-
friendly and highly interactive.  Simulator has the power for serious engineering analysis, but it is also so interactive 
and graphical that it can be used to explain power system operations to non-technical audiences.  With Version 10.0  
we’ve made Simulator easier to use, yet even more powerful and more visual.   

Simulator is actually a number of integrated products.  At its core is a comprehensive, robust Power Flow Solution 
engine capable of efficiently solving systems of up to 60,000 buses.  This makes Simulator quite useful as a stand-
alone power flow analysis package.  Unlike other commercially available power flow packages, however, Simulator 
allows the user to visualize the system through the use of full-color animated oneline diagrams  with full zooming and 
panning capability.  Moreover, system models may be modified on the fly or even built from scratch using Simulator’s 
full-featured graphical case editor.  Transmission lines may be switched in or out of service, new transmission or 
generation may be added, and new transactions may be established, all with a few mouse clicks.  Simulator’s 
extensive use of graphics and animation greatly increases the user’s  understanding of system characteristics, 
problems, and constraints, as well as of how to remedy them. 

Simulator also provides a convenient medium for simulating the evolution of the power system over time.   Load, 
generation, and interchange schedule variations over time may be prescribed, and the resulting changes in power 
system conditions may be visualized.  This functionality may be useful, for example, in illustrating the many issues 
associated with industry restructuring.   

In addition to these features, Simulator boasts integrated economic dispatch, area transaction economic analysis, 
power transfer distribution factor (PTDF) computation, short circuit analysis and contingency analysis, all accessible 
through a consistent and colorful visual interfac e.  These features are so well integrated that you will be up and 
running within minutes of installation. 
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What's New in Version 10.0 

Simulator Version 10.0 boasts a number of major new features as well as a host of smaller enhancements designed to 
improve the performance and convenience of the package.  Among Simulator’s major new features are the following: 

 

Graphical User Interface Changes 

• New User-Customizable Menus and Toolbars have been added throughout the software.  Included in this are 
numerous new toolbars buttons for changing settings and options in the software 

• New Custom Case Information Displays: these allow the user to build a custom "workbook-like" case info 
display where the value displayed in each cell is defined by the user. 

• Three Custom Floating Point and Custom Strings are now available for power system objects such as buses, 
lines, generators, shunts, etc…  Just add them using the Display/Column options on the relevant Case 
Information Displays. 

• Automated file archiving as you save PWB files.  This is accessed on the Environment tab of the Simulator 
Solution/Environment Dialog. 

• All the options on the Oneline Display Options dialog can now be saved as named Oneline Options.  These 
various settings are then stored with the case and can be applied to other onelines.  They may also be saved 
as an AUX file.  These features are accessed via button at the button of the Oneline Display Options Dialog. 

• Bus View Customizations: Users may now define the fields which are displayed on the bus view and store 
these as Custom Bus Views.  A new button is available at the top of the bus view which says Views > and gives 
access to these abilities.  Along with the custom views, there are now  two hard-coded views: System State and 
Input Data 

• Bus View Include Field Labels: users may choose a new option so that the name of the fields shown on the bus 
view are displayed. 

• A new oneline object has been added for displaying a multi-section line object as a single object instead of it’s 
component lines. 

• All oneline objects in Simulator may now be assigned to a layer.  Users may then show/hide entire layers or 
select objects based on these layers.  

• Text on the oneline may now be rotated. 

• A new ability to browse through all open onelines for particular objects is now available.  

• General improvements throughout when using the Search/Find dialogs 

• General improvements throughout regarding the case information diaplays: Color coding of columns headings 
for required/key fields, coloring of sorted columns, centering of column text, captions show the name of the 
advanced filter, and many other…) 

• Transformers may now have multiple colors allowing you to show the high and low voltage sides with different 
colors. 

• Added a oneline browsing path.  This is used with oneline links, document links, and substation objects.  When 
looking for a particular file or oneline to display after clicking on one of these links, Simulator will look in the 
specified directory path.  

• Pie Charts now display what their percentage is based on (MVA, Amps, PTDF, etc…) as well as what rating 
they are based on (A, B, C, etc…) 

 

New Data and Features 

• Interface elements may now have a multiplier specified for them.  Using this feature you may create limits which 
represent the weighted sum of element flows instead of only the pure sum. 

• Interfaces may now include DC lines flows, generator outputs, load values, and injection groups as members of 
the interface.  DC line flows add to the interface flow.  Generators add to the flow.  Loads subtract from the flow.  
Injection Groups add the "net injection" of the entire group to the flow.  Using this feature you may specify 
special limits such as the net generator output from a power plant (sum of generators < Max value). 

• Nomograms may now be created which represent a two-dimensional flow limit.  A nomogram is defined by 
specifying two interfaces as the two-dimensions, and then specifying a curve which represents the limitation on 
these interfaces. 

• An extra tool has been added for merging all the devices at a two buses into a single bus.  

• An extra button has been added to the TLR/GSF and Other Sensitivities dialog which allows you to set the "P 
Sensitivity" for out-of-service buses equal to the value at the c losest in-service bus. 

• Added support for specifying 8 transmission line and interface limits instead of the present 3 values. 
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• Ownership records throughout Simulator have been greatly enhanced.  For instance users may now Scale the 
system by owner. 

• The topological comparison tool has been enhanced to include all objects. 

• Substation information is made more prominent throughout the software. 

• Now when a bus is deleted from the case, you can choose to delete all attached devices at the same time. 

 

Contingency Analysis Changes 

• Contingency Comparison now includes violations from both the comparison and controlling case 

• Improved the linear solution techniques for Contingency Analysis and ATC so that they work properly when 
contingencies result in a change in the number of islands in the system 

• Many new contingency actions included:  
* DC Line Open/Close and MW/Amp set-point modifications 
* Phase Shifter MW set-point modifications  
* Addition of a power flow solution inside the contingency definition to change the method used for solving the 
power flow. 

• More options for automated text file contingency reporting 

• Added support for monitoring nomogram limits in the contingency analysis . 

• Added support for handling "Load Throwover" records for buses.  When a bus goes out-of-service as a result of 
a contingency the load at the bus is then moved to another bus to simulate distribution system switching. 

• Added script commands for auto-inserting contingencies. 

• Now record the total amount of load which is islanded during a contingency 

• The post-contingency solution make-up power is now handled by utilizing Simulator’s new Island-based 
Automatic Generation Control response. 

 

PVQV Modifications  

• Many upgrades to the reporting of PVQV information 

• Modification of how buses which contain switched shunts are handled in the QV  tool 

• Modified the QV curve tool to create the QV curve for contingencies even when the contingency is unsolvable 
in the base case system.  This provides estimates of "negative Mvar margin". 

 

Power Flow Modifications  

• Generation Control may now be achieved across an island instead of across an area.  Island-based AGC is 
available on the Power Flow Solution tab of the Solution/Environment Dialog. 

• Switched Shunt Control Range modification: You can now specify different target voltages for after hitting the 
high limit compared to the low limit 

• Modified Line-Drop-Compensation for generators so that all generators at a single bus act together to perform 
LDC voltage control. 

• Improvements to the optimal multiplier technique for use when calculating power flow solutions near voltage 
collapse. 

• Provided the ability to better control tap-changing transformers which are in parallel with each other.  Parallel 
transformers will coordinate their switching actions so that they maintain similar tap settings (the same value if 
possible). 

• Added the ability to specify post-solution actions.  Post-solution actions represent "contingency-like" actions that 
occur at the end of every power flow solution.  Normally these actions would be conditional actions such as 
under voltage load shedding (i.e. IF voltage is low, then Drop Load). 

 

OPF and SCOPF Enhancements 

• Added support for enforcement of the new nomogram limits in the OPF and SCOPF. 

• Add load-multipliers that are used when the "Use DC Approximation" option is checked in the Power Flow 
Solution Options.  These multipliers are specified for each bus in the system and are applied to all loads at the 
bus.  These multipliers are intended to represent the transmission system losses that are removed when using 
the DC approximation. 

• Add the ability to utilize the loss-sensitivity values which are "User-Specified" in the DC OPF/SCOPF routines.  
These act as penalty multipliers on the output of power of generators at these buses and will affect the dispatc h 
solution. 
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• Added the ability to specify a piecewise-linear curve to represent the maximum violation cost used in the OPF 
and SCOPF.  This curve can be thought of as a "penalty curve" applied when violating the flow constraints.  By 
specifying lower penalties for lower overloads and then increasing the penalty as the overload worsens, a more 
gradual change from enforceable to unenforceable will be seen. 

• Added load dispatch as a control in the SCOPF algorithm. 

• Added support for modeling reactive flow adjustments in the DC SCOPF algorithm 

• Added support for calculating the reactive power LMPs when solving the full AC OPF or SCOPF. 

• Add the MW area-to-area transaction as a control for the OPF and SCOPF algorithms.  When the transactions 
is between two areas that are both on OPF control, then the OPF algorithm will determine the appropriate MW 
level.  If only one area is on OPF control, then a price curve for a MW transaction may be specified to dispatch 
against. 

• Added the ability to specify a reference for losses and for energy by Area and Super Area.  These references 
are then used to calculate components of the final MW Marginal Cost (LMP) at each node in a power system.  
The components are for energy, losses and congestion. 

 

Simulator Automation Server (SimAuto) 

The Simulator Automation Server tool has undergone changes to the function declarations in version 10.  This will 
affect any currently written functions that access SimAuto from outside programs.  The changes should be fairly 
straightforward to make so that existing programs accessing SimAuto can be modified to access SimAuto in 
Simulator version 10.  For more information, see the help on the Simulator Automation Server. 

 

Script File Enhancements 

More script actions and data support have been added to the Simulator Script and Data Auxiliary file format. 
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Help 

On-line help is available in PowerWorld Simulator, either through using the Help main menu item, or by clicking the 
Help button or the F1 key on many dialogs and displays.  Furthermore, context-sensitive help is available on the 
oneline diagrams by positioning the mouse over any object on the oneline and pressing the F1 key to obtain help on 
that object. 

Sample power flow cases and other information are available at the PowerWorld web site, 
http://www.powerworld.com 

Contact our technical support at support@powerworld.com for answers to your questions regarding any PowerWorld 
product.  Or call us at (217) 384-6330. 

PowerWorld Corporation 
1816 South Oak Street 
Champaign, IL 61820 

PowerWorld Interface  

Windows Basics  

Simulator 10.0 runs under Windows 95/98/2000/Me/XP and NT 3.5 and later operating systems.  Since much of the 
interaction between Simulator and the user is accomplished by using the mouse, we have designed the interface to 
obey consistent conventions for mouse usage.  In general, the left-mouse button is used to affect some sort of 
immediate change or control over a power system element, while the right mouse button is used to gain more 
information about a power system element or to view a list of available options.  More details on mouse interaction will 
be provided throughout this manual. 
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PowerWorld Simulator: Getting Started 

The key to using Simulator is to recognize that it has two distinct modes: the Edit Mode and the Run Mode.  The Edit 
Mode is used to construct new simulation cases or to modify existing cases, while the Run Mode is used to perform 
the actual power system simulation.  You can easily switch between the modes at just about any time using the Edit 
Mode and Run Mode buttons on the Program Toolbar.  Each mode has its own distinct set of menu commands.  The 
entries on these menus are explained in the following sections.   

If you are new to Simulator and seek a quick means of familiarizing yourself with it, you may wish to start with the 
tutorial; see Creating a New Case.  Or if you’re interested in trial-and-error learning, you may just wish to open one of 
the sample cases and start learning.  
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Edit Mode Introduction 

The Edit Mode is used to create a new case or to modify existing cases.  To switch to Edit Mode, click on the Edit 
Mode button on the Program Toolbar, or choose File > Switch to Edit Mode  from the file menu.   

 

Here is a sampling of things you can do in Edit Mode: 

• Create a completely new case; see New Case for details.   

• Create a new oneline diagram; see New Oneline for details.   

• Add new components graphically to an existing case; see Insert Menu for details. 

• Modify the appearance of the oneline objects; see Format Menu for details. 

• View and modify a case using non-graphical lists displays; see Case Information Displays for details. 

• Equivalence a case; see Equivalencing for details. 

• Append a subsystem to an existing case; see Appending a Case for details.   

For more details on the Edit Mode please see Edit Mode Overview.   
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Run Mode Introduction 

The Run Mode is used to solve a single Power Flow Solution, run one of the available load flow tools, or run a time-
domain simulation of the power system.  To access the Run Mode click on the Run Mode button on the Program 
Toolbar, or choose File > Switch to Run Mode from the file menu. 

The key menu associated with the Run Mode is the Simulation menu.  This menu allows you to either perform a single 
Power Flow Solution (however, it is quicker to use the toolbar), or start a time-domain simulation. 

   

Other key components of the Run Mode include: 

• The oneline diagrams, which allow you to view the case graphically.  See Oneline Diagram Overview for details. 

• The Case Information Displays, which allow you to view the entire power system case using list displays.  See 
Case Information Displays for details.   

• Dialogs to change the simulation options and the Power Flow Solution.  See Simulation Options for details. 

• Various strip-charts for plotting the time-variation in system values.  See Load and Generation Chart for an 
example. 

• Scaling to allow easy variation in the load, shunts, and generation at any number of buses.  See Scaling for 
details.   

• Contouring, which shows a color contour representing the variation in any power system parameter across a 
system.  See Contouring for details.   

• Transfer distribution factor calculations.  See Power Transfer Distribution Factors for details. 

• Perform a fault analysis.  See Fault Analysis for details. 

• Run Transfer Capability studies. 

• Perform an Optimal Power Flow (OPF) or Security Constrained Optimal Power Flow (SCOPF) analysis. 

• Generate PV and QV curves. 

• Customization based upon whether you are doing pure power flow studies, or time-domain economic analysis.   
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Script Mode Introduction 

The Script Mode is used to access the Script Command window.  Simulator scripting allows a method of grouping 
multiple commands for sequential processing by Simulator.  From the Script Command Execution window, the user 
can manually enter script commands for processing, or load an auxiliary file containing multiple script commands and 
data modification commands. 
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Message Log 

The Message Log displays detailed results of each Power Flow Solution, chronicling the solution process iteration by 
iteration.  It also reports messages raised by Simulator in performing various operations, such as opening or validating 
a case.  The Message Log can be helpful when you run into problems solving a particular simulation case.  The 
Message Log is not used with Viewer.   

To display the Message Log, click on Log on the Program Toolbar. 

Right-clicking on the Message Log displays its local menu.  To print a highlighted section of or clear the log, select 
either Print Selection or Clear . You can also copy the contents of the message log to the Windows clipboard by 
highlighting text in the log and selecting Copy Selection to Clipboard.  You can change the Message Log’s font by 
selecting Change Font from the local menu.  Lastly, you will find some log options available, such as Change 
Maximum Lines, Disable Logging and Save Log to File options which allow automatically saving the log to a file 
during load flow analysis. 
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Web Publishing 

Simulator provides tools for creating presentations of data and diagrams produced using the application for display on 
the world-wide web.  These tools include 

 

• The ability to save case information display contents as HTML code. 

• The ability to save oneline diagrams and strip charts as jpeg files.  See Saving Images as Jpegs for more 
information. 

• A basic HTML editor that can import HTML code written using other applications. 

• A mechanism for uploading your HTML documents to your web server.  See Publish to Web for details. 

Consult the chapter on Web Publishing for more information on how to publish your Simulator data on-line. 
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Memo Display 

The Memo page is now available on many dialogs and displays in Simulator.  The purpose of the memo display is to 
allow the user to add their own custom information and comments to data and objects in the load flow case.  Simply 
switch to the Memo page on a display and start typing in the box.  The information added to these memo pages is 
stored with the objects in the load flow case. 

Toolbars 

Using the Toolbars 

Simulator 10.0 makes extensive use of toolbars for easy access to its many features.  You can move and size these 
toolbars according to your preferences.  The toolbars house several controls, each of which may be activated with a 
single mouse click.  Simulator provides several customizable toolbars that group commonly used functionality.  Many 
of these toolbars are displayed by default, with certain toolbars only available in either edit mode or run mode.  To 
either display or hide toolbars, you can either select the Window > Toolbars menu option, or right-click in the toolbar 
docking area near the top of the oneline diagram.  The Toolbars available in Simulator are: 

• Main Menu Toolbar 

• File Toolbar  

• Program Toolbar  

• Options/Info Toolbar  

• Zoom Toolbar  

• Format Toolbar  

• Edit Toolbar  

• Case Information Toolbar  

• Insert Toolbar  

• Pie Chart Options Toolbar  

• Animated Flow Options Toolbar  

• Contour Options Toolbar  

• Solution Options Toolbar  

• Thumbnail View Options Toolbar  

• Run Mode Toolbar  
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Main Menu Toolbar  

 
The Main Menu toolbar provides access to the main menus of the program, such as File, Edit, Insert, Windows, and 
Help.  This toolbar is always visible, but it can be customized just like any other toolbar in Simulator.  The menus can 
be customized to contain additional menu options beyond those initially displayed by default.  Any menu or toolbar 
customizations will be stored in the system registry for recall when Simulator is launched on your computer.  If you 
wish to reset the toolbars and menus to their default settings, you can do so by right-clicking in the toolbar area, and 
pressing the Reset button on the Toolbar page of the toolbar customization dialog. 
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File Toolbar  

 
The File Toolbar provides access to operating system activities such as saving a oneline diagram or case model to 
disk, printing a oneline display to a printer, or loading a case or oneline from disk.  This toolbar also offers access to 
the on-line help system and to PowerWorld’s case validation tool.  
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Program Toolbar 

 
The Program Toolbar gives you the ability to switch between the program’s Edit and Run Modes and to control various 
aspects of the Power Flow Solution.  The options available from the program toolbar include: 

Edit Mode  

Switches the program to Edit Mode, which can be used to build a new case or to modify an existing one. 

Run Mode  

Switches the program to Run Mode, which can be used to perform a single Power Flow Solution or a timed 
simulation with animation. 

Script Mode  

Opens the Script dialog, which can be used to call script commands or open auxiliary files containing script 
commands and data modifications. 

Single Solution (Run Mode only)  

Performs a single solution of the power flow equations, as opposed to a timed simulation.  The single solution 
button allows you to use Simulator as a standalone power flow.  See PowerWorld Simulation Control for details. 

Log 

Toggles the display of the message log window.  The log window shows what is going on with the Power Flow 
Solution process and may prove useful when you are trying to track down a problem with a non-converging model. 

Abort 

Terminates the current Power Flow Solution.  If the application is performing a timed simulation, pressing the abort 
button will pause the simulation. See PowerWorld Simulation Control for more details. 
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Edit Toolbar  

 
The Edit Toolbar (Edit mode only) links to several case edit tools.  You can cut or copy single objects on the oneline 
diagram and paste them into the same or another diagram.  You can perform the same operations with groups of 
elements that have been identified through either the Select By Criteria or the Selection Rectangle tools. 
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Insert Toolbar  

 
The Insert Toolbar (Edit mode only) contains a number of buttons that allow you to add drawing objects to the current 
oneline diagram.  These objects include power system components such as buses, transmission lines, transformers, 
loads, generators, areas, and zones, as well as informational objects such as pie charts and analogs.  You may also 
add display objects such as text fields, rectangles, ellipses, arcs, and free-form shapes, which are not linked to objects 
in the power system model.  The buttons on this toolbar provide access to most of the activities available from the 
Insert menu. 
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Format Toolbar  

 
The Format Toolbar (Edit mode only) allows you to control such display object attributes as font, color, line styles, 
zoom-dependent visibility, and display layer level.  This toolbar also enables you to set default values for various 
drawing parameters and to reset the default values when necessary. The Format Toolbar provides access to most of 
the activities available from the Format branch of the main menu. 
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Case Information Toolbar  

 
The List Display Toolbar provides easy access to many Case Information Display options for formatting and 
customizing a list display.  The buttons on the toolbar will only be available if you have at least one case information 
display open in Simulator.  The list display functions and options available from this toolbar are copying and pasting 
data, finding data or text, opening an information dialog, setting the display/column options, advanced filtering and 
sorting, refreshing the display, displaying metrics for a column, autosizing the grid, and setting the decimal places for 
columns containing numerical data.  All of these options are available through the popup menu of each case 
information display as well. 
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Zoom Toolbar  

 
To display large detailed power systems, Simulator’s onelines possess zooming and panning capabilities.  The Zoom 
Toolbar enables you to prescribe a zoom level either by directly specifying a zoom value or by selecting a rectangular 
region of the diagram on which to focus.  In addition, this toolbar enables you to save a view location, or recall a 
previously saved view location.  This toolbar also links to a dialog box from which you can select a bus on which to 
center the display. See Zooming and Panning for more information. 
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Options/Info Toolbar  

 
The Options/Info Toolbar provides quick access to Simulator’s many information displays and option settings.  Use this 
toolbar to set simulation and solution options, define area/zone/owner filters, perform a Single Power Flow Solution, 
generate quick power flow lists and the bus view displays, and to switch to other open oneline diagrams.  
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Run Mode Toolbar  

 
The Run Mode toolbar offers access to various Run Mode activities.  It features VCR-like controls for starting, 
resetting, and pausing the simulation.  It also links to Run Mode tools such as contouring, difference flows, and fault 
analysis.  
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Solution Options Toolbar  

 
The Solution Options Toolbar provides access to most of the solution options contained in the Solution Options dialog 
in an individual manner through menu commands. 
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Animated Flows Options Toolbar  

{  

The Animated Flows Options Toolbar provides access to most of the solution options contained in the Animated Flows 
Options dialog in an individual manner through menu commands. 
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Pie Chart Options Toolbar  

 
The Pie Chart Options Toolbar provides access to most of the solution options contained in the Pie Charts Options 
dialog in an individual manner through menu commands. 
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Thumbnail View Options Toolbar 

 
The Thumbnail View  Options Toolbar provides access to most of the solution options contained in the Thumbnail View 
Options dialog in an individual manner through menu commands. 



Getting Started With PowerWorld 

29 

Contouring Options Toolbar  

 
The Contouring Options Toolbar provides access to most of the solution options contained in the Contour Type 
Options dialog in an individual manner through menu commands.  
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Toolbars Customization 

The Customize Toolbar dialog allows the user to customize specific toolbars.  To access this dialog, select Window > 
Toolbars > Customize… or right-click on any toolbar and select Customize…  

The dialog The Print Options Dialog has three tabs: 

 

Toolbars 

This tab sheet allows the user to activate or deactivate specific toolbars, as well as create its own specialized ones.  It 
presents the following controls: 

Activate or deactivate a toolbar  

• Click the check box to activate (or deactivate) the specific toolbar. 

New toolbar  

• Click the New… button, and give the toolbar a name in the Toolbar name dialog box. 

• Add commands to the toolbar using the Commands tab of the Customize dialog box. 

Rename a toolbar 

• Click the Rename… button to edit the name of the toolbar. 

Delete a toolbar  

• Click the Delete  button to delete the currently highlighted toolbar in the Toolbars list box. 

• A prompt appears, asking if the user really wants to delete the toolbar.  Click Yes to confirm the deletion. 

Reset a toolbar  

• Click the Reset… button to reset the currently highlighted toolbar in the Toolbars list box to the state it was in 
when Simulator was installed.  

• A prompt appears, asking if the user really wants to reset the changes made to the toolbar.  Click Yes to 
confirm the resetting. 

 

Commands  

This tab sheet allows the user to c ustomize the menus or toolbars.  The following customizations can be done: 

To add a command to a toolbar or menu:  

• Select the command category in the Categories list box. The commands available appear in the Commands 
list box. 

• Click on a command in the commands list box and drag it to an existing menu or toolbar. 

• An I-beam appears when the cursor is placed over a valid position to drop the command. 

• Release the mouse button at the position you want to insert the command. 

Notes: 

• A small button appears at the tip of mouse pointer when you drag a command. The check mark below the 
pointer means that the command cannot be dropped at the current cursor position. 

• The check mark disappears whenever you can drop the command (over a tool bar or menu). 

• Placing the cursor over a menu when dragging opens it, allowing you to insert the command anywhere in the 
menu. 

• Commands can be placed in menus or tool bars. If you created you own toolbar you can populate it with your 
own commands/icons. 

To delete a command or menu:  

• Click on the menu entry or icon you want to delete, and drag with the mouse. 

• Release the mouse button whenever the check mark icon appears below the mouse pointer. 

• The command, or menu item is deleted from the menu or tool bar. 

 

Options  

This tab sheet allows the user to set general environment settings.  It presents the following controls: 

Menus show recently used commands first 

Check this box if you want the menus show your recently used command first. 

Show full menus after a short delay 
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Check this box if you want the full menus be shown after a short delay. 

Reset my usage data 

Click this button to reset the usage data, which includes the information about the recently used commands. 

Large icons  

Check this box to use larger versions of the icons, instead of the standard size icons. 

Show ToolTips on toolbars 

Check this box to display a popup when the mouse pointer is placed over an icon in any of the icon bars.  The 
popup contains a short description of the icon function, as well as the associated keyboard shortcut, if one has been 
assigned. 

Show shortcut keys in ToolTips  

Check this box to have the shortcut displayed in the tooltip. 

Menu animations  

Choose what kind of animation you want for the menus to display. 
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Using Oneline Diagrams 

Chapter 2 : Using Oneline Diagrams 

Simulator has been designed to be both highly graphical and interactive.  The key to making effective use of Simulator 
is understanding the oneline diagrams.  This chapter provides essential information on how to use and customize 
these onelines. 

The following material is included: 

• Oneline Diagram Overview  

• Oneline Screen Coordinates 

• Oneline Local-Menu  

• Save View Level Dialog 

• Oneline Zooming and Panning 

• Oneline Animation 

• Print Options Dialog/Printer Setup 

• Oneline Conditional Display of Objects  

• Copying Onelines to Other Programs  

• Window Menu Command 

• Oneline Customization Options 

• Relationship Between Display Objects and the Power System Model 
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Oneline Diagram Overview 

The purpose of the oneline diagram is to show information about the power system graphically.  Such displays are 
called oneline diagrams (onelines) because the actual three-phase power system components are represented using 
a single line.  Simulator helps make the onelines "come alive" by providing 

• zooming and panning 

• conditional display of objects  

• animation  

Additionally, a key aspect of Simulator is the ease with which it allows you to examine and modify many of the devices 
contained on the oneline diagram.  For most objects, this is accomplished by positioning the cursor on the object and 
right-clicking.  

You may open any number of oneline diagrams, including multiple copies of the same oneline. 
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Relationship Between Display Objects and the Power System Model 

This section is intended for more advanced users familiar with the fundamentals of power system modeling. 

A key strength of the Simulator is its ability to allow users to manipulate a power system model graphically. This 
capability greatly simplifies the work involved in developing or maintaining a power system case for both novice and 
advanced users.  However, it is important to keep in mind the distinction between the display objects shown on the 
onelines and the actual power system model, consisting of model objects.  A key concept is that any number of display 
objects, including none at all, can be associated with a single model element. 

Simulator uses a bus-oriented model.  In other words, the model objects are either the buses themselves, objects that 
are radially attached to a bus (i.e., loads, generators and switched shunts), or objects that join two buses (i.e., 
transmission lines, transformers or dc lines).  As long as there is a one-to-one mapping between display objects and 
model objects, the distinction between the two could be made entirely transparent to the user.   

However, this would limit flexibility.  In fact, It is quite reasonable to use more than one display object to represent a 
single model object.  For example, by using the conditional zoom feature, two bus display objects could be used on a 
single oneline to represent the same bus.  One bus might be visible over a particular zoom range, while another, with 
perhaps a different size/thickness, is visible over another range.  Alternatively the same bus could be represented 
using display objects drawn on separate onelines.   

An ambiguity arises when the user uses the Cut command to delete the bus.  Are they deleting just the Display Object 
or the Display Object and the Model Object?  To get around this difficulty, Simulator prompts you when you are 
deleting a display object with an associated model object.  You can either delete both the Display Object and its 
associated model object record, delete just the display object, or cancel the delete.   

Also, there is no requirement that model objects have a corresponding display object.  Thus, you could use the oneline 
diagram to show just a fraction of the total system buses and other devices.  Also, you can use the Case Information 
menu to view the model objects directly regardless of whether or not they are shown on a oneline. 

Oneline Tools and Options  

Oneline Local Menu 

The local menu provides access to a number of options and tools directly from the oneline.  To display the local menu, 
position the cursor to an empty portion of the oneline and then click the right mouse button.  The local menu will 
appear.  The contents of the local menu depends on whether the application is in Edit Mode or Run Mode.   

 

Find Object on Oneline (Edit and Run Modes) 

Displays the Zoom, Pan, and Find Objects dialog.  You can use this dialog to find a particular object on the oneline.  

Oneline Display Options (Edit and Run Modes)  

Displays the Oneline Display Options dialog.  This dialog allows you to customize the appearance of the oneline.  

Pan/Zoom Control (Edit and Run Modes)  

Displays the Zoom, Pan, and Find Objects dialog.  This dialog allows you to modify the zooming and panning levels 
for the display. 

Area Information Dialog (Edit and Run Modes)  

Displays the Area Information Dialog for the area of the bus that is closest to the point where the local menu was 
displayed. 

Contouring (Run Mode Only) 

Displays the Contour Options Dialog.  This dialog allows you to contour the system voltage magnitudes or angles.   

Difference Flows (Run Mode Only) 

Displays the Difference Flows Dialog.  This dialog is used to compare two power system operating points.   

Toggle Flow Visualization (Run Mode Only) 

Switches the oneline's animated flows between displaying actual flows and power transfer distribution factors. 

Set As Contingency Reference (Run Mode Only) 

This option is available only when the Contingency Analysis Dialog is open.  Select this option to set the case 
currently in memory as the starting point for future contingency analysis. 

Edit Screen Layers (Edit and Run Modes) 

Opens the Screen Layers case information display. 

Show Layers (Edit and Run Modes) 

Allows activation of any saved screen layer. 

Show Layer> 

By highlighting this option, you can then select the layer to be displayed from the submenu. 

Print Oneline (Edit and Run Modes) 
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Sends a copy of the oneline diagram to the printer.  Selecting this option has the same affect as selecting File, 
Print Oneline  from the main menu. See Printing Oneline Diagrams  for more information. 

Copy Image to Clipboard (Edit and Run Modes) 

Copies the oneline file into the Windows clipboard using the Windows Metafile format (*.wmf).  You can then paste 
the oneline into another program, such as a word processor.  See Copying Onelines to Other Programs  for details.   

Export Image to File (Edit and Run Modes)  

Saves a copy of the entire oneline diagram to a file.  Images of a oneline can be saved using the bitmap format 
(*.BMP), the Windows Metafile format (*.WMF, .EMF), or the JPEG format (.jpg). 

Toggle Full Screen (Run Mode Only) 

Setting this option will make the oneline diagram window full screen size, which will also hide all toolbars and status 
bars.  Right-click and uncheck the Full Screen option to return the window to normal. 

Borderless (Run Mode Only) 

Toggle this option to hide all borders currently displayed on the diagram. 

Embed a Display (Run Mode Only) 

Clicking on this option allows you to open another oneline diagram (or the same one) and embed the new display 
inside the existing display.  You can choose what percentage size the embedded display should be, and where 
within the existing window the embedded window should be placed. 

Apply Template (Edit and Run Modes) 

Allows the choice of applying either a case template (see Case Templates) or a oneline template (see Oneline 
Templates) to the current case.  Selecting this option has the same affect as selecting Options/Tools, Apply 
Template  from the main menu. 

Save/Edit/Delete View (Edit and Run Modes) 

Displays the Save View Level Dialog.  This dialog is used to set defined locations on the oneline for recalling 
specific views from a list of saved views. 

Go To View (Edit and Run Modes) 

Allows the user to go to a specific location and zoom level on the oneline by choosing from a list of saved views.  
This option does nothing if no views are saved. 

Form Control> (Edit and Run Modes) 

Options on this submenu allow you to resize the window, shift the window, or close the window. 
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Oneline Display Options Dialog 

The Oneline Display Options dialog allows you to customize the display of the oneline diagram. You can access this 
display by either right-clicking anywhere on an empty portion of a oneline and selecting Oneline Display Options  
from the resulting oneline local menu or selecting Options/Tools > Oneline Display from the main menu.  This dialog 
houses several pages of options that govern various aspects of the oneline display.  These pages are entitled Display 
Options, Pie Charts, Animated Flows, Thumbnail View, Grid/Highlight Unlinked Objects, Memo, Movie and Substation. 

 

Save Options to Case 

Of important note is the general option at the bottom of this dialog labeled Save Options to Case.  What this allows 
you to do is define a set of oneline options in the dialog, and then save that definition of options in the case by 
giving the definition a name.  Once you have named that set of options, you can recall it later by coming back to this 
dialog and choosing the name from the list of option set names that appears near the bottom of the dialog.  You can 
define as many different sets of custom options as you wish.  You can also use an option set saved with the case 
when you create a oneline view using the Save Views dialog. 
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Display Options  

Display Detail 

The Display Detail box allows you to control how much information is shown on the oneline display.  There are three 
choices: 

Minimal Show the oneline background, branch circuit breakers, generator MW output, 
and load MW/MVR.  

Moderate Show all Minimal information, along with bus voltages and all line flow pie 
charts.   

Complete Show all information.   

Of course, in order for a certain display object to appear, it must have been placed there by the person who 
designed the oneline. 

Set Custom Detail 

Clicking this button opens the Custom Detail Dialog, which allows you to customize the oneline diagram to hide 
objects that do not meet specific specifications. 

Background Color 

Select Change Background Color to select a different color for the oneline diagram background color.  Select the 
Set as Default Background Color option to set the background color as the default f or all oneline diagrams. 

Voltage Options  

Voltages may be expressed in either actual units (kV) or per-unit. 

Use Absolute Values for MW Line Flows 

If checked, this option will cause all MW flow text fields for lines to be displayed as the absolute value of the flow.  
Otherwise, the MW flow text fields will be positive near the source end of the line and negative near the sink end of 
the line. 

Use Absolute Values for Mvar Line Flows 

If checked, this option will cause all Mvar flow text fields for lines to be displayed as the absolute value of the flow.  
Otherwise, the Mvar flow text fields will be positive near the source end of the line and negative near the sink end of 
the line. 

Use Absolute Values for MW Interface Flows 

If checked, this option will cause all MW flow text fields for interfaces to be displayed as the absolute value of the 
flow.  Otherwise, the MW flow text fields will be positive near the source end of the interface and negative near the 
sink end of the interface. 

Enable Mouse Wheel Zooming 

When this box is checked, zooming can be done with a mouse wheel.  The default is off. 

Change in Generator Rotor Angle Per Refresh (degrees) 

Generator display objects are drawn with a dog bone rotor whose angle relative to the horizontal can be used to 
represent the generator internal angle.  Enter a nonzero value to make use of this feature. 

Visualizing Out-of-Service Elements  

Out-of-service elements can have optional visualization settings that makes them "stand out" in relation to in-service 
devices on the oneline diagram.  The options for out-of-service devices includes Use Dashed Lines, Draw and X 
Through Off-Line Generators, and Blink .  Any combination of these options can be used for out-of-service 
elements, although the X option only applies to out-of-service generators. 

Percent of Substation and Injection Group object height used by name 

When Substation and Injection Group objects are drawn on a oneline diagram, they can include a string inside the 
object displaying the name.  This setting determines how big the name should appear, relative to the size of the 
object. 

Browsing Path for Oneline Diagrams 

This option applies when you have Oneline Links included on a oneline diagram.  Rather than specify the full path 
and name of a oneline diagram as a oneline link, you can specify the file name only.  When the link is clicked in Run 
Mode, Simulator will check all directories listed here, in order, to try and find the oneline file name stored with the 
link. 
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Pie Chart Options  

The next several fields are used to customize the appearance of the line flow pie charts. 

Show Pie Charts in Run Mode  

When this option is checked, the pie charts will be visible during Run Mode.  Otherwise, they will be visible only 
during Edit Mode. 

Style 

The Line Pie Chart Style box determines whether the line flow pie charts show the percentage loading of the line 
based upon the MVA flow, the MW flow, the MVR flow, or the line amp/transformer MVA flow. 

Always Use Limiting Flow 

Typically, the flow at opposite ends of a transmission line is slightly different due to losses across the line.  If this 
option is checked, the pie chart will correspond to limiting MVA value of the line, independent of which end of the 
line that value occurs.  Otherwise, the pie chart will always show the MVA value at the from bus for the line. 

Show Value Percent 

When a branch's loading exceeds the value specified in the Show Value Percent field, the percentage loading is 
shown as text within the pie chart.  The default is 80%. 

Normal Size Scalar, Normal Color 

The standard, pre-warning fill color and scaling factor for pie charts. 

Show Limit Set in Header 

If this option is checked, the pie chart will display a text field showing the letter of the limit set presently being used 
for the element. 

Show Pie Style in Footer 

When checked, the pie chart will display a text field showing the style (MVA, MW, etc) that the pie chart is set to 
(refer to the Style property described above.) 

Warning Percent, Warning Size Scalar, Warning Color 

At loading percentages at or above the Warning Percent but below the Limit Percent, the size of the pie chart is 
automatically scaled by the amount of the Warning Size Scalar field.  These fields permit highlighting the pie charts 
associated with lines and transformers that are close to their limits.  The Warning Color changes the pie chart to 
this color when loading is at or above Warning Percent.  Double-click on the color field to change the warning fill 
color.  Default values for the Warning Percent, Warning Size Scalar, and Warning Color are 80%, 1.0, and Blue, 
respectively. If the Only in Monitored Areas option is checked, then the pie charts obey these parameters only for 
branches in areas for which the Report Limit Violations  option is active.  See Area Display<+> for more 
information. 

Limit Percent, Limit Size Scalar, Limit Color 

At loading percentages at or above Limit Percent, the size of the corresponding pie chart is automatically scaled by 
the factor prescribed by the Limit Size Scalar field and the fill color becomes the color specified by the Limit Color 
field.  These fields enable you to emphasize the pie charts associated with lines and transformers that are above 
their limits.  The limit color can be changed by double-clicking on the color itself. Default values for the Limit 
Percent, Limit Size Scalar, and Limit Color options are 100%, 2.0, and red, respectively. If the Only in Monitored 
Areas option is checked, then the pie charts obey these parameters only for branches in areas for which the 
Report Limit Violations  option is active.  See Area Display for more information. 

Max. Zoom Percentage for Full Resizing 

The pie charts dynamically resize when you are zooming in and out on a oneline diagram.  However, you can limit 
the point at which the pie charts resize when zooming in by setting a zoom level in this field.  This helps prevent the 
pie charts from getting so large that they occupy the entire screen. 

Only Apply to Monitored Elements  

If this option is checked, then only those pie charts that correspond to branches selected using the Limit Monitoring 
Settings will change appearance to reflect warning and limit loading levels.  If this option is not checked, then all pie 
charts will obey the options prescribed in this dialog. 

Pie Chart Background Color 

The background color for the pie charts is automatically set to be the same as the online background.  For a 
different color, select Specific color from the drop-down menu, and then click on the rectangle to the right to select 
the color.  For a clear background, select Clear from the dropdown menu. 

Pie Chart Relative Font Size 

Slide the slider bar to select the font size for the pie chart.  This will determine the size of the font indicating the 
percentage on the pie chart. 

Maximum Pie Chart Size 
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When zooming in on a line or transformer, the size of the pie charts, like that of all other objects, increases.  
Eventually the pie charts will tend to dominate the display unless their size is capped.  This field specifies a 
maximum size for the pie charts.  The default value is 99. 

Set color to be the same as the line… 

If checked, this option will cause the pie charts to assume the same normal colors as the transmission lines to 
which they are anchored.  This may be useful if the transmission lines are colored according to their nominal 
voltage level. 
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Animated Flows Options  

The fields on the Animated Flows page of the Oneline Display Options dialog are used to customize the appearance of 
the animated flows on the oneline diagram. 

Show Animated Flows 

Determines whether power flows are animated on the onelines.  If this option is not checked, then no f low symbols 
appear on the oneline. 

Density  

Determines the relative density of the animated flows on the devices.  Increasing this value causes Simulator to 
display a greater number of flow symbols per unit distance on the oneline.  This value may range from 1 to 999.   

Size  

Determines the relative size of the animated flows on the devices.  Increasing this number increases the size of the 
flow symbols.  This field may range from 1 to 999. 

Animate Flow  

This option determines whether or not the flow arrows are mobile or stationary on the oneline diagram.  Unchecking 
this box will cause the flow arrows to remain stationary on the diagram. 

Animate Size  

If checked, the size of the animation symbols will vary to represent the quantity of flow on the element (respective of 
the Animation Parameter.)  Otherwise, the symbol size will be the same on all devices regardless of the quantity 
represented. 

Scale Speed of Flows 

Checking this box will cause the arrows to flow at a speed proportional to the represented quantity.  When it is not 
checked, all of the flows will be at the same speed. 

Animation Parameter  

Determines whether the size and speed of animated flows represent actual flow or percentage loading.  This option 
applies only to transmission lines and transformers as flows on other devices, such as loads and generators, always 
represent actual flow.   

Max. Zoom Level to Resize 

As a oneline is zoomed, the animated flow symbols increase in size.  The value of Max. Zoom Level to Resize caps 
the size of the animated flows so that zooming beyond this level results in no further increase to the size of the flow 
symbols. 

Reference Values for Sizing 

Maximum flow reference for sizing the animated flows.  The lower the MVA reference, the larger the animated flows 
appear on the oneline diagram as the actual flow value is compared to the reference value for scaling. 

Reset Animated Flow Offsets  

This button allows the user to reset the animated flows to start at a specified offset position.  Mostly this would be 
used to reset the offset to 0, which would cause the animated flows to start at the beginning of the line or element.  
Since the animation moves the flow arrows every time the load flow is resolved, resetting flows to a specific offset 
could be useful for comparing different load flow solutions by looking at differences in the animated flow objects. 

Automatically Set Size, Density, and Parameters for this oneline  

Simulator detects the current zoom level and object parameters of the selected oneline diagram, and automatically 
adjusts the animation settings in an attempt to optimize the animation quality. 

Flow Visualization 

Animated flows on onelines may depict either actual power flows or power transfer distribution factors, depending 
on what you choose here.  You can also now choose to animate both the MW and MVAR flows or the MW and 
PTDF flows simultaneously. 

Use Fill Color  

Checked if animated flow symbols should be filled using the Fill Color. 

Symbol Fill Color 

Shows the fill color used for the animated flows if Use Fill Color is checked.  Double-click on these fields to change 
the colors of the four different types of animated flows. 

Animation Symbols  

Simulator can display animated flows using directional arrows, circles, or squares. 

Animation Rate  

If the oneline animation is too fast or too slow, the animation rate can be adjusted by moving the slide bar. 
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Thumbnail View 

The thumbnail view allows the user to see an overview of the oneline diagram in a smaller window in a specified 
location on the oneline diagram.  The thumbnail view is useful when the user has zoomed in to a specific area of the 
oneline diagram, but still wants to see what part of the system they are observing on a larger scale as they pan around 
the diagram.  The thumbnail view is not visible by default, but can be set up and displayed from the Oneline Display 
Options dialog.  The options for the thumbnail view are: 

 

Show ThumbNail View 

If checked, the thumbnail view will be visible in the specified corner of the oneline diagram. 

Size of ThumbNail View 

The size of the thumbnail view as a percentage of the size of the oneline diagram. 

Zoom Out Multiplier 

The amount to multiply the oneline diagram zoom level for display in the thumbnail view.  The higher the multiplier, 
the more of the diagram you will see in the thumbnail view. 

Location 

Choose the location on the oneline diagram in which the thumbnail view is to appear. 

Border Width in Pixels  

The pixel thickness of the border around the thumbnail view. 

Background Color 

If Use One -line Background Color is checked, the thumbnail background color will be the same as the oneline 
diagram.  If it is not checked, then a different thumbnail background color can be selected by clicking on the colored 
box next to the Use Custom Background Color label. 
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Substation Display Options 

The Substations  tab of the Oneline Display Options dialog provides parameters for customizing the appearance of 
Substation display objects. 

The upper right-hand corner of the Substation page displays a template of the substation object’s appearance in terms 
of locations or "zones" where information can be displayed on the object.  The rest of the page can be used to 
describe the appearance of the object and the information that appears in the substation objects. 

 

Upper % of Height 

This percentage indicates how much of the object is populated by the "upper" zone of the object.  This includes the 
Upper Field, Upper Left (UL) and Upper Right (UR).  As you decrease this percentage, the upper zone will get 
smaller, increasing the Identifer (middle) zone automatically, and vice-versa if you increase the percentage of the 
Upper zone. 

Identifier % of Height 

This is the percentage of the substation object that is occupied by the identifier or "middle" zone.  This is the 
substation identifier section of the object. 

Lower % of Height 

This is the percentage of the substation object that is occupied by the "lower" zone of the object.  This includes the 
Lower Field, Lower Left (LL) and Lower Right (LR).  Unlike the previous two percentages, this percentage cannot be 
directly modified.  Instead, it is automatically determined based on the settings of the Upper and Identifier 
percentages. 

Substation Identifier 

Choose how the identifier will be displayed for the substation.  Choose to display by name, by number, or by 
combinations of name and number.  The identifier will be displayed in the Identifier or "middle" zone of the 
substation object. 

Extra Substation Fields  

These two fields, represented as the Upper Field and Lower Field on the template, can be customized to display 
any substation field of your choosing.  Use the drop-down arrow of the Upper and Lower box to choose a field, or 
use the Find button to pull up a list of fields to choose from.  Once the field has been chosen, set the digits and 
number of decimal places for the field. 

Upper-Left Symbol (UL) 

Choose what symbol to display in the upper-left zone of the substation object.  You can choose from None, 
Switched Shunt, Generator, Number of Buses, and Load.  If the substation contains at least one type of the chosen 
object, a symbol representing that type of object will be displayed in the Upper-Left location of the object to indicate 
such a presence.  By default, the Upper-Left zone will display the Generator symbol. 

Upper-Right Symbol (UR) 

Choose what symbol to display in the upper-right zone of the substation object.  You can choose from None, 
Switched Shunt, Generator, Number of Buses, and Load.  If the substation contains at least one type of the chosen 
object, a symbol representing that type of object will be displayed in the Upper-Right location of the object to 
indicate such a presence.  By default, the Upper-Right zone will display the Load symbol. 

Lower Left Symbol (LL) 

Choose what symbol to display in the lower-left zone of the substation object.  You can choose from None, 
Switched Shunt, Generator, Number of Buses, and Load.  If the substation contains at least one type of the chosen 
object, a symbol representing that type of object will be displayed in the Lower-Left location of the object to indicate 
such a presence.  By default, the Lower-Left zone will display the number of buses in the substation. 

Lower-Right Symbol (LR) 

Choose what symbol to display in the lower-right zone of the substation object.  You can choose from None, 
Switched Shunt, Generator, Number of Buses, and Load.  If the substation contains at least one type of the chosen 
object, a symbol representing that type of object will be displayed in the Lower-Right location of the object to 
indicate such a presence.  By default, the Lower-Right zone will display the Switched Shunt symbol. 
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Set Custom Detail Dialog 

This dialog is opened from the Set Custom Detail button on the Oneline Display Options dialog.  The Custom Detail 
Dialog allows you to choose particular regions and devices for display on a oneline diagram.  The Custom Detail 
settings are temporary settings that allow "hiding" certain parts of a oneline diagram that may not be of interest for your 
current needs.  This option is only available during run mode.  Any custom detail settings being used in run mode will 
automatically be removed when switching to edit mode. 

 

General 

Area Numbers 

Specify the areas for display.  By default, all areas are displayed.  You can assign specific areas by entering in the 
area numbers, separated by a dash for a range of areas, and commas for individual areas.  You can also click the 
Find… button to search for areas by number or name. 

Zone Numbers 

Specify the zones for display.  By default, all zones are displayed.  You can assign specific zones by entering in the 
zone numbers, separated by a dash for a range of zones, and commas for individual zones.  You can also click the 
Find… button to search for zones by number or name. 

Nominal Voltage  

Specify the voltage range of the dev ices for display.  By default, all voltage levels are displayed.  You can assign a 
specific voltage range by entering the minimum and maximum nominal voltage values. 

Type of Drawing Object 

This list displays all the types of devices that can be displayed on a oneline diagram.  To choose the types of 
devices for display, click the check box next to each type you wish to keep on the diagram.  If you wish to display all 
the types of devices, you can click the Check All button or check the Show All Types option.  If you wish to 
uncheck all selected types of objects, you can click the Uncheck All button. 

 

Layers 

Use the Layers tab to specify the layers for display.  You can use the Check All or Uncheck All buttons to select or 
unselect all the layers in the list. 

 

When you are finished setting the Custom Detail options, you can click OK, only show these, and the oneline 
diagram will be redrawn, hiding any devices that do not meet the settings.  If you wish to remove a Custom Detail filter 
from a oneline diagram, you can re-open the Custom Detail Dialog, and click the Remove  button.  The oneline 
diagram detail will be returned to normal. 
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Oneline Animation 

An important feature of PowerWorld Simulator is its support of animated onelines.  The use of efficient display 
algorithms allow animation rates that are typically greater than several times per second, even on large cases and on 
onelines with a significant number of objects.  The extensive use of animation makes the display "come alive" so that 
system conditions can be ascertained more easily. 

In Simulator, animation is started from Run Mode by selecting Simulation > Play.  In Viewer, animation is started 
automatically when you load a case.   

The animation can be controlled and customized from the Animated Flows Tab  of the Oneline Display Options Dialog.  
To access this dialog, select Options/Tools > Oneline Display from the main menu, or right-click on an empty area of 
the oneline diagram and select Oneline Display Options from the resulting local menu.  
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Copying Onelines to Other Pr ograms 

The onelines can be easily copied to other programs.  This allows you to add PowerWorld onelines to your word 
processor documents or slide presentations.  The simplest way to copy a oneline diagram to another program is to use 
the Windows Clipboard.  This is accomplished as follows: 

• • In Simulator or Viewer, zoom and/or pan the display to the portion of the oneline diagram you would like to 
copy. 

• • Right-click on an empty portion of the oneline to display the local menu. 

• • Select Copy Window to Clipboard menu item.  This places a copy of the oneline into the Window's 
clipboard. 

• • In the other program, use Paste or Paste Special to copy the contents of the clipboard into that program.  
The oneline is pasted into the program using the Metafile format. 

In addition, oneline diagrams can also be saved as image files by right-clicking on an empty portion of the diagram and 
choosing Export Image to File. 

Changing the Oneline View  

Oneline Screen Coordinates 

Onelines can be any size and can contain any number of objects.  The size and position of objects on the screen are 
specified in terms of x -y "oneline screen coordinates."  When the zoom level is 100% the size of the oneline in screen 
coordinates is 100 by 100.  More generally, the size of the oneline is 1002 divided by the zoom level in both the x and y 
directions.   

The default screen center is the point (50,50) but this can be easily changed (See Oneline Panning and Zooming.)  
Negative screen coordinates are allowed.  Usually you will not have to be concerned about an object's location in 
screen coordinates. 
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Oneline Zooming and Panning 

All oneline diagrams permit zooming and panning.  Zooming and panning are very important tools for building and 
investigating large oneline diagrams that occupy more than a single screen of viewing area.  Moreover, the display of 
various objects can be set to depend on the zoom level.  See Oneline Conditional Display of Objects for more 
information on this feature. 

 

The following mechanisms are provided for zooming or panning a oneline: 

Zooming on Onelines 

Zooming involves adjusting the oneline diagram's display area by changing the magnification of the view.  Zoom in 
on a oneline to have the screen display less of the complete oneline diagram, and zoom out on a oneline to have 
the screen display more of the complete oneline diagram.   

To zoom on a oneline diagram using the keyboard, follow these instructions: 

• • Use CTRL-up arrow to zoom in  

• • Use CTRL-page up to zoom in quickly 

• • Use CTRL-down arrow to zoom out  

• • Use CTRL-page down to zoom out quickly 

The Zoom Toolbar offers additional zooming options: 

• • Use the Zoom in on Area button on the Zoom Toolbar of the toolbar to select a region on which to zoom. 

• • Use the Show Full Oneline  button on the Zoom Toolbar of the toolbar to zoom the display out to show the 
entire oneline. 

• • Use the Pan/Zoom Control button on the Zoom Toolbar of the toolbar to display the Pan/Zoom Dialog. 

• • Use the Save View button on the Zoom Toolbar of the toolbar to display the Save View Level Dialog, or click 
on the drop down arrow on the Save View button to choose from a list of saved views. 

• • Use the Rectangular Zoom Selector to select a section of the diagram to zoom into using a selection box.  
After clicking button (symbolized with a magnifying glass over a dashed rectangle,) left click and hold the 
mouse button down on the diagram, drag the mouse to select part of the diagram inside a box, then release the 
mouse button.  Simulator will zoom into the region selected inside the box.  

Finally, clicking the '+' button on the Pan/Zoom Toolbar of the PowerWorld Toolbar will zoom in on the oneline, 
while clicking the '-' button will zoom out. 

Panning on onelines 

Panning moves the screen's focus point around the oneline diagram.  You can pan left, right, up, or down to view 
different portions of the complete oneline diagram.  

To pan around the oneline using the keyboard, follow these instructions: 

• • Use the arrow keys to move in the desired direction 

• • Use page up to move up quickly 

• • Use page down to move down quickly 

• • Use the Home key to move left quickly 

• • Use the End key to move right quickly 

• • Left-click and hold the mouse button down anywhere on the background of the diagram.  Make sure you do 
not click on an object on the diagram.  While holding the left mouse button down, drag the mouse in any 
direction to "drag" the diagram in that direction. 

You can also use the Pan/Zoom Dialog to pan to a specific location, or even to a specific bus.  You can display the 
Pan/Zoom Dialog either by pressing the Pan/Zoom Button on the Zoom Toolbar of the PowerWorld Toolbar or by 
selecting Find Bus On Oneline  or Pan/Zoom Control from the oneline diagram's local menu. 
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Save View Level Dialog 

The Save View Level Dialog  is used to save an (x,y) location and zoom level, contour description, and/or hidden 
layer application for a oneline diagram in an easily accessible list for quick recall and application to the diagram.  This 
dialog can be called by selecting the Save/Edit/Delete View option from the oneline local menu, or by clicking the 
Save View button on the Zoom Toolbar.   

Recalling a saved view can be done by either right-clicking on the background to access the oneline local menu and 
choosing a view from the Go To View list, or by clicking on the drop down arrow on the Save View button and 
selecting a view from the resulting list.  Selecting a saved view automatically moves the oneline diagram location to 
the (x,y) coordinates and zoom level, applies a stored contour, and/or applies hidden layers stored with the selected 
view. 

 

This dialog can be used for creating a new view, editing an existing view, or deleting an existing view.  The Save View 
Level Dialog has the following options: 

View Name 

This is the name that the view will be stored under in the saved view list.  This must be a unique name for each view 
saved with the oneline diagram.  By default this field is blank.  To edit an existing view, choose the desired view 
from the drop down list. 

Update Dialog with Fields for Selected View 

If you wish to display the fields for a different view than being presently displayed, select the name of the view from 
the View Name list and click on this button to update the information in the dialog. 

Save Display Information in View 

When checked, the view will store an x -y coordinate and zoom level to associate with the view.  When the view is 
selected for display, the diagram will center on the x -y coordinate at the defined zoom level. 

X-Coordinate  

The x-coordinate for the view.  This value will default to the current x -coordinate for the oneline diagram, or will 
change to a saved value if a saved view is chosen from the View Name drop down list.  This value can be modified 
by the user. 

Y-Coordinate  

The y-coordinate for the view.  This value will default to the current y -coordinate for the oneline diagram, or will 
change to a saved value if a saved view is chosen from the View Name drop down list.  This value can be modified 
by the user. 

Zoom Level 

The zoom level for the view.  This value will default to the current zoom level for the oneline diagram, or will change 
to a saved value if a saved view is chosen from the View Name drop down list.  This value can be modified by the 
user. 

Save Contour Information in View 

If a contour is being displayed when the view is created, you can choose to save the contour information with the 
view by checking this box. 

Automatically Create Contour with View 

If contour information was s tored with the view, checking this box will result in the contour automatically being 
drawn when the view is selected for display on the diagram. 

Object Type to Contour 

This section displays the type of object the stored contour pertains to. 

Contour Field 

Displays the type of value the stored contour pertains to. 

Link to Oneline Display Options Settings  

In the Oneline Display Options in Simulator, you can save various sets of options with a case for quickly recalling 
oneline diagram settings by name.  This option allows you to include a custom defined option set by name with the 
current view.  Note that you first must have created and saved a custom set of options for a diagram from the 
Oneline Display Options dialog before this option on the Save Views dialog will be enabled. 

Save Hidden Layers 

Since Simulator allows the use of layers to display or hide objects on the diagram, views also can optionally store 
the layer settings when the view is created.  The window below this checkbox will list the layers that are presently 
hidden on the diagram.  When this view is recalled, the layers in this list will be hidden if they were stored with the 
view. 

Save 
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This button will save a new view or modify the values for an existing view of the name in the View Name field. 

Delete  

This button will delete the currently open view from the saved view list.  The dialog information will default to the 
saved view information of the previous view in the list. 

OK 

This button will save a new view or modify the values of an existing view of the name in the View Name field, and 
will close the Save View Level Dialog. 
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Window Menu Command 

The Window menu tree contains several commands that affect the appearance of the windows shown on the screen, 
and it lists the children windows that are currently open in Simulator.  To make a particular window active (and fully 
visible), simply click on its name. 

The Window menu tree houses the following c ommands: 

Keyboard Shortcuts  

It Opens the Keyboard Short Cut Actions dialog, which can be used to associate a keyboard shortcut to a oneline 
diagram and/or a view of such a oneline diagram. 

Tile  

Rearranges the open oneline diagrams such that the total window area is divided equally among all of them and 
each is completely visible. 

Cascade  

Rearrange all open windows such that all they appear on top of each other while leaving the title bars visible. 

Refresh Displays  

Redraws (refreshes) each of the open window s.  Simulator usually automatically refreshes the open windows as 
necessary.  However, this option allows you to trigger the refresh when you want it. 

Toolbars 

Provides the user control over which toolbars are visible.  The submenu lists all available toolbars.  Those that are 
currently visible are marked with a checkmark.  Click on the name of a toolbar toolbar to show or to hide it. 

Toolbars > Toolbar Settings > Reset All Toolbars 

Resets all the toolbars and menus to the state they were when PowerWorld Simulator was installed. 

Toolbars > Toolbar Settings > Save Toolbar Settings  

Saves the current settings (such as position and order) of all the toolbars to the specified INI file. 

Toolbars > Toolbar Settings > Load Toolbar Settings  

Loads the toolbar settings  stored in the specified INI file. 

Toolbars > Customize 

The Customize Toolbar dialog allows the user to customize specific toolbars to suit its personal needs. 
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Oneline Conditional Display of Objects  

Along with supporting zooming and panning, the onelines permit the conditional display of objects.  That is, it is 
possible to specify display objects so they are visible only at particular zooming ranges.  This enables the oneline to 
show additional details as the user zooms in and fewer details when the user zooms out.   

Please note that the zoom levels are defined as percentages.  If you want an object to display only between 50% and 
150%, you must select 50 and 150 as the zoom level boundaries. 

This option is available by assigning objects on the diagram to a Layer.  Layers can be defined and set to objects on 
the Format Multiple Objects dialog. 
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Keyboard Short Cut Actions Dialog 

The Keyboard Short Cut Actions dialog allows the user to associate a keyboard shortcut to a determined oneline 
diagram, and even to a particular view of such diagram.  When the keyboard s hortcut is pressed, the oneline diagram 
is opened (if it was closed) and brought to the front.  When a view is also associated, then the user is taken to such a 
view. 

 

The dialog has the following controls: 

Keyboard Shortcuts  

Lists all the keyboard shortcuts. When selecting a keyboard shortcut, it will show the oneline and the view 
associated to the selected keyboard shortcut. 

Clear All 

Clicking this button will delete all the associations of all the listed shortcuts. 

Oneline to Open or Bring Forward 

Shows the path and the name of the oneline diagram which will be opened when the selected keyboard shortcut is 
pressed.  If the field is blank, then no oneline diagram is associated to the keyboard shortcut.  You can click 
Browse to find the oneline diagram. 

View of respective Oneline to Open 

Shows the name of the view belonging to the associated oneline diagram to which the user will be taken when the 
selected keyboard shortcut is pressed.  If the field is blank, then no view is associated to the keyboard shortcut. 

Save Shortcut 

Click this button after entering a oneline diagram and eventually a view so they can be associated with the selected 
keyboard shortcut. 

Delete Shortcut 

Click this button to delete the associations of the selected keyboard shortcut with any oneline diagram and view. 

Save/Load shortcuts to/from an Auxiliary File  

Click the Save button to save all the shortcuts to an auxiliary file.  Click the Load button to load the shortcuts saved 
in an auxiliary file. The shortcuts saved in the auxiliary file will replace the shortcuts saved in the dialog. 

Close 

Closes this dialog. 

Printing Oneline Diagrams 

Printing Oneline Diagrams 

To print a oneline diagram, select File > Print Oneline  from the main menu, click the Print Window button on the File 
Toolbar, or right-click on the oneline background and select Print Window from the popup menu.  This opens the Print 
Options Dialog, which you can use to configure the print job, including its size, orientation, border, and title bar.  You 
can even choose to print a oneline to multiple pages using Simulator's multi-page printing. 
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Print Options Dialog 

The Print Options Dialog is used to configure the printing of oneline diagrams (including bus view displays) and of strip 
charts.  To print a oneline diagram, select File > Print Oneline  from the main menu.  To print a strip chart, right-click 
on it to invoke its local menu, and then select Print Window.  In both cases, Simulator will open the Print Options 
Dialog. 

The Print Options Dialog has three tabs: 

 

Page Layout 

This tab sheet contains options for how the diagram will appear on the printed page.  It presents the following controls: 

Margins  

Specify the horizontal and vertical margins in either inches or centimeters. 

Scaling 

Set this option to Proportional to print the oneline diagram or strip chart such that the screen’s aspect ratio is 
maintained.  Set this option to Fit to Page  to force the printout to take up all available space on the page in both 
horizontal and vertical directions. 

Draw Border 

Places a border to be drawn around the oneline diagram or strip chart. 

The second tab controls the printing of a title bar.  Check the Print Title Bar box to print a title bar at the bottom of 
the diagram.  Checking this box displays a number of options that allow you to specify various items to include in 
the title bar.  If you don’t want to include certain items on the plot, simply leave those fields blank. 

The title bar is split horizontally into three sections.  If you specify values for all requested items, they will be 
arranged in the title bar as follows: 

Company | Description Line 1 | Date 

Department | Description Line 2 | Drawing # 

Author | Description Line 3 | Title 

 

Title Bar 

This tab is used to specify whether or not to include a title bar on the diagram, along with the information that would be 
contained in the title bar. 

 

Multi-Page  

This tab allows the oneline diagram to be "divided" into a specified number of sections for printing the oneline to 
several pages.  A multi-page oneline can be useful for including "close-up" views of areas of a diagram in a report, or 
the multiple pages can be cut and combined to form a larger printed oneline if a plotter is not available.  The Multi-
Page tab presents the following controls: 

Grid Size 

Choose this value to subdivide the oneline into an N by N grid.  You can then choose which sections of the oneline 
to print based on the grid overlay.  The maximum size is 10 x 10. 

Choosing What to Print 

A low resolution picture of your oneline is shown on the Multi-Page  tab.  Gridlines are drawn over the diagram to 
show where the oneline has been subdivided based on the Grid Size chosen. 

To remove a grid section from the printout, click on the oneline image in the corresponding section of the grid.  The 
selected section of the grid will become dark to indicate you wish to prevent the section from printing. 

To add a grid section back into the print job, click on a darkened section of the grid to allow that section of the 
oneline to be printed. 

The number of pages you have chosen to print will be shown on the dialog.  When printing out a multi-page oneline 
with a title bar, the page number will appear on the title bar in the form "Column Letter"-"Row Number".  For 
example, if the Grid Size is 4, the pages are numbered A-1 through D-4. 

Click Print to send the document to the printer, or Cancel to abort the print.  Click Setup to view the default Windows 
printer dialog, which will allow you to specify whether to print the figure in portrait or landscape modes and to set 
various printer-specific properties. 
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Creating, Loading, and Saving Simulator Cases 

Chapter 3 : Creating, Loading, and Saving Simulator Cases 
This chapter describes the File and Simulation Control Menus.  The File Menu is used to open and save either full 
cases or oneline diagrams, or to create new cases or new onelines (Edit Mode).  The menu is also used to exit 
Simulator or to validate a case (Edit Mode).   

The Simulation Control Menu controls the actual simulation.  You can use this menu to do either a time-domain 
simulation or a single Power Flow Solution.   

The following material is included:   

• Opening Cases and Onelines 

• Case Formats 

• Starting a New Case or Oneline 

• Case Validation 

• Saving Cases and Onelines 

• Using Templates 

• Exporting Onelines in Different Graphical Formats 

• Saving and Loading Auxiliary Data 

• Saving Admittance Matrix and Jacobian Information 
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File Menu 

The file menu is used to open and save either full cases or oneline diagrams, or to create new cases.  The menu is 
also used to validate cases or to exit Simulator.  The buttons on the File Toolbar of the toolbar provide access to many 
of the same options housed by the File Menu. 
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Case Formats  

Simulator supports a number of case formats.  You can open and save cases using any of the following formats: 

 

PowerWorld Binary (*.pwb)  (Preferred Format) 

For most users, the best choice of power flow c ase formats is the PowerWorld Binary format.  This format stores the 
most complete set of case information but requires the smallest file sizes.  Information stored in this format includes 
power flow data, economic parameters, case time variation/options v alues, and screen customizations.  The only 
potential disadvantage of this format is that it is stored in binary form, which means that it cannot be viewed using a 
standard text editor.  All the other formats are ASCII and thus readable in text editors suc h as Notepad. 

PowerWorld Auxiliary File (*.aux) 

Simulator can now save and load cases using the PowerWorld defined auxiliary file format.  When the aux file 
format is chosen as the save file type in Simulator, the data describing the entire case is written to a text file 
described by Simulator’s auxiliary file format.  These files can be considerably larger than PowerWorld Binary files, 
and generally should not be used unless otherwise necessary.  Note that not all auxiliary files represent an entire 
case, and in fact in most cases do not.  Only when an auxiliary file is created using the Save As option in Simulator 
does the auxiliary file contain all necessary information for loading the complete case in Simulator as an auxiliary 
file. 

PowerWorld Case (*.pwc) 

The PowerWorld Case format is primarily included for backward compatibility with earlier versions of PowerWorld 
packages.  While this format does not include as much information as the PowerWorld binary format, it still includes 
power flow data, economic parameters, and most case time variation/options values.   

PTI Raw Data Format (*.raw) (version 29, 28, 27, 26, 25, 24 and 23) 

This format is included primarily for interchange of power flow data with other packages.  The PTI Raw Data format 
only contains power flow data.  When using this format, the generator participation factors are automatically set to 
be proportional to the MVA rating of each generator. 

GE PSLF Format (*.epc) 

This format is included primarily for importing load flow data saved from GE's PSLF program.  The EPC format is a 
text file format.  There are two major differences between the PSLF and Simulator load flow models.  First, PSLF 
models multi-section lines explicitly by storing a section number with transmission lines.  In Simulator, the sections 
are converted to their own individual line record, and dummy buses are placed at each internal point of the multi-
section line.  Simulator also keeps track of these lines and reports them as part of a multi-section line, though each 
section has its own entity in the load flow data.  Second, PSLF explicitly models three winding transformers.  
Simulator, thus far, does not explicitly model such transformers.  Rather, Simulator converts the three winding 
transformers to an equivalent model of three (or in special cases two) two winding transformers with a common bus 
(also called an internal or star node.)  The conversion of multi-section lines and three winding transformers is done 
automatically when an EPC file is opened in Simulator. 

Another issue with PSLF files is that they store quite a bit of excess information that is unused in Simulator.  Rather 
than loading all of this excess information in the computer's memory (which could hurt machine performance), the 
excess information is automatically stored in an extra external text file created by Simulator.  This text file has an 
extension of .ecf, and is saved with the same name as the original case file in the same directory as the original 
case file.  As the case is saved in Simulator, possibly with a different name, the ECF file can also have its name 
changed to reflect the name of the load flow file when it was saved as a PowerWorld Binary (.pwb) file.  The ECF 
file will never be needed unless the case is written back out to PSLF EPC format, at which time Simulator will locate 
the ECF file, if it exists in the same directory under the same name as the PWB file, and rewrite the extra data back 
out to the EPC file, along with the load flow data from Simulator. 

IEEE Common Format (*.cf) 

The IEEE Common Format is used to specify only power flow information.  CAUTION: IEEE common format does 
not support many of the formats used in the PowerWorld packages, such as multiple loads and generators at a bus.  
Usually, IEEE Common Format is used only for inputting cases.  



Printed Documentation 

58 

Validating a Case 

Select File > Validate Case to check the case for errors that would prevent it from working correctly in Simulator.  If a 
case has validation errors, you cannot switch to Run Mode.  Any errors are displayed in the message log. 

Case validation is performed automatically when switching from Edit Mode to Run Mode.   
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Printer Setup 

Choose File > Printer Setup from the main menu to configure the printer using the standard Windows printer setup 
dialog.  This dialog allows you to define which printer to use for printing from Simulator, the size of the printed page, 
the page’s orientation, and additional properties that are specific to the printer you are using. 

Opening Files 

Opening a Simulation Case 

The most common first step in using Simulator is to open a case.  When a case is opened, any associated oneline 
files are also opened.  To open a case, either select it from the list of recently opened cases  in the file menu or  

 

• Select File > Open Case from the main menu or Open Case button on the File Toolbar to display the Open 
Dialog. 

• In the Type of Files box, select the desired file type.  By default, the PowerWorld Binary type is selected (*.PWB).  
The PowerWorld Binary is the preferred file type, providing the most comprehensive power system information 
along with the smallest size and quickest load time.  Other file types include the PowerWorld Case type, PTI Raw 
Data formats versions 23 through 29, and IEEE Common Format.  Please see Case Formats for more details.   

• In the list of cases, click on the desired case.   

• Click OK.   

 

When opening an existing Simulator case, you may see one or more oneline diagrams pop up.  When opening a 
power flow case created with another program, a oneline may not be available.  However, you can easily create a 
oneline for such a case using the Edit Mode.   

If you are in the Edit Mode, you can modify the case.  See Edit Mode Overview for details.     

If you are in the Run Mode, the Clock Window may be displayed.  This window shows the simulation start time, end 
time and current time.  You may choose to close or open the clock at any time. 

If the case has validation errors, the mode is immediately switched to Edit Mode.  You must correct the validation 
errors shown in the message log before you can use the Run Mode to solve the case.   
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Opening a Oneline Diagram  

Simulator supports oneline diagrams  that have been developed using its Edit Mode tools.  PowerWorld can also 
import PTI Draw Files (*.drw).   

When a case is opened, any associated onelines are usually opened, as well.  Additionally, oneline diagrams can be 
opened directly from any existing onelines using oneline links.  However, you may also directly open a oneline 
diagram using the following procedure: 

 

• Select File > Open Oneline  from the main menu, or select the Open Oneline  button on the File Toolbar. 

• Choose the file type you would like to open (One Line Display File or PTI Draw File). 

• In the list of available oneline files, click on the desired oneline. 

• Click OK.   

You may open as many onelines as you like, and even multiple copies of the same oneline.  
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Recently Opened Cases 

A numbered list of the most recently opened cases appears in the File Menu immediately following the Print menu 
item.  Simply click on the case’s name in the menu to open the case.  

Creating Files 

Building a New Case 

To create a new case in Simulator, select File > New Case from the main menu, or select the New Case button on the 
File Toolbar.  After asking you whether or not to save the current working case (if one exists), Simulator will 
automatically switch to Edit Mode.  The screen will turn to the default background color, indicating that you can begin 
to build the new case. 

New users may wish to view the tutorial Creating a New Case from Scratch for further guidance. 
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Building a New Oneline  

This option enables you to create a new oneline diagram.  It is accessible from either the Edit or Run modes by 
choosing File > New Oneline  from the main menu or pressing the New Oneline button on the File Toolbar.  When 
you select it, the application will automatically switch to Edit Mode, from which you can construct the new oneline. 

New users may wish to view the tutorial Creating a New Case from Scratch for further guidance. 

Closing Files 

Saving Cases 

Simulator allows users to save case information in several different formats.  To call up the Save As dialog, select File 
> Save As  from the main menu.  The format in which the file will be saved depends upon the value of the Save File 
Type  field shown in the lower-left corner of the dialog.  Simulator can save cases in PowerWorld binary format (the 
default), PTI versions 23 through 29 raw data, GE PSLF format, and the IEEE common format.  Please see Case 
Formats for more details on the various case formats available. 

   

To convert a case to a different format, follow this procedure: 

• Select File > Open Simulation Case. 

• In the Type of Files box, select the desired file type.  By default, the PowerWorld Binary type is selected (*.PWB).   

• Select the name of the desired case and click OK.   

• Select File > Save Case As  from the main menu. 

• Change the Type of Files setting to match the desired file type, designate the name with which to save the file, 
and click OK. 

To simply save the case with its c urrent name and format, select either File > Save from the main menu or the Save 
Case button on the File Toolbar. 
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Saving a Oneline  

Select File > Save Oneline from the main menu to save the currently selected oneline file.  Alternatively, you may 
select the Save Oneline  button from the File Toolbar. 

Select File > Save Oneline As from the main menu to save the currently selected oneline file with a different name.  
You may overwrite existing files.   

For both the Save Oneline and Save Oneline As options, only the oneline diagram is saved; the case (i.e. the power 
flow model) is not written to disk. 



Printed Documentation 

64 

Close Oneline  

To close a oneline diagram, go to File, Close Oneline , or right-click on the background of the oneline diagram and 
select Close from the local menu.  This will prompt you to save the oneline if changes have been made since the last 
save.  Note that this does not close the current case, just the oneline diagram.  The power system data is still loaded, 
and case simulations can be run with the oneline closed. 

Auxiliary Files 

Area/Zone Load Schedule Format (*.shd) 

These files are outdated for Simulator version 8.0 and later.  Their descriptions are still maintained here as they can 
still be read into Simulator.  However, they can no longer be saved.  These records are now stored in Auxiliary 
Script/Data Files. 

The schedule files store the area and zone load variation schedules.  The files have the following format: 

For a desired area or zone, the first line of the record is either AREA or ZONE, followed by the area/zone’s number or 
name in single quotes.   

The next lines in the file must have the format timepoint, schedule value.  The timepoint format is either hh:mm, where 
hh is the hour and mm is the minutes, or hh:mm:ss, where ss is the seconds.  Multiple timepoints and schedule values 
can be on the same line. 

 

The record is terminated by a line with a single negative number.   

Example 

AREA    1 
06:00  1.0000  10:00  3.0000 
-1  
ZONE  2  
06:00  1.5000   9:00  2.5000  10:00  1.5000 
-1 
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Automatic Area Controls Format (*.aac) 

These files are outdated for Simulator version 8.0 and later.  Their descriptions are still maintained here as they can 
still be read into Simulator.  However, they can no longer be saved.  These records are now stored in Auxiliary 
Script/Data Files. 

The automatic area controls file stores the control settings for areas in the case.  The automatic area controls files 
have the following format, with one area per line: 

 

 AREA areaname areacontroltype autotaps autoshunts  

where 

areaname the area’s name in single quotes, 

areacontroltype the dispatch control for the area, in single quotes (Off AGC, Part. AGC, ED, 
Area Slack, OPF), 

autotaps the status of automatically switching taps (1 for automatically switching taps, 0 
otherwise), 

autoshunts the status of automatically switching shunts (1 for automatically switching 
shunts, 0 otherwise).  



Printed Documentation 

66 

Auxiliary File Format (*.aux) 

Simulator Auxiliary Files have now been greatly enhanced to include both Script sections for running Simulator 
commands in a "batch" process, and Data sections for changing mass amounts of load flow information.  Auxiliary file 
format and use now has its own help chapter titled Auxiliary Script/Data Files. 
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Generator Capability Curves Format (*.gcp) 

These files are outdated for Simulator version 8.0 and later.  Their descriptions are still maintained here as they can 
still be read into Simulator.  However, they can no longer be saved.  These records are now stored in Auxiliary 
Script/Data Files. 

The generator capability curves are used to model the dependence of the generator reactive power limits and the 
generator’s real power output.  The generator reactive capability curves files have the following format, with one 
generator per line: 

 

num or name, ID, P1, Q1,max,Q1,min, P2, Q2,max, Q2,min ... Pn, Qn,max, Qn,min 

where 

num/name the generator’s bus number or the bus’ name in single quotes,  

ID  the generator’s single character id,  

Pi  a generator MW output value,  

Qi,max and Qi,min  the associated maximum and minimum reactive power limits.   

Up to 10 different P/Qmax/Qmin values may be specified.   
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Generator Cost Data Format (*.gcd) 

These files are outdated for Simulator version 8.0 and later.  Their descriptions are still maintained here as they can 
still be read into Simulator.  However, they can no longer be saved.  These records are now stored in Auxiliary 
Script/Data Files. 

The generator cost data file contains the parameters used to model the generator operating costs.  Each record in the 
generator cost data file specifies the operating cost model for a single generator.  The cost model may be either a 
cubic polynomial or a piecewise linear curve.  When reading a file of generator cost data records, Simulator will open 
the Cost Curve Data Options Dialog.  This dialog gives you additional control over the input and process of generator 
cost information. 

 

Each generator cost data record begins with the fields  

num or name, ID, 

where 

num/name  the generator’s bus number or the bus’ name in single quotes,  

ID  the generator’s single character id, 

Following the ID field is an optional single-character field CostModel that specifies the type of cost model.  If 
CostModel is ‘CUBIC’ or is not specified, the record describes a cubic cost model and thus concludes with the 
following fields: 

 ai, bi, ci, d i, FuelCost ParFac 

where 

ai, bi, ci, d i input-output curve coefficients; see Generator Cost Information  for details, 

fuelcost fuel cost, expressed in price per Mbtu, 

ParFac generator participation factor. 
If, on the other hand, CostModel is ‘PLIN’, the record describes a piecewise linear cost model.  The remainder of the 
record specifies pairs of generator output and corresponding generator cost: 

 FixedCost MW1 IncCost1 MW2 IncCost2 …  MWn IncCostn MWneg ParFac 

where 

FixedCost Operation cost independent of the generator’s MW output; expressed in $/Hr, 

MWi, IncCosti  Output/incremental cost data point pairs that define the incremental cost model 
for the generator (note IncCosti has the units $/MWhr),   

MWneg An arbitrary negative value used to terminate the record, 

ParFac generator participation factor. 
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Generator Cost Curve Data Options  

The Cost Curve Data Options Dialog gives you additional control over the input and processing of generator cost 
information.  It appears when you try to read generator cost information from an auxiliary data file (either .aux or .gcd). 

To command Simulator to turn all units for which it reads a cost data record onto automatic generation control (AGC), 
check the first checkbox.  This box has the rather lengthy label "If a unit for which a cost curve is read is not on AGC, 
Simulator should set it on AGC."  In other words, if a cost curve is read for a particular generator, that generator will be 
set on AGC if this box is checked. 

Cross-compound is a generator architecture sporting a single boiler and two turbines, one operating at high pressure 
and the other operating at low pressure.  The existence of cross-compound units may complicate the modeling of 
generator cost characteristics, because sources for this information tend to describe the cost associated with the 
tandem, whereas Simulator’s economic dispatch will try to dispatch the two parts of the cross-compound unit as two 
separate units.  To address this problem, Simulator gives you the option to lump the properties of the high- and low -
pressure turbines into a single unit.  It consolidates the two components by adding together their maximum MW 
outputs, minimum MW outputs, and present output levels, assigning these quantities to one of the units, and setting 
the other unit off AGC and at 0 MW of output.  To have Simulator perform this function for you, check the box in the 
Cross Compound Units  panel. 

To tell Simulator how to identify units that belong to the same cross-compound generator, click the box labeled "How 
To Identify…".  This will open the How to Identify Cross-Compound Units dialog. 
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Identify Cross Compound Units  

Simulator regards cross-compound units as those that are connected to the same bus and that have generator id’s 
that match any of a number of specified pairs.  You must define for Simulator the pairs of generator id’s that should be 
used to identify cross-compound units.  Use the "How to identify cross-compound units " dialog to do this. 

Specify the pair of generator id’s in the small text boxes below the text labeled "Specify a new pair of id’s that identify 
two units that belong to the same cross-compound set."  Then, click the Add button to include the pair of id’s you just 
entered in Simulator’s cross-compound identification procedure.  The box on the right lists all the pairs of identifiers 
Simulator will use to identify parts of a cross-compound set.  To remove a pair of identifiers from this list, select it from 
the box and click the Delete key. 

The list of cross-compound identifier pairs is stored in the pwrworld.ini file, so there is no need to specify these pairs 
each time you load in a new case. 
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Injection Groups Format (*.inj) 

These files are outdated for Simulator version 8.0 and later.  Their descriptions are still maintained here as they can 
still be read into Simulator.  However, they can no longer be saved.  These records are now stored in Auxiliary 
Script/Data Files. 

The injection group files store the information for defined injection groups (also referred to as participation groups).  
The files have the following format: 

 

 GROUP groupname 

 POINTS 

 Devtype busnum id participation pointtype  

 . 

 . 

 . 

 END 

where 

groupname the name of the injection group, in single quotes, 

devtype either GEN or LOAD, 

busnum bus number of the device, 

id the device’s single character ID, 

participation relative amount each device will contribute during a transfer, 

pointtype either FIXED or DYNAMIC. 

Multiple GROUP sections can be put in the file, each marked with END to signify the end of that group’s data. 
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Interface Data Format (*.inf) 

These files are outdated for Simulator version 8.0 and later.  Their descriptions are still maintained here as they can 
still be read into Simulator.  However, they can no longer be saved.  These records are now stored in Auxiliary 
Script/Data Files. 

The interface data files store the interface data.  The files have the following format: 

 

 INTERFACE intname lima limb limc 

 Elemtype from to id checktoend fromto 

 . 

 . 

 . 

where 

intname the interface name, in single quotes, 

lima, limb, limc the three limits for the interface, in MW, 

elemtype one of three valid element types: AREA, LINE, or ZONE 

from for AREA and ZONE, the first area or zone number; for LINE, the from bus 
number, 

to for AREA and ZONE, the second area or zone number; for LINE, the to bus 
number, 

id only included for LINE, the two character circuit identifier; otherwise left blank, 

checktoend only included for LINE, if this field equals 1, the flow is checked at the to bus, 
otherwise the flow is checked at the from bus; otherwise left blank, 

fromto only included for LINE, if this field equals 1, the positive flow is assumed to be 
from the from bus to the to bus, otherwise the f low is assumed to be in the 
opposite direction; otherwise left blank. 

Multiple interface records can be listed in the file, and multiple interface elements can be listed in each interface 
record. 
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Sequence Data Format 

The sequence data files store the sequence data needed to run a fault analysis.  The sequence data format has the 
following five different types of records: 

• Generator 

• Load 

• Branch 

• Switched Shunt 

• Mutual Impedance 

Each of these four types of sequence data records has a different format, since they each store different information 
for the sequence data.  The format of each record is given below: 

 

Generator 

 GEN busnum ID Rpos Xpos Rneg Xneg Rzer Xzer RN XN 

where 

busnum generator terminal bus, 

id generator identifier, 

Rpos, Xpos positive sequence resistance and reactance, 

Rneg, Xneg negative sequence resistance and reactance, 

Rzer, Xzer zero sequence resistance and reactance, 

RN, XN neutral-to-ground resistance and reactance. 

 

Load 

 LOAD busnum Gneg Bneg Gzer Bzer 

where 

busnum load terminal bus, 

Gneg, Bneg negative sequence total conductance and susceptance for all loads at bus, 

Gzer, Bzer zero sequence total conductance and susceptance for all loads at bus. 

 

Branch 

BRANCH fbusnum tbusnum ckt Rzer Xzer Czer fGzer fBzer tGzer tBzer Xftype  

where 

fbusnum, tbusnum from and to bus numbers for the branch, 

ckt branch circuit identifier, 

Rzer, Xzer zero sequence branch resistance and reactance, 

Czer total zero sequence line charging, 

fGzer, fBzer zero sequence line shunt conductanc e and susceptance at the from bus end of 
the branch, 

tGzer, tBzer zero sequence line shunt conductance and susceptance at the to bus end of 
the branch, 

Xftype Transformer configuration, entered as an integer based on the following table.  
Note that the default for a transmission line is 3, since a grounded wye - 
grounded wye transformer connection has the same equivalent model as a 
transmission line. 

 0 Wye - Wye 

 1 Grounded Wye - Wye 

 2 Wye - Grounded Wye 

 3 Grounded Wye - Grounded Wye 

 4 Wye - Delta 

 5 Delta - Wye 

 6 Grounded Wye - Delta 
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 7 Delta - Grounded Wye 

 8 Delta - Delta 

 

Switched Shunt 

SSHUNT busnum numblocks Bzer1 Bzer2 … 

where 

busnum terminal bus number, 

numblocks number of different zero sequence admittance blocks, 

Bzer# zero sequence susceptanc e for each admittance block, maximum of 8. 

 

Mutual Impedance  

MUTIMP from1 to1 ckt1 from2 to2 ckt2 RM XM start1 end1 start2 end2 

where 

from1, to1 from and to bus numbers of the first mutually coupled branch, 

ckt1 circuit identifier of the first mutually coupled branch, 

from2, to2 from and to bus numbers of the second mutually coupled branch, 

ckt2 circuit identifier of the second mutually coupled branch, 

RM, XM zero sequence mutual resistance and reactance, 

start1, end1 start and end locations of the section of the first line affected by the mutual 
coupling, with each point represented as a percentage of the total line length 
(between 0 and 1), 

start2, end2 start and end locations of the section of the second line affected by the mutual 
coupling, with each point represented as a percentage of the total line length 
(between 0 and 1). 
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Exporting Onelines in Different Graphic Formats 

Simulator can export oneline diagrams and other graphical displays as bitmaps, metafiles, or jpegs.  Select File > 
Export Oneline  from the main menu.  A save file dialog appears where the dropdown menu for files type offers three 
choices: JPEG, BITMAP, METAFILE.  Select the file type and choose he name before clicking the save button. 

Exporting an image as a jpeg also requires you to set the compression ratio for the picture.  See Saving Images as 
Jpegs for more information. 
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Saving Images as Jpegs  

Simulator can save oneline diagrams, bus view displays, and strip charts as  jpeg images.  To save a oneline diagram 
or bus view display as a jpeg, select File > Export Oneline  from the main menu.  This brings up the save file dialog 
where you can specify file type from the dropdown menu.  Choose jpeg, type the file name, and pres s save.  This 
brings up the resolution screen where you decide the picture's resolution.  Adjust the resolution control to specify the 
compression ratio at which to save the diagram as a jpeg.  The greater the resolution you specify, the larger the 
resulting file will be.  Click Save to save the image or click Cancel to terminate the process without saving the image 
as a jpeg. 

To save a strip chart as a jpeg image, right-click on the background of the strip chart and select Save As Jpeg from 
the resulting local menu.  Specify the compression/resolution in the Jpeg Options Dialog.  Click Cancel to terminate 
the process, or click Save  to save the jpeg to a file whose name you specify. 
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Saving Admittance Matrix and Jacobian Information 

The Save Ybus or Power Flow Jacobian Dialog is used to store the power system bus admittance matrix (Ybus) 
and/or the pow er flow Jacobian in a text format that can be easily read into other programs such as MATLAB.  This 
dialog is primarily designed for users doing power system analysis research.  The dialog has the following fields. 

 

Ybus in MATLAB Format 

Filename for Saving Ybus 

Enter the name of the file in which to store the Ybus data.  The Ybus data is stored using the MATLAB sparse 
matrix format in the matrix Ybus .  If the Include Bus Voltages field is checked, then the bus voltages are also 
stored, but in the vector V.   

Save Ybus in MATLAB Format 

Click this button to save the Ybus. 

 

Power Flow Jacobian in MATLAB Format 

Jacobian Save File  

Enter the name of the file in which to store Jacobian data.  The Jacobian is stored using the MATLAB s parse matrix 
format in the matrix Jac.   

Jacobian ID Save File  

Enter the filename to store the text identifier information.  This information is used to translate the bus numbering 
convention used in the Jacobian and Ybus files with the actual bus number and name in the case. 

File Type  

Choose the type of MATLAB file you wish to save as.  The MATLAB .M Format is the more common text format 
used for directly loading MATLAB information.  The Text for MATLAB Ascii is for use with MATLAB’s ability to 
read Ascii files.  The Ascii file type can be read into MATLAB much faster than the traditional .M files.   

Jacobian Form 

Select Rectangular to store the rectangular form of the Jacobian, or Polar  to store the polar form of the Jacobian. 

Save Jacobian 

Click this button to save the Jacobian and object identifier information.   

Templates 

Using Templates 

Simulator allows you to use files called Templates to apply a pre-defined set of options to a particular case quickly 
and conveniently.  Simulator supports the use of two types of templates: 

• Case Templates, which store options related to the power flow case and the application environment.  These 
options include schedules, case information display customizations, and other options you would typically find on 
the PowerWorld Simulator Options Dialog. 

• Oneline Display Templates, which allow you to apply the options used for a particular oneline diagram to a 
different oneline diagram. 

Case templates are stored as separate files having the extension .pwt by default.  Oneline diagram templates are 
actually just PowerWorld oneline diagram files having the default extension .pwd. 

For more information, see Case Templates and see Oneline Templates. 
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Case Templates 

A case template is a file of options that you can apply to the case currently in memory.  You can use a case template, 
for example, to apply a set of options you have defined using Simulator for a previous case to a case you are just 
building from scratch, or to a case you have imported from another power flow program that does not support 
Simulator’s set of options. 

You can control the contents of a case template from the Templates Tab of the PowerWorld Simulator Options Dialog.  
A case template may contain schedules, case information display customizations, and any of the options specified on 
the other tabs of the PowerWorld Simulator Options Dialog. 

To save a set of options as a template, select File > Save Case As  from the main menu and change the Save As 
Type option to PowerWorld Template (*.pwt).  Specify the name of the template file and click Save . 

To apply a pre-existing case template file to the case currently in memory, select Options/Tools > Apply Template, 
Case from the main menu in either the edit or Run Modes.  Select the template file whose options  you wish to apply to 
the current case. 

You can configure Simulator to apply a particular case's template options to any case you load into memory by 
checking the Use Default Template checkbox on the Template Tab of the PowerWorld Simulator Options Dialog and 
specifying the name of the template file.  The default template file must exist in the same directory as the case to 
which you are applying it. 
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Oneline Templates 

A oneline template is really nothing more than the portion of a Simulator oneline diagram file that specifies its display 
options.  To apply the display options associated with a pre-existing oneline diagram to the case and oneline currently 
in memory, select Options/Tools > Apply Template > Oneline  from the main menu in either the run or Edit Modes.  
Then, select the oneline diagram file whose display options you wish to apply. 
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Building a Oneline Diagram 

Chapter 4 : Building a Oneline Diagram 

The oneline objects provide a key means of interacting with the power flow simulation.  This chapter provides a 
reference on how to insert each of the different types of objects shown on the oneline diagram, and an overview of 
Edit Mode.  Note that when you are using the Simulator, you can obtain context sensitive help for oneline objects by 
positioning the cursor on the desired object and pressing the F1 key.   

The following material is included: 

• Edit Mode Overview  

• Edit Mode General Procedure  

• Description of the Insert Menu 

• Use of Anchored Objects 

• Descriptions of All Oneline Objects 

Overview 

Edit Mode Overview  

The Edit Mode is used to create and/or modify cases and onelines.  You can use the Edit Mode to create a case from 
scratch or to modify existing power flow cases stored in PowerWorld PWB or AUX files, or in the PTI Raw data format, 
GE PSLF EPC data format, or the IEEE Common Format.  New users may wish to view step-by-step tutorials on either 

Creating a New Case from Scratch 

Creating Onelines for an Existing Power Flow Case. 

To enter the Edit Mode, select the Edit Mode button on the Program Toolbar, or choose File > Switch to Edit Mode 
(will only be visible if you are in Run Mode) from the file menu. 

A powerful capability of the Simulator is its ability to create or modify a case by graphically placing/editing display 
objects on a oneline diagram.  These display objects consist of both power system devices, such as buses, 
generators, and transmission lines; and additional objects that show various system parameters, provide descriptive 
text, or function as a static background.   

Simulator’s oneline diagrams illustrate the current state of the components of the power system.  Most display objects 
correspond to records in the underlying power system model, but not all records in the power system model need to 
have an associated display object.  In fact, for large system models, it may be that most of the system will not be 
illustrated.  In such cases, you will want to devote more detail to the more critical areas of the system so as not to 
clutter the view.  Furthermore, it is possible to associate more than one oneline with a single power flow case, and a 
single oneline may be associated with multiple cases. This great flexibility can prove to be a big time-saver.  Please 
see Relationship Between Display Objects and the Power System Model for a more thorough discussion.  



Printed Documentation 

82 

Edit Mode General Procedures  

In order to simplify the process of graphically constructing a power flow case, Simulator’s drawing interface obeys the 
following conventions for most objects: 

 

Inserting a New Object  

• Select the type of the object you wish to add from the Insert MenuBuilderInsertMenu<+>.  

• Left-click on the location on the display where you would like to position the object.   

• Once the object is placed, Simulator displays a dialog box that allows you to specify various options for the object.   

• If desired, use the Format Menu to change the appearance of the object once it has been placed.  

Moving or Resizing an Existing Object 

• Select the object by clicking on the object with the left mouse button.  Handles are displayed around the object to 
indicate it has been selected.   

• To move the position of the object, place the mouse anywhere on the object except at a handle location.  Then drag 
the object around the screen by holding the left mouse button down.   

• To change the size of an object using the mouse, first select the object.  Then place the mouse on one of the 
object’s resizing handles.  The cursor will change to either a horizontal, vertical or diagonal two-headed arrow 
shape.  Then drag the mouse to change the object’s size.  Text/field objects cannot be resized; rather, you should 
change their font size.  You can also specify the size of most objects using their dialog boxes.   

Viewing/Modifying Object Parameters 

• To view and/or change the options associated with an object, right-click on the object.  This either displays the 
object’s dialog box directly, or it display’s the objects local menu, from which you can elect to see the object’s dialog 
box. 

Selecting Several Objects to Modify Their Appearance  

Hold down the Shift key while clicking objects on the screen to select several objects at once.  You may then 
change the objects’ attributes, such as Font, Line/Fill, etc., by choosing Display/Size from the Format Menu.  To 
move the objects that are selected, click and hold down the left mouse button on any of the selected objects, drag 
the selected objects to a new location, and release the mouse button to place them. 

To select a set of objects that meet some given criteria, choose Select by Criteria from the Edit Menu.  As an 
example, use Select By Criteria to select all the 345 kV transmission lines in a case. 

You can also use the Rectangle Selector button on the Edit Toolbar to select all objects in a particular region of the 
oneline.  

Changing An Object’s Screen Appearance  

Use the Format Menu to change the screen appearance of either a selection of objects or the entire display. 
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Insert Menu 

The Insert Menu contains the key selections for creating or modifying the oneline diagram, and hence the associated 
case.  The options on this menu are only available in Edit Mode, and have opened an existing or new oneline diagram 
for the currently loaded case file.  Most of the insert activities are accessible from the Insert Toolbar, as well.  The 
insert menu provides a convenient means of inserting new objects into the case by graphically placing them on the 
oneline diagram.  See Case Information Display for details on modifying data that is not necessarily shown on the 
oneline. 
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Oneline Display Options  

The Oneline Display Options Dialog allows you to customize the appearance of the presently selected oneline 
diagram.  To view this dialog, either select Options/Tools > Oneline Display from the main menu or choose Oneline 
Display Options from the oneline’s local menu .  Please see the Oneline Display Options Dialog help for Run Mode 
and Edit Mode for more information.  
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Anchored Objects  

While in Edit Mode, Simulator allows certain objects to be attached, or anchored, to another object, called the anchor.  
When an object that functions as an anchor is moved, all objects that are anchored to it will move with it.  This feature 
can be very useful when you move objects around the oneline diagram in Ed it Mode.   

Anchoring has the property of "stacking" in Simulator.  In other words, one object is anchored to another, which is in 
turn anchored to yet another.  The best way to describe this is by example.  A generator text field can be anchored to 
a generator.  The generator, in turn, can be anchored to its terminal bus.  If you move the terminal bus, both the 
generator and its anchored fields also move with the bus.  However, if you just move the generator itself, only the 
generator fields will move with it.  The bus and all other objects anchored directly to the bus remain in their original 
location. 

There are several types of anchored objects: 

Buses  

Loads, generators, switched shunts, bus fields, and transmission lines may be anchored to their associated bus.  
When the anchor bus is moved, these anchored objects will move with it. 

Generators  

Generator fields may be anchored to their associated generator.  When the anchor generator is moved, these 
anchored objects will move with it. 

Loads  

Load fields may be anchored to their associated load.  When the anchor load is moved, these anchored objects will 
move with it. 

Switched Shunts  

Switched shunt fields may be anchored to their associated switched shunt.  When the anchor switched shunt is 
moved, these anchored objects will move with it. 

Area/Zone Objects  

Interface objects can be anchored to either area/zone objects or buses.   

Lines and Transformers  

Circuit breakers, line pie charts, and line analogs may be anchored to their associated line/transformer.  When the 
line/transformer is moved, these anchored objects will move with it.   

Interfaces  

Interface fields and interface pie charts can be anchored to their associated interface.   
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Inserting and Placing Multiple Display Fields  

Simulator provides a convenient method of adding display fields to a variety of oneline display objects and placing 
them in default positions relative to the display object.  Unlike the field placement implemented by selecting Insert > 
Fields  from the main menu, the method described here allows you to place multiple fields around a display object in a 
single operation.  This option is available for several different types of objects, including buses, generators, lines and 
transformers, shunts, and loads.  The option can always be accessed by right clicking the display object of interest and 
selecting the Add New Fields to … option from the resulting local menu.  This brings up the Insert New Fields 
around Selected Objects Dialog.  This dialog is divided into several tabs by object type.  Only tabs that correspond 
to the type of objects you have selected will be available. 

The tabs for inserting and placing multiple display fields for the various display objects (buses, generators, 
lines/transformers, shunts, and loads) are virtually identical in content.  The tab illustrates the possible locations of the 
display fields for the various orientations of the display object.  For example, since buses may be oriented either 
horizontally or vertically, the dialog shows how each of the eight possible bus fields would be positioned for each of the 
two orientations.  Generators, loads, and shunts each have four possible orientations, so the dialog identifies the 
locations for the possible fields for each of the four orientations.  Transmission lines and transformers can assume 
only one orientation, and the dialog will thus show the possible field locations for that single orientation. 

Each field location is identified on the illustrations with a label of the form Pos #.  In order to modify the settings, move 
your mouse over the position on the dialog you want to change and click.  This will bring up the appropriate Field 
Options Dialog such as the Bus Field Options, Generator Field Options, Load Field Options, Switched Shunt Field 
Options, or the Line Field Options.  Simply select the field you want and choose OK.  If you would like to set a default 
field to "none", click Remove Field instead of OK.  

Click OK to implement your choices for field additions and placement, or click Cancel to discard the changes. 

This help topic has gone over how to add new fields to existing display objects.  It should be noted from this discussion 
that all objects have an associated set of default fields that will be added to the oneline when the objects are originally 
inserted.  You may redefine the default fields selecting Options/Tools > Default Drawing Values from the main menu 
and modifying the Default Drawing Options Dialog.  

Areas and Zones 

Area/Zone/Super Area Display Objects  

Areas and zones may be represented on Simulator oneline diagrams.  This feature may prove particularly useful for 
illustrating how the areas and zones comprising the system are interconnected.  Not only can Simulator depict bus-to-
bus connections, but it can also show area-to-area and zone-to-zone connections through the use of area and zone 
display objects and interface objects.  Since multiple oneline diagrams can be associated with a single power flow 
case, you may find it useful to construct two oneline diagrams for your model:  one showing the system at the bus 
level, and the other representing the areas or zones that make up the model as blocks tied together by area-area or 
zone-zone interface objects.  

 

Edit Mode  

To add an area or zone display object to a oneline, choose Insert > Area/Zone/Super Area from the main menu or 
click the Area/Zone  button on the Insert Toolbar.  Then, click the left mouse on the oneline to indicate where you 
would like to place the new area or zone object.  The Area/Zone/Super Area Display Options Dialog will appear.  
Supply the requested information and click OK to finish adding the area or zone or Cancel to abort the operation.  If 
you choose OK, the new area or zone display object will appear on the oneline diagram at the location you chose. 

When you select an area or zone display object, it will display its sizing handles.  Use the sizing handles to resize 
the area or zone display object as desired. 

Area or zone objects may be connected together by interface objects.  

It is important to note that this discussion covers how to add area or zone display objects  only, not area or zone 
records.  Area or zone records cannot be added graphically.  Instead, area or zone records are added to the model 
whenever a bus is assigned to an area or zone that does not already exist.  The procedure we have discussed here 
can be used only to represent a pre-existing area or zone graphically on a oneline.  It cannot be used to add an 
area or zone to a case model. 
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Area/Zone/Super Area Display Options Dialog 

When you try to insert an area or zone display object on a oneline diagram, Simulator opens the Area/Zone/Super 
Area Display Options  dialog.  Use the Area/Zone/Super Area Display Options dialog to control various display and 
identity attributes of the area or zone display object.  The dialog contains the following fields: 

 

Type of Record 

Indicate whether area/zone/super area display object you are adding corresponds to an area, zone, or super area. 

Number 

This dropdown box lists the number of all areas (if you are inserting an area object), zones (if you are inserting a 
zone object), or super areas (if you are inserting a super area object) in the case.  Use this control to associate the 
display object with the correct area, zone, or super area. 

Name 

If you would prefer to search through areas, zones, and super areas by name rather than by number, use the Name 
dropdown box to see a list of names of all the areas or zones in the case. 

The remainder of the choices presented on the Area/Zone/Super Area Display Options dialog pertain to the object's 
display appearance. 

Style 

Choose whether the display object should appear as a rectangle or as an ellipse. 

Caption 

Indicate how the display object should be identified to the user: by name, number, or both. 

Width, Height 

The dimensions of the new display object. 

Click OK to save your selections and add the object to the oneline, or choose Cancel to terminate the addition. 
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Area Fields on Onelines 

Area fields are used to show various values associated with a particular area of the power system.  Right clicking on 
the area field displays the Area Field Dialog.   

 

Edit Mode  

To enter a new area field, first select Insert > Fields > Area Fields  from the main menu, or click the Area Fields  
button on the Insert Toolbar. Then, click on or near a bus in the area for which you w ant to add a field. This calls up 
the Area Field Dialog.  Verify that the area number is correct.  By default, this value is the number of the area 
associated with the closest bus.  Enter the total number of digits the field should display as well as the number of 
digits to the right of the decimal point.  Depending on what the field is designed to display, you may need to enter an 
additional area number.  Finally, select the field type.  Click OK to save the field or Cancel to abort the operation.  

To modify the parameters of an existing area field, position the cursor anywhere on the area field and right-click.  
This again brings up the Area Field Dialog.  Use the Format > Display / Zoom Levels main menu option to change 
various display attributes for the area field, including its font and background color.  Finally, you can use the Format 
> Oneline Display > Default Font option to change the font for all fields on the display.  
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Zone Fields on Onelines 

Zone field objects are used to show different values associated with zones and the system.  This dialog is used to view 
and modify the parameters associated with these fields.  Note that the zone number itself cannot be changed on this 
dialog.  To reach this dialog, go to Insert > Field > Zone Field in Edit Mode. 

 

Zone Number 

Zone number associated with the field.  When you insert fields graphically, this field is automatically set to the zone 
number associated with the closest bus on the oneline.  With most types of zone fields, an Zone Number of 0 is 
valid and defines the field as showing values for the entire system.   

Find… 

If you do not know the exact zone number you are looking for, you can click this button to open the advanced 
search engine. 

Total Digits in Fields  

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Other Zone Number 

Some of the fields, such as MW Flow to Other Zone , require that a second area be specified.  If applicable, enter 
the second (other) zone here.   

Delta per Mouse Click  

This value is used only with the Sched Flow to Other Zone  field type.  When there is a nonzero entry in this field, 
and the field type is Sched Flow to Other Zone , a spin button is shown to the right of the zone field.  When the up 
spin button is clicked, the flow to the other zone is increased by this number of MW; when the down button is 
clicked, the scheduled flow is decreased by this amount.   

Field Value  

Shows the current output for the zone field.  Whenever you change the Type of Field selection, this field is 
updated.   

For the Sched Flow to Other Zone  field type only, you can specify a new value in MW.  Exports are assumed to be 
positive.  

Field Prefix 

An optional string that precedes the field value.   

Rotation Angle in Degrees 

The angle at which the text is to appear on the oneline diagram. 

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

Type of Field 

Used to determine the type of zone field to show.  The two choices available are Name and Number. 

Name  

Zone name (eight characters maximum).  The Zone Number field must correspond to a valid zone. 

Number 

Zone number (1 - 999).  The Zone Number  field must correspond to a valid area.  

MW Load, M var Load 

If the zone number is nonzero, then these fields show Total MW or Mvar load for the zone.  If the zone number is 
zero, these fields show the total load in the entire system. 

MW Generation, Mvar Generation  

If the Zone Number is nonzero, then these fields show Total MW or Mvar generation for the zone.  If the Zone 
Number is zero, these fields show the total generation in the entire system. 

MW Shunts, MVR Shunts  

If the Zone Number is nonzero, then these fields show Total MW or Mvar shunt compensation for the zone.  If the 
Zone Number is zero, these fields show the total shunt compensation in the entire system. 

MW Flow to Other Zone, Mvar Flow to Other Zone  
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Total MW or Mvar flow from the zone specified in the Zone Number field to the zone specified in the Other Zone 
Number field.  The Zone Number field must correspond to a valid zone.  If the Other Zone Number field is zero, this 
field shows the zone's total MW or Mvar exports.   

MW Losses, MVAr Losses 

If the Zone Number is nonzero, then these fields show Total MW or Mvar losses for the zone.  If the Zone Number 
is zero, these fields show the total real or reactive losses in the entire system. 

Load Schedule Multiplier 

Indicates the current value of the multiplier applied to the zone's loads.  See Load Variation Display for more detail. 

Select OK to save changes and close the dialog or Cancel  to close dialog without saving your changes.   
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Super Area Fields on Onelines 

To display certain information about a super area, such as MW Load or MVAR losses, insert a super area field.  This 
can be done in Edit Mode through Insert > Fields > Super Area Field.  This will bring up the Super Area Field 
Information.  From here you can choose which super area to describe, how many digits in the field, and how many 
digits to the right of the decimal.  There are also 12 different field options to choose from.  If a field value is not defined, 
question marks will be shown. 

To view the different owners and see the number of objects they own, select Case Information > Ownership.  For 
more information, see Owner Data Information Display. 

When you save the case, any changed values are saved in the .pwb file, either in the Owners section of the .pwb or 
with the individual objects.  Owner data can also be saved with PTI version 25 and later text formats. 

Buses 

Bus Display Objects  

In power system analysis, the term "bus" is used to refer to the point where a number of electrical devices, such as 
lines, loads or generators, join together.  On the oneline diagram, buses are usually represented with either a thick 
horizontal line or a thick vertical line.  The bus thickness and color can be customized.   

Right-clicking on the bus will display its local menu.  The local menu offers you the chance to view the corresponding 
Bus Dialog, the Quick Power Flow List, and the Bus View Display.  When the application is in Edit Mode, the local 
menu will also allow you to add bus fields to the bus and to insert any undrawn buses connected to the selected bus.  
Bus Fields are often placed close to the bus to indicate its voltage magnitude, voltage angle, and other relevant 
information.   

 

Edit Mode  

To add a new bus to the case, follow this simple procedure:  

• • Select Insert > Bus  from the main menu, or select the Bus  button on the Insert Toolbar.  This prepares 
Simulator to insert a new bus. 

• • Left-click on the oneline background at the location where you want to place the new bus.  This invokes the 
Bus Option Dialog. 

• • Use the Bus Option Dialog Box to specify the number, name, size, thickness, orientation, area, zone, and 
nominal voltage of the bus, as well as the load and shunt compensation connected to it.  Every bus must have 
a unique number. 

• • Click OK on the Bus Option Dialog to finish creating the bus and to close the dialog.  If you do not wish to add 
the bus to the case, click Cancel. 

If you are simply adding a symbol to the oneline diagram for a bus that has already been defined in the case, many 
of the parameters you are asked to specify in step three will be filled in for you.  

To modify the parameters for an existing bus, position the cursor on the bus and right-click to invoke the bus' local 
menu.  From the local menu, choose Bus Information Dialog to view the associated Bus Dialog.  You may change 
any of the parameters specified there.  When a bus' number is changed, the bus numbers associated with all of the 
devices attached to that bus are also automatically changed.  To renumber a number of buses simultaneously, 
please see Options, Bus Renumbering Dialog. 

To modify any aspect of a bus' appearance, first select the bus, and then click Format > Display/Size from the 
main menu.  You can change the length of the bus (but not its thickness) by dragging the bus' resizing handles.   

To delete an existing bus, use either the Edit > Cut command to preserve a copy of the bus on the Windows 
clipboard, or Edit > Delete  to remove the bus without copying it to the clipboard.  You will be asked whether you 
want to remove both the display object and its associated bus record, or merely the display object, leaving the bus 
in the power flow model.  If you will never be deleting a record from the pow er system model, you may also choose 
the option labeled Always Delete Objects Only.  Be careful when deleting existing buses with attached devices.  An 
error will occur during validation if you do not also delete the attached devices or attach them to other buses.   
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Bus Fields on Onelines 

Bus field objects are used primarily to indicate various quantities associated with bus devices.  Furthermore, some bus 
field types, which are distinguished by an integrated spin button, may be used to change bus device properties. 

 

Run Mode  

For bus fields with an associated spin button, clicking on the up/down arrows will change the value of the 
associated field. 

Right clicking on a bus field gives you the option to open the Bus Field Dialog or the Bus Information Dialog.   

 

Edit Mode  

Simulator offers two options for adding bus fields to a oneline in Edit Mode.  If you need to enter only a single field, 
the easier approach may be to choose Insert > Field > Bus Field from the main menu or the Bus Field button from 
the Insert Toolbar and then select the bus to which you want to add the field.  This invokes the Bus Field Dialog.  
Enter the bus number associated with the device (the default is the closest bus to the field), the total number of 
digits to show, and the number of digits to the right of the decimal point.  Specify the ID field when working with 
fields related to generators or loads.  Next, select the type of field to show. To show load/capacitor/generator 
values, the corresponding device must, of course, be attached to the bus.  The Setpoint Generator MW type should 
be selected only for cases that employ the uniform frequency option.  For generator actual MW and Setpoint MW 
types and load MW and Mvar fields, specify a nonzero value in the Delta per Mouse Click to design a bus field with 
an integrated spin control.  The Gen AGC Status field is used to display the automatic generation control status of 
the generator.  The user can toggle this status in Simulator by clicking on the field.  Likewise, the Gen AVR Status 
field is used to display the automatic voltage regulation status of the generator.  Again the user can toggle this 
status by clicking on the field.    

The second approach for adding new bus fields entails right-clicking the bus and selecting Add New Fields Around 
Bus from the resulting local menu.  Please see Inserting and Placing Multiple Display Fields  for more details. 

To modify the parameters of an existing bus field, position the cursor anywhere on the object and right-click.  This 
brings up the Bus Field Dialog.  Choose Font, Line/Fill, or Display/Size from the Format menu to change various 
display attributes of the field, including its font and background color. 
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Voltage Gauges 

Voltage gauges provide a way to visualize the voltage of a bus relative to its high- and low -voltage alarm limits.  A 
gauge looks very much like a thermometer.  As the temperature changes, the height of the mercury in the 
thermometer moves up and down.  One reads the temperature measured by the thermometer by noting the marking 
that matches the top of the mercury.  Voltage gauges in Simulator work the same way.  A voltage gauge has three 
markings on its side, each of which identifies a key per-unit voltage level.  Specifically, these three markings locate the 
minimum, maximum, and target per-unit voltages.  Often, the target voltage level is the nominal voltage, but this is not 
a requirement.  Inside the gauge is a filled region.  The default color of the filled region is blue, but this can be 
changed.  When you c reate the voltage gauge, you associate it with a bus, and you specify its fill color and its 
minimum, maximum, and target voltage levels.  Once the gauge has been placed on a display, it will reveal changes in 
its associated bus’s voltage by varying the height of its filled region.  This tool was introduced to provide an alternative 
to voltage contours to show the variation of voltage across a region.  Contouring can reveal the variation of only a 
single quantity at a time.  For example, it is impossible to contour bus voltage magnitude and bus voltage phase angle 
simultaneously.  Voltage gauges are helpful because they allow you to show the voltage profile superimposed on a 
contour of some other quantity. 

To add a voltage gauge to a display, switch to Edit Mode and select Insert > Gauges > Bus from the main menu.  
The cursor will become a crosshairs.  Click on the oneline diagram where you would like the new voltage gauge to 
appear.  The Voltage Gauge Options Dialog will appear.  Use this dialog to define the minimum, maximum and target 
voltages for the voltage gauge, as well as its fill color and whether it should be anchored to its associated bus.  After 
you click the "OK" button, the Voltage Gauge Options Dialog will close, and the new voltage gauge will appear. 

Once a gauge has been placed on the oneline, the height of its filled region will change as the voltage of its associated 
bus changes.  To modify any of the characteristics of the gauge, such as its key voltage levels, fill color, and anchor 
setting, simply right-click on the bus voltage gauge to open the Voltage Gauge Options Dialog again. 
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Voltage Gauge Options Dialog 

The Voltage Gauge Options Dialog is used to define and configure a bus voltage gauge.  A bus voltage gauge is 
associated with a particular bus and reveals the bus’s voltage relative to specified minimum, maximum, and target per-
unit voltage levels.  The height of the colored column in the voltage gauge indicates the bus’s voltage relative to these 
markings. 

 

The dialog sports the following controls: 

Number, Name, and Find 

Use the Number and Name dropdown boxes to identify the bus to which you want the gauge to correspond.  Select 
a bus number from the Number dropdown box to identify the bus by number, and a bus name from the Name 
dropdown box to identify a bus by name.  It may be more convenient to press the Find to open the Find Dialog, 
which allows you to specify a bus by either name or number using wildcards.  When you first open the Bus Voltage 
Gauge Dialog, the bus name and number will correspond to the bus object that was closest to the point where you 
clicked. 

Minimum, Target, and Maximum 

Use these three spin edit boxes in the Voltage levels  group box to specify the minimum, maximum, and target per-
unit voltage levels. These settings determine where on the gauge its three markings will be drawn. 

Fill color 

The Fill color box reveals the color that will be used to paint the filled region of the gauge. Click on the Fill color box 
to open a Color Dialog, which you may then use to specify a different color. 

Anchored 

A bus voltage gauge is said to be anchored if, when you move its associated bus object, it moves with it. Check the 
Anchored check box to ensure that the gauge will move with its associated bus.  Otherwise, when you move its 
associated bus object, the gauge will stay in its current position. 

OK, Help, and Cancel 

Click OK to finalize your settings. This will create a new voltage gauge object if you are trying to create one from 
scratch, or it will modify the appearance and settings of an existing one if you have chosen to modify one that has 
already been defined.  Click Cancel to dispose of your changes. Click the Help button to reveal this help text. 

Substations  

Substation Display Objects  

Substations in Simulator define a group of buses that are closely connected.  Each bus can belong to either one 
substation or no substation (called unassigned).  By default in Simulator, all buses are not assigned to a substation.  
This is done because all traditional text file power flow formats do not include information regarding a bus' substation. 

Substations are represented on the oneline as a rectangle with the name of the substation inside it.  Other information 
about the substation is also displayed on the rectangle: 

• • The upper left corner displays a generator symbol if generation exists in the substation. 

• • The upper right corner displays a load symbol if load exists in the substation. 

• • The lower right corner displays a shunt symbol if shunts exist in the substation. 

• • The lower left corner displays the number of buses inside the substation. 

• • The lower middle displays the maximum voltage level in the substation. 

You can also customize the size, colors, and font name and style of a substation object.  Note however that the font 
size of the substation object is automatically changed by Simulator as you change the size of the rectangle.   

Right-clicking on the substation will display its local menu.  The local menu offers you the chance to view the 
corresponding Substation Information Dialog and the Substation View Display. 

Generators 

Generator Display Objects  

Generators are represented on the oneline as circles with a "dog bone" rotor inside.  Multiple generators at a bus are 
allowed, with each being distinguished by a unique character identifier.   

Each generator symbol (except that corresponding to the slack) is equipped with a circuit breaker that can be used to 
change the status of the generator.  You may toggle the generator status by clicking on the circuit breaker.  
Furthermore, the angular position of the dog bone rotor can indicate the "angle" of the voltage at the generator 
terminal if desired. 

Generator fields are often placed close to the generator on the oneline to indicate the generator's MW/Mvar output. 

 

Run Mode  
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When animation is active, the default flow of the arrows emerging from the generator is proportional to its MW 
output.  You can customize the appearance of this flow using the Animated Flows Tab of the Oneline Display 
Options Dialog.   

Right clicking on the generator brings up the generator submenu.  This menu is used to display a v ariety of 
information about the generator, including 

• • Γενερατορ Ινφορµατιον ∆ιαλογ  

• • Ινπυτ−ουτπυτ χυρϖε  

• • Φυελ χοστ χυρϖε  

• • Ινχρεµενταλ χοστ χυρϖε  

• • Ηεατ−ρατε χυρϖε  

• • Ρεαχτιϖε χαπαβιλιτψ χυρϖε  
 

Edit Mode  

To add a new generator to the case, select Insert > Generator from the main menu, or click the Generator button 
on the Insert Toolbar.  Then, place the cursor on the bus where you would like to attach the generator, and click 
with the left mouse button.  This calls up the Generator Dialog.  The bus number is automatically determined from 
the bus to which you attached the generator.  The ID field contains a an alphanumeric ID used to distinguish 
multiple generators at a bus.  The default is '1'.   

Enter the size, the thickness of the lines (in pixels) used to display the device, orientation, and other parameters for 
the generator.  Each generator automatically contains a switch for connecting or disconnecting the device in 
Simulator.  Select OK to add the generator.  If you do not want to add the generator to the case, select Cancel.   

To modify the parameters for an existing generator, position the cursor on the generator and right-click.  This again 
brings up the Generator Dialog. You can then change any parameter (be careful in renumbering an existing 
generator). Use the Format Menu commands to change the color, line thickness, and other display parameters.   
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Generator Fields on Onelines 

Generator field objects are used primarily to indicate various quantities associated with generation devices.  
Furthermore, some generator field types, which are distinguished by an integrated spin button, may be used to change 
generation device properties. 

 

Run Mode  

For generator fields with an associated spin button, clicking on the up/down arrows will change the value of the 
associated field. 

Right clicking on a generator field gives you the option to open the Generator Field Dialog or the Generator 
Information Dialog.   

 

Edit Mode  

Simulator offers two options for adding generator fields to a oneline in Edit Mode.  If you need to enter only a single 
field, the easier approach may be to choose Insert > Field > Generator Field from the main menu or the 
Generator Field button from the Insert Toolbar and click near generator for which you want to add the field.  This 
invokes the Generator Field Dialog.  Enter the bus number associated with the device (the default is the bus 
associated to the closest generator to the field), the ID field, the total number of digits to show, and the number of 
digits to the right of the decimal point.  Next, select the type of field to show.  The Setpoint Generator MW type 
should be selected only for cases that employ the uniform frequency option.  For generator actual MW and Setpoint 
MW types and load MW and Mvar fields, specify a nonzero value in the Delta per Mouse Click to design a bus field 
with an integrated spin control.  The Gen AGC Status field is used to display the automatic generation control status 
of the generator.  The user can toggle this status in Simulator by clicking on the field.  Likewise, the Gen AVR 
Status field is used to display the automatic voltage regulation status of the generator.  Again the user can toggle 
this status by clicking on the field.    

The second approach for adding new generator fields entails right-clicking the bus and selecting Add New Fields 
Around Generator from the resulting local menu.  Please see Inserting and Placing Multiple Display Fields  for more 
details. 

To modify the parameters of an existing generator field, position the cursor anywhere on the object and right-click.  
This brings up the Generator Field Dialog.  Choose Font, Line/Fill, or Display/Size from the Format menu to 
change various display attributes of the field, including its font and background color. 

Loads  

Load Display Objects  

Simulator models aggregate load at each system bus.  Multiple loads at a bus are allowed.  Each load object on the 
oneline comes equipped with a circuit breaker.  The status of the load corresponds to the status of its circuit breaker. A 
circuit breaker is closed if it appears as a filled red square, and it is open if it appears as a green square outline.  In 
Run Mode, you may toggle the status of the load by clicking on its associated circuit breaker. 

Load fields are often placed close to the loads on the oneline to indicate their MW/Mvar value. 

 

Run Mode  

When animation is active, the flow of the arrows into the load is proportional to its current MW load. You can 
customize the appearance of this flow using the Animated Flows Tab of the Oneline Display Options Dialog. 

Right clicking on a load (bus) field gives you the option to open the Load Field Dialog or the Load Dialog.   

 

Edit Mode  

To add a new load to the case, select Insert > Load from the main menu, or click the Load button on the Insert 
Toolbar.  Then, select the bus to which you want to attach the load with the left mouse button.  This calls up the 
Load Dialog.  The bus number is automatically determined from the bus to which you attached the load. The ID field 
contains a two-character ID used to distinguish multiple loads at a bus.  The default ID is 1.   

Enter the size, the thickness of the lines [in pixels] used to display the device, the orientation, and the base MW and 
Mvar load values for the device.  Usually, only the Constant Power fields are specified as nonzero.  The Constant 
Current and Constant Impedance fields are used to specify loads that vary with voltage.  Constant current loads 
vary proportionally with bus voltage, while constant impedance loads vary with the square of the voltage.  Specify 
the constant current and constant impedance values assuming one per-unit voltage.  

Select OK to add the load.  If you do not want to add the load to the case, select Cancel.   

To modify the parameters for an existing load, position the cursor on the load and right-click.  Select Load 
Information Dialog from the local menu to invoke the Load Dialog. You can then change any parameter as desired.  
You can select Format > Display/Size from the main menu to change the drawing parameters of the load. 
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Load Fields on Onelines 

Load field objects are used primarily to indicate various quantities associated with load devices.  Furthermore, some 
load field types, which are distinguished by an integrated spin button, may be used to change load device properties. 

 

Run Mode  

For load fields with an associated spin button, clicking on the up/down arrows will change the value of the 
associated field. 

Right clicking on a load field gives you the option to open the Load Field Dialog or the Load Information Dialog.   

 

Edit Mode  

Simulator offers two options for adding load fields to a oneline in Edit Mode.  If you need to enter only a single field, 
the easier approach may be to choose Insert > Field > Load Field from the main menu or the Load Field button 
from the Insert Toolbar and then select the load to which you want to add the field.  This invokes the Load Field 
Dialog.  Enter the bus number associated with the device (the default is the bus associated to the closest load to the 
field), the ID field, the total number of digits to show, and the number of digits to the right of the decimal point.  Next, 
select the type of field to show.  

The second approach for adding new generator fields entails right-clicking the bus and selecting Add New Fields 
Around Load from the resulting local menu.  Please see Inserting and Placing Multiple Display Fields   for more 
details. 

To modify the parameters of an existing load field, position the cursor anywhere on the object and right-click.  This 
brings up the Load Field Dialog.  Choose Font > Line/Fill, or Display/Size from the Format menu to change 
various display attributes of the field, including its font and background color. 

Transmission Lines 

Transmission Line Display Objects  

Transmission lines are represented on the onelines using multiple segment lines drawn between buses.  Transmission 
lines may be equipped with circuit breakers that can be used to change the line's status.  You can also add pie charts 
and line fields to transmission lines to indicate how heavily loaded the line is.  The appearance of transmission lines, 
including line thickness and color, may also be customized. 

 

Run Mode  

Simulator's animation feature can be used to indicate the magnitude of the flow on the transmission line, either in 
MW or in terms of the line's percentage loading. You can customize the line flow animation using the Animated 
Flows Options  on the Oneline Display Options Dialog. 

Right-clicking on a transmission line displays the line's local menu, from which you can choose to inspect the 
Line/Transformer Dialog.   

 

Edit Mode  

To add a new transmission line to the case, first select the Insert > Transmission Line command, or click the AC 
Transmission Line  button on the Insert Toolbar.  Then place the cursor on the first bus for the transmission line 
(the "from" bus) and click the left mouse button.  Add more segments to the line by moving the cursor and clicking 
with the left mouse button.  To complete adding a new line, place the cursor on the second bus for the line (the "to" 
bus) and double-click with the left mouse button.  This calls up the Line/Transformer Dialog.  The "from" and  "to" 
bus numbers are set automatically provided the line starts and ends on existing buses.  If there is just one line 
between the buses, the circuit number should be "1."  For multiple lines between buses, you must give each a 
unique circuit number.  Enter the thickness of the lines [in pixels] used to display the transmission line.   Enter the 
per unit (100 MVA base) resistance, reactance, total charging susceptance (that is B not B/2) for the line, and an 
MVA rating.  Select OK to add the line.  If you do not want to add the line to the case, select Cancel.   

To modify the parameters for an existing line, position the cursor anywhere on the line and right-click.  This brings 
up the Line/Transformer Dialog, which you can use to change various line parameters. Choose Format > 
Display/Size from the main menu to change the drawing parameters of the line.   

To change the shape of the line, first left-click on the line to select it.  This causes handles to appear at each vertex.  
You can then move any vertex clicking and holding the left mouse button down on the vertex, dragging it to a new 
location, and then releasing the mouse button.  To remove a vertex, hold down the CTRL key and then click the 
vertex you would like to delete.  To add a vertex, hold down the CTRL key and then click on the line where you 
would like to add a vertex . 
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Line Fields on Onelines 

Line field objects are used to show values associated with lines, transformers and dc transmission lines.   

 

Run Mode  

Right clicking on the line field gives you the option to open the Line Field Dialog or the Line Information Dialog. 

Edit Mode  

To enter a new line field, select Insert > Fields > Line Field from the main menu or the Line Fields  button on the 
Insert Toolbar and select the line, transformer, or dc line to which you want to add the field. The Line Field Dialog 
will open. Enter the near and far bus number associated with the device (the default values for these fields 
correspond to the device on which you clicked) and the circuit number of the device.  The field will display the flow 
value at the near end of the device.  Enter the total number of digits to show on the screen and the number of digits 
to the right of the decimal point.  Finally, select the desired field type.   

To modify the parameters of an existing line field, position the cursor anywhere on the object and right-click.  This 
again brings up the Line Field Dialog.  Select Format > Display/Size from the main menu to change many of the 
line field's display attributes.  Choose Format > Oneline Display > Default Font to change the font for all fields on 
the display. 

Another way to add line fields to the oneline entails right-clicking the line and selecting Add New Fields Around Line 
from the resulting local menu.  Please see Inserting and Placing Multiple Display Fields for more details.  
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Circuit Breakers on Onelines 

Circuit breakers are used to open or close transmission lines and transformers.  Closed circuit breakers are shown as 
solid red squares, while open circuit breakers are shown as a green square outline.  Circuit breakers cannot be plac ed 
on dc transmission lines.  Clicking on the circuit breaker with the left mouse button in run mode changes the status of 
the breaker. 

In PowerWorld Simulator, a circuit breaker directly controls the status of the associated line or transformer.  Therefore, 
to open a line, you do not have to open circuit breakers at both ends of the line.  In other words opening either of the 
line's circuit breakers opens the line.  However, it is often convenient to place circuit breakers at both ends of a line. 

 

Edit Mode 

By default, when you add a new transmission line or transformer to a oneline diagram, circuit breakers are 
automatically added at each end of the branch. 

To add a new circuit breaker to the oneline, select Insert > Circuit Breaker from the main menu and then click the 
line to which you want to add the breaker. The Circuit Breaker Options Dialog will appear with the from and to bus 
numbers, and the circuit number automatically set to identify the line you selected.  Specify the size for the switch 
and its initial status, as well as whether it will be anchored to the line so that it will move with the line.  Click OK to 
add the circuit breaker, or click Cancel  to abort the process. To add more circuit breakers to the line, simply repeat 
this procedure. 

To modify the parameters for an existing switch, position the cursor anywhere on the device and right-click.  This 
invokes the Circuit Breaker Options Dialog, from which you can change many of the breaker's parameters. 
Additional display settings for the circuit breaker can be accessed by selecting Format > Display/Size from the 
main menu. 
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Line Flow Pie Charts on Onelines 

The line flow pie charts are used to indicate the percentage MVA, MW, or Mvar loading of a transmission line or a 
transformer.  The degree to which the pie chart is filled shows how close the device is to its limit (provided the device 
has a nonzero limit).  A line flow pie chart becomes completely filled when the device's flow meets or exceeds 100% of 
its rating.   

Use the Pie Chart Options  tab of the Oneline Display Options Dialog to customize various attributes of all pie charts.  
The tab allows you to define a warning level at which the size and color of the pie charts will change to a size and 
color you specify.  The tab also allows you define a limit percent as well as the size and color to which to change the 
pie charts when their corresponding devices violate their limits.  You can also specify whether the pie charts should 
reveal total power flow (MVA), real power flow (MW), or reactive power flow (MVR).  The oneline display options dialog 
can be invoked either by selecting Options/Tools > Oneline Display from the main menu or by right-clicking on the 
background of the oneline diagram and selecting Oneline Display Options from the resulting local menu. 

Right clicking on the pie chart displays the Line Flow Pie Chart Options Dialog.  This dialog allows you to view the from 
and to bus  numbers and the circuit number of the line/transformer associated with the pie chart.  You can change the 
pie chart's size and the MVA rating of the line/transformer associated with the pie chart.   

 

Edit Mode  

To enter a new line flow pie chart, select Insert > Line Flow Pie Chart from the main menu or click the Line Flow 
Pie Chart button on the Insert Toolbar and click on the line or transformer to which you want to add the pie chart.  
This opens the Line Flow Pie Chart Options Dialog box.  Enter the near and far bus number associated with the 
device (these fields default to the terminal bus numbers of the device on which you clicked), the circuit number of 
the device, and the desired size of the pie chart.  The field will display the flow value at the near end of the device.  
Enter the size of the device.  Select OK to insert the line flow pie chart.  Otherwise, select Cancel.   

To modify the parameters of an existing line flow pie chart, position the cursor anywhere on the object and right-
click.  This again brings up the Line Flow Pie Chart Options Dialog box.  
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DC Transmission Line Display Objects  

DC transmission lines are represented on the onelines using multiple segment lines drawn between two buses.  The 
line thickness and color of dc transmission lines can be customized using Format > Display Appearance  from the 
main menu. Line fields are often placed close to dc transmission lines on the oneline to indicate the power flow 
through the device.   

Note that, unlike ac transmission lines, dc transmission lines cannot be equipped with circuit breakers. 

 

Run Mode 

Simulator's animation feature can be used to indicate the magnitude of the flow on the dc transmission line, either in 
MW or in terms of the line's percentage loading. You can customize the line flow animation using the Animated 
Flows Options  on the Oneline Display Options Dialog. 

Right-clicking on a dc transmission line displays the line's local menu, from which you can choose to inspect the DC 
Transmission Line Dialog. 

 

Edit Mode  

To add a new dc transmission line to the case, first select Insert > DC Transmission Line  from the main menu, or 
click the DC Transmission Line  from the Insert Toolbar.  Then place the cursor on the bus you desire to be the 
rectifier bus for the line and click the left mouse button.  Add more segments to the line by moving the cursor and 
clicking with the left mouse button.  To complete the new line, place the cursor on the second bus for the line, which 
will serve as the inverter bus, and double-click the left mouse button.  This calls up the DC Transmission Line 
Dialog.  If you successfully selected the rectifier and inverter buses, their numbers will be automatically filled in for 
you when the dialog opens.  

The DC Transmission Line Record Dialog has four separate pages: Line Parameters, Rectifier Parameters, Inverter 
Parameters, and Actual Flows.  The separate pages can be accessed using the tabs shown at the top of the dialog.  
These pages are used to set the modeling parameters associated with the dc lines.  

To modify the parameters for an existing dc transmission line, position the cursor anywhere on the line and right-
click.  This will provide access to the corresponding DC Transmission Line Dialog, from which you can modify any of 
the dc line's parameters.  Select Format > Display Appearance from the main menu to change the color and/or 
line thickness of the dc line.  

To change the shape of the line, first left-click on the line to select it.  This causes handles to appear at each vertex.  
You can then move any vertex by clicking and holding the left mouse button down, dragging the vertex to a new 
location, and releasing the mouse button.  To remove a vertex, hold down the CTRL key and then click the vertex 
you would like to delete.  To add a vertex, hold down the CTRL key and then click on the line where you would like 
to add a vertex.   
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Multi-section Line Display Objects  

Multi-section lines are represented on the onelines using a line segment with intermediate or "dummy" bus 
representations.  These objects are not the same as a normal transmission line.  They do display animated flows in 
run mode, but do not have pie charts, circuit breakers, or text fields currently associated with the objects. 

 

Run Mode  

Simulator's animation feature can be used to indicate the magnitude of the flow on the transmission line, either in 
MW or in terms of the line's percentage loading. You can customize the line flow animation using the Animated 
Flows Options  on the Oneline Display Options Dialog. 

Right-clicking on a multi-section line displays the Multi-section Line Information Dialog.   

 

Edit Mode  

Unlike transmission lines and transformers, multi-section lines CANNOT be inserted in a case by adding the mult-
section line graphically.  Therefore, when inserting a multi-section line object, the data for the object must already 
exist in the case.  To insert the multi-section line object, first select Insert > Transmission MS Line  command from 
the Insert menu.  Then place the cursor on the first bus for the transmission line (the "from" bus) and click the left 
mouse button.  Add more segments to the line by moving the cursor and clicking with the left mouse button.  To 
complete adding a new line, place the cursor on the second bus for the line (the "to" bus) and double-click with the 
left mouse button.  Completing the multi-section line opens the Multi-section Line Information dialog.  At the bottom 
of this dialog are display options for the line, such as line pixel thickness, symbol size (for the series capacitor 
representations, if any,) anchored, and options for drawing the buses. 

To change the shape of the line, first left-click on the line to select it.  This causes handles to appear at each vertex.  
You can then move any vertex clicking and holding the left mouse button down on the vertex, dragging it to a new 
location, and then releasing the mouse button.  To remove a vertex, hold down the CTRL key and then click the 
vertex you would like to delete.  To add a vertex, hold down the CTRL key and then click on the line where you 
would like to add a vertex. 

Transformers 

Transformer Display Objects  

Transformers are represented as transmission lines with two opposing coils drawn on one of the segments.  The 
transformer's line thickness, color, and symbol segment can be customized using the Edit Mode.  Optionally, circuit 
breakers and pie charts can be placed on the transformer.  Clicking on the circuit breakers changes the status of the 
transformer.   

Line fields are often placed close to transformers on the oneline to indicate the power flow through the device.  
Transformer fields are often placed close to transformers on the oneline to indicate and control their tap positions.  
See Transformer Modeling for details on modeling either LTC or phase shifting transformers. 

 

Run Mode  

Simulator's animation feature can be used to indicate the magnitude of the flow through the transmission line, either 
in MW or in terms of the transformer's percentage loading. You can customize the line flow animation using the 
Animated Flows Options on the Oneline Display Options Dialog. 

Right-clicking on a transformer displays the line's local menu, from which you can choose to inspect the 
Line/Transformer Dialog.   

 

Edit Mode  

New transformers are inserted in much the same way as transmission lines.  To add a new transformer to the case, 
first select Insert > Transformer from the main menu, or click the Transformer button on the Insert Toolbar.  Then 
place the cursor on the first bus for the transformer (the from bus ) and click the left mouse button.  Add more 
segments to the transformer by moving the cursor and clicking with the left mouse button.  To complete the new 
transformer, place the cursor on the transformer's other terminal (the to bus) and double-click with the left mouse 
button.  This calls up the Line/Transformer Dialog.  The from and to bus numbers for the transformer should have 
been set automatically.  If there is just one transformer between the buses, the circuit number should be "1."  For 
multiple transformers between buses, you must give each a unique circuit number. Enter the thickness of the lines 
[in pixels] used to display the transformer, the number of the line segment in which you would like the transformer 
symbol drawn, and the size of the transformer symbol.   

Enter the per unit (100 MVA base) resistance, reactance and charging susceptance for the transformer, and an 
MVA rating.  Enter the off-nominal tap ratio and the phase shift angle in degrees. (For a transformer without tap or 
phase control, the off-nominal tap should be 1.0 and the phase shift angle should be 0 degrees.) 

Select the appropriate Automatic Control Option.  If the transformer does not have tap control, select No Automatic 
Control  (this is the default).  Select AVR (Automatic Voltage Regulation) if the transformer changes its tap ratio to 
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control the voltage at user specified regulation bus.  Select Reactive Power Control if the transformer changes its 
tap ratio to control the reactive power through the transformer.  Finally, select Phase Shift Control if the transformer 
changes its phase shift to control the MW flow through the transformer.  If you need any of the last three options , 
select the Automatic Control Options button to set the parameters associated with the automatic control. 

For AVR control, enter the number of the bus whose voltage is to be controlled, the allowable range for the 
controlled voltage (in per unit), the minimum and maximum tap ratios (typical values are 0.9 and 1.1), and the step 
size for the discrete changes in the tap ratio (typical value is 0.00625). 

For reactive power control, the control variable is always the reactive power measured at the from bus  (i.e., the 
tapped side) of the transformer.  Positive flow is assumed to be going through the transformer to the to bus .  Enter 
the minimum and maximum allowable flows, the minimum and maximum tap ratios (typical values are 0.9 and 1.1), 
and the step size for the discrete changes in the tap ratio (typical value is 0.00625). 

For phase shift control, the MW flow through the transformer is the controlled value.  Enter the bus number of the 
terminal whose flow is controlled, the allowable range for the controlled flow (positive flow is assumed to be into the 
transformer at the terminal entered in the previous field), the minimum and maximum phase angles (typical values 
are -30° and 30°), and the step size in degrees (typical values are between 1° and 2°).    

Select OK to save the values and return to the Transformer Options Dialog; otherw ise select Cancel.   

If you would like the transformer to be initially modeled as being on automatic control at the start of the case, select 
the Automatic Control Active checkbox. 

If you do not want to add the transformer to the case, select Cancel.   

To modify the parameters for an existing transformer, position the cursor anywhere on the device and right-click.  
This brings up the local menu from which you can choose to view the Line/Transformer Dialog.  Use the 
Line/Transformer Dialog to adjust many of the transformer's electrical properties.  Select Format > Display 
Appearance to change the transformer's color and/or line thickness.   

See Transformer Modeling for details on modeling either LTC or phase shifting transformers. 
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Transformer Fields on Onelines 

Transformer fields are used to show field values specific to transformers, such as tap position.   

 

Run Mode  

If there is a spin control integrated with the field, you can click on the spinner to change the field's value by the 
associated Delta Per Mouse Click. 

Right clicking on the transformer field gives the option to display the Transformer Field Dialog or the 
Line/Transformer Information Dialog. 

Edit Mode  

To enter a new transformer field, select Insert > Fields > Transformer Field from the main menu or the 
Transformer Field button on the Insert Toolbar, and then click on the transformer object to which you want to add 
the new field.  This calls up the Transformer Field Dialog.  Enter the from and to bus numbers associated with the 
device (the default values for these fields correspond to the transformer on which you clicked), and the circuit 
number of the device.  Enter the total number of digits that the field should display, as well as the number of digits to 
the right of the decimal point.  Finally, specify what the field should display: the off-nominal tap ratio, the off-nominal 
tap position, or the phase shift angle in degrees.  

To modify the parameters of an existing transformer field, position the cursor anywhere on the object and right-click 
to bring up the Transformer Field Dialog.  Use the Format > Display Appearance main menu option to change 
various display attributes for the transformer field, including its font and background color.  Finally, you can use the 
Format > Oneline Display > Default Font option to change the font for all fields on the display. 

Series Capacitors 

Series Capacitor Display Objects  

Series capacitors are represented as transmission lines with two opposing parallel bars drawn on one of the 
segments.  The series capacitor’s line thickness, color and symbol segment can be customized using the Edit Mode.  
If the series capacitor branch is operating, but the series capacitor status is set to Bypassed, a low impedance 
segment will be drawn around the series capacitor symbol to indicate the capacitor has been bypassed.  The capacitor 
status of Bypassed or In Service  can be toggled in run mode if the Series Capacitor Status field is displayed on the 
oneline diagram.  When a left-click is registered on the Series Capacitor Status field when in Run Mode, the capacitor 
status is toggled.  Note that this is not the same as the overall branch status of Open or Closed.   

Optionally, circuit breakers and pie charts can be placed on the series capacitor.  Clicking the circuit breakers changes 
the branch status of the series capacitor. 

 

Run Mode  

Simulator's animation feature can be used to indicate the magnitude of the flow through the series capacitor, either 
in MW or in terms of the transformer's percentage loading. You can customize the line flow animation using the 
Animated Flows Options on the Oneline Display Options Dialog. 

Right-clicking on a transformer displays the line's local menu, from which you can choose to inspect the 
Line/Transformer Dialog.  

 

Edit Mode  

New series capacitors are inserted in much the same way as transmission lines.  To add a new series capacitor to 
the case, first select Insert > Series Capacitor from the main menu, or click the Series Capacitor button on the 
Insert Toolbar.  Then place the cursor on the first bus for the series capacitor (the from bus) and click the left mouse 
button.  Add more s egments to the series capacitor by moving the cursor and clicking with the left mouse button.  
To complete the new series capacitor, place the cursor on the series capacitor's other terminal (the to bus) and 
double-click with the left mouse button.  This c alls up the Line/Transformer Dialog.  The from and to bus numbers 
for the series capacitor should have been set automatically.  If there is just one branch between the buses, the 
circuit number should be "1."  For multiple branches between buses, you must give each a unique circuit number. 
Enter the thickness of the lines [in pixels] used to display the series capacitor, the number of the line segment in 
which you would like the series capacitor symbol drawn, and the size of the series capacitor symbol.   

Enter the per unit (100 MVA base) resistance, reactance and charging susceptance for the series capacitor, and an 
MVA rating.  On the Series Capacitor tab, check the box labeled Is Series Capacitor to indicate that the branch 
model is a series capacitor device. 

If you do not want to add the series capacitor to the case, select Cancel.  Otherwise click OK to add the series 
capacitor to the case.   

To modify the parameters for an existing series capacitor, position the cursor anywhere on the device and right-
click.  This brings up the local menu from which you can choose to view the Line/Transformer Dialog.  Use the 
Line/Transformer Dialog to adjust many of the series capacitor's electrical properties.  Select Format > 
Display/Size to change the series capacitor's color and/or line thickness.   
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See Series Capacitor Information for more details on modeling series capacitors. 
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Series Capacitor Fields on Onelines 

Series capacitor fields are used to show field values specific to series capacitors.   

 

Run Mode  

If the Series Capacitor field for capacitor status is displayed, the capacitor status can be toggled in run mode when 
you left-click on the field. 

Right clicking on the series capacitor field gives the option to display the Series Capacitor Field Dialog or the 
Line/Transformer Information dialog. 

 

Edit Mode  

To enter a new series capacitor field, select Insert > Fields > Series Capacitor Field from the main menu or the 
Series Capacitor Field button on the Insert Toolbar, and then click on or near the series capacitor object for which 
you want to add the new field.  This calls up the Series Capacitor Field Dialog.  Enter the from and to bus numbers 
associated with the device (the default values for these fields correspond to the series capacitor on which you 
clicked), and the circuit number of the device.  Enter the total number of digits that the field should display, as well 
as the number of digits to the right of the decimal point.  Finally, specify what the field should display: the capacitor 
status or the series capacitance.  

To modify the parameters of an existing series capacitor field, position the cursor anywhere on the object and right-
click to bring up the Series Capacitor Field Dialog.  Use the Format > Display/Size main menu option to change 
various display attributes for the series capacitor field, including its font and background color.  Finally, you can use 
the Format > Font option to change the font for selected fields on the display. 

Switched Shunts  

Switched Shunt Display Objects  

Switched shunts are either capacitors that supply reactive power to the system or reactors that absorb reactive power.  
Simulator represents switched shunts as a number of blocks of admittance that can be switched in a number of 
discrete steps or over a continuous range.  Switched shunt display objects come equipped with a circuit breaker that 
indicates the shunt's status.  If the switched shunt is closed, the circuit breaker appears as a filled red square.  If the 
switched shunt is open, the circuit breaker appears as a green square outline.  To change the status of the switched 
shunt, click the corresponding circuit breaker. 

Switched shunt fields are often placed next to switched shunts to indicate the amount of reactive power supplied by 
the device.  For switched shunts with such a field, you can manually increase the reactive power supplied by the 
device (provided its control mode is discrete) by clicking on the up-arrow associated with the device's reactive power 
field.  Likewise, you can decrease the reactive power supplied by the device by clicking on the down-arrow.  To make 
the up/down arrows visible, set the Delta per Mouse Click on the switched shunt field to a nonzero value. 

Right-clicking on the switched shunt displays the Switched Shunt Dialog.  Use the Switched Shunt Dialog to inspect or 
modify the model of the switched shunt. 

You can add a new switched shunt to the case in Edit Mode.  Select Insert > Switched Shunt from the main menu, or 
click the Switched Shunt button on the Insert Toolbar.  Then click the bus where you would like to attach the device.  
The Switched Shunt Dialog will appear.  The bus number is automatically determined from the bus to which you 
attached the capacitor.  Enter the size, the thickness of the pen [in pixels] used to draw the device, and its orientation.  
The Nominal Mvar field gives the amount of reactive power the device would supply if its terminal voltage were 1.0 per 
unit.  The Control Mode field determines whether the switched shunt has a fixed value or will vary discretely or 
continuously within its operating limits to maintain its terminal voltage within the voltage range specified in the Voltage 
Regulation field.  

The amount of shunt admittance is specified in the Switched Shunt Blocks table.  The columns in this field correspond 
to different blocks of admittance. The first row indicates the number of steps in each block, and the second row gives 
the amount of nominal Mvars per step.  The switched shunts are always switched in the order specified in this field.   

Select OK to add the device.  If you do not want to add the switched shunt to the case, select Cancel. 

To modify the parameters for an existing switched shunt, position the cursor on the device and right-click.  This again 
brings up the Switched Shunt Dialog. You can then change any parameter of the switched shunt.  Choose Format > 
Display Appearance from the main menu to change the color and/or line thickness.   

To delete an existing switched shunt, use the Edit > Cut or Edit > Delete menu items . 
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Switched Shunt Fields on Onelines 

Switched Shunt field objects are used primarily to indicate various quantities associated with switched shunt devices.  
Furthermore, some switched shunt field types, which are distinguished by an integrated spin button, may be used to 
change switched shunt device properties. 

 

Run Mode  

For switched shunt fields with an associated spin button, clicking on the up/down arrows will change the value of the 
associated field. 

Right clicking on a generator field gives you the option to open the Switched Shunt Field Dialog or the Switched 
Shunt Information Dialog.   

 

Edit Mode  

Simulator offers two options for adding switched shunt fields to a oneline in Edit Mode.  If you need to enter only a 
single field, the easier approach may be to choose Insert > Field > Switched Shunt Field from the main menu or 
the Switched Shunt Field button from the Insert Toolbar and then select the switched shunt to which you want to 
add the field.  This invokes the Switched Shunt Field Dialog.  Enter the bus number associated with the device (the 
default is the bus associated to the closest switched shunt to the field), the ID field, the total number of digits to 
show, and the number of digits to the right of the decimal point.  Next, select the type of field to show.  

The second approach for adding new switched shunt fields entails right-clicking the bus and selecting Add New 
Fields Around Switched Shunt from the resulting local menu.  Please see Inserting and Placing Multiple Display 
Fields  for more details. 

To modify the parameters of an existing switched shunt field, position the cursor anywhere on the object and right-
click.  This brings up the Switched Shunt Field Dialog.  Choose Font, Line/Fill, or Display/Size from the Format 
menu to change various display attributes of the field, including its font and background color. 

Interfaces 

Interface Display Objects  

Interface display objects are used on the onelines to visualize the flow of power through an interface record.  Interface 
records are used to show the net real power (MW) flow on a group consisting of one or more of the following devices: 
1) transmission lines and/or transformers, 2) total tie-lines between two adjacent areas, and 3) total tie-lines between 
two adjacent zones.   Only area-area and zone-zone interface records can be displayed using interface display 
objects. 

Interfaces, like transmission lines, are represented as multi-segment lines, except that they may be drawn between 
area/zone objects in addition to buses.  Drawing interface display objects involves the same steps as drawing 
transmission lines and transformers.   The line thickness and color of interface objects may be customized by selecting 
Format > Display/Size from the main menu.   

Interface Fields  and Interface Pie Charts  are often placed close to or on the interface to indicate the power flow 
through the device.    

 

Run Mode  

When animation is active, the flow of the arrows on the interface object may represent either the MW flow through 
the interface or the currently calculated power transfer distribution factor (PTDF) pertaining to that interface.  You 
can customize the appearance of the animated flows using the Animated Flows Tab of the Oneline Display Options 
Dialog available using the local menu.     

Right-click on the interface to view the Interface Dialog for the interface.    

 

Edit Mode  

The quickest method of inserting new interface objects is to use the Options > Auto Insert Interfaces.  Please see 
Automatically Inserting Interfaces for details.   

To manually add a new interface object to the case, first select Insert > Interface from the main menu, or click the 
Interface button on the Insert Toolbar.  Then place the cursor on the starting location for the interface (usually an 
area/zone object or a bus object) and left-click.  Add more segments to the interface by moving the cursor and the 
left-clicking at the end of the segment.  To finish adding an interface, place the cursor on the terminal object for the 
interface and double-click.  This then calls up the Interface Dialog.  Either select an existing interface, or define a 
new interface (see Interface Dialog for details).     

Interfaces can be anchored to either area/zone objects or bus objects.   

To change the shape of the interface, first left-click on the object to select it.  This causes handles to appear at each 
vertex.  You can then move any vertex by dragging it with the left mouse button down.  To remove a vertex, hold 
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down the CTRL key and then click the vertex you would like to delete.  To add a vertex, hold down the CTRL key 
and then click on the interface where you would like to add the vertex.   
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Inserting Interfaces Dialog 

The Inserting Interfaces Dialog is used to insert a group of interfaces.  Only interfaces between adjacent areas or 
adjacent zones can be inserted automatically; single-branch interfaces between buses must be inserted with line 
insertion options.  Adjacent areas or zones are those that share at least one tie line.  To reach this field, go to Case 
Information > Interfaces and then right-click on the display to bring up the submenu.  From the submenu choose 
Auto Insert Interfaces.  This dialog is NOT brought up through the menu item Insert > Auto Insert > Interfaces, 
which is for inserting interface objects on an oneline diagram. 

 

The Inserting Interfaces Dialog sports the following fields: 

Type of Interfaces to Insert 

Select the type of interfaces to insert.  Area-to-area interfaces join adjacent areas, while zone-to-zone interfaces 
join adjacent zones.  The name of the new interface defaults to "Area1- Area2" or "Zone1-Zone2" with an Optional 
Prefix. 

Optional Prefix 

This field allows you to specify an optional prefix of up to three characters.  Use this prefix to avoid duplicating 
names, particularly when some of the areas or zones have the same name. 

Delete Existing Interfaces 

If this option is checked, then all existing interfaces are deleted before inserting the new interfaces.  By default, this 
option is checked.  If this option is not checked, the existing interfaces are not deleted.  However, new interfaces will 
automatically overwrite any existing interfaces having the same name. 

Only Insert Between Areas/Zones with Area/Zone Filters Set 

If this option is checked, the set of potential areas or zones for inserting interfaces is limited to those for which the 
area/zone filter setting is Yes . 

Limits  

Simulator can either calculate an interface rating based on the ratings of the components included in the interface, 
or the user can specify a set of ratings to be used for the interface.  If neither of these options is used to set an 
interface limit, then by default, the interface limits are left as 0, indicating no limit has been applied. 

Insert Interfaces 

Click this button to insert the interface records into the case. 

Cancel 

Closes the dialog without modifying the list of interfaces. 
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Interface Fields on Onelines 

Interface field objects are used to show values associated with interface records. 

 

Run Mode  

Right clicking on the interface field displays the Interface Field Dialog. 

 

Edit Mode  

To enter a new interface field, select Insert > Field > Interface Field, and then click on the background of the 
oneline diagram where you want the field placed.  This calls up the Interface Field Dialog.  Enter the name of the 
interface, the total number of digits desired in the field, and the type of field.   

To modify the parameters of an existing interface field, position the cursor anywhere on the object and right-click.  
This again brings up the Interface Field Dialog.  Use the Format > Font command to change the font (including its 
color) used with the field.  Use the Format > Line/Fill command to change the background color used for the field. 
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InterArea Flow Options Dialog 

This dialog is outdated in PowerWorld Simulator version 5.0 and later.  See help on the Interface Field Information 
Dialog for the updated dialog. 

When viewing an area diagram containing inter-area objects created using PowerWorld Simulator version 4.2 or older, 
this dialog allows you to set text fields displaying either the actual or scheduled MW flow on the inter-area object. 
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Interface Pie Charts on Onelines 

Interface pie charts are used to graphically show the percentage loading on an interface record.  The amount of 
shaded region of the pie chart indicates how close the interface is to its limit (provided the interface has a nonzero 
limit).  The appearance of the interface pie charts, including their color and the ability to automatically change size 
based upon loading level, can be customized on the Oneline Display Options Dialog.   

Right-clicking on the interface pie chart displays the Interface Pie Chart Dialog.  This dialog can be used to customize 
the size of the pie chart, or change the interface's limit.   

 

Edit Mode  

To enter a new interface pie chart, select Insert > Interface Pie Chart from the main menu or click the Interface 
Flow Pie Chart button on the Insert Toolbar.  Then, click the left mouse on the interface object with which you want 
to associate the pie chart. This calls up the Interface Pie Chart Dialog, which is used to customize the appearance 
of the pie chart.   
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Loading NERC Flowgates 

This command reads flowgates from a text file and inserts them as interface records.  The format for this file should be 
similar to the file found at http://www.nerc.com/~oc/dfwg.html.  To access this file you must have a NERC-supplied 
username and password.  At the time of writing we have not seen an official description of the format -- currently 
Simulator just mimics the format found in this file.  Flowgates are used by NERC (under Policy 9) as proxies for 
transmission limitations and transmission service usage on the interconnected electric power network.  Simulator 
models flowgates using the interface records.  Interface records MAY include contingency elements.  Flowgate 
contingency elements are only used during the PTDF caculations. 

The Load NERC Flowgates option is available from the local menu of the Interface Records display.   
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Saving NERC Flowgates 

This command writes all the interfaces to a text file using the NERC flowgate format.  See the file found at 
http://www.nerc.com/~oc/dfwg.html for an example of the NERC format.  To access this file you must have a NERC-
supplied username and password. 

The Save NERC Flowgates option is available from the Save As option of the local menu of the Interface Records 
display.   

Oneline Links 

Links to Other Onelines 

Run Mode  

Oneline links are one of the mechanisms used in Simulator to allow you to view multiple oneline diagrams on the 
same screen.  By default, the oneline links are shown as blue rectangles surrounding a text identifier of the linked 
oneline diagram.  Double-clicking the left mouse button anywhere within the oneline link object will display the 
linked oneline diagram, even if it has not already been opened. 

The ability to associate multiple oneline diagrams with a single case may prove particularly helpful when dealing 
with large cases.  If a single oneline diagram is used to display a case having many buses, the diagram may 
become cluttered, and it will be difficult to analyze the case in sufficient detail.  The ability to associate additional 
onelines with the case and to call up those additional onelines using one-links can significantly enhance your view 
of the system. 

Note that you can also use the File > Open Oneline command from the main menu to open any oneline diagram 
(*.pwd) file directly.  See Opening a Oneline Diagram for further details. 

Edit Mode  

To add a new oneline link to a oneline diagram, first select Insert > Oneline Link  from the main menu, or select the 
Link  button on the Insert Toolbar.  Then, click the left mouse button at the location where you would like to display 
the new link.  The Oneline Link Options Dialog box will open, asking you to enter the name of the file that stores the 
linked oneline and a caption for the clickable oneline link object.  Note that you can enter simply the name of the 
oneline file in this location.  Simulator will look in the same directory as the case file by default.  However, you can 
also specify additional directory locations to search for oneline diagrams by opening the Solution/Environment 
Options, switching to the Oneline tab, and using the Edit Oneline Browsing Path option to add additional search 
locations for oneline diagrams  

To modify the parameters of an existing oneline link, position the cursor anywhere on the object and right-click.  
This invokes the Oneline Link Options Dial og, allowing you to change the identity of the linked file and the caption. 
Select Format > Display/Size from the main menu to modify various display attributes of the oneline link, including 
font size and background color.   
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Document Links on Onelines 

Just as you can link to other oneline displays from a oneline diagram using oneline link objects, you can also link to 
documents and data on the world-wide web using Document Link Objects.  When you click on Document Link Objects 
in Run Mode, your system's default browser will be launched to retrieve the linked URL address.  This feature is not 
only for web URL's, though.  Any file can be linked and its associated application will automatically open.  This means 
that power point files, word documents or spreadsheets can also be linked. 

To add a Document link to a oneline diagram, select Insert > Document Link from the main menu.  Then, click the 
left mouse on the oneline diagram at the position where you would link to insert the Document link.  The Document 
Link Options Dialog box will appear, asking you to specify the world-wide web address to which to link as well as a 
clickable caption to display on the oneline diagram. Enter the requested information and press OK to add the 
Document link object to the oneline.  

To modify the caption or address for a Document link object, right-click anywhere on its text.  Specify its new 
parameters in the Document Link Options Dialog and press OK.  You may also modify various aspects of its 
appearance, including the font size, by choosing Format > Display/Size from the main menu. 

Note that Document links are active only in Run Mode.  Clicking on a Document link object from the Edit Mode will 
have no effect other than to select the object for placement, formatting, etc. 

Background Objects and Text 

Background Lines on Onelines 

The background of a oneline diagram can display added lines, polylines, and filled polygons among other items. 

 

Edit Mode  

To add a new background line, first select Insert > Background Graphic > Background Line   from the main menu 
or click the Background Line  button on the Insert Toolbar. To draw a series of straight line segments on the 
background, follow these steps: 

• • Position the mouse cursor where you want the series to begin and click and release the left mouse button.   

• • Move the mouse to the desired termination point of the first line segment.  A straight segment will follow your 
mouse movements.  Click and release the left mouse button to complete the line segment and prepare for 
drawing the next line segment, or double-click if this line segment is the last segment you wish to draw. 

To draw a freehand shape rather than a series of straight line segments, click and hold the left mouse button where 
you would like the freehand shape to begin and drag the mouse to trace the shape you desire (while holding the left 
mouse button down).  Release the left mouse button to complete the section of the freehand shape you have been 
drawing.  At this point, you can add either another freehand section or a straight line segment.  When you have 
finished drawing in the background, double click the mouse button. 

Note that background display objects composed of straight line segments display significantly faster than lines 
drawn freehand.   

Use the Format > Display/Size command to change the color, line thickness and fill color associated with the line.  
If the Use Background Fill option on the Line/Fill Tab  of the Edit Multiple Objects Dialog is checked, the line is 
assumed to be a polygon, with a line automatically drawn between the first point on the line and the last point.  The 
polygon is filled using the color specified in the Fill Color Field.   

To change the shape of the line, first left-click on the line to select it.  This causes handles to appear at each vertex.  
You can then move any vertex by holding the left mouse button down and dragging the vertex to a new location.  To 
remove a vertex, hold down the CTRL key and then click the vertex you would like to delete.  To add a vertex, hold 
down the CTRL key and then click on the line where you would like to add a vertex.  Note that freehand lines are 
nothing more than a continuous series of vertices. 
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Background Rectangles on Onelines 

The background of a oneline diagram can display rectangles among other items.  

 

Edit Mode  

To add a new rectangle, first select Insert > Background Graphic > Background Rectangle  from the main menu.  
Position the cursor where you would like to place the upper left-hand corner of the rectangle and click with the left 
mouse button.  A rectangle having the default size is inserted.  Drag the rectangle's resizing handles to 
resize/reshape the rectangle. 

To resize or reshape an existing rectangle, click on it to select it.  The resizing handles will appear, which you can 
then drag to reshape or resize the rectangle. 

To change the color, line thickness or fill color of the rectangle, first select it by clicking on it and then choose 
Format > Display/Size from the main menu.  
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Background Ellipses on Onelines 

The background of a oneline diagram can display ellipses among other items.  

 

Edit Mode  

To add a new ellipse, first select Insert > Background Graphic > Background Ellipse from the main menu, or 
click the Background Ellipse button on the Insert Toolbar.  Then position the cursor where you would like to place 
the upper left-hand corner of the ellipse and click with the left mouse button.  An ellipse having the default size and 
shape is inserted. Drag the ellipse's resizing handles to resize/reshape it. 

To resize or reshape an existing ellipse, click on it to select it.  The resizing handles will appear, which you can then 
drag to reshape or resize the ellipse. 

Select Format > Display/Size from the main menu to change the color, line thickness and fill color of the ellipse.  
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Background Pictures on Onelines 

The background of a oneline diagram can display a variety of objects, including lines, filled polygons, and even 
pictures.  The latter will be discussed in this section. 

 

Edit Mode  

Simulator can insert bitmaps, jpegs, enhanced and standard metafiles, and icons f rom files into the oneline 
diagram. These pictures may either serve as a background or appear above other objects on the oneline. 

To add a picture object to the oneline diagram, select Insert > Background Graphic > Picture from the main 
menu.  Then, click the oneline diagram at the point where you would like the top left corner of the graphic to be 
placed.  The Open Picture Dialog will open, asking you to select the graphic file that you want to insert.  When you 
select a file from the dialog, the dialog displays a preview image so that you can be sure that you are selecting the 
right file.  When you have identified the file to insert, click OK.  The image will then appear on the oneline.  It may be 
resized by dragging its resizing handles.   

By default, pictures are inserted at the middle stack level.  Thus, they hide most other oneline display objects.  To 
change the stack level of the picture, click it to select it, and then select Format > Display/Size from the main 
menu.  From the Line/Fill Tab , select the stack level of your choice.  The Base stack level places the picture below 
all other oneline display objects, while the Top stack level will cause the picture to obscure all other display objects. 

To resize or reshape an existing picture object, click on it to select it and then drag its resizing handles.  To change 
the stack level of an existing picture object, click on it to select it and then select Format > Display/Size from the 
main menu for access to the Line/Fill Tab , from which you can modify the picture's stack level. 
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Oneline Text Fields  

The Oneline Text Fields are fields that can be placed on a oneline diagram that display values specific to the current 
display of the diagram, such as x and y coordinate of the mouse cursor, animation rate, zoom percentage, and x and y 
coordinate of the center of the diagram at the center of the screen.  These fields can be inserted on a oneline diagram 
by choosing Insert > Field > Oneline Field. 

The fields mentioned above are currently the only available fields, but expect that more fields for displaying similar 
type diagram values and options will be added in the future. 
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Text on Onelines 

Text display objects are used to show single lines of text on the oneline. 

 

Edit Mode  

To add descriptive text to the oneline, select Insert > Text from the main menu and click the oneline where you 
would like the text to appear. The Text Options Dialog will open, asking you to enter the desired text string, and the 
angle at which the text is to appear on the oneline diagram. 

To modify an existing text object, position the cursor anywhere on the text and right-click.  The New Text Options 
Dialog will appear, allowing you to edit the text. Use the Format > Display/Size menu option to control the font and 
background color of the text object. 
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Generic Model Fields  

The Generic Model Fields are fields that can be placed on a oneline diagram that display any value for any object in 
the case on the diagram.  These fields can be inserted on a oneline diagram by choosing Insert > Field > Generic 
Model Field. 

This type of field comes in handy when you want to place a variety of fields on the diagram, without inserting specific 
object-type fields.  All fields of data are available in one location for placement on a diagram. 
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Edit Mode Tools and Options  

Chapter 5 : Edit Mode Tools and Options  

Edit Mode provides a number of commands for customizing and modifying the case that are different from Run Mode. 

This chapter covers the following: 

• Insertion Palettes 

• Appending Additional Power Flow Components to the Existing Case 

• Automatically Inserting Buses, Transmission Lines, Generators, Loads, Switched Shunts, Interf aces, Substations 
and Borders on the Oneline 

• Renumber the Buses in a Case and/or Oneline 

• Drawing Options 

• Equivalencing 

• Scaling the Case 

General Tools  

Appending a Case 

The Append Case command allows you to append additional power system components to an existing case.  Unlike 
the Open Case command, Append Case does not delete the existing case (if any) before loading the selected case.  
To append a case to the existing case, select Options/Tools > Append Case in Edit Mode.   

The Append Case command can be useful when used in conjunction with the Equivalencing Display.   

 

Notes 

Appended data completely overwrites an existing record corresponding to the same bus number. 

Branch elements are appended to a case only if both of their terminal buses exist. 



Printed Documentation 

124 

Refresh Anchors 

The Refresh Anchors option of the Edit Mode Options/Tools menu allows you to update or reset the anchoring of 
objects on a oneline diagram to their respective anchor.  When building oneline diagrams and adding several new 
devices, it can s ometimes be advantageous to use the Refresh Anchors option when finished to ensure the anchoring 
of objects to the appropriate anchor on the finished oneline diagram. 
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Bus Renumbering Dialog 

The Renumber Buses Display allows you to change the bus numbers for either the entire power system case, and/or 
for any open oneline diagrams.  To show this display, select Options/Tools > Renumber Buses. 

The bus renumbering feature is provided because it is sometimes necessary to renumber buses in the power system 
model, either to make room for new buses or to move buses to a different zone or area that has a different numbering 
scheme.  It may also be necessary to renumber bus display objects on the oneline if you want to use the oneline with 
a case other than the one for which it was originally designed.  The bus-renumbering feature provides a convenient 
way of accomplishing this. 

The table at the bottom of the Bus Renumbering Dialog is used to manage the lists of current bus numbers and any 
desired changes to the numbering scheme.  You can specify the bus numbers to change and their new values by 
directly typing them into the table.  Alternatively, you can generate the bus list automatically by selecting one of the 
Automatic Setup of Bus List Options and clicking the Setup Bus Swap List button.  The Automatic Setup options 
allow you to add to the list all buses in the case, all buses in the case subject to the area/zone/owner filter constraints, 
all buses currently displayed on the oneline, or a set of numbers from a text file.   

The table behaves just like a Case Information Display and thus has a local menu that can be invoked by clicking the 
right mouse button.  Select Insert from the local menu to insert a new bus number to change, or select Delete to 
delete a bus number that is currently in the list.  Select Show Dialog to display the Bus Information Dialog 
corresponding to the bus number on which you right-clicked.  You may clear the entire list by pressing the Clear Bus 
List button. 

Once you have indicated which buses you would like to renumber in the table, select an option from Bus Change 
Options to specify where you would like to implement the changes (in both the case and the oneline, in the case only, 
or in the oneline only).  Make the changes by pressing the Change Bus Numbers button.  Close the dialog by 
pressing Close. 

The option groups at the top of the dialog deserve further discussion. 
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Bus Renumbering: Automatic Setup of Bus List Options  

This section of the Bus Renumbering Dialog is used to generate automatically a list of the buses to be renumbered.  
Select an option from the list and click on the Setup Bus Swap List button to generate the list, or Clear Bus Swap 
List to clear the list.   

 

Load All Buses in Cases 

Creates entries in the table for every bus in the system.  By default the new bus number is the same as the old bus 
number.  Of course you do not have to renumber every bus.  If you would like a bus to keep its same number, either 
add that bus to the table, or simply have an entry with the old and new bus numbers identical. 

Load Buses with Valid Area/Zone Filters 

Same as the Load All Buses In Case option except only those buses with valid area/zone/owner filters  are added.  
This allows y ou to easily modify the bus numbers in just an area or zone.   

Load Only Buses on Oneline  

Creates entries in the table only for those buses on the current oneline.  This option is most useful when you are 
just changing the buses on the onelines. 

Load Buses From Text File  

Creates entries in the table using an external text file.  The format of this file is as follows: 

1 11    Specifies converting from old bus number 1 to new bus number 11 

2 22    Specifies converting from old bus number 2 to new bus number 22   

etc. 

Freshen Current Oneline  

The Freshen Buses option is designed to help you quickly renumber an existing oneline to work with a new 
numbering scheme. You will find this method helpful if you have been using the oneline with a case and now must 
use it with a different case having a different set of bus numbers, but the same bus names. Freshen Buses will try to 
match the buses on the oneline with the buses in the new case by matching bus names and kv, rather than by 
number (which is how Simulator usually tries to link bus display objects with bus records in the case). The best way 
to learn how to use Freshen Buses is to consider the following example:  

 

To update an old oneline to work with a new bus numbering scheme:  

• Open the oneline and the old case w ith which it was used. 

• Choose Options/Renumber Buses from the edit-mode menu.  

• Select "Load Only Buses on Oneline" and press the "Set up Bus Swap List" button. 

• Change the "Swap?" field values all to Yes.  

• Right click on the table and choose Save List to File. Give the file a name. For this example, we'll name the file 
"oldscheme.txt." This file will contain the list of buses represented on the oneline, specifying each bus's 
number, name, kv, and area.  

• Close the old case.  

• Open the new case and the oneline you wish to renumber. If any other onelines open with the case, close 
them. You want only the oneline you wish to renumber to be shown.  

• Choose Options/Renumber Buses from the edit-mode menu.  

• Select "Freshen Current Oneline" and specify the file "oldscheme.txt" (for this example).  Click the "Set up 
Swap List" button. Simulator will match the old numbering scheme used in the oneline with elements in the new 
case by name and kv. If it finds more than one match, it will use the element's area name as a tie breaker. If it 
still can't reconcile the multiple matches, it will add both renumbering options to the table.  

• Go through the new list and make sure that you want to swap the buses that are listed. If you do, change the 
"Swap?" field value for each to Yes (you can do this quickly for all buses by right-clicking on the Swap? column 
and choosing "Toggle All Yes." Be sure to reconcile any duplicate bus renumbering suggestions. These are 
cases for which Simulator could not determine how to renumber the buses a bus on the diagram matches more 
than one bus in the case by name, kv, and area.  

• Click the Change Bus Numbers button at the bottom of the form.   

 

Once the oneline has been renumbered, save it with the case by selecting File / Save (or File / Save As if you wish 
to give it a different name) from the main menu.  
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Bus Renumbering: Bus Change Options  

This option is used to specify which buses to change.  

 

Change Both Case and Onelines (default) 

Renumbers the buses in both the case and any open oneline diagrams.  You will usually want to select this option. 

Change Only Case 

Only renumbers the buses in the case.  The oneline bus numbers are not changed.   

Change Only Onelines 

Only renumbers the buses on the onelines.  The case itself is not changed.  You would want to select this option if 
you have already changed the case, but now have several onelines based on that case that also need to be 
changed.  
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Merging Buses 

Two or more buses can be merged to a new bus in "Edit Mode" with the loads, generators, and shunts of the buses 
merged moved to the new bus. The transmission lines among the buses merged will be deleted while the transmission 
lines connecting the merged buses and buses which are not selected to merge will be moved to the new bus.  

To join two or more buses together, select at least two power system elements (at least one of them being a bus), then 
right click to invoke the one-line popup menu and select Merge selected buses . Specify the buses to merge further if 
needed by clicking Add and/or Delete  button. To add buses to merge, click Add and select all the needed buses in 
the Choose a Bus  dialog and click OK. To delete from already selected buses, select the buses to delete and click 
the Delete  button.  

Once you have the elements to merge selected, enter the number, name, nominal voltage, zone number, area number 
and substation number for the new bus. These properties can be set to be the same as one of buses to merge by 
selecting it in the Specify buses to merge  box and pressing the Set new bus properties same as selected bus . 

Buses can also be merged in the Bus Records case information display. To do so, select a cell and right click to popup 
the local menu. Select Merge selected buses which is the third item in the second group. The buses to merge and 
the properties of the new bus can be edited in the Bus Merging Dialog.  

When buses are merged from the one-line diagram, the selected buses will be joined in both the PWB case and the 
one-line. When buses are merged from the bus grid, the selected buses will be joined only in the PWB case but not in 
the one-line. This might result in bus objects not connected to bus records in the one-line.   
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Splitting Buses 

Simulator assists you in transforming one bus into two connected buses.  This process is called splitting a bus.  In 
performing the split, the user is able to decide which equipment to keep connected to the original bus and which 
equipment to move to the new bus.  Because this activity impacts the structure of the power flow equations, bus 
splitting can be performed only in Edit Mode. 

To split a bus from the oneline diagram, right click on the bus y ou wish to split, and click Split from the resulting local 
menu.  To split a bus from the Bus Case Information Display, right-click on its corresponding record and again click 
Split from the resulting local menu.  In either case, the Bus Split Dialog will appear. 

Multi-section lines merit special consideration during bus split operations.  These are the rules Simulator follows when 
you try to split a bus that is part of a multi-section line.  If the original bus is the endpoint bus of a multi-section line and 
the ending line segment was transferred to the new bus, then the new bus becomes the new ending terminal of the 
multi-section line.  If the original bus was a dummy bus of the multi-section line, and if exactly one of the branches 
connected to the original bus is rerouted to the new bus, then both the new bus and the original bus will be dummy 
buses in the reconstituted multi-section line.  If neither or both of the lines connected to the original dummy bus were 
rerouted to the new bus, then the multi-section line definition is eliminated, since Simulator has no way to determine 
how the multi-section line should be redefined. 

A final consideration involving bus splits is how sequence data is treated.  If you have defined sequence data for fault 
analysis, Simulator will recalculate the sequence data for the original and new buses after the split.  In this case, the 
zero sequence impedance for the new branch that connects the original and the new bus will be set to j0.0001. 
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Split Bus  Dialog 

The Split Bus dialog contains two sections labeled Existing Bus  and New Bus .  These sections enable you to 
designate the bus you want to split and the name and number of the new bus created by the bus split operation.  If you 
opened the Split Bus Dialog from either the Bus Case Information Display or a oneline diagram, the Existing Bus 
Name and Number fields will be read-only and will identify the bus you selected.  However, if you opened the Split Bus 
Dialog from Simulator’s main menu, you will first have to choose a bus to split.  In this case, use the Find… speed 
button located next to the Existing Bus  label to select the bus to split, or simply type its number in the Existing Bus 
Number field.  Then, provide the name and number for the new bus to create using the New Bus Name and Name 
fields.  The number you specify in the New Bus Number field must be unique; it cannot be a number that identifies 
another number in the case.  If you do specify an existing number, Simulator will issue an error message and require 
you to specify a different number.  If you choose not to specify a name for the new bus, Simulator will set the name of 
the new bus to be the same as the bus’s number. 

Once you have identified the bus to split and the name and number for the new bus resulting from the split, you may 
then specify whether a bus tie should be inserted between the existing bus and the soon-to-be-created new bus.  By 
checking the Insert bus tie between existing and new buses checkbox, you command Simulator to place a very 
low -impedance bus tie between the bus to split and its offspring.  The new branch will have an impedance of 0.0000 + 
j0.0001 ohms.  If the bus tie should be inserted as an open branch, check the Normally open checkbox.  This option 
becomes available, of course, only if you elect to have Simulator automatically add the new bus tie. 

After you have finished making your selections, click OK.  Simulator will create the new bus, assign its electrical 
attributes to match those of the existing bus, and add the bus to the power system model.  If a oneline diagram is 
currently active and the existing bus is represented on it, Simulator will add a symbol for the new bus to the diagram, 
placing it immediately to the right of the existing bus’s symbol.  If you elected to create a bus tie between the existing 
and new buses, Simulator will also add a symbol for the bus tie to the diagram.   

Finally, Simulator will automatically open the Equipment Mover Dialog to help you manage the transfer of equipment 
from the existing bus to the new bus. 
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Equipment Mover 

Simulator provides a convenient tool for transferring equipment between buses.  Simulator allows you to move bus 
shunts, loads, generators, switched shunts, and transmission lines between buses.  For loads, generators, and both 
varieties of shunts, Simulator offers you the ability to transfer all or part of the equipment from the origin bus to the 
destination bus. 

Equipment may be transferred between buses using the Equipment Mover Dialog.  The Equipment Mover Dialog can 
be opened in any of four ways: 

 

• From the main menu, choose Options / Tools > Move Bus Equipment … 

• Right click on the bus from which you want to move equipment and select Move Equipment… from the resulting 
local menu. 

• From a Bus Case Information Display, right-click on the record corresponding to the bus from which you want to 
move equipment and select Move Equipment … from the resulting local menu. 

• As the final step of the Bus Split operation. 

 

Regardless of the approach you take, Simulator will then open the Equipment Mover Dialog.  The Equipment Mover 
Dialog consists of three sections.  The top portion of the dialog is split in two sections that identify the bus from which 
equipment will be transferred (on the left) and the bus equipment will be transferred to (on the right).  If the dialog was 
opened as the final operation of the Bus Split operation, these two buses will be hard-coded to identify the original bus 
and the bus resulting from the split.  If the dialog was opened from the main menu, you must select both the origin and 
destination buses from lists that are reminiscent of case information displays.  If the dialog was opened using one of 
the other two methods, the origin bus w ill be set to the bus you selected, and you will then have to choose the 
destination bus.  To select a bus to be an origin or destination bus, simply select the corresponding record from the 
appropriate list. 

Once the origin and destination buses have been identified, you must then select the equipment to transfer from the 
origin to the destination bus using the case information display that occupies the bottom of the dialog.  To move a 
particular piece of equipment, toggle the value of the Move Object? field to YES.  To move just portions of loads, 
generators, or shunts from the origin to the destination bus, adjust the value of the Move % field from 100.0 to the 
percentage you desire.   

Once you have selected the equipment you wish to transfer, click the Move equipment button.  Simulator will adjust 
the power system model to reflect your equipment transfer requests.  Furthermore, Simulator will provide you an 
opportunity to manually adjust all open oneline diagrams to reflect the equipment transfers.  To facilitate this activity, 
Simulator will open a Potential Misplacements Dialog for each oneline that displays the origin bus.  The Potential 
Misplacements Dialog lists the display objects associated with the equipment that had just been transferred from the 
origin to the destination bus.  By clicking on an entry in this list, you can pan the associated oneline diagram to focus 
on that object.  This allows you to identify display objects that perhaps should be relocated to reflect their new bus 
associations.  Once you have finished addressing these potentially misplaced display objects, click the OK button to 
close the Potential Misplacements Dialog. 

If you find that you would like to reopen the Potential Misplacements Dialog after you have closed it, click the List 
most recent transfers button.  This will reopen the Potential Misplacements Dialog associated with the most recent 
equipment transfer operation. 

To conclude the equipment transfer operation, click the Close button. 
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Potential Misplacements Dialog 

In the wake of an equipment transfer operation using the Equipment Mover Dialog, some oneline display objects may 
be out of place.  To ease the task of correcting these misplacements, Simulator provides the Potential Misplacements 
Dialog.  Simulator opens a Potential Misplacements Dialog for each oneline that displays the bus that served as the 
origin for equipment transfer.  The Potential Misplacements Dialog lists the display objects associated with the 
equipment that had just been transferred from the origin to the destination bus.  By clicking on an entry in this list, you 
can pan the associated oneline diagram to focus on that object.  This allows you to identify display objects that 
perhaps should be relocated to reflect their new bus associations.  Once you have finished addressing these 
potentially misplaced display objects, click the OK button to close the Potential Misplacements Dialog. 
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Tapping Transmission Lines 

Simulator eases the process of inserting a bus at some location along an existing transmission line. This feature can 
be extremely useful when you want to add a new generation site to a model, for example.  Rather than having to 
delete an existing line, place the bus, and draw two new transmission lines, Simulator simplifies the task to a one-step 
process. 

A line can be tapped from a oneline diagram, the transmission line case information display, or by choosing Tap 
Transmission Line  from the Options/Tools  menu.  From the oneline diagram, right-click on a transmission line and 
select Insert Line Tap from the popup menu.  From the case information display, simply right-click on the 
corresponding branch record and select Tap Transmission Line  from the popup menu.  Either of these methods will 
open the Automatic Line Tap dialog for setting up and inserting the new bus. 

Note that transmission lines may be split only from Edit Mode.  You cannot access this functionality from Run Mode. 
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Automatic Line Tap Dialog 

The Automatic Line Tap Dialog will allow you to define the settings to use for inserting a new bus along a transmission 
line.  The transmission line to tap will be represented in the panel at the top of the dialog, displayed as a Near Bus and 
Far Bus.  If the Automatic Line Tap Dialog was opened by right-clicking a line on a oneline diagram, or by right-clicking 
on a record in the case information display, the line will already be selected in the panel.  You can change the line 
selection by first choosing the Near Bus you desire, and then selecting the Far Bus from the list of possible 
connections to the chosen Near Bus.  Note that the percentage entered in the Position along line  field will be in 
relation to the selected Near Bus.  The inserted bus and new sections of the tapped line will adhere to the following 
settings: 

 

Position along line  

The field labeled Position along line  will indicate the point where you right-clicked the mouse relative to the 
location of the nearest of the two buses to the mouse-click in terms of a percentage of the total line length.  In other 
words, if the line is 10 units long, and you clicked the right mouse at location 7 units from one end of the line, the 
Position along line  will indicate 30% from the bus at the other end of the line, identified on the display as the Near 
Bus.  If you opened the Automatic Line Tap Dialog from the case information display or the Options/Tools  menu, 
the Position along Line will be set to 50%.  In either case, you can adjust this setting to place the new bus more 
precisely.  The placement of the new bus controls how the impedances of the new lines are set, as the impedance 
of each section will equal the section’s corresponding percentage length multiplied by the impedance of the original 
line.  Note that the original charging capacitance of the line will be reassigned as determined by the selection under 
the Shunt Model option. 

New Bus Number 

By default, Simulator will find and set an unused bus number for you, but you can specify the number to be used for 
the new bus, between 1 and 99999.  If you enter a bus number that already exists, you will be prompted to enter a 
different number when you click the Tap button. 

New Bus Name 

Specify a name to be assigned to the new bus.  By default this field is blank, and if left blank Simulator will set the 
name of the bus the same as the new bus number. 

New Bus Area 

You can specify the area for the new bus to be the same as the Near Bus , the Far Bus , or another value of your 
specification.  If you select the Specify option, the edit box and find button will become enabled.  You can then 
enter an area number manually, or click Find to locate an area from the list of areas currently in the case.  If you 
want a new area to be assigned to the case for this bus, simply enter an unused area number manually in the box, 
and Simulator will automatically set up the new area record for the case.  You can then open the Area Information 
Display and set the name and other values for the new area. 

New Bus Zone  

You can specify the zone for the new bus to be the same as the Near Bus, the Far Bus , or another zone of your 
specification.  If you select the Specify option, the edit box and find button will become enabled.  You can then 
enter a zone number manually, or click Find to locate a zone from the list of zones currently in the case.  If you 
want a new zone to be assigned to the case for this bus, simply enter an unused zone number manually in the box, 
and Simulator will automatically set up the new zone record for the case.  You can then open the Zone Information 
Display and set the name and other values for the new Zone. 

Shunt Model 

By default, Simulator will reassign the original charging capacitance as line shunts at the original terminal bus ends 
of the two new line segments.  The charging capacitance of the two new branch elements will be set to 0.  This will 
result in an exact match of power flows before and after the line tap. 

Alternatively, you can choose to have the capacitance converted approximately using percentage entered as the 
Position along line.  In other words, the original capacitance will be scaled and assigned to the two new segments 
as charging capacitance.  This will result in a slightly different power flow result after the line tap, as it is an 
approximation of charging capacitance on the two new segments. 

Treat sections as a multi-section line  

Check the box labeled Treat sections as a multi-section line  to force the status of the two new line sections to be 
controlled in unison. 

Click the Tap button to close the Automatic Line Tap Dialog and perform the line tap BuilderBusDialog.  If a value on 
the dialog is not set properly, a warning message will appear, and you will need to either change the specified value or 
cancel the process. 
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Setting Default Drawing Options  

The Default Drawing Options Dialog is used to define the default sizes of new display objects, as well as various other 
display parameters. These options are available only from Edit Mode.  To open the Default Drawing Values Dialog, 
select the menu option Options/Tools > Default Drawing Values in Edit Mode. 

The Default Drawing Values Dialog is organized using tabs showing the types of objects that can be added to 
onelines.  Each type of object has a table which describes the defaults available for that object. 

 

Variable Defaults depending on Voltage Level 

Many kinds of objects can have more than one set of defaults specified depending on their voltage level.  When 
more than one set of defaults is specified, the table is always sorted by Nom KV. 

A new object is inserted with properties corresponding to the default with the lowest Nom KV that the object's 
nominal KV is larger than.  If the object's nominal KV is smaller than all defaults, then it will be set according to the 
default with the lowest nominal KV. 

For instance, assume 4 sets of  defaults are defined for buses roughly as follows 

Nom KV Size 

>400  15 

>300  10 

>200  8 

>100  5 

A new bus with nominal voltage of 345 kV is inserted with size 10.   

A new bus with nominal voltage of 299 kV is inserted with size 8. 

A new bus with nominal voltage of 69 kV is inserted with size 5. 

In order to add another set of defaults for a kind of object, right-click on the table and choose Insert from the local 
menu.  In order to delete a set of defaults, right-click on the table and choose Delete. Once y ou have inserted a 
new default, specify the new Nom KV for the default along with the new defaults.  

Notes: When you change the Nom KV of a default, the list always sorts itself according to Nom KV.  Insert will not 
be enabled in the local menu for objects that can not have more than one set of defaults. Delete  will not be enabled 
if only one set of defaults is defined. 

Modifying Values in the Default Drawing Values Dialog 

The font colors in tables of this dialog follow the conventions of the Case Information Displays.  Most default values 
are enterable and can be modified by selecting the value you want to change and then typing in the new value.  
Other values are toggleable and can be changed by double-clicking on the value.  For reference regarding what the 
various "size" defaults mean, when the zoom level is at its nominal value (100%), the size of the screen is 100 by 
100.  There are also some special kinds of fields in this dialog which are discussed next. 

Editing Colors and KV-Based Color Coding 

In order to modify a color value, double-click on the colored rectangle to bring up the Color Dialog.  Then specify the 
color you want.  For some defaults, such as fill color, it is possible to specify the default color to be "none".  In order 
to set a color def ault to "none", select the colored rectangle and press the Delete key.   

At times, a user may want to see the kV level of screen objects directly from the oneline diagam, without having to 
open a text display.  One way to do this is to color code the elements on the oneline diagram according to kV level.  
Right-click on the table and choose Insert from the local menu.  Specify the Nom kV and color. 

Editing Default Field Positions ("Pos1", "Pos2", etc…) 

Many objects allow you to specify some default fields to be automatically added when a new object is drawn.  For 
example, you may want to insert the bus name next to all new Bus Objects.  In order to specify these defaults, click 
on the table row corresponding to defaults you are interested in.  Then click on the Show Field Positions  button.  
This brings up the Positions for Adding New Fields Dialog and will show you the present settings for new fields.  
Positions that have a default specified will be highlights and the name of the default field will be shown.  Positions 
with no default field will not be highlighted and will say "Pos1", "Pos2", etc….  For objects that have more than one 
possible orientation (e.g. generators can be up, right, left or down), the Adding New Fields Dialog will show 
positions for each orientation. 

In order to modify the settings, move your mouse over the position on the dialog you want to change and click.  This 
will bring up the appropriate Field Options Dialog such as the Bus Field Options, Generator Field Options, Load 
Field Options, Switched Shunt Field Options,or the Line Field Options.  Simply select the field you want and choose 
OK.  If you would like to set a default field to "none", click Remove Field instead of OK.  You can also modify 
default fields by double-clicking on the table for "Pos1", "Pos2", etc…  This brings up the appropriate Field Options 
Dialog as well.  If you press the Delete key while on a "Pos" field in the table, it will set the default field to "none".   

Note that as you navigate through the tabs on this Default Drawing Values Dialog, the Positions for Adding New 
Fields Dialog will update to show you the default for the present object and voltage level you have selected. 
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Editing Stub Size and Stub Space  

When utilizing the Automatically Insert Transmission Lines feature, the Stub Size and Stub Space  values are used.  
Simulator will draw each automatically inserted branch such that it emerges from both its terminal buses at right 
angles.  To accomplish this, Simulator draws each automatically inserted branch in three segments: two stubs 
perpendicular to the terminal buses having a length specified by the value supplied for Stub Size, and a third 
segment joining the two stubs.  The amount of space between lines as the converge into a bus is set by Stub 
Space . 

If you do not want transmission line stubs to be inserted, then set Stub Size to 'none' or to a negative number.  Note 
in order to set a value for Stub Space , Stub Size must be set to a positive number first. 

Editing CB Size 

When you insert new transmission lines or transformers, circuit breakers will automatically be inserted on the 
branch with their size specified by CB Size.  If you do not want Circuit Breakers inserted for a particular voltage 
level, then set CB Size to 'none' or a negative number. 

Editing Pie Size 

When you insert new transmission lines or transformers, pie charts will automatically be inserted on the branch with 
their size specified by Pie Size.  If you do not want pie charts inserted for a particular voltage level, then set Pie Size 
to 'none' or a negative number. 

Set Default Font 

Click on this button to set the default font used for new text fields.  This is the font which will be used for all new text 
fields.  Note however that the default font size set using this dialog is not used unless the option Use the default 
font size for new text objects is selected.  Otherwise, the specific kind of object and voltage level specifies what 
the font size should be.  For example, in the Interface tab, one of the defaults is Font Size. New Interface Fields will 
use this font size. 

Only Cut/Copy Display Objects, Not Power System Records 

When you cut or delete an object from the oneline, Simulator needs to know whether you simply want to delete the 
display object from the oneline or to purge the definition of the power system object from the model.  Check this box 
to tell Simulator to assume that it should always delete objects just from the oneline display, not from the power 
system model. 

Oneline / Bus View Background Color 

To change the default oneline background color, click on the Change button to select a new color.  This color 
applies to both new oneline diagrams and the background color of the bus view oneline diagram. 
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Bus Selection Page  

The Bus Selection page is currently used with two displays: 

• The Equivalencing Display, to partition the system into the study subsystem ("Study") and the external 
subsystem ("External"). 

• The Facility Analysis Dialog, to determine the buses in the external subsystem from which the buses in the 
facility would be isolated. 

The following description concerns the Equivalencing Display, but the functionality of the Bus Selection Page is similar 
for both applications. 

Buses, Areas, and Zones lists  

For both equivalencing and facility analysis, use these lists to manually change the system designation of individual 
buses, areas, or zones.  Note that changing the system designation on the area or zone tab is just another form of 
changing the designation of study / external system of individual buses.  Click on the Which System field in each of 
these tables to toggle the object’s affiliation with the study or external systems, subject to the values of the Filter by 
kV option and the Neighbor Tiers field. 

In addition, the bus selection table for facility analysis contains one additional column labeled Selected.  This Yes 
or No field indicates which buses in the Study system belong to the Facility being analyzed.  Double-clicking one of 
the fields in this column will toggle the value of the field between Yes or No. 

External 

Use these fields to specify a range of areas, zones, or buses to be added to the external system.  The Filter by kV 
and Neighbor Tiers controls will also shape the selection of buses to add to the external system. 

Internal 

Use these fields to specify a range of areas, zones, or buses to be added to the study system. The Filter by kV and 
Neighbor Tiers controls will also shape the selection of buses to add to the study system. 

Neighbor Tiers 

This value indicates the number of tiers of neighbors to carry with each selected bus when adding the selected bus 
to either the study or external system.  For example, if Neighbor Tiers is 1 and we elect to add bus X to the external 
system, both bus X and its first tier of neighbors will be added to the external system.  If Neighbor Tiers is 0, only 
bus X will be added to the external system. 

Filter by kV 

If the Filter by kV box is checked, then only buses having a nominal voltage level between the values given in the 
Max kV  and Min kV  fields can be selected. 

Set All As External 

Click this button to assign all buses to the external system. 

Set Branch Terminals External or Study 

Clicking either of these two buttons allows setting advanced filter criteria which define a branch or group of 
branches.  Once the criteria are set, clicking Filter will select the terminal buses of all branches meeting the filter 
criteria, and set those buses to either the External or Study system, depending on which button was pressed. 

Select Buses using a Network Cut 

A custom network cut can be defined for choosing which buses should remain in either the Study or External 
system. 

Save Buses to File  

Once the system has been partitioned, this command allows you to store the numbers of the buses of the study 
system in a text file. 

Load Buses from File 

Click on this button to load a listing of the buses to be included in the study system from a text file.  You will be 
prompted to select the text file.  The format of this text file is such that one bus number occupies each line.  Any 
buses not identified in this file are defined as being in the external system. 

Example  

Assume you would like to create an equivalent containing all the buses in areas 1-5 and 10, plus any tie buses, and 
bus number 2050.   

• Since initially all buses are in the study system, first enter 1-1000 in the Areas field of Add to External 
System.  Since the area of every bus is within this range, this places all the buses in the external system.   
Alternatively, click Set All As External to accomplish the same objective. 

• Set Neighbor Tiers to 1.  This indicates that all subsequent selections will affect the specified buses and their 
first tier of neighbors.  



Printed Documentation 

138 

• In the Areas field of Add to Study System, enter 1-5,10.  This places all the buses in these areas, plus any 
tie buses (since Neighbor Tiers is 1), into the study system.   

• In the Buses list, click on bus 2050 to change its status.   
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List Unlinked Display Objects  

Select Options/Tools > List Display Objects > Unlinked from the main menu in Edit Mode to identify display objects 
on the currently selected oneline that are not linked to a record in the power system model.  The existence of unlinked 
display objects on a oneline diagram can be misleading because they have zero flows and zero bus voltages 
associated with them.   

 

The Unlinked Display Objects has the following controls: 

Total Number of Unlinked Display Objects  

Indicates the total number of unlinked objects on the display.  Ideally, this number should be zero.  If nonzero, the 
unlinked objects are identified in the table by type, screen location, and zoom range over which the object is visible. 

Delete Unlinked Objects  

Click on this button to permanently remove all unlinked objects from the display.  Exercise this option carefully.  
Generally, you will want to do this either when you have substantially modified a power flow case, such as by 
creating an equivalent, or when you are using the oneline with a new power system case.   

View Options fro Highlighting Unlinked Objects on the One-line  

Click on this button will open the Grid/Highlight Unlinked Objects tab of the Oneline Display Options Dialog. 

Type, X/Y Location 

The remainder of the display shows the type, location, identification, layer, applicable zoom level, anchored 
property, and font size for each unlinked object.  This table is a type of Case Information Display and thus behaves 
similarly to all other case information displays.  Right-click on a record in this table to invoke the local menu.  Select 
Pan Oneline to Object to locate and select the unlinked object on the oneline diagram.  
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List All Display Objects  

Select Options/Tools > List Display Objects > All from the main menu in Edit Mode to generate a list of all display 
objects featured on the oneline diagram.  The Oneline  Objects Dialog features a Case Information Display that 
identifies each display object by its type, X and Y screen coordinates, what layer the object is contained in, whether or 
not it is subject to conditional zooming, if it is anchored, and the font size (if applicable.)  Since the table is a type of 
Case Information Display, it exhibits behavior similar to that of all other case information displays. 

Right-click on a record in the display to view the local menu.  From the local menu, choose Delete to remove the 
display object from the oneline.  Choose Show Dialog to show the object’s corresponding information dialog.  Finally, 
choose Pan Oneline to Object to locate and select the corresponding display object on the oneline. 
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Set Selected Field 

The Set Selected Field option is an oft unused featured in Simulator, but can at times prove very useful.  Each object 
in Simulator has a property called Selected, which does nothing in Simulator other than allow the user to choose a 
specialized set of objects for some other purpose, such as advanced filtering a display.  The user can add a column to 
most types of case information displays which shows the value of the Selected property for the type of object being 
observed.  By default, this field is always set to No.  However, the user can change the value of this field, and then 
sort the column, filter the display, or any other action that can normally be performed on a column of a Yes/No type. 

In addition to modifying the Selected property manually in a case information display, it is also possible to define a 
group of buses' Selected property by defining a network cut on the system.  Choosing the Set Selected Field option 
from the Case Information menu will open the network cut dialog automatically for setting the Selected property of a 
group of objects according to a desired cut plane chosen. 
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Network Cut 

The Network Cut tool is another method for choosing sets of buses for such features as Scaling or Equivalencing. 

The use of the network cut method is to define a set of branches as the "cut" plane, then choose a bus on one side or 
the other of the cut to indicate which side of the cut you are interested in.  The network cut dialog provides the 
functionality necessary for defining the network cut. 

 

Defining Network Cut 

The first step in defining the network cut is to choose the branches which define the cut plane in the system.  The 
one caution is to be sure you select a closed loop cut plane.  In other words, if you do not select a set of branches 
which completely topologically separates two portions of the system.  If you only choose a partial cut plane, which 
does not completely cut the system in two distinct pieces, then attempted use of the ill-defined cut plane will fail. 

To choose the branches which define the cut plane, simply highlight the branches by clicking on them in the list.  
For each branch you highlight, you must click on arrow button (pointing to the box on the right) to add the branch to 
your cut plane definition.  You can make use of the control (Ctrl) and shift keys to select multiple branches at one 
time in the list of branches.  Note that you can also select a cut plane similarly using interfaces or DC lines. 

Once you have the branches (or interfaces or DC lines) selected which form the cut plane, you then need to choose 
a bus on either side of the cut plane to indicate which side you are interested in.  The bottom panel on the display 
allows you to locate and select this bus. 

Require Paths to be Energized 

This option can be checked if the branches forming a network cut should be energized to be included. 

Include How Many Tiers of Neighbors 

Once the network cut has been defined by a set of branches and the bus defining which side of the cut is being 
examined has been chosen, this option will then include buses within so many tiers of the network cut 
boundary, on the opposite side of the cut as the specified bus.  If the number of tiers is set to zero, then the 
buses examined will only be those on the same side of the cut as the bus selected. 

 

Setting the Field 

Once the network cut has been defined and the side of the cut to be examined has been chosen, the appropriate 
field for eac h bus in the area of interest can be set.  If the network cut is for the equivalencing tool, then the field to 
set is the Which System property, which defines if a bus is in the external or study system when creating an 
equivalent.  If the network cut is f or the scaling tool, then the field to set is the Scale property, which defines if a bus 
is to be included in a scaling action. 

Filter by KV  

The buses within the network cut can be filtered by nominal voltage level before the field(s) are set.  Only buses 
that are within the network cut and are within the nominal KV level specified will have their fields set to the 
desired value. 

Use Area/Zone Filters 

The buses within the network cut can be filtered by the area or zone in which they are contained before the 
field(s) are set.  Only buses that are within the network cut and whose area meets the defined Area/Zone filter 
specified will have their fields set to the desired value. 
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Browse Open Onelines 

All the objects in all the open .pwd files can be listed in the Browse Oneline Environment dialog. To do so, go to 
Options/Tools > Browse open onelines in Edit Mode or Run Mode. The power system objects are listed in the first 
12 pages according to their type. For instance, all the buses and bus fields are listed in the Buses page while all the 
generators and generator fields are listed in the Generators page. The Others page lists all the objects in the one-
lines, which are not associated with power systems, e.g. background lines, texts, or graphs. The All page lists all the 
objects in all the open one-lines. The exceptions are areas, zones and super-areas are listed in the Others page 
instead of their corresponding power system element pages.  The default display columns for each grid page include 
the one-line file name of the object and the type of the object. The first 12 pages also have default display columns of 
the associated power system element type. The Others and All pages include the default display columns for generic 
display objects.  

The one-line displays can be panned to the selected object. To do so, select one object from the Browse Oneline 
Environment dialog and right click to invoke the local popup menu. Click Pan one -line to object. This will bring the 
one-line with the s elected object to the front and pan to the selected object. When panning, the browsing dialog can be 
kept on top if Keep browsing dialog on the top when choosing Pan One -line to Object is checked. Otherwise, the 
dialog will be sent to back when panning. 

Note: Browse Oneline Environment dialog is for use in browsing only. To change information, go to the respective 
Case Information Display. 

Insertion Using Palettes 

Palette Overview 

The display object palettes are designed to help you lay out a new oneline diagram for a pre-existing power flow model 
as quickly as possible.  Display object palettes exist for Areas, Buses, Substations and Zones.  Palettes list the display 
objects that you have already added to the oneline, the display objects that have not yet been drawn that neighbor 
those displayed objects, and the set of all display objects that have not yet been added to the drawing.  By selecting 
and dragging a display object name from either the Undrawn Neighbors list or the All Undrawn list to a location on 
the oneline diagram where you would like that object to appear, you can add that display object to the drawing with 
very little effort.  The display object palettes are especially useful for adding a region of an interconnection in its 
entirety. 

To display one of the four available palettes, select Insert > Show Insert Palette For from the main menu. 
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Using the Insert Palettes 

The display object palettes are a tool designed to accelerate the building of a oneline diagram based on a pre-existing 
power flow case.  To display a palette, select Insert > Show Insert Palette for from the main menu. 

 

The display object palettes feature the following controls: 

Displayed 

Lists those objects defined in the power flow case that have already been added to the oneline diagram.  When you 
click on an entry in the Displayed list, the contents of the Displayed Neighbors and Undrawn Neighbors lists will 
be refreshed to identify all display objects that neighbor the display object you selected.  Only the display objects 
matching the type of Insert Palette opened will be shown in the list. 

Double click on an entry in this list to pan to it so that the selected display object appears in the center of the 
screen.  If you are looking at the Insert Palette for Buses, you can right-click on an entry and choose either Quick 
Power Flow List or Bus View Display to learn more about the selected bus. 

Displayed Neighbors 

Lists those objects defined in the power flow case that neighbor the display object selected in the Displayed list that 
have already been drawn on the oneline diagram.  You can make a "Displayed Neighbor" the selected "Displayed" 
object by right-clicking on a display object in the Displayed Neighbor List and selecting Make Current Displayed 
from the local menu.  Only the display objects matching the type of Insert Palette opened will be shown in the list. 

Undisplayed Neighbors 

Lists those display objects defined in the power flow case that neighbor the object selected in the Displayed list that 
have not yet been drawn.  To add the undrawn display object to the oneline diagram, select its name with the left 
mouse button and keep the left mouse button pressed as you move the mouse to the point on the oneline where 
you would like to drop the object.  When you let go of the left mouse button, the Information Dialog box for that 
display object will appear.  Use the Information Dialog to change display parameters for the object and click OK to 
finish dropping the object onto the oneline.  The display object you have just added will be appended to the end of 
the Displayed list and will also be added to the History List so that you can identify its own undrawn neighbors 
quickly.  Only the display objects matching the type of Insert Palette opened will be shown in the list. 

If you are looking at the Insert Palette for Buses, you can right-click on an entry and choose either Quick Power 
Flow List or Bus View Display to learn more about the selected bus. 

All Undisplayed 

Lists those display object defined in the power flow case that have not yet been added to the oneline diagram, 
regardless of whether the object neighbors a displayed object or not.  This list functions identically to the 
Undisplayed Neighbors List. To add the undrawn display object to the oneline diagram, select its name with the 
left mouse button and keep the left mouse button pressed as you move the mouse to the point on the oneline where 
you would like to drop the object.  When you let go of the left mouse button, the Information Dialog box for that 
display object will appear.  Use the Information Dialog to change display parameters for the object and click OK to 
finish dropping the object onto the oneline.  The display object you have just added will be appended to the end of 
the Displayed list and will also be added to the History List so that you can identify its undrawn neighbors quickly.  
Only the display objects matching the type of Insert Palette opened will be shown in the list.   

If you are looking at the Insert Palette for Buses, you can right-click on an entry and choose either Quick Power 
Flow List or Bus View Display to learn more about the selected bus. 

History List 

Identifies the display objects you have added to the oneline diagram using the insert palettes since the last time you 
opened the display object palette.  Select a name from this list to display the undrawn neighbors of the 
corresponding display object.  Only the display objects matching the type of Insert Palette opened will be shown in 
the list. 

Define a Filter 

The Define a Filter button opens the Advanced Filters dialog.  This dialog allows you to customize which display 
objects appear in the various lists.  This can be helpful, for example, if you wish to add objects to the oneline that 
reside only in particular areas, or if you don't want objects less than a certain voltage level to be listed. 

When you click OK on the Advanced Filters dialog, the display object palette's lists will automatically be updated to 
reflect the filter settings. 

Click Close  when you are done using the display object palette. 

Automatic Object Insertion 

Automatically Inserting Buses 

Simulator can automatically insert buses on your oneline diagram if you have data regarding their spatial or 
geographic location.  To achieve this, go to the menu and choose Insert > Auto Insert > Buses.  This opens the Auto 
Insert Bus Dialog. 
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On this dialog you must first specify the file which contains the location data.    You must also specify whether the file 
contains x,y coordinates, or if you are drawing a map of the United States, you can use longitude, latitude coordinates.  
The format of the location data text file is as follows: 

The first line of this text file is ignored by Simulator.  The following lines consist of three numbers:  Bus Number, X 
location, and Y location.   If you are reading longitude, latitude for the United States, then X signifies longitude and Y 
signifies latitude. 

Num, X Location, Y Location 

 1,   24001.46,   19715.15 

 3,   24001.46,   19715.15 

16,   24130.91,   19638.99 

17,   24007.31,   19093.09 

21,   23649.27,   18439.07 

22,   23649.27,   18439.07 

etc... 

Simulator will place the buses on the oneline diagram at the X, Y locations.  The buses will be drawn according to 
default bus object information defined in the Default Drawing Values for New Objects dialog. 

Finally, if you would like Simulator to automatically insert transmission lines after completing the auto insertion of your 
buses, check the box.  Transmission lines and transformers will be automatically drawn based on the Line/XFMR 
default options defined in the Default Drawing Values for New Objects dialog. 
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Automatically Inserting Transmission Lines 

The Automatic Insertion of Lines/Transformers Dialog is used to automatically draw transmission lines and 
transformers on the oneline diagram between existing bus -display objects.  Only branches that are already defined in 
the power flow case can be added automatically; if you need to define a brand new branch, see Transmission Line 
Display Objects.  Thus, this option is useful only when you are starting with an existing power flow case, not building a 
case from scratch. 

To insert lines and transformers automatically, you must first have drawn the buses for each end of the device.  
Simulator then draws the branch display objects connecting the buses for each transmission line/transformer in the 
power flow case not already shown on the oneline.  

To display the dialog, in the Edit Mode select Insert > Auto Insert > Lines from the main menu. 

 

The dialog has the following options: 

Minimum kV Level 

Simulator will automatically draw line and transformer display objects between terminals whose nominal voltages 
meet or exceed the minimum kV level specified in this field.  For a branch object to be drawn, either one of its 
terminals must satisfy this criterion.  This option is useful for suppressing the automatic addition of generator step-
up transformers if that kind of detail is not warranted. 

Default Drawing Values 

This button opens the Default Drawing Values Dialog.  Options such as the automatic insertion of transmission line 
stubs, text fields, circuit breakers, and pie charts are specified in the Default Drawing Values Dialog. 

Insert Text Fields  

If this box is checked, the text fields defined in the original oneline will be displayed. 

Insert Equivalenced Objects  

If this option is checked, equivalenced objects modeled as lines will also be automatically inserted with the real 
transmission lines. 

Use Only Selected Buses 

Instead of having Simulator automatically insert line and transformer display objects throughout the oneline 
diagram, you can force it to insert the new objects only between the bus display objects that are currently selected.  
This option is enabled only when two or more bus display objects are currently selected on the oneline. 

Identifying Bus Ties 

This area deals with lines used as ties between breakers.  These lines are modeled as zero impedance 
connections.  In this area two choices are given for how to insert the bus tie breakers: Do not insert stubs for bus 
ties and Only insert a single circuit breaker.  The first choice allows you to decide if line stubs will be drawn when 
the tie breaker is inserted.  The second sets whether or not only one circuit breaker is inserted on the tie breaker.  
This could be useful for determining real lines from bus tie breakers. 
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Automatically Inserting Generators 

The Automatic Insertion of Generators Dialog is used to automatically draw generators on the oneline diagram on 
existing bus -display objects.  Only generators that are already defined in the power flow case can be added 
automatically; if you need to define a new generator, see Generator Display Objects.  Thus, this option is useful only 
when you are starting with an existing power flow case, not building a case from scratch. 

To insert generators automatically, you must first have drawn the terminal bus for each device.  Simulator then draws 
the generator display objects connected to the buses for each generator in the power flow case not already shown on 
the oneline.  

To display the dialog, in the Edit Mode select Insert > Auto Insert > Generators from the main menu. 

 

The dialog has the following options: 

Minimum kV Level 

Simulator will automatically draw generator display objects at terminal buses whose nominal voltages meet or 
exceed the minimum kV level specified in this field.  For a generator object to be drawn, its terminal must satisfy this 
criterion. 

Default Drawing Values 

This button opens the Default Drawing Values Dialog.  Options such as the automatic insertion of text fields are 
specified in the Default Drawing Values Dialog. 

Insert Text Fields  

When this box is checked, the default fields associated with the generator will appear around the generator, such as 
voltage, name, and/or MW. 

Insert Equivalenced Objects  

This field is not used when automatically inserting generators. 

Use Only Selected Buses 

Instead of having Simulator automatically insert generator display objects throughout the oneline diagram, you can 
force it to insert the new objects only between the bus display objects that are currently selected.  This option is 
enabled only when two or more bus display objects are currently selected on the oneline. 
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Automatically Inserting Loads  

The Automatic Insertion of Loads Dialog is used to automatically draw loads on the oneline diagram on existing bus -
display objects.  Only loads that are already defined in the power flow case can be added automatically; if you need to 
define a brand new load, see Load Display Objects.  Thus, this option is useful only when you are starting with an 
existing power flow case, not building a case from scratch. 

To insert loads automatically, you must first have drawn the terminal bus for each device.  Simulator then draws the 
load display objects connected to the buses for each load in the power flow case not already shown on the oneline.  

To display the dialog, in the Edit Mode select Insert > Auto Insert > Loads  from the main menu. 

 

The dialog has the following options: 

Minimum kV Level 

Simulator will automatically draw load display objects at terminal buses whose nominal voltages meet or exceed the 
minimum kV level specified in this field.  For a load object to be drawn, its terminal must satisfy this criterion. 

Default Drawing Values 

This button opens the Default Drawing Values Dialog.  Options such as the automatic insertion of  text fields are 
specified in the Default Drawing Values Dialog. 

Insert Text Fields  

When this box is checked, the default fields associated with the load will appear with the loads, such as MVAR 
and/or MW. 

Insert Equivalenced Objects  

If this option is checked, equivalenced objects modeled as loads will also be automatically inserted with the real 
transmission lines. 

Use Only Selected Buses 

Instead of having Simulator automatically insert load display objects throughout the oneline diagram, you can force 
it to insert the new objects only between the bus display objects that are currently selected.  This option is enabled 
only when two or more bus display objects are currently selected on the oneline. 
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Automatically Inserting Switched Shunts  

The Automatic Insertion of Switched Shunts Dialog is used to automatically draw switched shunts on the oneline 
diagram on existing bus-display objects.  Only switched shunts that are already  defined in the power flow case can be 
added automatically; if you need to define a brand new switched shunt, see Switched Shunt Display Objects.  Thus, 
this option is useful only when you are starting with an existing power flow case, not building a case from scratch. 

To insert switched shunts automatically, you must first have drawn the terminal bus for each device.  Simulator then 
draws the switched shunt display objects connected to the buses for each switched shunt in the power flow case not 
already shown on the oneline.  

To display the dialog, in the Edit Mode select Insert > Auto Insert > Switched Shunts  from the main menu. 

 

The dialog has the following options: 

Minimum kV Level 

Simulator will automatically draw switched shunt display objects at terminal buses whose nominal voltages meet or 
exceed the minimum kV level specified in this field.  For a switched shunt object to be drawn, its terminal must 
satisfy this criterion. 

Default Drawing Values 

This button opens the Default Drawing Values Dialog.  Options such as the automatic insertion of text fields are 
specified in the Default Drawing Values Dialog. 

Insert Text Fields  

When this box is checked, the default fields associated with the switched shunt will appear around the generator, 
such as nominal MVAR. 

Use Only Selected Buses 

Instead of having Simulator automatically insert switched shunt display objects throughout the oneline diagram, you 
can force it to insert the new objects only at the bus display objects that are currently selected.  This option is 
enabled only when two or more bus display objects are currently selected on the oneline. 
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Automatically Inserting Interfaces 

The Automatic Insertion of Interfaces Dialog is used to automatically insert interface objects  on the oneline diagram 
between existing area/zone display objects.  Interface pie chart objects  can also be inserted as part of this process.  
The automatic insertion of interface display objects greatly accelerates the construction of interface diagrams, which 
are particularly useful for animating the results of PTDF calculations.  Only area-area and zone-zone interface records 
can be displayed using interface display objects. 

The following procedure describes the quickest way to create an interface diagram for showing PTDF information and 
area-area or zone-zone flows.  It steps through the process from the creation of area-area or zone-zone interface 
records to the addition of the area or zone display objects and, finally, to the automatic insertion of interface display 
objects. 

 

• Select Case Information > Interfaces from the main menu to bring up the Interfaces Display. 

• Right-click on the Interface Records Display to show its local menu.  Select Auto Insert Interfaces from the local 
menu.  This generates the Auto-Insert Interfaces Dialog.  

• Use the Auto-Insert Interfaces Dialog to create the area-area or zone-zone interface records automatically.   

At this point, the interface records  have been created automatically.  We now want to generate an interface diagram, 
with the interface display objects added to it automatically.  

• On a oneline diagram (either an already open diagram or a brand new one created by choosing File > New Oneline 
from the main menu), place area/ zone objects at the desired locations. 

• Select Insert > Auto Insert > Interfaces to display this dialog.  

• Check the Insert Pie Charts on Interfaces box to automatically insert interface pie chart objects when the 
interfaces are inserted.  If this option is selected, change the Default Size of Interface Pie Charts  to specify their 
size. 

• Select OK to insert the new oneline objects.  New interface objects are automatically inserted between any 
area/zone objects that have a corresponding interface record that is not already represented.   

 

Note that you can do this automatic insertion as often as you like.  The Number of Interfaces Not Shown field 
indicates how many interfaces still need to be added to the diagram to represent all defined area-area or zone-zone 
interfaces.  It is a read-only field.   
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Automatically Inserting Substations  

Simulator can automatically insert substations on your oneline diagram if you have data regarding their spatial or 
geographic location.  To achieve this, go to the main menu and choose Insert > Auto Insert > Substation.  This 
opens the Auto Insert Substation Dialog. 

On this dialog you must first specify the file which contains the location data.    You must also specify whether the file 
contains x,y coordinates, or if you are drawing a map of the United States, you can use longitude, latitude coordinates.  
The format of the location data text file is as follows 

The first line of this text file is ignored by Simulator.  The following lines consist of three numbers:  Substation Number, 
X location, and Y location.   If you are reading longitude, latitude for the United States, then X signifies longitude and Y 
signifies latitude. 

Num, X Location, Y Location 

1,   24001.46,   19715.15 

3,   24001.46,   19715.15 

16,   24130.91,   19638.99 

17,   24007.31,   19093.09 

21,   23649.27,   18439.07 

22,   23649.27,   18439.07 

etc... 

Simulator will place the substations on the oneline diagram at the X, Y locations.  The substations will be drawn 
according to default substations object information defined in the Default Drawing Values for New Objects dialog. 

Finally, if you would like Simulator to automatically insert transmission lines after completing the auto insertion of your 
substations, check this box.  Transmission lines and transformers will be automatically drawn based on the Line/XFMR 
default options defined in the Default Drawing Values for New Objects dialog. 
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Automatically Inserting Borders 

PowerWorld Simulator allows you to automatically insert geographic borders, which PowerWorld Corporation has 
drawn.  These include the states in the United States of America and several International Borders as well. You may 
also define a border in a text file and insert this User-Defined border. To bring up the Auto Insert Borders Dialog, go 
to the menu and choose Insert > Auto Insert > Borders.  This dialog has several tabs described below: 

 

United States 

This tab allows you to select states in the United States that you want to insert.  (Note: to select several states to insert 
at once, use the Ctrl and Shift keys while clicking with your mouse.)  These states will be placed on the screen such 
that as you add new states they will be placed geographically appropriately. 

Once you have selected the states you want to insert, Click OK. 

 

International 

This tab allows to insert several borders which PowerWorld Corporation has drawn recently.  Note: if you have drawn 
a oneline which contains a geographic border you would like us to include in future version of Simulator, please 
contact us at support@powerworld.com and we'll add it to our next release. 

 

User-Defined Borders 

This tab allows you to read in a border from a text file that you create. The first row of this text file is a comment row 
and is ignored when reading it in.  After this it reads in the description of each background line.  This description starts 
with the number of points in the line followed by a list of x, y coordinates.  The file ends when the number of  points for 
a line is read as -1.  An example file follows: 

Comment row  

5 

   59, 60 

   10, 20 

   40.3, 95.20 

   89.3, 22.11 

   79.5, 34.56 

45 

   40, 66 

   etc… 

-1   this signifies the end of the file 

Equivalencing 

Equivalents  

An equivalent power system is a power system model of smaller dimension than the original system that approximates 
the behavior of the original system reasonably well.  In reality, most pow er system models are actually an "equivalent" 
of a much larger interconnected network.  When performing power system studies, it may be desirable to reduce the 
size of the system model even further so that it may be solved more quickly.  You can build power system equivalents 
in Simulator using the Equivalencing Display.   The following paragraphs provides some details on this process.   

The most important part of constructing an equivalent is determining which buses should be explicitly retained in the 
equivalent, and which buses should be equivalenced, or removed from the case.  Several definitions are useful here: 

Study System 

The buses that are to be retained. 

External System 

The buses that are to be equivalenced. 

Boundary Buses 

Any buses in the study system that are connected to buses in the external system.   

How well the equivalent system approximates the behavior of the original system depends upon which buses are 
retained in the study system.  Retaining more buses yields results that more closely match those of the original case, 
but at the expense of greater computation time.  The number of buses to retain in the study system depends upon how 
the equivalenced system will be us ed.  Building system equivalents is as much an art as it is a science, with few solid 
rules of thumb.  However, to improve accuracy, you should retain as many generator units as possible.   

The actual equivalent is constructed by performing a matrix reduction on the bus admittance matrix.  A result of this 



Edit Mode Tools and Options 

153 

process is the creation of "equivalent" transmission lines that join boundary buses equipped with equivalent shunts or 
loads.  Equivalent lines have a circuit identifier of ‘99’.  Since many of the equivalent lines created during the matrix 
reduction have very high impedance values, an option is provided to ignore equivalent lines with impedances 
exceeding a specified threshold value.  Additionally, an option is provided to convert the equivalent shunts added at 
the boundary buses to constant PQ loads. 
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Equivalents Display 

The Equivalents Display is used to construct equivalent systems.  An Equivalent System is a system of smaller 
dimension that exhibits similar power flow properties.  Equivalent systems are constructed to help accelerate 
computation without sacrificing accuracy.  For more information, please see Equivalents. 

To bring up the Equivalencing Display, select Options/Tools > Create Equivalent from the main menu in Edit Mode.  
This display contains two pages, the Bus Selection Page and the Create Equivalent Page .  Use the Bus Selection 
Page to partition the power system into the study system and the external system.  Use the Create Equivalent Page to  

• Save the external system in a file 

• Extract the external system 

• Build an Equivalent 

Each of these tasks is described below.   

Bus Selection Page  

To perform any of the tasks described on the Create Equivalent Page, you first need to specify the study system and 
the external system.  Do this by directly assigning buses to the desired system.  The Bus Selection Page has been 
designed to provide a number of powerful and complimentary ways of accomplishing this task.   

The most important point to keep in mind when using this page is that membership in the study system and the 
external system is on a bus -by-bus basis (as opposed to by areas or zones).  Thus, each bus is either in the study 
system or the equivalent system.  Each bus’ current assignment is indicated in the Buses list, which is shown on the 
bottom left corner of the page.  By default, all buses initially reside in the study system.  Please see Bus Selection 
Page <+> for more details.   

Create Equivalent Page  

The Create Equivalent Page allows you to save the external system in a file, to delete the external system, and to 
build the power system equivalent. 

Build Equivalent 

This procedure constructs an equivalent system.  For background on equivalents, please see Equivalents.  The 
following sections are all options for building an equivalent. 

Delete All External Generators or Retain Generators with Max MW Ratings Above  

If the Delete All External Generators checkbox is checked, the equivalencing routine will remove all external 
generators from the case, regardless of their MW rating.  Otherwise, the equivalencing routine will add to the 
study system any generators originally in the external system whose real power output exceeds the specified 
value.  Retaining large generators often makes an equivalent significantly more accurate.  If you do not wish to 
retain any additional generators, check the Delete All External Generators checkbox. 

Retain Remotely Regulated Buses 

Some generators and transformers regulate buses other than their terminals.  When this box is checked, these 
remotely regulated buses are automatically included in the equivalent if the regulating generator or transformer 
is included.  If the box is not checked, the regulated bus is set to the terminal of the retained object.  It is 
strongly recommended that you leave this box checked at all times.   

Retain Branch Terminals For 

This section allows you to customize the retention of branch terminals for special-case types of branches.  You 
may choose to retain terminal buses for transformers, zero impedance ties, area tie lines, and/or zone tie lines. 

Max Per Unit Impedance for Equivalent Lines 

During the equivalencing process, a number of equivalent lines are created joining the boundary buses.  All 
equivalent lines with per unit impedance values above this threshold are ignored. 

Two Character Circuit ID for New Equivalent Lines 

Choose the circuit identifier to be used for the equivalent lines that are created.  Typical circuit ID’s for 
equivalent lines are 99 or EQ. 

Remove External Objects from Onelines 

This feature removes display objects associated with the external system from any open onelines.   

Convert Equivalent Shunts to PQ Loads  

During the equivalencing process, shunt elements are added at the boundary buses.  Check this box if you 
would like these equivalent shunts converted to constant PQ loads.  If this option is checked, equivalent loads 
are created with a load ID of ‘99’. 

Remove Radial Systems 

Checking this option results in all radial connections in the network to be reduced to their nearest non-radial bus 
(i.e. node.)  The equivalencing routine will iteratively reduce the network when this option is checked, until no 
more radial connections exist in the system. 
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Select Build Equivalent System to construct the equivalent system.  Constructing an equivalent system 
permanently removes the external system from the case and adds a number of equivalent lines and shunts/loads.   

Saving the External System in a File 

This procedure allows an external system to be saved in a file without deleting the external system.  This option is 
useful for allowing you to save a portion of the system in a file, modify it using perhaps another program, and then 
use Append Case to append the modified file to the original case.   

When saving the external case, there are two options: 1) save just the external case, or 2) save the external case 
and any ties to the original case.  Option one just saves the external case, while option two saves the external case 
and any transmission lines or transformers that connect the external system to the rest of the system.  Save just the 
external case if you are planning to use the external case as a standalone case.  Save the external case and its ties 
if you are planning to modify the external case and then to append it back to the original case.   

Click Save External System to save the external system in a file.  You will be prompted for the desired case format
. 

Deleting the External System 

This procedure deletes the external system from the original case.  All devices in the external system are removed, 
including any buses and lines/transformers in the external system and any lines/transformers that join the external 
system to the study system.  Check the Remove External Objects from Onelines to remove any display objects 
linked to the external system from the open onelines.   

This command permanently removes the external system from the case; an equivalent system is not created.  
Select Delete External System to actually delete the system.   

System Scaling 

Scaling 

Use the Power System Scaling Dialog to scale the load, generation, or bus shunts uniformly for either the entire 
case or a group of selected buses.  This display allows you to scale any of the following values: 

• Bus real power load 

• Bus reactive power load 

• Generator real power output 

• Real component of the bus shunt admittance 

• Capacitive component of the bus shunt admittance 

• Reactive component of the bus shunt admittance 

To display the Power System Scaling Dialog, select Options/Tools > Scale Case from either Edit Mode or Run Mode.  
When the dialog appears, you may begin to select the buses to be scaled.  Buses can be selected individually or in a 
group by areas or zones.  In addition, if you already have specific groups of devices defined as an injection group, you 
can choose to scale values associated with the injection group. 

 

Scale by Bus, Area or Zone  

The Buses Table  lists the name and number of all buses in the system and whether or not each bus will participate in 
the scaling.  Similarly, the Areas, Zones, and Super Area tables list the names and numbers of all areas, zones or 
super areas in the system and whether or not each area will participate in the scaling.  Simulator initially assumes that 
you wish to scale load, generation, or shunt compensation at all buses in the case.  If you instead wish to scale only a 
subset of the system, press the Set All To No button and begin to select the buses and areas to scale.  The Power 
System Scaling Dialog furnishes a number a ways to do this: 

• Use the Add to be Scaled fields to enter either a range of areas and/or buses to scale. 

• Use the Remove from Scaling fields to enter either a range of areas and/or buses to omit from the scaling. 

• Define a Network Cut to choose a custom set of buses within a portion of the system to be scaled or omitted from 
the scaling. 

• Use the Buses, Areas, Zones and Super Areas tables to change the scaling status of individual areas or buses.  
Simply double-click on the Scale field for a bus or area to toggle its value. 

• Click the Set All To Yes button to scale the entire case.  Click the Set All To No button to remove the entire case 
from scaling. 

Changing the scaling for an area changes the scaling status for all buses in the area.  For example, to scale all the 
buses in a single area, first click Set All to No.  Then, click on the Scale field for the desired area in the Area Table.  
To scale all buses in an area except for a select few, repeat the above process, but then click on the Scale field for the 
buses not to scale. 

As you select the buses to be scaled, the fields in the Totals for Selected Buses are updated to indicate the total 
load, generation, or shunt compensation that will be scaled.   

Once you have selected the buses, you can either use the Scale By fields to enter a new scaling factor for each of the 
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quantities or use the New Value fields to specify a new value directly.  If you do not wish to scale a particular type of 
device, such as bus shunts, simply leave the Scale By field as unity.   

To ensure that the reactive power is scaled proportionately to maintain the current load power factor, click the 
Constant P/Q Ratio option.  To enforce generator limits when scaling generation, check the Enforce Gen MW Limits 
option.  To scale generation and load to enforce ACE, check Scale Gen to Keep ACE Constant.  When Simulator 
scales generation, all generator power outputs at the selected buses are scaled by the specified factor, regardless of 
area control.  To scale only generators whose AGC field is set to YES only, check Scale Only AGCable Generation.  
To scale both in-service and out-of-service loads, check Scale Out-Of-Service Loads . 

Finally, click Do Scaling to scale the load, generation, or shunt compensation. 

 

Scale by Injection Group 

If injection groups have been defined for the case, you can scale the generation and load values for the injection group 
by first clicking on the Injection Groups  button.  The Buses Table will be replaced with a new table listing the 
Injection Groups in the case.  To choose injection groups to scale, double-click the Scale field to toggle the value 
between No and Yes.  As Scale fields are toggled to Yes, the Generator and Load MW and Mvar fields will update to 
display the totals for the selected injection groups.  When all of the desired injection groups have been selected, either 
the Scale By or the New Value  fields can be modified for a desired new value for the selected injection groups. 

To ensure that the reactive power is scaled proportionately to maintain the current load power factor, click the 
Constant P/Q Ratio option.  To enforce generator limits when scaling generation, check the Enforce Gen MW Limits 
option.  When Simulator scales generation, all generator power outputs at the selected buses are scaled by the 
specified factor, regardless of area control. 

Finally, click Do Scaling to scale the load and generation for the selected injection groups. 

 

Scale by Owners 

You can scale the generation and load values by ownership by first clicking on the Owners button.  The Buses Table  
will be replaced with a new table listing the Owners in the case.  To choose owners to scale, double-click the Scale 
field to toggle the value between No and Yes.  As Scale fields are toggled to Yes, the Generator and Load MW and 
Mvar fields will update to display the totals for the selected owner.  When all of the desired owners have been 
selected, either the Scale By or the New Value  fields can be modified for a desired new value for the selected 
owners. 

To ensure that the reactive power is scaled proportionately to maintain the current load power factor, click the 
Constant P/Q Ratio option.  To enforce generator limits when scaling generation, check the Enforce Gen MW Limits 
option.  To scale generation and load to enforce ACE, check Scale Gen to Keep ACE Constant.  When Simulator 
scales generation, all generator power outputs at the selected buses are scaled by the specified factor, regardless of 
area control.  To scale only generators whose AGC field is set to YES only, check Scale Only AGCable Generation.  
To scale both in-service and out-of-service loads, check Scale Out-Of-Service Loads . 

Finally, click Do Scaling to scale the load and generation for the selected injection groups.  

Note: When scaling generators with multiple owners, the scaling will be done on the entire output of these generators, 
regardless of the fact that not all the owners have been set to scale.  If this is not a desired behavior, you can define 
multiple generators at the bus, each with 100% ownership. 

Facility Analysis  

Overview of Facility Analysis in PowerWorld Simulator 

Facility Analysis is used to study the topological redundancy of interconnect specific electric facilities. This application 
determines the minimum set of AC transmission lines and transformers that when opened or removed from the system 
would electrically isolate a set of Facility buses  from a set of External buses.  

The tool is an application of the augmenting path max flow min cut algorithm with modifications to handle electric 
networks.  

 

The Facility analysis process has two steps: 

1 The Select the Buses dialog is used to specify the External and Facility buses. Multiple selection of the External 
buses can be done using any of the area or zone selectors. The Facility buses are specified by setting the selected 
field of buses to YES. 

2 The Facility Analysis dialog is used to determine the Min Cut and visualize the branches that belong to the min cut.  

The Facility analysis application runs in edit mode and takes into consideration the open or closed status of the 
branches. Open lines are considered as not present in the system. The Figure below illustrates the functionality of the 
Facility Analysis tool.  
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Facility Analysis Dialog 

This dialog is used to determine the branches that would isolate the Facility from the External region as specified in 
the Select the Buses dialog. When switching to the Facility Analysis dialog, the application builds a graph data 
structure and reports information regarding the External Region and the Facility.  The Facility Analysis tool is only 
available in Edit Mode, and can be opened from the menu Options / Tools > Network Topology > Facility Analysis . 

External Region  

Is a set of buses from which the Facility would be isolated. Although the buses in the External region may not be 
adjacent to each other, the algorithm will assume that any of these buses can supply electricity to the Facility and 
thus the buses in the External region are considered to be connected. The External region is defined using the 
Select the Buses  dialog. 

External Region - Number of Buses  

Indicates the number of buses in the External region. This number is equal to the number of buses in the system 
that were labeled as External in the Select the Buses dialog. There should be at least one bus in the external 
region. 

External Region - Capacity 

Indicates the number of branches that connect the external buses to study buses in the system. This is the outgoing 
graph flow capacity from the External region toward the Facility. 

Facility  

Is the set of buses that constitute the Facility. Although the buses in the Facility may not be adjacent to each other, 
the algorithm will assume that any of these buses may receive power from the External region, and thus the Facility 
buses are considered to be connected to each other.  

Facility - Number of Buses  

Indicates the number of buses in the Facility. This number is equal to the number of buses in the system that were 
labeled as Study and whose selected field is set to YES. There should be at least one bus in the Facility. 

Note that if a bus was specified to be External and its selected field is YES, then the application will issue an error, 
since Facility buses cannot be in the External region. In such cases the status will indicate that the graph structure 
is incomplete. 

Facility - Capacity 

Indicates the number of branches that connect Facility buses with study buses. This number is equal to the 
outgoing graph flow capacity from the Facility toward the External region. 

Status  

Shows the status of the Facility Analysis application. If the External region and the Facility are specified, the status 
will indicate that the graph structure is ready. During execution of the Min Cut algorithm, the status shows the 
number of the augmenting paths found so far and the number of branches in the current path.  

Find Minimum Cut 

Press this button to initiate the Min Cut algorithm. The button is inactive if the graph structure is incomplete, i.e., 
there is either no external bus or facility bus, or facility buses were f ound inside the External region.  

Show Paths 

Toggle this button to visualize the augmenting paths at the bottom of the form. The augmenting paths are listed in 
the order in which they were found. Note that the first path has fewer nodes, since the algorithm uses a shortest 
(least number of nodes) path routine. For each augmenting path the number of buses in the path, as well as the 
corresponding bus numbers are listed in the dialog. This button is enabled only if a min cut has been found. 
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Augmenting Path Max Flow Min Cut Algorithm  

The augmenting path max flow – min cut algorithm is used to identify the minimum number of branches that need to 
be opened or removed from the system in order to isolate the Facility from the External region.  

The algorithm is an application of the Max Flow - Min Cut theorem, which states that the maximum flow that can be 
transferred from a set of source nodes to a set of sink nodes across a graph equals the capacity of the minimum cut. 
The facility analysis in Simulator finds a min cut, although this cut may not be unique. 

 

The application consists of three stages:  

1 Convert the electric ne twork to a graph structure 
In this stage, each branch of the system is converted to an undirected arc with graph flow capacity equal to one. 
Thus, only one unit of graph flow can be sent through a branch. The Facility buses and the External buses are 
converted to Facility and External supernodes, respectively. This effectively reduces the problem to finding the min 
cut between these two supernodes.   
The number of nodes and capacities of the Facility and the External region are also computed during this stage. 

2 Find the Max Flow using the Augmenting Path Algorithm  
This is an iterative process. At each step, the algorithm finds a new augmenting path from the Facility to the 
External region and augments the graph flow along this path in one unit. Consequently, the branches in the path 
won’t be available for flow augmentation in the next step. Each new path is determined using a shortest path 
routine.  
The algorithm stops when no augmenting path from the Facility to the External region can be found. The number of  
units transferred from the Facility to the External region (path augmentations) reaches the number of branches in a 
certain cut. Note that the number of branches in the min cut can not exceed the capacity of either the Facility or the 
External region.  

3 Determine the branches in the min cut 
The identification of the braches that constitute the min cut consists in tracking down labels in the buses and 
branches used during each path augmentation.  
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Graph Flow  

Most network and graph theory applications use the concept of flow to represent any object that can be transported, 
such as communication packets or trucks, but also connectivity properties of graphs. In the augmenting path max flow 
min cut algorithm the flow is an artificial concept used to represent topological connectivity of buses. Two buses are 
adjacent if flow can be sent from one to the other through a branch.  

 

Graph Flow Capacity of a Branch 

Networks that transport some flow are said to be capacitated if its arcs (here synonym of "branches") have some 
limit associated to the flow transportation. For instance, capacity of a communication channel, or number of trucks 
that can be simultaneously on a certain road. The algorithm used in the Facility Analysis assigns a capacity of one 
to each branch. This means that the branch can be used only once for "connecting" two nodes.  

Graph Flow Capacity of a Cut 

The capacity of a topological cut is equal to the sum of the capacities of its arcs. In the Facility Analysis, the 
capacity of the min cut is equal to the number of branches in the min cut, since each branch has a capacity of one. 
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Editing Oneline Diagrams 

Chapter 6 : Editing Oneline Diagrams 
The Format Menu is used in the Edit Mode to customize the appearance of the oneline diagrams.   

This chapter covers the following: 

• Edit Menu 

• Format Menu 

• Changing Fonts 

• Line and Fill Dialog 

• Other Display Object Properties 

• Background Color Dialog 

• The Drawing Grid 

• Zoom, Pan, and Find Dialog 

• Default Drawing Values 

• Inserting and Placing Multiple Display Fields 

Overview 

Edit Menu 

The Edit Menu allows most of the basic editing functions.  It is available only in Edit Mode.  The following commands 
are available on the Edit Menu: 

 

Cut  

Deletes the currently selected object(s) from display.  Cut objects are also copied into the paste buffer.   

Copy 

Copies the currently selected object(s) into the paste buffer without deleting them.    

Paste 

Copies the contents of the paste buffer (if any) onto the display at the current cursor location.   

Delete  

Deletes the currently selected object(s) from the display without also copying the object(s) to the clipboard. 

Select by Criteria  

Brings up the Select by Criteria Dialog which allows selection of many objects which meet a set of criteria.  For 
example, you could select all the 345 kV transmission lines in Area X and then change them to the color blue using 
the Format Selection Dialog. 

Select Region 

Allows you to select objects on the diagram by dragging a box around the objects you wish to select.  To form the 
box, left click and hold the mouse button down at the starting point, drag the mouse to form the box around the 
objects, and release the mouse button.  Only objects which fall ENTIRELY within the box will be selected. 

Selecting Objects  

Rectangle Selector 

You can use the Rectangle Selector button on the Edit Toolbar to select all objects in a particular region of the oneline. 
After clicking the Rectangle Selector button, click and hold the left mouse button on the oneline at the point where you 
would like to begin the selection.  Then, drag the mouse to size the selection rectangle.  Finally, let go of the mouse 
button once every object you need to select has been selected by the selection rectangle.  Handles will appear on 
every object located within the selection rectangle, indicating that they have been selected. 
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Select by Criteria Dialog 

Selecting Edit > Select By Criteria from the main menu brings up the Select By Criteria Dialog.  The Select By 
Criteria Dialog provides a way of selecting objects that meet a specific set of criteria.  The criteria may include Area 
Numbers, Zone Numbers, Voltage Levels, Zoom Levels, and Object Type. 

Use the dialog's controls to specify the selection criteria.  Use the Area and Zone fields to select the areas and zones 
in which you want to select display objects.  Ranges of area and zone numbers can be entered in the usual way, or 
you can check the All Areas  or All Zones boxes to select all areas and all zones.  Specify the max and min voltage 
levels for selected objects using the boxes that are provided, keeping in mind that all voltages are in kV.  Specify the 
layers for selected objects in the Layers tab. If not all the layers are selected, the Layers Range  option will be 
selected.  If the All Layers option is clicked, then all the layers will be selected.  Next, select the type of object in 
which you are interested from the supplied list.  To select items from this list, check the box next to the type of field(s) 
you desire.  Display object types that are followed by a right-arrow, such as Area Fields , are expandable, meaning that 
they have several associated subtypes.  If you checked a field type that has subtypes, you can highlight the type in the 
list to see the available subtype list.  You can then more specifically select subtypes that you wish to include.  By 
default, all subtypes of a general object type are selected. 

If you wish to select objects that do not have the chosen criteria, then check Select All Except What Meets the 
Above Criteria. 

If the Select by Criteria Dialog is open and some display objects have already been selected, an advanced selection 
option becomes available.  If the box labeled Use as a filter on presently selected objects  is checked, the criteria 
chosen in the Select by Criteria Dialog will only affect the previously selected objects.  In other words, only the objects 
that were previously selected AND that match the chosen criteria will remain selected when the OK button is pressed.  
For example, you could have used the Rectangular Selector to select a group of objects on the oneline.  Then using 
the Select by Criteria Dialog, choose the Bus criteria and check Use as a filter on presently selected objects  to 
select only the buses from the rectangular selected group of objects. 

Once you have selected the criteria and pressed OK, all objects that satisfy ALL the criteria will be chosen.  If the 
Select All Except What Meets the Above Criteria is unchecked, then the selected objects will lie within the specified 
areas AND zones, the specified voltage level, and the specified zoom levels, and will be of one of the drawing types  
specified. 

Using this dialog in conjunction with the Format Selection Dialog, can be a very fast and easy way to customize your 
displays. 

NOTE:  When choosing to select all tie lines, all objects associated with the tie line will also be selected.  This includes 
all line fields for the line as well as the two buses that are the endpoints of the line. 

Changing Basic Display Object Properties 

Grid/Highlight Unlinked Objects  

The Grid/Highlight Unlinked Objects tab is only available in Edit mode.  It controls the appearance of a grid in the 
oneline. A grid is not visible by default, but can be setup from the Grid/Highlight Unlinked Objects page of the Oneline 
Display Options dialog.  Additional options are available from this dialog for disabling anchors and highlighting 
unlinked objects on oneline diagrams. 

 

Snap Objects to Grid 

If checked, new objects placed on the oneline will be aligned with the grid; the grid does not need to be visible on 
the oneline to align objects to it. 

X Grid Spacing, Y Grid Spacing 

These determine the horizontal and vertical spacing of the grid. 

Display Grid Lines on Oneline  

If checked, the grid lines will appear on the oneline 

Horizontal Show Every, Vertical Show Every 

These numbers determine the density of the visible gridlines; for less lines enter higher numbers. 

Gridline Color 

Click in the rectangle to choose the color of the gridlines.  The default is grey. 

Anchor Options  

A check box is available for temporarily disabling anchors on a oneline diagram.  This option will disable the anchor 
properties of all objects on the oneline diagram. 

Do not prompt regarding relinking objects after dragging 

Check this check-box to avoid being prompted whether to relink a graphical object after this has been dragged. 

Highlighting of Unlinked Objects  

Highlight Unlinked Objects  with Color 
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Checking this box allows for any objects on all open oneline diagrams that are currently not linked to any data 
in the case to be highlighted using the highlight color.  To change the highlight color used, left-click in the color 
box to choose a different color. 

Minimum Highlighted Object Pixel Size 

The minimum size, in pixels, of the highlight image.  This is to prevent the highlight from being unnoticeable 
when the zoom level is very low. 

Extra Width for Highlighted Lines (pixels) 

Sets an extra width parameter, in pixels, for highlighting line objects.  This will make line object highlights 
appear wider than other highlighted objects. 
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Setting Background Color 

The Background Color Dialog changes the background color for the display.  To view this dialog, select 
Options/Tools > Oneline Display or right-click in the background of the oneline and select "Oneline Display Options" 
from the local menu.  Switch to the Display Options tab, click Change Background Color, or click on the colored 
rectangle to bring up the Color Dialog, which you can then use to select the new background color.  Click OK to 
register the new color.  The Oneline Display Options dialog will provide a preview of the color you selected.  To define 
this color as the default background color to use in all new onelines you create, click the Set as Default Background 
Color.  Finally, click OK to save your color selection.  
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Zoom, Pan, and Find 

The Zoom, Pan, and Find Options Dialog is used to specify a desired zoom level and screen location or to locate a 
particular bus or area/zone on the oneline.  The dialog can be opened by right-clicking on the background of the 
diagram and choosing Pan/Zoom Control from the oneline popup menu.  The dialog has the following fields: 

 

Find Objects on Oneline  

The Find Object on Oneline section of the dialog is used to pan to any desired bus object , area/zone object , branch 
object, interface object, or substation object on the oneline.  The dialog makes use of the advanced find functionality of 
Simulator to locate a device. 

Only Include Objects Visible at Current Zoom Level 

If checked (the default), then the Object ID combo box only lists those objects that are visible at the current zoom 
level. 

Object Type  

Select the type of object to find: Buses, Areas, Zones, Interfaces, Substations  and Lines/Transformers. 

Find By 

Specify whether you are entering the object by its number or by its name by choosing either Sort by Name or Sort 
by Number.  This option also determines how the entries in the list of objects are sorted (either by number or by 
name). 

Object ID 

Enter the object’s number or name (depending on the sort type chosen) or select the object from the list.   

Allow Auto Updating on Selection 

Check this box to automatically pan to the specified object.  The object will be located at the center of the oneline 
diagram.  This command does not change the zoom level. 

Pan to Object on Oneline  

Click this button to pan to the specified object if the Auto Updating box is not checked.  The object will be located at 
the center of the oneline diagram.  This command does not change the zoom level. 

Auto-Zoom when Panning 

Check this box to automatically change the zoom when panning to the specified object. 

 

Zoom / Pan 

The Oneline Zoom / Pan tab on this dialog is used to allow the user to specify either a new zoom level and/or screen 
center and to define these as the new display default settings.  The zoom level and screen center can also be 
changed from the keyboard.  Please see Oneline Zooming and Panning  for details.  

Zoom Level 

Enter the desired percentage zoom level (nominal is 100%). 

Horizontal, Vertical  

Enter a desired location for the center of the screen. The nominal screen center is 50 horizontal and 50 vertical.   

Restore Default Values  

Resets the zoom level and screen center to the default values. 

Set as Default Values 

Sets the current zoom level and screen center as the default values for the oneline.  The Pan/Zoom to New 
Location button must be clicked before this feature can be implemented. 

Pan/Zoom to New Location 

Changes the screen center and zoom level to the values specified in the above fields.   
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Default Drawing Values 

The Default Drawing Options Dialog allows you to see and change the various default values used to create new 
objects.  To show this dialog select Options/Tools > Default Drawing Values in Edit Mode. 



Editing Oneline Diagrams  

167 

Format Menu 

The Format Menu can be used to change the screen appearance of either individual objects or the entire display.  If no 
items are currently selected, the menu options on the Format Menu will be unavailable. 

Choosing any of the first three options offered by the Format Menu brings up the Format Selection Dialog.  The 
Format Selection Dialog is subdivided into four tabs that control different aspects of display objects, including font, line 
thickness and style, fill color, zoom levels and layers, and individual object size and display orientation. 

 

The Format Menu offers the following options: 

Font 

Select this option to change the font with which the selected objects are displayed.  The Font Tab of the Format 
Selection Dialog is displayed. 

Line/Fill 

Select this option to change the line thickness and style with which a display object is drawn, or the fill color for 
closed shapes.  The Line/Fill Tab of the Format Selection Dialog is displayed. 

Levels/Layers 

Select this option to change the stack level of an object, the layer the object is contained in, and optional settings for 
when an object should resize.  The Levels/Layers Tab of the Format Selection Dialog is displayed. 

Display/Size 

Simulator can change the attributes of the way multiple objects are displayed using this option, which opens the 
Display/Size page of the Format Selection Dialog.  The size of the objects can be adjusted, as well as the 
orientation of the object(s) from their terminal buses.  Objects can also be Anchored to their terminal buses or 
devices, or marked as Immobile, meaning the object(s) cannot be moved on the oneline diagram. 

Send to Back, Bring to Front 

The Send to Back and Bring to Front menu options govern the visibility of display objects that occupy the same 
screen stack level.  All objects have an associated screen stack level, which may be one of Base, Background, 
Middle, or Top.  Objects having a screen stack level of Top obscure all objects having stack levels of Middle, 
Background, or Base that occupy the same region of the screen.  They may or may not obscure objects having the 
same stack level of Top depending on the order in which the objects having the same stack level are drawn.  
Selecting Send to Back for a selected object will cause it to be obscured by all other same-level objects that occupy 
its location.  Selecting Bring to Front for a selected object will cause it to be drawn above all other same-level 
objects that occupy the same region of the screen.  The Send to Back and Bring to Front menu options govern 
relative placement of objects only within stack levels.  The Send to Back and Bring to Front options do not affect the 
relative placement of objects having different stack levels. 
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Format Multiple Objects  

The Format Selection Dialog features four tabs of controls for modifying the display attributes of selected objects.   

 

Font  

The Font Tab is used to change the font used in text/font objects.  

Line/Fill 

The Line/Fill Tab is used to change the line size, color, and style and the fill color with which the selected objects 
are drawn. 

Levels/Layers 

The Levels/Layers Tab is used to change the stack level of an object, the layer the object is contained in, and 
optional settings for when an object should resize. 

Display/Size 

The Display/Size Tab controls the size and orientation of the selected objects. 
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Font Properties 

The Font Tab allows you to define the font for the selected objects by choosing Font type, size, color and effects.  The 
page also allows you to control the default display font using the Make Default button.   

By clicking on Make Default, the current font name, size, and effects will be set as the default font for the display.  
This has the s ame effect as opening the Default Drawing Values and setting the default font.  

If a field is currently selected on the oneline diagram, the Include Suffix check-box will specify whether to include the 
corresponding field suffix.  If a number field is currently selected, the Total Digits in Field and Digits to Right of 
Decimal define the format of the number displayed by the selected field. 
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Line/Fill Properties 

The Line/Fill Tab is used to customize the line size/color and the fill color of selected objects.  You can view this tab by 
selecting Format > Line/Fill from the main menu.  This tab’s controls can be used to change the appearance of most, 
but not all, screen objects.  When you modify the line thickness or color of an object, these new values will be set as 
the default settings for all new line objects.  You can view the case defaults using the Default Drawing Options Dialog.  
The Line and Fill Options tab has the following fields/commands: 

 

Line Thickness 

Thickness of the line in pixels.   

Dashed 

Allows setting a line to appear as a dashed line on the diagram.  There are three types of line dashing to choose 
from in the drop down menu for this option. 

Note: Due to drawing limitations, the line thickness for a dashed line must be equal to 1.  Any other line thickness 
will result in the line being drawn as solid, regardless of the dashed setting. 

Line Color 

The Line Color field shows the current line color.  To change the line’s color, click on the box displaying the current 
line color, or click the Change Line Color button.  This displays the Color Dialog.  Select the desired color and 
select OK to change the color, or click Cancel if you do not wish to change the color. 

Line Color 2 

The Line Color 2 field applies only to transformer objects.  Transformers can be represented by different colors on 
each side of the transformer coils.  This is commonly used to color match each side of the transformer with the color 
used to represent the voltage level of the transmission system on each particular side of the transformer.  However, 
you can customize the colors for selected transformers by modifying them here.   

Note that the Line Color 2 field ALWAYS applies to the high voltage side of the transformer when you change 

Use Background Fill 

Click on this field to toggle whether or not to fill the background for the selected objects with the selected 
background fill color.  Only text objects such as Text, Bus Fields, Generator Fields, Load Fields, Switched Shunt 
Fields, Line Fields, Transformer Fields,  and Area Fields  and background objects such as Background Lines and 
Background Rectangles can be filled.   

Fill Color, Change Fill Color 

The Fill Color field shows the current fill color.  To change the fill color, click on the box that displays the current fill 
color, or click the Change button.  This displays the Color Dialog.  Click on the desired color and the select OK to 
change the color, or click Cancel if you do not wish to change the color. 
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Levels/Layers Options  

The Levels/Layers Tab is used to customize the stack level or layer an object is contained in.  To set layers for 
objects, select the objects on the oneline diagram (edit mode only) and then choose Format > Levels/Layers.  The 
Levels/Layers Options page of the Format Multiple Objects dialog will be displayed, with the following settings 
available. 

 

Stack Level 

An object’s stack level dictates what objects it will appear above, and which objects it will appear below on a oneline 
diagram.  For example, circuit breaker and pie chart objects have a default stack level of Top.  Therefore anything 
with a stack level of Middle, Background or Base will appear underneath pie charts and circuit breakers on the 
oneline diagram.  Objects that are within the same stack level and are drawn in the same location will result in the 
last object drawn being the visible object on the diagram.  You can toggle which elements within the same stack 
level at the same location is visible using the Send to Back and Bring to Front options of the Format Menu. 

Layers 

Layers are different than stack levels in that layers are designed to allow the user to filter the elements visible on a 
diagram (in run mode).  Initially all diagram objects are in the same layer, called Default.  This default layer cannot 
be modified or deleted.  However, you can introduce additional layers using the Define Layers button.   Clicking on 
Define Layers will open the Screen Layers list display, which will allow you to manage the layers defined for the 
diagram.  Once layers have been defined, you can choose which layer the selected objects belong to by choosing 
the Layer name from the drop-down list by clicking on the down arrow to the right of the layer name. 

Settings for resizing when zooming 

You can modify the maximum and minimum zoom levels at which the selected text fields will no longer resize.  Thus 
when zooming in or out on the diagram, text fields will resize according to the zoom level until the minimum or 
maximum zoom level are reached.  At that point, text fields will no longer resize, but will stay fixed at their current 
size as you continue to zoom. 

Maintain Fixed Screen Location (do not pan) 

This option is available for text fields.  When checked for selected text fields, these text fields will no longer pan 
when you pan the rest of the diagram.  This allows you to place text that will always be visible, regardless of what 
part of the diagram you are observing.  You can still move the individual text field itself in edit mode. 

Maintain Fixed Screen Size (do not resize on zoom) 

This option is available for text fields.  When checked for selected text fields, these text fields will no longer resize 
when the zoom level of the diagram is changed.  This allows you to place text that will always be visible at a 
constant size, regardless of what zoom level you are currently observing on the oneline diagram.  You can still 
select the text fields themselves in edit mode and change their font size. 
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Screen Layers 

The Screen Layers display can be invoked from either the Levels/Layers option of the Format menu in Edit Mode, or 
by right-clicking on the oneline diagram background and choosing Edit Screen Layers. 

Screen layers allow you a way to filter objects on a oneline diagram based on zoom level or which layer they are 
currently contained in.  Initially each object is in a common layer called Default, which cannot be modified or deleted.  
However, you can introduce new layers using this Screen Layers list display. 

Since the Screen Layers display is a Case Information Display, you can access many case information display 
features by right-clicking on the display to invoke the local popup menu.  Most importantly, this menu contains the 
options to Insert and Delete screen layers.   

To delete a screen layer, right-click on that layer in the display and select Delete from the popup menu.  The one 
exception is the Default layer, which cannot be deleted. 

To insert a new screen layer, right-click on a record in the display and choose Insert from the popup menu.  This will 
open the Screen Layer Options dialog for defining the options of the new layer you are inserting. 
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Screen Layer Options  

The Screen Layer Options are used to define options for new  layers, or modify options for existing layers.  Devices 
can be added to a layer by choosing the layer name from the drop-down list on the Levels/Layers Tab of the Format 
Multiple Objects dialog.  

 

Name 

Layers can have any name desired to describe the layer.  The default naming convention is "Layer #". 

Show Layer 

If this box is checked, any objects on the diagram which are contained in this layer may be visible.  This depends on 
the settings for low and high zoom level, described below.  If the box is unchecked, however, then any objects 
contained in this layer will be hidden.  Unlike Custom Display Detail, layers can be applied in both edit mode and 
run mode.  

Use Conditional Display by Zoom Level 

Objects can conditionally be displayed based on the settings  of their Layer and the current zoom of the oneline 
diagram.  Checking this box, and setting the Low Zoom Level and High Zoom Level fields, dictates at what zoom 
range the objects contained in the zoom level will be visible.  If the zoom level is outside the range defined, any 
objects belonging to the zoom level will be hidden.  This also applies to both edit mode and run mode. 
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Other Display Object Properties 

Use the Display/Size Tab of the Format Multiple Objects dialog to change the display size, orientation, anchor property 
of the selected objects.  To change the display size of the selected objects, modify the Size parameter.  To change the 
orientation of the selected objects, modify the Orientation setting.  To toggle whether or not the selected objects are 
anchored , check or uncheck the Anchored option.  To force the object to stay in the same position, check the 
Immobile  check-box. 

 

Number of Selected Objects  

This field shows the number of objects that are currently selected on the oneline.   

Cutting and Pasting 

Cut Command 

The Cut Command is used in the Edit Mode to delete the currently selected object(s).  To delete a set of objects, first 
select the objects.  Then select the Cut command from the Edit Menu.  For power system objects, such as buses, 
generators or transmission lines, you are given an option of whether to delete just the display object(s), or delete both 
the display object(s) and their underlying power system records.  See Relationship Between Display Objects and the 
Power System Model for further explanation of these choices.  To delete only the display object(s) and never the 
power system records from now on, select the Always Delete Object(s) On ly option.  You will not be prompted again.  
You can disable this selection on the Default Drawing Options Dialog.   

Unlike Delete, Cut also copies the selection into the paste buffer.   
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Copy Command 

The Copy Command copies the currently selected object(s) into the paste buffer  without deleting them.  For power 
system objects, such as buses, generators or transmission lines, you are given an option of whether to copy just the 
display object(s), or copy both the display object(s) and their underlying power system records.  See Relationship 
Between Display Objects and the Power System Model for further explanation of these choices.  To copy only the 
display object(s) and never the power system records from now on, select the Always Copy Object(s) Only option.  
You will not be prompted again.  You can disable this selection on the Default Drawing Options Dialog.   
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Paste Command  

The paste command copies the contents of the paste buffer (if any) onto the display at the current cursor location.  
Use the Paste  command from the Edit Menu.  Note that the paste buffer may contain both display objects and the 
underlying power system records.  When pasting, the display objects are pasted regardless of whether an identical 
display object already exists on the oneline.  In contrast, duplicate power system records are never pasted.  This is 
because, for example, it is acceptable to have two display objects referring to the same generator, but the generator 
exists only as a single entity in the power system model.  See Relationship Between Display Objects and the Power 
System Model for further details.   
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Delete Command 

The Delete Command is used in the Edit Mode to delete the currently selected object(s).  To delete a set of objects, 
first select the objects.  Then select the Delete command from the Edit menu.  For power system objects, such as 
buses, generators or transmission lines, you are given an option of whether to delete just the display object(s), or 
delete both the display object(s) and their underlying power system records.  See Relationship Between Display 
Objects and the Power System Model for further explanation of these choices.  To delete only the display object(s) 
and never the power system records from now on, select the Always Delete Object(s) Only option.  You will not be 
prompted again.  You can disable this selection on the Default Drawing Options Dialog.   

Unlike Cut, Delete does not copy the selection into the paste buffer.   
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Properties of Simulator Objects  

Chapter 7 : Properties of Simulator Objects  

This chapter provides a description of the properties of each of the Oneline Display Objects.  Note that when you are 
using the Simulator, you can obtain context sensitive help for oneline objects by positioning the cursor on the desired 
object and pressing the F1 key.  Of the many properties of the various objects in Simulator, some are relevant only to 
the Edit Mode, and some only to the Run Mode.  This chapter is divided into sections based on Edit Mode related 
properties, Run Mode related properties, and general properties. 

Edit Mode Properties and Information 

Zone Properties 

Zone Information (Edit Mode) 
The Zone Dialog is used in the Edit Mode to view information about a zone and to move one or more buses from one 
zone to another.  (See Zone Information (Run Mode) for help on the corresponding Run Mode version.)  To view this 
dialog, first select Case Information, Zones to view the Zone Records Display.  Then, right-click on the desired zone 
record and select Show Dialog to view this dialog.   

 

The dialog has the following fields: 

Zone Number 

Zone number between 1 and 999.  You can use the spin button immediately to the right of this field to move to 
either the next zone (click the up arrow) or the previous zone (click the down arrow).   

Zone Name 

Alphanumeric identifier for the zone of up to eight characters in length.  You can use this field to change the zone's 
name, provided you click either Save or OK.   

Find By Number 

To find a zone by its number, type the number in the Number field and click this button. 

Find… 

If you do not know the exact zone number you are looking for, you can click this button to open the advanced 
search engine. 

Labels  

To assign alternative identifying labels to the zone, click the Labels button. 

Zone Buses Table  

This table lists all of the buses in the zone.  Number, name, voltage, area number, and area name are shown for 
each bus.  This table can be used to move buses to a different zone.  Select the bus or buses you would like to 
move with the mouse.  Then, enter the Destination Zone Number, which is the zone to which you want to move 
the selected buses.  You may enter a zone number that does not already exist, too, so that the buses will be moved 
to a brand new zone.  In this case, be sure to provide the Zone Name, as well.  Finally, click the Move Selected 
Bus(s) to Destination Zone  button to implement the move.  

OK, Save, Cancel 

OK saves any changes to the zone name and closes the dialog.  Save saves any changes to the zone name, but 
does not close the dialog.  Cancel closes the dialog ignoring any changes.  

Bus Properties 

Bus Information (Edit Mode) 
This dialog is used to view/modify information about each bus in the system during Edit Mode.  It is very similar in 
content to its Run Mode counterpart. 

 

Bus Number 

Unique number between 1 and 99,999 used to identify the bus.  You can use the spin button immediately to the 
right of the number to move to the next bus (click the up arrow) or the previous bus (click the down arrow). 

Find By Number 

To find a bus by its number, enter the number into the Bus Number field and then click this button.   

Bus Name 

Unique alphabetic identifier for the bus consisting of up to eight characters.   

Find By Name 

To find a bus by its name, enter the bus name into the Bus Name field (case insensitive) and then click this button. 



Printed Documentation 

180 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected bus. 

Find… 

If you do not know the exact bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

OK, Save, and Cancel 

OK saves your changes and closes the dialog.  Save  saves your changes but does not close the dialog; this allows 
you to use, for example, the Find By Number command to edit additional buses.  Cancel closes the dialog without 
saving any changes.   

 

Bus Information 

Display Shape  

Sets the appearance of the bus object. 

Pixel Thickness 

Thickness of the bus in pixels.   

Display Size 

Specifies the length of a horizontal bus, height of a vertical bus, horizontal axis of an elliptical bus, or horizontal side 
length of a rectangular bus. 

Display Height 

Only visible if Display Shape is Oval or Rectangle.  Specifies the vertical axis of an elliptical bus or the vertical side 
length of a rectangular bus. 

Link to New Bus 

If you have right clicked on a bus and opened the bus information dialog, you could change the bus number in the 
Bus Number field and press this button to force the bus object on the diagram to link to the new bus number and 
information in the load flow data. 

Area Number 

Number of the bus’ area.  Each bus must be associated with an area record.  If a bus is specified as belonging to an 
area that does not already exist in the model, the new area is created.   

Area Name 

Alphabetic identifier for the bus’ area.  If the area already exists, you do not need to enter this value. 

Zone Number 

Number of the bus’ zone, between 1 and 999.  Each bus must be associated with a zone record. If a bus is 
specified as belonging to a zone that does not already exist in the model, the new zone is created.  Zones provide a 
useful mechanism for breaking up a large system.  Buses can be assigned to zones independent of their area 
assignments.  Thus, a single area could contain multiple zones, or a single zone could span multiple areas.  You 
can use the Zone Dialog  to list the buses in a particular zone and easily move a group of buses from one zone to 
another. 

Zone Name 

Alphabetic identifier for the bus’ zone.  If the zone already exists, you do not need to enter this value. 

Owner Number 

The number of the bus’ owner. 

Owner Name 

The name of the bus’ owner. 

Substation Number 

The number of the substation the bus is contained in. 

Substation Name 

The name of the substation the bus is contained in. 

Nominal Voltage  

The nominal voltage for the bus in kV. 

System Slack Bus  

Check only if the bus should be modeled as a system slack bus.  Each case requires at least one slack bus.   

Voltage (pu), Angle (degrees) 
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Current per-unit voltage magnitude and angle for the bus.  If you are inserting a new bus into an existing system, 
you should not change the initial per unit voltage values.  Rather, when you first switch to Run Mode, Simulator 
will estimate the voltage magnitude and angle at the new buses in such a way as to reduce the initial mismatches.  
This automatic estimation is only available if you have not modified the voltage in any way. 

 

Attached Devices   

Load Summary Information 

Displays the net MW and Mvar load at the bus.  You cannot change either of these fields from this display.  Select 
the Add or Edit Bus Load Records to view the individual load records for the bus via the Load Dialog. 

Shunt Admittance  

The real (G) and reactive (B) components of shunt compensation at the bus, expressed in MW and MVR, 
respectively. 

 

Fault Parameters 

The parameters on this tab are used when running a fault analysis study.  The values represent the total load at the 
bus for the negative and zero sequence as equivalent admittances.  By default, these values are zero.  For load 
buses, these values can be changed by the user, or they can be specified by loading short circuit data from within the 
Fault Analysis Dialog.  It is also possible to define these values as non-zero at a bus w here no load exists in the load 
flow, but it is not usually desirable to do so. 
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Bus Field Information 
Bus field objects are used primarily to indicate various quantities associated with bus devices.  Furthermore, some bus 
field types, which are distinguished by an integrated spin button, may be used to change bus device properties. 

The Bus Fields Information Dialog can be used to modify the properties of individual bus fields on the oneline.  The 
dialog displays the following fields: 

 

Find… 

If you do not know the exact bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

Bus Number 

Number of the bus associated with the field.  Use the dropdown box to view a list of all buses in the case with valid 
area/zone/owner filters.    

Bus Name 

Name of the bus associated with the field.  Use the dropdown box to view a list of all buses in the case with valid 
area/zone/owner filters.    

ID 

The ID field is used when showing generator or load fields.  Generator ID fields are single-character, whereas load 
ID’s are two characters in length. 

Total Digits in Field 

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Field Value  

The current value of the field being displayed. 

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Delta Per Mouse Click  

Bus fields can be used not only to show various fields associated with bus devices, but they can also be used to 
change some values.  This is accomplished using spin buttons shown to the right of the bus field.  When the up spin 
button is clicked, the bus field value is increased by the amount specified in the delta per mouse click field.  When 
the down spin button is clicked, the bus field value is decreased by  the same amount. 

This field is only used for fields of the following types: Load MW, Load Mvar, Setpoint Gen MW, and Switched Shunt 
Mvar.  Specifying a nonzero value in this field causes the integrated spin button to appear as part of the bus field on 
the oneline. 

Maintain Constant Load Power Factor 

This field only applies when you have chosen to display the Load MW for a bus, AND have set the Delta per Mouse 
Click to a non-zero value.  When this field is selected, changing the MW value for a bus load using the load spin 
button in run mode will automatically adjust the Load MVAR to keep the load power factor constant.  If this field is 
unchecked and the Load MW is changed using the spin button, the Load MVAR will remain unchanged. 

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

Anchored 

If the Anchored checkbox is checked, the bus field is anchored to its associated bus, which means that it will move 
with the bus. 

Rotation Angle in Degrees 

The angle at which the text will appear on the diagram. 

Type of Field 

Used to determine the type of bus field to show.  The following choices are available: 

Bus Name Name of the bus  

Bus Number Bus number (from 1 to 99,999) 

Bus Voltage Bus voltage magnitude 

Bus Angle Bus voltage angle in degrees 

Load MW Total MW load at the bus 
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Load Mvar Total Mvar load at the bus  

Switched Shunt Mvar Total Mvar capacitance at the bus  

Gen MW Output Total MW generation at the bus 

Gen Mvar Output Total Mvar generation at the bus 

Gen AGC Status AGC status of generator; status can be toggled in Simulator 

Gen AVR Status AVR status of generator; status can be toggled in Simulator 

MW Marginal Cost Bus MW marginal cost in $/MWh; available only with OPF 

Mvar Marginal Cost Bus Mvar marginal cost in $/Mvarh; available only with OPF 

MW Loss Sensitivity Increase in losses for 1 MW of generation over the nominal  

Gen Setpoint Voltage Voltage of generator on bus 

Select a Field Choose from any of 42 different fields 

Select OK to save changes and to close the dialog, or click Cancel to close the dialog without saving your changes.   
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Shortest Path Between Buses 
The Shortest Path Between Buses dialog provides a way to find the shortest electrical pathway between two buses in 
the power system.  To identify the shortest electrical path between buses, open the Bus Records display, right click on 
one of the bus' records you are interested in, and choose Find Shortest Path Between Buses from the local menu.  
When the Shortest Path Between Buses dialog opens, the first bus should be filled in for you.  Enter the bus number of 
the second bus in the second field, and then click Show Shortest Path Between Buses.  The result will be the list of 
the buses comprising of the shortest electrical connection between the two buses specified, in order from the starting 
bus to the ending bus. 

Substation Properties 

Substation Information (Edit Mode) 
The Substation Dialog is used in the Edit Mode to view information about a substation and to move one or more buses 
from one substation to another.  (See Substation Information (Run Mode) for help on the corresponding Run Mode 
version.)  To view this dialog, first select Case Information > Substations  to view the Substations Records Display.  
Then, right-click on the desired substation record and select Show Dialog to view this dialog.   

 

The dialog has the following fields: 

Substation Number 

An integer identifier for the substation.  You can use the spin button immediately to the right of this field to move to 
either the next substation (click the up arrow) or the previous substation (click the down arrow).   

Substation Name and ID 

Two alphanumeric identifiers for the substation.  You can use these fields to change the substation’s name or ID, 
provided you click either Save or OK. 

Find By Number 

To find a substation by its number, enter the number into the Substation Number field, then click this button. 

Find By Name 

To find a substation by its name, enter the name into the Substation Name field, then click this button. 

Find By Sub ID 

To find a substation by its substation ID, enter the ID into the Substation ID field, then click this button. 

Find… 

If the exact substation number, name and ID are not known, you can use the Find Dialog to search for and select a 
substation from a list of substations. 

Labels  

Clicking this button will open a dialog displaying the list of defined labels for the substation.  New labels can also be 
added for the substation from the dialog as well. 

Substation Buses Table  

This table lists all of the buses in the substation.  Number, name, voltage, area number and name, and zone 
number and name are shown for each bus.  This table can be used to move buses to a different substation.  Select 
the bus or buses you would like to move with the mouse.  Then, enter the Destination Substation Number, which is 
the substation to which you want to move the selected buses.  You may enter a substation number that does not 
already exist, too, so that the buses will be moved to a brand new substation.  In this case, be sure to provide the 
new substation a name and ID, as well.  Finally, click the Move Selected Bus(s) to Destination Substation button to 
implement the move. 

Substation Generators, Loads, and Switched Shunts Tables 

These tables list all of the generators, loads, and switched shunts in the subs tation.  Number, name, ID, status, and 
additional fields for each type of device are shown for each device. 

OK, Save, Cancel 

OK saves any changes to the substation name or ID, and closes the dialog.   

Save saves any changes to the substation name or ID, but does not close the dialog.   

Cancel closes the dialog ignoring any changes. 

Generator Properties 

Generator Information (Edit Mode) 
This dialog is used to view and modify the parameters associated with each generator in the system.  It can also be 
used to insert new generators and sometimes to delete existing generators.   

The Edit Mode version of the Generator Information Dialog is almost identical to the Run Mode version.   
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Bus Number 

Unique number between 1 and 99,999 used to identify the bus to which the generator is attached.   The dropdown 
list enumerates all generator buses in the case that meet the criteria established by area/zone/owner filters.   You 
may select a bus number directly from the dropdown list, or you may use the spin buttons to cycle through the list of 
generator buses.  

Bus Name 

Unique alphabetic identifier for the bus to which the generator is attached, consisting of up to eight characters.  Use 
this dropdown box to view a list of all generator bus names in the case with valid area/zone/owner filters.      

ID 

Two-character alphanumeric ID used to distinguish multiple generators at a bus; ‘1’ by default.   

Fuel Type  

Type of fuel used by the generator this model represents.  In most cases, this f ield is unnecessary for normal load 
flow analysis, and hence the default value is Unknown.  However, this value can be useful during the Security 
Constrained OPF analysis. 

Unit Type  

The type of unit the generator represents, such as combined cycle, steam, hydro, etc. 

Find By Number 

To find a generator by its number and ID, enter the number into the Bus Number field and the ID into the ID field.  
Then click this button.   

Find By Name 

To find a bus by its name and ID, enter the bus name into the Bus Name field (case insensitive) and the ID into the 
ID field.  Then click this button. 

Find… 

If you do not know the exact generator bus number or name you are looking for, you can click this button to open 
the advanced search engine. 

Status  

Status of the generator, either Closed (connected to terminal bus) or Open (not connected).  You can use this field 
to change the status of the generator.   

Area Name 

Alphabetic identifier for the terminal bus’ area. 

Same Owner as Terminal Bus  

Read-only check-box that indicates whether the generator’s owner is the same than the terminal bus’ owner. 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected generator. 

 

There are six additional areas of information on this dialog for specific aspects of generation: 

Display Information  

MW and Voltage Control 

Costs  

Fault Parameters  

Owners, Area, Zone  

Memo  
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Generator Field Information 
Generator field objects are used primarily to indicate various quantities associated with generation devices.  
Furthermore, some generator field types, which are distinguished by an integrated spin button, may be used to change 
generation device properties. 

The Generator Fields Information Dialog can be used to modify the properties of individual generator fields on the 
oneline.  The dialog displays the following fields: 

 

Find… 

If you do not know the exact bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

Bus Number 

Number of the bus to which the generator associated with the field is connected.  Use the dropdown box to view a 
list of all buses with generators in the case with valid area/zone/owner filters.    

Bus Name 

Name of the bus to which the generator associated with the field is connected.  Use the dropdown box to view a list 
of all buses with generators in the case with valid area/zone/owner filters.    

ID 

ID of the generator associated with the field. Generator ID are two-character alphanumeric fields. 

Total Digits in Field 

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Field Value  

The current value of the field being displayed. 

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Delta Per Mouse Click  

Generator fields can be used not only to show various fields associated with generation devices, but they can also 
be used to change some values.  This is accomplished using spin buttons shown to the right of the generator field.  
When the up spin button is clicked, the generator field value is increased by the amount specified in the delta per 
mouse click field.  When the down spin button is clicked, the generator field value is decreased by the same 
amount. 

This field is only used for fields of the following types: Setpoint Gen MW, Setpoint Gen Mvar, and Gen Setpoint 
Voltage.  Specifying a nonzero value in this field causes the integrated spin button to appear as part of the 
generator field on the oneline. 

Rotation Angle in Degrees 

The rotation angle at which the text field should be displayed. 

Anchored 

If the Anchored checkbox is checked, the generator field is anchored to its associated generator, which means that 
it will move with the generator.   

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

 

Type of Field 

Used to determine the type of generator field to show.  The following choices are available: 

Gen MW Output MW generation 

Gen Mvar Output Mvar generation 

Gen AGC Status AGC status of generator; status can be toggled in Simulator 

Gen AVR Status AVR status of generator; status  can be toggled in Simulator 

Gen Setpoint Voltage Voltage of generator on bus 

Select a Field Choose from any of the different generator fields 

Select OK to save changes and to close the dialog, or click Cancel to close the dialog without saving your changes.  
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Generator Information: Display 
This information is located on the Generator Information Dialog. 

 

Display Size 

The size of the generator. 

Scale Width with Size 

If checked, the Display Width will automatically be scaled to the appropriate setting when the Display Size is 
changed.  If unchecked, then only the length of the generator object will be affected by changing the value of the 
Display Size. 

Display Width 

The width of the display object.  This setting is automatically set if Scale Width with Size is checked and the value of 
the Display Size field is changed, or the Display Width value can be set manually to a new value. 

Pixel Thickness 

Thickness of the display object in pixels.   

Orientation 

Specifies the direction in which to draw the object.   

Anchored 

If checked, the object is anchored to its terminal bus.  See Anchored Objects for details. 

Link to New Generator 

Links the object to a different generator in the data. 
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Generator Information: Costs 
This information is located on the Generator Information Dialog. 

The cost data tab of the Generator Information dialog is used to show/change values associated with the cost of 
operation of the generator.  See Generator Cost Information for details.  Cost data can also be saved/loaded using the 
Generator Cost Data files.  

 

Cost Model 

Simulator can model generators as not having a cost model, or having either a cubic cost model or a piecewise 
linear model.  The cost model type you choose determines the content of the remainder of this dialog.   

Unit Fuel Cost 

The cost of fuel in $/MBtu.  This value can be specified for both cubic and piecewise linear cost curves.  However, 
while the fuel cost is an integral part of the cubic cost model (meaning it must be supplied and is always used during 
cost calculation,) it is not necessarily used for the piecewise linear cost models, as theoretically the fuel cost has 
already been included in the determination of the marginal costs entered at the MW break points.  However, it is 
good practice when defining the piecewise linear cost curves to also enter the fuel cost used when determining the 
marginal costs.  Thus if the fuel cost changes later on, you can change the fuel cost in this dialog, and Simulator 
has the capability to automatically scale the marginal costs in the piecewise linear curve to reflect the new fuel cost 
scaled from the previous fuel cost entered. 

Variable O&M  

Variable Operations and Maintenance costs can be entered.  This field only applies to the cubic model. 

Cost Shift, Cost Multiplier 

The cost shift and cost multiplier allow you to easily apply a shift to the cost function for the purpose of assessing 
how variations in bids impact profit.  The cost function is affected based on the following equation: 

(Original Cost Function + Cost Shift) * Cost Multiplier 

Cubic Cost Coefficients A, B, C, D 

For cubic cost models of the form C(Pgi) = (d*Pgi^3 + c*Pgi^2 + b*Pgi + a) * (fuel cost), specify the cost curve’s 
coefficients.  These coefficients can be specified only when you have chosen to use a cubic cost model. 

Piecewise Linear Table  

If you have chosen to use a piecewise linear cost model, a table appears that allows you to specify pairs of MW 
output levels and corresponding generator operating costs.  To insert a new point on the cost curve, right-click on 
the table and choose Insert New Point from the resulting local menu.   To delete an existing point from the cost 
curve, right-click on the table and choose Delete Point from the resulting local menu.  To edit an existing point in the 
table, simply enter your changes to the appropriate cells.  

Fixed Cost 

The fixed cost associated with operating the unit.  This cost is independent of the generator’s MW output level and 
is added to the cost prescribed by the piecewise linear model to obtain the total cost of operating the generator in 
$/MWHr.  This option can be specified only for piecewise linear cost models. 

Convert Cubic Cost to Linear 

Use this option to create a piecewise linear cost function from the cubic cost function specified by the coefficients A, 
B, C, and D and the fuel cost.  Specify the number of break points, and hence the number of segments, in the 
Number of Break Points  field.  Click the Convert to Linear Cost button to create the piecewise linear function that 
approximates the cubic cost function.  This action switches Cost Model option to Piecewise Linear and displays the 
Piecewise Linear Table  that identifies the piecewise linear curve’s breakpoints. 
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Generator Information: MW Control 
This information is located on the Generator Information Dialog. 

The MW Control grouping fields are used to show/change the values associated with the real power output of the 
generator.   

 

MW Output 

Current real power output of the generator. 

Minimum and Maximum MW Output 

Minimum and maximum real power output limits for the generator.  Simulator will not let the MW output go below its 
minimum value or above its maximum value if the Enforce MW Limits option is exercised.   

Enforce MW Limits  

If checked, the minimum and maximum MW limits are enforced for the generator, provided the Enforce Generator 
MW Limits  field is also checked on the Limits Tab of the PowerWorld Simulator Options Dialog.  If this box is 
checked and a generator is violating a real power limit, the generator’s MW output is immediately changed.   

Available for AGC 

Determines whether or not the generator is available for automatic generation control (AGC).  Normally this box 
should be checked.  However, there are times when you would like to control the generator output manually (such 
as if you are using the generator to remove a line limit violation), in which case you should leave this box 
unchecked.  A generator is also placed on "manual" control anytime you manually change its output.  You could 
then place the generator back on AGC control by using this dialog.   

Participation Factor 

The participation factor is used to determine how the real power output of the generator changes in response to 
demand when the generator is available for AGC and the area is on participation factor control.  When you open a 
case using the PTI Raw Data Format, this field is initialized to the per unit MVA rating of the generator, since 
participation factor information is not stored in the PTI format.  

MW Ramp Limit 

When running a simulation over time, the generator cannot change by more than this value per time step.  The 
global option for obeying generator ramp limits must be turned on. 



Printed Documentation 

190 

Generator Information: Voltage Control 
This information is located on the Generator Information Dialog. 

The Voltage Control grouping is used to show/change values associated with controlling the voltage/reactive power 
output of the generator.  

  

Mvar Output 

Current reactive power output of the generator.  You can manually change this value only if Available for AVR is 
not checked.   

Min and Max Mvar Output 

Specify the minimum and maximum allowable reactive power output of the generator.   

Available for AVR 

Designates whether or not the generator is available for automatic voltage regulation (AVR).  When the AVR field is 
checked, the generator will automatically change its reactive power output to maintain the desired terminal voltage 
within the specified reactive power range.  If a reactive limit is reached, the generator will no longer be able to 
maintain its voltage at the setpoint value, and its reactive power will then be held constant at the limit value.   

Use Capability Curve  

If checked, then the generator’s reactive power limits are specified using a reactive capability curve that prescribes 
the dependence of the generator’s reactive power limits on its real power output.  Otherwise, the fixed values given 
in the Min Mvar Output and Max Mvar Output fields are used.  The generator reactive capability can be defined 
using the table that appears at the bottom of the dialog.  Please see Generator Reactive Power Capability Curve for 
details.   

Regulated Bus Number 

Number of the bus whose voltage the generator is regulating.  This is usually, but not always, the generator’s 
terminal bus.  Multiple generators can regulate the same remote bus, but the regulated bus must not be another 
generator bus.  If the generator is at a slack bus , it must regulate its own terminal voltage.  Select Case 
Information, Others, Remotely Regulated Buses to view the Remotely Regulated Buses Dialog, which identifies 
all buses that are being remotely regulated. 

SetPoint Voltage  

Specifies the desired per unit setpoint voltage value the generator is to regulate at the regulated bus.  The regulated 
bus need not be the generator terminal bus. 

Remote Reg % 

This field is only used when a number of generators at different buses are regulating a remote bus (i.e., not their 
terminal buses).  This field then specifies the percentage of the total reactive power required by the remote bus to 
maintain its voltage that should be supplied by this generator.  The default value is 100. 
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Generator Information: Fault Parameters 
The parameters on this tab are used when running a fault analysis study.   

 

Generator MVA Base 

The assumed MVA base for the generator.  This value is used when calculating fault analysis values for the internal 
generator parameters. 

Neutral Grounded 

Check this check-box if the generator has the neutral grounded. 

Generator Step Transformer 

The resistance, reactance and tap setting for the generator step-up transformer, if one is being modeled internally 
with the generator.  By default, no internal transformer model is assumed. 

Internal Impedance  

These fields represent the internal impedance of the generator for all three sequences.  By  default, all three values 
are initially the same as the load flow internal impedance of the generator.  All three sets of values can be modified, 
either manually or by loading values from an external file using the Fault Analysis Dialog.   

Neutral-to-Ground Impedance  

Neutral-to-ground impedance for the generator.  These values get implemented with the zero sequence admittance 
matrix.  Note that the neutral-to-ground impedance will not be used, even if specified, if the original model for the 
generator implicitly models the generator step-up transformer.  This is because the implicitly modeled transformer is 
assumed to have a delta winding on the generator side of the transformer, which isolates the generator from the 
rest of the zero sequence network. 
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Generator Information: Owners, Area, Zone 
This information is located on the Generator Information Dialog. 

This tab is used to display or change the generator’s owner information, area information, and zone information 

 

Owners 

Currently, Simulator supports up to four owners for generators.  To add an owner of a generator, change one of the 
Owner fields to a new owner number, and update the owner percentages accordingly.  To modify an owner's 
percentage of ownership, simply modify the value in the percentage field for that owner.  If you set the percentage 
of an owner to 0, that owner will be removed from the list of owners for the device.  You can also remove an owner 
from owning part of a device by changing the owner field for that owner to 0.  Note that if you do not set the new 
owner percentages of all specified owners such that the total is 100%, Simulator will normalize the percentages 
such that the total is 100% when you click Save or OK on the generator dialog. 

Area Number, Area Name 

The area number and name to which the generator belongs.  Note that you can change the area of the generator to 
be different than the area of the terminal bus.  If you do so, you will be prompted to confirm that you wish to place 
the generator within a different area than that of the bus to which it is electrically connected. 

Zone Number, Zone Name 

The zone number and name to which the generator belongs.  Note that you can change the zone of the generator 
to be different than the zone of the terminal bus.  If you do so, you will be prompted to confirm that you wish to place 
the generator within a different zone than that of the bus to which it is electrically connected. 
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Generator Cost Information 
The cost associated with operating a generator varies according to the output of the generator, with the general rule 
that getting more power out of a generator cos ts more.  In Simulator, there are two options for modeling generator 
cost.  The first employs the common cubic relationship 

 Ci(Pgi)    =  ( ai  +  bi Pgi  +  c i (Pgi)
2
  +  di (Pgi)

3
 ) * fuel cost         $/Hour 

where Pgi is the output of the generator at bus i in MW.  The values ai, bi, ci, and di are used to model the generator's 
input-output (I/O) curve.  The I/O curve specifies the relationship between how much heat must be input to the 
generator (expressed in MBtu per hour) and its resulting MW output.  Normally, the cubic coefficients remain constant 
for a generator.  The last term in the equation is the fuel cost, expressed in $/MBtu.  This value varies depending on 
the fuel used in a generator.  Typical values would be $ 1.25/MBtu for coal and $ 2/Mbtu for natural gas.  The resultant 
equation is known as the fuel-cost curve.  The values of the a i, bi, ci, di, and the fuel cost can be viewed and modified 
using the Generator Information Dialog. 

Simulator can also model generator costs using a piecewise linear model consisting of pairs of MW output and 
incremental cost ($/MWhr) of generation, along with a fixed cost.  These piecewise linear curves must be convex 
curves, meaning the marginal cost of the current MW break point must be higher than the previous MW break point. 

Such curves can be defined using the Generator Information Dialog or by loading data from generator cost data files. 
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Set Generator Participation Factors 
Participation factor control is another of Simulator’s mechanisms for distributing an area’s responsibility to serve its 
load, losses, and interchange.  It is particularly well-suited to implementing automatic generation control (AGC) when 
you do not have good economic information for an area’s generators.  With participation factor control, the amount of 
power that each generator contributes to meeting its areas load, loss, and interchange responsibilities is controlled by 
the size of its participation factor.  The unit that has the largest participation factor contributes the most, and the unit 
that has the smallest participation factor contributes the least. 

The Set Generator Participation Factors Dialog gives you a convenient way to define the participation factors for 
multiple generators.  You can set the participation factor according to a number of different formulae and then apply 
this prescription to all generators in a specific area, all generators in a specific zone, all generators in the system, or all 
generators whose display filters are currently set to true. 

To display the Set Generator Participation Factors Dialog, you first need to open the Area Information Dialog and 
switch to the Options page. The Area Information Dialog has a button labeled Set Participation Factors that is 
enabled only if the Participation Factors is selected under the Area Control Options heading.  Set the area on 
participation factor control by selecting the Participation Factors option, and then press the Set Participation Factors 
option. 

The Set Generator Participation Factors Dialog is divided into two parts.  The first part, which occupies the top half of 
the form, allows you to indicate how the participation factors should be calculated or set for each generator.  Your 
options include: 

 

Max MW Rating of Generator The participation factor for each generator is set to the generator’s 
maximum MW capability. 

Difference Between Max and Current Output The participation factor for each generator is set to the generator’s 
reserve power, so that each generator partic ipates in proportion to 
how much it has left to contribute. 

Constant Value of The participation factor for each generator is set to the same hard-
coded value. 

File The participation factor for each generator is read from a file.  The 
first line of the file should contain the keyword NUMBERS or NAMES 
indicating whether generators are identified by bus number or by bus 
name in the file.  All subsequent lines should be comma-delimited 
and contain three fields: the number or name of the generator’s bus, 
the generator’s id, and the generator’s participation factor. 

 

If you choose any of the first three options, you then must tell Simulator to what generators you want to assign the 
participation factors.  To assign the participation factors to all generators in a specific area, select the All Generators 
in Area option, and then choose the area from the adjacent dropdown box.  If you want to assign the participation 
factors to all generators in a specific zone, select the All Generators in Zone  option, and then choose the zone from 
the adjacent dropdown box.  If you want to assign the participation factor to all generators in the system regardless of 
their area or zone affiliation, select the All Generators in System option.  Finally, if you want to assign the 
participation factor to just those generators whose display filter criteria evaluates to true, choose the All Generators 
With Valid Display Filters option. 

If you instead chose to read participation factors from a file, only those generators whose factors you read from the file 
will have their factors set by this action.  However, unless each generator’s associated area is set to control generator 
output using participation factor control, this information will be ignored.  To make sure that each generator’s area is 
set to participation factor control, check the Set Corresponding Areas to Participation Factor Control box.  Then, 
each corresponding area will be set to participation factor control. 
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Generator Reactive Power Capability Curve  
The reactive power output of most generators depends on the real power output of the generator.  This dependence is 
expressed using a reactive capability curve.  Simulator models the reactive capability curve using a piecewise linear 
approximation.  The reactive capability curve is modified on the generator dialog and can be saved/loaded using the 
Generator Reactive Capability Curve Auxiliary files.   

 

Modeling a Reactive Power Capability Curve From the Generator Dialog 

• • Make sure the Use Capability Curve checkbox is checked.   

• • In the table immediately below the checkbox, prescribe the reactive capability curve using up to 50 points.  
The points should be ordered by MW, in numerically increasing order.  At each point specify the MW value, the 
minimum reactive power value in Mvar, and the maximum reactive power value in Mvar.  The first point should 
correspond to the minimum MW output of the generator, while the last point should correspond to the maximum 
MW output. 

• • To insert a new point, click on the desired column, and then right-click to display the table's local menu.  
Select Insert Point. 

• • To remove a point, click on the desired column, and then right-click to display the table's local menu.  Select 
Delete Point.   

• • When finished be sure to select Save  to save your modifications.   

In the Run Mode, you can view the reactive power capability curve graphically by right-clicking on the generator to 
display its submenu and then selecting Reactive Capability Curve.   

Load Properties 

Load Information (Edit Mode) 
This dialog is used to view and modify the parameters associated with each load in the system.  It can also be used to 
insert new loads and sometimes to delete existing loads.  It is nearly identical in structure to its Run Mode counterpart. 

The Load Information Dialog can be used to inspect and modify the model of a bus load.  To view the Load 
Information Dialog, simply right-click on the load of interest and select Load Information Dialog from the resulting local 
menu.  The dialog has the following fields: 

 

Bus Number 

Unique number between 1 and 99,999 used to identify the bus  to which the load is attached.  The dropdown box 
provides a list of all load buses with valid area/zone/owner filters.   You can use the spin button to cycle through the 
list of load buses.  

When you insert objects graphically, the Bus Number and Bus Name fields are usually set automatically to the bus 
upon which you placed the object.  

Bus Name 

Unique alphabetic identifier for the bus to which the load is attached, consisting of up to eight characters.  The 
dropdown box lists the names of all load buses in the case with valid area/zone/owner filters.    

ID 

Two-character ID used to distinguish multiple loads at a bus.  By default, the load ID is equal to "1 ."  An identifier of 
‘99’ is used to indicate an equivalent load.   

Find By Number 

To find a load by its number and ID, enter the number into the Bus Number field and the ID into the ID field.  Then 
click this button.   

Find By Name 

To find a load by its name and ID, enter the bus name into the Bus Name field (case insensitive) and the ID into the 
ID field.  Then click this button. 

Find… 

If you do not know the exact load bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

Status  

Status of the load, either Closed (connected to terminal bus) or Open (not connected). You can use this status field 
to change the load’s status.   

Area Number, Area Name 

Number and name of the area the load is a member of. 

Zone Number, Zone Name 
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Number and name of the zone the load is a member of. 

Owner Number 

Number of the owner the load is a member of.  If the load owner is the same as the terminal bus owner, the Same 
Owner as Terminal Bus box will be checked.  Loads DO NOT have to be owned by the same owner as the 
terminal bus. 

Same Owner as Terminal Bus  

If this check-box is selected, the load owner is the same as the terminal bus owner, and the ability to change the 
load owner is dis abled. 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected load. 

OK, Save, Delete, and Cancel 

OK saves your changes and closes the dialog.  Save  saves your changes but does not close the dialog; this allows 
you to use, for example, the Find By Number command to edit additional loads.  Delete  deletes the current load. 
Cancel closes the dialog without saving your changes. 

 

Load Information 

MW and Mvar Value Fields  

The MW and Mvar Value fields are used to represent the amount of base real and reactive load at the bus.  Usually 
this load is modeled as being "constant power," meaning that the amount of load is independent of the bus voltage 
magnitude.  However, Simulator also permits modeling "constant current" load, for which the load varies in 
proportion to the bus voltage magnitude, and "constant impedance" load, for which the load varies in proportion to 
the square of the bus voltage magnitude.  Values in these fields are specified in MW and MVR assuming one per 
unit voltage.  All six fields can be modified by the user. 

Display Size 

Size of the load. 

Scale Width with Size 

If checked, the Display Width will automatically be scaled to the appropriate setting when the Display Size is 
changed.  If unchecked, then only the length of the generator object will be affected by changing the value of the 
Display Size. 

Display Width 

The width of the display object.  This setting is automatically set if Scale Width with Size is checked and the value of 
the Display Size field is changed, or the Display Width value can be set manually to a new value. 

Pixel Thickness 

Thickness of the display object in pixels. 

Orientation 

Specifies the direction to draw the object.   

Anchored 

If checked, the object is anchored to its terminal bus.  See Anchored Objects for details. 

Link to New Load 

Links the object to a different load record in the data. 

 

OPF Load Dispatch 

Benefit Model 

If this f ield is set to none, the load will not be dispatchable in the OPF solution.  If the option is set to Piecewise 
Linear, the load is dispatchable during the OPF, according to the following fields. 

Min. and Max.  MW Output 

Minimum and maximum load MW demand for OPF dispatch. 

Available for AGC 

If checked, the load will be available for redispatch during the OPF routine. 

Fixed Benefit 

Value of the load benefit at minimum demand. 

Piece-wise Linear Benefit Curve  
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This table allows you to specify pairs of MW demand levels and corresponding load benefit values, which in turn 
define the starting points and slopes of the piece-wise linear benefit curve segments.  To insert a new point on the 
cost curve, right-click on the table and choose Insert New Point from the resulting local menu.   To delete an 
existing point from the cost curve, right-click on the table and choose Delete Point from the resulting local menu.  To 
edit an existing point in the table, simply enter your changes to the appropriate cells. 
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Load Field Information 
Load field objects are used primarily to indicate various quantities associated with load devices.  Furthermore, some 
load field types, which are distinguished by an integrated spin button, may be used to change load device properties. 

The Load Fields Information Dialog can be used to modify the properties of individual load fields on the oneline.  The 
dialog displays the following fields: 

 

Find… 

If you do not know the exact bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

Bus Number 

Number of the bus to which the load associated with the field is connected.  Use the dropdown box to view a list of 
all buses with loads in the case with valid area/zone/owner filters.    

Bus Name 

Name of the bus to which the load associated with the field is connected.  Use the dropdown box to view a list of all 
buses with loads in the case with valid area/zone/owner filters.    

ID 

ID of the load associated with the field. Load ID fields are two characters in length. 

Total Digits in Field 

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Field Value  

The current value of the field being displayed. 

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Delta Per Mouse Click  

Load fields can be used not only to show various fields associated with load devices, but they can also be used to 
change some values.  This is accomplished using spin buttons shown to the right of the load field.  When the up 
spin button is clicked, the load field value is increased by the amount specified in the delta per mouse click field.  
When the down spin button is clicked, the load field value is decreased by the same amount. 

This field is only used for fields of the f ollowing types: Load MW and Load Mvar.  Specifying a nonzero value in this 
field causes the integrated spin button to appear as part of the load field on the oneline. 

Note that the Maintain Constant Load Power Factor option will allow you to specify a Delta per Mouse-click for 
the MW load, and when the MW value is changed in run mode, the MVAR load will also change in such a way as to 
keep the power factor of the load constant. 

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

Anchored 

If the Anchored checkbox is checked, the load field is anchored to its associated load, which means that it will move 
with the load. 

Rotation Angle in Degrees 

The angle at which the text is placed on the diagram, in degrees. 

 

Type of Field 

Used to determine the type of load field to show.  The following choices are available: 

Load MW MW load 

Load Mvar Mvar load 

Select a Field Choose from any of the different load fields  

Select OK to save changes and to close the dialog, or click Cancel to close the dialog without saving your changes.   
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Load Modeling 
Each load can be modeled as having voltage and/or time variation.  The voltage variation is modeled using the Base 
Load Model fields on the Load Information.   The time variation in the load is modeled using Area and Zone load 
variation schedules.  Thus the actual real and reactive value of each load is determined using the following equation:  

MW LoadMultiplier(t) * (SMW + IMW * V + ZMW * V * V) 

Mvar LoadMultiplier(t) * (SMvar + IMvar * V + ZMvar * V * V) 

where 

MW  current real power load in MW 

Mvar current reactive power load in Mvar 

SMW constant power MW value 

Smvar constant power Mvar value 

IMW constant current MW value (assuming 1.0 per unit voltage) 

Imvar constant current Mvar value (assuming 1.0 per unit voltage) 

ZMW constant impedance MW value (assuming 1.0 per unit voltage) 

Zmvar constant impedance Mvar value (assuming 1.0 per unit voltage) 

V per unit bus voltage magnitude 

The Load Multiplier field is a potentially time varying field.  Its value is given by  

LoadMultiplier(t)    (Case Load Multiplier) * (Area Schedule Value) * (Zone Schedule Value) 

The Case Load Multiplier allows you to scale all the loads in the case quickly and conveniently.  This value is specified 
on the Simulation Tab of the PowerWorld Simulator Options Dialog.   

The Area Schedule Value scales all of the loads in an area based upon a time-dependent schedule.  These values are 
defined as part of a load variation schedule that can be established or modified by using the Load Schedule Dialog.  
Each area can have an associated load schedule, which is identified in the Area Records Display.   

The Zone Schedule Value scales all of the loads in a zone based upon a time-dependent schedule.  These values are 
defined as part of a Load Variation Schedule that can be established or modified by using the Schedule Dialog.  Each 
zone can have an associated load schedule, which is indicated in the Zone Records display.   

Note that area and zone load schedules can also be saved to and loaded from Auxiliary Files.   

Line Properties 

Line/Transformer Information (Edit Mode) 
The Line/Transformer Information Dialog is used to view and modify the parameters associated with each transmission 
line and transformer in the system.  You can also insert new transmission lines and delete existing transmission lines 
from this dialog.  

The Edit Mode version of this dialog is very similar in content to its Run Mode counterpart. 

 

The Line/Transformer Information Dialog has the following fields: 

From Bus Number and Name 

From Bus  number and name.  For transformers, the from bus  is the tapped side.   

To Bus Number and Name 

To Bus number and name.   

Circuit 

Two-character identifier used to distinguish between multiple lines joining the same two buses.  Default is ‘1'.   

Find By Numbers 

To find a line or transformer by its bus numbers, enter the from and to bus numbers and the circuit identifier.  Then 
click this button.  Use the spin button to cycle through the list of lines and transformers in the system. 

Find By Names 

To find a line or transformer by the names of its terminal buses, enter the from and to bus names and the circuit 
identifier.  Then click this button. 

Find… 

If you do not know the exact from and to bus numbers or names you are looking for, you can click this button to 
open the advanced search engine. 

From End Metered 
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This field is only used for lines and transformers that serve as tie lines, which are lines that join two areas.  If this 
field is checked for a tie line, then the from end of the device is designated as the metered end.  Otherwise the to 
end is metered.  By default, the from end is metered.  The location of the metered end is important in dealing with 
energy transactions because it determines which party must account for transmission losses. 

Default Owner (Same as From Bus) 

Read-only check-box that indicates whether the line’s owner is the same than the from bus’ owner. 

From and To Bus Nominal kV 

Nominal voltage level of each terminal bus, in kV. 

From and To Bus Area Name 

Control area name in which each terminal bus is located. 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected branch. 

OK, Save, Delete, and Cancel 

OK saves your changes and closes the dialog.  Save  saves your changes but does not close the dialog; this allows 
you to use, for example, the Find By Number command to edit additional transmission lines.  Delete  deletes the 
current transmission line.  Cancel closes the dialog but does not save any changes.   

 

Parameters / Display 

Status  

Current status of the device.   

Resistance, Reactance, Charging (B) 

The resistance, reactance, and the total charging susceptance (that is, B, not B/2) of the device (in per unit).  

Limits  

Ratings for the transmission line or transformer in MVA.  Simulator allows the use of up to eight different limits sets. 

Line Shunts  

Select to view the Line Shunt Dialog.  This dialog is used to change the values of the line shunts.   

Calculate Per Unit Impedances 

Clicking this button will open the Line Per Unit Impedance Calculator dialog, which can be used to convert actual 
impedance and current limits to per unit impedance and MVA limits, and vice versa. 

Length 

If the length of the line is known, it can be entered here for informational purposes. 

Convert Line to Transformer 

Clicking this button turns the currently selected transmission line into a transformer, making the transformer specific 
fields available. 

Pixel Thickness 

Thickness of the display object in pixels.   

Anchored 

If checked, the object is anchored to its terminal bus, which means that it will move when you move the terminal 
bus.  See Anchored Objects for details. 

Link to New Line  

Use the Link to New Line button to create a new line corresponding to the entries you have made in the dialog.  
This button performs the same function as pressing Save.  Note that adding a new line to the case in this way does 
not add a transmission line to the oneline display; the new line is present only in the model.  You may then add the 
newly modeled line to the oneline diagram in the usual way (such as select Insert, Transmission Line  from the 
main menu). 

Symbol Segment 

Only visible for transformer and series capacitor objects.  This field specifies which "segment" of the branch 
contains the transformer or capacitor  symbol.  A segment constitutes a section of the line between vertex points of 
the line object, and are numbered starting at the from bus. 

Symbol Size 

Only visible for transformer and series capacitor objects.  Specifies the size (width) of the transformer or capacitor 
symbol on the branch. 

Symbol Percent Length 
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The distance or "length" of the symbol on the segment of the branch which contains it. 

 

Transformer Control 

This tab is only visible for transformer objects.  See Transformer Modeling for details on modeling either LTC or 
phase shifting transformers. 

 

Series Capacitor 

 

This tab is only visible for series capacitor objects.  See Series Capacitor Information for details on modeling a 
series capacitor. 

 

Fault Parameters 

The parameters on this tab are used when running a fault analysis study.  The values represent the zero sequence 
impedance and zero sequence line shunt admittances for the analysis.  By default, the positive and negative 
sequence line impedances and line shunt admittances are the same as the load flow impedance.  The same fields 
are used for transformers, along with the configuration field.  The configuration field defines the winding type 
combinations for the transformer (wye, delta, etc.)  As a default, Simulator assumes a grounded wye to grounded 
wye transformer, which has the same model as a transmission line.  Usually transformers are not of this type, and 
the proper type would need to be defined either manually or loaded from an external file in order for the fault 
analysis to be accurate. 

 

Owners 

Transmission elements can have up to four different owners, each with a certain owner percentage.  To add an 
owner of a transmission element, change one of the Owner fields to a new owner number, and update the owner 
percentages accordingly.  Note that if you do not set the new owner percentages of all specified owners such that 
the total is 100%, Simulator will normalize the percentages such that the total is 100% when you click Save  or OK 
on the  line/transformer dialog. 
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Line Shunts Information 
The Line Shunts Information Dialog is used to modify the parameters of transmission line shunts.  The modeling of the 
line shunts is explained below. 

 

Line Shunts  

Line shunts are included in the model as admittance-to-ground values at either the From end or the To end of a 
transmission line.  These values can represent many things, such as shunt-to-ground capacitors, reactors, zig-zag 
(or grounding) transformers, or equivalenced system values.  Line shunt values are entered in per unit, with a 
positive B corresponding to capacitors and a negative B corresponding to reactors.  Mathematically, the line shunts 
are included in the algorithm in the same manner that line charging capacitance is included using the Pi model. 

Line shunt values can be modified from the Transmission Line Information dialog. 
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Line Per Unit Impedance Calculator Dialog 
The Line Per Unit Impedance Calculator Dialog allows to convert actual impedance and current limit values to per unit 
impedance and MVA limit values, and vice versa. 

 

The dialog has the following elements: 

Actual Impedance and Current Limits  

This part of the dialog shows all the impedance related values in Ohms/length-unit as well as the transmission line 
limits specified in Amps.  If any of these values is modified, the corresponding per unit or MVA value will be 
changed accordingly, taking into consideration the current line length, length units, and system base values. 

Line Length 

This value indicates the length of the line in miles or kilometers, depending on the units selected in Length Units . 
The option When changing convert is used to convert the values when the length value is modified.  The option 
PU/MVA --> indicates that the actual impedance and current limits will be converted to per unit impedance and MVA 
limits when the length value is changes.  The option <-- Electrical specifies that the per unit impedance and MVA 
limits will be converted to actual impedance and current limits when the length value is modified. 

Length Units  

This option indicates the length units.  Choices are miles and kilometers.  When this parameter is changed, the user 
will be prompted to confirm to convert the actual impedance and current limits, as well as the line length values, 
from the old units to the new units.  If the answer is positive, then the actual impedance and current limits, and the 
line length will be the same but they will be expressed in the new units selected.  If the answer is negative, the 
values will not change numerically but they still will be expressed in the new units selected. 

System Base Values 

The system base values show the power base, the voltage base, and the impedance base.  These values can not 
be modified in this dialog. 

Per Unit Impedance and MVA Limits  

This part of the dialog shows all the impedance related values in per unit as well as the transmission line limits 
specified in MVA.  If any of these values is modified, the corresponding actual or Amps value will be changed 
accordingly, taking into consideration the current line length, length units, and system base values. 

Set Actual Impedance and Current Limits According to a Conductor Type  

With this option, the user can select a conductor type from the dropdown list and set the actual impedance and 
current limits to the determined values for the selected conductor. 
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Series Capacitor Information 
The Series Capacitor tab of the Line/Transformer Information dialog displays information relating to a series capacitor, 
including its status. 

 

Status  

The capacitor itself has two status positions, Bypassed and In Service .  When the series capacitor is in service, 
the branch is modeled as a reactive branch, using the line parameters from the Parameters / Display page.  If the 
capacitor is bypassed, a low impedance branch is introduced to bypass the capacitor.  Note that this is not the 
same as the branch status of Open or Closed.  The branch status is the indicator of whether or not the entire circuit 
is operating (closed), regardless of Bypassed or In Service  status on the capacitor itself. 

Is Series Capacitor 

If this box is checked, the branch can be treated as a series capacitor, with the series Status of Bypassed or In-
Service available. 
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Multi-Section Line Information 
Multi-section line records are used to group a number of series-connected transmission lines together so that their 
status is controlled as a single entity.  They are usually used to model very long transmission lines that require multiple 
individual transmission line records if they are to be modeled accurately.  In terms of line status, Simulator then treats 
each multi-section line as a single device.  In other words, changing the status of one line in the record changes the 
status of the other lines in the record, as well.   

Multi-section line records are not directly represented on the oneline diagrams.  Rather, to view this dialog, right-click 
the record of interest on the Multi-Section Line Records display and select Show Dialog from the resulting local menu.  
To define a new multi-section line, switch to Edit Mode and, from the Multi-Section Line Records display, right-click 
and select Insert from the resulting local menu. 

 

The Multi-Section Lines Dialog contains the following fields: 

From Bus Number and Name 

Number and name of the from bus for the record.  If you are defining a new multi-section line, this must be the first 
data item you specify. 

To Bus Number and Name 

Number and name of the "to" bus for the record.  You cannot specify this value directly.  Instead, use the table at 
the bottom of the dialog to define the intermediate buses and to terminal.  

Circuit 

Two character identifier used to distinguish between multiple records joining the same from/to buses.  The first 
character of the circuit identifier must be an "&."   

You can use the spin button immediately to the right of the circuit field to view other multi-section line records.  
However if you have changed the record, you must select Save  before moving to another record.  Otherwise, your 
changes will be lost. 

From End Metered 

If checked, the from end of the record is the metered end; otherwise the to end is metered. 

Multi-Section Line Name 

The name for the multi-section line. 

Table  

The table lists the dummy (or intermediate) buses and the to bus that comprise the record.  The first column should 
contain the first dummy bus number and the circuit ID of the transmission line joining the from bus  with the first 
dummy bus.  The next column should contain the second dummy bus number and the circuit id of the transmission 
line joining this bus to the first dummy bus.  Continue until the last column contains the to bus and the circuit ID of 
the transmission line joining the last dummy bus with the "to" bus.   

Each transmission line comprising the multi-section line must already exist.  If only one transmission line joins any 
two buses, you may omit the circuit identifier.   

OK 

Saves any modifications and closes the dialog.   

Save 

Saves any modifications but does not close the dialog. 

Cancel 

Closes the dialog without saving modifications to the current record. 

Delete  

Deletes the current multi-section line record. 

Help 

Displays this help page; you may also get help by pressing the F1 key from anywhere on the dialog.   

If any of the transmission lines comprising a multi-section line record are deleted, the entire multi-section line record 
is deleted as well.  
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Line Field Information 
Line field objects are used to show different values associated with transmission lines, transformers and dc lines.  This 
dialog is used to view and modify the parameters associated with these fields. 

 

Find… 

If you do not know the exact line identifiers you are looking for, you can click this button to open the advanced 
search engine. 

Near Bus Number 

Bus associated with the near end of the object.  All fields display values calculated at the near bus  end.  When 
inserting fields graphically, this field is automatically set to the closest bus on the oneline.   

Far Bus Number 

Bus associated with the far end of the object.   

Circuit 

Two-character identifier used to distinguish between multiple lines or transformers joining the same two buses.  
Default is ‘1’.   

Total Digits in Fields  

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Delta Per Mouse Click  

Only used with the MVA Limit field type.  Specifying a nonzero value for this field equips the MVA Limit Field with an 
integrated spin button that can be clicked to increment or decrement the MVA Limit by the amount of the Delta Per 
Mouse Click value. 

Field Value  

The current value of the field being displayed. 

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Rotation Angle in Degrees 

The angle at which the text will appear on the diagram. 

Anchored 

If checked, the line analog is anchored to its associated line.   

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

Type of Field 

Used to determine the type of line field to show.  The following choices are available: 

AC Line MW Flow MW flow into the line or transformer at the near bus 

AC Line Mvar Flow Mvar flow into the line or transformer at the near bus  

AC Line MVA Flow Magnitude of MVA flow into the line or transformer at the near bus  

AC Line Amp Flow Magnitude of Amp flow (in amps) into the line at the near bus 

AC Line MW Losses Real power losses on the line or transformer in MW 

AC Line Mvar Losses Reactive power losses on the line or transformer in Mvar 

DC Line MW Flow MW flow into the dc line at the near bus  

DC Line Mvar Flow Mvar flow into the dc line at the near bus 

MVA Limit MVA limit for the line or transformer 

DC Line Setpoint Set point value for the dc line; see DC Transmission Line dialog 

Select a Field Choose from over 80 different fields 

Select OK to save changes and close the dialog or Cancel to close the dialog without saving your changes.   
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Series Capacitor Fields Information Dialog 
Series capacitor field objects are used to show field values specific to series capacitors.  Use Line Fields to show 
fields generic to transformers, series capacitors and transmission lines, such as the flow of power through the device.  
The series capacitor fields dialog is used to view and modify the parameters associated with series capacitor specific 
fields. 

 

Near Bus Number 

Bus associated with the near end of the series capacitor. 

Far Bus Number 

Bus associated with the far end of the series capacitor.   

Circuit 

Two-character identifier used to distinguish between branches joining the same two buses.  Default is '1'.   

Total Digits in Field 

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Rotation Angle in Degrees 

The angle at which the text will be placed. 

Field Value 

The value of the currently selected field. 

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Anchored 

When checked, the text field will move with the series capacitor if the series capacitor is moved on the oneline 
diagram. 

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

Type of Field 

Designates the type of transformer field to show.  The following choices are available: 

Status Capacitor status  

Series Capacitance Capacitance of series capacitor 

Select OK to save changes and close the dialog or Cancel to close dialog without saving your changes. 
DC Line Information 

DC Transmission Line Information 
This dialog is used to view and modify the parameters associated with each two-terminal dc transmission line in the 
system.  It can also be used to insert new two-terminal dc transmission lines or to delete existing ones.  

This dialog has four separate pages: Line Parameters, Rectifier Parameters, Inverter Parameters, and Actual Flows.  
The Actual Flows page is not used in Edit Mode.  The separate pages can be accessed using the tabs shown at the 
top of the dialog.  These pages can be used to view/change the modeling parameters associated with the dc lines.  
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DC Line Information: Line Parameters 
This page is used to enter parameters associated with the dc line itself. 

 

Rectifier and Inverter Bus Numbers and Names 

These fields indicate the numbers and names of the rectifier and inverter ends of the line.  When graphically 
inserting a dc line, these fields are automatically determined based upon the starting and ending buses used in 
drawing the line.  When investigating existing dc line records, you may use the Find By Numbers button to identify a 
dc line between a specific rectifier - inverter pair.  You may also use the spin control to cycle through the list of dc 
line records modeled in the case. 

Circuit ID 

This field is not currently used, since only one dc transmission line can exist between each inverter-rectifier pair.  It 
is hard-coded to be 1. 

Area Name 

Names of the areas in which the rectifier and inverter buses are located. 

Control Mode  

The initial control mode for the line.  Specify Blocked to disable the dc line, Power to maintain specified MW power 
flow through the line, or Current to maintain specified current flow through the line.   

Setpoint 

If the line operates in the Power Control Mode, Setpoint should indicate the desired power flow in MW.  To specify 
power flow at the rectifier end, enter a positive value.  Enter a negative value to specify power flow at the inverter 
end.  If the dc line operates in Current Control Mode, enter the desired line flow in amps.   

Resistance  

Resistance of the dc Line. 

Sched. Voltage  

Scheduled dc line voltage in kV.  The value of Rcomp is used to determine whether this value specifies the inverter 
end or the rectifier end. 

Switch Voltage  

When the line operates in the  Power Control Mode, this is the inverter voltage level in kV at which the line switches 
from constant power to constant current control.   

Rcomp 

Compounding resistance.  The compounding resistance dictates whether the inverter voltage is scheduled (Rcomp 
= 0), or the rectifier voltage is scheduled (Rcomp = dc line resistance).  Simulator does not currently support 
scheduling the voltage at a point along the DC line (0 < Rcom < dc line resistance), but instead will treat any non-
zero value of Rcomp as scheduling the voltage at the rectifier. 

Status  

Initial status of the dc line. 
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DC Line Information: Rectifier Parameters 
This page is used to enter parameters associated with the rectifier end of the line. 

 

# of Bridges 

Number of valve bridges in series. 

Base Voltage  

Base ac voltage in kV on primary side of transformer. 

XF Ratio 

Transformer ratio. 

XF Tap 

Transformer tap setting. 

XF Min/Max Tap, XF Tap Step 

Transformer minimum and maximum tap settings, and the tap's step size. 

Commuting XF Resistance and Reactance 

Commuting resistance and reactance for the transformer, in ohms.   

Minimum, Maximum, and Actual Firing Angle  

Minimum, maximum, and actual values of the firing angle for the rectifier.   
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DC Line Information: Inverter Parameters 
This page is used to enter parameters associated with the inverter end of the line.  Entries are identical to the Rectifier 
Page, except here they are associated with the inverter. 

 

# of Bridges 

Number of valve bridges in series. 

Base Voltage  

Base ac voltage in kV on primary side of transformer. 

XF Ratio 

Transformer ratio. 

XF Tap 

Transformer tap setting. 

XF Min/Max Tap, XF Tap Step 

Transformer minimum and maximum tap settings, and the tap's step size. 

Commuting XF Resistance and Reactance 

Commuting resistance and reactance for the transformer, in ohms.   

Minimum, Maximum, and Actual Firing Angle  

Minimum, maximum, and actual values of the firing angle for the rectifier.   
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DC Line Information: Actual Flows 
Shows the ac tual real and reactive power flows into the line at the rectifier and the inverter, as well as the voltage at 
both ends (in kV) and the line current in amps.  The contents of this page are valid only when Simulator is in Run 
Mode. 

Multi-Terminal DC Line In formation 

Multi-Terminal DC Record Information 
This dialog is used to view and modify the parameters associated with multi-terminal DC records.  It is also used when 
inserting new multi-terminal DC records. 

The Multi-Terminal DC Record dialog can be used to inspect and modify the model of a multi-terminal DC network 
record.  To view the Multi-Terminal DC Record, simply right-click on the record of interest in the Multi-Terminal DC 
Record Display and select Show Dialog from the resulting popup menu.  The dialog has the following fields: 

 

Record Number 

Unique number between 1 and 999 which identifies the current multi-terminal DC record.  

Number of Devices 

Lists the number of DC buses, conv erters, and DC Lines that form the multi-terminal DC network. 

Control 

The control method used when solving the multi-terminal DC network.   

Controlling Converter 

The AC converter bus number where the DC voltage is being controlled. 

MTDC Network Status 

Status of the entire Multi-terminal DC network.  If this field is set to Closed, the entire DC subnetwork of the MTDC 
model is considered disconnected in the load flow case. 

DC Buses Tab 

This page of the dialog displays the DC bus records for the multi-terminal DC network.  The display on this page 
exhibits the same features as other case information displays.  To view the specific information for a DC bus, right-
click on the record of interest and choose Show Dialog from the popup menu. 

DC Converters Tab 

This page of the dialog displays the DC converter records for the multi-terminal DC network.  The display on this 
page exhibits the same features as other case information displays.  To view the specific information for a DC 
converter, right-click on the record of interest and choose Show Dialog from the popup menu. 

DC Lines Tab 

This page of the dialog displays the DC line records for the multi-terminal DC network.  The display on this page 
exhibits the same features as other case information displays.  To view the specific information for a DC line, right-
click on the record of interest and choose Show Dialog from the popup menu. 
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Multi-Terminal DC Bus Information 
This dialog is used to view and modify the parameters specific to multi-terminal DC network buses.  The dialog is also 
used to enter values for new multi-terminal DC buses when inserting a Multi-Terminal DC Record. 

To view the Multi-Terminal DC Bus Record dialog, right-click on a bus record in the DC Buses tab of the Multi-Terminal 
DC Record dialog and select Show Dialog from the resulting popup menu.  The dialog has the following fields: 

 

DC Bus Number, DC Bus Name 

The number and name identifiers for the selected DC bus. 

AC Bus Number 

The AC bus number connected to the DC bus through an AC / DC converter.  If the selected DC bus is a bus that is 
internal to the DC multi-terminal network (not directly connected to an AC bus,) this field will be 0. 

Area Number, Area Name 

The number and name identifiers of the control area the DC bus is contained in. 

Zone Number, Zone Name 

The number and name identifiers of the zone the DC bus is contained in. 

Ground Resistance  

Resistance to ground of the DC bus, entered in Ohms.  This field is currently only for storage of values supported by 
other load flow formats, and is currently not used by Simulator. 
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Multi-Terminal DC Converter Information 
This dialog is used to view and modify the parameters specific to multi-terminal DC network buses.  The dialog is also 
used to enter values for new multi-terminal DC buses when inserting a Multi-Terminal DC Record. 

To view the Multi-Terminal DC Bus Record dialog, right-click on a bus record in the DC Buses tab of the Multi-Terminal 
DC Record dialog and select Show Dialog from the resulting popup menu.  The dialog has the following fields: 

 

Converter Parameters 

Number of Bridges 

Number of bridges in series for the selected converter. 

Converter Type 

R for rectifier or I for inverter. 

Commutating Impedance 

Commutating impedance per bridge, in Ohms. 

Firing Angle Limits  

The maximum and minimum firing angle limits, in degrees. 

 

Transformer Parameters 

AC Base 

The primary base voltage, in kV. 

Transformer Ratio 

Actual transformer ratio. 

Tap Settings  

Displays the actual tap setting, the tap step, and maximum and minimum tap values for the converter transformer. 

 

Control Parameters 

Setpoint 

The setpoint control value at the converter.  For the voltage controlling converter, this field is set to 0.  For the 
remaining converters, this field displays MW when in Power mode, or Amps when in Current mode. 

Margin 

Rectifier margin, entered in per-unit of the DC power or current.  This field is currently only for support of other load 
flow formats, and is not used by Simulator. 

DC Participation Factor 

Converter participation factor.  This field is currently only for support of other load flow formats, and is not used by 
Simulator. 

Voltage  

The DC Voltage magnitude at the DC side of the converter. 

 

Solved Parameters 

Firing Angle  

The firing angle of the converter, as determined during the load flow solution. 

DC Current 

The calculated DC current at the converter DC terminal. 

MW, MVAR 

The real and reactive power delivered to (or absorbed from) the AC system by the converter. 
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Multi-Terminal DC Line Information 
This dialog is used to view and modify the parameters specific to multi-terminal DC network buses.  The dialog is also 
used to enter values for new multi-terminal DC buses when inserting a Multi-Terminal DC Record. 

To view the Multi-Terminal DC Bus Record dialog, right-click on a bus record in the DC Buses tab of the Multi-Terminal 
DC Record dialog and select Show Dialog from the resulting popup menu.  The dialog has the following fields: 

 

From and To DC Bus Number 

The DC bus numbers of the From and To buses in the multi-terminal DC network.  These fields must contain valid 
DC bus numbers of the selected multi-terminal DC record.  AC bus numbers from the load flow case are not 
acceptable bus numbers for a multi-terminal DC line. 

DC Circuit 

The circuit identifier for the DC line. 

DC Resitance and DC Inductance  

The resistance and inductance of the DC line.  Resistance is in Ohms, and is used for solving the load flow of the 
DC network.  The inductance is in milliHenries, and is not used for solving the load flow.  The inductance field is 
currently only for support of other load flow formats, and is not used by Simulator. 

Transformer Properties 

Transformer Modeling 
Transformers are used to transfer power between different voltage levels or to regulate real or reactive flow through a 
particular transmission corridor.  Most transformers come equipped with taps on the windings to adjust either the 
voltage transformation or the reactive flow through the transformer.  Such transformers are called either load-tap-
changing (LTC) transformers or tap-changing-under-load (TCUL) transformers.  

Another type of transformer is known as a phase-shifting transformer (or phase shifter).  Phase-shifting transformers, 
which are less common than LTC transformers, vary the angle of the phase shift across the transformer in order to 
control the MW power flow through the transformer.  This type of control can be very useful in controlling the flow of 
real power through a transmission system.   

 

Off-nominal Turns Ratio and Phase Shift Degrees 

The Line/Transformer Dialog displays several transmission line and transformer properties. For transformers, this 
dialog box also shows information about the LTC or phase shifter controls.  The Off-nominal Turns Ratio field 
indicates the voltage transformation, while the Phase Shift Degrees field show the phase shift angle.  If the 
transformer is not on automatic control, these values can be changed manually.  The off-nominal tap ratio 
determines the additional transformation relative to the nominal transformation.  This value normally ranges from 
0.9 to 1.1 (1.0 corresponds to no additional transformation).  For phase-shifting transformers the phase shift value 
normally ranges from about -40° to 40°.  The phase angle field can be non-zero for LTC and fixed transformers, 
most notably +/- 30° if the transformer configuration is a delta-wye or wye-delta configuration.  The transformer 
configuration is very important when performing a fault analysis study. 

 

When in Edit Mode, the dialog also reveals the type of transformer.  Valid types are 1) No Automatic Control (in which 
the taps are assumed fixed), 2) AVR (automatic voltage regulation), 3) Reactive Power Control, and 4) Phase Shift 
Control.  The type of transformer CANNOT be modified in the Run Mode.   

Simulator provides you with a great deal of flexibility in being able to specify which transformers will actually be used 
for automatic control in the Power Flow Solution.  For a transformer to be used for voltage or flow control, three criteria 
must be met. 

• • The transformer's Automatic Control Active  field must be checked on its Line/Transformer dialog.  This field 
can also be modified on the Transformer Records display.   

• • The transformer's area must have automatic transformer control enabled.  This is specified on the Options 
Tab of the Area Records display.   

• • Transformer control must not be disabled for the entire case.  This is specified on the Power Flow Solution 
Tab  of the PowerWorld Simulator Options Dialog. 

 

The area and case enforcement of transformer control are also accessible from the Run Mode Line/Transformer 
Dialog. 

Automatic Control 

The Automatic Control fields are only visible on the Edit Mode Line/Transformer Dialog. 

No Automatic Control 
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On this control setting the transformer will operate at the given off-nominal turns ratio and phase shift, and will 
remain fixed at those values during the entire solution process unless manually changed by the user. 

AVR (Automatic Voltage Regulation) 

When on automatic voltage control, the transformer taps automatically change to keep the voltage at the 
regulated bus (usually one of the terminal buses of the transformer) within a voltage range between the 
minimum voltage and maximum voltage values (given in per unit).  These values can be seen by clicking on the 
Automatic Control Options button.  Note that automatic control is possible only if a regulated bus has been 
specified.   

The tap position for an LTC transformer is indicated on the oneline by the number of tap step positions from the 
nominal position (i.e., the position when the off-nominal tap ratio is equal to 1.0).  When the off-nominal ratio is 
greater than 1.0, the transformer's tap is said to be in the "raise" position, and an 'R' appears after the number. 
Likewise, when the off-nominal ratio is less than 1.0, the transformer's tap is said to be in the "lower" position, 
and an 'L' appears after the number.  For example, with a step size of 0.00625 and an off-nominal ratio of 1.05, 
the tap would be in position 8R.  The tap position can be changed manually only when the transformer has 
been set off automatic voltage control.  For this case, clicking on the tap position with the left button raises the 
tap one step, while clicking on the tap position with the right button lowers the tap one step. 

Simulator will also detect instances when controlling transformers are in parallel, and will employ checks during 
the solution routine to prevent the controllers from fighting each other and potentially going to opposite tap 
solutions, which could result in unwanted loop flow through the transformer objects.  This option is enabled by 
default, but can be turned off in the Power Flow Solution General Options. 

Transformer Reactive Power Control 

When on automatic reactive power control, the transformer taps automatically change to keep the reactive 
power flow through the transformer (measured at the from bus) within a user-specified range.  The reactive 
power control parameters can be seen by clicking the Automatic Control Options button.   

Phase Shift Control 

When a transformer is on phase shift control, the transformer phase shift angle automatically changes to keep 
the MW flow through the transformer (measured at the regulated bus end) between the minimum and maximum 
flow values (given in MW, with flow into the transformer assumed positive).  The limits on the phase shifting 
angles are specified in the minimum and maximum phase fields (in degrees).  These values can be seen by 
clicking on the Automatic Control Options button.  The phase shift angle changes in discrete steps, with the 
step size specified in the Step Size field (in degrees). The MW Per Phase Angle  Step Size provides an 
estimate of the change in the controlled MW flow value if the phase angle is increased by the step size value.   

Specify Transformer Bases and Impedances 

Shows the Transformer Bases and Impedances Dialog.  This dialog allows the user to specify the transformer 
parameters in per unit on the transformer base (taken as its rating).  Click OK to convert all the transformer 
parameters values to the system base specified in the General Power Flow Solution Options. 
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Transformers Bases and Impedances Dialog 
Typically the impedances and tap values of transformers is already assumed to have been converted to unity tap base 
and bus nominal voltage base.  However, some load flow formats provide the taps and impedances on specific 
transformer bases, which are different than the bus voltage and unity tap base assumptions.  In these cases, 
Simulator will convert parameters from the transformer bases to the unity tap and bus nominal voltage base.  Display 
of the impedances and tap values normally displayed in the Line/Transformer Options dialog are displayed on the 
Simulator assumed bases.  However, if you wish to view the original transformer values on the transformer supplied 
bases, this dialog will display the original values.  You can modify the original values stored here in this dialog.  Note 
that when you do so, the converted values that Simulator stores on the system bases will also be automatically 
updated to reflect the change that has been made to the original values on the transformer bases. 



Properties of Simulator Objects 

217 

Transformer Impedance Correction Table Display 
The Transformer Impedance Correction Display shows information about all the transformer impedance correction 
tables in the case.  The Transformer Impedance Correction Display is used to model the change in the impedance of 
the transformer as the off-nominal turns ratio or phase shift angle is varied.   

The Correction Display is a class of Case Information Display and therefore can be used in a manner consistent with 
all other case information displays.   It has a local menu from which you can print, copy, and modify its information as 
well as view the information dialog of its associated correction tables.  When in Edit Mode, you can define new tables 
using the Insert option, or delete existing tables using Delete.  You can also sort the transformer impedance correction 
information by clicking on the heading of the field by which you want to sort.  

To show this display select Case Information > Other > Transformer Impedance Correction Tables. 

 

The display contains the following fields by default: 

Table  

Shows the table number for the record.  Table number must be between 1 and 64.  Each table record occupies two 
lines on the display. 1, 2, …  11 

Transformer Impedance Scaling Factors 

The next eleven columns show the actual fields in the table.  The first line shows the off-nominal turns ratio, or 
phase shift angle, while the second line shows the associated scaling factor for the transformer’s impedance.  
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Transformer AVR Dialog 
The Transformer AVR Dialog is used to view the control parameters associated with load-tap-changing (LTC) 
transformers when they are used to control bus voltage magnitudes.  To view this display, click the Automatic Control 
Options button on the Line/Transformer Information Dialog.  Note that the button will not respond to the click if the No 
Automatic Control  option is selected under the Automatic Control  group. 

 

This dialog has the following fields: 

Regulated Bus Number 

The number of the bus whose voltage is regulated by the control. 

Current Regulated Bus Voltage  

The present voltage of the regulated bus. 

Voltage Error 

If the regulated bus' voltage falls outside the regulating range of the transformer (as defined by the Minimum 
Voltage and Maximum Voltage fields), the Voltage Error field indicates by how much the voltage deviates from the 
control range. 

Minimum Voltage  

The minimum acceptable voltage at the regulated bus. 

Maximum Voltage  

The maximum acceptable voltage at the regulated bus. 

Current Tap Ratio 

The tap ratio of the transformer for the current system state. 

Minimum Tap Ratio, Maximum Tap Ratio 

Minimum and maximum allowable off-nominal tap ratios for the LTC transformer.  Typical values are 0.9 and 1.1.   

Tap Step Size 

Transformer off-nominal turns ratio increment.  The off-nominal turns ratio is either incremented or decremented 
from 1.0 in integer multiples of this value.  Default value is 0.00625.   

Voltage to Tap Sensitivity 

Shows the sensitivity of the voltage magnitude at the regulated bus to a change in the transformer's tap ratio.  You 
can use this field to assess whether or not the transformer can effectively control the regulated bus voltage.  In an 
ideal case, such as when the LTC transformer is being used to control the voltage at a radial load bus, the 
sensitivity is close to 1.0 (or -1.0 depending upon whether the tapped side of the transformer is on the load side or 
opposite side of the transformer).  However, sometimes the transformer is very ineffective in controlling the voltage.  
This is indicated by the absolute value of the sensitivity approaching 0.  A common example is a generator step-up 
transformer trying to control its high-side voltage when the generator is off-line.  Simulator automatically disables 
transformer control if the transformer sensitivity is below the value specified on Power Flow Solution Tab  of the 
PowerWorld Simulator Options dialog.     

Impedance Correction Table  

This field specifies the number of the transformer's corresponding transformer impedance correction table.  
Transformer impedance correction tables are used to specify how the impedance of the transformer should change 
with the off-nominal turns ratio.  If this number is 0, then no impedance correction table is associated with the 
transformer, and the impedance of the transformer will thus remain fixed as the tap ratio changes.  Valid impedance 
correction table numbers range from 1 to 63.  To assign an existing impedance correction table to the transformer, 
enter the existing table's number.  To view the existing impedance correction tables, click the Insert/View 
Impedance Correction Table button, which brings up the Transformer Impedance Correction Dialog.  To define a 
brand new impedance correction table for the transformer, enter an unused table number and then click Insert/View 
Impedance Correction Table to prescribe the correction table.  Note that the association between a transformer and 
an impedance correction table is not finalized until you select either OK or Save on the Line/Transformer Dialog. 

View Transformer Correction Table or Insert Transformer Correction Table  

Click on this button either to view or to insert transformer correction tables.  Clicking on this button displays the 
Transformer Impedance Correction Dialog.  Note that the table must prescribe at least two points in order to be 
defined. 
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Transformer Mvar Control Dialog 
The Transformer Mvar Control dialog is used to view the control parameters associated with load-tap-changing (LTC) 
transformers that are used to control the Mvar flow through the transformer.  To view this display, click on the 
Automatic Control Options  button on the Line/Transformer Information Dialog.   

When used to control reactive power, the LTC transformer always controls the reactive power flow at the from end of 
the transformer (i.e., the tapped side), with positive flow assumed to be going through the transformer to the to bus.  
Therefore the regulated bus field is not used.   

 

The dialog has the following fields: 

Mvar Flow at From Bus 

The current Mvar flow as measured at the from end of the line.  This is the parameter the transformer tries to 
control. 

Mvar Error 

If the Mvar flow at the from end violates the limits defined by the Minimum Mvar Flow and Maximum Mvar Flow 
fields, the Mvar Error field indicates by how much the flow falls outside the control range.  

Minimum Mvar Flow, Maximum Mvar Flow 

Minimum and maximum allowable reactive power flow as measured at the from bus.  The transformer attempts to 
regulate the reactive flow to fall within this range. 

Current Tap Ratio 

The transformer's present off-nominal turns ratio.   

Minimum Tap Ratio, M aximum Tap Ratio 

Minimum and maximum allowable off-nominal tap ratios for the LTC transformer.  Typical values are 0.9 and 1.1.   

Tap Step Size 

Transformer off-nominal turns ratio increment.  The off-nominal turns ratio is either incremented or decremented 
from 1.0 in integer multiples of this value.  Default value is 0.00625.   

Mvar to Tap Sensitivity 

The amount of Mvar shift that would be implemented by switching one tap position from the current position.  This 
sensitivity indicates the ability of the transformer to control Mvars. 

Impedance Correction Table  

Specifies the number of the transformer's corresponding transformer impedance correction table.  Transformer 
impedance correction tables are used to specify how the impedance of the transformer should change with the off-
nominal turns ratio.  If this number is 0, no impedance correction table is associated with the transformer, and the 
impedance of the transformer will thus remain fixed as the tap ratio changes.  Valid impedance correction table 
numbers range from 1 to 63.  To assign an existing impedance correction table to the transformer, enter the existing 
table's number.  To view the existing impedance correction tables, click the Insert/View Impedance Correction Table 
button, which brings up the Transformer Impedance Correction Dialog.  To define a brand new impedance 
correction table for the transformer, enter an unused table number and then click Insert/View Impedance Correction 
Table to prescribe the correction table.  Note that the association between a transformer and an impedance 
correction table is not finalized until you select either OK or Save on the Line/Transformer Dialog. 

View Transformer Correction Table or Insert Transformer Correction Table  

Click on this button either to view or to insert transformer correction tables.  Clicking on this button displays the 
Transformer Impedance Correction Dialog.  Note that the table must prescribe at least two points in order to be 
defined. 
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Transformer Phase Shifting Information 
The Transformer Phase Shifting Dialog is used to view the control parameters of phase-shifting transformers.  To view 
this display, click on the Automatic Control Options  button on the Line/Transformer Information Dialog, provided that 
the Phase Shift Control option is chosen from the Automatic Control group. 

 

Regulated Bus Number 

Number of the terminal bus of the phase shifter regulated by the phase shifter.  When control is active, the phase 
shifter will automatically change its phase shift to keep the MW flow at this bus at the desired value. 

Current MW Flow  

Current MW flow through the transformer measured at the regulated bus terminal.   

MW Error 

If the current MW flow falls outside the minimum/maximum MW flow limits, the MW Error field indicates by how 
much the flow violates the regulating range. 

Minimum MW Flow, Maximum MW Flow 

Minimum and maximum allowable MW flow through the phase shifter. 

Current Phase Angle (Degrees) 

The phase angle of the transformer for the current solved system state.   

Minimum Phase Angle, Maximum Phase Angle  

Minimum and maximum allowable phase shift in degrees.  

Step Size (Degrees) 

Phase shift change per step in degrees. 

MW Flow to Phase Sensitivity 

The sensitivity of the controlled MW flow to changes in the transformer's phase.  This sensitivity indicates the 
transformer's ability to regulate its MW flow. 

Impedance Correction Table  

Specifies the number of the transformer's corresponding transformer impedance correction table.  Transformer 
impedance correction tables are used to specify how the impedance of the transformer should change with the off-
nominal turns ratio.  If this number is 0, no impedance correction table is associated with the transformer, and the 
impedance of the transformer will thus remain fixed as the tap ratio changes.  Valid impedance correction table 
numbers range from 1 to 63.  To assign an existing impedance correction table to the transformer, enter the existing 
table's number.  To view the existing impedance correction tables, click the Insert/View Impedance Correction Table 
button, which brings up the Transformer Impedance Correction Dialog.  To define a brand new impedance 
correction table for the transformer, enter an unused table number and then click Insert/View Impedance Correction 
Table to prescribe the correction table.  Note that the association between a transformer and an impedance 
correction table is not finalized until you select either OK or Save on the Line/Transformer Dialog. 

View Transformer Correction Table or Insert Transformer Correction Table  

Click on this button either to view or to insert transformer correction tables.  Clicking on this button displays the 
Transformer Impedance Correction Dialog.  Note that the table must prescribe at least two points in order to be 
defined. 
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Transformer Fields Information Dialog 
Transformer field objects are used to show field values specific to transformers.  Use Line Fields to show fields generic 
to transformers and transmission lines, such as the flow of power through the device.  The transformer fields dialog is 
used to view and modify the parameters associated with transformer-specific fields. 

 

Near Bus Number 

Bus associated with the near end of the transformer. 

Far Bus Number 

Bus associated with the far end of the transformer.   

Circuit 

Two-character identifier used to distinguish between transformers joining the same two buses.  Default is '1'.   

Find… 

If you do not know the exact transformer you are looking for, you can click this button to open the advanced search 
engine. 

Total Digits in Field 

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Delta per Mouse Click  

This value is used only with the Off-nominal Tap Ratio and Phase Shift Angle  field types.  When there is a 
nonzero entry in this field, and the field type is valid, a spin button is shown to the right of the zone field.  When the 
up spin button is clicked, the field value is increased by this number; when the down button is clicked, the field value 
is decreased by this amount.  

Field Value  

Shows the current output for the transformer field.  Whenever you change the Type of Field selection, this field is 
updated.   

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Rotation Angle in Degrees 

The angle at which the text is to appear on the oneline diagram. 

Anchored 

When checked, the text field will move with the transformer if the transformer is moved on the oneline diagram. 

Include Suffix 

If  the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

Type of Field 

Designates the type of transformer field to show.  The following choices  are available: 

Off-nominal Tap Ratio Actual tap ratio 

Phase Shift Angle Actual phase shift in degrees  

Off-nominal Tap Position Tap position in steps, usually ranging from L16 to R16 

Automatic Control Status The status of the control for the transformer 

Select OK to save changes and close the dialog or Cancel to close dialog without saving your changes. 
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Three Winding Transformer Information 
The Three Winding Transformer Dialog is used to create, modify or delete three winding transformer records in Edit 
Mode, or to view information for a specific three winding transformer record in run mode.  Note that all the values 
displayed on this dialog are on the system MVA base.  If the records were created them from a file, the values are 
automatically converted to the system base.  If a three winding transformer record is entered manually, the parameters 
need to be entered into Simulator computed with the same system MVA base Simulator is using.   

 

This dialog has the following controls: 

Primary Winding 

This section of the dialog displays the primary winding terminal bus number, nominal kV, and fixed tap value (in per 
unit).  In addition, the automatic tap changer is assumed to be on the primary winding of a three winding 
transformer.  Therefore the LTC field displays the tap changer tap value (in per unit) on the primary winding. 

Secondary Winding 

This section of the dialog displays the secondary winding terminal bus number, nominal kV, and fixed tap value (in 
per unit). 

Tertiary Winding 

This section of the dialog displays the tertiary winding terminal bus number, nominal kV, and fixed tap value (in per 
unit). 

Star Bus (Internal Node) 

This section of the dialog displays the internal node parameters of the three winding transformer model.  Three 
winding transformers are modeled as three two winding transformers connected at the three winding transformer 
terminal buses to a common or internal node, referred to as the star bus.  The parameters displayed for the star bus 
are the bus number, voltage (in per unit), and angle. 

Primary-Secondary, Secondary-Tertiary, and Tertiary-Primary Impedance  

These are the actual three winding transformer winding to winding impedances, in per unit on the system base.  
These values are used to compute the equivalent two winding transformer impedances for the two winding 
transformers used to model the three winding transformer operation. 

Circuit ID 

The circuit identifier for the three winding transformer. 

Status  

The status of the three winding transformer.  If checked, the three winding transformer model is in service, 
otherwise the equivalent model is treated as out of service. 

Mathematically equivalent two-winding transformers 

This table displays the three two winding transformers that are mathematically equivalent representations of the 
three winding transformer.  If you read the three winding transformer record from a file, the two winding equivalent 
transformers are created automatically.  If you are inserting a three winding transformer manually, you can set the 
parameters for the primary, secondary and tertiary windings in the fields above, then click the Set Two-Winding 
Equivalent Transformers button to have Simulator automatically create the two winding transformer records for 
you.  You can also right-click in this table and insert, modify or delete two winding transformers manually if you 
already have the two winding transformer representations created. 

Once you are finished with the dialog, you can click Save  or OK to save any changes.  If y ou wish to abandon any 
changes you have made, click Cancel. 

Switched Shunt Properties 

Switched Shunt Information (Edit Mode) 
This dialog is used to view and modify the parameters associated with each switched shunt in the system.  It can also 
be used to insert new switched shunts and sometimes to delete existing shunts.  Only one switched shunt is permitted 
at each bus.  Switched shunts usually consist of either capacitors to supply reactive power (in MVR) to the system, or 
reactors to absorb reactive power.  The switched shunts are represented by a number of blocks of admittance that can 
be switched in a number of discrete steps.  If at least one block is in service, the shunt is said to be online.  The 
shunt’s corresponding circuit breaker can be used to determine and to toggle the switched shunt’s status. 

 

The Edit Mode version of this dialog is very similar in content to its Run Mode counterpart. 

Bus Number 

Unique number between 1 and 99,999 used to identify the bus to which the switched shunt is attached.  You can 
use the spin button immediately to the right of the number to move to the next switched shunt (click the up arrow) or 
the previous switched shunt  (click the down arrow). 

Find By Number 
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To find a switched shunt by its bus number, enter the number into the Bus Number field.  Then click this button.   

Bus Name 

Unique alphabetic identifier for the bus to which the switched shunt is attached, consisting of up to eight characters.   

Find By Name 

To find a switched shunt by its bus name, enter the bus name into the Bus Name field (case insensitive).  Then click 
this button. 

Shunt ID 

Since multiple switched shunts are allowed on a single bus, each switched shunt has a unique Shunt ID. 

Status  

Open or closed status of the switched shunt. 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected load. 

Find… 

If you do not know the exact switched shunt bus number or name you are looking for, you can click this button to 
open the advanced search engine. 

Display Size 

Size of the switched shunt. 

Scale Width with Size 

Automatically scales the width of the symbol when the object is resized. 

Display Width 

Width of the switched shunt symbol. 

Pixel Thickness 

Thickness of the display object in pixels.   

Orientation 

Specifies the direction in which to draw the object.   

Anchored 

If checked, the object is anchored to its terminal bus.  See Anchored Objects for details. 

Link to New Shunt 

Adds a new record in the data or links the selected shunt to a different record. 

OK, Save, Delete, and Cancel 

OK saves your changes and closes the dialog.  Save  saves your changes but does not close the dialog; this allows 
you to use, for example, the Find By Number command to edit additional switched shunts.  Delete  deletes the 
current switched shunt; this option is not available when inserting objects graphically – use the cut command 
instead.   Cancel closes the dialog but does not save any changes. 

   

Parameters 

Nominal Mvar  

The Nominal Mvar field gives the initial amount of reactive power the device would supply (in Mvars) if its terminal 
voltage were 1.0 per unit. 

Nominal MW 

This field is only visible when a switched shunt object has been read from a file as a Bus Shunt.  In that case, it is 
possible for the bus shunt to have both a MW and MVAR component.  The MW component will be displayed here.  
In general, switched shunts of other control types do not have MW components, and this field will not be displayed.  
If you change a switched shunt read as a bus shunt to another form of control, the MW component will remain, but 
has no controllability. 

Control Mode  

Determines whether the switched shunt has a fixed value, or whether the amount of reactive power supplied by the 
device changes in either discrete steps or continuously in order to maintain its terminal voltage within the voltage 
range specified in the Voltage Regulation fields.  This field can be changed (except in Viewer).  However, for a 
switched shunt to be used for automatic control, three fields must be set correctly: 1) the Control Mode field must be 
set to either Discrete or Continuous , 2) the corresponding area’s Auto Shunts  property must be true, and 3) the 
case-wide Disable Switched Shunt Control  option, which can be set on the Power Flow Solution Tab  of the 
PowerWorld Simulator Options Dialog<+>, must not be checked. 
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Note: automatic control of switched shunts is disabled if the voltage regulation high value is not greater 
than the low value; they should not be equal unless in the continuous mode.   

Note the additional control mode called Bus Shunt (Fixed).  This is analogous to the shunt MW and MVAR values 
that can also be stored at the bus level.  The difference is that bus shunts stored directly with the bus cannot be 
turned on and off in the load flow; rather they are always included in the load flow solution.  Bus shunts that are 
represented as switched shunt objects on Bus Shunt control, however, are mathematically exactly the same and 
can be turned on or off.  The reason for the differentiation of the Bus Shunt versus normal Fixed control is that the 
Bus Shunt control type is intended to identify the difference between a bus shunt and a transformer that MAY have 
controllability, but is currently turned of off control by being set to a Fixed value.  

Voltage Regulation 

When the switched shunt is on automatic control, its reactive power is changed in discrete steps or continuously to 
keep the voltage at the regulated bus within the per unit voltage range defined by High Value  and the Low Value.  

In the case of discrete control, the amount of reactive power supplied by this device changes in discrete amounts, 
thus the High Value should be greater than the low value.  The necessary voltage range depends upon the size of 
the switched shunt blocks.  In addition to a voltage range for discrete control, a specific Target Voltage  can be 
specified as well.  The target voltage will try to be met, either approximately under discrete control, or exactly under 
continuous control (either true continuous or discrete with a continuous shunt correction element.)  The number of 
the regulated bus is shown in the Reg. Bus # field. 

Switched Shunt Blocks 

The amount of shunt reactive power (susceptance) is specified in the Switched Shunt Block field.  The columns in 
this field correspond to different blocks of reactive power. The first row indicates the number of steps in each block, 
and the second row gives the amount of nominal Mvars per step (assuming 1.0 per unit voltage).  You may model 
both capacitors and reactors.  The reactors should be specified first, in the order in which they are switched in, 
followed by the capacitors, again in the order they are switched in.  The sign convention is such that capacitors are 
positive and reactors negative.  Shunt blocks are switched in order from left to right. 

 

Control Parameters 

Single Largest Step 

This option only applies when a switched shunt is set on discrete control.  If checked the switched shunt will switch 
in EITHER all of the available reactor blocks OR all of the capacitor blocks at once when the voltage falls outside 
the given range.  Whether the reactor or capacitor blocks switch is determined by which limit is violated.  A switched 
shunt with this option checked will only switch ONCE during a load flow solution, and then remains fixed at the new 
output for the remainder of the same solution calculation. 

Use Continuous Element 

If this option is checked, then Simulator will use a continuous element to fine-tune a discrete controlled switched 
shunt by injecting or absorbing additional MVARs to try and obtain the target voltage of the controlled bus. 

Minimum and Maximum Susceptance  

The minimum and maximum susceptance range for the continuous correction element. 

Use High Target Voltage 

Check this box to use the target voltage specified in the High Target Value  edit box when the regulated point goes 
above the High limit.  This will give a different target value if the voltage goes out of range on the high end than the 
low end.  If the voltage goes out of range on the low end, the original target value on the Parameters page will be 
used.  If this box is unchecked, only the target value on the parameters page will be used, whether the violation is 
high or low. 

 

Short Circuit Parameters 

Typically switched shunts are treated as open circuits in the zero sequence data for fault analysis.  However, it is 
possible to define zero sequence admittance blocks to be used.  The blocks work similarly to the load flow Switched 
Shunt Blocks discussed above.  Usually there will be the same number of blocks in the zero sequence data as in the 
load flow data.  Simulator will determine how many blocks were switched in for the power flow solution, and then use 
the zero sequence block data to calculate the z ero sequence admittance for the same number of blocks. 
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Switched Shunt Field Information 
Switched shunt field objects are used primarily to indicate various quantities associated with switched shunt devices.  
Furthermore, some switched shunt field types, which are distinguished by an integrated spin button, may be used to 
change switched shunt device properties. 

The Switched Shunt Fields Information Dialog can be used to modify the properties of individual switched shunt fields 
on the oneline.  The dialog displays the following fields: 

 

Find… 

If you do not know the exact bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

Bus Number 

Number of the bus to which the switched shunt associated with the field is connected.  Use the dropdown box to 
view a list of all buses with switched shunts in the case with valid area/zone/owner filters.    

Bus Name 

Name of the bus to which the switched shunt associated with the field is connected.  Use the dropdown box to view 
a list of all buses with switched shunts in the case with valid area/zone/owner filters.    

ID 

ID of the switched shunt associated with the field. 

Total Digits in Field 

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Field Value  

The current value of the field being displayed. 

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Delta Per Mouse Click  

Switched shunt fields can be used not only to show various f ields associated with switched shunt devices, but they 
can also be used to change some values.  This is accomplished using spin buttons shown to the right of the 
switched shunt field.  When the up spin button is clicked, the switched shunt field value is increased by the amount 
specified in the delta per mouse click field.  When the down spin button is clicked, the switched shunt field value is 
decreased by the same amount. 

This field is only used for Switched Shunt Mvar fields.  Specifying a nonzero value in this field causes the integrated 
spin button to appear as part of the switched shunt field on the oneline. 

Rotation Angle in Degrees 

The angle at which the text is placed on the diagram, in degrees. 

Anchored 

If the Anchored checkbox is checked, the switched shunt field is anchored to its associated switched shunt, which 
means that it will move with the switched shunt.   

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

 

Type of Field 

Used to determine the type of switched shunt field to show.  The following choices are available: 

Switched Shunt Mvar Total Mvar capacitance at the bus  

Select a Field Choose from any of the different switched shunt fields 

Select OK to save changes and to close the dialog, or click Cancel to close the dialog without saving your changes.   

Run Mode Properties and Information 

Bus Properties 
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Bus Information (Run Mode) 
This dialog is used to view information about each bus in the system.  It can be displayed by right-clicking on any bus 
and choosing Bus Information Dialog.  This dialog can only be reached in Run Mode, but has a similar Edit Mode 
counterpart.  The Bus Information Dialog has the following fields: 

 

Bus Number 

Unique number between 1 and 99,999 used to identify the bus.  You can use the small arrow immediately to the 
right of the number to view a list of all buses in the case with valid display filters.   Or you can use the spin button 
further to the right of the number to move to the next bus (click the up arrow) or the previous bus (click the down 
arrow). 

Find By Number 

To find a bus by its number, enter the number into the Bus Number field and then click this button.   

Bus Name 

Unique alphabetic identifier for the bus consisting of up to eight characters.  You can use the small arrow 
immediately to the right of the bus name to view a list of all bus names in the case with valid display filters.    

Find By Name 

To find a bus by its name, enter the bus name into the Bus Name field (case insensitive) and then click this button. 

Find… 

If you do not know the exact bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected bus. 

Area Number, Name 

Each bus is associated with an Area record.  These fields show  the number and name of this area.  See Area 
Records Display for more details about areas.   

Zone Number 

Each bus is associated with a Zone record.  This field is '1' by default.  See Zone Records Display for more details 
about zones.  You can also use the Zone Dialog  to list the buses in a particular zone and to easily move a group of 
buses from one zone to another.    

Voltage (per unit) 

Bus voltage in per unit notation.  You may enter a new per unit voltage magnitude.  However, the only effect this 
has is changing the initial voltage guess used in the iterative solution.  If you would like to change the reference 
voltage for a generator, please see Generator Information Dialog. 

Voltage (kV) 

Bus voltage in actual kilovolts. 

Angle (degrees) 

Voltage angle at the bus in degrees.  You may enter a new voltage angle.  However, the only effect this has is 
changing the initial voltage guess used in the iterative solution EXCEPT AT THE SLACK BUS.  Changing the angle 
for the slack bus will shift the voltage angle for all the buses in the slack bus' island by a similar amount.   

Owner Number, Owner Name 

Number and name of the bus’ owner. 

Substation Number, Substation Name 

The number and name of the substation the bus is contained in. 

Status  

Status of the bus, either connected or disconnected.  A disconnected bus is not energized.  You can use this field to 
change the status of the bus.  When the bus is initially connected, selecting Disconnected opens all of the 
transmission lines incident to the bus, disconnecting the bus from the rest of the system.  Selecting Connected 
closes all of the lines incident to the bus unless they attach to another disconnected bus.   

System Slack Bus  

Checked only if the bus is a system slack bus.  This value can only be changed in the Edit Mode. 

View Owner Dialog 

Clicking on this button will open the bus’ owner dialog. 

View Substation Dialog 



Properties of Simulator Objects 

227 

Clicking on this button will open the substation dialog for the substation the bus is contained in. 

 

Device Info   

Load Information 

Displays the total MW and Mvar load at the bus.  You cannot change either of these fields from this display.  Select 
the View/Edit Bus Load Records to view the individual load records for the bus.  Selecting this button displays the 
Load Dialog. 

Generator Information 

Displays the total MW and Mvar generation at the bus.  You cannot change either of these fields from this display.  
Select the View/Edit Generator Records to view the individual generator records for the bus.  Selecting this button 
displays the Generator Dialog for the first generator at the bus. 

Shunt Admittance  

Shows the real and reactive components of the shunt admittance to ground.  Entered in either MW or Mvar, 
assuming one per unit voltage.  B is positive for a capacitor and negative for a reactor.  If B corresponds to a 
switched device, consider using a switched shunt. 

 

Fault Analysis Load Parameters 

The parameters on this tab are used when running a fault analysis study.  The values represent the total load at the 
bus for the negative and zero sequence as equivalent admittances.  By default, these values are zero.  For load 
buses, these values can be changed by the user, or they can be specified by loading short circuit data from within the 
Fault Analysis Dialog.  It is also possible to define these values as non-zero at a bus where no load exists in the load 
flow, but it is not usually desirable to do so. 

 

OPF 

This tab is only available if you have the Optimal Power Flow (OPF) add-on tool for PowerWorld Simulator.  This tab 
displays the MW marginal cost (Locational Marginal Price) for the bus when performing an OPF solution.  The page 
also breaks down the LMP into its cost components. 

Substation Properties 

Substation Information (Run Mode) 
This dialog is used in the Run Mode to view and modify information associated with a substation record.  It displays 
different information from the Edit Mode version of the substation dialog.  To display it from Run Mode, first select 
Case Information > Substations  from the main menu to bring up the Substation Records Display.  Right-click on the 
substation of interest and choose Show Dialog.  The Run Mode Substation Dialog has the following fields: 

Substation Number 

An integer identifier for the substation.  You can use the spin button immediately to the right of this field to move to 
either the next substation (click the up arrow) or the previous substation (click the down arrow).   

Substation Name and ID 

Two alphanumeric identifiers for the substation.  

Find By Number 

To find a substation by its number, enter the number into the Substation Number field, then click this button. 

Find By Name 

To find a substation by its name, enter the name into the Substation Name field, then click this button. 

Find By Sub ID 

To find a substation by its substation ID, enter the ID into the Substation ID field, then click this button. 

Find… 

If the exact substation number, name and ID are not known, you can use the Find Dialog to search for and select a 
substation from a list of substations. 

Labels  

Clicking this button will open a dialog displaying the list of defined labels for the substation.  New labels can also be 
added for the substation from the dialog as well. 

View All Flows at Substation 

Clicking this button will open a quick power flow display listing the buses contained in the substation. 

 

Information 
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Load and Generation 

Real and reactive load, generation, shunts, losses, and interchange for the substation. 

Generation AGC Range  

Total amount of generation increase or decrease available for all generators in the substation. 

Bus Voltages 

Summary information on all buses in the substation, including total number of buses, number of dead 
(disconnected) buses, and minimum and maximum bus voltage and angle within the substation. 

 

Buses 

The Buses table identifies the buses in the substation, and provides summary information on each. 

 

Gens  

The Gens table identifies the generators in the substation, and provides summary information on each. 

 

Loads  

The Loads table identifies the loads in the substation, and prov ides summary information on each. 

 

Switched Shunts  

The Switched Shunts table identifies the switched shunts in the substation, and provides summary information on 
each. 

 

Substation Tie Lines 

The Substation Tie Line Table identifies the flows on all of the substation's ties to other substation. 

Generator Properties 

Generator Information 

Generator Information (Run Mode) 
This dialog is used to view information about each generator in the system.  Many fields on this display can also be 
changed (except in Viewer).  Here we describe the Run Mode version of the Generator Information Dialog.  The Edit 
Mode version is very similar. 

 

Bus Number 

Unique number between 1 and 99,999 used to identify the bus to which the generator is attached.   The dropdown 
list enumerates all generator buses in the case that meet the criteria established by display filters.   You may select 
a bus number directly from the dropdown list, or you may use the spin buttons to cycle through the list of generator 
buses.  

Bus Name 

Unique alphabetic identifier for the bus to which the generator is attached, consisting of up to eight characters.  Use 
this dropdown box to view a list of all generator bus names in the case with valid display filters.      

ID 

Two character alphanumeric ID used to distinguish multiple generators at a bus; '1' by default.   

Fuel Type  

Type of fuel used by the generator this model represents.  In most cases, this field is unnecessary for normal load 
flow analysis, and hence the default value is Unknown.  However, this value can be useful during the Security 
Constrained OPF analysis. 

Unit Type  

The type of unit the generator represents, such as combined cycle, steam, hydro, etc. 

Find By Number 

To find a generator by its number and ID, enter the number into the Bus Number field and the ID into the ID field.  
Then click the Find By Number button.   

Find By Name 
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To find a bus by its name and ID, enter the bus name into the Bus Name field (case insensitive) and the ID into the 
ID field.  Then click the Find By Name button. 

Find… 

If you do not know the exact generator bus number or name you are looking for, you can click this button to open 
the advanced search engine. 

Status  

Status of the generator, either Closed (connected to terminal bus) or Open (not connected).  You can use this field 
to change the status of the generator. 

Area Name 

Name of the area in which the generator's terminal bus is located. 

Same Owner as Terminal Bus  

Read-only check-box that indicates whether the generator’s owner is the same than the terminal bus’ owner. 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected generator. 

 

There additional sections of generator information available from the Run Mode generator dialog: 

Power and Voltage Control  

Generator Cost Information  

OPF  

Fault Parameters  

Owners, Area and Zone  

Memo  
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Generator Information: Power and Voltage Control 
The Power Control grouping fields are used to show/change the values associated with the real power output of the 
generator.   

 

MW Output 

Current real power output of the generator. 

Minimum and Maximum MW Output 

Minimum and maximum real power output limits for the generator.  Simulator will not let the MW output go below its 
minimum value or above its maximum value if the Enforce MW Limits  option is exercised.   

Available for AGC 

Determines whether or not the generator is available for automatic generation control (AGC).  Normally this box 
should be checked.  However, there are times when you would like to control the generator output manually (such 
as if you are using the generator to remove a line limit violation), in which case you should leave this box 
unchecked.  A generator is also placed on "manual" control any time you manually change its output.  You could 
then place the generator back on AGC control by using this dialog.   

Enforce MW Limits  

If checked, the minimum and maximum MW limits are enforced for the generator, provided the Enforce Generator 
MW Limits  field is also checked on the Limits Tab of the PowerWorld Simulator Options Dialog <+>.  If this box is 
checked and a generator is violating a real power limit, the generator's MW output is immediately changed.   

Participation Factor 

The participation factor is used to determine how the real power output of the generator changes in response to 
demand when the generator is available for AGC and the area is on participation factor control.  When you open a 
case using the PTI Raw Data Format, this field is initialized to the per unit MVA rating of the generator, since 
participation factor information is not stored in the PTI format.  

MW Ramp Limit 

Specifies the maximum rate at which the real power output of the unit can be changed (in MW/minute).  This rate is 
needed because of the mechanical and thermal stresses that arise when the output of a generator is changed.  
Since changing the output too quickly can damage a generator, the program will enforce this limit.  You can 
command Simu lator to ignore the limit by removing the check from the Enforce Generator Ramp Limits  option on 
the Limits Tab of the PowerWorld Simulator Options Dialog.  Then the output of the generator will change 
instantaneously.  

Loss Sensitivity 

Shows how the losses for an area will change for an incremental increase in the generation at the bus.  This 
information is useful in determining the economic dispatch for the generation.  The implicit assumption in calculating 
this field's value is that the incremental change in generation will be absorbed by the system "slack bus."  This field 
cannot be changed.   

Voltage Control 

The Voltage Control grouping is used to show/change values associated with controlling the voltage/reactive power 
output of the generator.   

Mvar Output 

Current reactive power output of the generator.  You can manually change this value only if Available for AVR is 
not checked.   

Min and Max Mvar Output 

Specify the minimum and maximum allowable reactive power output of the generator.   

Available for AVR 

Designates whether or not the generator is available for automatic voltage regulation (AVR).  When the AVR field is 
checked, the generator will automatically change its reactive power output to maintain the desired terminal voltage 
within the specified reactive power range.  If a reactive limit is reached, the generator will no longer be able to 
maintain its voltage at the setpoint value, and its reactive power will then be held constant at the limit value.   

Use Capability Curve  

If checked, the generator's reactive power limits are specified using a reactive capability curve that prescribes the 
dependence of the generator's reactive power limits on its real power output.  Otherwise, the fixed values given in 
the Min Mvar Output and Max Mvar Output fields are used.  The generator reactive capability can be defined 
using the table that appears at the bottom of the dialog.  Please see Generator Reactive Power Capability Curve
<+> for details.   

Regulated Bus Number 
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Number of the bus whose voltage the generator is regulating.  This is usually, but not always, the generator's 
terminal bus.  Multiple generators can regulate the same remote bus, but the regulated bus must not be another 
generator bus.  If the generator is at a slack bus, it must regulate its own terminal voltage.  Select Case 
Information, Others, Remotely Regulated Buses to view the Remotely Regulated Bus Records Dialog , which 
identifies all buses that are being remotely regulated. 

Desired Reg. Bus Voltage  

Specifies the desired per unit voltage for the generator at the regulated bus.  The regulated bus need not be the 
terminal bus of the generator. 

Actual Reg. Bus Voltage  

Shows the actual per unit voltage at the regulated bus.  If the generator is on AVR and has not reached a reactive 
power limit, the actual regulated bus voltage should be equal to the desired regulated bus voltage.  This field cannot 
be changed.   

Remote Reg % 

This field is only used when a number of generators at different buses are regulating a remote bus (i.e., not their 
terminal buses).  This field then specifies the percentage of the total reactive power required by the remote bus to 
maintain its voltage that should be supplied by this generator.  The default value is 100.   
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Generator Cost Information 
The Costs tab of the Generator Information dialog (run mode) is used to show/change values associated with the cost 
of operation of the generator.  See Generator Cost Information for details.  Cost data can also be saved/loaded using 
the Generator Cost Data files.  

 

Cost Model 

Simulator can model generators as not having a cost model, or having either a cubic cost model or a piecewise 
linear model.  The cost model type you choose determines the content of the remainder of this dialog   

Unit Fuel Cost 

The cost of fuel in $/MBtu.  This value can be specified only when you have chosen to use a cubic cost model. 

Variable O&M  

The Operations and Maintenance costs.  Only used for cubic cost models. 

Cost Shift, Cost Multiplier 

The cost shift and cost multiplier allow you to easily apply a shift to the cost function for the purpose of assessing 
how variations in bids impact profit.  The cost function is affected based on the following equation: 

(Original Cost Function + Cost Shift) * Cost Multiplier 

Cubic Cost Coefficients A, B, C, D 

For cubic cost models of the form C(Pgi) = (d*Pgi^3 + c*Pgi^2 + b*Pgi + a) * (fuel cost), specify the cost curve's 
coefficients.  These coefficients can be specified only when you have chosen to use a cubic cost model. 

Piecewise Linear Table  

If you have chosen to use a piecewise linear cost model, a table appears that allows you to specify pairs of MW 
output levels and corresponding generator operating costs.  To insert a new point on the cos t curve, right-click on 
the table and choose Insert New Point from the resulting local menu.   To delete an existing point from the cost 
curve, right-click on the table and choose Delete Point from the resulting local menu.  To edit an existing point in the 
table, simply enter your changes to the appropriate cells. 

Fixed Cost 

The fixed cost associated with operating the unit.  This cost is independent of the generator's MW output level and 
is added to the cost prescribed by the piecewise linear model to obtain the total cost of operating the generator in 
$/MWHr.  This option can be specified only for piecewise linear cost models. 

Convert Cubic Cost to Linear 

Use this option to create a piecewise linear cost function from the cubic cost function specified by the coefficients A, 
B, C, and D and the fuel cost.  Specify the number of break points, and hence the number of segments, in the 
Number of Break Points  field.  Click the Convert to Linear Cost button to create the piecewise linear function that 
approximates the cubic cost function.  This action switches Cost Model option to Piecewise Linear and displays the 
Piecewise Linear Table  that identifies the piecewise linear curve’s breakpoints. 

Marginal Cost 

Shows the marginal cost of producing real power at the generator at its current output level, dCi(Pgi)/dPgi. 

ED/OPF Cost 

This is the cost of production for this generator following an economic dispatch or optimal power flow solution, 
including the scaling from the cost shift and cost multiplier fields. 

Unscaled Cost 

The cost of production of the generator, ignoring the cost multiplier and cost shift.  This cost is the result of the 
original cost function by itself. 
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Generator Information: OPF 
The fields on this tab display information regarding the generator’s participation in an OPF load flow solution. 

 

OPF MW Control 

The type of control the generator is allowed during an OPF solution.  The generator can be set to No control during 
OPF, control only if its AGC property is set to Yes, or to always be controlled by the OPF regardless of the AGC 
status of the generator. 

Fast Start Generator 

The generator is being treated as a fast start generator during the OPF solution. 

Generator MW limits  

The MW limits of a generator can be altered in this location if you wish for the generator to use different limits than 
originally assigned in the load flow case, without actually changing the original values.  Simply change the Current 
Min MW Limit and Current Max MW Limit to alter the limits observed by the generator during and OPF solution. 

MW Marginal Cost for Generator’s Bus  

The OPF solved marginal cost at the generator’s terminal bus. 

Initial, Final and Delta MW Output 

The MW output information for the generator resulting from the OPF run. 

Initial, Final and Delta Hourly Cost 

The hourly cost information for the generator resulting from the OPF run. 
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Generator Information: Owners, Area, Zone 
This information is located on the Generator Information Dialog. 

This tab is used to display or change the generator’s owner information, area information, and zone information 

 

Owners 

Currently, Simulator supports up to four owners for generators.  To add an owner of a generator, change one of the 
Owner fields to a new owner number, and update the owner percentages accordingly.  To modify an owner's 
percentage of ownership, simply modify the value in the percentage field for that owner.  If you set the percentage 
of an owner to 0, that owner will be removed from the list of owners for the device.  You can also remove an owner 
from owning part of a device by changing the owner field for that owner to 0.  Note that if you do not set the new 
owner percentages of all specified owners s uch that the total is 100%, Simulator will normalize the percentages 
such that the total is 100% when you click Save  or OK on the generator dialog. 

Area Number, Area Name 

The area number and name to which the generator belongs.  Note that you can change the area of the generator to 
be different than the area of the terminal bus.  If you do so, you will be prompted to confirm that you wish to place 
the generator within a different area than that of the bus to which it is electrically connected. 

Zone Number, Zone Name 

The zone number and name to which the generator belongs.  Note that you can change the zone of the generator 
to be different than the zone of the terminal bus.  If you do so, you will be prompted to confirm that you wish to place 
the generator within a different zone than that of the bus to which it is electrically connected. 

Load Properties 

Load Information (Run Mode) 
The Load Information Dialog can be used to inspect and modify the model of a bus load.  To view the Load 
Information Dialog, simply right-click on the load of interest and select Load Information Dialog from the resulting local 
menu.  This is very similar to its Edit Mode counterpart.  The dialog has the following fields: 

 

Bus Number 

Unique number between 1 and 99,999 used to identify the bus to which the load is attached.  The dropdown box 
provides a list of all load buses with valid display filters.   You can use the spin button to cycle through the list of 
load buses.  

Bus Name 

Unique alphabetic identifier for the bus to which the load is attached, consisting of up to eight characters.  The 
dropdown box lists the names of all load buses in the case with valid display filters.    

ID 

Two-character ID used to distinguish multiple loads at a bus.  By default, the load id is equal to "1 ."  An identifier of 
'99' is used to indicate an equivalent load.   

Find By Number 

To find a load by its number and ID, enter the number into the Bus Number field and the ID into the ID field.  Then 
click this button. 

Find By Name 

To find a load by its name and ID, enter the bus name into the Bus Name field (case insensitive) and the ID into the 
ID field.  Then click this button. 

Find… 

If you do not know the exact load bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

Status  

Status of the load, either Closed (connected to terminal bus) or Open (not connected). You can use this status field 
to change the load's status.  

Area Number, Area Name 

Number and name of the area the load is a member of. 

Zone Number, Zone Name 

Number and name of the zone the load is a member of. 

Owner Number, Owner Name 

Number and name of the owner the load is a member of. Loads DO NOT have to be owned by the same owner as 
the terminal bus. 
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Substation Number, Substation Name 

Number and name of the substation the load is a member of. 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected load. 

 

 Load Information 

Base Load Model, Current Load 

The Base Load Model fields are used to represent the amount of base real and reactive load at the bus.  Usually 
this load is modeled as being "constant power," meaning that the amount of load is independent of the bus voltage 
magnitude.  However, Simulator also permits modeling "constant current" load, for which the load varies in 
proportion to the bus voltage magnitude, and "constant impedance" load, for which the load varies in proportion to 
the square of the bus voltage magnitude.  Values in these fields are specified in MW and MVR assuming one per 
unit voltage.  All six fields in the Base Load Model section can be changed. 

Load Multiplier 

The actual load at the bus is equal to the base value multiplied by the corresponding load multiplier.  The load 
multiplier is a potentially time varying value specifying how the load is scaled.  The load multiplier depends upon the 
area load multiplier, the zone load multiplier, and the case load multiplier.  See Load Modeling for more details.  The 
load multiplier value cannot be changed on this dialog.  

Bus Voltage Magnitude  

Voltage magnitude of the load’s terminal bus. 

 

 OPF Load Dispatch 

The information on this tab displays the load information resulting from the load’s participation in an OPF solution 

Benefit Model 

If this field is set to none, the load will not be dispatchable in the OPF solution.  If the option is set to Piecewise 
Linear, the load is dispatchable during the OPF, according to the following fields. 

Min. and Max. MW Demand 

The minimum and maximum MW demand the load must operate within during the OPF solution. 

Available for AGC 

The load is only available for redispatch during the OPF solution if this option is checked. 

Fixed Benefit 

Value of the load benefit at minimum demand. 

Piece-wise Linear Benefit Curve  

This table the MW demand levels and their corresponding load benefit values, which in turn define the starting 
points and slopes of the piece-wise linear benefit curve segments. 

Line/Transformer Properties 

Line/Transformer Information Dialog (Run Mode) 
The Line/Transformer Information dialog box is used to view information about each transmission line and transformer 
in the system.  You may use this dialog also to change many of the properties of lines and transformers (except in 
Viewer). 

The Run Mode version of this dialog is very similar in content to its Edit Mode counterpart. 

 

The Line/Transformer dialog sports the following fields: 

From Bus Number and Name 

From Bus  number and name.  For transformers, the from bus  is the tapped side.   

To Bus Number and Name 

To Bus number and name.   

Circuit 

Two-character identifier used to distinguish between multiple lines joining the same two buses.  Default is '1'.   

Find By Number 

To find a line or transformer by its bus numbers, enter the from and to bus numbers and the circuit identifier.  Then 
click this button.  Use the spin button to cycle through the list of lines and transformers in the system. 



Printed Documentation 

236 

Find By Name 

To find a line or transformer by the names of its terminal buses, enter the from and to bus names and the circuit 
identifier.  Then click this button. 

Find… 

If you do not know the exact from and to bus numbers or names you are looking for, you can click this button to 
open the advanced search engine. 

From End Metered 

This field is only used for lines and transformers that serve as tie lines, which are lines that join two areas.  If this 
field is checked for a tie line, then the from end of the device is designated as the metered end.  Otherwise the to 
end is metered.  By def ault, the from end is metered.  The location of the metered end is important in dealing with 
energy transactions because it determines which party must account for transmission losses. 

Default Owner (Same as From Bus) 

Read-only check-box that indicates whether the line’s owner is the same than the from bus’ owner. 

From and To Bus Nominal kV 

From and To bus nominal voltage levels. 

From and To Bus Voltage (p.u.) 

The actual terminal bus voltages of the transmission element, in per unit. 

From and To Bus Area Name 

Names of the areas in which the From and To buses are located. 

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected branch. 

 

Parameters 

Status  

Current status of the device.   

Resistance, Reactance, Charging (B) 

The resistance, reactance, and the total charging susceptance (that is, B, not B/2) of the device (in per unit).  

Limits  

Ratings for the transmission line or transformer in MVA.  Simulator allows the use of up to eight different limit sets.  

Has Line Shunts  

Indicates whether or not line or transformer has shunt compensation.  You cannot directly change the value of this 
field.  Rather, use the Line Shunts / Series Capacitor button to view/modify existing line shunts or to enter new line 
shunts.  Line shunts are expressed in terms of the per-unit conductance and susceptance at each end of the line or 
transformer. 

Line Shunts  

Select to view the Line Shunts Information Dialog.  This dialog is used to change the values of the line shunts. 

Line Flow 

These next fields show the actual real and reactive power flow at both ends of the device (because of real and 
reactive losses these numbers may be different), and its percentage MVA loading. 

 

Transformer Info 

This fields on this tab are enabled only if the branch is a transformer.  See the Transformer Modeling help for more 
information on transformer types and controls.  

Off-nominal Turns Ratio 

The off-nominal tap ratio for the transformer. 

Phase Shift Degrees 

Phase angle for the transformer.  This field is usually non-zero only for phase shifting transformers or wye-delta and 
delta-wye connected transformers, but can be non-zero for an LTC or fixed transformer on rare occasions. 

Automatic Control Enabled 

Check this box to enable automatic control of the transformer.  Note that automatic control will be implemented only 
if  (1) transformer control has been enabled for the transformer's area (see Area Display for details) and (2) 
transformer control has not been disabled for the entire case (via the Disable Transformer Control  option on the 
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Power Flow Solution tab of the PowerWorld Simulator Options Dialog).  The Line/Transformer Dialog gives you 
convenient access to these control options through the Case Control Enabled and Area Transformer Control 
Enabled check boxes. 

Case … Control Enabled and Area Transformer Control Enabled 

Both of these boxes must be checked for a transformer to be controlled.  Case Control Enabled has to be checked 
for any transformer in the entire case to be controlled and Area Transformer Control Enabled has to be checked 
for any transformer in that area to be controlled.  Checking these does NOT automatically make the entire case or 
entire area on control. 

Automatic Control Options… 

Depending on the type of control of the transformer, this button will open up the control options for LTC Control, 
MVAR Control, or Phase Shifter Control. 

 

Series Capacitor 

The parameters on this tab are enabled when the selected branch is a series capacitor.  If the branch is a series 
capacitor, the Is Series Capacitor box will be checked.  In addition, the Status  field for series capacitors will be 
enabled, allowing you to change the Bypassed or In Service status of the series capacitor.  The series capacitor status 
IS NOT the same as the branch status of Open or Closed. 

 

Fault Analysis Parameters 

The parameters on this tab are used when running a fault analysis study.  The values represent the zero sequence 
impedance and zero sequence line shunt admittances for the analysis.  By default, the positive and negative sequence 
line impedances and line shunt admittances are the same as the load flow impedance.  The same fields are used for 
transformers, along with the configuration field.  The configuration field defines the winding type combinations for the 
transformer (wye, delta, etc.)  As a default, Simulator assumes a grounded wye to grounded wye transformer, which 
has the same model as a transmission line.  Usually transformers are not of this type, and the proper type would need 
to be defined either manually or loaded from an external file in order for the fault analysis to be accurate. 

 

OPF 

The OPF tab is only visible if you have the OPF (Optimal Power Flow) add-on tool for PowerWorld Simulator. 

Enforce Line Flow Limit 

This check box must be checked if the branch limit is going to be enforced when running an OPF solution.  If this 
box is not checked, the OPF routine will allow the branch to violate its branch limits. 

Treat Limit as Equality Constraint 

If checked, the OPF solution will attempt to solve the load flow while keeping the flow on the branch at its limit. 

Maximum MVA Flow 

The largest MVA flow value measured on the line, either at the From or To bus. 

Present MVA Limit 

The limit enforced by the OPF for the branch.  This is set in the OPF constraint options, and is related to the original 
branch limits. 

Maximum Percentage  

The highest percentage of flow measured on the line, either at the From or To bus. 

Limit Marginal Cost 

The cost of enforcing the branch MVA limit. 

Flow Limit Unenforceable  

If the line limit could not be maintained in the OPF solution, this box will be checked to indicate such.  This check 
box cannot be changed manually. 

Line was Included in OPF Solution? 

Specifies whether or not the branch flow and limit was included as a constraint in the OPF solution.  In general, 
branches that are not near their limit and do not appear to be changing flow dramatically towards their limit will be 
ignored in the OPF calculation to speed up the solution.  No and Yes indicate whether or not the OPF process 
determined that the line needed to be included.  The user can initially force the branch to be included or not 
included with these two fields.  By choosing Always , the branch will be included in the OPF solution constraints 
regardless of the propensity of the line to be approaching it's limit. 

From/To Bus MW Marginal Costs  

Displays the marginal costs of the branches terminal buses, following the solution of the OPF. 
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Transformer AVR Dialog 
The Transformer AVR Dialog is used to view the control parameters associated with load-tap-changing (LTC) 
transformers when they are used to control bus voltage magnitudes.  To view this display, click the Automatic Control 
Options button on the Line/Transformer Information Dialog.  Note that the button will not respond to the click if the No 
Automatic Control  option is selected under the Automatic Control  group. 

 

This dialog has the following fields: 

Regulated Bus Number 

The number of the bus whose voltage is regulated by the control. 

Current Regulated Bus Voltage  

The present voltage of the regulated bus. 

Voltage Error 

If the regulated bus' voltage falls outside the regulating range of the transformer (as defined by the Minimum 
Voltage and Maximum Voltage fields), the Voltage Error field indicates by how much the voltage deviates from the 
control range. 

Minimum Voltage  

The minimum acceptable voltage at the regulated bus. 

Maximum Voltage  

The maximum acceptable voltage at the regulated bus. 

Current Tap Ratio 

The tap ratio of the transformer for the current system state. 

Minimum Tap Ratio, Maximum Tap Ratio 

Minimum and maximum allowable off-nominal tap ratios for the LTC transformer.  Typical values are 0.9 and 1.1.   

Tap Step Size 

Transformer off-nominal turns ratio increment.  The off-nominal turns ratio is either incremented or decremented 
from 1.0 in integer multiples of this value.  Default value is 0.00625.   

Voltage to Tap Sensitivity 

Shows the sensitivity of the voltage magnitude at the regulated bus to a change in the transformer's tap ratio.  You 
can use this field to assess whether or not the transformer can effectively control the regulated bus voltage.  In an 
ideal case, such as when the LTC transformer is being used to control the voltage at a radial load bus, the 
sensitivity is close to 1.0 (or -1.0 depending upon whether the tapped side of the transformer is on the load side or 
opposite side of the transformer).  However, sometimes the transformer is very ineffective in controlling the voltage.  
This is indicated by the absolute value of the sensitivity approaching 0.  A common example is a generator step-up 
transformer trying to control its high-side voltage when the generator is off-line.  Simulator automatically disables 
transformer control if the transformer sensitivity is below the value specified on Power Flow Solution Tab  of the 
PowerWorld Simulator Options dialog.     

Impedance Correction Table  

This field specifies the number of the transformer's corresponding transformer impedance correction table.  
Transformer impedance correction tables are used to specify how the impedance of the transformer should change 
with the off-nominal turns ratio.  If this number is 0, then no impedance correction table is associated with the 
transformer, and the impedance of the transformer will thus remain fixed as the tap ratio changes.  Valid impedance 
correction table numbers range from 1 to 63.  To assign an existing impedance correction table to the transformer, 
enter the existing table's number.  To view the existing impedance correction tables, click the Insert/View 
Impedance Correction Table button, which brings up the Transformer Impedance Correction Dialog.  To define a 
brand new impedance correction table for the transformer, enter an unused table number and then click Insert/View 
Impedance Correction Table to prescribe the correction table.  Note that the association between a transformer and 
an impedance correction table is not finalized until you select either OK or Save on the Line/Transformer Dialog. 

View Transformer Correction Table or Insert Transformer Correction Table  

Click on this button either to view or to insert transformer correction tables.  Clicking on this button displays the 
Transformer Impedance Correction Dialog.  Note that the table must prescribe at least two points in order to be 
defined. 
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Transformer Mvar Control Dialog 
The Transformer Mvar Control dialog is used to view the control parameters associated with load-tap-changing (LTC) 
transformers that are used to control the Mvar flow through the transformer.  To view this display, click on the 
Automatic Control Options  button on the Line/Transformer Information Dialog.   

When used to control reactive power, the LTC transformer always controls the reactive power flow at the from end of 
the transformer (i.e., the tapped side), with positive flow assumed to be going through the transformer to the to bus.  
Therefore the regulated bus field is not used.   

 

The dialog has the following fields: 

Mvar Flow at From Bus 

The current Mvar flow as measured at the from end of the line.  This is the parameter the transformer tries to 
control. 

Mvar Error 

If the Mvar flow at the from end violates the limits defined by the Minimum Mvar Flow and Maximum Mvar Flow 
fields, the Mvar Error field indicates by how much the flow falls outside the control range.  

Minimum Mvar Flow, Maximum Mvar Flow 

Minimum and maximum allowable reactive power flow as measured at the from bus.  The transformer attempts to 
regulate the reactive flow to fall within this range. 

Current Tap Ratio 

The transformer's present off-nominal turns ratio.   

Minimum Tap Ratio, Maximum Tap Ratio 

Minimum and maximum allowable off-nominal tap ratios for the LTC transformer.  Typical values are 0.9 and 1.1.   

Tap Step Size 

Transformer off-nominal turns ratio increment.  The off-nominal turns ratio is either incremented or decremented 
from 1.0 in integer multiples of this value.  Default value is 0.00625.   

Mvar to Tap Sensitivity 

The amount of Mvar shift that would be implemented by switching one tap position from the current position.  This 
sensitivity indicates the ability of the transformer to control Mvars. 

Impedance Correction Table  

Specifies the number of the transformer's corresponding transformer impedance correction table.  Transformer 
impedance correction tables are used to specify how the impedance of the transformer should change with the off-
nominal turns ratio.  If this number is 0, no impedance correction table is associated with the transformer, and the 
impedance of the transformer will thus remain fixed as the tap ratio changes.  Valid impedance correction table 
numbers range from 1 to 63.  To assign an existing impedance correction table to the transformer, enter the existing 
table's number.  To view the existing impedance correction tables, click the Insert/View Impedance Correction Table 
button, which brings up the Transformer Impedance Correction Dialog.  To define a brand new impedance 
correction table for the transformer, enter an unused table number and then click Insert/View Impedance Correction 
Table to prescribe the correction table.  Note that the association between a transformer and an impedance 
correction table is not finalized until you select either OK or Save on the Line/Transformer Dialog. 

View Transformer Correction Table or Insert Transformer Correction Table  

Click on this button either to view or to insert transformer correction tables.  Clicking on this button displays the 
Transformer Impedance Correction Dialog.  Note that the table must prescribe at least two points in order to be 
defined. 
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Transformer Phase Shifting Information 
The Transformer Phase Shifting Dialog is used to view the control parameters of phase-shifting transformers.  To view 
this display, click on the Automatic Control Options  button on the Line/Transformer Information Dialog, provided that 
the Phase Shift Control option is chosen from the Automatic Control group. 

 

Regulated Bus Number 

Number of the terminal bus of the phase shifter regulated by the phase shifter.  When control is active, the phase 
shifter will automatically change its phase shift to keep the MW flow at this bus at the desired value. 

Current MW Flow  

Current MW flow through the transformer measured at the regulated bus terminal.   

MW Error 

If the current MW flow falls outside the minimum/maximum MW flow limits, the MW Error field indicates by how 
much the flow violates the regulating range. 

Minimum MW Flow, Maximum MW Flow 

Minimum and maximum allowable MW flow through the phase shifter. 

Current Phase Angle (Degrees) 

The phase angle of the transformer for the current solved system state.   

Minimum Phase Angle, Maximum Phase Angle  

Minimum and maximum allowable phase shift in degrees.  

Step Size (Degrees) 

Phase shift change per step in degrees. 

MW Flow to Phase Sensitivity 

The sensitivity of the controlled MW flow to changes in the transformer's phase.  This sensitivity indicates the 
transformer's ability to regulate its MW flow. 

Impedance Correction Table  

Specifies the number of the transformer's corresponding transformer impedance correction table.  Transformer 
impedance correction tables are used to specify how the impedance of the transformer should change with the off-
nominal turns ratio.  If this number is 0, no impedance correction table is associated with the transformer, and the 
impedance of the transformer will thus remain fixed as the tap ratio changes.  Valid impedance correction table 
numbers range from 1 to 63.  To assign an existing impedance correction table to the transformer, enter the existing 
table's number.  To view the existing impedance correction tables, click the Insert/View Impedance Correction Table 
button, which brings up the Transformer Impedance Correction Dialog.  To define a brand new impedance 
correction table for the transformer, enter an unused table number and then click Insert/View Impedance Correction 
Table to prescribe the correction table.  Note that the association between a transformer and an impedance 
correction table is not finalized until you select either OK or Save on the Line/Transformer Dialog. 

View Transformer Correction Table or Insert Transformer Correction Table  

Click on this button either to view or to insert transformer correction tables.  Clicking on this button displays the 
Transformer Impedance Correction Dialog.  Note that the table must prescribe at least two points in order to be 
defined. 
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Transformer Impedance Correction Tables Dialog 
The Transformer Correction Tables Dialog is used to view information about the transformer impedance correction 
tables.  These tables are used on some LTC or phase shifting transformers to model the impedance of the transformer 
as a function of the off-nominal turns ratio or phase shift.  The dialog has the following fields: 

 

Transformer Impedance Correction Table Number 

Number of the impedance correction table, between 1 and 63.  Use the spin button immediately to the right of this 
field to step through the list of defined tables.  If you have made changes to a particular table, you must click Save 
before moving to another correction table; otherwise, your changes will be lost. 

Table Entries 

Used to insert/edit/delete the actual entries in the impedance correction table.  In the first row, enter either an off-
nominal turns ratio for an LTC transformer, or a phase shift in degrees for a phase shifting transformer.  The entries 
in the first row must be entered in strictly ascending form.  In the second row, enter the scale factor to apply to the 
transformer impedance.  The transformer's nominal impedance is multiplied by the scale factor to obtain the actual 
value.  Note that at least two columns must be used. 

Right-click on the table to invoke its local menu, which allows you to delete and to insert columns.  To insert a new 
column, click on the column before which you want to insert a new column and select Insert New Point from the 
local menu.  To delete a column, position the cursor on the column you want to delete and select Delete Point.   

Table is Used by the Following Transformers 

Lists all the transformers in the case that use this impedance correction table.  A single table may be used by any 
number of transformers.  To associate a table with a transformer, use the Transformer AVR Dialog for LTC 
transformers or the Transformer Phase Shifting Dialog for phase shifters.  

Switched Shunt Properties 

Switched Shunt Information (Run Mode) 
The Switched Shunt Information Dialog box can be displayed by placing the cursor on its symbol and right-clicking.  
This is very similar to its Edit Mode counterpart.  The dialog has the following fields: 

 

Bus Number 

Unique number between 1 and 99,999 used to identify the bus to which the switched shunt is attached.  This 
dropdown list identifies the buses in the case with switched shunts that also have valid display filters.   Use the spin 
button to step through the list of shunts in the case.  Note that only one switched shunt is allowed at each bus.   

Find By Number 

To find a switched shunt by its bus number, enter the number into the Bus Number field.  Then click the Find By 
Number button.   

Bus Name 

Unique alphabetic identifier for the bus to which the switched shunt is attached, consisting of up to eight characters.  
This dropdown box lists the names of all the switched shunt buses in the case with valid display filters.     

Find By Name 

To find a switched shunt by its name, enter the bus name into the Bus Name field (case insensitive).  Then click the 
Find By Name button. 

Shunt ID 

Since multiple switched shunts are allowed on a single bus, each shunt is identified by a unique ShuntID. 

Status  

Status of the switched shunt, either Closed (connected to terminal bus) or Open (not connected).  On the oneline, 
the switched shunt can be opened by placing the cursor on the (red) circuit breaker box and clicking, and it can be 
closed by placing the cursor on the (green) box and again clicking.  You can also use this status field to change the 
switched shunt's status.  Note that the switched shunt is only available for automatic control when its status is 
closed.   

Labels  

Clicking on this button will open the Subscribed Aliases dialog listing all the labels or aliases assigned for the 
selected load. 

Find… 

If you do not know the exact switched shunt bus number or name you are looking for, you can click this button to 
open the advanced search engine. 

 

Parameters 
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Nominal Mvar  

Amount of reactive power that would be supplied by the switched shunt if its terminal voltage were one per unit 
(capacitive is positive). 

Actual Mvar  

Actual reactive power in Mvar being injected into the system by the switched shunt (capacitive is positive).  The 
Actual Mvar field is equal to the Nominal Mvar field multiplied by the square of the terminal buses per unit voltage.   

Nominal MW 

This field is only visible when a switched shunt object has been read from a file as a Bus Shunt.  In that case, it is 
possible for the bus shunt to have both a MW and MVAR component.  The MW component will be displayed here.  
In general, switched shunts of other control types do not have MW components, and this field will not be displayed.  
If you change a switched shunt read as a bus shunt to another form of control, the MW component will remain, but 
has no controllability. 

Actual MW 

This field is only visible when a switched shunt object has been read from a file as a Bus Shunt.  The value 
displayed is the actual real power in MW being injected into the system by the shunt.  The Actual MW field is equal 
to the Nominal MVAR field multiplied by the square of the terminal buses per unit voltage. 

Control Mode  

Determines whether the switched shunt has a fixed value, or whether the amount of reactive power supplied by the 
device changes in either discrete steps or continuously in order to maintain its terminal voltage within the voltage 
range specified in the Voltage Regulation fields.  This field can be changed (except in Viewer).  How ever, for a 
switched shunt to be used for automatic control three fields must be set correctly: 1) the Control Mode field must be 
set to either Discrete or Continuous , 2) the corresponding area's Auto Shunts  property must be true, and 3) the 
case-wide Disable Switched Shunt Control  option, which can be set on the Power Flow Solution Tab  of the 
PowerWorld Simulator Options Dialog, must not be checked. 

Note: automatic control of switched shunts is disabled if the voltage regulation high value is not greater 
than the low value; they should not be equal unless in the continuous mode.   

Note the additional control mode called Bus Shunt (Fixed).  This is analogous to the shunt MW and MVAR values 
that can also be stored at the bus level.  The difference is that bus shunts stored directly with the bus cannot be 
turned on and off in the load flow; rather they are always included in the load flow solution.  Bus shunts that are 
represented as switched shunt objects on Bus Shunt control, however, are mathematically exactly the same and 
can be turned on or off.  The reason for the differentiation of the Bus Shunt versus normal Fixed control is that the 
Bus Shunt control type is intended to identify the difference between a bus shunt and a transformer that MAY have 
controllability, but is currently turned of off control by being set to a Fixed value.  

Voltage Regulation 

When the switched shunt is on automatic control, its reactive power is changed in discrete steps or continuously to 
keep the voltage at the regulated bus within the per unit voltage range defined by High Value  and the Low Value.  
You may modify these values (except in Viewer).  When operating in discrete control mode, the amount of reactive 
power supplied by this device changes in discrete amounts, therefore the High Value should be greater than the low 
value.  The necessary voltage range depends upon the size of the switched shunt blocks.  The Reg. Value  field 
shows the current per unit voltage at the regulated bus, while the Target Value  is displaying the actual desired 
voltage at the regulated bus.  The number of the regulated bus is shown in the Reg. Bus # field. 

Reg. Bus P.U. Voltage to Mvar Sensitivity 

The number in this area is the amount that will be added to the per unit voltage for each 1 Mvar increase by the bus 
controlling element. 

Switched Shunt Blocks 

The amount of shunt admittance is specified in the Switched Shunt Blocks table.  The columns in this field 
correspond to different blocks of admittance. The first row indicates the number of steps in each block, and the 
second row gives the amount of nominal Mvars per step.  The switched shunts are always switched in the order 
specified in this field. Reactive blocks (negative shunt MVR) should be specif ied before capacitive blocks (positive 
shunt MVR). 

 

Control Options  

Single Largest Step 

This option only applies when a switched shunt is set on discrete control.  If checked the switched shunt will switch 
in EITHER all of the available reactor blocks OR all of the capacitor blocks at once when the voltage falls outside 
the given range.  Whether the reactor or capacitor blocks switch is determined by which limit is violated.  A switched 
shunt with this option checked will only switch ONCE during a load flow  solution, and then remains fixed at the new 
output for the remainder of the same solution calculation. 

Use Continuous Element 
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If this option is checked, then Simulator will use a continuous element to fine-tune a discrete controlled switched 
shunt by injecting or absorbing additional MVARs to try and obtain the target voltage of the controlled bus. 

Minimum and Maximum Susceptance  

The minimum and maximum susceptance range for the continuous correction element. 

 

Fault Analysis Parameters 

Typically switched s hunts are treated as open circuits in the zero sequence data for fault analysis.  However, it is 
possible to define zero sequence admittance blocks to be used.  The blocks work similarly to the load flow Switched 
Shunt Blocks discussed above.  Usually there will be the same number of blocks in the zero sequence data as in the 
load flow data.  Simulator will determine how many blocks were switched in for the power flow solution, and then use 
the zero sequence block data to calculate the zero sequence admittance for the same number of steps and blocks. 

 

Owners 

This tab is used to display or change the generator’s owner information, area information, and zone information 

Area Number, Area Name 

The area number and name to which the generator belongs.  Note that you can change the area of the generator to 
be different than the area of the terminal bus.  If you do so, you will be prompted to confirm that you wish to place 
the generator within a different area than that of the bus to which it is electrically connected. 

Zone Number, Zone Name 

The zone number and name to which the generator belongs.  Note that you can change the zone of the generator 
to be different than the zone of the terminal bus.  If you do so, you will be prompted to confirm that you wish to place 
the generator within a different zone than that of the bus to which it is electrically connected. 

Owner Number, Owner Name 

The owner number and name to which the switched shunt belongs.  Note that you can change the owner of the 
switched shunt to be different than the owner of the terminal bus.  If you do so, you will be prompted to confirm that 
you wish to place the switched shunt within a different owner than that of the bus to which it is electrically 
connected. 

Substation Number, Substation Name 

The substation number and name to which the switched shunt belongs.  Note that you can change the substation of 
the switched shunt to be different than the substation of the terminal bus.  If you do so, you will be prompted to 
confirm that you wish to place the switched shunt within a different substation than that of the bus to which it is 
electrically connected. 

Zone Properties 

Zone Information (Run Mode) 
This dialog is used in the Run Mode to view and modify information associated with a zone record.  It displays different 
information from the Edit Mode version of the zone dialog.  To display it from Run Mode, first select Case Information, 
Zones from the main menu to bring up the Zone Records Display.  Right-click on the zone of interest and choose 
Show Dialog.  The Run Mode Zone Dialog has the following fields: 

 

Zone Number, Zone Name 

Number and name of the associated zone.  Use either the combo box or the spin arrows to view the different zones.   

Find… 

If you do not know the exact zone number you are looking for, you can click this button to open the advanced 
search engine. 

Labels  

To assign alternative identifying labels to the zone, click the Labels button. 

The rest of the Run Mode Zone Dialog is divided into three pages of controls: 

 

Information 

Load and Generation 

Real and reactive load, generation, shunts, losses, and interchange for the zone. 

Generation AGC Range  

These two fields show the total available MW reserve for generators in the zone that are on AGC and have nonzero 
participation factors.  In other words, these fields show the total MW by which the generation in the zone can be 
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increased or decreased using only generation that is presently on-line.  The generator status, AGC status, and 
participation factor can be changed on the Generator Records Display.   

Load Variation Model 

As with areas, the load variation within a zone is governed by a load variation schedule, which prescribes a time-
dependent load multiplier to apply to the zone's load. 

Load Schedule  

This dropdown box identifies the load schedule that is currently associated with the zone.  Use the dropdown box to 
specify the load schedule to apply to the zone from the list of defined load schedules. It is acceptable not to 
associate a load schedule with a zone, in which case the value specified in the Schedule Value  field is applied at 
all times. 

Schedule Value  

This field shows the current load multiplier for the zone, which scales all loads in the zone.  If no Load Schedule  
has been assigned to the zone, this field will display a prefix of 'N'.  If the associated load schedule is disabled, the 
field will display a prefix of 'D'. 

 

Tie Lines 

Zone Tie Lines 

The Zone Tie Line Table identifies the flows on all of the z one's ties to other zones. 

 

  OPF 

Average LMP for Zone  

The computed average locational marginal price of all buses contained in the zone. 

LMP Standard Deviation 

The standard deviation of the locational marginal price for all buses contained in the zone. 

Minimum LMP 

The minimum locational marginal price of all the buses in the zone. 

Maximum LMP 

The maximum locational marginal price of all the buses in the zone. 

  Zone Buses, Zone Gens, Zone Loads, Zone Switched Shunts  

These pages show the case information display with the buses, generators, loads and switched shunts belonging to 
the zone. 

 

  Memo 

The Memo page of the Zone Information dialog is simply a location to log information about the zone.  To log 
information about the zone, simply switch to the Memo page on the dialog, and start typing your information or 
comments about the zone in the page. 

General Properties and Information 

Labels  

Power system equipment such as buses, generators, loads, switched shunts, areas, zones, and interfaces may have 
alternative names assigned to them.  These alternative names are called labels.  Labels allow you to refer to 
equipment in the power system model in a way that may be unique to your organization.  Labels may thus help clarify 
which elements are described by a particular set of data, especially when the short names employed by the power 
system model prove cryptic.  Furthermore, since labels are likely to change less frequently than bus numbers, and 
since a label must, by definition, identify only one power system component, they may function as an immutable key 
for importing data from auxiliary files into different cases, even when bus numbering schemes change between the 
cases. 

Information dialogs corresponding to buses, generators, loads, switched shunts, areas, zones, and interfaces feature a 
button called Labels .  If you press this button, the device’s Label Manager Dialog will appear.  The Label Manager 
Dialog lists the labels associated with the device.  You can delete a label from the list by selecting it and pressing the 
delete key on the keyboard.  You may add a label to the device by typing its name in the textbox labeled New Label 
and pressing the Add button.  You will not be allowed to add a Label that already exists, regardless of whether the 
existing label is associated with the current device or some other device.  A single power system device may have 
multiple labels, but each label may be associated with only one device.   

You also may designate a particular label to be the primary label for the device by selecting it from the list and clicking 
the Make Primary button.  A device’s primary label is the one that can be displayed individually in a Case Information 
Display.  The other labels associated with a device can be used to import data from auxiliary data files, but they cannot 
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be viewed individually from Case Information Displays.  However, all Case Information Displays can hold a field that 
lists all labels assigned to a device as a semicolon-delimited string. 

Labels can be used to map data from an auxiliary data file to a power system device.  Recall that auxiliary data files 
require you to include a device’s key fields in each data record so that data may be mapped to the device.  Labels 
provide an alternative key.  Instead of supplying the bus number to identify a bus, for example, you can supply one of 
the bus’s labels.  The label will enable Simulator to associate the data with the device associated with that label.  This 
mechanism performs most efficiently when the primary label is used, but secondary labels will also provide the 
mapping mechanism. 

Again, it is important to remember this: a single power system device may have multiple labels, but each label may be 
associated with only one device.  This is the key to enabling data to be imported from an auxiliary file using labels. 

Area Properties 

Area Information 

Area Information 
The Area Information Dialog shows information about each area in the system.  It displays an area’s load, generation 
and losses; the area’s scheduled interchange with other areas; options for controlling the area’s generators, 
transformers, and shunts; the flows on its tie lines; and its operating cost information. You may view this dialog by 
doing any of the following: 

• Right-click in an empty portion of the oneline near a bus in the area of interest to display the oneline's local menu.  
Select Area Information Dialog.   

• Select Case Information, Areas from the main menu.  This displays the Area Display.  Right-click on the record 
corresponding to the desired area to bring up the display’s local menu, and choose Show Dialog. 

• Right-click on an Area/Zone Display Object that represents an area. 

The Area Information Dialog contains the following information: 

Number 

A dropdown box that specifies the area number.  Select an area from the dropdown box, or use the spin button to 
cycle through the list. 

Find By Number 

To find an area by its number, type the number in the Number field and click this button. 

Name 

A dropdown box that specifies the area’s alphabetic identifier, which may be any length in Simulator.  When saving 
area names to other load flow formats, the names are truncated at the maximum character length supported by that 
format. 

Find By Name 

To find an area by its name, type the name in the Name field and click this button. 

Find… 

If you do not know the exact area number or name you are looking for, you can click this button to open the 
advanced search engine. 

Super Area 

To associate an area with a particular super area, either select an existing super area from the dropdown box, or 
type the name of a new super area. 

Area Control Options  

Select to change the area’s method of Automatic Generation Control (AGC.)    

Labels  

To assign alternative identifying labels to the area, click the Labels button. 

The rest of the Area Information Dialog is divided into nine pages of controls: 

• Information/Interchange  

• Options  

• Tie Lines  

• Simulation Summary  

• Scheduled Power Transactions 

• OPF  

• Area Buses  
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• Area Gens 

• Memo  
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Area Information: Info/Interchange 
The Info/Interchange Tab serves as an accounting sheet for flows into and out of an area.  It houses the following 
controls: 

Load, Generation, Shunts, Losses, Interchange  

These read-only fields express the total real and reactive load, generation, shunt compensation, losses, and 
interchange for the area. 

Base Interchange by Area 

Base scheduled interchange in MW between the area and all other areas (exporting power is positive).  Base 
Interchange is interchange for which detailed time-dependent schedules are not modeled.  See Area Transactions 
Modeling<+> for more information on the difference between Base Interchange and Scheduled Interchange. 

Use the Base Interchange by Area Table  to set the interchange between the area and all other areas.  To 
prescribe the interchange with a specific area, simply enter the amount of power in MW to export to that area in the 
MW Export column.  To specify an import, enter a negative value.  If the recipient of the power is unknown, you may 
enter the net total in the Unspecified MW Interchange  field found above the list of base transactions.   

Check the box Only Show Areas with Nonzero Interchange  to display only those areas whose interchange is 
different from zero. 

By default, one interchange record is initially defined between each area.  The total interchange between two areas 
can be managed using this single record.  However, it is now possible to define multiple base interchange records 
between the same areas.  To do so, you can right-click in the base interchange table and select Insert from the local 
menu.  This will open the Transaction Dialog, which will allow you to insert a new transaction.  Transactions 
between the same two areas must have unique transaction ID’s.  Once you have multiple transactions defined 
between the same two areas, you can choose which transactions are enabled using the Enabled property in the 
Base Interchange table.  This field is a toggleable field, meaning you can double-click in the field to toggle its value. 

To save the changes you make to this table, be sure to click Save Changes or OK.  To sort the entries in any 
column in the Base Interchange Table, simply left- or right-click on the column title. 

The total Base interchange defined for an area will be displayed in the summary field labeled Base in the lower left 
corner of the page.   

Scheduled 

Current scheduled interchange in MW between the area and all other areas, with power exports represented as 
positive.  In pure power flow studies, Base Transactions are normally used instead of Scheduled Transactions, 
because pure power flow studies usually do not require time or cost information.  For a discussion of modeling area 
transactions covering how to set up scheduled transactions and the difference between this field and base 
interchange, see Area Transactions Modeling. 

ACE (Area Control Error) 

Current area control error (ACE) for the area in MW.  Note that, when the constant frequency model is used, ACE = 
area generation - area load - area losses - scheduled area interchange.  

Tolerance  

The MW tolerance is used in enforcing area interchange.  When the absolute value of the ACE is less than this 
value, Simulator considers the area interchange constraint to be satisfied. 
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Area Information: Options 
Report Limit Violations  

If checked, limit violations for this area are reported. Limits violations are reported in the Limit Violations List. 

Generation AGC Values 

These fields indicate the total available AGC range for all the generators in the zone that are specified as being 
on AGC and have nonzero participation factors.  That is, these fields show the total amount the generation in the 
area or z one that can be increased or decreased using the presently on-line generation.  This may be referred to as 
the spinning reserve.  The generator status, AGC status, and participation factor can be changed on the Generator 
Records Display.   

Load Schedule  

Use this dropdown box to specify the load schedule to use for the area.  The load schedule prescribes how the load 
in the area should vary with time. 

Load MW Multiplier Value  

This value is used for scaling the area MW load.  The base load remains unchanged. 

Load MVAR Multiplier 

This value is used for scaling the area MVAR load.  The base load remains unchanged. 

Area Slack Bus Number 

Identifies which bus to model as the area’s slack bus. 

Automatic Control Options  

The Automatic Control Options section provides a convenient mechanism to enable or disable automatic control of 
switched shunts and transformers in the area. 

Generator MW Limits  

Indicates whether or not generator MW limits should be enforced for the area. 

Include Loss Penalty Factors in ED 

If this box is unchecked, then the economic dispatch for the area is calculated assuming that the area is lossless.  
Otherwise, the solution will incorporate losses when computing the economic dispatch.  The penalty factors gauge 
the sensitivity of the area’s losses to changing injection at specific generators.  The option to calculate loss penalty 
factors is relevant only when the area operates according to Economic Dispatch Control . Usually, if the system’s 
cost curves are relatively flat, the inclusion of losses in the solution will not have much of an effect on the dispatch. 

Economic Dispatch Lambda 

The lambda value calculated during the economic dispatch computation.  This field is valid only when the area is on 
economic dispatch control. 

Wheeling Charge  

The transmission price charged by the area for wheeling power between two other areas as part of a transaction.  

Set Participation Factors 

Press this button to open the Generator Participation Factors Dialog, which gives you control over how the 
participation factor for each generating unit is defined.  If you decide not to prescribe participation factors using this 
button, Simulator will assign participation factors in proportion to the maximum MW rating of each unit.  This button 
will be enabled only if the area has been set to Participation Factor area control. 
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Area Information: Tie Lines 
The tie line grid shows the flow on all of the tie lines for the area.  The grid displays the area name, bus number, and 
bus name for each terminal of the tie line, with the local area’s terminal listed first.  The next column shows the tie 
line’s circuit identifier.  The next two columns show the real and reactive power flowing from this area to the other 
area.  The next column gives the status of the tie line as open or closed.  The last two columns show the real and 
reactive power losses.  The Tie Lines display is a Case Information Display, and contains several of the options 
available to these types of displays. 
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Area Information: Simulation Summary 
Earlier versions of Simulator employed a distinction between Simulation and Study applications.  In Study mode, 
system economics are essentially ignored.  This mode was used to perform pure power flow studies for which 
economics were not a concern.  The Simulation mode was commonly applied to timed simulations where area costs 
were a primary concern.  In terms of the user interface, the only difference between the two modes involved which of 
the two varieties of Area Information Dialog were presented to the user.  As of Simulator 6.0, the application no longer 
enforces this dichotomy between Study and Simulation modes.  To maintain compatibility with earlier versions, 
however, the Simulation Summary tab has been provided to house the contents of the Simulation-mode Area 
Information Dialog.  

Total Area Cost 

Total area cost in $ from the start of the simulation to the current time. 

Hourly Cost 

Current average hourly cost for the area in $/hour.  Select the Graph Button to the right of this field to display the 
Hourly Cost Chart for this area.   

Lambda 

Current incremental cost for the area in $/MWH.  This field is only valid if the area is on Economic Dispatch AGC.   

Load 

Present area load in MW.  Select the Graph Button to the right of this field to display the Load and Generation 
Chart for this area.   

Generation 

Current generation for the area in MW. Select the Graph button to the right of this field to display the Load and 
Generation Chart for this area.   

Losses 

Current real power losses in MW for the area.  Select the Graph Button to the right of this field to display the Area 
Losses Chart for this area.   

Sched. Interchange 

Current scheduled interchange in MW between the area and all other areas (selling power is positive) beyond the 
base value. Select the Graph Button to the right of this field to display the Area MW Transactions Chart for this 
area.  For a discussion of modeling area transactions, including how to set up scheduled transactions and the 
difference between this field and base interchange, see Area Transactions Modeling. 

Area Control Error 

Current area control error (ACE) for the area in MW.  When the constant frequency model is used, ACE = area 
generation - area load - area losses - scheduled area interchange.  Select the Graph Button to the right of this field 
to display the ACE Chart for this area. 

Inadvertent 

The inadvertent interchange keeps track of how much energy in MWH beyond its requirements the area has 
produced.  The inadvertent error increases anytime the ACE is positive (indicating the area is producing too much 
power), while it decreases anytime the ACE is negative. 

Unserved Load 

Current amount of area load that is not being served.  To account for the economic costs associated with this 
unserved load, the area hourly cost is increased by a value equal to the amount of unserved load times the case-
wide cost for unserved load (expressed in $/MWH), which is specified on the Simulation Tab  of the PowerWorld 
Simulator Options Dialog.   

Base Interchange  

Base interchange in MW between the area and all other areas, with exports represented as positive.  Base 
interchange represents real power transactions for which detailed time-dependent schedules and cost information 
are not modeled.  See Area Transactions Modeling for more information on the difference between Study 
Transactions and Scheduled Transactions. 
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Area Information: Scheduled MW Transactions 
The Scheduled MW Transactions tab identifies the scheduled transactions in which the area participates.  For more 
information on this table, please see MW Transactions Display. 
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Area Information: OPF 
The OPF Tab contains information regarding the Optimal Power Flow (OPF) solution data for an area.  It houses the 
following information: 

Average LMP for Area 

The computed average locational marginal price of all buses contained in the area. 

LMP Standard Deviation 

The standard deviation of the locational marginal price for all buses contained in the area. 

Min/Max LMP 

The minimum and maximum locational marginal price of all the buses in the area. 

Total Generator Production Cost (Scaled) 

The scaled cost includes the Cost Shift and Cost Multiplier.  These two values can be defined for each generator, 
and allow the user a way to assess changes to the LMP results when a generators cost or "bid" is modified, without 
actually changing the original generator cost or bid curve.  The scaled cost function for each generator is equal to: 

(original cost function + cost shift) * cost multiplier 

Total Generator Unscaled Production Cost 

The total unscaled generator production cost, based on the original generator cost or bid curves. 

Total Generator LMP Profit 

The profit of the generators in the area based on the Locational Marginal Prices (LMPs) determined by the OPF 
solution.  The profit is determined as: 

LMP Price * MW Output – Unscaled Cost Function 

Cost of Energy Reference 

Specify a reference for determining the cost of energy.  The choices are Cost of Increasing Export, Weighted-
Average of Area’s Bus Loads, or Weighted-Average of Injection Group. 

Cost of Losses Reference  

Specify a reference for determining the cost of losses.  The choices are Existing Loss Sensitivities Directly, Area’s 
Bus Loads, Injection Group, or a Specific Bus. 
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Area Information: Memo 
The Memo page of the Area Information dialog is simply a location to log information about the area.  To log 
information about the area, simply switch to the Memo page on the dialog, and start typing your information or 
comments about the area in the page. 
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Area Field Options 
Area field objects are used to show different values associated with areas and the system.  This dialog is used to view 
and modify the parameters associated with these fields.  Note that the area number itself cannot be changed on this 
dialog. 

 

Area Number 

Area number associated with the field.  When you insert fields graphically, this field is automatically set to the area 
number associated with the closest bus on the oneline.  With most types of area fields, an Area Number of 0 is valid 
and defines the field as showing values for the entire system.   

Find… 

If you do not know the exact bus number or name you are looking for, you can click this button to open the 
advanced search engine. 

Total Digits in Fields  

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Rotation Angle in Degrees 

The angle at which the text is to appear on the oneline diagram. 

Other Area Number 

Some of the fields, such as MW Flow to Other Area, require that a second area be specified.  If applicable, enter 
the second (other) area here. 

Other Area Transaction ID 

Since it is now possible to have more than one base transaction defined between the same two areas, base 
transactions must now also have a unique ID to distinguish between transactions among the same two areas.  If 
you are displaying a field that pertains to the display of the scheduled flow between areas, the ID of the transaction 
in question will also need to be entered here. 

Delta MW per Mouse Click  

This value is used only with the Sched Flow to Other Area field type.  When there is a nonzero entry in this field, 
and the field type is Sched Flow to Other Area, a spin button is shown to the right of the area field.  When the up 
spin button is clicked, the flow to the other area is increased by this number of MW; when the down button is 
clicked, the scheduled flow is decreased by this amount.   

Field Value  

Shows the current output for the area field.  Whenever you change the Type of Field selection, this field is updated.   

For the Sched Flow to Other Area field type only, you can specify a new value in MW.  Exports are assumed to be 
positive.  

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

 

Type of Field 

Used to determine the type of area field to show.  The following choices are available: 

Name  

Area name (eight characters maximum).  The Area Number field must correspond to a valid area. 

Number 

Area number (1 - 999).  The Area Number  field must correspond to a valid area.  

MW Load, Mvar Load 

If the area number is nonzero, then these fields show Total MW or Mvar load for the area.  If the area number is 
zero, these fields show the total load in the entire system. 

MW Generation, Mvar Generation  
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If the Area Number is nonzero, then these fields show Total MW or Mvar generation for the area.  If the Area 
Number is zero, these fields show the total generation in the entire system. 

MW Losses, Mvar Losses 

If the Area Number is nonzero, then these fields show Total MW or Mvar losses for the area.  If the Area Number is 
zero, these fields show the total losses in the entire system. 

ACE (MW)  

Area Control Error in MW for the area.  The Area Number field must correspond to a valid area.   

Hourly Cost ($/hr)  

If the Area Number is nonzero, then this field shows the hourly cost for the area.  If the Area Number is zero, these 
fields show the hourly cost for the entire system. 

Total Cost ($) 

If the Area Number is nonzero, this field shows the total cost incurred by the area since the beginning of the 
simulation.  If the Area Number is zero, this field shows the total cost incurred throughout the system since the 
beginning of the simulation. 

MW Flow to Other Area, Mvar Flow to Other Area 

Total MW or Mvar flow from the area specified in the Area Number field to the area specified in the Other Area 
Number field.  The Area Number field must correspond to a valid area.  If the Other Area Number field is zero, this 
field shows the area’s total MW or Mvar exports.   

Sched. Flow to Other Area 

Scheduled MW transaction from the area specified in the Area Number field to the area specified in the Other Area 
Number field, and with the Transaction ID given in the Other Area Transaction ID field.  The Area Number field must 
correspond to a valid area.  If the Other Area Number field is zero, this field shows the area’s total scheduled MW 
transactions.  If the Delta per Mouse Click value is nonzero, you can use the spin arrows on the oneline to change 
this value.  Also, you may directly enter a new value in the Field Value field.   

Select OK to save changes and close the dialog or Cancel  to close dialog without saving your changes. 

Load Schedule Multiplier 

Indicates the current value of the multiplier applied to the zone’s loads.  See Load Variation Dialog for more detail. 

AGC Status  

Displays the AGC status of the area.   

Select a Field   

Choose from all possible information fields that can be displayed for areas. 

Super Area Properties 

Super Area Information Dialog 
The Super Area Information Dialog displays information pertaining to Super Area Display.  It summarizes the super 
area's real and reactive load and generation, scheduled transactions, and constituent areas.  It also allows you to 
manage the list of areas to include in the super area and to designate how its generation should be controlled.  To 
display the Super Area Information Dialog, right-click on the Super Area Records Display and select Show Dialog 
from the resulting local menu.   

The Super Area Information Dialog has the following fields: 

 

Area in Super Area 

Name 

The list of all super areas that have been defined in the case are listed in this dropdown box.  Select one of the 
super areas to display its information, or type a new name in the box and click Add New to define the new super 
area. 

Rename 

Click this button to change the name of the super area specified in the Name field. 

Delete  

Click this button to delete the super area specified in the Name field. 

Areas in Super Area 

Lists the areas contained in the super area.  Right-click on a row and select Remove to remove the area from the 
super area. 

Super Area Control Options  



Printed Documentation 

256 

Specify the type of generation control to employ for the super area.  The super area may be removed from area 
control or employ Participation Factor or Economic Dispatch control. See Area Control for details on these types of 
generation control. 

An additional type of control available to Super Areas is to Use Area Participation Factors.  If the super area is set 
to participation factor control, and this option is NOT checked, then the generators within the super area respond by 
redispatching to meet the entire super area generation change based on their own participation factors.   

However, if this option IS checked, then an additional level of participation control complexity is added for the super 
area.  First, the total super area generation change is divided across each area forming the super area, according to 
the participation factors of the AREAS, as set in the grid on this dialog.  Once the total generation change has been 
determined for each area within the super area, then the generators within each individual area are dispatched 
using area participation factor control to meet each specific area's determined generation change. 

New Area Name 

Use the dropdown box to select an area to add to the super area.  Click the Add New Area by Name to add the 
selected area to the super area. 

New Area #'s  

Enter in a list of area numbers separated with dashes or commas and click Add New Areas by Number button to 
add the areas to the Super Area 

 

Summary Information 

Total Scheduled Transactions  

Lists the total scheduled import or export for the super area.  It is computed by summing the scheduled interchange 
for all areas comprising the super area.  Exports are positive. 

Total ACE 

The total area control error for the super area.  It is calculated by summing the ACE for all areas comprising the 
super area.   

Lambda 

The marginal cost associated with the super area.  Lambda is valid only for super areas that are on economic 
dispatch control. 

Tolerance  

The Area Control Error tolerance observed for the super area during a load flow solution. 

Load, Generation, Shunts, Losses, Interchange  

The Load and Generation section of the Super Area Information Dialog accounts for the real and reactive power 
flows into, out of, and within the super area.   Each quantity is computed by summing over the areas comprising the 
super area. 

Hourly Cost 

Current average hourly cost for the super area in $/hour. 

 

OPF 

The OPF Tab contains information regarding the Optimal Power Flow (OPF) solution data for a super area.  It houses 
the following information: 

Average LMP for Area 

The computed average locational marginal price of all buses contained in the area. 

LMP Standard Deviation 

The standard deviation of the locational marginal price for all buses contained in the area. 

Min/Max LMP 

The minimum and maximum locational marginal price of all the buses in the area. 

Total Generator Production Cost (Scaled) 

The scaled cost includes the Cost Shift and Cost Multiplier.  These two values can be defined for each generator, 
and allow the user a way to assess changes to the LMP results when a generators cost or "bid" is modified, without 
actually changing the original generator cost or bid curve.  The scaled cost function for each generator is equal to: 

(original cost function + cost shift) * cost multiplier 

Total Generator Unscale d Production Cost 

The total unscaled generator production cost, based on the original generator cost or bid curves. 

Total Generator LMP Profit 



Properties of Simulator Objects 

257 

The profit of the generators in the area based on the Locational Marginal Prices (LMPs) determined by the OPF 
solution.  The profit is determined as: 

LMP Price * MW Output – Unscaled Cost Function 

Cost of Energy Reference 

Specify a reference for determining the cost of energy.  The choices are Cost of Increasing Export, Weighted-
Average of Area’s Bus Loads, or Weighted-Average of Injection Group. 

Cost of Losses Reference  

Specify a reference for determining the cost of losses.  The choices are Existing Loss Sensitivities Directly, Area’s 
Bus Loads, Injection Group, or a Specific Bus. 
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Super Area Field Information 
Super area field objects are used to show different values associated with super areas.  This dialog is used to view 
and modify the parameters associated with these fields.  Note that the super area name itself cannot be changed on 
this dialog. 

 

Super Area Name 

Select the name of the super area for which you are inserting or viewing information of a super area field. 

Find… 

If you do not know the exact super area name you are looking for, you can click this button to open the advanced 
search engine. 

Total Digits in Field 

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Field Value  

Shows the current output for the super area field.  Whenever you c hange the Type of Field selection, this field is 
updated. 

Field Prefix 

A prefix that can be specified and displayed with the selected value. 

Rotation Angle in Degrees 

The angle at which the text will appear on the diagram. 

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

 

Type of Field 

Used to determine the type of super area field to show.  The following choices are available: 

Name  

Super area name (eight characters maximum).  The super area name field must correspond to a valid super area. 

MW Load, Mvar Load 

Total MW or Mvar load for the super area. 

MW Generation, Mvar Generation  

Total MW or Mvar generation for the super area. 

MW Losses, Mvar Losses 

Total MW or Mvar losses for the super area. 

ACE (MW)  

Area Control Error in MW for the super area.  The super area name field must correspond to a valid super area. 

MW Exports  

Total MW exports for the super area. 

Hourly Cost ($/hr)  

The hourly cost for the super area. 

AGC Status  

Displays the AGC status of the super area. 

MW Marginal Cost ($ / MWhr) 

MW marginal cost for the super area. 

Load Variation Properties 

Load Variation Dialog 
The Load Variation Dialog allows you to define and to modify load variation profiles.  These profiles can then be 
assigned to specific areas or zones using either the Options  tab of the Area Information Dialog or Zone Information 
Dialog or the corresponding case information display.   



Properties of Simulator Objects 

259 

Load profiles, or schedules, are piecewise linear prescriptions of how the load multiplier of any area or zone 
associated with the profile should vary over time.  Per the Load Modeling  discussion, all loads are subject both to a 
case load multiplier and to the load multiplier of their corresponding area or zone.  The Load Variation Dialog provides 
control over both these parameters. 

The Case Load Multiplier entry allows you to specify the load multiplier to apply to all loads in the case.  The nominal 
value of this parameter is 1.0.  Please see Load Modeling for further details. 

The next section of the dialog, entitled Schedule , enables you to define the load variation.  The Name dropdown box 
lists all the load variations that have been defined thus far.  If you are creating a new load variation, simply ignore the 
Name box; you will have the opportunity to assign a name to your new profile when you click Save Record As . 

The Time Scale  dropdown box controls the granularity of the schedule. 

Check the Disable option to deactivate a currently defined schedule.  Any area or zone associated with a disabled 
schedule will not have its load controlled by that schedule.  The option to disable a schedule can be particularly useful 
when you want to try several different load profiles for a particular area in subsequent simulations. 

The Current Value  text box indicates the current value of the profile’s prescribed load multiplier.  This is a read-only 
field. 

Simulator recognizes three types of load profiles: daily, weekly, and weekday/weekend.  Define the load schedule as 
one of these classes by selecting one of the choices listed under Schedule Type .  Daily load profiles specify how load 
is to vary over the course of a single day.  If the simulation stretches over multiple days, the same load variation will be 
modeled for each subsequent day if the active load profile is of type daily.  A weekly load profile is actually a 
composite of 7 daily load profiles.  It allows you to specify load multipliers for each hour of each day of the week.  If the 
simulation occurs over multiple weeks, the same weekly load variation will be modeled for each subsequent week if 
the active load profile is of type weekly.  Finally, a weekday/weekend load profile gives you the flexibility to specify 
different load profiles for weekdays and weekend days.  If all weekdays exhibit the same load variations, specifying a 
weekday/weekend schedule will require less work than specifying a weekly schedule, since a weekly schedule 
requires you to enter a profile for each day of the week.  Use a weekly profile if you want to model the variations in 
load peaks and shoulders exhibited by different days of the week. 

Following the Schedule Type option is a table listing pairs of time points and load multiple values.  This table defines 
the schedule for the load variation. If no schedule has been defined, a default schedule is shown with all values equal 
to 1.0.  If unmodified, the default schedule is automatically deleted.  If you do not wish to model a schedule, simply 
leave the default schedule without making any modifications.  

The schedule table has a local menu that can be invoked by clicking the right mouse button.  To insert a new point, 
choose Insert Time Point from the local menu, or press the Insert Time Point button.  To delete an existing time point, 
right click on the record’s Load Scale field and choose Delete Time Point, or press the Delete Time Point button. To 
see a plot of the load profile as it is currently defined, press the Show Graph button.  To modify the load multiplier at a 
particular time, simply edit the corresponding Load Scale field.   

Note that you can also edit the load profile from the graph that appears when you click Show Graph.  Click on the plot 
of the profile to reveal its vertices.  The vertices represent the time points listed in the table. When you move the 
mouse over a vertex, it becomes a crosshair pointer.  When the mouse is in this state, you can move the vertex 
around the plot area to modify both the time and the load scale parameters associated with that point.  You may 
discover and even modify the load scale associated with a vertex by right clicking the mouse when the pointer is a 
crosshairs.  You may introduce a new time point by holding the CTRL key down and then selecting the curve with the 
left mouse button at the point in time where you want to define the new  load scale.  You can delete a vertex by holding 
down CTRL as you select the vertex with the left mouse key.  You can adjust the scale of either axis by right-clicking 
on the axis.  Finally, you may move the entire load profile up or down the load scale or along the time axes by 
selecting the curve somewhere other than at a vertex.  When you are done modifying the load variation using the plot, 
you may close it. 

To save the changes you have made to the load profile, click Save Record.  To save the load prof ile to a new 
schedule, click Save Record As .  Finally, to close the Load Variation Dialog without saving your changes, click 
Cancel. 

Interface Properties 

Interface Information 
The Interface Dialog is used to create, modify, or delete interface records in both the Edit and Run Modes.  This dialog 
has the following controls: 

 

Interface Name 

An alphanumeric identifier for the interface of up to 24 characters.  Use the dropdown box or the spin button to 
navigate through the list of existing interface records. 

Interface Number 

A numeric identifier for the interface, between 1 and 32,767. 

Add New Interface  
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Click the Add New Interface button to define a new interface from the Interface Dialog.  When you click this button, 
the Interface Name field and Interface Elements table are cleared, requiring you to enter a new name and new 
elements. 

Delete Interface 

Select this button to delete the currently displayed interface.  Once the interface record has been deleted, the 
Interface Name field displays the previous interface record, if any.  If there are not previously defined interface 
records, Simulator will close the dialog. 

Interface Limits  

Specify the possible limits for net interface flow.  As for transmission lines and transformers, up to eight distinct 
limits can be specified for interfaces.  Which limit set is used can be controlled from the Limits Tab  of the 
PowerWorld Simulator Options Dialog or the Line and Transformer Limit Violations Display. 

Direction for Flow Monitoring 

This area allows the user to change the flow monitoring direction.  Clicking on the interface in the Interface 
Elements area will bring up the Interface Elements Dialog.  This is where the default direction is set.  To keep this 
default direction, choose FROM à TO, to change this direction, choose TO à FROM, and to monitor both 
directions, choose Both Directions. 

Non-contingent MW Flow 

Indicates the present net flow through the interface elements, not including affects of contingencies, in MW. 

Contingent MW Flow  

The amount of flow that would be added to the interface flow if the contingency defined with the interface were to 
occur, in MW. 

Total MW Flow  

The sum of the non-contingent MW flow and Contingent MW flow, for the total MW flow considered on the interface, 
in MW. 

PTDF Value (%) 

The Power Transfer Distribution Factor for the interface, if calculated. 

 

Interface Elements  

The Interface Elements Table lists each element comprising the interface.  If Simulator is in Run Mode, the table will 
also show the present flow through each element.  To edit or delete an existing element in the table, click on it to bring 
up the Interface Element Dialog.  Use the Interface Element Dialog to modify or delete the element. 

Insert New Element 

Click the Insert New Element Dialog to add a new element to the interface using the Interface Element Dialog. 

Click OK to save any changes you have made and to close the Interface Information Dialog.  Click Save to save 
your changes but to leave the dialog open so that you can view and modify other interface records.  Click Cancel to 
close the dialog without saving your latest change.  

Element Identifiers 

Choose whether to show the interface descriptions using the interface names, the interface numbers, or a 
combination of both. 

 

OPF 

The OPF page will only be visible if you have the Optimal Power Flow add-on for PowerWorld Simulator.  This page 
contains interface information relating to performing an OPF solution. 

Enforce Interface Flow Limit 

If checked, the Interface limit will be checked for enforcement during an OPF solution. 

Treat Limit as Equality Constraint 

If checked, the OPF routine will try and maintain the flow on the interface at its limit value.  Otherwise the limit will 
be treated as the maximum for an inequality constraint. 

Limit Marginal Cost 

The incremental cost of maintaining the flow on the Interface at its limit value. 

MW Flow on Interface  

The actual MW flow on the interface. 

Present MW Limit 

The currently defined limit for the interface. 
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Percentage of Limit 

The MW flow on the interface as a percentage of the limit. 

Flow Limit Unenforceable  

This field cannot be changed by the user.  If the OPF solution cannot maintain the limit on the interface and reach a 
solved state, then this box will be checked by Simulator and the Interface limit will be violated. 
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Interface Element Information 
The Interface Element Dialog is used to redefine or to add the individual elements comprising an interface.  Individual 
lines or transformers, inter-area ties, inter-zone ties, line contingencies, DC lines, injection groups, generators, and 
loads may make up an interface.  The Interface Element Dialog allows you to add all three varieties of interface 
elements to an interface. 

The Interface Element Dialog comes in two very similar forms, depending upon how it was invoked.  The dialog may 
be called from the Interface Information Dialog by clicking on either the Interface Elements Table or the Insert New 
Element button. 

 

The Interface Element Dialog contains the following controls: 

Element Type  

Specifies the type of interface element being investigated or added.  Interface elements can be any line or 
transformer or, more specifically, they can be groups of lines and transformers that tie two areas or two zones 
together.  Interfaces can also contain line contingencies, DC lines, generators, loads, and injection groups.   

When the selection for Element Type changes, the available Element Identifiers change to allow you to pick the 
appropriate elements of that type. 

Element Identifiers 

Depending upon the Element Type selection, different element identifiers are required to designate the element to 
add to the interface.  You can search through the list of identifiers to find the particular elements you wish to include.  
Note that the flow direction on transmission line, transformer, and DC line elements will be dependent on which end 
of the line you choose as the near bus.  The flow will always be measured in the direction of near bus to far bus.  
The flow will be positive when flowing from near to far, and negative when flow from far to near.  In addition, line 
elements also have an additional setting labeled Monitor Flow at To End.  This determines which magnitude of 
flow should be reported.  If checked, the flow  at the To end of the line will be reported, otherwise the flow magnitude 
at the From end is used. 

Insert 

If you came to the Interface Element Dialog by pressing the Insert New Element button on the Interface Information 
Dialog, only the Insert, Cancel, and Help buttons will be available.  Click the Insert button to add the element you 
have just defined to the list of elements comprising the interface.  After you click Insert, the dialog will disappear, 
and the Interface Elements table on the Interface Information Dialog will contain the element you just added. 

Replace, Delete  

If you arrived at the Interface Element Dialog by clicking on an element in the Interface Elements Table of the 
Interface Information Dialog, the Replace , Delete , Cancel, and Help buttons will be visible.  Click Replace  to 
modify the interface element according to your specifications on this dialog.  Click Delete  to remove the element 
from the interface definition. 

Cancel 

Click Cancel to close the Interface Elements Dialog without saving your changes. 
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Interface Field Information Dialog 
Interface field objects are used to show the different values associated with interface records.  This dialog is used to 
view and modify the parameters associated with these fields.  The dialog has the following fields: 

 

Interface Name 

Case insensitive name of an existing interface (12 characters maximum). 

Find… 

If you do not know the exact interface name you are looking for, you can click this button to open the advanced 
search engine. 

Total Digits in Field 

Total number of digits to show in the field. 

Digits to Right of Decimal 

Number of digits to show to the right of the decimal point. 

Rotation Angle in Degrees 

The rotation angle at which the text field should be displayed. 

Anchored 

If checked, the interface field is anchored to its associated interface display object.   

Include Suffix 

If the Include Suffix checkbox is checked, the corresponding field units will be displayed after the current value.  
Otherwise, only the value without units will be shown. 

Type of Field 

Type of field to show for the interface record.  Interface fields may show the interface's name, its MW Limit, MW 
Flow, percent loading, or any other interface specific field available by clicking the Select a field option and choosing 
a field from the drop-down list. 
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Interface Pie Chart Information Dialog 
Interface Pie Chart objects are used to graphically show the percentage flow associated with interface records.  This 
dialog is used to view and modify the parameters associated with these fields.  The dialog has the following fields: 

 

Interface Name 

Case-insensitive name of an existing interface (12 characters maximum). 

Size 

Size of the pie chart.  Note that the pie chart's size and color can be set to change automatically when the 
interface's loading is above a specified limit.  Please see Oneline Display Options for details.   

Percent (read-only) 

In Run Mode, this field shows the current percentage loading for the interface; if the MVA rating is zero, the 
percentage is defined as zero, as well. 

MW Rating 

MW limit for the interfac e, using the current limit set for the case.   

Anchored 

If checked, the interface pie chart object is anchored to its associated interface.   
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Nomogram Information Dialog 
The Nomogram Dialog is used to create, modify, or delete nomogram records in both the Edit and Run Modes.  
Nomograms are used for combining a pair of interface objects for the purpose of monitoring a combined flow 
restriction on the two interfaces together. 

 

This dialog has the following controls: 

Nomogram Name 

An alphanumeric identifier for the nomogram. 

Interface A 

The first interface forming the interface pair.  To add the interface from scratch in the nomogram dialog, click on the 
Insert New Element button.  In this manner you will be creating the interface from the individual elements, the 
same as creating an interface on the interface dialog.  If you already have an interface defined, and wish to clone 
the elements of that interface for this nomogram, use the button labeled Clone Elements From to find the interface 
and copy the element definition. 

Interface B 

The second interface forming the interface pair.  To add the interface from scratch in the nomogram dialog, click on 
the Insert New Element button.  In this manner you will be creating the interf ace from the individual elements, the 
same as creating an interface on the interface dialog.  If you already have an interface defined, and wish to clone 
the elements of that interface for this nomogram, use the button labeled Clone Elements From to find the interface 
and copy the element definition. 

Nomogram Breakpoints  

This section is used for defining the limit boundaries for the interface.  The limit boundaries are defined by inserting 
nomogram breakpoints.  These breakpoints correspond to a pair of MW flows on each interface.  In other words, 
you define the amount of flow allowed on Interface B when interface A is at a certain amount.  Typically you will 
have a flow limit on Interface B that is constant for a certain range of flow in interface A.  Howev er, at some point as 
the flow on Interface A increases, the limit of flow on Interface B can start to decrease due to desired flow limit 
restrictions of the combined interfaces.  At some point, the limit of Interface A would reach a maximum amount and 
remain constant, and the range of flow on interface B would be fairly small due to the heavy loading in Interface A. 

To build this Nomogram Limiting Boundary, begin by right-clicking in the Nomogram Breakpoints list and choose 
Insert Point.  Note that the boundary definition must be a convex piecewise linear curve.  You would typically being 
by defining the flow limit allowed on Interface B when the flow on interface A is small or zero.  Then define 
breakpoints where the limit on B decreases as the flow on A increases.  Eventually you will define a point where the 
flow on A reaches a limit as the flow on B continues to decrease towards zero.  In short, the nomogram limiting 
boundary is actually a combination of boundary limits that are scaled combinations of the individual interface limits.  
See the image below for an example of a nomogram limiting boundary. 
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Text-Based Information Displays  

Chapter 8 : Text-based Information Displays 
This chapter describes the case information displays.  The case information displays are used to display information 
about the case, regardless of whether or not it is shown on the onelines.   

The following material is included: 

• Overview of Using the Case Information Displays 

• Use of Data Filters 

• Power Flow and Quick Power Flow List Displays 

• Information Summary Displays 

• Displays for All Major Case Components   

Fundamentals  

Case Information Displays  

Simulator offers several Case Information Displays that provide a convenient, spreadsheet-like view of the power 
system and its components and are available regardless of whether the case has an associated oneline diagram or 
not.  The Case Information menu item provides a link to these displays.  Case information displays are available for 
buses, bus mismatches, generators, generator costs, ac lines, transformers, transformer impedance correction tables, 
dc lines, interfaces, areas, zones, schedules, and many other types of objects.  Other screens, such as the 
Area/Zone/Owner Filters and Limit Violations displays to name a couple, also fall into the category of case information 
displays.  There are many different characteristics associated with the Case Information Displays, as discussed in the 
following topics: 

Colors and Cell Styles  

Using Cell Handles  

Local Menu Options  

Sorting Records  

Configuring the Case Information Displays  

Finding Records  

Case Information Displays  

Configuring the Case Information Displays 
The content and format of all case information displays can be controlled through the Display / Column Options dialog.  
This dialog can be viewed by clicking Display/Column Options  from the case information display’s local menu. 

To reset all case information display properties to their default settings, including column and data field associations, 
click the Reset All to Default Values button.   

To save your changes and close the dialog box, click OK.  To save your changes without closing the dialog box, click 
Save.  To undo the changes you have specified and close the dialog box, click Cancel.  Finally, click Help to view the 
corresponding help screen. 

 

 Column Options  

Available Fields  

This list contains all the fields available for addition to the respective case information display.  You may select 
several entries from this list by holding down the Shift and Control keys.  Hold down the control key to select several 
individual fields.  Hold down the Shift key to select all fields between two successive mouse clicks.  You may then 
add multiple fields to the Shown fields (see Add below). 

Show these fields in this order 

This list contains the fields which are presently shown on the respective case information display.  You may select 
several entries from this list by holding down the Shift and Control keys.  Hold down the control key to select several 
individual fields.  Hold down the Shift key to select all fields between two successive mouse clicks.  You may then 
remove multiple fields (see Remove  below) or move the order of fields (see Move  below). 

Column Width 

Enter a new value to adjust the physical width of the column.  This will affect all fields selected in the Show these 
fields list. 

Total Digits  

The number of digits to use when displaying values in the column (including the decimal point.)  This will affect all 
fields selected in the Show these fields list. 

Decimal Places 
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Number of total digits to the right of the decimal point.  This will affect all fields selected in the Show these fields list. 

< Remove (Removing Columns) 

Click the < Remove  button to remove the fields that are currently selected in the Show these fields list.  You may 
also click on the selected fields in the Show these fields list and drag and drop the fields on the Available fields.  

Add > (Inserting Columns) 

Click the Add > button to add all selected available fields to the end of the Show these fields list.  You may also 
click on the selected Available fields and drag and drop the field on the Show these fields list.  When drag/dropping 
the fields, all selected fields will be inserted just before the field that the mouse is over when you drop the fields.  
Once you have added fields you may then utilize the  

Move Up, Move Down (Moving Columns) 

If you selected a block of fields in the Show these fields list, you may change the order of the list by clicking on the 
Move Up or Move Down button. 

Highlight Key Fields  

Checking this option will highlight the key fields  for the type of object displayed in the case information display 
presently being modified.  The fields highlighted in Yellow in the two lists are either the Primary key fields 
(numbered) or the Secondary key fields (lettered).  Note that some key fields, usually the Circuit ID, are both 
numbered and lettered, meaning they are used as both Primary or Secondary key fields.  Either ALL numbered key 
fields OR all lettered key fields must be included in the list of shown columns if you intend to export the data to 
either Excel or a text file, modify it, and paste it back into Simulator. 

The fields highlighted in Green are the fields that would be necessary in Excel or an auxiliary file in order to create 
NEW objects of the type displayed when pasting from Excel or reading in an auxiliary file.  If all of the green 
highlighted fields are not present in the external source, Simulator will not be able to create new objects that may be 
defined in that source, and will only paste information for objects that already exist in the present case. 

Frozen Columns  

The number of columns that are fixed and do not scroll when you scroll left or right in the display.  Frozen columns 
will have a background color of gray instead of white.  The number of frozen columns is 1 by default. 

 

Display Options  

Automatically Refresh 

Check this box to ensure that data presented by the case information displays always reflects the current state of 
the system.  Generally, you will want to have the case information displays refresh automatically.  However, for 
large systems, having several automatically refreshing case information displays open simultaneously may hamper 
program performance. 

Use Area / Zone Filters 

Check this box to restrict the case information display’s record set to cover only those areas and zones specified by 
the area/zone/owner filters.  If this box is unchecked, all records, regardless of zone or area, will be displayed.  (The 
area/zone filters option obviously does not apply to the Area/Zone Filters information display.) 

Advanced Filter 

Clicking this button will open the Advanced Filters Dialog, which will allow more detailed filtering on the display. 

Use Custom Font / Row  Height 

If checked, then the Row Height and Custom Font specifications will be used.  Changing either the Row Height or 
Custom Font properties will cause this box to become checked automatically.  If you wish not to apply your custom 
specifications to the active case information display, uncheck this box; the default font and row height settings, as 
defined under the Case Information Displays tab of the PowerWorld Simulator Options dialog box, will be reapplied. 

Row Height 

Defines the height of the rows of the case information display. 

Change Custom Font 

Defines the font with which to display the records. 

Set as Default 

Sets the current Font and Row Height as the defaults. 

Auto Size all Column Widths  

Constrains all field widths to contain the widest data elements in each column. 
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Case Information Displays: Local Menu Options 
All case information displays have a set of local menu options.  The local menu can be brought up at any time by right 
clicking on case information display.  The following local menu options are common to most case information displays.  
Additionally, many local menus of case information displays have specific menu options that are only available for the 
type of object being displayed. 

 

Find 

Use the Find local menu option to retrieve a record pertaining to a particular element.  Choosing Find from the local 
menu will open the Find Dialog Box, which may be used to find records pertaining to an element identified by either 
number or name. 

Search for Text 

Use the Search for Text local menu option to find text inside the Case Information display.  Choosing Search for 
Text from the local menu will open the Search for Text Dialog, which may be used to find the specified text in a list 
display. 

Contour Column 

Use the Contour Column local menu option to contour a column of the list display.  Choosing Contour Column from 
the local menu will open the Contour Column Dialog. 

Display/Column Options  

The contents and format of the information display can be controlled using the Case Information Display Dialog.  
See Configuring the Case Information Displays for more details. 

Show Dialog 

Selecting the Show Dialog option will invoke a dialog box containing more detailed information and settings 
regarding the corresponding system object.  For example, clicking Show Dialog from the local menu of a Bus Case 
Information Display will bring up the Bus Information Dialog. 

Quick Power Flow List 

Use the Quick Power Flow List local menu option to invoke Simulator's Quick Power Flow List tool. 

Bus View Oneline  

Use the Bus View Oneline local menu option to bring up the Bus View Display, which illustrates how the selected 
bus is connected to the rest of the system.  

Copy All 

The Copy All menu option copies the entire record set contained in the case information display to the Windows 
clipboard, from which it can be copied into other programs such as Excel for further analysis.  See Copying 
Simulator Data to and from Other Applications for more details. 

Copy Selection 

The Copy Selection menu option copies the records selected in the case information display to the Windows 
clipboard, from which the selection can be copied into other programs such as Microsoft Excel for further analysis.  
See Copying Simulator Data to and from Other Applications for more details. 

Send All to Excel 

The Send All to Excel menu option copies the entire record set contained in the case information display and 
automatically sends it to Excel.  The first time this option is selected, Simulator will start a new instance of Excel on 
your machine and paste the data on the first sheet.  Subsequent calls to Send to Excel will continue to add sheets 
and paste data to this instance of Excel, until the Excel instance is closed manually by the user. 

Send Selection to Excel 

The Send Selection to Excel menu option copies the selected record set in the case information display and 
automatically sends it to Excel.  The first time this option is selected, Simulator will start a new instance of Excel on 
your machine and paste the data on the first sheet.  Subsequent calls to Send to Excel will continue to add sheets 
and paste data to this instance of Excel, until the Excel instance is closed manually by the user. 

Copy / Send Special 

The Copy / Send Special menu option will open the a dialog that allows the user to set a few custom options before 
completing the data copy.  The user can choose to copy all or a selection, and to copy the data either to the 
Windows clipboard or send it directly to Excel.  In addition, the user can choose whether to use the normal column 
headings or variable names as column identifiers.  Lastly, the user can specify whether or not to include a row 
containing the type of object the data represents (Object Name) and a row containing the column headers for each 
column of data.  Note that for pasting the information back into Simulator, the Object Name and Column Heading 
rows must be contained with the data to be pasted.  If you have changed the settings on this dialog and wish to 
make them the case default settings, click on the Make Default for all Copy Actions button. 

Paste 
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Select Paste from the local menu to copy a record set from the Windows clipboard into the case information display.  
See Copying Simulator Data to and from Other Applications for more details. 

Print 

You can print the contents of most of the case information displays by selecting Print from the local menu. 

Save As  

This option will save the contents of the case information display to an external file. 

Auxiliary File  

This option allows saving all the contents of the case information display to an auxiliary file. 

Auxiliary File (Only Selection) 

This option allows saving the selected record set in the case information display to an auxiliary file. 

CSV (Comma Delimited) 

This option allows saving all the contents of the case information display to a comma delimited file. 

CSV (Only Selection) 

This option allows saving the selected record set in the case information display to a comma delimited file. 

HTML 

You can save the entire table or selected records to an HTML file for viewing from an Internet browser.  For 
more information, see Saving Case Information Display Contents as HTML Tables. 

Bitmap 

This option allows saving the case information display into a Bitmap picture file. 

JPeg 

This option allows saving the case information display into a JPEG picture file. 

Load 

This option will load the contents of an external file to the case information display. 

Auxiliary File (Any Data) 

This option allows loading an auxiliary file containing any data. 

Auxiliary File (Only Specific Data) 

This option allows loading an auxiliary file containing only data related to the current case information display. 

Advanced Filter 

Allows the user to custom filter the information in the display based on desired criteria.  See Advanced Filtering for 
more information. 

Advanced Sort 

Allows the user to custom sort the information in the display based on desired criteria. 

Define Expression 

Allows you to define Custom Expressions that are functions of other fields. 

Get Column Metrics  

This option allows you to compute the metrics for the selected column.  Choosing Get Column Metrics from the 
local menu will bring the Grid Metrics Dialog.  This option is only available for columns whose content is numeric. 

Refresh Display 

Select this option to update the currently displayed data to match the present state of the system. 

Why is this field or line disabled? 

This option will display a message showing the reason why the field is disabled.  This option will be enabled only if 
the field is actually disabled. 

Help 

Display context-sensitive help for the case-information display. 

Form Control 

This menu option allows to control the case information display. 

Close 

Closes the case information display. 

Make Top Left of Form Visible  

Makes the top or the left of the case information display visible, if either the top or the left are not visible. 
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Shift Form Up 

Moves the case information display up so the bottom of the case information display can be visible. 

Maximize 

Maximizes the size of the case information display. 

Unmaximize (Restore) 

Restores the size of the case information display. 

Minimize 

Minimizes the size of the case information display. 
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Case Information Displays: Colors and Cell Styles 
The case information displays distinguish data field types by text color and cell style.  Most of the entries on the case 
information display are colored using the following color convention.  These colors can be customized using the Case 
Information Displays tab on PowerWorld Simulation Options Display , which can be invoked by selecting 
Options/Tools > Solution/Environment from the main menu.  

 

There are three types of data fields:  

Standard Fields Fields that cannot be modified directly from the case information display are colored black 
by default.   

Enterable Fields Fields that can be modified are colored navy blue by default.  When selected, a cell 
containing an enterable field will display a tiny filled square in its bottom right corner.  This box is called a cell. 

Toggleable Fields Fields whose values can be toggled are colored green by default.  The values contained 
in toggleable fields are modified by left-clicking on them.  Like cells in enterable fields, cells in toggleable fields 
display a cell handle when selected. 

Besides indicating field type, color coding is also used to highlight violations of branch flow, generator MW or MVR 
output, and bus voltage constraints.  Fields that are either at a limit or violating a limit are colored red by default.  This, 
too, is configurable from the Case Information Displays tab on PowerWorld Simulation Options Display . 
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Case Information Displays: Using Cell Handles 
When selected, cells corresponding to enterable and toggleable fields exhibit a small filled square in their bottom right 
corner called a cell handle.  The cell handle may be used to propagate the value of the selected cell to other cells in 
the same field.   

Suppose we have selected a toggleable or enterable cell and that we wish to copy its value to other records.  Call this 
cell the source cell and its value the source value.  To copy the source value to another record or records, perform the 
following steps: 

 

• Drag the mouse onto the cell handle until the pointer becomes a crosshair.   

• With the mouse pointer showing as a crosshair, click and hold the left mouse button.   

• With the left mouse button depressed, drag the mouse up or down from the source cell to select a group of records 
to which to copy the source value.  These destination cells will display a yellow background when selected in this 
manner. 

• When you have finished selecting the destination cells, release the left mouse button. 

• A message box w ill appear asking whether you want to change the values of the destination cells to the source 
value.  Answer Yes to complete the copy. 



Printed Documentation 

274 

Case Information Displays: Sorting Records  
You can sort the entries on the case information displays by just about any field.  To sort the records by a particular 
column, left-click on the column’s heading.  Left-click the column’s heading again to reverse the sort order. 

To sort the records by the absolute value of a field, hold down the shift key as you left-click on the field’s heading. 

Simulator also has a more advanced sorting tool, which can be accessed by selecting Advanced Sort from the local 
menu.  Advanced sort allows you to sort information based on values in more than one column of data.  Advanced sort 
also allows you to sort based on the absolute value of numerical fields and by case sensitivity for string fields. 
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Case Information Displays: Finding Records  
The Find Dialog is used to find the device of the specified type on the different Case Information displays.  The Find 
Dialog is available on most case information displays from the local menu, which can be invoked by right-clicking in 
the grid.  

Different Find dialogs exist for Areas, Buses, Interfaces, Lines and Zones.  Note that the Bus Dialog is used to locate 
all bus objects, such as generators, loads, switched shunts and the bus  itself.  In general, the format of each dialog is 
similar, allowing you to find the desired object using either its number or name.  The only exception is interfaces, for 
which no name is defined.  The basics of the Find dialog are explained in the Find Dialog Basics help topic. 

Filtering 

Area/Zone/Owner Filters 
The Area/Zone/Owner Filters Display, invoked by clicking Case Information > Area/Zone/Owners Filters from the 
main menu or the corresponding button on the Options/Info Toolbar, allows you to filter the information shown on the 
case information displays and other dialogs by area, zone or owner.  For small cases, you will usually not need to use 
this filtering capability, but it can be essential for large cases.  The filters display lists each area, zone and owner in the 
case, the number of buses in each, the range of bus numbers contained in each, and whether or not information about 
that area, zone or owner should be displayed.  In order for a device to be displayed, its area, zone and owner Shown 
property must be set to yes. 

You can switch between displaying the filters for the case areas or the zones by clicking on the associated tab. 

The Filters list is itself a case information display and therefore shares many of the same local menu options and 
characteristics.  Using the local menu, you can search for an area, zone or owner by number or by name, copy 
records to and from other applications, and send the records to a printer.  You can inspect an area, zone or owner by 
selecting Show Dialog from the local menu, which invokes the Area Information , Zone Information or Owner 
Information Dialogs.  You can also change the format and content of the filters display by selecting the Display 
Column/Options  item from the local menu.  The records can be sorted by any of its component fields simply by clicking 
the corresponding column’s heading. 

The display’s only enterable field is the one entitled Shown, which may assume only the values Yes and No.  For 
example, if the Area/Zone/Owner Filters setting for an area is No, then any case information display configured to 
enforce area/zone/owner filters will omit the area’s elements from the resulting record set.  You can specify whether a 
particular case information display enforces filters using the display’s Display/Column Options Dialog.   

Double-click on a cell in the Shown field to toggle its value.  Use the cell handle to propagate a particular value to 
multiple areas, zones or owners, or use the Toggle All Yes or Toggle All No local menu options to set the values of all 
area, zone or owner records. 
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Advanced Filtering 
Simulator has always had the ability to filter data by Area and by Zone.  In Version 10 it is also possible to filter by 
Owner.  This is known as Area/Zone/Owner Filtering.  In Version 7.0 the ability to augment this filtering using 
Advanced Filtering was added.  Advanced Filtering is accessed by right-clicking on a Case Information Display and 
choosing Advanced Filter from the local menu.  This brings up the Advanced Filters Dialog, which allows you to 
custom filter the information in the display.  Advanced Filters are stored with your Power System Case.  

A Case Information Display will have the phrase "(advanced filter)" in its caption if an Advanced Filter has been 
applied to it.  To remove a filter from a Case Information Display, bring up the Advanced Filters Dialog and and click 
on Remove .  Note that Remove does NOT delete the filter, but just stops using it to filter the data.  You can always 
remove the filter temporarily and then come back into the Advanced Filters Dialog and reapply the filter.  If you want to 
Delete a filter, you must bring it up in the Advanced Filters Dialog and click on Delete .   
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Advanced Filters Dialog 
When you open this dialog, you will only see filters that have been defined for the type of object you are trying to filter 
(e.g. Bus, Generator, Interface, etc…).  You can choose a filter from the Filter Name drop-down box showing the list of 
filters available, or you can create a new filter.  To make a new filter, simply click on Save As to save a copy of the 
present filter under a new name and then specify the properties of the f ilter as discussed below.  When you have 
specified the filter as you wish, click Filter. 

Note that advanced filters are stored with the case file when the case is saved.  In addition, the filters can be exported 
to a Simulator Auxiliary File for storage and import into other cases.  A list of all advanced filters defined for a case can 
be viewed in the Advanced Filters case information display. 

 

To create an Advanced Filter you must specify the following things: 

Filter Name 

A string that describes your filter so that you can call it up from other forms in the future. 

Condition 1, Condition2, etc… 

Describes the conditions of your filter.  To define a condition 

• Specify the field you are filtering.  By default, the fields in the drop-down list are limited to the fields presently 
shown as columns in the display.  If you wish to choose from a list of all fields for the object, change the radio 
button setting to Show All Fields . 

• Specify the comparison operation such as "between" or "greater than". 

• Specify the values the field is compared to. Depending on the comparison operation, either one or two values 
are needed. 

• Select ABS to use the absolute value of the field value in the comparison operation. 

Note: The comparison operation "within integer range list" uses the same format as described in Entering a Range 
of Numbers. 

Note: To add or delete conditions click on the Add>> or Delete… button 

Logical Comparison 

The following describes how the Filter uses the Conditions which are specified   

• AND means that all conditions should be true 

• Not AND is the opposite of AND (i.e. any one of the conditions can be false) 

• OR means that any one of the conditions can be true 

• Not OR is the opposite of OR (i.e. all of the conditions must be false) 

Pre-Filter using Area/Zone Filters 

When this box is checked, data is filtered first by the Area/Zone/Owner Filters and then by the Advanced Filter, 
therefore the data must meet both filters in order to be shown.  When this box is unchecked, the Area/Zone/Owner 
Filters are ignored. 

Enable Field to Field Comparisons  

When this box is checked, it is possible to compare two fields.  In order to do so, select Field and click on Find to 
select the second field to be compared. 
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Advanced Filters Display 
The Advanced Filters Display is a Case Information Display available from the Case Information > Other > 
Advanced Filters menu option.  The purpose of this display is to list any advanced filters you have defined for the 
current case.  Each record will list the name of the filter, the type of object the filter is for, filter logic, and whether or not 
a pre-filter was used.  Advanced filters cannot be created or deleted manually from this display, but they can be saved 
to an auxiliary file or loaded from an auxiliary file by right-clicking on the display and choosing the appropriate option 
from the popup menu. 

Custom Expressions  

Custom Expressions 
Simulator allows you to define Custom Expressions that are functions of other fields.  These Custom Ex pressions can 
then be shown as a column in the Case Information Display.  Defining Custom Expressions is accessed by right-
clicking on a Case Information Display and choosing Define Expression from the local menu.  This brings up the 
Define Custom Expressions Dialog.  When you bring up the dialog you will only see expressions that have been 
defined for the type of object shown on the Case Information Display (e.g. Bus, Generator, Interface, etc…). 

To define a new custom Expression click New.   

You can name the expression for easy identification in the list of fields for the object by filling in the Expression Name 
field. 

To define the Custom Expression, first specify which fields you would like to use in the expression and assign them to 
the variables x1, x2, …, x8.  Then type in the expression as function of the variables x1, x2, …, x8.  For example 

x1 * SIN(x2) + EXP( -x5) 

or 

TAN(x1) + ABS(x6)*8 - 100 

For a complete list of functions and operators that are available to you, see Functions and Operators Available. 

Once the Custom Expression has been defined, you may add the expression to the column of the Case Information 
Display you called it from by clicking on Add Column…  For more information on how to add columns to a display see 
Configuring the Case Information Displays. 
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Custom Expressions Display 
The Custom Expressions display can be opened by choosing the menu option Case Information > Other > Custom 
Expressions.  If you have defined any custom expressions for your case, you can see the list of those expressions in 
this display.  The name of the expression is given, along with the custom expression itself.  The display also shows the 
values being represented by each of the variables in the custom expression. 

Custom expressions cannot be inserted manually in this display, but they can be loaded from an auxiliary file by right-
clicking on the grid and choosing to load data from an auxiliary file.  Conversely you can save a list of custom 
expressions in a case to an auxiliary file by right-clicking on the grid and choosing Save As > Auxiliary file. 

General 

Contour Column Dialog 
The Contour Column Dialog allows you to contour case information display columns. 

The Contour Column Dialog has two tabs: the Contour Type Tab, and the Custom Color Map Tab. 
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Find Dialog Basics 
Many times when working with large load flow cases, it can be somewhat difficult to locate devices in the case 
information displays regarding a specific device.  Simulator has many tools to facilitate filtering data, such as the 
Area/Zone/Owner filters and the Advanced Filtering tool.  Even with these helpful tools, finding a device can still be 
hampered when the bus number or exact spelling of the bus name are not known. 

To facilitate locating devices in Simulator, you can use the Find tool to use Simulator’s advanced search engine for 
finding the device(s) you are looking for.  The Find tool is available from the popup menus of almost all case 
information displays, as well as several of the various information dialogs in Simulator.  Anywhere you see a button or 
menu option labeled Find… you can open the advanced search tool. 

Once the Find dialog has been opened, the dialog will automatically adjust to suit the type of device you are searching 
for.  The caption of the dialog should reflect the type of object the dialog is currently attuned to locate.  For most 
devices, such as buses, generators, loads, etc., there will be one list displayed at the bottom of the dialog containing 
numbers and names of the type of device you are searching for.  In some instances, mostly when searching for 
branch-type devices, the bottom panel is split with a second list is displayed in the right side panel.  This list is used to 
display the possible connections of the bus selected in the first list.  For example, if bus number one is selected and it 
has connections to bus two and bus three, the second list will display the information for bus two and bus three.  Thus 
you can search for a bus in the first list, then choose from the possible connections in the second list to get a specific 
branch from the list. 

Despite what type of device you are trying to find, the first few options and buttons on the dialog will be the same.  
Sort by Name and Sort by Number allow you to choose how you wish to find a device in the list.  If you know the bus 
number you are looking for, choose Sort by Number.  If you know the name, or at least part of the name, that you are 
looking for, then choose Sort by Name.  The list (or first list for branches) will be sorted accordingly. 

If you wish to narrow down the list of devices to search through, you have a couple of options for filtering the list before 
searching through it.  First you can make use of the traditional Area/Zone/Owner filters by clicking in the associated 
check box.  If you need to set more specific conditions for filtering the list, you can instead click the Define Filter 
button to set up an advanced filter.  Either one will reduce the number of devices in the list for the search. 

Once you have the list set up for your search, you can type in the number or name you wish to find in the text box.  If 
you do not know the exact number or name, you can use wildcards to facilitate the search and find all possible 
matches for a set of characters or numbers.  You can use a question mark (?) to represent a single character wildcard, 
or an asterisk (*) to represent a multiple character wildcard. 

For example, if you want to find bus number 10005, but all you know is the first four digits are 1000, you can type in 
*1000*, and Simulator will search until it finds the first number that contains those four digits.  You can then use the 
Search Next button (note that pressing Enter is the same as clicking Search Next) to find the next number containing 
the four numbers, and so on.  The same goes for searching by name.  If you are looking for bus ACEONE, but all you 
know is the name contains the string ACE, then you can type in *ACE* and then keep pressing Enter until you find the 
bus named ACEONE.  By using the beginning and ending *, we would also find elements such as NEWACE, because 
the double * looks for strings that contain ACE anywhere in the string.  Note that if you know the first few letters (or 
numbers), you can narrow down the number of elements found from the search by eliminating the first * from the 
search string.  For example, to find bus ACEONE, we could have instead used ACE*, and this would have gone 
through all matches that started with ACE, ignoring other elements such as NEWACE.  You can also use wildcards in 
the middle of a string, such as AC*NE, and Simulator will find any name that starts with AC and ends with NE.     



Text-Based Information Displays 

281 

Search for Text Dialog 
This dialog allows you to search for specific text in a case information display.  Specify the text you want to search in 
Search for  edit box.  Clicking on Search Next will take you to the next field whose content matches with the text 
specified.  The search can be made By Rows, in which the text is searched first in all the fields of a record, before 
searching in the next record.  If the search is made By Columns  then the text is searched first in all the fields of a 
column, before searching the text in the next column.  If the option Match case is checked, the search for text will be 
case-sensitive.  The option Find entire cells only will take you only to fields whose entire content matches completely 
with the text you are searching for. 
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Model Conditions Display and Dialog 
Model Conditions are a type of Model Criteria.  Model Criteria represent Boolean expressions regarding the present 
state of the power system model.  They can be used to create a convenient display that shows whether the power 
system meets a set of criteria.  They can also be used in conjunction with the definition of a contingency in the 
Contingency Definition Display to create contingency actions that are conditional on the state of the power system. 

A model condition contains two parts: a power system element and an advanced filter.  The model condition will then 
return true or false depending on the result of applying the advanced filter to the power system element specified.  
Model conditions can also be used as part of a Model Filter. 

The Model Conditions Display is a type of Case Information display and has the abilities common to this type of 
display.  To delete a model condition, right-click on the display and choose Delete .  To insert a new model condition, 
right-click on the display and choose Insert.  This brings up the Model Conditions Dialog that can be used to create, 
delete, and modify Model Conditions. 

 

Model Conditions Dialog 

The Model Conditions Dialog has three sections.  The top section provides the ability to Save, Save As , Rename 
and Delete  model conditions.  To choose a different Model Condition, use click on the down arrow next to the 
Model Condition name. 

The middle section provides a location to specify what power system element this Model Condition is related to.  On 
the left is a list of Element Types that are available.  When clicking on one of these types, the right portion of the 
dialog will provide you with a list of the elements of this type.  This list is a familiar Find Dialog and  provides you the 
ability to search for the element you are interested in.  

The bottom section provides a location to specify an Advanced Filter which you would like to have applied to the 
power system element chosen in the middle section.  The bottom section of the dialog behaves identically to the 
Advanced Filtering Dialog.  If an Advanced Filter exists for the type of element you are creating a Model Condition 
for, you can click the Set Filter Same As  button to choose this filter.  This will then set the parameters of the Model 
Condition to be the same as the Advanced Filter. 
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Model Filters Display and Dialog 
Model Filters are a type of Model Criteria.  Model Criteria represent Boolean expressions regarding the present state 
of the power system model.  They can be used to create a convenient display that shows whether the power system 
meets a set of criteria.  They can also be used in conjunction with the definition of a contingency in the Contingency 
Definition Display to create contingency actions that are conditional on the state of the power system. 

A model filter contains a list of Model Conditions and a Boolean operator to apply to these model conditions.  The 
model filter then returns true or false depending on the resulting of applying the Boolean operator to the Boolean 
results of the model conditions. 

The Model Filters Display is a type of Case Information display and has the abilities common to this type of display.  
To delete a model filter, right-click on the display and choose Delete.  To insert a new model filter, right-click on the 
display and choose Insert.  This brings up the Model Filters Dialog that can be used to create, delete, and modify 
Model Filters. 

 

Model Filters Dialog 

The Model Filters Dialog behaves in a manner very similar to the Advanced Filtering Dialog.  To choose model 
conditions for the model filter, click the down arrows next to the model conditions list.  You may also click the Find... 
button to the left of the list.  To insert or delete model condititions from the model filter, click the Add>> or Delete  
button.  When specifying more than one model condition, choose the Logical Comparison that will be used to 
compare the conditions.  Finally, the top of the dialog provides the ability to Save , Save As , Rename and Delete  
model filterss.  To choose a different Model Filter, use click on the down arrow next to the Model Filter name. 

To modify the model conditions in the case, click the Modify Model Conditions Dialog.  This will open the Model 
Conditions Dialog. 
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Entering a Range of Numbers 
On a number of displays it is often convenient to enter a group of numbers, including ranges.  Examples include 
entering buses or areas to scale on the Scaling Display, or buses on the Quick Power Flow List.  The format for this 
field is to enter individual numbers separated by commas, and/or ranges with a dash between the beginning of the 
range and the end of the range.   

For example the entry  

1-5,21,23-25 

corresponds to numbers 1 through 5, 21 and 23 through 25.   
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Copying Simulator Data to and from Other Applications 
You may sometimes find it useful to copy data from Simulator to other applications such as a word processor or 
spreadsheet program.  Alternatively, you may want to copy data from other applications into Simulator.  Simulator’s 
case information displays provide a convenient way to accomplish this.  In particular, the Copy All, Copy Selection, 
and Paste  options from the local menu allow Simulator to communicate data with other applications. 

To copy a selection of data from a case information display to another application, first select the range of cells to copy 
from the case information display.  Then, right-click on the case information display to display its local menu, and 
choose Copy Selection.  To copy the entire content of a case information display to another application, follow the 
same procedure, except choose Copy All from the local menu instead of Copy Selection.  Switch to the application 
that will serve as destination for the data and use that application’s Paste  command to finish copying the selected 
Simulator data to that application.  Note that not only is the data copied, but by default so are the data headings.  The 
data headings are very important to maintain if you are planning on copying data from a spreadsheet back into a 
Simulator case information display. 

 

Note: Be aware that most programs have limitations on the amount of information you can paste.  For example, some 
spreadsheet programs only allow up to 256 columns and 65,000 rows of information.  Some power system 
information, particularly the Ybus or Jacobian matrices, can easily exceed these limitations. 

 

To paste data from another application into a case-information display, select the data in the other application and use 
that application’s Copy command.  In order to paste back into Simulator, you must have the record type and data 
headings selected with the columns of data.  The record type (or object name) must match the case information 
display you are attempting to paste into, and the data headings (or variable names) tell Simulator which columns of 
data you are pasting.  In order for the data to be pasted to the correct records, you must include the key field columns 
in the data to be pasted into Simulator.  It is not necessary to copy and paste all columns or rows of data back into 
Simulator, as long as the column headings match a valid heading for the case information display.  It is also important 
to note that you CANNOT have columns of data that are unrecognizable by Simulator in between valid data columns 
in the data you are attempting to paste.  Simulator will only paste columns of data from the clipboard up to the point 
where it finds an unrecognizable column header.  If there are any valid columns of data after the unrecognized 
column, that data will be ignored.  If you wish to copy data from a spreadsheet into a Simulator display, you must 
make sure they are ordered in such a way that all the information you wish to paste can be grouped and copied as one 
block of date from the spreadsheet.  Once you have copied all the information from the spreadsheet you wish to 
transfer, switch to Simulator, open the case information display in which to paste the data, and select Paste  from its 
local menu. 

 

Note: You can only paste values into the case information displays if the values are enterable on the display (shown 
blue by default).  Also, be careful about pasting redundant data.  For example, in the Bus Records display both voltage 
in per unit and voltage in kV are enterable, but they specify the same information.  Make sure you only copy ONE of 
these columns into Simulator.  Otherwise you may not get what you expect.  Simulator will paste the value in twice, 
and whatever value was pasted 2nd will be used. 
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Save Case Information Data 
The Save Data Dialog gives you quick access to saving data from certain Case Information Displays in a PowerWorld 
Simulator Auxiliary File. 

Specify the name of the auxiliary file in which to save the data records in the text box labeled Name of File to Save .  
Instead of typing the name of the file by hand, you can press the Browse button to locate it.  Then, indicate whether 
you want the objects whose data you are writing to the file to be identified by number or by name.  Finally, to ensure 
that only the records currently listed in the Case Information Display are written to the auxiliary file, check the Save 
Only Records Listed in this Display checkbox.  Otherwise, data for all such objects in the entire system will be 
saved to the file. 

When you have finished setting these options, click OK.  If you changed your mind and do not want to save the data to 
a file, click Cancel. 
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Key Fields  
Key fields are required fields when attempting to paste data into a Case Information display from another data 
application.  Other fields are also considered required fields for the purpose of creating new objects in Simulator by 
pasting or loading information from another source, such as Excel or a PowerWorld Auxiliary file.  The key fields are 
easily identified from a few different locations. 

 

Column Headings  

The column headings of case information displays are colored to indicate fields that are key fields.  Any field that is 
a required key field will be highlighted yellow.  Also note that some fields are highlighted green.  These fields are 
fields that are required when you are attempting to create a new object by pasting or loading the data into the 
display from another application.  If the necessary key fields (yellow) are not included in the data loaded into the 
display from another source, the information for that object is ignored.  If all of the required (green) fields are not 
included in an object that is detected as new, Simulator will skip it.  If all the required fields are present, then 
Simulator can create the new object.  Note that for new objects, the key fields are required as well. 

Display/Column Options  

The Display/Column Options dialog, available by right-clicking on any case information display, also has the 
capability to highlight both the key fields and required fields, as described above.  The check box labeled "Highlight 
Key Fields" will enable highlighting of the field names in the two lists on the display. 

Export Object Fields  

This option from the Help menu in Simulator allows you to export a list of most fields for each type of object in a 
case.  The list also indicates which fields are key fields for each object.  You can output this list of fields as either a 
text file or into Excel. 

 

The following table lists some of the more commonly accessed key fields needed when attempting to Paste data into 
existing objects in a Case Information Displays from another data application. 

 

Type of Data Data Description 

 

Required Key 
Columns for Paste 

  

Area Area Records  Area Num   

Bus Bus Records  Number   

DC Line DC Line Records Rectifier Number Inv Number Num 

Gen Gen Records Number ID  

Interface Interface Records  Name   

Line/Transformers Line Records From Number To Number Circuit 

Load Load Records  Number ID  

Substations Substation Records  Sub Num   

Switched Shunt Switched Shunt Records  Number ID  

Zone Zone Records  Zone Num   
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Customized Data Grids  
The Customized Data Grid display can be opened by choosing the menu option Case Information > Other > 
Customized Data Grid.  If you have customized any of the case information displays for your case, you can see a list 
of the customized displays and their settings from this display . 

Customized Data Grid settings cannot be inserted manually or modified on this display.  Those modifications must be 
done on the actual case information display.  The primary use of this list display is to provide you a location to save 
and load case information customizations to an auxiliary file.  Customizations can be loaded from an auxiliary file by 
right-clicking on the grid and choosing to load data from an auxiliary file.  To save the customizations, right-click on this 
display and choose Save As > Auxiliary Data. 
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Functions and Operators Available 
Below is a list of functions and operators that are available for use in Defining Custom Expressions: 

Symbol Equivalent Description Example 

( )  Prioritizes an expression 5*(1+1) = 10 

! FACT Factorial 5! = 120fact(5) = 120 

%  Percentage 35% = 0.35 

^ ** Raised to the power of 4 ^ 5 = 1024 

*  Multiply by 3 * 6 = 18 

/  Divide by 9 / 2 = 4.5 

\ DIV Integer divide by 9 \ 2 = 4 

MOD  Modulo (remainder) 7 mod 4 = 3 

+  Add 1 + 1 = 2 

-  Subtract 9 - 5 = 4 

>  Greater than 9 > 2 = 1   * see note 

<  Less than 7 < 4 = 0 

== = Equal test 5 == 4 = 0 

>= => Greater or equal 3 >= 3 = 1 

<= =< Less or equal #h3E <= 9 = 0 

<>  Not equal #b10101 <> 20 = 1 

NOT  Bitwise NOT NOT(15) = -16 

AND & Bitwise AND #b101 AND #h1E=4 

OR | Bitwise OR 13 OR 6 = 15 

XOR  Bitwise Exclusive OR 9 XOR 3 = 10 

EQV  Bitwise Equivalence 6 EQV 9 = -16 

IMP  Bitwise Implication 1 IMP 5 = -1 

IIF  If condition IIf(1+1=2,4,5) = 4 

MIN  Minimum value min(10,3,27,15) = 3 

MAX  Maximum value max(1,9)=9 *see note 

SIN  Sine sin(pi) = 0  *see note 

COS  Cosine cos(pi) = -1 

TAN  Tangent tan(pi) = 0 

ASIN  Arc sine asin(1) = 1.570 

ACOS  Arc cosine acos(-1) = 3.141 

ATAN ATN Arc tangent atan(0) = 0 

SEC  Secant sec(0) = 1 

CSC  Cosecant csc(1) = 1.18 

COT  Cotangent cot(1) =  0.642 

SINH  Hyperbolic sine sinh(3) = 10.01 

COSH  Hyperbolic cosine cosh(2) = 3.76 

TANH  Hyperbolic tangent tanh(1) = 0.76 

COTH  Hyperbolic cotangent coth(1) = 1.31 

SECH  Hyperbolic secant sech(0) = 1 

CSCH  Hyperbolic cos ecant csch(1) = 0.85 

ASINH  Hyperbolic arc sine asinh(2) = 1.44 

ACOSH  Hyperbolic arc cosine acosh(9) = 2.89 

ATANH  Hyperbolic arc tangent atanh(.1) = 0.10 

ACOTH  Hyperbolic arc cotangent acoth(7) = 0.14 

ASECH  Hyperbolic arc secant asech(.3) = 1.87 

ACSCH  Hyperbolic arc cosecant acsch(2) = 0.48 
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ABS  Absolute value abs(-8) = 8 

EXP  e to the power of exp(3) = 20.08 

EXP2  2 to the power of exp2(3) = 8 

EXP10  10 to the power of exp10(3) = 1000 

LOG LN Natural log log(16) = 2.77 

LOG2  Log base 2 log2(8) = 3 

LOG10  Log base 10 log10(100) = 2 

CEIL   Round up ceil(6.2) = 7 

RND  Random number rnd(1) = .969 

INT  Truncate to an integer int(6.8) = 6 

SGN SIGN Sign of expression (-1, 0, or 1) sgn(-9) = -1 

SQR SQRT Square root sqr(64) = 8 
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Contour Column Type 
Color Map 

Choose from various predefined color maps using the color map combo-box.  A color map, along with the values 
specified, defines how values are mapped to a color on the contour image. 

If a color map showing both high and low values is desired (such as for bus voltages), use of "Blue = Low, Red = 
High" is recommended.  If a color map showing only high values is desired (such as for line flows), use of "Weather 
Radar, Nominal to High" is recommended. 

A user may also define additional color maps by going to the Custom Color Map Tab.  

Reverse Color Map Colors 

Check this check-box to reverse the colors of the selected color map, so the low color becomes the high color, and 
vice versa. 

Brightness 

Modify the brightness track bar to change the brightness of the color map. 

Use cell values directly 

Select this option to use the cell values to do the contouring. 

Use the specified field below 

Select this option to use a different field value to do the contouring. 

Value 

Select the quantity to use in the contouring from the Value dropdown box or click the Find Value  button to find 
the desired field. 

Draw Color Key 

Checking this box will cause the contour to draw a color key showing which colors are mapped to which values.  
You can also give the color key a title, unit label, and specify the number of digits to display in numerical values. 

Title  

Title for the color key. 

Entry Labels  

Units of the contoured value displayed on the color key. 

Label Digits to Right of Decimal 

Number of decimal places of the contoured value displayed on the color key. 

Save Contour Image with Oneline  

Checking this box will allow a displayed contour to be saved with a oneline diagram.  If a contour is saved with a 
oneline diagram, the next time the oneline diagram is opened the contour will automatically be redrawn as well. 

Continuously Update Contours 

Normally contouring is only done on a snap shot of the power system state.  However, you can also set 
PowerWorld to automatically update the contour every time the display is redrawn.  In this way, an animation of the 
contour can be created.  If you would like to create this animation, simply check the Continuously Update Contours 
checkbox.  Note, however, that this will slow down the animation of the display, as the program must recalculate the 
contour at each step.  If this slows down your display too much, try lowering the contour resolution to speed it up. 

Use absolute value  

Check this check-box to use the absolute values of the quantity selected at the Value dropdown box (above). 

Values 

These values along with the color map define how to convert your values into a color for the contour.  The values 
are: 

Maximum  The largest value allowed in the contour.  All values above this will be mapped 
to the highest color.  This value corresponds to 100% in the color map. 

Break High This value is used by some color maps to highlight a lower limit.  This value 
corresponds to 75% in the color map. 

Nominal  This value is the nominal value for the contour.  Values around this will be 
mapped to the middle color.  This value corresponds to 50% in the color map. 

Break Low This value is used by some color maps to highlight a lower limit.  This value 
corresponds to 25% in the color map. 

Minimum The smallest value allowed in the contour.  All values below this will be mapped 
to the lowest color.  This value corresponds to 0% in the color map. 

Note: a representation of the color map is shown to the right of the values. 
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Grid Metrics Dialog 
The grid metrics dialog allows you to determine the metrics for a set of columns.  The metrics determined include: 
Sum, Average, Variance, Standard Deviation, Maximum and Minimum. 

By default the dialog is set to determine the metrics for the whole column of the case information display where the 
option has been selected.  However, the selected record set can be modified.  The Start Column and End Column 
values specify what columns to include in determining the metrics.  The Start Row and End Row values specify what 
records to include when computing the metrics.  If the option Treat blank cells as zero is checked, then any blank 
cells will be considered as zero when computing the metrics.  Instead, if the option Ignore blank cells for calculation 
is checked, any blank cell will be taken out of the metrics calculation.  Check Use Absolute Values  to use the 
absolute values of field values for the metrics computation.  Finally, click Update Metrics  to determine the metrics with 
the new set of options. 

 

Custom Case Information Displays  

Custom Case Information Display 
To open the Custom Case Information Displays, choose Case Information > Custom  Case Info from the menu.  
(Note: if this option is not displayed by default, then it can be added by right-clicking on the Toolbars and choosing 
Customize.  Then either "Reset" the Main Menu or add the command under the Commands tab.) 

Custom Case Information Displays can be used to create a display very similar in appearance to a spreadsheet 
workbook with several worksheets.  This display can show any information that can be shown on a case information 
display, but also allows you to customize the layout of the information in any manner.   

There are three buttons which allow you to Rename the present sheet, Add a new sheet, and Delete the present 
sheet.   

 

There are three different kinds of cells allowed on this display 

• Blank Cell – contains nothing 

• Plain Text Cell – contains a user-entered string with no link to any data in the model. 

• Model Field Cell – contains a link to model field similar to inserting a model field on a oneline diagram 

 

Each cell of the display will behave differently depending on the Custom Case Info Mode.  There are four distinct 
modes which control the user interaction and operation of the custom case information display.  These four modes and 
the effect they have on the display are described in topics 

• Define Fields/Strings  

• Change Field Data  

• Show Fields Primary  

• Show Fields Secondary  
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Define Fields/Strings 
The "Define Fields/String" mode is the primary mode for use when setting up a new Custom Case Information Display. 
The three kinds of cells behave as follows in this mode. 

Blank Cell 

To convert to a Plain Text Cell, just type in the cell.  To convert to a Model Field Cell, double-click on the cell to 
open up a dialog for defining the model field. 

Plain Text Cell 

These cells will appear in the Case Info Display Enterable Color (blue by default).  To change them just type on the 
cell.  When pasting into such a cell or editing it directly it will parse the string entered trying to create a Model Field 
as though the string represents the model fields as shown in the Show Fields modes.  If the string does not 
represent such a field, then it will remain a Plain Text Cell 

Model Field Cell 

Model Field cells will not be enterable.  In order to edit these fields, you must double-click on the cell to open a 
dialog for defining the model field. 
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Change Field Data 
The "Change Field Data" mode can be used to edit the data referred to by the model fields on the display.  The three 
kinds of cells behave as follows in this mode. 

Blank Cell 

Blank cells may not be edited in any manner. 

Plain Text Cell 

Plain Text cells may not be edited in any manner.  It will appear in a special color defined for the custom case 
information display which may be specified from the local menu of the workbook tabs.  By default this color is dark 
gray. 

Model Field Cell 

Model Field cells will behave according to the field to which they refer.  Enterable fields will be enterable, toggleable 
fields will toggleable, etc…  When pasting in the sheet in this mode you will be modifying the model data directly.  In 
the following picture there are three fields in cells C4, C5, and C6 which refer to read-only, enterable, and 
toggleable field respectively.  The fields are labeled using the plain text cells in D4, D5, and D6. 
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Show Fields Primary 
The "Show Fields Primary" mode is used for interacting with an external spreadsheet to actually create the model field 
links.   The three kinds of cells behave as follows in this mode. 

Blank Cell 

Blank cells behave the same as for the "Define Fields/Strings " mode. 

Plain Text Cell 

Plain Text cells behave the same as for the "Define Fields/Strings " mode. 

Model Field Cell 

Model field cells will display a string which represents information about the model field link.  The format for this 
string will be  

‘model field name’ ‘variable name’ totaldigits decimalpoints IncludeUnits 

 

The model field string will use the primary key fields. 

 

When pasting into such a cell or editing it directly it will parse the string entered trying to create a Model Field as 
though the string represents the model fields as shown in the Show Fields modes.  If the string does not represent 
such a field, then it will remain a Plain Text Cell. 
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Show Fields Secondary 
This mode is identical to the Show Fields mode, except that it will show model fields string using the sec ondary key 
fields. 
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Custom Case Informati on Display Local Menu 
By right-clicking on the tabs representing the various sheets of the custom case information display, a local menu 
appears giving you the following options. 

 

• Rename Sheet – this is only available if you click directly on a specific tab.  Choose it to rename the sheet. 

• Delete Sheet – this is only available if you click directly on a specific tab.  Choose it to delete the sheet. 

• New Sheet – Choose this to add a new sheet 

• Save All Sheets… – Choose this save all the information on the sheets to an auxiliary file.  For the fields one 
the display, all information will be saved to the auxiliary file using Primary Key Fields  unless the Custom Case 
Info Mode is set to Show Fields Secondary.  In this case, they will be saved using the secondary key fields. 

• Custom Case Info Mode – Choose this to open a submenu that allows you to change the mode. 

• Tabs Position – Choose this to open a submenu that allows you to change the location of the tabs relative to 
the sheets  

• Plain Text Change Data Color – Choose this to change the color which is used to denote Plain Text cells when 
the Custom Case Info Mode is set to Change Field Data.  The default color is dark gray. 

 

By right-clicking on one of the Custom Case Information Display sheets, you will open a local menu that has many 
options which are the same as other Case Information Displays.  There are a few extra options listed as follows 

 

• Insert Row – Choose this to insert a new row at the location of the presently selected cell 

• Delete Row – Choose this to delete rows that are part of the present selection 

• Insert Column – Choose this to insert a new column at the location 

• Delete Column  – Choose this to delete columns that are part of the present selection 

• Delete Cell – Choose this to delete the presently selected cells 

• Custom Case Info Menu – Choose this to open the same menu available by right clicking on the tabs 
representing the various sheets  

 

 

Summary Displays  

Case Description 

The Case Description Dialog allows you to enter a text description of a case.  The portion of the description that is 
actually saved with the case varies with the case type, as indicated here:  

PowerWorld Binary (*.pwb) Essentially an unlimited number of lines allowed 

PTI Raw Data format (*.raw) Two lines 

GE EPC Data format (*.epc) No case description supported 

PowerWorld Case (*.pwc) No case description supported 

IEEE Common Format (*.cf) No case description supported 

In PowerWorld Viewer, these descriptions are read-only.   

Select Case Information, Case Description from the main menu to display the Case Description Dialog. 
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Case Summary 

The Case Summary Display provides a summary of the current case.  Note that there are no enterable fields on the 
display.  To display the Case Summary, select Case Information > Case Summary from the main menu.  The fields 
shown on this display include: 

 

Number of Devices in Case shows the number of each of the following device types: 

Buses 

Total number of buses  in the case.  Use the Bus Display to see a listing of these buses.   

Generators 

Total number of generators in the case.  Use the Generator Display to see a listing of these generators. 

Loads  

Total number of loads in the case.  Use the Load Display to see a listing of these loads. 

Switched Shunts  

Total number of switched shunts in the case.  Use the Switched Shunt Display to see a listing of these switched 
shunts. 

Lines/Transformers 

Total number of transmission lines and transformers in the case.  Use the Line/Transformer Display to see a listing 
of these lines and transformers.  

2 Term. DC Lines 

Total number of two-terminal dc transmission lines in the case.  Use the DC Transmission Line Display  to see a 
listing of these dc lines.   

N-Term. DC Lines 

Total number of multi-terminal dc transmission lines in the case.  Use the DC Transmission Line Display to see a 
listing of these dc lines. 

Control Areas  

Total number of control areas in case.  Use the Area Display to see a listing of these areas.  

Zones 

Total number of zones in the case.  Use the Zone Display to see a listing of these zones.  

Islands  

Total number of islands in the case.  An island is a group of buses that are interconnected through ac transmission 
lines or transformers but are isolated from the rest of the system.  Each island must have a slack bus.  In Simulator, 
use the Power Flow Solution tab of the PowerWorld Simulator Options display to specify whether multiple islands 
are allowed. 

Interfaces 

Total number of interfaces in the case.  An interface is a grouping of tie line objects between area objects.  In 
Simulator, use the Case Information > Interfaces records display to open the Interface Dialog to define and modify 
interface objects. 

Case Totals  

Summarizes the total load, generation, shunt compensation, and losses for the case.  Positive shunt compensation 
denotes shunt load, whereas negative shunt compensation indicates a shunt injection (such as shunt capacitance).  
The case totals fields are valid only when the current case is solved. 

Generator Spinning Reserves 

The total difference between the present total generator output versus the total maximum possible output of all in-
service generation. 

Slack Bus Number(s) 

The number(s) of the slack bus or buses.  One slack bus is required for each island.  

Case Pathname 

Full file name of the current case.   
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Power Flow List 

The Power Flow List shows detailed information about the system’s power flows in a more traditional text-based form.  
This information is intended for users who would like detailed flow information about the power flow. Including the per 
unit voltage at the bus, the bus’ load and generation, and flows on all lines and transformers emanating from the bus.  
The content of this display (i.e. which buses are included in the list) is governed by the area/zone/owner filters.  

To show this display select Case Information > Power Flow List from the main menu. 

To view flows at just a few select buses you may want to use the Quick Power Flow List instead.  For large systems 
with no area/zone filtering set, it may take Simulator a long time to generate the complete Power Flow List.  Note also 
that this display can show a maximum of 32,767 lines of text.  If this limit is exceeded, Simulator will generate a 
resource error.  Either use the area/zone/owner filters to limit the number of devices shown on this display, or use the 
Quick Power Flow List to focus on a few selected buses of interest. 

The Power Flow List allows you to navigate through the system’s buses rather easily. You can also use the display to 
show the flows for a bus’ neighbor by double-clicking on the line that reads "TO nnnnn…," where nnnnn is the number 
of the bus you would like to see.  The display is then positioned at this bus.  If the bus is in an area and/or zone whose 
area/zone filter is not set, the area/zone filter is set automatically.  In this way, you can inspect the system bus by bus.  

The display can also be used to quickly display the dialog box associated with different bus objects.  Place the c ursor 
on the desired device, depress the CTRL key and then left click.  The corresponding bus, load, generator, or shunt 
information dialogs will be displayed.   

The Power Flow List also has its own local menu, which can be viewed by clicking the right mouse button on the 
display.  Select Change Font to modify the style and size of the display’s font.  Select Refresh to ensure that the 
display’s contents concur with the current system state.  To skip to particular bus in the list, click Find Bus, which will 
open the Find Bus Dialog.  To display the information dialog for the currently selected branch, bus, load, or shunt, 
select Display Object Dialog.  To print the display, choose the Print local menu option. Choosing Copy enables you 
to copy the display into the Windows clipboard, from where the information can be pasted into another application.  
Finally, select Close to close the display.   

When printing the display you can either send the results directly to the printer or save them to a text file.  To save the 
results in a text file on the Print Dialog select the Save to File  option shown in the lower left corner of the dialog.   

 

For each bus, the following items are shown: 

Bus 

Shows the bus’ number, name, and nominal voltage in kV.  The next four fields are the MW, MVar, MVA and 
percentage headers for subsequent rows.  The next fields specify the per unit voltage magnitude, voltage angle in 
degrees, the bus’ area number and the bus’ area name.  Depress the CTRL key and then left click on this line to 
display the Bus Dialog. 

Generator 

For each generator at the bus, the Power Flow List shows the generator’s ID (immediately after the keyword 
GENERATOR) and the power output of the generator in MW.  Following this is generator’s reactive power output in 
Mvar.  A single character is shown immediately after the Mvar field.  An ‘R’ indicates that the generator is regulating 
the bus voltage, ‘H’ indicates that the generator is at its high reactive power limit, ‘L’ indicates that the generator is 
at its low reactive power limit, and a blank suggests that the generator is set off of AVR.  The last field in the 
GENERATOR item is the MVA output of the generator.  Depress the CTRL key and then left click on this line to 
display the Generator Dialog.  If no generators are connected to the bus, this item will be absent from the display. 

Load 

Shows the total power consumed by each load at the bus.  If no loads are present at the bus, this item will be 
absent from the display.  Depress the CTRL key and then left click on this line to display the Load Dialog. 

Shunt 

Shows the total power for the fixed shunts at the bus.  Positive shunt values denote shunt load, while negative 
shunt quantities indicate injection.  If no shunts are connected to the bus, this item will be absent from the display. 

Switched Shunt 

Shows the total power for the switched shunts at the bus.  Depress the CTRL key and then left click on this line to 
display the Switched Shunt Dialog.  If no switched shunts are located at the bus, this item will be absent from the 
display. 

Lines and Transformers 

For each line or transformer coming into the bus, the Power Flow List shows the line’s flow and percentage loading.  
For transformers, the off-nominal tap ratio and phase shift angle in degrees are also shown.  Immediately to the 
right of the off-nominal tap ratio is a two-character designation indicating the tapped side of the transformer:  ‘TA’  
indicates that the bus is on the tapped side, while ‘NT’ identifies the bus as residing on the side without the tap.  
You can lef t- click on this field to immediately reposition the bus to the other end of the line or transformer.   

Depress the CTRL key and then left click on this line to display the Transmission Line/Transformer Dialog.  Simply 
left-click (without holding the CTRL key) to navigate through the system from bus to bus. 
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Quick Power Flow List 

The Quick Power Flow List provides a convenient means of viewing a listing of the flows at individual buses in the 
system.  The format and control of the Quick Power Flow List is generally the same as that of the Power Flow List, 
except that the Quick Power Flow List displays results for just the desired bus or range of buses.   

 

You can ac cess this Quick Power Flow List in a number of different ways: 

• From most of the Case Information Displays, right-click to invoke the display’s local menu, and select Quick Power 
Flow List. 

• From the Bus Information Dialog click on the View All Flows at Bus  button. 

• From the oneline diagram, right-click on the bus symbol to display the bus’ local menu, and select Quick Power 
Flow List. 

• Select the toolbar icon from the Options/Info Toolbar.  

 

This display is automatically created if it is not already shown.  Information on subsequent buses appears at the 
bottom of the display. 

As with the Power Flow List, you can navigate through the system bus-by-bus by double-clicking on the lines that 
begin with "TO nnnnn …," where nnnnn is the number of the bus you would like to investigate.  Information for that bus 
will appear at the bottom of the display.   

Like the Power Flow List, the Quick Power Flow List has a local menu that is accessed by right-clicking on the display.  
Among the things you can do from the local menu is to display the bus, branch, generator, load, or shunt 
corresponding to the currently selected record by selecting Display Object Dialog.  You can also navigate through 
the system bus-by-bus just as you can do through double-clicking by choosing Goto Line Bus  from the local menu. 
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Making Reports  

Choosing Report Writer allows you to create text style reports of all power system information.  This includes 
information regarding Areas, Zones, Buses, Generators, Loads, Switched Shunts, and Transmission Lines.  These 
reports may be printed and customized as desired. 

When you select Case Information > Report Writer (run mode only), the Reports Criteria Dialog will appear. This 
allows y ou to customize the information contained in the report.  By default, the Make Reports activity will create a 
comprehensive set of reports for all areas whose Area/Zone/Owner Filter settings allow them to be displayed.   To 
specify which types of reports will be created and for which buses, use the options provided on the Reports Criteria 
Dialog. 

 

• First, select either Area Reporting or Zone Reporting.  This will designate whether to organize the report by areas or 
by zones.   

• Next, select the areas or zones you would like to include in the report.  To add or remove an area/zone from the 
report, click on its status with the left button to toggle between ‘In Report’ and ‘NOT in Rep’.  You may also add or 
remove large ranges of area/zone numbers by typing number ranges  into the Add or Remove text boxes and 
pressing Return. 

• Select the voltage levels you would like the reports to cover.  The report will include rec ords only for power system 
equipment whose nominal voltage falls in this range. 

• Choose the Types of Reports  you would like to create.  To produce the entire set of reports (which is the default 
setting), select All.  You can select multiple items from this list by using the shift and/or control keys. 

• Select either List Reports by Area/Zone  or List Reports Together.  This will determine the format of the report.  
For instance, if you choose to List Reports Together, then all of the bus information will be grouped in one listing; 
whereas if you choose List Reports by Area/Zone, then the information will be grouped by Area/Zone. 

• Finally, choose, OK, Make Reports .  

 

A new dialog containing the report will appear.  The report dialog features both a main menu and a local menu 
(accessible by right-clicking on the report) that allow you to change the font of the report, send it to a printer, or copy 
portions of the report to the Windows clipboard for use with another application. 
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Outages 

The outages display, available by choosing Case Information > Outages menu option (run mode only), presents a 
tabular listing of devices that are currently out-of-service in the load flow model.  The display contains pages that 
resemble case information displays for branches, generators, loads, switched shunts, buses, and Multi-section lines.  
All devices listed in the pages on this display are the out-of-service elements. 

Area and Zone Displays 

Area Display 

The Area Display houses data about each area in the case. The Area Display is a class of Case Information Display 
and therefore can be used in a manner consistent with all other case information displays.   It has a local menu from 
which you can print, copy, or modify its records as well as view the information dialog of its associated areas. You can 
also sort the area records by clicking on the heading of the field by which you want to sort.  

To show the area records display, select Case Information > Areas . 

By default, the area records display contains the following fields: 

 

Number, Name 

Area’s number, between 1 and 9999, and its alphanumeric identifier.  Simulator supports names of any character 
length.  However, when writing out names to file formats with limitations on name length, the area names will be 
truncated at their maximum supported length. 

AGC Status  

Area’s automatic generation control status.  This field indicates whether or not the area’s generation is changing 
automatically to control the area interchange.  See Area Control for more details.  You can toggle the value of the 
area’s AGC Status (except in Viewer) by left clicking on the entry.  Valid entries in this field include: 

Off AGC Area is off AGC.  Generation must be adjusted manually to meet changes in 
load and losses.  If it is not, the system slack will be forced to pick up the 
balance. 

Part AGC Area is on AGC, with generation dispatch controlled by its units’ participation 
factors. 

ED Area is on economic dispatch control so that generation is dispatched in order 
of least cost. 

OPF Area is on OPF control (only used with Simulator OPF ).  This option is only 
used with Simulator OPF.  When the case is solved using the OPF the area 
controls are changed by the OPF to maintain area power balance.  During non-
OPF solutions this option is equivalent to Off AGC.   

Gen MW 

Total real power generation in the area in MW. 

Load MW 

Total real power load in the area in MW.   

Tot Sched MW 

The net of the base and scheduled transactions between the area and all other areas, with exporting power 
indicated as a positive value.  The base interchange for an area is set on the Area Information Dialog; the 
scheduled transactions for an area can be viewed using the specified MW Transactions display.  See Area 
Transaction Modeling for a description of the difference between base and scheduled transactions. 

Int MW 

The actual interchange between this area and all other areas, with exporting power positive.  If an area is on AGC 
control, its actual interchange should match its scheduled interchange. 

ACE MW 

The area control error in MW.  This is the amount of MW flow difference between the actual MW interchange and 
the desired MW interchange.  A positive value means the super area is generating and exporting excess MW's, and 
a negative value means the super area is under-generating and importing too many MW's. 

Lambda 

The area’s marginal cost.  This marginal cost is relevant only  when an Economic Dispatch (not OPF) solution has 
been run.  Theoretically, if losses are ignored, an area operates most economically if all generators operate at the 
same incremental cost.  This common incremental cost is the area’s lambda, or marginal cost. 

The local menu of the area records display has an additional option labeled All Area Gen IC Curves .  Select this 
activity to generate a plot showing the incremental cost curves for all units located in a particular area. 

Loss (MW) 
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Total real power losses for the area. 

Auto Shunts  

Determines whether switched shunts for the area are available for automatic control.  You can use this field to 
disable all the switched shunts in an area. Click on this field to toggle its value.  Click on the Toggle All Yes  or 
Toggle All No local menu options to set the auto shunts property for all switched shunts.  Note that a switched shunt 
is available for automatic control only if it meets three conditions: 1) its control mode property is set to Automatic 
(see Switched Shunt Information Dialog); 2) its associated area’s Auto Shunts  property is set to Yes ; and 3)  the 
Disable Switched Shunt Control  option on the Power Flow Solution tab of the PowerWorld Simulator Options Dialog 
must not be checked.   

Auto XF 

Determines whether tapped transformers for the area are available for automatic control.  You can use this field to 
disable all the transformers in an area. Click on this field to toggle its value.  Click on the Toggle All Yes  or Toggle 
All No local menu options to set all entries in this column. Note that three conditions must be met for a transformer 
to be used for automatic control: 1) its Auto field must be set to Yes (see Transformer Modeling for details);  2) its 
associated area’s Auto XF property is set to Yes; and 3) the Disable Transformer Control option on the Power Flow 
Solution tab of the PowerWorld Simulator Options dialog must not be checked.   

Load Schedule  

Identifies the load variation schedule that governs how load varies in the area.  The load variation schedule 
specifies values for the load multiplier at specific points in time.  To examine the details of a load schedule or to 
modify its prescription, select Case Information > Load Variation Schedules from the main menu to bring up the 
Load Variation Dialog. 

Load Mult 

Shows the current load multiplier for the area, as constrained by the prevailing load schedule.  All load in the area is 
scaled by this multiplier. This value of this field can be modified only through adjusting or redefining the area’s 
associated load schedule using the Load Variation Dialog. 
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Zone Display 

The Zone Display provides information about all the zones in the case.  Similar to the Area Display, the Zone Display 
provides a means of dividing up a power system.  System results can then be summarized by zones using this display.  
Buses can be assigned to zones independent of their area assignments.  Thus a single area could contain multiple 
zones, or a single zone could span multiple areas.  The zone number for each bus is shown on the Bus Dialog.  In the 
Edit Mode, groups of buses can be easily moved from one zone to another using the Zone Dialog.   

The Zone Records Display is a class of Case Information Display and therefore can be used in a manner consistent 
with all other case information displays.   It has a local menu from which you can print, copy, and modify its records as 
well as view the information dialog of its associated zones.  You can call up the Quick Power Flow List or Bus View 
Display to obtain more information about representative bus in the zone.  You can also sort the zone records by 
clicking on the heading of the field by which you want to sort.  

To show this display select Case Information > Zones. 

 

The display contains the following fields by default: 

Zone Number, Zone Name 

Zone’s number, between 1 and 9999, and its alphanumeric identifier.  Simulator supports names of any character 
length.  However, when writing out names to file formats with limitations on name length, the zone names will be 
truncated at their maximum supported length. 

Load MW, Load MVR 

Total real and reactive power load in the zone. 

Gen (MW), Gen (Mvar) 

Total real and reactive power generation in the zone. 

Loss MW, Loss MVR 

Total real and reactive power loss in the zone.  Losses are computed by summing the losses of the individual 
transmission lines and transformers in the zone.  Because of shunt charging, these devices can also generate 
reactive power.  Therefore, reactive power losses may actually be negative.   

Int MW, Int MVR 

Net interchange of real and reactive power with all other zones.  Exported power is assumed to be positive. 

Load Schedule  

Identifies the load variation schedule that governs how load varies in the zone.  The load variation schedule 
specifies values for the load multiplier at specific points in time.  To examine the details of a load schedule or to 
modify its prescription, select Case Information > Load Variation Schedules from the main menu to bring up the 
Load Variation Dialog. 

Load Mult MW 

Shows the current load multiplier for the zone, as constrained by the prevailing load schedule.  All load in the area is 
scaled by this multiplier. This value of this f ield can be modified only through adjusting or redefining the area’s 
associated load schedule using the Load Variation Dialog. 
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Super Area Display  

The Super Area Display identifies any super areas that have been defined for the case.  Super areas are groups of 
areas whose generators are dispatched as a coordinated group.  Super areas can thus  be useful for modeling the 
operation of independent system operators or power pools. 

Super areas cannot be inserted into a case from the Insert menu.  Instead, a super area can be defined when 
modifying or creating an area simply by typing the name of a new super area in the Super Area dropdown box on the 
Area Information Dialog.  

The Super Area Records Display is a class of Case Information Display and therefore can be used in a manner 
consistent with all other case information displays.   It has a local menu from which you can print, copy, and modify its 
records as well as view the information dialog of its associated super areas.  You can call up the Quick Power Flow 
List or Bus View Display to obtain more information about representative bus in the super area.  You can also sort the 
super area records by clicking on the heading of the field by which you want to sort.  

To show this display select Case Information > Super Areas. 

The display contains the following fields by default: 

 

Name 

The name of the super area. 

AGC Status  

The Super Area may operate without automatic generation control (AGC Status = Off AGC), with participation factor 
control (AGC Status = Part. AGC), or according to an economic dispatch (AGC Status = ED).  This is a toggleable 
field. 

Use Area PF 

Indicates whether to use the areas participation factors when the super area is to operate with participation factor 
control (Part. AGC). 

Num Areas  

Indicates the number of areas defined as being part of the super area.  Areas are added to super areas using the 
Super Area dropdown box on the Area Information Dialog. 

Gen MW 

Total MW injection from all the generators in the super area. 

Load MW 

Total MW load demanded in the super area. 

Tot Sched MW 

Total scheduled MW interchange with other areas or super areas. 

ACE MW 

The area control error in MW.  This is the amount of MW flow difference between the actual MW interchange and 
the desired MW interchange.  A positive value means the super area is generating and exporting excess MW's, and 
a negative value means the super area is under-generating and importing too many MW's. 

Lambda 

The super area’s marginal cost. 

Loss MW 

Indicates the real power losses incurred within the super area. 

ED Use PF 

Indicates whether the power flow  engine will calculate loss penalty factors in computing the economic dispatch 
solution for the super area.  If loss penalty factors are not calculated, then the economic dispatch is calculated 
assuming that the super area is lossless.  Otherwise, the economic dispatch solution incorporates losses.  The 
penalty factors gauge the sensitivity of the area’s losses to changing injection at specific generators.  The option to 
calculate loss penalty factors is relevant only when the super area operates according to Economic Dispatch 
Control .  Usually, if the system’s cost curves are relatively flat, the inclusion of losses in the solution will not have 
much of an effect on the dispatch. 

Bus Displays  

Bus Display 

The Bus Display presents data describing each bus in the case. The Bus Display is a class of Case Information 
Display and therefore can be used in a manner consistent with all other case information displays.  It has a local menu 
from which you can print, copy, and modify its records as well as view the information dialog of its associated bus. You 
can also sort the bus records by clicking on the heading of the field by which you want to sort.  Additionally, you can 
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choose to restrict the records shown by the Bus Records Display according to the constraints of the area/zone/owner 
filters.  Finally, when Simulator is in Edit Mode, the local menu allows you to add new buses to or remove existing 
buses from the system.   

To show the bus records display, select Case Information > Buses. 

 

By default, the bus records display contains the following fields: 

Number and Name 

Bus number between 1 and 99,999, and its alphanumeric identifier, eight characters maximum.  

Area Name 

Alphanumeric identifier of the bus’ area. 

Nom kV 

The nominal base voltage of the bus in kV. 

PU Volt 

Bus’ per unit voltage magnitude.   

Volt (kV) 

Bus’ actual voltage magnitude in kV.  This is the per unit voltage magnitude multiplied by the bus’ nominal voltage. 

Angle (Deg) 

Bus’ voltage angle in degrees.   

Load MW, Load Mvar  

Total real and reactive load at the bus.  If no loads are located at the bus, these fields are blank. 

Gen MW, Gen Mvar  

Total real and reactive generation at the bus.  If no generators are located at the bus, these fields are blank. 

Switched Shunt Mvar  

Total switched shunt device reactive power injection at the bus. 

Act G Shunt MW, Act B Shunt Mvar  

Total real and reactive fixed bus shunt injections. 

Area Num 

The area number in which the bus is located. 

Zone Num  

The zone number in which the bus is located. 
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Remotely Regulated Bus Display 

The Remotely Regulated Bus Display provides information about all buses that are remotely regulated by one or more 
generators.  The bus that a generator regulates is specified in the Edit Mode using the Generator Dialog.  Whenever a 
generator is regulating a bus that is not its terminal, it is considered to be remotely regulating that bus.  The bus that is 
remotely regulated, along with the regulating generators, will appear on this display. 

The Remotely Regulated Bus  Display is a class of Case Information Display and therefore can be used in a manner 
consistent with all other case information displays.   It has a local menu from which you can print, copy, and modify its 
information as well as view the information dialog of its associated buses.  You can find a specific remotely regulated 
bus, and you can learn more information about a particular remotely regulated bus by choosing either Quick Power 
Flow List or Bus View Oneline.  You can also sort the remotely regulated bus information by clicking on the heading of 
the field by which you want to sort. Additionally, you can choose to restrict the information shown by the Load  Display 
according to the constraints of the area/zone/owner filters. 

To call up the Remotely Regulated Bus Display, click Case Information > Other > Remotely Regulated Buses. 

 

This Remotely Regulated Bus Display contains the following fields by default: 

Number, Name, Area Name 

Number, name, and area name for the bus that is being remotely regulated.  

PU Volt 

Per unit voltage magnitude for the bus. 

Set Volt 

Setpoint voltage for the bus.  When a bus is being remotely regulated by a set of generators, the generators vary 
their reactive power output to maintain the voltage at the bus at the setpoint value.  You can enter a new value for 
this field.  Changing the setpoint voltage here changes the setpoint voltage for all the generators that are remotely 
regulating this bus. 

Volt Diff 

Per unit difference between the actual voltage magnitude and the set point voltage magnitude. 

AVR 

Combined automatic voltage regulation (AVR) status for all the generators remotely regulating this bus.  If AVR is 
No, no generators regulate voltage; if AVR is Yes, all the available generators are regulating; if AVR is Mixed, some 
generators regulate voltage and some do not.  Regulation of individual generators can be specified using the 
Generator Display .  You can toggle this field between "Yes" and "No" by clicking on it.   

Total Mvar  

Total of the reactive power being supplied by all the generators remotely regulating the bus.   

MVR Min, MVR Max 

Total of the minimum and maximum reactive power limits for all the generators remotely regulating the bus.   

Gen Buses 

The next several fields list the generators that are remotely regulating this bus.  Left clicking on either of these fields 
allows you to see all the flows into the generator’s bus using the Quick Power Flow List, while right clicking on the 
fields displays the Generator Dialog  for the generator.   
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Bus Mismatches Display 

The Bus Mismatches Display lists the real and reactive mismatches at each bus.  The bus mismatches are defined as 
the difference between the power entering the bus and the power leaving the bus.  A power flow case is considered 
solved when all the bus mismatches are below the convergence tolerance specified on the Power Flow Solution tab of 
the PowerWorld Simulator Options dialog.  

Most of the time you will not need to be concerned about the bus mismatches.  If the power flow solves, the 
mismatches are guaranteed to be below the desired tolerance.  However, advanced users will find this display useful 
in determining the cause when a power flow diverges. 

The Bus Mismatch Display is a class of Case Information Display and therefore can be used in a manner consistent 
with all other case information displays.   It has a local menu from which you can print, copy, and modify its information 
as well as view the information dialog of its associated bus.  You can find a specific bus mismatch using the name or 
number of the bus, and you can learn more about the bus by choosing either Quick Power Flow List or Bus View 
Oneline. You can also sort the bus mismatch information by clicking on the heading of the field by which you want to 
sort.  

To show this display select Case Information > Mismatches.  You can view bus mismatches only when the 
application is in Run Mode. 

 

The Bus Mismatch Display contains the following fields by default: 

Number, Name, Area Name 

The number and name of the bus and the name of the area in which it is located. 

MW Mismatch, MVR Mismatch, MVA Mismatch 

The real and reactive mismatches at each bus, and the total complex power mismatch. 

Substation Displays  

Substation Records Display 

The Substation Records Display presents data describing each substation in the case. The Substation Display is a 
class of Case Information Display and therefore can be used in a manner consistent with all other case information 
displays.  It has a local menu from which you can print, copy, and modify its records as well as view the information 
dialog of its associated substation. You can also sort the substation records by clicking on the heading of the field by 
which you want to sort.  Additionally, you can choose to restrict the records shown by the Substation Records Display 
according to the constraints of the area/zone/owner filters.  Finally, when Simulator is in Edit Mode, the local menu 
allows you to add new substations to or remove existing substations from the system.  Note: a substation is 
considered in an area/zone if any single bus in the substation is in the area/zone.   

To show the substation records display, select Case Information > Substations . 

 

By default, the substation records display contains the following fields: 

Sub Num  

An integer identifier for the substation. 

Sub Name, Sub ID 

Two alphanumeric identifiers for the substation. 

Area Name, Zone Name 

The names of the area and zone of the buses in the substation.  If some of the buses in the substation are in 
different areas or zones, then this is the most common area or zone. 

# of Buses 

The number of buses inside the substation. 

Gen MW, Gen MVR 

Total real and reactive generation at the substation.  If no generators are located at the substation, these fields are 
left blank. 

Load MW, Load MVR 

Total real and reactive load at the substation.  If no loads are located at the substation, these fields are left blank. 

Shunt MW, Shunt MVR 

Total real and reactive shunt values at the substation.  If no shunts are located at the substation, these fields are left 
blank. 

Generator Displays  

Generator Display 
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The Generator Display presents data describing each generator in the case. The Generator Display is a class of Case 
Information Display and therefore can be used in a manner consistent with all other case information displays.   It has 
a local menu from which you can print, copy, and modify its records as well as view the information dialog of its 
associated generators.  The Quick Power Flow List and Bus View Display tools are available for finding more 
information on the generator’s terminal bus.  You can also sort the generator records by clicking on the heading of the 
field by which you want to sort.  Additionally, you can choose to restrict the records shown by the Generator Records 
Display according to the constraints of the area/zone/owner filters. Finally, you can use the local menu’s Insert and 
Delete options when the application is in Edit Mode to insert a new generator into the case or to delete an existing 
generator. 

Some columns which can be added to the generator records are related to the post-contingency solution options.  For 
more information about these columns see the sections "Define Generator Line Drop and Reactive Current 
Compensation" and "Define Generator Maximum MW Responses in Post-Contingency" in the Advanced Modeling 
Options for Contingency Analysis. 

To show the generator records display, select Case Information > Generators. 

 

By default, the generator records display contains the following fields: 

Number, Name 

Number and name of the bus to which the generator is attached.  The display’s local menu offers you the 
opportunity to view the Quick Power Flow List and the Bus View Display for the bus. 

ID 

Single character ID used to distinguish multiple generators at the same bus.  This default value for this field is ‘1’. 

Status  

Displays the Open / Closed status of the generator.  This field is a toggleable field. 

Gen MW, Gen Mvar  

The real and reactive power output of the generator.  If the generator is on AVR control, the reactive power is set 
automatically. 

Set Volt 

Per unit setpoint voltage for the generator.  When a generator is on AVR control, the reactive power output of the 
generator is varied automatically in order to maintain the regulated bus voltage at this value.  The regulated bus is 
usually, but not alw ays, the generator’s terminal bus.  Use the Generator Dialog to see the regulated bus number. 

AGC 

Designates whether the generator’s real power output is governed by automatic generation control.  If the AGC field 
is set to Yes , the generator is on automatic generation control (AGC).  When a generator is on AGC, its real power 
output can be varied automatically.  Usually the purpose for AGC is to keep the area interchange at a desired value.  
You can click on this field to toggle its value (except in Viewer).  Please see Area Control for more details. 

AVR 

Designates whether the generator will vary its reactive power output to maintain a constant terminal voltage.  If the 
AVR property is set to Yes , the generator is on automatic voltage regulation (AVR) control.  When a generator is on 
AVR control, its reactive power output is varied automatically to keep the regulated bus voltage at the Set Volt 
value.  AVR is limited by the generator’s reactive power limits.  You can click on this field to toggle its value (except 
in Viewer). 

Min MW, Max MW 

Minimum and maximum allowable real power output of the generator. 

Min Mvar, Max Mvar  

Minimum and maximum allowable reactive power output of the generator. 

Cost Model 

The type of cost model the generator is currently set to use.  Cost models are necessary for performing economic 
analysis, such as Economic Dispatch or Optimal Power Flow. 

Part. Factor 

Generator’s participation factor.  Participation factors are used to determine how AGC generators participate in area 
control when their area is on participation factor control.  Please see Area Control for more details. 
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Generator/Load Cost Models  

The Generator/Load Cost Models option from the Case Information menu allows you to choose to view detailed 
information on generator cost curves or load benefit curves.  This cost information can be very important when solving 
an Optimal Power Flow or Security Constrained Optimal Power Flow solution.   

The Generator/Load Cost Models option has four submenu options to choose from: 

Generator Cubic Cost Models  

Generator Piecewise Linear Cost Models  

All Generator Cost Models  

All Load Benefit Models  
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Generator Cost Models Display 

The Generator Cost Models Display presents detailed cost information for each generator in the case, regardless of 
what type of cost curve has been entered for the generator.  The Generator Cost Models Display is a class of Case 
Information Display and therefore can be used in a manner consistent with all other case information displays.   It has 
a local menu from which you can print, copy, and modify its records as well as view the information dialog of its 
associated generators.  The Quick Power Flow List and Bus View Display tools are available for finding more 
information on the generator’s terminal bus.  You can also sort the generator records by clicking on the heading of the 
field by which you want to sort.  Additionally, you can choose to restrict the records shown by the Generator Cost 
Models Display according to the constraints of the area/zone/owner filters.  Finally, you can use the local menu’s Insert 
and Delete options when the application is in Edit Mode to insert a new generator into the case or to delete an existing 
generator. 

To show the generator piecewise linear cost display, select Case Information > Generator/Load Cost Models > All 
Generator Cost Models . 

 

By default, the generator records display contains the following fields: 

Number, Name 

Number and name of bus to which the generator is attached. 

Area Name of Gen 

Name of the area to which the generator belongs.  The generator can belong to an area which is different than the 
area of which its terminal bus is a member. 

ID 

Single character ID used to distinguish multiple generators at the same bus; ‘1’ by default. 

Status  

The Open / Closed status of the generator.  This is a toggleable field. 

AGC 

Designates whether the generator’s real power output is governed by automatic generation control.  If the AGC field 
is set to Yes , the generator is on automatic generation control (AGC).  When a generator is on AGC, its real power 
output can be varied automatically.  Usually the purpose for AGC is to keep the area interchange at a desired value.  
You can click on this field to toggle its value (except in Viewer).  Please see Area Control for more details. 

Gen MW 

Current real power output of the generator. 

Min MW 

Minimum MW output of the generator. 

Max MW 

Maximum MW output of the generator. 

Cost Model 

The type of model this generator is currently using.  Can be Cubic, Piecewise Linear or None. 

IOA, IOB, IOC, IOD 

Parameters used to model the cost characteristic of the generator.  Please see Generator Cost Information  for 
details.  Please note that these values can be saved/loaded using the Generator Cost Data  auxiliary f ile. 

These fields will be disabled unless the Cost Model type is set to Cubic. 

Fuel Cost 

The fuel cost of the type of fuel for the generator. 

Variable O&M  

Operations and Maintenance costs for the generator. 

This field will be disabled unless the Cost Model type is set to Cubic. 

Fuel Type  

An informational field that can be set to the type of fuel the generator uses. 

Unit Type  

An informational field that can be set to reflect the type of unit the generator is, such as combined cycle, steam, 
hydro, etc. 

Cost Shift $/MWh, Cost Multiplier 

The cost shift and cost multiplier allow you to easily apply a shift to the cost function for the purpose of assessing 
how variations in bids impact profit.  The cost function is affected based on the following equation: 
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(Original Cost Function + Cost Shift) * Cost Multiplier 

Fixed Cost 

The fixed operating cost of the generator. 

MWh Break x, MWh Price x 

The remainder of the display is populated with MWh Break and MWh Price pairs.  These pairs define the break 
points of the piecew ise linear curve.  The MWh Break value is a MW output value of the generator.  The MWh Price 
value is the corresponding marginal cost of producing an additional MW of power at that MW output level.  
Therefore entering the break points of the piecewise linear curve in this manner defines the slopes of the next 
section of the curve, starting at the current MW Break point and up to but not including the next defined break point.  
The last MWh Break and MWh Price pair defined will define the marginal price of the unit from that break point 
location to the maximum output of the generator. 

A requirement of the piecewise linear cost curve is that it must be convex, meaning the next MWh Price must be 
higher than the previous MWh Price. 

These fields will be disabled unless the Cost Model type is set to Piecewise Linear. 
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Generator Cubic Cost Display 

The Generator Cubic Cost Display presents detailed cost information for each generator in the case set to use a cubic 
cost model.  The Generator Cubic Cost Display is a class of Case Information Display and therefore can be used in a 
manner consistent with all other case information displays.   It has a local menu from which you can print, copy, and 
modify its records as well as view the information dialog of its associated generators.  The Quick Power Flow List and 
Bus View Display tools are available for finding more information on the generator’s terminal bus.  You can also sort 
the generator records by clicking on the heading of the field by which you want to sort.  Additionally, you can choose to 
restrict the records shown by the Generator Cubic Cost Display according to the constraints of the area/zone/owner 
filters.  Finally, you can use the local menu’s Insert and Delete options when the application is in Edit Mode to insert a 
new generator into the case or to delete an existing generator. 

To show the generator cubic cost display, select Case Information > Generator/Load Cost Models > Generator 
Cubic Cost Models . 

 

By default, the generator records display contains the following fields: 

Number, Name 

Number and name of bus to which the generator is attached. 

Area Name of Gen 

Name of the area to which the generator belongs.  The generator can belong to an area which is different than the 
area of which its terminal bus is a member. 

ID 

Alphanumeric ID used to distinguish multiple generators at the same bus; ‘1’ by default. 

Status  

The Open / Closed status of the generator.  This is a toggleable field. 

AGC 

Designates whether the generator’s real power output is governed by automatic generation control.  If the AGC field 
is set to Yes , the generator is on automatic generation control (AGC).  When a generator is on AGC, its real power 
output can be varied automatically.  Usually the purpose for AGC is to keep the area interchange at a desired value.  
You can click on this field to toggle its value (except in Viewer).  Please see Area Control for more details. 

Gen MW 

Current real power output of the generator.   

IOA, IOB, IOC, IOD 

Parameters used to model the cost characteristic of the generator.  Please see Generator Cost Information  for 
details.  Please note that these values can be saved/loaded using the Generator Cost Data  auxiliary file. 

Fuel Cost 

The fuel cost of the type of fuel for the generator. 

Variable O&M  

Operations and Maintenance costs for the generator. 

Fuel Type  

An informational field that can be set to the type of fuel the generator uses. 

Unit Type  

An informational field that can be set to reflect the type of unit the generator is, such as combined cycle, steam, 
hydro, etc. 

Cost Shift $/MWh, Cost Multiplier 

The cost shift and cost multiplier allow you to easily apply a shift to the cost function for the purpose of assessing 
how variations in bids impact profit.  The cost function is affected based on the following equation: 

(Original Cost Function + Cost Shift) * Cost Multiplier 

Cost $/Hr  

Operating cost for the generator in $/hr. 

IC 

Incremental cost to produce an additional MWh.  This can be expressed as dC(Pgi)/dPgi, where C denotes the 
generator’s cost of operation in $/hr and Pgi expresses the current MW output of the unit.   In a lossless system, the 
incremental dispatch is equal to the generator’s lambda value. 

LossSens  
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Area loss sensitivity.  This field is only calculated when the generator’s area is on economic dispatch control.  
This field specifies the incremental change in area losses if this generator were to produce one more MW, with the 
excess generation absorbed by the system slack.  This may be expressed as ∂Ploss/∂Pgi.  The loss sensitivity 
is used in calculating the generator’s lambda value for the economic dispatch activity. 

Generator MW Marg. Cost 

The marginal cost of the generator supplying an additional MW of power to the system.   
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Generator Piecewise Linear Cost Display 

The Generator Piecewise Linear Cost Display presents detailed cost information for each generator in the case set to 
use a piecewise linear cost model.  The Generator Piecewise Linear Cost Display is a class of Case Information 
Display and therefore can be used in a manner consistent with all other case information displays.   It has a local 
menu from which you can print, copy, and modify its records as well as view  the information dialog of its associated 
generators.  The Quick Power Flow List and Bus View Display tools are available for finding more information on the 
generator’s terminal bus.  You can also sort the generator records by clicking on the heading of the field by which you 
want to sort.  Additionally, you can choose to restrict the records shown by the Generator Piecewise Linear Cost 
Display according to the constraints of the area/zone/owner filters.  Finally, you can use the local menu’s Insert and 
Delete options when the application is in Edit Mode to insert a new generator into the case or to delete an existing 
generator. 

To show the generator piecewise linear cost display, select Case Information > Generator/Load Cost Models > 
Generator Piecewise Linear Cost Models . 

 

By default, the generator records display contains the following fields: 

Number, Name 

Number and name of bus to which the generator is attached. 

Area Name of Gen 

Name of the area to which the generator belongs.  The generator can belong to an area which is different than the 
area of which its terminal bus is a member. 

ID 

Alphanumeric ID used to distinguish multiple generators at the same bus; ‘1’ by default. 

Status  

The Open / Closed status of the generator.  This is a toggleable field. 

AGC 

Designates whether the generator’s real power output is governed by automatic generation control.  If the AGC field 
is set to Yes , the generator is on automatic generation control (AGC).  When a generator is on AGC, its real power 
output can be varied automatically.  Usually the purpose for AGC is to keep the area interchange at a desired value.  
You can click on this field to toggle its value (except in Viewer).  Please see Area Control for more details. 

Gen MW 

Current real power output of the generator. 

Min MW 

Minimum MW output of the generator. 

Max MW 

Maximum MW output of the generator. 

Fuel Cost 

The fuel cost of the type of fuel for the generator. 

Fuel Type  

An informational field that can be set to the type of fuel the generator uses. 

Unit Type  

An informational field that can be set to reflect the type of unit the generator is, such as combined cycle, steam, 
hydro, etc. 

Cost Shift $/MWh, Cost Multiplier 

The cost shift and cost multiplier allow you to easily apply a shift to the cost function for the purpose of assessing 
how variations in bids impact profit.  The cost function is affected based on the following equation: 

(Original Cost Function + Cost Shift) * Cost Multiplier 

Fixed Cost 

The fixed operating cost of the generator. 

MWh Break x, MWh Price x 

The remainder of the display is populated with MWh Break and MWh Price pairs.  These pairs define the break 
points of the piecewise linear curve.  The MWh Break value is a MW output value of the generator.  The MWh Price 
value is the corresponding marginal cost of producing an additional MW of power at that MW output level.  
Therefore entering the break points of the piecewise linear curve in this manner defines the slopes of the next 
section of the curve, starting at the current MW Break point and up to but not including the next defined break point.  
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The last MWh Break and MWh Price pair defined will define the marginal price of the unit from that break point 
location to the maximum output of the generator. 

Load Displays  

Load Display 

The Load Display presents data describing each load in the case.  The Load Display is a class of Case Information 
Display and therefore can be used in a manner consistent with all other case information displays.   It has a local 
menu from which you can print, copy, and modify its information as well as view the information dialog of its 
associated loads.  The local menu also affords the opportunity to insert new loads into the model or to delete existing 
ones.  Moreover, it enables you to invoke the Quick Power Flow List and Bus View Display for the load’s terminal bus.  
You can also sort the load information by clicking on the heading of the field by which you want to sort. Additionally, 
you can choose to restrict the information shown by the Load Display according to the constraints of the 
area/zone/owner filters.  

To show the load display, select Case Information > Loads . 

 

The load display contains the following fields by default: 

Number, Name 

Number and name of bus to which the load is attached.  

ID 

Two-character ID used to distinguish multiple loads at the same bus; ‘1’ by default. 

Status  

Either Closed if the load is connect to its bus, or Open if it is not.  You can click on this field to toggle its value.  If the 
load is open, the entire load record is dimmed.   

MW, Mvar, MVA 

Total real, reactive, and complex power for the load.  Loads may be both voltage dependent and time dependent.  
The total load is the sum of the constant power, constant current, and constant impedance components. See Load 
Information and see Load Modeling  for more information. 

S MW, S MVAR, I MW, I MVR, Z MW, Z MVR 

These six fields describe the composition of the load at the bus assuming 1 pu bus voltage.  The SMW and SMVAR 
fields indicate the constant power portion of the load, the component that does not vary with bus voltage magnitude.  
The IMW and IMVR fields express the constant current part of the load, which varies in proportion to the bus 
voltage magnitude.  Finally, ZMW and ZMVR indicate the constant impedance portion of the load, which varies  with 
the square of the voltage.  The sum of the SMW, IMW, and ZMW fields yields the base MW load at the bus 
(assuming 1pu voltage), and the sum of the SMVR, IMVR, and ZMVR fields provides the base MVR load at the bus 
(assuming 1 pu voltage).  Please see Load Modeling  for more details on how bus load is modeled. 
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Load Variation Schedules 

The Load Variation Schedules Display identifies load variation profiles that have been defined. These profiles can be 
assigned to areas or zones to prescribe how the load within the areas or zones should vary over time. PowerWorld 
employs a load model in which all the loads in the case are first scaled from their Base Case values by the Case Load 
Multiplier.  This provides a convenient means of changing the load level for the entire case.  Furthermore, for each 
area and zone the loads can be modeled to change proportionally with time (i.e., they are all scaled from their base 
values by the same value) according to a piecewise linear model whose values can be displayed and modified using 
the Schedules Dialog.  The Load Variation Display identifies information that specify various piecewise linear 
variations that can be applied to the loads in an area or zone.   

The Load Variation Schedules Display is a class of Case Information Display and therefore can be used in a manner 
consistent with all other case information displays.   It has a local menu from which you can print, copy, and modify its 
information as well as view the information dialog of its associated load profiles.  The local menu also affords the 
opportunity to define new load profiles or to delete existing ones, or to enable or disable a particular profile.  You can 
also sort the load variation information by clicking on the heading of the field by which you want to sort.  Additionally, 
you can choose to restrict the records shown by the Load  Display according to the constraints of the area/zone/owner 
filters. 

To show the load  display, select Case Information > Others > Load Variation Schedules.  

 

The load  display contains the following fields by default: 

Name 

The name of the load profile schedule.  This name may contain up to 24 characters. 

Enabled 

Indicates whether the current load variation will be applied to any area or zone that has been defined to use it.  An 
area may be associated with a particular load variation through either the Options Tab  of the Area Information 
Dialog or the Load Schedule field of the Area Case Information Display.  Likewise, zones may be associated with a 
particular load variation through either the Options Tab  of the Zone Information Dialog  or the Load Schedule field of 
the Zone Case Information Display. 

Value  

The current value of the load multiplier prescribed by the schedule. 

Type  

Simulator recognizes three types of load profiles.  Daily load profiles describe a load variation that is common to all 
days for which the simulation is performed.  Weekly load profiles chart load variation across an entire week.  Finally, 
weekend load profiles permit a distinction between how load is to vary during a weekday and how it is to vary on a 
weekend day.  The Type field will thus contain one of three values:  daily, weekly, or weekend. 

# Time Points  

Indicates the number of segments in the piecewise linear model.  A load profile having n time points defines the 
load multiplier at n points in time.  Time points may be added or deleted using the Load Schedule Dialog. 
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Load Benefit Models Display 

The Load Benefit Models Display presents detailed cost information for each load in the case set to use a piecewise 
linear benefit model.  The Load Benefit Models Display is a class of Case Information Display and therefore can be 
used in a manner consistent with all other case information displays.   It has a local menu from which you can print, 
copy, and modify its records as well as view the information dialog of its associated loads.  The Quick Power Flow List 
and Bus View Display tools are available for finding more information on the load’s terminal bus.  You can also sort the 
load records by clicking on the heading of the field by which you want to sort.  Additionally, you can choose to restrict 
the records shown by the Load Benefit Models Display according to the constraints of the area/zone/owner filters.  
Finally, you can use the local menu’s Insert and Delete options when the application is in Edit Mode to insert a new 
load into the case or to delete an existing load. 

To show the generator piecewise linear cost display, select Case Information > Generator/Load Cost Models > All 
Load Benefit Models . 

 

By default, the generator records display contains the following fields: 

Number, Name 

Number and name of bus to which the load is attached. 

Area Name of Gen 

Name of the area to which the load belongs.  The load can belong to an area which is different than the area of 
which its terminal bus is a member. 

ID 

Alphanumeric ID used to distinguish multiple generators at the same bus; ‘1’ by default. 

Status  

The Open / Closed status of the load.  This is a toggleable field. 

AGC 

Designates whether the generator’s real power output is governed by automatic generation control, since effectively 
dispatching a load can be viewed as dispatching negative generation.  If the AGC field is set to Yes , the load is on 
automatic generation control (AGC).  When a load is on AGC, its real power output can be varied automatically.  
Usually the purpose for AGC is to keep the area interchange at a desired value.  You can click on this field to toggle 
its value (except in Viewer).  Please see Area Control for more details. 

Gen MW 

Current real power demand of the load. 

Min MW 

Minimum MW demand of the load. 

Max MW 

Maximum MW demand of the load. 

Fixed Benefit 

The fixed benefit of the load. 

Benefit Model 

The type of model this load is currently using.  Can be either Piecewise Linear or None. 

MWh Break x, MWh Price x 

The remainder of the display is populated with MWh Break and MWh Price pairs.  These pairs define the break 
points of the piecewise linear curve.  The MWh Break value is a MW demand value of the load.  The MWh Price 
value is the corresponding marginal benefit of extracting an additional MW of load at that MW output level.  
Therefore entering the break points of the piecewise linear curve in this manner defines the slopes of the next 
section of the curve, starting at the current MW Break point and up to but not including the next defined break point.  
The last MWh Break and MWh Price pair defined will define the marginal benefit of the load from that break point 
location to the maximum demand of the load. 

A requirement of the piecewise linear benefit curve is that it must be concave, meaning the next MWh Price must be 
lower than the previous MWh Price.  In other words, as more load is supplied, the less the benefit it is providing.  
This is how  a load can be dispatched along with generation, according to marginal costs (and marginal benefits.) 

These fields will be disabled unless the Cost Model type is set to Piecewise Linear. 

Line and Transformer Displays  

Line and Transformer Display 

The Line/Transformer Display presents data describing each transmission line and transformer in the case.  The 
Line/Transformer Display is a class of Case Information Display and therefore can be used in a manner consistent 
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with all other case information displays.   It has a local menu from which you can print, copy, and modify its information 
as well as view the information dialog of its associated branches.  The local menu also affords the opportunity to insert 
new lines or transformers into the model or to delete existing ones.  Moreover, it enables you to invoke the Quick 
Power Flow List and Bus View Display for each branch’s terminal buses.  You can also sort the line and transformer 
information by clicking on the heading of the field by which you want to sort.  Additionally, you can choose to restrict 
the information shown by the Line/Transformer Display according to the constraints of the area/zone/owner filters.  

To show the line/transformer display, select Case Information > Lines and Transformers. 

The contents of the display depends upon the application’s operating mode.   

 

The line/transformer display shows the following fields by default: 

From Bus Number and Name 

From Bus  number and name.  For transformers, the from bus  is the tapped side.  Right-clicking on either of these 
fields brings up the display’s local menu from which you may select Quick Power Flow List or Bus View Display to 
obtain more information about the from bus . 

To Bus Number and Name 

To Bus number and name. Right-clicking on either of these fields brings up the display’s local menu from which you 
may select Quick Power Flow List or Bus View Display to obtain more information about the to bus . 

Circuit 

Two-character identifier used to distinguish between multiple lines joining the same two buses.  Default is ‘1’. 

Status  

The service status of the branch.  This field is toggleable. 

Xfrmr 

Yes or no field signifying if the branch is a transformer or transmission line.  This field cannot be changed. 

From MW, From Mvar, From MVA (Run Mode default) 

Real, reactive, and complex power flowing into the line at the from bus. 

Lim MVA, Max Percent 

The current MVA limit of the branch, and the amount of the actual flow as a percentage of the MVA limit. 

MW Loss, Mvar Loss (Run Mode default) 

Real and reactive power losses on the transmission line or transformer.  Since reactive power losses include the 
effect of line charging, the reactive power losses may be negative.   

Resistance, Reactance, Capacitance (Edit Mode default) 

Indicates the branch’s R, X, and line charging in ohms. 

Lim A MVA, Lim B MVA, Lim C MVA (Edit Mode default) 

Identifies the first three limit settings.  Five additional limits can be set, for which the columns can be added using 
the Display/Column options from the local popup menu.  All limits are expressed in MVA. 

See Transformer Display for viewing transformer specific fields.   
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Multi-Section Lines Display 

The Multi-Section Line Display lists the multi-section lines that exist in the c ase.  The Multi-Section Line Display is 
used to functionally group a number of transmission lines together.  They are usually used to model very long 
transmission lines that require the use of multiple individual transmission line information to be modeled accurately.  
Simulator then treats each multi-section line as a single device with regard to line status.  That is, changing the status 
of one line in the record changes the status of the other lines in the record as well.   

Each multi-section line record consists of the "from" bus, one or more "dummy" buses and the "to" bus.  Each dummy 
bus must have only two lines connected to it, each of which are members of the multi-section line record.  See Multi-
Section Line Information for details.   

The Multi-Section Line Display is a class of Case Information Display and therefore can be used in a manner 
consistent with all other case information displays.   It has a local menu from which you can print, copy, and modify its 
information as well as view the information dialog of its multi-section line information.  The local menu also affords the 
opportunity to insert new multi-section lines into the model or to delete existing ones when the application operates in 
the Edit Mode.  Moreover, it enables you to invoke the Quick Power Flow List and Bus View Display for the line’s 
terminal buses.  You can also sort the multi-section line information by clicking on the heading of the field by which you 
want to sort.  Additionally, you can choose to restrict the information shown by the Multi-Section Line  Display 
according to the constraints of the area/zone/owner filters.  

To show this display select Case Information > Others > Multi-Section Lines. 

 

The display contains the following fields by default: 

From Bus #, From Name 

Number and name of the multi-section lines from bus .  Right clicking on one of these fields invokes the display’s 
local menu from which you can select either Quick Pow er Flow List or Bus View Display to find more information 
about the from bus . 

To Bus #, To Name 

Number and name of the multi-section lines to bus . Right clicking on one of these fields invokes the display’s local 
menu from which you can select either Quick Power Flow List or Bus View Display to find more information about 
the to bus . 

Circuit 

Two-character circuit identifier for the multi-section line.  The first character in the identifier should always be an "&."   

Sections 

Number of individual lines within the multi-section line record. 

Status  

Current status of the record.  Note, the status is Closed only if all the lines in the record are closed, and is Open 
only if all the lines in the record are open.  Otherwise the status is Mixed.   
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Transformer Display 

The Transformer Display identifies all transformers in the case.  The data presented in the Transformer Display 
supplements the data presented in the Line/Transformer Display by presenting transformer-specific information.  
Consult the Line/Transformer Display for the transformer flows. 

The Transformer Display is a class of Case Information Display and therefore can be used in a manner consistent with 
all other case information displays.   It has a local menu from which you can print, copy, and modify its information as 
well as view the information dialog of its associated transformer.  You can find a specific transformer using the names 
or numbers of its terminal buses, and you can learn more about a particular transformer’s terminal buses by choosing 
either Quick Power Flow List or Bus View Oneline.   When in Edit Mode, you can delete an existing transformer from 
the case.  You can also sort the transformer information by clicking on the heading of the field by which you want to 
sort.  

To show this display select Case Information > Transformers Controls . 

 

The Transformer Display contains the following fields by default: 

From Bus Number and Name 

From Bus  number and name.  The From Bus  is the tapped side.  You may view either the Quick Power Flow List or 
the bus view display for the From Bus  from the local menu. 

To Bus Number and Name 

To Bus number and name. You may view either the Quick Power Flow List or the bus view display for the To Bus 
from the local menu.  

Circuit 

Two-character identifier used to distinguish between multiple transformers joining the same two buses. 

Status  

The service status of the transformer.  This field is toggleable. 

Type  

Type of transformer.  Possible values include   

Fixed  The tap positions are fixed  

LTC  The tap ratio changes to regulate bus voltage 

Mvar The tap ratio changes to regulate reactive power flow  

Phase  The phase angle changes to regulate real power flow  

Tap/Phase 

Indicates the tap ratio for LTC and fixed transformers and the phase shift angle in degrees for phase-shifting 
transformers.  

XF Auto 

If the value of this field is Yes , the transformer will automatically change its tap or phase angle to keep the regulated 
value within the specified regulation range, provided that the Auto XF field of its associated area is set to Yes and 
transformer tap/phase control has not been disabled for the entire case.  The Auto XF field of individual areas is set 
from the Area Display, and case-wide transformer control can be set from the Power Flow Solution tab of the 
PowerWorld Simulator Options Dialog. Click on this field to toggle its values.   

Reg Bus  

For an LTC transformer, this is the number of the bus whose voltage is controlled by the transformer.  For phase 
shifting transformers, the real power is always controlled at the tapped bus.   

Reg Value  

For an LTC transformer, this is the present per unit voltage at the regulation bus.  For a phase shifting transformer, 
this is the present real power flow through the transformer measured on the "from" (tapped) side.  

Reg Error 

Error between the regulated value and the regulation range specified by Reg Min and Reg Max.  If the regulated 
value is within the regulation range, then the error is zero.  The error is negative if the regulated value falls below 
the regulation range, and it is positive if the regulated value exceeds the regulation range. 

Reg Min, Reg Max 

Minimum and maximum values for the regulation range.  For LTC transformers, these fields represent per unit 
voltage at the regulated bus.  For phase shifting transformers, these fields represent actual MW flow through the 
transformer measured on the "from" (tapped) side.  Because transformers use discrete control, the maximum 
regulation value must be somewhat greater than the minimum value.   

Tap Min, Tap Max 
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For LTC transformers, these fields specify the minimum and maximum tap ranges for the transformer.  For phase 
shifting transformers, these fields specify the minimum and maximum phase shift angle in degrees. 

Step Size 

The per unit step size for tap changing transformers.  This step size is usually determined by dividing the total range 
of transformer operation by the number of tap positions available. 
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Three Winding Transformer Display 

The Three Winding Transformer Display shows information about all the three winding transformer devices in the 
case.  Three winding transformers are modeled in Simulator as a grouping of tw o winding transformers, connected at 
a common midpoint or "Star" bus.  The Three Winding Transformer Display is a way to view all the terminal connection 
points for the three winding transformers and the power delivered at each of the terminals. 

The Three Winding Transformer Display is a class of Case Information Display, and therefore can be used in a 
manner consistent with all other case information displays.  It has a local menu from which you can print, copy, and 
modify its information as well as view the information dialog of its associated three winding transformers.  When in Edit 
Mode, you can define new three winding transformers using the Insert option, or delete existing three winding 
transformers using Delete .  You can also sort the three winding transformer information by clicking on the heading of 
the field by which you want to sort. 

To show this display, select Case Information > Others > Three Winding Transformers. 

 

This display contains the following fields by default: 

Pri Bus Num, Sec Bus Num , Ter Bus Num  

These are the primary winding, secondary winding and tertiary winding terminal bus numbers for the three winding 
transformer connections. 

Pri, Sec and Ter MW and MVAr  

These fields display the real and reactive power delivered at each of the three winding transformer terminals. 

Circuit 

The circuit identifier for the three winding transformer. 
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DC Lines Display 

The DC Line Display presents data describing each dc line in the case. The DC Line Display is a class of Case 
Information Display and therefore can be used in a manner consistent with all other case information displays.   It has 
a local menu from which you can print, copy, and modify its records as well as view the information dialog of its 
associated dc lines. You can also sort the dc line records by clicking on the heading of the field by which you want to 
sort.  Additionally, you can choose to restrict the records shown by the DC Line Records Display according to the 
constraints of the area/zone/owner filters.  

To show the dc line records display, select Case Information > DC Lines, and click on the DC Lines tab. 

 

By default, the dc line records display contains the following fields: 

Number 

Each dc line must be assigned a unique number, typically between 1 and 40.   

Rect Number, Rect Name, Rect MW, Rect Mvar  

Number and name of the rectifier bus, and the real and reactive power flow from the rectifier into the dc line.  You 
may right-click on any of the rectifier-related fields and select Quick Power Flow List or Bus View Oneline from the 
local menu to view additional information about the rectifier bus. 

Inv Number, Inv Name, Inv MW, Inv Mvar 

Number and name of the inverter bus, and the real and reactive power flow from the inverter into the dc line. You 
may right-click on any of the inverter-related fields and select Quick Power Flow List or Bus View Oneline from the 
local menu to view additional information about the inverter bus. 

Control Mode  

Specifies how flow on the dc line is controlled.  If this field is set to Power, then the line’s MW flow is the control 
parameter.  If the control mode is defined as Current, then the line’s current is the control parameter. 

Setpoint 

Specifies the initial value of the control parameter, which is expressed either in MW or in amps depending on the dc 
line’s control mode. 

Set kV 

Specifies the voltage of the dc line in kV. 
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Multi-Terminal DC Record Display 

The Multi-terminal DC Line Display presents data describing each multi-terminal DC line in the case.  The Multi-
Terminal DC Line Display is a class of Case Information Display and therefore can be used in a manner consistent 
with all other case information displays.   It has a local menu from which you can print, copy, and modify its information 
as well as view the information dialog of its associated records.  The local menu also affords the opportunity to insert 
multi-terminal DC line records into the model or to delete existing ones.  

To show the Multi-Terminal DC Line display, select Case Information > DC Lines from the main menu bar, and click 
on the Multi-terminal DC Lines tab of the transformer case information display. 

 

The Multi-terminal DC Line display show s the following fields by default: 

Number 

The record number of each multi-terminal DC record. 

Num Conv 

The total number of converters in each multi-terminal DC network. 

Num Buses 

The total number of DC buses in each multi-terminal DC network. 

Num Lines 

The total number of DC lines in each multi-terminal DC network. 

Mode  

The control mode of the multi-terminal DC network: 0 is Blocked control, 1 is Power control, and 2 is Current control.  

V. Cont. Bus  

The number of the AC converter bus at which the DC voltage is controlled. 

Switched Shunt Displays  

Switched Shunt Display 

The Switched Shunt Display identifies all switched shunt devices in the case.  Switched shunts are used in power 
systems either to inject additional MVR into the system (capacitive shunts) or to absorb excess reactive power 
(inductive shunts).  They may also be used to regulate bus voltage within some specified range. 

The Switched Shunt  Display is a class of Case Information Display and therefore can be used in a manner consistent 
with all other case information displays.   It has a local menu from which you can print, copy, and modify its information 
as well as view the information dialog of its associated switched shunts.  You can find a specific switched shunt using 
its bus name or number, and you can learn more about a particular shunt’s terminal bus by choosing either Quick 
Power Flow List or Bus View Oneline.   When in Edit Mode, you can insert a new shunt into the case or delete an 
existing shunt.  You can also sort the switched shunt information by clicking on the heading of the field by which you 
want to sort. Additionally, you can choose to restrict the information shown by the Load  Display according to the 
constraints of the area/zone/owner filters.  

To call up the Switched Shunt Display, click Case Information > Switched Shunts . 

 

The Switched Shunt Display contains the following fields by default: 

Number, Name 

Number and name of terminal bus to which the switched shunt is attached.  Only one switched shunt is allowed per 
bus.  Use the right menu options to inspect either the Quick Power Flow List or the Bus View Display for the 
terminal bus. 

ID 

Circuit identifier for the switched shunt device. 

Reg Bus Num. 

Number of the bus whose voltage is regulated by the switched shunt.  If the regulation bus is the same as the 
terminal bus, this field is blank. 

Status  

The service status of the switched shunt.  This field is toggleable. 

Control Mode  

Control Mode for the switched shunt.  A switched shunt may operate either as Fixed if its reactive value is to be held 
constant, as Discrete if its reactive output is controlled automatically in discrete steps to regulate its terminal 
voltage, or as Continuous  if its reactive injection is allowed to vary over a continuous spectrum of values to regulate 
its terminal voltage.  A shunt will be switched either discretely or continuously to regulate its terminal bus’ voltage 
between its high and low voltage limits provided the Auto Shunt field of its corresponding area is set to Yes  and 
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switched shunt control has not been disabled for the entire case.  You may set the value of the Auto Shunt field 
from the Area Display, and you can control case-wide enforcement of shunt switching from the Power Flow Solution 
tab of the PowerWorld Simulator Options  Dialog.  This Control Mode field is toggleable. 

Regulates 

Can be set to regulate either bus voltage or generator MVAR output. 

Actual Mvar  

The reactive power currently supplied by the switched shunt.   

Volt High 

Per unit high-voltage limit for the regulation range.  It is important for discrete shunt control that Volt High exceed 
Volt Low by a nontrivial amount; otherwise, the output of the shunt may oscillate during the Power Flow Solution. 

Volt Low 

Per unit low-voltage limit for the regulation range. 

Reg Volt 

Actual per unit voltage at the regulated bus.  When Control Mode is either Discrete or Continuous, this voltage 
should be between Volt Low and Volt High.   

Deviation 

Deviation of the regulated bus’ actual per unit voltage from the desired regulation voltage.  If the actual voltage is 
within the regulation range, this field is zero.  If the voltage is greater than Volt High, the deviation is positive.  It is 
negative if the actual voltage is less than Volt Low. 

Nominal Mvar  

The Nominal Mvar field gives the initial amount of reactive power the device would supply (in Mvars) if its terminal 
voltage were 1.0 per unit. 

Max Mvar, Min Mvar  

The maximum and minimum Mvar range for the switched shunt. 

Interface Displays  

Interface Display 

The Interface Display is used to show the net real power (MW) flow on a group consisting of one or more of the 
following devices: 1) transmission lines (AC and DC) and/or transformers, 2) total tie-lines between two adjacent 
areas, 3) total tie-lines between two adjacent zones, 4) Generators and Loads, 5) Injection Groups, and 6) 
Contingency Actions  .  Interface information is useful because secure power system operation often requires that the 
flow on such groups be less than some limit value.  For example, interface information could be used as "proxies" for 
other types of security constraints, such as voltage or transient stability limitations.  Another major potential use for 
interfaces is in the Optimal Power Flow solution to monitor flows on groups of devices, such as a set of transmission 
lines, generation leaving a plant, load demanded in a certain region, etc.  Interface information can also be extremely 
useful for summarizing the flows occurring on a large network.  Interface flows can be monitored using the Limit 
Violations Display.   

The Interface Display presents more detailed information for each interface that has been defined for the case. The 
Interface Display is a class of Case Information Display and therefore c an be used in a manner consistent with all 
other case information displays.   It has a local menu from which you can print, copy, and modify its information as well 
as view the information dialog of its associated interfaces.  The local menu also affords the opportunity to insert new 
interface definitions either singly ( Insert) or as a group (Automatic Insertion) into the model or to delete existing ones.  
In addition, PowerWorld has also added options for reading NERC flowgate files (Load NERC Flowgates) and writing 
NERC flowgate files (Save NERC Flowgates) to the local menu. 

You can sort the interface information by clicking on the heading of the field by which you want to sort.  Additionally, 
you can choose to restrict the information shown by the Interface Display according to the constraints of the 
area/zone/owner filters.  

To show the interface display, select Case Information > Interfaces. 

Interface information can be saved in the "*.aux" auxiliary file format.  See Auxiliary Files for details.   

 

The Interface display contains the following fields: 

Number 

Numeric identifier for the interface. 

Name 

Alphanumeric identifier for the interface (24 characters maximum). 

MW Flow 

Current MW flow on the interface.  This flow is the sum total of the Base MW Flow and the Contingent MW Flow. 
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MW Limit 

Current rating for the interface in MW. 

Percent 

The actual MW flow on the interface as a percentage of the MW limit. 

Monitor Direction 

The current direction in which the MW flow is being monitored.  The possibilities are From - To, To - From, or Both. 

MW A Limit, MW B Limit, MW C Limit 

These three fields display the values of the three possible limits for the interface. 

Has Contingency 

This is a Yes or No field that will be set to Yes if any of the elements making up part of the interface are at a device 
limit. 

Contingent MW Flow  

If the interface defined contains a contingency action, the Contingent MW Flow is the approximated flow amount 
that would be added to the interface should the contingency occur. 

Base MW Flow  

The base MW flow is the flow on the interface prior to any considered contingency elements. 
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Nomogram Display 

The Nomogram Display is used to modify and create Nomogram definitions.  Nomograms are combinations of two 
interfaces for monitoring combined flows on the interfaces concurrently.  These Nomogram interfaces will have a limit 
definition that defines a region of allowed flow on the interfaces, and can be monitored in many tools in Simulator as 
potential constraints, such as the contingency analysis reporting of interface violations.  Another major potential use 
for nomograms is in the Optimal Power Flow solution to monitor the flow on a pair of interfaces.  Nomogram 
information can also be extremely useful for summarizing the flows on a pair of interfaces whose operation and 
allowed flow are closely tied together.  Nomogram flows can be monitored using the Limit Violations Display.   

The Nomogram Display presents more detailed information for each nomogram that has been defined for the case. 
The Nomogram Display is a class of Case Information Display and therefore can be used in a manner consistent with 
all other case information displays.   It has a local menu from which you can print, copy, and modify its information as 
well as view the information dialog of its associated nomograms. 

You can sort the nomogram information by clicking on the heading of the field by which you want to sort.  Additionally, 
you can choose to restrict the information shown by the Interface Display according to the constraints of the 
area/zone/owner filters.  

To show the interface display, select Case Information > Nomograms. 

Nomogram information can be saved in the "*.aux" auxiliary file format.  See Auxiliary Files for details.   

 

The Nomogram display contains the following fields: 

Name 

Alphanumeric identifier for the nomogram. 

Int A Flow 

Current MW flow on the first interface of the interface pair forming the nomogram.  This flow is the sum total of the 
Base MW Flow and the Contingent MW Flow. 

Int B Flow  

Current MW flow  on the second interface of the interface pair forming the nomogram.  This flow is the sum total of 
the Base MW Flow and the Contingent MW Flow. 

% Limit, Max Nomo-interface  

The actual MW flow on the nomogram as a percentage of the combined nomogram limit. 

Monitor 

Indicates whether or not the nomogram should be monitored for violations or as a constraint in the Optimal Power 
Flow. 

Limit Group 

The name of the limit group the nomogram is a member of for limit monitoring. 

Island Displays  

Island Display 

The Island Display presents information on the system’s islands.  An island consists of a group of buses that are 
electrically connected via ac transmission lines and transformers and thus operate in synchronism with one another.  
Multiple islands can be connected together via dc transmission lines.  Each island requires a slack bus.  All systems 
have at least one island, which may encompass the entire system. 

The Island Display is a class of Case Information Display and therefore can be used in a manner consistent with all 
other case information displays.   It has a local menu from which you can print, copy, and modify its information.  You 
can also sort the islands information by clicking on the heading of the field by which you want to sort.  

To show this display select Case Information > Islands .  The display is only available in run mode. 

You cannot modify any fields on this display.   

 

The display has the following fields for each island:  

Slack Bus Number, Slack Bus Name, Slack Bus Area 

Number, name and area of the slack bus for the island.  Each island requires at least one slack bus. 

Total Buses 

Total number of buses in the island.   

Energized 

Indicates whether the island is connected to a source of power. 

Gen MW, Gen Mvar  
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Total real and reactive generation for the island.   

Load MW, Load Mvar  

Total real and reactive load for the island. 

Scheduled Exports  

The power scheduled to be provided by the island to other regions of the system. Because the island is isolated 
from the rest of the system, this export requirement is currently not met. 

DC MW Exports  

The power provided by the island to other regions of the system across a DC line. 

Transactions Displays  

Base MW Transactions Display 

The Base MW Transactions Display is a quick way to view the defined base transactions between areas within the 
load flow case.  

The Matrix of Base Transactions display is set up as a matrix of transactions, with the areas listed as both the 
column and row identifiers.  It is important to note that the direction of the base transaction is such that the area 
represented by the row is assumed the exporting area, and the area represented by the column is assumed the 
importing area.  For example, if there is a 50 MW transaction from area one to area two, you will see a +50 in the 
matrix in row 1, column 2.  However, if you look at row 2, column 1, you will see a – 50.  This is because the grid is 
displaying the EXPORT from area two to area one, but since area two is importing, not exporting, the value is 
represented as negative. 

Each row and column position, with the exception of the diagonal positions (it does not make sense for an area to 
export to itself), can be directly modified by the user in this information display.  As you type a value in one of the 
matrix positions, Simulator automatically fills the symmetric matrix position with the negative of the value you enter.  
This makes for a quick and easy location for adding and removing base transactions from the case. 

Note that you cannot modify Unspecified transactions in the Base MW Transactions display.  This makes sense, as 
the unspecified transactions have only one associated area.  To modify unspecified transaction amounts, you must 
open the Area Information Dialog for the area you wish to modify, and change the Unspecified transaction amount.   

The List of Base Transactions  is just another way of showing the base transactions between areas.  The List of 
Base Transactions Display is a class of Case Information Display and therefore can be used in a manner consistent 
with all other case information displays.   It has a local menu from which you can print, copy, or modify its records as 
well as view the information dialog of its associated areas.  You can also sort the area records by clicking on the 
heading of the field by which you want to sort.  

 

By default, the List of Base Transactions display contains the following fields: 

Export Area Number, Export Area Name 

Exporting area number and alphanumeric identifier. 

Other Area Number, Other Area Name 

Importing area number and alphanumeric identifier. 

MW Transfer  

Value of the transfer in MW. 
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MW Transactions Display (Scheduled) 

The MW Transactions Display lists the MW transactions that have been defined for the case.  Please note that this 
display shows only the scheduled transactions between areas, not the base transactions.  See Area Transaction 
Modeling for a description of the difference between the two. 

The MW Transactions Display is a class of Case Information Display and therefore can be used in a manner 
consistent with all other case information displays.   It has a local menu from which you can print, copy, and modify its 
information as well as view the MW Transac tion Information dialog of its associated transactions.  The local menu also 
affords the opportunity to define new MW transactions using the same MW Transaction Information Dialog or to delete 
existing ones.  You can also sort the MW transaction information by clicking on the heading of the field by which you 
want to sort. Additionally, you can choose to restrict the information shown by the Load  Display according to the 
constraints of the area/zone/owner filters. 

To call up the MW Transactions  Display, click Case Information > MW Transactions  from Run Mode. 

 

This MW Transactions  Display contains the following fields by default: 

Seller Area Name, Buyer Area Name 

Names of the selling and buying areas. 

Type  

Designates the firmness of the transaction: either firm (non-recallable) or nonfirm (recallable). 

Enabled 

Indicates whether the transaction is active or inactive.  Inactive transactions will not be modeled as part of the 
simulation.  This is a toggleable field.  For inactive transactions, the information fields are printed in gray text. 

Sched MW 

Scheduled MW value for the transaction.  The scheduled MW will equal the actual MW for the transaction except 
during ramp periods.  The duration of the ramp periods can be specified from the Simulation tab of the PowerWorld 
Simulator Options  Dialog.  You can also disable the enforcement of generator ramp limits from the Limits tab of the 
same dialog.   

Actual MW 

Actual MW value for the transaction.  When a transaction is inactive, its actual MW value is zero. 

Buy Price ($/MWhr) 

Price the buyer pays for the transaction in $/MWhr.  The seller receives this amount, minus any wheeling charges.   

Start Time, End Time 

Starting and ending time for the transaction.  To model transactions without a starting or ending time, model it as a 
base transaction. 

Day Type  

Designates how to model the transaction for different days of the week.  This field can assume one of four possible 
values.  A value of Specified Days  forces Simulator to model the transaction only for the days specified in the Start 
Day and End Day fields.  A value of Week Days indicates that the transaction will be modeled every day Monday 
through Friday, but not on the weekends.  Transactions with a Day Type of Every Day are modeled both on 
weekdays and weekend days.  Finally, transactions with a Day Type of Weekend occur only on the weekend.  This 
is a toggleable field. 

Start Day, End Day 

For transactions having a Day Type of Specified Days , the Start Day and End Day fields define the days for which 
the transaction will be modeled.  These fields are ignored if the transaction’s Day Type is not Specified Days. 

Wheeling Cost 

The amount of the buy price being paid as Wheeling charges. 
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Scheduled MW Transactions Information Dialog 

The MW Transactions Information Dialog is used to modify or insert new scheduled transactions.   You can display this 
dialog from the local menu of the MW Transactions (Scheduled) list display.   

 

The dialog has the following fields: 

Buyer Area, Se ller Area 

Shows the buying and selling area associated with the transaction.  You can only modify these fields when you are 
inserting a new transaction from the MW Transactions list display.  Otherwise to change either the buyer or the 
seller you need to f irst remove the transaction and then insert a new one. 

Transaction Amount (MW) 

MW amount of the transaction.  Each transaction can only have a single value.  By default, this value equals the 
MW Blocks for Transactions option that is specified on the Simulation Tab  of the PowerWorld Simulator Options 
Dialog. 

Ramping (Minutes) 

The length of time over which the transaction will increase from zero to its scheduled amount.  By default, this value 
equals the Transaction Ramp Time option that is specified on the Simulation Tab of the PowerWorld Simulator 
Options Dialog. 

Transaction Type  

Designates the transaction as either non-firm (recallable) or firm (non-recallable).  Simulator currently does not use 
these identifiers in any of its calculations.  They are provided for your bookkeeping. 

Buyer’s Price ($/MWhr) 

Price the buyer is paying for the transaction in $/MWhr.  The seller is receiving this amount, minus any wheeling 
charges.  Modifying the Buyer’s Price automatically changes the Seller’s Price by a corresponding amount.     

Wheeling Price ($/MWhr) 

Indicates the total paid to areas that wheel power between the tw o transacting parties.  This field is visible only if 
you have defined wheeling areas using the Wheeling Areas Dialog. 

Seller’s Price ($/MWhr) 

Price the seller is receiving for the transaction in $/MWhr.  Modifying the Seller’s Price automatically changes the 
Buyer’s Price by a corresponding amount. 

Start Time, End Time 

Starting and ending time for the transaction, entered in the form of hh:mm.   

Start Day, End Day 

The start and end days for the transaction.  These values are obeyed only when Day Type  is Specified Days. 

View/Modify Wheeling Areas  

Pressing this button brings up the Transaction Wheeling Dialog, which can be used to identify those areas that will 
provide and bill transmission service for the transaction.  Such areas are called wheelers.  

Day/Time Type  

Specifies the days on which the transaction will take place.  Select Specified Days if the transaction should be 
modeled only on the days you have specified using the Start Day and End Day fields.  Select Every Day if the 
transaction should occur between Start Time and End Time every day of the week, including weekends.  Select 
Week Days if the transaction should occur between Start Time and End Time only on days Monday through 
Friday.  Select Weekends if the transaction should occur between Start Time and End Time only on Saturdays and 
Sundays.  Finally, select Always On if the transaction should be modeled at all times during the simulation. 

Transaction Enabled 

This box will be checked if the defined transaction is currently being used for the simulation. 
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Wheeling Areas Dialog 

When two areas participate in a power transaction, the power that is exchanged likely will flow through one or more 
neighboring areas that are not directly participating in the transaction.  If a significant portion of the power flows 
through a particular entity , that entity likely will try to bill the transacting parties for transmission service.  Such an entity 
is called a wheeler.  The Wheeling Areas Dialog allows you to identify areas that will wheel power as part of the 
transaction, and at what cost. 

You may invoke the Wheeling Areas Dialog from the MW Transaction Information Dialog by clicking on the 
View/Modify Wheeling Areas  button. 

The table that occupies the left half of the Wheeling Areas Dialog identifies each wheeling area that has been defined 
for the transaction.  This table is a Case Information Display and thus exhibits properties and controls common to all 
case information displays. 

To define a new wheeling area for a transaction, specify an area name (or an area number) and click the Add New 
Area By Name (or the Add New Areas By Number) button.  If you choose to identify new wheeling areas by number, 
you may add more than one new wheeling area at a time by specifying a range of area numbers.  New wheeling areas 
are added to the Wheeling Areas in Transaction table, with the wheeling cost set equal initially to a default value of 
$2/MWHr.  You can change the wheeling charge by specifying a new value in the grid. 

To delete a wheeling area, right-click on the row of the record you wish to delete and select Delete from the resulting 
local menu.   

To abort the wheeling area definition process without saving changes, click Cancel.  To save changes and close the 
dialog, click OK. 

Limit Violations Displays  

Limit Violations 

The Limit Violations Dialog allows you to see buses, lines, or interfaces that exceed their limit.   

 

The following fields are shown on the display: 

Elements To Show 

Change this value to modify which elements are displayed in the Buses, Lines, and Interfaces.  Set it to… 

All Elements to show all Buses, Lines and Interfaces regardless of monitoring settings. 

Monitored Elements to only display Buses, Lines and Interfaces that meet the conditions for 
monitoring.  See Limit Monitoring Settings for more information on setting 
which values are monitored. 

Violating Elements to only display Buses, Lines and Interfaces that are violating. See Limit 
Monitoring Settings for more information on setting what is considered a 
violation. 

Number of Bus Voltage Magnitude Violations  

Shows the total number of bus voltage magnitude violations.  These violations are shown on the Bus Voltage 
Magnitude Limit Violations Display.  This field is read-only. 

Low Voltage Suspects  

Shows the total number of buses whose voltages have fallen below a designated threshold to indicate a low voltage 
solution is being reached in some location in the system. 

Number of Line/Transformer Violations  

Shows the total number of violations reported on Line and Transformer Limit Display.  This field is read-only. 

Number of Interface Violations  

Indicates the total number of interface violations.  These violations are shown on the Interface Violations Display.  
This field is read-only. 

Limit Group Values 

This part of the dialog shows information about the Limit Groups that are defined.  For more information see Limit 
Monitoring Settings. 

 

Buses, Lines, Interfaces and Nomograms Tabs  

These tabs contain tables showing lists of the respective elements.  Since these tables are another variety of the Case 
Information Displays, you may interact with it in a familiar manner.  Click on any of the field headings to sort by that 
field.  Right-click on the display to call up the display’s local menu.  From the local menu, you can print the violations, 
copy the violation records to the Windows clipboard for use with another application, modify the format and content of 
the violations listing, view the information dialog of the respective element, and view the Quick Power Flow List or Bus 
View Display. 
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The default fields for each tab are as follows: 

Buses Tab 

Number, Name 

Bus number between 1 and 99,999, and its alphanumeric identifier.  

Area Name 

Alphanumeric identifier of the bus’ area. 

Monitor 

Specifies whether the individual element is eligible for monitoring.  See Limit Monitoring Settings for more 
information. 

Limit Group 

The limit group the element belongs to.  See Limit Monitoring Settings for more information. 

PU Volt 

Bus’ per unit voltage magnitude.   

Volt (kV) 

Bus’ actual voltage magnitude in kV.  This is the per unit voltage magnitude multiplied by the bus’ nominal 
voltage. 

 

Lines Tab 

From Bus Number and Name 

"From" bus number and name.  For transformers, the from bus is the tapped side.  Right- clicking on either of 
these fields allows you to see all the flows measured at the "from" bus using the Quick Power Flow List or Bus 
View Display local menu options.  

To Bus Number and Name 

"To" bus number and name.  For transformers, the to bus is the untapped side.  Right-clicking on either of these 
fields allows you to see all the flows into the "to" bus using the Quick Power Flow List or Bus View Display local 
menu options. 

Circuit 

Two-character identifier used to distinguish between multiple lines joining the same two buses. 

Monitor 

Specifies whether the individual element is eligible for monitoring.  See Limit Monitoring Settings for more 
information. 

Limit Group 

The limit group the element belongs to.  See Limit Monitoring Settings for more information. 

Used Limiting Flow, Limit, Used % of Limit 

The flow at the end of the branch selected for measurement, and its MVA or Amp limit.  The percentage 
equivalent of the flow to it’s limit is given in the Used % of Limit column. 

MVA or Amps? 

Units used with the Max Flow and the Limit field.  All flows are expressed either in MVA or amps. 

 

Interfaces Tab 

Number, Name 

Number and alphanumeric name identifiers for the interface. 

Monitor 

Specifies whether the individual element is eligible for monitoring.  See Limit Monitoring Settings for more 
information. 

Limit Group 

The limit group the element belongs to.  See Limit Monitoring Settings for more information. 

Interface MW Flow  

Current MW flow on the interface. 

MW Limit 

Interface limit in MW. 
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Percent 

Percentage loading of the interface, calculated as MW Flow/MW Limit * 100. 

 

Nomograms 

Name 

Alphanumeric name identifier for the nomogram. 

Monitor 

Specifies whether the individual element is eligible for monitoring.  See Limit Monitoring Settings for more 
information. 

Limit Group 

The limit group the element belongs to.  See Limit Monitoring Settings for more information. 

Interface A Flow 

The MW flow on the first nomogram interface forming the nomogram. 

Interface B Flow  

The MW flow on the second nomogram interface forming the nomogram. 

% Limit, Max Nomo-Interface  

The percent of the nomogram limit, with respect to the nomogram interface which is loaded higher. 

 

Area Reporting and Zone Reporting Tabs  

These tabs display all the Areas and Zones in the system.  The important columns are 

Report Limits  

Toggle this between YES and NO to set whether the specific element should be monitored. 

Report Min kV and Report Max kV 

Only buses and lines within this kV range will be monitored. 
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Limit Monitoring Settings  

Simulator offers many tools to study the capabilities of a power system.  Examples include: 

• Limit Violations Display 

• Contingency Analysis  

• Available Transfer Capability  

• Optimal Power Flow  

• Security Constrained OPF Overview  

• Voltage Adequacy and Security Tool 

All of these tools make extensive use of power system limits.  Limits for various power system elements include: 

• MVA (or Amp) limits on transmission lines and transformers 

• MW limits on Interfaces  

• High and low voltage limits for Buses  

The accuracy of all these limits is very important, as is the specification of which limits should be monitored.  While 
ensuring the accuracy of input data such as power system limits must be left to the user, PowerWorld Simulator 
provides several ways to specify which limits should be monitored.  Limit Monitoring is specified according to settings 
for the Area, Zone and Limit Group to which the power system element belongs.  A power system element is 
monitored only if ALL of the following conditions are met. 

 

Conditions for Monitoring an Element’s Limit 

• Its Monitor field is set to YES 

• Its Limit Group is Enabled 

• Its Area is set to Report Limits and it meets the KV range for reporting  

• Its Zone is set to Report Limits and it meets the KV range for reporting  

The Limit Monitoring Settings Dialog gives you ability to specify all these settings to setup the limits you want to 
monitor, and thus enforce in the various tools that Simulator provides. 
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Limit Monitoring Settings Dialog 

The Limit Monitoring Settings Dialog gives you ability to specify which limits you want to monitor, and thus enforce in 
the various tools that Simulator provides.  In general, keep in mind that a bus, transmission line/transformer, or 
interface’s limit is monitored only if the following conditions are met. 

 

Conditions for Monitoring an Element’s Limit 

• Its Monitor field is set to YES 

• Its Limit Group is Enabled 

• Its Area is set to Report Limits and it meets the KV range for reporting  

• Its Zone is set to Report Limits and it meets the KV range for reporting  

 

The tabs on the Limit Monitoring Settings Dialog allow you to change these settings. 

Buses, Lines, and Interfaces Tabs  

Each tab shows a list of the respective type of power system element.  The important columns include 

Monitor : toggle this between YES and NO to set whether the specific element 
should be monitored. 

Limit Group : toggle this value to specify which Limit Groups the element belongs to 

Note: If Use Area/Zone Filters on List Displays  is checked then the Area/Zone/Owner Filters will effect what is 
displayed on these lists. 

Note: If Elements to Show is set to Monitored Elements, then only elements which meet the conditions for 
monitoring will be displayed in these lists. 

Area Reporting and Zone Reporting Tabs  

These tabs display all the Areas and Zones in the system.  The important columns are 

Report Limits : toggle this between YES and NO to set whether the specific element 
should be monitored. 

Report Min kV and Report Max kV : Only buses and lines within this kV range will be monitored. 

Nomogram Tab 

This tab displays any defined Nomograms in the system.  The important columns are 

Monitor : toggle this between YES and NO to set whether the specific element 
should be monitored. 

Limit Group : toggle this value to specify which Limit Groups the element belongs to 

Modify/Create Limit Group Tab 

Every power system elements belongs to a single Limit Group.  By default, all power system elements are in the 
same Limit Group that is named "Default".  New limit groups can be added by right-clicking in the table and 
choosing Insert from the popup menu.  Additional limit groups give the flexibility of assigning devices to different 
groups, where each group can have its own set of defined limit information. 

The limit group stores important values regarding the enforcement and monitoring of the power system elements 
within the Limit Group.  The values are 

Branch Percentage: The percentage to which Simulator’s study tools will limit a line or 
transformer.  Typically this is 100%, but it can be modified.  In 
Contingency Analysis, then lines will be flagged as violated if they exceed 
this percentage.  In performing an Optimal Power Flow, all attempts will be 
made to keep the line below this percentage. 

Line Rate Set: You may define eight different ratings to transmission lines or 
transformers (for more information see Line/Transformer Information).  
Change this value to specify which rating set should be used for 
lines/transformers in the limit group. 

Amps or MVA:  Limits for transmission lines and transformers are always entered in MVA.  
However, when reporting limit violations, it is common to check 
transmission line limits in terms of their amp loading.  If the Treat Line 
Limits As Equivalent Amps is checked, the limits for transmission lines are 
reported in amps rather than MVA.  If this box is not checked, limits for 
both transmission lines and transformers are expressed in MVA. 

  For reference, note that the amp rating of a line is derived from the MVA 
rating using the formula 
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Interface Percentage: The percentage to which Simulator’s study tools will limit an interface.  
Typically this is 100%, but it can be modified.  In Contingency Analysis, 
then interfaces will be flagged as violated if they exceed this percentage.  
In performing an Optimal Power Flow, all attempts will be made to keep 
the interface below this percentage. 

Interface Rate Set: You may define eight different ratings to an interface.  Change this value 
to specify which rating set should be used for interfaces in the limit group. 

Nomogram Percentage: The percentage to which Simulator’s study tools will limit a nomogram. 

Low PU Volt: Buses will be flagged as violated if they fall below this per unit voltage. 

High PU Volt: Buses will be flagged as violated if they go above this per unit voltage. 

Disabled: Set the value to YES to ignore all power system element limits in the Limit 
Group.  Set the value to NO to monitor limits according to the settings of 
the Limit Group. 

Contingency Line Rate Set:  This field specifies the rating set used for post-contingency monitoring of 
Lines/Transformers. 

Interface Contingency Rate Set: This field specifies the rating set used for post-contingency monitoring of 
Interfaces during Contingency Analysis. 

Limiting End: Specified as higher or lower, this  field determines whether the higher or 
the lower flow amount on the element is used for reporting a limit violation.  
If you use higher, it is possible that the lower flow is not violating the line 
limit.  If you use lower, then you are guaranteed that the element limit is 
being violated at both ends of the element. 

Use Limit Cost: If this field is set to yes, you are enabling the capability to have a cost 
function associated with enforcing constraints.  This cost function can be 
viewed as similar to a generator cost function, in that as the constraint 
becomes overloaded by larger amounts, the marginal cost of enforcing the 
constraint will increase.  For setting the piecewise linear limit cost curve, 
right-click and choose show dialog from the popup menu to access the 
Limit Group Dialog. 

Often monitoring elements according to Area and/or Zone is all that you need.  However, if you need to monitor 
specific groups of power system elements and not others then you need to create some new Limit Groups. 

Elements To Show 

Set to Monitored Elements to only display Buses, Lines, and Interfaces that meet the conditions for monitoring. 

Set to All Elements to show all Buses, Lines and Interfaces regardless of monitoring settings. 

Save/Load Monitoring Settings  

The Save and Load Monitoring Settings buttons allow the user to save the current set or load a previously saved set 
of Limit Monitoring Settings options.  The options are saved in a PowerWorld Auxiliary File text format. 

Limit Group Values 

The values regarding the currently selected Limit Group are graphically displayed here to make them easier to 
modify. 

Do not monitor radial lines and buses  

Check this box to ignore limits on radial lines and buses throughout the case. 



Printed Documentation 

338 

Limit Group Dialog 

The Limit Group Dialog reflects much of the same information that is summarized in the Limit Monitoring Settings 
Dialog’s Modify/Create Limit Groups page.  The same information can be changed here as on the previously 
mentioned display.  One important feature that is unique to this dialog is the ability to define a piecewise linear limit 
cost curve, which can be used for setting up "soft" constraints that can be used in the Security Constrained Optimal 
Power Flow. 

Disabled 

Check this option to ignore all pow er system element limits in the Limit Group.  Leave the box unchecked to monitor 
limits according to the settings of the Limit Group. 

Add New Limit Group 

Clicking this button will create a new limit group, displaying a dialog in which the name for the new limit group can 
be specified. 

Rename Limit Group 

Clicking this button will display a dialog in which a new name for the current limit group can be specified. 

 

Lines/Interfaces 

% of Limit for Reporting (Branches) 

The percentage to which Simulator’s study tools will limit a line or transformer.  Typically this is 100%, but it can be 
modified.  In Contingency Analysis, then lines will be flagged as violated if they exceed this percentage.  In 
performing an Optimal Power Flow, all attempts will be made to keep the line below this percentage. 

Line/Transformer Rating Set 

You may define eight different ratings to transmission lines or transformers (for more information see 
Line/Transformer Information).  Change this value to specify which rating set should be used for lines/transformers 
in the limit group. 

Line/Transformer Contingency Rating Set 

This field specifies the rating set used for post-contingency monitoring of Lines/Transformers. 

Treat Transmission Line Limits as Equivalent Amps  

Limits for transmission lines and transformers are always entered in MVA.  However, when reporting limit violations, 
it is common to check transmission line limits in terms of their amp loading.  If the Treat Line Limits As Equivalent 
Amps is checked, the limits for transmission lines are reported in amps rather than MVA.  If this box is not checked, 
limits for both transmission lines and transformers are expressed in MVA. 

 For reference, note that the amp rating of a line is derived from the MVA rating using the formula 

   
Limiting End of Line  

Specified as higher or lower, this field determines whether the higher or the lower flow amount on the element is 
used for reporting a limit violation.  If you use higher, it is possible that the lower flow is not violating the line limit.  If  
you use lower, then you are guaranteed that the element limit is being violated at both ends of the element. 

% of Limit for Reporting (Interfaces) 

The percentage to which Simulator’s study tools will limit an interface.  Typically this is 100%, but it can be modified.  
In Contingency Analysis, then interfaces will be flagged as violated if they exceed this percentage.  In performing an 
Optimal Power Flow, all attempts will be made to keep the interface below this percentage. 

Interface Rating Set 

You may define eight different ratings to an interface.  Change this value to specify which rating set should be used 
for interfaces in the limit group. 

Interface Contingency Rating Set 

This field specifies the rating set used for post-contingency monitoring of Interfaces during Contingency Analysis. 

% of Limit for Reporting (Nomograms) 

The percentage to which Simulator’s study tools will limit a nomogram. 

Use Limit Cost 

If this field is checked, you are enabling the capability to have a cost function associated with enforcing constraints.  
This cost function can be viewed as similar to a generator cost function, in that as the constraint becomes 
overloaded by larger amounts, the marginal cost of enforcing the constraint will increase. 
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Once the box is checked, the table for defining the limit cost function will become enabled.  The starting point (% 
Flow) must be at or above 100%.  You can then begin inserting additional points in the piecewise linear curve by 
right-clicking in the table and selecting Insert Point from the popup menu, followed by entering the new percent flow 
and marginal cost.  Note that the cost function must be strictly increasing, meaning the next marginal cost value 
must be equal to or greater than the immediately previous value. 

When constraints are given the ability to use this limit cost curve, it effectively gives the optimal power flow the 
ability to "dispatch" the limit of the elements according to the marginal costs of the limit cost curve.  You are 
determining the point on the limit cost curve where the shadow price of enforcing the constraint is met.  Thus the 
OPF routine will determine how much you will allow the element to be overloaded by giving the element the 
piecewise linear curve.  The OPF will solve the problem, and optimize the constraints as it determines shadow 
prices for each constraint and adjusts the limit accordingly during the iterations of the routine.  Since these are 
somewhat flexible limit assignments to the elements, they are sometimes considered "soft" constraints. 

 

Buses/Summary 

Low Per Unit Limit 

Buses will be flagged as violated if they fall below this per unit voltage. 

High Per Unit Limit 

Buses will be flagged as violated if they fall below this per unit voltage. 

Low-voltage solution flag 

Enter a per unit value at which you wish to measure a voltage and consider the solution to be a low voltage solution. 

Include Out-Of-Service Buses 

Check this check-box to include out-of-service buses. 

Elements using Limit Group 

Lists the number of elements that are members of the selected limit group. 

Ownership Displays  

Owner Data Information Display 

The Owner Data display will display the owners sorted by owner number, and show the total number of devices, as 
well as a breakdown of the number of specific devices.  The owner display will also summarize the total device output 
or demand for the owned devices, such as generator output and load demand. 

You can right click on the owner grid to open the local menu, from which you can perform various actions and view an 
informational regarding the owner selected in the grid.  Once an owner dialog is displayed for a particular owner, you 
can browse through information on all the owners. 
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Owner Dialog 

The Owner Dialog displays summary information about the devices designated as owned by the selected owner. 

The dialog for an individual owner displays each of the elements for that owner, along with the percentage of 
ownership, in the device pages labeled Buses, Loads, Generators, and Lines. 

 

The dialog also contains a memo page for making comments or notes about the selected owner. 

General Info 

Load and Generation 

The information in the Load and Generation section provides a summary of the total injections of the owned 
devices.  This includes a total of all the load, generation, and shunt injections owned. 

Summary of Owner Objects  

This information section simply lists a total number of all owned devices.  Note that buses and loads do not 
currently have fractional ownership.  However, generators and transmission lines do have the capability to be 
partially owned by more than one owner.  Therefore it is possible to see fractional ownership amounts for the 
number or generators or lines. 

Generator Costs and OPF Results  

This information provides a summary of LMP and cost information determined by running an Optimal Power 
Flow solution.  The information provided is determined only for devices owned by the selected owner. 
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Owned Bus Records Display 

The Owned Bus Records display is a Case Information Display that allows you many of the same options as the Case 
Information Bus Display.  In addition to the information available for viewing from the Bus Display, the Owned Bus 
Records Display also shows the owner number and percentage of ownership.  Currently, Simulator only allows one 
owner per bus, so by default the ownership percent is always 100%. 
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Owned Load Records Display 

The Owned Load Records display is a Case Information Display that allows you many of the same options as the 
Case Information Load Display.  In addition to the information available for viewing from the Load Display, the Owned 
Load Records Display also shows the owner number and percentage of ownership.  Currently, Simulator only allows 
one owner per load, so by default the ownership percentage is always 100%. 
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Owned Generator Records Display 

The Owned Generator Records Display is a Case Information Display that allows you many of the same options as the 
Case Information Generator Display.  In addition to the information available for viewing from the Generator Display, 
the Owned Generator Records Display also shows the owner number and percentage of ownership.  Currently, 
Simulator allows up to four owners for one generator, with a total percentage ownership between 0 and 100%.  To 
make changes to the owners and ownership percentages for a generator, right-click on the grid and choose Show 
Dialog and select the Owners, Area, Zone tab. 
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Owned Line Records Display 

The Owned Line Records Display is a Case Information Display that allows you many of the same options as the Case 
Information Line and Transformer Display.  In addition to the information available for viewing from the Line and 
Transformer Display, the Owned Line Records Display also shows the owner number and percentage of ownership.  
Currently, Simulator allows up to four owners for one generator, with a total percentage ownership between 0 and 
100%.  The make changes to the owners and ownership percentages for a transmission line, right-click on the grid 
and choose Show Dialog and select the Owners tab. 

Load Flow Displays  

Jacobian Display 

The Jacobian display is a matrix showing the system Jacobian matrix for the currently loaded Simulator case.  This 
display can be very useful for educational purposes.  Keep in mind that for a large case, this display can contain a very 
large matrix.  It is possible to right-click on this display and save the grid to a Matlab formatted file, or to export the grid 
to an Excel spreadsheet.  However, Excel does have limitations on the number of rows and columns that could quickly 
be exceeded with a Jacobian matrix from a large case. 
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Ybus Display 

The Ybus display (bus admittance matrix) is a matrix showing the system Ybus for the currently loaded Simulator 
case.  This display can be very useful for educational purposes.  Keep in mind that for a large case, this display can 
contain a very large matrix.  It is possible to right-click on this display  and save the grid to a Matlab formatted file, or to 
export the grid to an Excel spreadsheet.  However, Excel does have limitations on the number of rows and columns 
that could quickly be exceeded with a Ybus from a large case. 
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Injection Groups  

Chapter 9 : Injection Groups 

This chapter describes the setup and use of injection groups.  Injection groups are useful for modeling generators and 
loads together like a unit. 

The following topics are covered in this chapter: 

• Injection Group Overview  

• Creating and Deleting Injection Groups 

• Injection Group Display and Dialog 

• Participation Points Overview  

• Participation Point Record Display 

• Adding Participation Points 
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Injection Group Overview 

An injection group is a collection of loads and generators.  In that respect, injection groups are somewhat analogous to 
areas and zones.  However, unlike with areas and zones, a generator and load can belong to more than one injection 
group.  Moreover, a single injection group may contain generators and loads from several different areas and zones.  
Thus, injection groups are useful when you need to model a collection of generators and loads that act together as a 
unit, regardless of each individual’s area or zone affiliation.  The most common use for injection groups is to model a 
transfer of power from one group of generators and loads to another for PTDF calculations and for PV/QV analysis.  
They are called injection groups  because their components (generators and loads) are objects that inject power into 
the network. 

Working with Injection Groups  

Creating Injection Groups  

To create an injection group, select Case Information > Injection Groups  from the main menu to open the Injection 
Group Case Information Display.  Click the right mouse button on this display, and select Insert from the resulting 
local menu.  Specify a name of up to 24 characters to identify the new injection group, or click the Load button to 
import injection groups from an Injection Group Auxiliary Data File.  If you specify an injection group name, the 
Injection Group Dialog will open, which will allow you to add injection points to the group. 

Alternatively, if the Injection Group Dialog is already open, you can click the button labeled New.  You will then be 
asked to supply the name of the group you wish to add. 
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Deleting Injection Groups  

To delete an injection group, select Case Information > Injection Groups from the main menu to open the Injection 
Group Case Information Display.  Click the right mouse button on this display, and select Delete  from the resulting 
local menu. 

Alternatively, if the Injection Group Dialog is open, you can delete the injection group listed in the Name dropdown box 
by clicking the Delete  button. 
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Injection Group Display 

The Injection Group Records Display presents data describing each injection group in the case. It is a class of Case 
Information Display and therefore can be used in a manner consistent with all other case information displays.   It has 
a local menu from which you can print, copy, and modify its records as well as view the Injection Group Dialog. You 
can also sort the injection group records by clicking on the heading of the field by which you want to sort.  

To show the Injection Group Records Display, select Case Information > Injection Groups  

 

By default, the Injection Group Records display contains the following fields: 

Name 

The name of the injection group.  To change the name of an injection group, simply type a new name in the 
corresponding cell. 

Number of Gens  

Identifies the number of generators contained in the injection group. 

% Gen PF 

Indicates the degree to which generators will contribute to the output of the injection group relative to loads.  An 
injection group that has a % Gen PF value of 100.0% receives all of its output from generator points; an injection 
group that has a % Gen PF of 50% and a % Load PF of 50% receives equal contributions from its constituent loads 
and generators. 

Number of Loads  

Identifies the number of loads contained in the injection group. 

% Load PF 

Indicates the degree to which loads will contribute to the output of the injection group relative to generators.  An 
injection group that has a % Load PF value of 100.0% receives all of its output from load points; an injection group 
that has a % Load PF of 50% and a % Gen PF of 50% receives equal contributions from its constituent loads and 
generators. 
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Injection Group Dialog 

The Injection Group Dialog provides information about injection groups and allows you to modify them.  Specifically, 
the Injection Group Dialog lists the number of generators and loads contained in the group and the percentage 
contribution of generators and loads to the injection group’s output.  The Injection Group Dialog also houses the 
Participation Points Records display, from which you can add and delete points from the injection group’s list of 
participants and change various attributes of the points. 

To view the Injection Group Dialog for a particular injection group, open the Injection Group Records display by 
selecting Case Information > Injection Groups from the main menu. Find the injection group in which you are 
interested, and right-click it.  Then select Show Dialog from the resulting local menu. 

 

The Injection Group Dialog contains the following fields and controls: 

Name 

Identifies the injection group whose information is currently displayed.  You can select a different name from this 
dropdown box to display information for another injection group. 

New, Delete  

To insert a new injection group from this dialog, press New , and supply the name you want to give the new injection 
group.  To delete the injection group that is currently being shown, click Delete . 

# Gens  

Displays the number of generators contained in the injection group. 

# Loads  

Displays the number of loads contained in the injection group. 

% Gen Part., % Load Part. 

Displays the relative contributions of generators and loads to the output of the injection group. 

 

Participation Points  

The tab on the right hand side of the Injection Group Dialog lists the points that make up the injection group.  This 
display is called the Participation Point Record Display.  By right-clicking on this display, you can add and delete points 
from the injection group, and you can change the properties of specific points. 
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Injection Group Contributions By Area 

This dialog is only available from the PV Curve tool in Simulator.  Once you have defined the injection groups 
necessary for your source and sink, you can click on the Areas button to display a list of the percent contribution by 
area, according to the participation factors of the generators selected within each area. 

Injection groups may include generator and load points from an arbitrary number of control areas.  By default, the 
contribution of each generator or load point is controlled just by the point’s participation factor.  Sometimes you may 
need more precise control over how much each generator or load contributes to an injection group’s export in order to 
achieve a certain percentage contribution from each area represented in the group.  For example, suppose the 
injection group consists of points (generators and loads) contained in areas A, B, and C.  Using the Injection Group 
Contributions By Area Dialog, you can scale the factors for each of these points such that, for example, 40% of the 
total contribution comes from points in area A, 30% from points in area B, and 30% from points in area C.  Within each 
area, the points contribute in proportion to the original participation factors you defined.  However, the total contribution 
from each area is determined by the percentages you enter on the Injection Group Contributions By Area Dialog. 

 

The dialog houses a table containing the following fields: 

Area Number The number of the area 

Area Name The name of the area 

% Contribution The current percent contribution of the area.  This is calculated as the sum of the 
participation factors of the injection group’s points that belong to the area divided by 
the sum of all the injection group’s points’ participation factors. 

New % Contribution The new percent contribution you want to achieve from the area.  The participation 
factors of the points that belong to the area will be scaled so that the area’s total 
participation becomes this percentage of the injection group’s total participation. 

To set the contribution for a specific area, simply type in a new value for the New % Contribution field for that area.  
This is the only field you can change in the table.  Only areas that are represented in the injection group by load or 
generator points will be listed in the table. 

After you have set the new percent contributions to your liking, click the Change Contributions By Area button.  If 
you changed your mind and do not want to rescale the participation factors, click Cancel. 

Participation Groups  

Participation Points Overview  

A participation point is a member of an injection group.  It is a generator or load that participates in, or contributes to, 
the output of an injection group.  Each participation point record identifies the generator or load that fills this role, its 
participation factor, and how that participation factor is calculated.  A participation point’s participation factor identifies 
the degree to which the point will contribute to its injection group’s output relative to the other points making up the 
group.  Participation factors may be defined as having a fixed value, or they may be re-calculated with every use to 
stay true to how they were originally defined.  For generators, participation factors may be defined as having a fixed 
value or being equal to the generator’s MW reserve in the direction of increasing output (MAX GEN INC), MW reserve 
in the direction of decreasing output (MAX GEN DEC), or their maximum output (MAX GEN MW). 

Participation points are added to or deleted from an injection group using the Injection Group Dialog.  The Injection 
Group Dialog houses the Participation Point Records display, which allows you to add or delete points or to find out 
more information about them using the Participation Point Dialog. 
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Participation Point Records Display 

The Participation Point Records display shows information about the points that comprise a particular injection group.  
You can access this display f or a particular injection group only from the Injection Group Dialog. 

The Participation Point Records display is a class of Case Information Display and therefore can be used in a manner 
consistent with all other case information displays.   It has a local menu from which you can print, copy, and modify its 
records as well as view the Generator Dialog or Load Dialog for a particular point.  It also allows you to add 
participation points to the group through the Add Participation Points Dialog, and to delete participation points. You 
can also sort the participation point records by clicking on the heading of the field by which you want to sort.  

 

The Participation Point Records display  shows the following fields by default: 

Point Type  

Every participation point is either a generator (GEN) or load (LOAD). 

Number 

Identifies the number of the bus to which the generator or load is connected. 

Name 

Identifies the name of the base to which the generator or load is connected. 

ID 

Identifies the ID of the generator or load. 

AutoCalc? 

If the value of AutoCalc is YES, the participation factor of the point is re-calculated with every use to be consistent 
with the way the point’s participation factor w as initially defined.  If the value of AutoCalc is NO, the participation 
factor is assumed fixed at its present value. 

Initial Value  

Indicates how the participation factor of the point was originally computed.  For generators, the possible values of 
this f ield are  

SPECIFIED   The participation factor was specified as a constant. 

MAX GEN INC  The participation factor was defined as the difference between the generator’s 
maximum MW output and its present MW output. 

MAX GEN DEC  The participation factor was defined as the difference between the generator’s 
present MW output and its minimum MW output. 

MAX GEN MW  The participation factor was defined as the maximum MW output of the 
generator. 

For loads, the Initial Value property can assume only two possible values: 

SPECIFIED  The participation factor was specified as a constant. 

LOAD MW  The participation factor was defined as the size of the load in MW. 

The Initial Value field is important if you intend to save the injection groups to an auxiliary file and use them with 
another case that might have a different generation dispatch or load profile.  If you specify the Initial Value for a 
point as GEN MAX INC, for example, and load the point from an auxiliary file into another case, Simulator will re-
calculate the point’s participation factor to match the generator’s positive MW reserve in that case.   

The Initial Value field is also important if the AutoCalc field is set to YES, because AutoCalc uses the rule defined 
by the Initial Value field to recalculate the participation factor with every use.  For example, if Initial Value is MAX 
GEN INC and AutoCalc is YES, the point’s participation factor will be updated to match the generator’s MW reserve 
every time the point is accessed. 

When you toggle the value of the Initial Value field, the point’s participation factor, shown in field ParFac, will update 
to match the new definition.  The Initial Value field must equal SPECIFIED for you want to change the value of the 
point’s ParFac field by typing the new value directly into the field. 

If AutoCalc is NO and you do not intend to use the injection group with any other case, then you should either 
ignore this field or set its value to SPECIFIED. 

ParFac 

Indicates the participation factor of the participation point.  The participation factor defines the relative contribution of 
the point to the total output of the injection group. The load or generation change for each point is calculated based 
on the value of the participation factor, with values for points having the largest participation factors experiencing 
the greatest change. 

To add points to the injection group, right-click on the Participation Point Records display and select Insert from the 
local menu.  This opens the Add Participation Points Dialog. 
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Add Participation Points Dialog 

The Add Participation Points Dialog enables you to add participation points to an injection group.  You can access this 
dialog from the Participation Point Records display on the Injection Groups dialog by right-clicking in the participation 
points list and selecting Insert or Show Dialog from the resulting local menu. 

The Add Participation Points Dialog features three tabs, one for adding generator points, another for adding load 
points, and a third for adding points from groups that have already been defined.   

 

The three tabs are almost identical and contain the following controls: 

Filtering 

If the Use Area/Zone Filters box is checked, the list box beneath it, which lists generators, loads or previously 
defined groups depending on the tab, will list only those elements contained in areas or zones whose 
area/zone/owner filter setting is YES.  If this box is not checked, all generators or loads in the case will be listed. 

Alternatively, a custom filter can also be defined by clicking on the Define Filter button.  This will open the 
Advanced Filter dialog, which allows you to customize a filter for determining the devices to list in the display. 

Once the list of devices has been set, with or without filtering, you can search through the list using the advanced 
search techniques in Simulator.  These techniques allow you to sort the list by name or by number, and use 
wildcard characters.  Simply choose Name or Number, and type the name or number you are looking for in the box.  
Simulator will look for and highlight the first matching device in the list.  If the first device is not the one you are 
looking for, use Search Next to find the next device that matches the search criteria.  For a comprehensive list of all 
objects matching the search criteria, press Search All. 

Element List 

The box that occupies the left side of each tab lists the generators, loads, or groups (depending on which tab is 
active) that can be added to the injection group.  You can select multiple elements from each of these lists.  To 
select several elements in a row, drag the mouse to highlight the elements you want to add.  Alternatively, click the 
first element you want to add, press and hold the shift key, and click the last element you want to add.  To select 
elements that are not adjacent in the list, click the first element you want to add and hold down the CTRL key while 
clicking the other elements you want to add. 

Once an element is selected in the Element List, it is ready to be added to the injection group. 

Participation Factors 

You have several options for how to define the participation factor of the points you have selected.   

For generators, you can specify a value, use the generator’s present participation factor (which comes from the 
case and is displayed in the Generator Records Display), calculate the participation factor as the difference 
between its present output and either the unit maximum or minimum, or its maximum output capability.  For loads, 
you can specify a value, or you can base the participation factor on the load’s size.  For groups, you can specify a 
value to use for every point in the injection group, or you can use the values already defined for the injection group. 

Recalculate Factors Dynamically 

If this box is chec ked, the participation factors of the points you are adding will be automatically updated every time 
the points are used.  Such points will then have an AutoCalc value of YES.  If this box is not checked, the 
participation factors of the points you are adding will be fixed at the values defined at the time they were created. 

To add the points that you have selected, click the Arrow button.  The new points will be added to the list box on the 
right. 

The list box that occupies the right side of each tab lists the points that already comprise the injection group.  To delete 
specific points from the injection group, select them from this list box and click the Trash button. 

To close this dialog, click OK. 
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Solving and Simulating a Case 

Chapter 10 : Solving and Simulating a Case 

This chapter describes the controls and general tools for solving a load flow in Simulator.  These topics are used to 
customize and control the time domain and single Power Flow Solutions in the Run Mode.  Additional topics also 
describe w ays to view results and data graphically using auto-generated graphical displays. 

The following material is included: 

• PowerWorld Solution/Environment Options 

• Controlling Simulations and Solving the Power Flow  

• Description of Area Control and Transaction Modeling 

• Charts 

• Bus View Display 

• Substation View Display  

Options  

Solution/Environment Options  

Simulator provides a flexible environment for simulating power system operation by offering you access to a number of 
customizable options.  The PowerWorld Simulator Options Dialog houses six pages of options that you can 
customize to tailor the simulation to your needs.  To display this dialog, select Options/Tools > 
Solution/Environment from the main menu. If a timed simulation is active when you open the dialog, it is 
automatically paused and will not resume until you close the dialog. 

There are six tabs of options for the Solution/Environment Options dialog: 

Power Flow Solution Options  

Environment Options  

Oneline Options  

Case Information Display Options  

Template Options  

Simulation Options  

Limits Options  
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Power Flow Solution Options  

The Power Flow Solution Tab offers various options regarding how Simulator solves the power flow problem.  There 
are five sub-categories on the Power Flow Solutions tab: Solution Options, Island-Based AGC, DC Options,  General, 
and Storage.   Each of these categories is shown on tabs at the bottom of the page.  Many of the options in the Power 
Flow Solution options will be of interest only to advanced users of the package. 
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Power Flow Solution: Solution Options  

MVA Convergence Tolerance  

The MVA conv ergence tolerance serves as a yardstick for determining when the Power Flow Solution process has 
reached an acceptable solution.  The MVA mismatch is computed as the maximum real or reactive mismatch at any 
bus in the system.  Usually, this value should be around 0.1 MVA.  If you are having difficulty solving a particular 
case, it may be helpful to temporarily increase the MVA Convergence Tolerance to drive the solution closer to the 
actual solution, and then re-solve from this solution using the smaller MV A tolerance.   

Maximum Number of Iterations  

This option defines the maximum number of iterations Simulator will perform during the Power Flow Solution 
process in an effort to converge to a solution. If Simulator must exceed this number of iterations, it assumes that the 
power flow case is not converging and will terminate the solution process.  If Simulator is configured to represent 
non-converging power flow cases as blackouts, the screen will turn gray and the blackout warning message will 
appear. 

Do Only One Iteration 

If checked, then Simulator will only perform one iteration of the load flow solution process when Single Solution is 
clicked, regardless of the Maximum Number of Iterations setting. 

Initialize From Flat Start Values 

When checked, each Power Flow Solution is started assuming that all voltage magnitudes and generator set point 
voltages are unity and all angles are zero.  By default, this option is not selected.  Some power flow problems can 
be very difficult to solve from flat start assumptions.  Therefore, use this option sparingly. 

Disable Power Flow Optimal Multiplier 

If checked, the Newton solution process will ignore the optimal multiplier.  The optimal multiplier is a mathematically 
calculated value that indicates the ability of the iterative solution process to continue towards a valid solution.  If the 
optimal multiplier becomes too small, it signifies that the solution process has hit a point where it is changing by 
extremely small amounts during each iteration.  If this happens at a point where the solution is not within the 
allowed tolerance for the Newton process, the Newton process will result in a failed convergence to a valid solution. 

Enforce Generator MW Limits  

If checked, then generator minimum and maximum MW limits are enforced for all generators whose Enforce MW 
Limits  field is set to true.  See Generator Information Dialog for more information.  Otherwise, generator MW limits 
are not enforced. 

Disable Automatic Generation Control (AGC) 

If checked, the enforcement of the Generation Re-dispatch to account for MW interchange constraints for all areas 
is disabled.  By default, this option is not checked. 

Include Loss Penalty Factors in ED 

If checked, the economic dispatch calculation will consider losses in determining the most economic generation 
dispatch.  Otherwise, the generation dispatch calculation will disregard system losses. 

Enforce Convex Cost Curves in ED 

The economic dispatch algorithm attempts to set the output of all generators that are set to be automatically 
controlled so that the system’s load, losses, and interchange are met as economically as possible.  The algorithm is 
guaranteed to reach a unique solution only when all generator cost curves , which model the variation of the cost of 
operating a unit with its output, are convex.  If this option is checked, Simulator will identify units whose operating 
point is outside the convex portion of the cost curve and set them off automatic control. 

Post Power Flow Solution Actions  

Clicking this option will open the Post Power Flow Solution Actions dialog, where the user can specify a list of 
actions to be executed at the end of every Full AC power flow solution. 

Disable Checking Gen VAR Limits  

If checked, the Mvar limits are ignored for all the generators in the case during a Power Flow Solution.  By default, 
this option is not selected. 

Check Immediately 

If checked, violations of the Mvar limits for each generator are checked before the Power Flow Solution is started.  
Normally, the Power Flow Solution is started without checking the Mvar limits until after a solution has been 
reached.  If any of the Mvar limits are violated after the solution is reached, the violations are corrected, and the 
power flow is solved again.  With this option checked, the violations are checked before the first time the power flow 
is run.  By default, this option is not selected. 

Disable Switched Shunt Control 

If checked, automatic control of switched shunts is disabled in all areas.  By default, this option is not selected. 

Disable LTC Transformer Control 
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If checked, automatic control of LTC transformers is disabled in all areas. By default, this option is not checked. 

Minimum Sensitivity for LTC Control 

This option specifies the minimum-voltage-to-tap sensitivity for LTC transformers.  All transformers having an 
absolute value of voltage-to-tap sensitivity below this value are automatically disabled from automatic control.  This 
prevents Simulator from changing transformer taps that have little effect on their controlling voltage.  The 
Transformer AVR Dialog shows the voltage-to-tap sensitivity for each voltage-controlling transformer. 

Disable Balancing of Parallel LTC Taps 

Simulator has the capability to attempt to balance tap positions of parallel transformers, in an attempt to avoid 
parallel transformers from going to opposite tap settings, inducing loop flow through the parallel transformers.  
Checking this option disables the automatic balancing of parallel transformers.  The only transformers that will be 
balanced are those in parallel between the same terminal buses, or those in parallel between terminal buses that 
are connected with zero impedance branches. 

Disable Phase Shifter Transformer Control 

If checked, then automatic control of phase shifting transformers is disabled in all areas.  By default, this option is 
not checked. 

Model Phase Shifters as Discrete Controls  

If checked, then phase shifters will switch tap positions discretely based on the tap step size of the phase shifting 
transformer.  By default, this option is not checked, which means the phase shifters will switch continuously, 
independent of the tap step size. 

Prevent Controller Oscillations  

Sometimes, a power flow  will fail to converge because certain automatic controls such as Mvar limit enforcement at 
generators, transformer tap switching, and shunt switching oscillate between their control bounds.  These 
oscillations very often are due to modeling inaccuracies.  If this option is checked, Simulator will automatically 
detect such oscillating controls and fix them at their current value so that they no longer oscillate.  You may find this 
option helpful if you feel that the modeling of automatic controls in your system is inaccurate. 

Maximum Number Controller Loop Iterations  

As part of the solution process, the outer loop of the solution algorithm is a check of any necessary controller 
changes due to changes in controlled values from the last iteration of the Newton-Raphson load flow solution.  The 
maximum number of loops through the control change algorithm can be set here.  This is not the same as the 
Maximum Number of Iterations, which applies to the actual Newton-Raphson inner loop algorithm, which solves that 
actual power flow. 
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Post Power Flow Solution Actions Dialog 

The Post Power Flow Solution Actions dialog describes a list of actions that are executed at the end of every Full AC 
power flow solution, which means they are not performed for DC solutions.  Normally, these actions would all have 
Model criteria specified. 

Check the Do Not Used Post Power Flow Solution Action List check-box to avoid using these actions. 

The action list display identifies the actions that comprise the post power flow solution action list.  To add actions to the 
list, right-click on the display and choose Insert.  This will bring up the Contingency Element Dialog where you can 
define the action.  To delete an action, right-click on the display and choose Delete . 

The action display is a type of Case Information Display and thus shares many characteristics and controls common to 
all other case information displays.   

 

The Action List Display always contains the following fields: 

Actions  

This shows a string which describes the action.  You may customize the format of the string that describes the 
actions by right-clicking on the Action List Display and choosing Display Descriptions By, and then choosing 
either Name, Num, Name/Num, PW File Format by Numbers, PW File Format by Name/kV or PTI File Format. 

Model Criteria 

Simulator allows you to define Model Criteria, which consist of both Model Conditions and Model Filters.  These 
specify a criteria under which a contingency action would occur.  For example, you could specify that a generation 
outage only occur if the pre-contingency flow on a line is higher than a specified amount.  Normally, no Model 
Criteria will be specified, and this field will be blank.  Also, note that Model Criteria can be overridden by the Model 
Condition and Filter option on the Contingency Options Tab.  You can open a dialog to define Model Filters or 
Conditions by right-clicking on the Action List Display and choosing Define Model Criteria. 

Status  

Three options are available for this field 

• CHECK : The action will be executed only if the Model Criteria is true.  It will also be executed if no model 
criteria is specified.  This is the default setting 

• ALWAYS: The action will always be executed, regardless of the Model Criteria. 

• NEVER: The action will never by executed, regardless of the Model Criteria. 

• POSTCHECK: This action is checked AFTER the other Check and Always actions have been performed 
and the load flow solution solved.  If the criteria specified for the Postcheck action are met in the resulting 
load flow solution, then this action is taken and the load flow is again resolved.  This will recursively occur 
for all Postcheck actions until either all postcheck actions have been taken, or the criteria for all remaining 
postcheck actions have not been met. 

Note that the Never action allows you to disable a particular action without deleting it. 

Comment 

A user-specified comment string that can be associated with this action.  While this comment is not used by 
Simulator in any way, these comments can be saved to be loaded at a later time.  This is provided for the user to 
add comments regarding the action.  For example, for an action with a Model Criteria you may could add a 
sentence explaining why the action is only performed under the specified criteria. 
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Power Flow Solution: Island-Based AGC 

The Island Based AGC options allow the user to choose to dispatch generation by island instead of by area or super 
area.  The options available for dispatch here are: 

 

Disable (Use the Area and Super Area Dispatch Settings) 

When this option is selected, Island Based AGC is being used, and generators are dispatched according to the 
usual area or super area generation dispatch. 

Use Participation Factors of individual generators 

When selected, the island-based AGC is used, based on the individual participation factors of each generator within 
the island.  Area and super area ACE requirements will be ignored, and all generators in the island will be 
dispatched to serve load, losses, and any DC transfers to other islands. 

Calculate Participation Factors from Area Make Up Power Values 

The AGC will dispatch generation by area participation factor, instead of by individual participation factor.  What this 
means is that each area will be assigned a participation factor, similar to assigning a participation factor to a 
generator.  Based on the participation factor each area in the island, the amount of the generation dispatch needed 
will be divided amongst each area based on its factor.  Higher factors will account for more of the generation 
dispatch than areas with smaller factors.  The within each area, the generation dispatch is handled on an individual 
generator participation factor basis, where each generator will account for a portion of the dispatch that was 
assigned to its area. 

For example, three areas have participation factors of 2, 1 and 1, respectively.  If the total generation redispatch in 
the island is 100 MW, then area 1 will account for 2 / (2+1+1), or 50%, of the total.  Therefore area 1 is expected to 
redispatch by 50 MW.  If area 1 then has tw o generators with participation factors of 4 and 1, they will account for 
the 50 MW by picking up 4 / (4+1) and 1 / (4+1), or 80% and 20%, respectively, of the 50 MW needed from the 
area. 

Dispatch using an Injection Group (Loads and Generators will respond) 

Checking this option will allow for the island dispatch to be covered by change in generation and/or load defined in 
an injection group. 

Additional options are available when dispatching based on an injection group: 

Allow only AGC Units to Vary 

If this option is checked, only units whose AGC status is turned on will be allowed to participate in the injection 
group dispatch. 

Enforce unit MW limits  

If checked, then each generator’s defined MW limits will be strictly adhered to during the redispatch. 

Do not allow negative loads  

When checked, loads included in the injection group are not allowed to drop below zero MW or MVAR load 
demand. 

How should reactive power load change as real power load is ramped? 

You can choose to keep the ratio of real and reactive power constant for each load that is included in the 
injection group, or you can specify a constant power factor that the MVAR value will be determined from when 
the MW value is changed. 
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Power Flow Solution: DC Options  

Use DC Approximation 

When this box is checked, Simulator will solve the load flow using the DC Approximation method.  When not 
checked, Simulator performs the modified Full Newton AC load flow algorithm.  Note that once a case, especially a 
large one, has been solved using a DC approximation, it tends to be quite difficult to revert back to the Full Newton 
AC load flow from a solved DC approximation. 

Compensate for Losses by Adjusting the Load 

Traditionally a DC load flow is treated as lossless.  However, you can approximate the loss in the load flow by 
artificially adjusting the load in the case to include estimated losses.  To do so, click on the DC Loss Setup button 
to open the DC Power Flow Loss Setup dialog for setting the DC Loss Multipliers. 

Compensate for Reactive Power Flows by Adjusting the Branch Limits … 

One issue with DC load flow is how to treat the inclusion of reactive power flows.  In a standard DC load flow, the 
reactive flows are typically ignored, and the MW flow of a branch is compared to its original MVA branch limit.  
However, Simulator also gives you the option to instead solve the DC load flow and compute approximate MVAR 
flows by assuming the voltages in the system remain constant when the DC load flow is solved. 

Compensate for Dispatch Sensitivities with User-Specified Values 

This option allows for the bus MW loss sensitivities to be used in the OPF and ED dispatch algorithms, if the type of 
loss sensitivity on the General tab is set to User-Specified. 
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DC Power Flow Loss Setup 

The DC Power Flow Loss Setup dialog gives you a location to apply approximate losses during a DC load flow 
solution.  The losses can be approximated by scaling the loads in the case to include an approximation of losses.  
Loss multiplication factors can be applied individually by bus, or as a group by area or by zone.  Note that loss 
multipliers by area or by zone are just quick ways for setting the bus multiplication factors for all buses in the group.  
You will see the value reflected for all buses in the Buses page.  If you wish to apply the same multiplication factor to 
the entire case, you can simply set the Case DC Loss Multiplier at the bottom of the dialog.  This will automatically set 
all buses in the case to have the same DC Loss Multiplier specified. 

Once the DC Loss Multipliers have been set, click OK to save the multipliers.   
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Power Flow Solution: General 

Dynamically add/remove slack buses as topology is changed (Allow Multiple Islands) 

If checked, multiple islands are allowed during the solution by Simulator dynamically choosing a new slack bus for 
the island.  If there are no in-service generators in the new island, the island cannot be solved and will be isolated 
and ignored during the load flow solution. 

Restore Initial State on Restart 

If checked, a paused simulation will revert to initial conditions whenever the user selects Simulation, Play from the 
main menu to start a simulation, or selects Simulation, Reset followed by the Play option to restart a simulation.  
Otherwise, selecting Play with a paused simulation will simply resume the paused simulation. 

Play/Animation Solution Method 

This option is available only for OPF releases of Simulator.  Use it to indicate whether Simulator’s repetitive power 
flow should perform a normal power flow solution or an optimal power flow (OPF) solution. 

Assumed MVA Per-Unit Base 

This option allows the user to specify the MVA base to be used for the entire case.  By default, this value is set to 
100 MVA. 

Bus Loss Sensitivity Function 

Bus loss sensitivities indicate how island or area losses change with power injection at the bus.  Here you may 
choose to forego the calculation of bus loss sensitivities or to base them on island losses or area losses.  If the case 
consists of only one island, which, by definition, corresponds to the entire system, then the bus loss sensitivities are 
measured with respect to total system losses.  If the bus sensitivities are set to User-Specified, the sensitivities will 
remain at their last calculated values, according to the loss function type previously specified when the loss 
sensitivities were calculated. 

Suppress the following messages in the log 

Checking the check-boxes in this option will remove the corresponding message writing to the log, thus speeding up 
the computation process. 

In log Messages, Identify buses by 

This option allows the user to specify how to identify the buses in log messages.  The options are by numbers, by 
names, or by both numbers and names. 

Monitor/Enforce Contingent Interface Elements  

This global location allows you to determine how contingency elements in an interface should be treated in 
Simulator.  You can choose to never include the impact of contingent elements on interface flow, to only include 
contingent element impacts in the standard power flow or optimal power flow routines, or in all solution routines 
including contingency analysis and security constrained OPF. 

It is not uncommon to ignore the impact of contingent elements when using the contingency analysis or security 
constrained OPF tools, as they are already processing lists of contingencies and evaluating flows on interfaces.  
Ignoring contingent elements within interface definitions allows for a determination of the impact of other 
contingencies on the flows of the non-contingent elements forming the interface, without impact from additional 
contingent element considerations. 
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Power Flow Solution: Storage  

Simulator offers the ability to restore either the last power flow solution state or the state of the system immediately 
before the last solution attempt.  If your system has insufficient memory and you are working with large systems, you 
may wish to disable one or both of these options. 

Disable "Restore last solution" 

Restoring the last solution will undo any changes made to the data that were made after the last successful solution 
and return the case to the last valid solution.  For large cases, the amount of memory required to store the last 
solution can be significant.  If this option is checked, Simulator will not store this information in memory, and the last 
solution cannot be restored if a solution fails. 

Disable "Restore state before failed solution attempt" 

Restoring the state before failed solution attempt will undo only the attempted solution, but will retain any changes 
to data that were made before the solution process.  This allows the user to return to the point just before the 
solution in order to add or remove changes in an effort to obtain a valid solution.  For large cases, the amount of 
memory required to store the state before a solution attempt can be significant.  If checked, Simulator will not store 
the state information in memory, and the state before the failed solution cannot be restored. 
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Environment Options  

The Environment Options Tab provides you control over a number of display and simulation options.  The first section 
of the page contains a list of check boxes that you can use to designate the content of the oneline displays.   

 

These options include: 

Show Log 

If checked, the message log is displayed.  The message log shows detailed results of each Power Flow Solution.  
Usually this log is NOT shown.  However, if you are running into problems with a simulation case, it can prove 
useful for debugging the case.   

Auto Load Script File  

If checked, the script file is automatically loaded with the case.  This is not checked by default.  Note:  scripts can be 
loaded manually from an option in the simulation menu. 

Disable Showing Blackouts  

You can dramatize a power flow case’s failure to converge by representing it as a blackout.  The background of the 
oneline diagram will become a dark shade of gray, and a message box will appear to announce that the system has 
experienced a blackout.  To disable this behavior, select the Disable Showing Blackouts box.  Representing the 
failure to converge as a blackout can be very helpful for presentation purposes.  Very often, the power flow’s failure 
to converge can be traced to the system’s inability to serve the load demand, a situation that requires that load be 
"blacked out," or shed, to restore the system to a viable operating state.  Thus, displaying the failure to converge as 
a blackout has physical significance. 

Auto Open Bus Records if No Oneline  

If a case is opened in Simulator which does not have an associated oneline diagram, then Simulator will 
automatically open the Bus Records case information display if this option is checked. 

Disable AGC When Manually Changing Generator MW 

When this option is checked, changing the MW output of a generator manually will automatically remove a 
generator from Automatic Generation Control.  If you wish for generators to maintain their automatic generation 
control settings following a manual change of MW output, you must uncheck this option. 

Automatic Archiving of PWB Files 

This option allows you to effectively make backup copies of your working case every time you save the pwb file.  
For example, assume you have a case named Test Case.pwb.  With the Automatic Archiving turned on, saving the 
case will first create a copy of the original file and rename it Test Case_1.pwb.  The character used as a delimiter 
can be chosen optionally.  The case with any changes you have just made will then be saved as the new Test 
Case.pwb file.  Each time you save the case, the latest version is named Test Case.pwb, the last Test Case.pwb is 
renamed with the delimiter and 1 appended, and all other archived versions will be renamed with their number 
incremented by 1.  The number of archive versions to maintain can also be chosen by setting the maximum number 
of archive files property. 

Automatically Load Contingencies when Case is Opened 

If checked, Simulator will open the file specified in the Contingency File field when the case is opened and load the 
contingencies from the file into memory. 

Power Units for Display 

Allows switching between displaying power values in Mega- units or Kilo- units. 

Clock Style  

The clock serves as a timer for timed simulations by showing the current time, the start time, and the end time of the 
simulation.  You can choose to hide the simulation clock by specifying a clock style of None.  Otherwise, to display 
the clock in its own window, choose Dialog, and to display the clock on the program’s status bar, select Status Bar. 

Measurement System 

This option allows the user to choose English (Imperial) or Metric (SI) units for system measurements.  By default, 
this option is set to English units. 

Recently Used File List Entries 

The maximum number of file names and locations stored in the History List of the File menu. 
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Oneline Options  

These options are available on the Oneline tab of the PowerWorld Simulator Options dialog. 

 

Show Oneline Hints  

If checked, pop-up hints will appear when you drag the mouse over an object in the oneline.  These give information 
about the object; for example, for a generator the pop-up hint displays the bus number, generator ID, the MW output 
and the MVAR output. 

Show X,Y Coordinates 

If checked, the (x,y) location of the cursor is monitored in the status bar at the bottom of the screen.  The (x,y) 
location of the cursor is only shown in Edit Mode.  By default, this option is selected. 

Save Contour Image with Oneline File  

If checked, and if a contour is being displayed on the oneline diagram, Simulator will store the contour with the 
oneline diagram when you save the case or save the oneline. 

Display Only 

If checked, Simulator only displays the case; it does not solve the power flow equations.  System flows are 
determined by the initial values in the case file.  This option should be checked if you simply want to use Simulator 
to visualize a case that has already been solved.  The advantage of the display-only mode is that animation is 
significantly faster, particularly for large cases.  The drawback to the display-only mode is that the power flow 
equations are not automatically solved at each time step; you must explicitly call for a Power Flow Solution using 
either the Single Solution button of the Program Toolbar or one of the two Power Flow Solution options available 
from the Simulation menu on the main menu. 

Minimum Screen Font Size 

The minimum font size at which text is visible on the screen.  This is useful when zooming out on a oneline diagram 
where a lot of text might become cluttered or hard to read on the screen. 

Minimum Print/Copy Font Size 

The minimum font size at which text can be printed or copied.  This is useful if the application or printer you are 
sending to can or cannot display smaller fonts. 

Visualizing out-of-service elements  

These three options allow you to choose how objects on the diagram should appear when they are representing a 
power system device that is currently "open" or "out-of-service."  The three options are Blink, Use dashed lines, and 
Draw and X through off-line generators.  The first two options apply to any oneline object, while the third option is 
specific to generator objects only. 

Transformer Symbol 

Since transformer representation varies in different countries, this option allows the user to represent transformers 
as coils or circles.  By default, transformers are represented as coils. 

Main Oneline File 

This option is used to identify the primary oneline diagram to use with the case.  The main oneline is the file that is 
displayed when you first open the case.  The dropdown box lists all the oneline files that reside in the same 
directory as the case.  Select one of these files, or enter the full path of the oneline you want to use if it does not 
appear in the dropdown box. 

Use Default Oneline File  

You can command Simulator to open a particular oneline diagram file if it cannot find a oneline diagram file for the 
case you are trying to open.  For example, there is no oneline diagram associated with a PSS/E raw data file when 
you first read it into Simulator.  However, if your application is such that you will always use the same oneline file 
whenever you open a PSS/E raw file, check the Use Default Oneline File  to have Simulator open the oneline 
identified in the Default Oneline File  box whenever it encounters a case that has no associated oneline.  The 
default oneline must exist in the same directory as the case you are trying to open. 

Save Onelines when Saving Case 

By default, Simulator always saves any oneline diagrams that are open when the user chooses to save the case 
(pwb) file.  This option allows you to choose to be prompted to s ave oneline diagrams when a case file is saved, or 
to never save onelines when the case file is saved. 

Oneline Browsing Path 

This option applies when you have Oneline Links included on a oneline diagram.  Rather than specify the full path 
and name of a oneline diagram as a oneline link, you can specify the file name only.  When the link is clicked in Run 
Mode, Simulator will check all directories listed here, in order, to try and find the oneline file name stored with the 
link. 
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Case Information Display Options  

PowerWorld uses numerous case information displays to show power system data in tabular format.  The options 
presented on this page of the PowerWorld Simulator Options Dialog control some of the general features of the case 
information displays. 

Enterable Field Color 

Fields whose values can be directly entered on the case information displays are colored navy blue by default.  
Click on the color field to change the color of enterable fields, or click the Change button. 

Toggleable Field Color 

Fields whose values can be toggled (changed) by left-clicking on them are colored green by default.  Click on the 
color field to change the color of toggleable fields, or click the Change button. 

At or Exceeding Limit Color 

Fields whose values are at or exceeding a limit, are colored red by def ault.  Click on the color field to change the 
color of such fields, or click the Change button. 

Normal Field 

Fields that cannot be modified directly from the case information display are colored black by default.  Click on the 
color field to change the color of such fields, or click the Change button. 

Field not presently used 

Fields whose values are overridden by other instances of the program are colored gray by default.  Click on the 
color field to change the color of such fields, or click the Change button. 

Background 

Background of cells is colored white by default.  Click on the color field to change the color of the background, or 
click the Change button. 

Heading Background 

Background of column and row headings is colored light gray by default. Click on the color field to change the color 
of the heading background, or click the Change button. 

Data Fill Background Color 

Background of selected cells when propagating values is colored yellow by default. Click on the color field to 
change the color of the heading background, or click the Change button. 

Set Case Info Factory Default Colors 

Clicking the Dark Colors button will reset the field and background colors to the defaults mentioned above, which 
comprise dark colors for fields, and light colors for backgrounds. Clicking the Light Colors button will set field and 
background colors to a specified set of light colors for fields and dark colors for backgrounds. 

Save as Auxiliary File Data Format 

This option allows the user to decide if the auxiliary files that can be saved from case information displays should be 
space delimited files or comma delimited files. 

View/Modify Default Font 

Clicking this button brings up a font dialog from which you can choose the font in which case information displays 
should show their data.  Selecting a new font, font size, style, or color and pressing OK will change the default font, 
so that all case information displays will then employ a font having the selected properties. 

Default Row Height 

This option sets the height of the rows in the case information displays.  This field may need to be changed 
depending on the screen size and font size of the computer.  By default, the height is set to 20. 

Column Headings  

This option allows you to choose whether the column headings of the case information displays are the normal 
column headings, or are the variable names of the type of data stored in each column. 

Highlight Key and Required Field Column Headings 

If this option is checked, the key fields needed for identifying objects will be highlighted in the case information 
display.  These fields are important if you are planning on pasting data back into Simulator from Excel, or reading 
data in from an auxiliary file.  If the necessary key fields are not present in the Excel paste of auxiliary file, the data 
in those formats cannot be processed by Simulator. 

Similarly, the Required Field Column Headings can also be highlighted in the case information display.  In order for 
Simulator to create new objects by reading them from an auxiliary f ile or and Excel paste, the required fields must 
be present in the pasted data or the object cannot be created. 

Copy/Send Options  
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Typically when you copy information to the clipboard or send data to excel from a case information display, the first 
two rows of the copied information contain the type of object the data represents (object name) and the column 
headings for each column of data.  These rows are necessary if you intend to paste the information back into 
Simulator, but are unnecessary if you are only exporting data to another program with no intention of pasting the 
information back into Simulator.  Thus these two options allow you to choose which of the two rows, if either, you 
wish to have copied along with the actual data from a case information display when pasting in another application. 

Disable Auto Refresh 

This option prevents Simulator from automatically updating the contents of open case information displays with 
each solution.  If this option is not checked, the data in all open case information displays will be updated 
automatically to reflect the system state calculated from each Power Flow Solution. 

Set Factory Defaults  

Clicking on this button will reset the options to their defaults. 
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Template Options  

Simulator offers the ability to apply case templates  to open power flow cases.  Templates are binary files that store 
such things as schedules, case information display customizations, and settings for many of the options described in 
this section.  For more information on how to work with templates, please see Using Case and Oneline Templates. 

Save in Template File 

The type of information to store in the case template.  Your choices include schedules, case information 
customizations, and case options, as configured from this PowerWorld Simulator Options Dialog.  In addition, a 
default auxiliary data file can be saved with the case template, allowing the default auxiliary file to be automatically 
applied to a case whenever the template is applied. 

Use Default Case Template  

By checking this option, you can also have Simulator load in a default set of options, regardless of the case you are 
working with.  If this option is checked, whenever Simulator tries to open a new case, it will apply the options stored 
in the default template file you identify.  The template file must exist in the directory of the case you are attempting 
to open. 
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Simulation Options  

The Simulation Tab controls such things as the timing of the simulation and the structure of energy transactions.   

 

The Simulation Tab offers the following options: 

Simulation Never Ends  

If checked, this option forces the continual simulation of the load flow when using the Play functionality, ignoring the 
Simulation Start and Simulation End Time settings. 

Simulation Start and Simulation End Times 

The start and end times of the simulation have both time and day attributes, since Simulator can model a system 
over multiple days.  All time specifications must have the form hh:mm.  Weeks are assumed to begin on Mondays. 

Current Time 

This indicates the current time of the simulation.  Adjust this value to rewind or fast-forward the simulation to a 
particular point in time. 

Simulation Speed-Up 

The Simulation Speed-Up controls how fast the simulation runs relative to actual time.  For example, entering 60 in 
this field causes the simulation to run at 60 times actual time so that one minute of simulation time occurs in one 
second of actual time.  This field is visible only if the Fixed Time Step box is unchecked. 

Fixed Time Step 

By using this option you can specify the rate of the simulation in terms of the number of seconds to advance with 
each Power Flow Solution.  If this box is checked, the Simulation Speed-Up field is relabeled the Fixed Time Step 
(seconds) field. 

Fixed Time Step (seconds) 

The Fixed Time Step (seconds) field is used to specify the number of seconds the simulation should advance with 
each Power Flow Solution.  For example, specifying a fixed time step of 60 seconds means that the simulation time 
will advance 1 minute each time the power flow is solved.  This field is visible only when the Fixed Time Step box is 
checked. 

Default Area Number 

This option specifies the default area number used with the strip-chart displays.   

MW Blocks for Transactions  

This option indicates the default size of new MW transactions.  When you try to insert new MW transactions using 
the MW Transactions Display and MW Transactions Dialog, the initial transaction amount will default to this value. 

Transaction Ramp Time (seconds) 

This option sets the default ramp rate for inter-area transactions.  This value specifies the amount of time in 
seconds over which a transaction will ramp from zero to the level indicated by the MW Blocks for Transactions  
field.  When you try to insert new MW transactions using the MW Transactions Display and MW Transactions Dialog
, the initial value of the Ramping parameter will default to this value. 

Scheduled System Frequency 

This option specifies the system frequency. 

Cost of Unserved Energy 

This field is used to assign a penalty cost to areas that fail to fulfill their side of energy transactions.  This cost will 
be included in computing the total cost of operating the offending area. 

Case Load Multiplier 

This field is used to specify a scalar by which to multiply the value of all real and reactive loads throughout the 
system.  See Load Modeling for further details. 

Transformer Tap Delay 

Typically, a time delay is built into the switching of transformer taps.  You can model this delay during timed 
simulations in Simulator by specifying a nonzero value for the Transformer Tap Delay in seconds.  If this value is 
nonzero, Simulator will wait until the specified delay time has elapsed before switching the transformer taps as long 
as the Use Transformer Tap Delay box is checked. 

Unexpected Events 

This field allows you control the frequency with which "unexpected events," such as lightning hitting a transmission 
line, can occur during a simulation.  When such an event occurs, the line’s circuit breakers immediately open to 
protect the line from further damage.  For some events (such as a lightning strike), you can immediately re-close the 
line (i.e., you can use the oneline to close the circuit breakers).  However, for other events, like tornadoes, the line 
will stay open for the remainder of the simulation (since it can take months to rebuild a line).  These events occur at 
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random times.  Whenever an unexpected event occurs, you will be shown a message box, which you must 
acknowledge to proceed.  

Auto Start 

If the Auto Start box is checked, a timed simulation for the case will be launched as soon as the case is loaded into 
memory.  

Auto Solve on Load 

If this option is checked, the case is automatically solved when it is loaded, provided Simulator is in Run Mode ; 
otherwise, the case is not solved until the user starts the simulation. 

Use Transformer Tap Delays  

This box must be checked in order for the tap delay setting in the Transformer Tap Delay box to take effect. 
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Limits Options  

These options can be found on the PowerWorld Simulator Options dialog, and are used for options specific to limit 
enforcement or identification.  Some of these settings are also available in other locations. 

Enforce Generator MW Limits  

If checked, generator MW limits are enforced. 

Enforce Generator Ramp Limits  

If checked, generator MW ramp limits are enforced. 

Automatically Open Overheated Lines During Simulation 

If checked, overheated lines automatically open during simulation. 

Highlight Analogs of Objects with Limit Violations  

If checked, the text fields for objects on the diagram that correspond to device parameters with range limits that are 
violated will be colored according to the High Limit Color and Low Limit Color fields.  The colors of these two 
fields can be defined by the user. 

Solution and Control 

Simulation Control 

The main function of the PowerWorld Simulator is to simulate the operation of an interconnected power system.  The 
simulation may focus on a single instant of time or may chart the evolution of the system over time using a series of 
system snapshots.  The Simulation Menu and the corresponding Program Toolbar are used to control both types of 
simulation.  For timed simulations, the menu is used to start/continue the simulation, pause the simulation and reset 
the simulation to its starting parameters.  The system clock is usually visible during a timed simulation and shows the 
current simulation time along with the simulation’s start and end time.  The system clock will appear either in its own 
window or as a series of panels in the right corner of the window’s status bar.  The other type of simulation, that of a 
single instant of time, is accomplished by selecting Single Solution from either the main menu or the Program 
Toolbar.  This activity performs a single Power Flow Solution.  See Solving the Power Flow for more information.   

 

The following tasks are available from the Simulation Control menu and the Program Toolbar: 

Starting a Timed Simulation 

To commence a timed simulation, select Simulation > Play from the main menu, or click the play button on the Run 
Mode Toolbar. The simulation clock, visible in either its own window or the status bar, will keep track of the 
simulation time.  Regardless of the speed of your computer, the simulation time will change at a fixed rate that is 
governed by the Simulation Speedup selected in the Simulation Options Dialog. 

You can reset the simulation at any time by choosing the Simulation > Restart command, or by clicking the restart 
button on the Run Mode Toolbar.  

Pausing a Timed Simulation 

Once the simulation has started, you can pause it at any time by selecting Simulation > Pause from the main menu 
or by clicking the pause button on the Run Mode Toolbar.  It is helpful to pause the simulation when you want to 
take a closer look at a particular instant of the simulation. 

Continuing a Timed Simulation 

Once the simulation has been paused, you can continue with the simulation by selecting Simulation > Play from 
the main menu, or by clicking the play button on the Run Mode Toolbar.   

Restoring a Previous Solution or a Previous State  

Sometimes a power flow attempt won't converge to a solution.  When this occurs, the voltages and angles 
calculated by the solution engine will not satisfy the real and reactive power balance constraints at each bus.  Then, 
the state currently stored in memory will not be an actual system operating point.  It is often very difficult to coax the 
system to solve once it has failed to converge. 

To help you recover from a solution attempt that has failed to converge (both timed simulations and single 
solutions), Simulator offers you two options. 

After Simulator solves a system successfully, it will store the voltages and angles it found in memory.  If the 
changes that you then make to the system result in a system that can't be solved, you can select Simulation > 
Restore > Last Successful Solution to reload the results of the last converged solution.  After reloading this 
information, Simulator will re-solve the system and refresh all displays. 

In addition to restoring the last converged solution, Simulator also gives you the ability to restore the state of the 
system as it was just prior to the unsuccessful solution attempt.  This can be thought of as "un-doing" the effect of 
the solution attempt.  Before attempting a solution, Simulator stores the state of the system in memory.  If it solves 
the power flow successful, Simulator will discard this pre-solution state.  However, it the power flow f ails to 
converge, Simulator will keep the state in memory.  To recover it, select Simulation > Restore > State Before Last 
Solution Attempt from the main menu.  Simulator will replace the non-converged post-solution state with the pre-
solution state and refresh the displays.  You can then play with the system to try to make it easier to solve. 
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If you are working with large systems, you should be aware that saving these system states can consume a lot of 
memory.  Therefore, Simulator offers you the option to disable one of both of these features.  To do this, select 
Options/Tools > Solution/Environment... to open the Solution/Environment Dialog, and then go to the Storage 
sub-tab of the Solution tab.  You will see two checkboxes there that can be modified to control whether or not these 
extra system states are saved. 

Performing a Single Solution 

Whenever a timed simulation isn’t currently active, you can instruct Simulator to perform a single power flow 
calculation by selecting one of the solution types from the Simulation menu.  In addition, the single solution 
button solves the power flow using the either the Full Newton AC load flow or the DC Approximation load flow, as 
specified in the Solution / Environment Options.  The simulation time and total system costs do not change as a 
result of the single solution. 

Reset to Flat Start  

Select Simulation > Reset to Flat Start from the main menu to initialize the Power Flow Solution to a "flat start."  A 
flat start sets all the voltage magnitudes and generator setpoint voltages to 1.0 per unit and all the voltage angles to 
zero.  Usually, a flat start should be used only if the power flow is having problems converging.  You can also use 
the flat start option on the Simulation and Environment Options Dialog to initialize every solution from a flat start. 

Robust Solution Process 

The Robust Solution Process provides a method to attempt to reach a solution when the standard load flow 
(Newton-Raphson) solution fails.  The robust process performs a solution in a series of steps. 

First, the robust solution will turn off all controls in the case.  Then the load flow will be solved using a fast 
decoupled power flow.  If the fast decoupled power flow reaches a solution, Simulator then immediately solves the 
load flow using the Newton-Raphson load flow, still keeping the controls turned off.  If the Newton-Raphson solution 
is also successful, Simulator will begin adding controls bac k into the solution process, one type of control at a time.  
Thus the generator MVAR controls are added back in, and the load flow is resolved.  Then the switched shunt 
controls are restored, and the load flow is again resolved.  Simulator will continue in this manner by reintroducing 
next the LTC control, followed by the area interchange control, and lastly the phase shifter control.  Furthermore, 
when reintroducing the phase shifter control, the controls are added one at a time for each phase shifter, with a load 
flow solution occurring after each. 

Primal LP 

Choosing this menu option is the same as choosing the option LP OPF > Primal LP.  Simulator will attempt to solve 
an Optimal Power Flow, provided that all setup requirements for performing an OPF have been completed. 

Open Script File, Clear Script File  

If you wish to apply commands from a script file to Simulator, you can do so by loading a script file using the Open 
Script File option.  To remove a loaded Script file from memory, use the Clear Script File option. 
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Solving the Power Flow  

At its heart, Simulator is a Power Flow Solution engine.  Power flow is a traditional power engineering calculation that 
is performed to determine the flows on all lines and the voltages at all buses in the system given the power injections 
at all buses and the voltage magnitudes at some of them.  When Simulator performs a timed simulation, it actually 
performs a sequence of power flow calculations, each based on data that present a snapshot of system conditions at a 
particular instant. Since it is based on power flow, Simulator models the system as being of constant frequency.  This 
assumption is only an approximation, but frequency deviations are generally very small in everyday operation. 

The power flow problem entails solving a system of nonlinear equations.  Solving a nonlinear system requires the use 
of an iterative algorithm to hone in on the correct solution.  Many nonlinear system solvers have been developed, and 
PowerWorld provides access to the full Newton-Raphson method. 

Usually, the power flow computation converges quickly.  However, it is certainly possible to model conditions for which 
no Power Flow Solution exists, or for which the algorithm cannot converge to the solution within the maximum number 
of iterations specified.  For such situations, the message log will provide a message indicating that the computation 
failed to converge.  Furthermore, unless blackouts are disabled, the screen is grayed, and a message indicating a 
blackout has occurred is shown. 
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Area Control 

One of the most important aspects of interconnected power system operation is the requirement that each operating 
area changes its total generation to match changes in the sum of its load plus losses plus power transactions with 
other areas. Normally, this requirement is met by Automatic Generation Control (AGC).  The purpose of AGC is to 
ensure that the actual MW output of an area is equal to the scheduled MW output of the area.  The AGC system 
accomplishes this by first calculating the Area Control Error (ACE), which is defined as  

 ACE = Pactual - Pscheduled + (a term dependent upon system frequency) 

where Pactual is the actual amount of MW flowing out of an area.  If power is actually flowing into the area, Pactual is 
negative. Pscheduled is the amount of power scheduled to flow out of the area and thus equals the areas total sales 
minus its total purchases, both expressed in MW.  The last term in the ACE depends upon the deviation of the actual 
system frequency from the scheduled system frequency.  When the system frequency is modeled using constant 
frequency, this term is always equal to zero.  Otherwise, the equation assumes uniform, but not constant, frequency 
throughout the system.  In this case, this term, known as the frequency bias, equals   -10 B ∆f, where B is an area 
specif ic bias factor with units of MW/0.1 Hz (always negative), and ∆f is the deviation of the frequency from the 
nominal frequency (usually either 50 Hz or 60 Hz).  Simulator currently always assumes a constant frequency. 

In Simulator, Pscheduled  has two components, Scheduled Transactions and Base Transactions.  The two types are 
provided in order to simplify transaction modeling in some studies.  Scheduled Transactions have a specified starting 
time, ending time, MW amount, and price.  However, in many power flow studies in which one is concerned only with 
the static flow of power in the transmission network and not specifically with cost information, it is much easier just to 
model the net flow of power from one area to another (or even to an unspecified area).  For these situations, there is 
no need to specify price or start and end times.  Simulator refers to these as Base Transactions.  Both Base and 
Scheduled Transactions can be defined on the Area Information Dialog. 

Whenever the ACE is greater than zero, it means that the area is over generating and thus needs either to decrease 
generation or to sell more.  Likewise, whenever the ACE is less than zero, the area is under generating and thus 
needs either to increase generation or to buy more.  AGC works to keep the ACE close to zero.   

 

In Simulator, there are five options for implementing AGC:   

No area control 

The output of the generators does not change automatically.  You must manually change the generation to match 
system load/losses/transaction variation.   

Participation Factor Control 

The output of all AGC generators in the area change automatically to drive the area control error (ACE) to zero.  
Each generator’s output is changed in proportion to its participation factor. Checking this option enables the Set 
Factors button, which, when pressed, opens the Generator Participation Factors Dialog.  Participation Factor 
Control only adjusts generation when a disturbance to the system has been put in place, such as changing the 
amount of load in the case, or defining new area to area transactions. 

Economic Dispatch Control 

The output of all AGC generators in the area changes automatically to drive the area control error (ACE) to zero.  
Each generator’s output is changed so that the system is dispatched economically, based on cost information 
entered for the generators in the case.  Note that cost data is not generally included in standard load flow data.  
Without realistic cost data entered into Simulator, the use of the economic dispatch algorithm may not be very 
useful.  Cost data must be obtained from another source and entered into a case in Simulator, either manually or 
through the use of Simulator Auxiliary Files. 

Optimal Power Flow (OPF) 

The OPF option will only be available if you have the OPF add-on for PowerWorld Simulator.  The OPF control is 
very similar to the Economic Dispatch control in that it attempts to dispatch generation to minimize costs.  The 
additional function of the OPF is to minimize the costs while also obeying line, transformer, and interface limit 
constraints.  This option is also not useful without realistic generator cost information, which usually must be 
obtained from another source and entered into Simulator to augment a load flow case. 

Area Slack Bus Control 

Only the output of the area’s slack bus changes automatically to drive the area control error (ACE) to zero.  This 
type of generation control is usually only good for small disturbances to the injections and/or transactions in a case, 
and can often fail to find a solution when larger disturbances are examined. 

  

In Participation Factor Control, the ACE is allocated to each AGC generator in the area in proportion to that 
generator’s participation factor divided by the total of the participation factors for all AGC generators in the area.  A 
generator’s participation factor cannot be negative.  By default, a generator’s participation factor equals its current MW 
setpoint value, but individual participation factors can be changed. 

With Economic Dispatch (ED) Control, Simulator tries to change the output of the area’s AGC generators economically 
so that the area’s operating cost is minimized.  ED control recognizes that some generators are less expensive than 
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others and tries to use the least expensive generators to the largest extent possible. 

To do economic dispatch, we need to know how much it would cost to generate one more MW at a particular 
generator.  This is known as the incremental or marginal cost.  The incremental cost for each generator is modeled 
using the formula 

 λi  =  ICi (Pgi)  =  ( bi   +  2ci Pgi   + 3di (Pgi) 2 ) * fuelcost       $/MWH 

The plot of ICi(Pgi) as a function of Pgi is know as the incremental-cost curve.  The economic dispatch for a system 
occurs when the incremental costs for all the generators (λi) are equal.  This value is known as the system λ (lambda) 
or system incremental cost.  Its value tells you how much it would cost to generate one more MW for one hour.  The 
system lambda becomes important when trying to determine whether or not an area should buy or sell power.  For 
example, if an area can buy power for cheaper than it can generate it, it might be a good idea for the area to buy 
power. 

The OPF control also relies on the cost curve in order to perform an economically optimal power flow.  However, the 
OPF routine makes use of piecewise linear curves in its solution algorithm.  This does not prevent you from entering 
the cost information as cubic cost models, described by the equation above.  Rather Simulator’s OPF routine allows 
you to specify how to break up the cubic curve and model it as a piecewise linear curve for the OPF algorithm. 

In addition, you can also enter piecewise linear curves directly instead of the cubic cost curve models.  In fact, a 
mixture of piecewise linear and cubic models is acceptable.  For the economic dispatch routine, whichever type of 
model is entered will be used directly for each generator.  For the OPF routine, all piecewise linear curves entered 
directly will be used as is, and any cubic models entered will be converted to piecewise linear curves internally during 
the processing of the OPF algorithm. 
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Set Generator Participation Factors 
Participation factor control is another of Simulator’s mechanisms for distributing an area’s responsibility to serve its 
load, losses, and interchange.  It is particularly well-suited to implementing automatic generation control (AGC) when 
you do not have good economic information for an area’s generators.  With participation factor control, the amount of 
power that each generator contributes to meeting its areas load, loss, and interchange responsibilities is controlled by 
the size of its participation factor.  The unit that has the largest participation factor contributes the most, and the unit 
that has the smallest participation factor contributes the least. 

The Set Generator Participation Factors Dialog gives you a convenient way to define the participation factors for 
multiple generators.  You can set the participation factor according to a number of different formulae and then apply 
this prescription to all generators in a specific area, all generators in a specific zone, all generators in the system, or all 
generators whos e display filters are currently set to true. 

To display the Set Generator Participation Factors Dialog, you first need to open the Area Information Dialog and 
switch to the Options page. The Area Information Dialog has a button labeled Set Participation Factors that is 
enabled only if the Participation Factors is selected under the Area Control Options heading.  Set the area on 
participation factor control by selecting the Participation Factors option, and then press the Set Participation Factors 
option. 

The Set Generator Participation Factors Dialog is divided into two parts.  The first part, which occupies the top half of 
the form, allows you to indicate how the participation factors should be calculated or set for each generator.  Your 
options include: 

 

Max MW Rating of Generator The participation factor for each generator is set to the generator’s 
maximum MW capability. 

Difference Between Max and Current Output The participation factor for each generator is set to the generator’s 
reserve power, so that each generator participates in proportion to 
how much it has left to contribute. 

Constant Value of The participation factor for each generator is set to the same hard-
coded value. 

File The participation factor for each generator is read from a file.  The 
first line of the file should contain the keyword NUMBERS or NAMES 
indicating whether generators are identified by bus number or by bus 
name in the file.  All subsequent lines should be comma-delimited 
and contain three fields: the number or name of the generator’s bus, 
the generator’s id, and the generator’s participation factor. 

 

If you choose any of the first three options, you then must tell Simulator to what generators you want to assign the 
participation factors.  To assign the participation factors to all generators in a specific area, select the All Generators 
in Area option, and then choose the area from the adjacent dropdown box.  If you want to assign the participation 
factors to all generators in a specific zone, select the All Generators in Zone  option, and then choose the zone from 
the adjacent dropdown box.  If you want to assign the participation factor to all generators in the system regardless of 
their area or zone affiliation, select the All Generators in System option.  Finally, if you want to assign the 
participation factor to just those generators whose display filter criteria evaluates to true, choose the All Generators 
With Valid Display Filters option. 

If you instead chose to read participation factors from a file, only those generators w hose factors you read from the file 
will have their factors set by this action.  However, unless each generator’s associated area is set to control generator 
output using participation factor control, this information will be ignored.  To make sure that each generator’s area is 
set to participation factor control, check the Set Corresponding Areas to Participation Factor Control box.  Then, 
each corresponding area will be set to participation factor control. 

Transactions  

Area Transaction Modeling 

One of the primary benefits of interconnected power system operation is the ability to do power transactions between 
areas.  In its simplest form, a power transaction entails one area selling a specific amount of power for a time period 
(often specific, sometimes not) at a specific price to another area.   

Simulator offers two complimentary mechanisms for specifying area interchange:  Base Area Interchange and 
Scheduled Area Interchange.  These mechanisms may be used simultaneously, provided you understand that the use 
of base transactions in economic studies can skew results c onsiderably.  This discussion should clarify the issues 
involved in using the two types of transactions. 

 

Base Area Interchange  

The base interchange for an area is the amount of power (in MW) scheduled to be exported from the area to either 
another area or to an unspecified buyer(s).  However, since base interchange is intended only for use in standalone 
power flow studies, no start/end times and no price are associated with the transaction.  Since no price is specified, 
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from an economic modeling point of view the area is essentially giving the power away for free.  This can, of course, 
have a major impact on area economics.  Additionally, base interchange has no starting or stopping time; it is 
always assumed to be active.   

However, the use of base interchange is convenient when you are simply doing power flow studies/simulations, as 
long as the economic ramifications of the interchange is of no concern.  Base interchange values can be set on the 
Area Dialog.   Please note that when you use base interchange with unspecified buyers, it is your responsibility to 
ensure that the net of all base transactions add to zero.  That is, in order for some areas to export, other areas must 
be importing a corresponding amount.  Base interchange values can also be viewed and modified on the onelines 
using area fields.   

Scheduled Area Interchange  

The scheduled interchange for an area is the amount of  power (in MW) scheduled to be sold from the area to 
specific buying areas for a specific duration and price.  You should use these types of transactions exclusively when 
you are doing economic/pricing studies/simulations.  The only downside to the use of scheduled interchange is that 
you must specifically set up each such transaction.  Please see MW Transactions Display for a description of how 
to do this. 

If the total interchange (base and scheduled) in the case do not sum to 0, Simulator will prompt you with a warning in 
the message log.  This means that Simulator will automatically find the area that contains the system slack bus and 
turn it off of AGC controlAreaControl.  The system slack bus will then account for the difference between the total 
imports and the total exports defined in the case. 
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Area Transaction Options Dialog 

This dialog is outdated in PowerWorld Simulator version 5.0 and later.  See help on the Area Information dialog, 
specifically the Scheduled MW Transactions, for changing, inserting, and deleting scheduled area transactions. 

When viewing an area diagram containing area objects created using PowerWorld Simulator version 4.2 or older, a 
transaction can be defined for an area by left-clicking on the Deal / Wheel field in an area's object to open the Area 
Transaction Options Dialog.  This dialog allows the user to define a particular type of transaction for the selected 
area.  Note that the dialog does not specify where the resulting transaction is from or to.  For either a buying or selling 
action, the user will need to specify the appropriate transaction for each of the involved areas and the amount of real 
power (MW) included in the transaction.  The costs associated with the transaction can be estimated by pressing the 
Estimate Price  button once the MW amount of the transaction has been specified. 
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Transaction Dialog 

The Transaction Dialog can be used to modify or create Base Interchange Transactions between two areas.  This 
dialog can be opened by right-clicking in the Base Interchange table of the Area Information Dialog and choosing 
Show Dialog to see an existing transaction definition, or Insert to add a new transaction. 

The transaction dialog is divided into two pages of controls: 

 

Information 

Exporting Area 

This is the "from" area for the transaction.  For an export from this area, the transaction value will be positive.  For 
an import into the Exporting Area, the transaction value specified would be negative.  Flow out (export) of the 
exporting area is always considered positive. 

Importing Area 

This is the "to" area for the transaction. 

Transaction ID 

New in Simulator version 10 is the ability to have multiple transactions defined between the same two areas.  
Because of this, it is now required that transactions also have a Transaction ID. 

Rename Transaction ID 

If you wish to change the transaction ID for a particular transaction, enter the new value in the Transaction ID field, 
and press this button. 

Switch Directions  

Press this button if you wish to reverse the defined Exporter and Importer for the transaction. 

Transaction MW Amount 

The MW amount of the transaction being defined.  This value should be positive for an export from the Exporting 
area to the Importing area.  The value can also be entered as negative to define a transaction into the Exporting 
area from the Importing area. 

Transaction Minimum MW 

The minimum transaction amount between the two areas.  This field is only enabled if the check box labeled 
Transaction Dispatchable in OPF is checked. 

Transaction Maximum MW 

The maximum transaction amount between the two areas.  This field is only enabled if the check box labeled 
Transaction Dispatchable in OPF is checked. 

Transmission Charge  

The cost to transfer power, in $/MWh.  This adds an economic penalty for making the transfer, making the transfer 
less likely to take place.  Half the charge is assigned to the buyer and half to the seller. 

Transaction Enabled 

Transaction can now be defined and either enabled or disabled.  Any disabled transactions will be ignored in both a 
standard power flow solution and an OPF solution. 

Transaction Dispatchable in OPF 

Checking this box enables the transfer to be dispatched by the OPF algorithm.  Dispatching the transaction makes 
the two areas of the transaction appear to be one area for the purpose of economically dispatching the generation 
in the two areas.  The transaction can have a maximum and minimum transfer amount when dispatchable, and a 
transmission charge associated with the transaction. 

Determine Price in OPF 

Checking this box allows the OPF algorithm to determine the cost associated with the transfer.  The cost is 
determined by the marginal cost of enforcing the power balance constraint for the combined areas.  This is the 
typical way to implement a transfer if both areas are on OPF control.  If only one of the two areas are on OPF 
control, then the area which is off of OPF control needs to specify a price for the transfer.  This is done by explicitly 
defining a piecewise linear cost curve. 

Piecewise Linear Transaction Cost Curve  

These two curves are only enabled if the option Transaction is Dispatchable in OPF is checked and the option 
Determine Price in OPF is unchecked.  These two curves can be defined for the purpose of assigning a price to 
the transfer of power between one area on OPF control and another area which is not on OPF control.  Separate 
curves can be defined for export transactions (from the Exporter to the Importer) and import transactions.  To add 
points to the curves, simply right-click in the grid and choose Insert from the local menu.  Enter the MW value and 
corresponding marginal cost for the inserted breakpoint of the piecewise linear curve you are defining.  To delete a 
point, right-click on that row in the grid and choose Delete from the local menu. 
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Memo 

The Memo page of the Transaction dialog is simply a location to log information about the transaction.  To log 
information about the transaction, simply switch to the Memo page on the dialog, and start typing your information or 
comments about the transaction in the page. 
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Calculate MW-Distance  

Simulator can estimate MW * Distance quantities for the system’s areas and zones that result from a specified 
transaction.   Given a transaction from a specified source to a specified sink, Simulator uses power transfer distribution 
factors (PTDFs) to estimate the change in flow for each line in the system that results from the transaction.  For each 
line, multiplying the line’s change in flow by its length then gives the MW * Distance index for that line.  Simulator then 
sums the MW * Distance indices by area and by zone to obtain the total MW * Distance for each area and zone in 
response to the specified transaction. 

Because the MW * Distance calculations use PTDFs, you must access the MW * Distance functionality from the PTDF 
Dialog.  Once you have calculated PTDFs for a particular transaction by pressing the Calculate PTDFs  button, click 
the Calculate MW * Distance  button to bring up the MW * Distance Calculations Dialog. 

The top portion of the MW * Distance Calculations Dialog is used to set the lengths of the lines in the case.  Although 
line length is represented as a data element in the power flow case, it often is left blank.  However, Simulator needs 
line length information if it is to calculate MW * Distance indices.  Simulator offers a few options regarding the source 
of line length information.  If you do not have access to line lengths, either from the existing case or an external text 
file, Simulator can estimate line lengths for you.  It does this by using the Ohms/Length values you specify in the table 
for lines of various kV.  Simply indicate the voltage levels in the first row of the table, and the corresponding ohms or 
reactance per length in the second column.  You do not need to differentiate here between English and metric units, 
because the calculation is independent of the measurement system.  If you want the length estimates calculated using 
this table to overwrite any line lengths that may already be present in the case, be sure to check the Always Estimate 
Length checkbox; otherwise, the new estimates will set the lengths only of lines whose pre-defined length isn’t greater 
than zero.  If you want the estimates to populate the lengths of lines in the model so that, when you save the model, 
the estimated lengths are saved as part of the model, check the Save Estimates With Case.  (This provides a handy 
way to set line lengths for a case that might not have any defined.)  Note that, in performing these estimates, 
transformers are defined as having zero length.  If you do not want Simulator to estimate line lengths but instead want 
to use the line lengths that are currently stored in memory, check the Do Not Use Length Estimates box.  Finally, if 
you want to load line lengths from a text file, click the Load Line Lengths from File  button.  This file can be either 
comma- or space-delimited, and each line must have the following fields in the order specified: 

 From_Bus_Number  To_Bus_Number  Circuit_ID Length 

Once Simulator knows how to calculate line lengths, it can calculate MW*distance indices for each area and zone.  
Specify the amount of MW that will be transacted in the Size of Transaction textbox.  You may use the arrows to 
increase or decrease the size of the transaction.  Simulator assumes that the transaction is to occur between the 
source and sink groups for which you just calculated PTDFs.  Press the button labeled Calculate  to compute the 
indices.  Two tables are populated with the results of the calculation, one for areas, and another for zones.  Use the 
tabs to switch between the two tables.  These tables are Case Information Displays and thus behave in a manner 
identical with all other case information displays.  Thus, you can sort the tables, add or delete columns, access the 
area and zone dialogs, print the tables, and save their content as HTML. 

Several options can be set to customize the calculation of MW*Distance.  These options are reached from the 
MW*Distance Options Dialog. 
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MW-Distance Options  

The calculation of MW*Distance quantities can be customized in a number of ways.  These options are set from the 
MW*Distance Options Dialog.   

Include Tie Lines Only 

If this box is checked, then the only branches that contribute to the MW*Distance calculation are those that tie two 
areas together.  Otherwise, both tie lines and lines internal to areas and zones are included in the calculation.  In 
the latter case, tie lines are assumed to belong to the area that owns the metered end of the branch. 

Internal Flows 

If you choose to include both tie line flows and flows internal to areas and zones in calculating MW*Distance 
quantities, you have two options for how to treat internal flows.  You can ignore flows resulting from  the transaction 
that flow in the reverse direction of the existing flow on a branch by checking the Include flow increases only 
checkbox.  You can also choose to treat all such counterflows as negative contributions to an area or zone’s MW * 
Distance value by checking the Deduct flow reductions  checkbox. 

Omit Branches 

To omit branches for which the PTDF corresponding to the transaction is less than a specified value, specify a 
nonzero percentage in this textbox. 

Charts  

Area Control Error (ACE) Chart 

The ACE chart plots the area control error for an area over time. For details on ACE, please see topic Area Control<+>
.  To view this display, select Options/Tools > Charts > ACE Chart from the main menu in Run Mode, or press the 
corresponding button on the Simulation Summary tab of the Area Information Dialog.  If you use the main menu to 
view this chart, it shows information for the default area, but this can be changed.  The strip chart starts to plot the data 
when you open it, with new data appearing on the left.  You can change the scale of either the x -axis (the time axis) or 
the y-axis (Scheduled Transactions axis) by right-clicking anywhere on the axis itself and specifying the new axis limits 
and number of intervals.  

Right-click on the display (except on the axes) to view the display’s local menu.  The local menu is used to print the 
strip chart, save the strip chart in a file, copy the strip chart to the Window’s clipboard, or change the number of the 
area being displayed.   

Use the display’s control-menu box to close the display (i.e. the ‘X’ button at the top right corner of the form).   
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Area Load and Generation Chart 

The Load and Generation chart plots an area’s load + losses and generation in MW over time.  To view this display, 
select Options/Tools > Charts > Area Load and Generation Chart from the main menu in Run Mode, or press the 
corresponding button on the Simulation Summary tab of the Area Information Dialog. If you use the main menu to view 
this chart, it shows information for the default area, but this can be changed.  The strip chart starts to chart the data 
when you open it, with new data appearing on the left.  You can change the scale of either the x -axis (the time axis) or 
the y-axis (Load/Generation MW axis) by right-clicking anywhere on the axis itself and specifying the axis limits and 
number of intervals. 

Right-click on the display (except on the axes) to view the display’s local menu.  The local menu is used to print the 
strip chart, save the strip chart in a file, copy the strip chart to the Window’s clipboard, or change the number of the 
area being displayed.   

Use the display’s control-menu box to c lose the display (i.e. the ‘X’ button at the top right corner of the form).  
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Area Losses Chart 

The Area Losses chart plots an area’s real power losses over time. To view this display, select Options/Tools > 
Charts > Area Losses Chart from the main menu in Run Mode, or press the corresponding button on the Simulation 
Summary tab of the Area Information Dialog. If you use the main menu to view this chart, it shows information for the 
default area, but this can be changed.  The strip chart starts to chart the data when you open it, with new data 
appearing on the left.  You can change the scale of either the x-axis (the time axis) or the y-axis (Load/Generation MW 
axis) by right-clicking anywhere on the axis itself. 

Right-click on the display (except on the axes) to view the display’s local menu.  The local menu is used to print the 
strip chart, save the strip chart in a file, copy the strip chart to the Window’s clipboard, or change the number of the 
area being displayed.   

Use the display’s control-menu box to close the display (i.e. the ‘X’ button at the top right corner of the form).  
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Area MW Transactions Chart 

The Scheduled MW Transactions chart plots the scheduled real power (MW) transactions for an area over time. To 
view this display, select Options/Tools > Charts > Area MW Transactions Chart from the main menu in Run Mode, 
or press the corresponding button on the Simulation Summary tab of the Area Information Dialog. If you use the main 
menu to view this chart, it shows information for the default area, but this can be changed.  The strip chart starts to 
chart the data when you open it, with new data appearing on the left.  You can change the scale of either the x-axis 
(the time axis) or the y-axis (Scheduled Transactions axis) by right-clicking anywhere on the axis itself and specifying 
the new axis limits and number of intervals. 

Right-click on the display (except on the axes) to view the display’s local menu.  The local menu is used to print the 
strip chart, save the strip chart in a file, copy the strip chart to the Window’s clipboard, or change the number of the 
area being displayed.   

Use the display’s control-menu box to close the display (i.e. the ‘X’ button at the top right corner of the form).  
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Area Average Cost Chart 

The Average Cost per MWH chart plots the average cost per MWH for an area over time. This value is calculated by 
dividing the total cost of operating the area (generation cost + purchased power cost - revenue from power sales) by 
the MW load in the area.  To view this display, select Options/Tools > Charts > Area Average Cost Chart from the 
main menu in Run Mode, or press the corresponding button on the Simulation Summary tab of the area information 
dialog. If you use the main menu to view this chart, it shows information for the default area, but this can be changed.  
The strip chart starts to plot the data when you open it, with new data appearing on the left.  You can change the scale 
of either the x-axis (the time axis) or the y-axis (Scheduled Transactions axis) by right-clicking anywhere on the axis 
itself and specifying the new axis limits and number of intervals.  Note that as the area’s load increases, the average 
cost per MWH tends to increase. 

Right-click on the display (except on the axes) to view the display’s local menu.  The local menu is used to print the 
strip chart, save the strip chart in a file, copy the strip chart to the Window’s clipboard, or change the number of the 
area being displayed.   

Use the display’s control-menu box to close the display (i.e. the ‘X’ button at the top right corner of the form).  

Bus View Oneline  

Bus View Display 

The Bus View Display feature serves as a graphical analog to the text-based Quick Power Flow List.  Like the quick 
power flow list, the bus view displays enable convenient bus-by-bus navigation through the power system.  Moreover, 
the bus view display contains much the same information as the items on the quick power flow display.  From the bus 
view, you can find out a bus’ voltage and angle, the load, shunt compensation, and generation connected to the bus, 
and the flows on all lines emanating from the bus.  You can also discover the bus’ area and zone affiliations, as well as 
the bus’ marginal cost.  Moreover, as with the quick power flow lists, you can find out all information about the 
elements associated with the bus by directly invoking their associated information dialogs.  The advantage of the bus 
view displays, however, is that you interact with them in the same, familiar way you interact with oneline diagrams.  In 
other words, the bus view displays provide the content and maneuverability of the quick power flow lists with the ease 
of use of the oneline diagrams. 

Along the top of the bus view display resides a panel of controls.  The buttons labeled Back and Ahead allow you to 
step through the history of buses you have viewed thus far.  The next two controls following the Bus label allow to 
specify a bus name (in the first text box) or a bus number (in the second text box).  If you type a number or name that 
does not ex ist, the bus display will continue displaying the current bus.  Following the bus specification fields are two 
text boxes displaying the name and number of the bus’ associated area.  These two fields are read-only. 

Below this top panel sits the actual bus display.  The bus you have chosen to inspect, which we shall refer to as the 
target bus , is represented by a long, thick black horizontal line.  Notice that the bus’ voltage in kV and per unit, its 
angle, and its marginal cost are specified to the left of the bus.  Any loads and generating loads connected to the 
target bus are drawn above the bus symbol, along with their associated annotation.  Emanating from the bottom of the 
bus symbol are all transmission lines and transformers that connect the target bus to its neighbors.  The transmission 
line and transformer symbols are equipped with pie charts and annotation identifying flows as measured at the target 
bus, as well as arrows to identify the direction of MW flow on the branch. Branches that serve as tie lines are drawn in 
green for easy identification. Neighboring buses are represented as filled yellow rectangular regions, with symbol 
indicators included if other types of devices, such as loads, generators, etc., are attached.  When you drag the mouse 
over one of these symbols, it turns into a pointing finger.  Clicking the left mouse button when the mouse cursor is in 
this shape redefines the target bus to be the bus whose symbol you just clicked.  The bus view display is redrawn to 
show the same sort of  display for the newly chosen target.  You can go back to the previously displayed target bus by 
clicking the Back arrow, and then return to this record by clicking the Ahead arrow. 

It is useful to think of the bus view displays as nothing more than an addition oneline diagram.  In other words, you 
interact with the objects drawn on the bus view display in the same way you work with objects on a more conventional 
Simulator oneline.  Right-clicking on any power system object will bring up that object’s local menu, which includes a 
link to the object’s associated information dialog.  As on a conventional oneline diagram, flows on a bus view display 
can be animated.  Right-clicking on the bus view display’s background will generate the same local menu as other 
oneline diagrams.  Again, the bus view display is the quick power flow list in the form of a oneline diagram. 

 

The bus view display can be generated using any of the following methods: 

• From the main menu, choose Case Information > Bus View .  You will have to specify a bus name or number upon 
entry. 

• Right click on the bus of interest on the oneline diagram to display the bus’ local menu, and choose Bus View.  The 
bus view display will open with the selected bus already displayed. 

• From any of the case information displays that convey bus information, right click on a record to bring up its local 
menu, and choose Bus View Oneline.  The bus view display will open with the corresponding bus already displayed. 

• Click the corresponding toolbar icon on the Options/Info Toolbar. 

To switch between the bus view and the main oneline, use the Window menu tree on the main menu. To close the 
bus view display, simply close the form using the X button in the top right corner of the bus view display. 
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Bus View Options  

Number of Tiers 

The bus view can display one or two "tiers" of buses in the display.  Use this selection from the Options  menu to 
toggle the number of tiers displayed. 

Show Hints  

When this option is checked, holding the cursor over an object will briefly pop up a hint box containing information 
about that object. 

Show Serial Buses 

When putting in the branch connections, the Bus View display will look out into the network and find the next bus 
which has more than two neighbors.  It will then make this the destination bus for that branch of the Bus View.  The 
intermediate buses will then be shown in order above the destination branch.  This option works especially well in 
systems with a lot of multi-section lines. 

Show Equivalent Lines 

This option indicates to the Bus View display whether or not to include branches representing equivalent circuits as 
connections in the display. 

Default Drawing Values 

Choosing this option will open the Default Drawing Values for New Objects dialog.  Changing these options can 
change some of the drawing aspects of the bus view, including device color and font size or color. 

Open Multiple Bus Views 

This option indicates whether to open multiple bus views simultaneously.  Choices are never, always, and prompt 
for confirmation when a new additional bus view is about to open. 

Include Field Labels  

Selecting this option will place labels for each displayed field on the bus view diagram. 

Change Bus Link Color 

Selecting this option will display the color palette to select the color with which the buses linked to the current bus 
will be displayed. 

Show Field Suffixes 

This option specifies whether to display the field values units as suffixes.  If this option is not selected, all the fields 
will be display as a value without units. 

 

Views 

Define Custom View  

The fields displayed on the bus view can be customized using this option.  Clicking on this option will open a 
customization settings display, in which you can add and remove field definitions for the objects on the bus view 
display.  Customized bus view layouts can be saved with the case for recall, identifiable by a custom bus view 
layout name.  Custom layouts can also be saved to a file for loading into another load flow case. 

Input Data 

Switching the bus view to Input Data changes the bus view from displaying system state information to displaying 
input data information.  For example, switching to Input Data view will display line impedances and limits, generator 
minimum and maximum outputs, etc.  The default Input Data view fields can be modified using the Define Custom 
View customization dialog. 

System State  

Switching the bus view to System State changes the bus view from displaying Input Data information to displaying 
system state information.  This will result in line flows being displayed, voltage and angles displayed, etc., of the 
current solution state of the system.  The default System State view fields can be modified using the Define Custom 
View customization dialog. 

Substation View Oneline  

Substation View Display 

The Substation View Display feature is analogous to the Bus View Display.    

Along the top of the substation view display resides a panel of controls.  The buttons labeled Back and Ahead allow 
you to step through the history of substations you have viewed thus far.  The next two controls following the Substation 
label allow to specify a substation name (in the first text box) or a number (in the second text box).  If you type a 
number or name that does not exist, the substation display will continue displaying the current substation.  

Below this top panel sits the actual substation view display.  
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Just as with the bus view, it is useful to think of the substation view displays as nothing more than an addition oneline 
diagram.  In other words, you interact with the objects drawn on the substation view display in the same way you work 
with objects on a more conventional Simulator oneline.  Right-clicking on any power system object will bring up that 
objects local menu, which includes a link to the object’s associated information dialog.  As on a conventional oneline 
diagram, flows on a substation view display can be animated.  Right-clicking on the substation view display’s 
background will generate the same local menu as other oneline diagrams. The substation view can be generated 
using any of the following methods: 

 

• From the main menu, choose Case Information > Substation View.  You will have to specify a bus name or 
number upon entry. 

• Right click on a substation of interest on the oneline diagram to display the substations local menu, and choose 
Substation View.  The substation view display will open with the selected substation already displayed. 

• From any of the Substation Records display, right click on a record to bring up its local menu, and choose 
Substation View Oneline.  The substation view display will open with the corresponding substation already 
displayed. 

• Click the corresponding toolbar icon on the Options/Info Toolbar. 

 

To switch between the substation view and the main oneline, use the Window menu tree on the main menu. To close 
the substation view display, simply close the form using the X button in the top right corner of the substation view 
display. 
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Run Mode Tools and Options  

Chapter 11 : Run Mode Tools and Options  

Run mode provides a number of commands for simulating and modifying the case that are different from Edit Mode. 

This chapter covers the following: 

• Difference Flows 

• Generator Economic Curve Displays 

• Movie Maker 

• Contingency Analysis 

• Fault Analysis  

• Contouring 

• Distribution Factors 

• Sensitivities 

General Tools  

Governor Power Flow 

A new dialog has been created which stores all information related to solving a governor power flow.  This dialog may 
be accessed by choosing Options/Tools > Governor Power Flow.  This brings up a dialog on which you can modify 
settings related to solving the case while on Governor or "Island-Based Automatic Generation Control (AGC)". 

The Governor Power Flow Dialog has two tabs: 

 

Options  

This tab sheet presents the following controls: 

Disable Automatic Generation Control 

Disables automatic MW generation changes during the power flow solution. 

Island AGC Tolerance  

The ACE mismatch tolerance allowed for the Island to be considered solved in terms of generation dispatch. 

Island-Based Automatic Generation Control 

Select how the generations should be controlled for the dispatch. 

• Disabled: The area and super area dispatch settings from the case will be used 

• Use Participation Factors of individual generators: Each generator will have it’s own participation factor, and 
will contribute according to its participation factor divided by the sum of all participation factors of all other 
generators in the same island. 

• Calculate Participation Factors from Area Make Up Power Values: Each area can be assigned a "factor" as to 
how it should participate towards the generation dispatch in the island.  This is similar to participation factors 
for generators.  Each area can be assigned a factor.  The total percentage the area contributes towards the 
generation change needed in the island is equal to its individual factor divided by the sum of all area make up 
power factors.  Then within each area, the generator participation factors determine how the area’s 
percentage is made up of available generation within the area.  The area make up power values can be set in 
the table of areas on the right hand side of the dialog. 

• Dispatch using an Injection Group: The island dispatch will be made up by a combination of generators and 
loads, defined in an injection group that can be selected from the dropdown list. 

How should reactive power load change as real power load is ramped? 

If you are using an injection group with load as part of the dispatch, then you can specify how the reactive power 
load should respond as the real power demand of loads changes with the dispatch.  The reactive power can either 
be kept at the starting ratio of real and reactive power of the load, or the MVAR amount can change at each load by 
a specified power factor. 

 

Generator Options (Ignore Area/Zone/Owner filter) 

This tab sheet presents a case information display with all the generators of the case. 
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Difference Flows 

The Difference Flows feature provides an easy mechanism for comparing two power system cases.  For example, it 
could be used to show the difference in transmission line flows and bus voltages resulting from a contingency or a 
change in power transfer between two areas.  Use of this feature affects all aspects of the Simulator environment, for 
all oneline diagrams, case information displays, and power flow lists will reflect either the operating state of one of the 
two cases being compared or the differences between those cases. 

 

Using the Difference Flows activity is fairly easy: 

• Set up a solved power system corresponding to a desired operating point.  This operating point will be defined as 
the Base Case.   

• Select Options/Tools > Difference Flows from the main menu, Difference Flows from the oneline local menu in 
Run Mode, or the Difference Flows button (not the arrow next to the button!) on the Run Mode Toolbar to display 
the Difference Flows Dialog. 

• On the Difference Flows Dialog, click the button labeled Set Present as Base Case.  This stores the current 
operating point as the Base Case.  The Base Case is the operating point against which the difference flows 
comparison will be made. 

• Define the operating point for which to perform the difference flows comparison.  This new operating point, the 
Present Case, will be compared with the Base Case to determine the difference flows.  The Present Case may be 
developed either by modifying the Base Case as desired and re-solving, or by opening a new case using File, 
Open Case from the main menu.  In the latter situation, the new case that you open must have the same bus 
numbering scheme as the Base Case.  

• On the Difference Flows Dialog, use the Case Type to Display group box to toggle between displaying the 
Present Case, the Base Case, or the Difference Case, which shows the difference between the Present Case and 
the Base Case values, calculated relative to the Base Case’s operating point.  The Case Type to Display setting 
controls which operating state - the Base Case, the Present Case, or the Difference Case - is displayed by all 
oneline diagrams and all case information displays.  Alternatively, click the arrow next to the Difference Flows 
button to produce a list of which case to display:  Present Case, Base Case, or Difference Case.  The presently 
selected case is flagged with a checkmark.  Select the case you wish to display.  

When showing the Difference Case, most of the fields shown on the onelines and case information displays show the 
difference between the present value and its Base Case value.  For example, on the Generator Records Display, an 
entry of 0.0 in the MW field indicates that the real power output of the generator did not change.  An entry of 10.0 in 
the MW field indicates that the present real power output of the generator is 10 MW greater than it was in the Base 
Case.   

At any time during a simulation, you can set the present case as the Base Case by clicking the Set Present as Base 
Case button on the Difference Flows Dialog.   Conversely, if you have made changes to the present case, and you 
wish to revert to some or all of the base case values, you can click on the Reset Case… button.  When you click this 
button, the dialog will expand to show you options for resetting specific types of values to their base case values.  
Once you have indicated which types of values you want to reset (by default, all are selected), you can click on the 
Reset Present Case to Base Case Values button to complete the process of reverting to base case values.  Note: 
once you have finished resetting to the base case values, you can hide the Reset options by clicking the Hide Reset 
Button in the upper right hand corner of the Reset options panel. 

The oneline diagrams and case information displays cannot indicate structural differences in the case very well, such 
as the addition or removal of a device.  To identify such differences, make use of the Present Topological Differences 
from Base Case tool to identify topology differences. 
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Present Topological Differences from Base Case 

The Present Topological Differences from Base Case option provides the users a way to compare the topological 
differences between two difference cases in Simulator. 

To compare two cases topologically, you must load the first case you wish to use as the reference into Simulator.  Use 
the Difference Flows tool from Options/Tools > Difference Flows (run mode only) to set the case as the base case in 
memory.  Once the reference case has been stored as the base case, open the second or comparison case into 
Simulator.  Now if you check the Options/Tools  menu, you should see the option labeled Present Topological 
Differences from Base Case available.  Choosing this option will open the dialog to display the topological 
differences. 

 

Summary 

A listing of the types of objects in the case.  The first column displays the number of NEW devices in the 
comparison case that were not in the base case.  Alternately, the Removed column displays the number of devices 
in the base case that do NOT exist in the comparison case.  The third column simply displays the number of items 
that were matched between the two cases. 

Elements Added 

Tabular listings of all objects that exist in the comparison case, but not in the reference case. 

Elements Removed 

Tabular listings of all objects that exist in the reference case, but are not present in the comparison case. 

Elements in Both 

Tabular listings of all objects present in both cases. 

Create Bus Swap List 

A local location for setting up a bus renumbering list.  It is possible that discrepancies in topology between the 
comparison case and the reference case can be due to a difference in bus numbering between the two cases.  
Renumbering the buses in the comparison case may take care of most of the topology discrepancies that are 
reported in this instance. 
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Economic Curves 

Four characteristic curves describe the efficiency and resulting costs associated with operating a particular generating 
unit.  These four curves plot 

• Fuel Cost 

• Heat Rate 

• Input-Output 

• Incremental Cost 

 

Simulator can display plots of all these curves.  To display a particular plot for a generator, right-click on the generator 
in Run Mode to display its local menu, and then select the plot you wish to see.  The plot will be presented in its own 
window.  The windows for all plots exhibit identical characteristics.  For example, the current operating point is 
identified by a red filled circle.  Right clicking on an open area of the window displays the plot’s local menu which 
allows you to print the plot, save it to a file, or copy it to the clipboard for use in other programs.  To adjust the length 
and number of intervals shown on an axis, right-click on the axis (not on the numbers) and specify the min and max 
display values and number of intervals.  To close a plot window, simply click the X button in its top right corner. 

The Run Mode generator local menu also provides access to a fifth type of plot curve - the "All Area Gen IC Curves" 
plot.  This plot simply shows the incremental cost curves and present operating points of all generators in the same 
area as the generator on which you clicked. 

 

Fuel Cost Curve  

The fuel cost curve specifies the cost of fuel used per hour by the generating unit as a function of the unit’s MW 
output.  This is a monotonically increasing convex function. 

Heat-rate Curve 

The heat rate curve plots the heat energy required per MWH of generated electrical output for the generator as a 
function of the generator’s MW output.  Thus, the heat rate curve indicates the efficiency of the unit over its 
operating range.  Generally, units are least efficient at the minimum and maximum portions of their MW output 
capability and most efficient somewhere in the middle of their operating range.  The vertical axis is plotted in 
MBtu/MWH and the horizontal axis is plotted in MW.  You may interpret the heat rate for a generator producing X 
MW as follows:  the heat rate indicates the amount of heat input energy per MWH of generation required to produce 
X MW of power.  The lower this number, the less input energy is required to produce each MWH of electricity. 

Input-Output Curve  

The input-output curve is derived simply from the heat-rate curve by multiplying it by the MW output of the unit.  This 
yields a curve showing the amount of heat input energy required per hour as a function of the generator’s output. 

Incremental Cost Curve  

By multiplying the input-output curve by the cost of the fuel in $/MBTU, one obtains the cost curve for the unit in 
$/hr.  By taking the derivative of the cost curve, one obtains the incremental cost curve, which indicates the 
marginal cost of the unit:  the cost of producing one more MW of power at that unit.   
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Movie M aker 

Simulator has a feature called Movie Maker that enables you to record the animation of oneline diagrams as AVI 
movie files.  This feature can be useful for producing demonstrations of system conditions and distributing them to 
colleagues who may not be using PowerWorld Simulator. 

To open Movie Maker, select Options / Tools > Make Movie  from the main menu in Run Mode.  A dialog entitled "PW 
Movie Maker" will open.  This dialog allows you to control various settings for the recording of the movie, including its 
length and screen dimensions.  It also provides controls for starting and pausing the recording of the movie, and 
saving and playing it once the recording has finished. 

Note that you must have a PowerWorld oneline diagram open in order to use the Movie Maker.  This only makes 
sense, as without a oneline diagram there are no frames of animation to record. 
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Movie Maker Dialog 

The PowerWorld Movie Maker Dialog is opened by selecting Options / Tools > Make Movie  from the main menu in 
Run Mode.   

 

This dialog features the following controls: 

Type of Movie  

Two types of movie files can be recorded, AVI files or MPEG files. 

Length of Movie  

Two options are provided for specifying the length of the movie to record.  You can either use the start recording 
and pause recording buttons that appear along the bottom of the Movie Maker form, or you can specify that the 
movie is to contain a fixed number of slides.  A slide is simply one frame of animation.  If you check the latter option, 
you must also specify the number of slides to include. 

Step by Step 

Allows you to pause after each frame. 

Length of Frame 

The Movie Maker works by capturing sequential frames of animation of a oneline diagram.  This particular attribute 
controls how long eac h captured frame is kept on the screen during the movie.  This duration is expressed in 
milliseconds. 

Dimensions (pixels) 

Controls are provided that allow you to specify the width and the height the movie should assume during playback.  
During the record process, the oneline image will be scaled to match these dimensions so that the movie will 
preserve the original resolution when replayed. 

Pixel Depth 

You can choose the quality of the video by adjusting the Pixel Depth. 

Miscellaneous  

You can choose to stretch or compress the video. 

Temporary Folder 

Set the location of the temporary storage folder for use while making the movie. 

Along the bottom of the dialog is a row of control buttons.  From left to right, these buttons are: 

New Movie… 

Press this button to begin producing a new movie.  If you have already used the tool to produce a movie but have 
not yet saved it, you will be asked if you would like to save the movie before proceeding.  Then, the dialog will be 
restored to its original default settings.  Notice that this button is disabled until a movie has been recorded and is 
stored in memory. 

Start Recording 

Movie Maker will begin capturing animation frames by launching the animation of the currently selected oneline 
diagram and storing each frame in a buffer in memory.  If you have chosen to use a fixed number of frames as the 
criterion for stopping the recording, then the frame capturing will cease after the specified number of frames have 
been saved.  Otherwise, you will have to press the Pause recording button.  If you press the Start recording 
button after having pressed Pause recording button, the new captured frames will be appended to the list of frames 
already in memory. 

Pause Recording 

Use this button to pause the recording process.  If you have s pecified that the movie should include a set number of 
frames, you likely will not need to press this button.  However, you may, in fact choose to use it.  You can then 
press the Start recording button again, and the new screen frames will be appended to the list of frames already 
stored in memory. 

Save Movie  

Press this button to store the sequence of frames to a file in AVI video format.  Simply provide a name for the 
movie, and Movie Maker will transfer the images to the file for later playback. 

Play Movie 

If you press this button, Simulator will launch your system’s movie player to play the movie you just recorded.  If you 
have not yet saved the frames to a movie file, you will first be asked to provide a name for the movie file in which to 
save the captured images.  Movie Maker always plays movies from a file rather than from the sequence of frames 
stored in memory. 

Show Options  
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When you record a movie, the Movie Maker dialog assumes a much smaller footprint so that it blocks as little of the 
animated oneline as possible.  This hides the panel that houses the aforementioned options.  If you want to restore 
Movie Maker to its original size, press this button. 

Close This Form 

As the name suggests, pressing this button will close the Movie Maker dialog.  If you have not already saved the 
movie to a file, you will be asked to do so. 

Contingency Analysis 

Overview 

Contingency Analysis: An Introduction 
Contingency analysis is a vitally important part of any power system analysis effort. Whether you are investigating the 
long-term effects on the transmission system of new generation facilities or projected growth in load, or you are 
considering whether to accept a transaction for next-hour’s energy trade, it is extremely important that you analyze the 
system not only for its current topology but also for the system that results from any statistically likely contingency 
condition. Industry planning and operating criteria often refer to the n-1 rule, which holds that the system must operate 
in a stable and secure manner for the loss of any single transmission or generation outage. Therefore, it is very 
important to pay attention to the effects contingencies may have on the operation of your system. 

PowerWorld Simulator is equipped with a set of tools for analyzing the effect of contingencies in an automatic fashion. 
The current edition of Simulator can process lists of contingencies involving  

 

• The opening or closing of transmission lines and transformers 

• The loss or recovery of a particular generator, load, or switched shunt 

• The movement of generation, load, or switched shunt MWs or Mvars 

• The changing or setting of load, switched shunt, or generator MWs or Mvars 

• The opening of all lines connected to a bus  

• The opening or closing of all lines or transformers in an interface 

• The opening, closing, or changing of output of all devices in an injection group 

 

Simulator can be set to use a full Newton solution to analyze each contingency or use a dc load flow method. The full 
Newton approach is not as fast as dc load flow, but the results tend to be significantly more accurate, and also allow 
for gauging voltage/var effects.  
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Contingency Case Dialog 
The Contingency Case Dialog serves  as an information source for displaying the actions of each contingency that has 
been defined for the case. You can use the Contingency Case Dialog to scroll through the list of actions, to view and 
modify their definitions, and to insert new actions for a contingency. You may access this dialog by choosing either 
Show Dialog or Insert from the local menu of the Contingency Records Display.  

 

The Contingency Case Dialog has the following controls: 

Contingency Label 

Identifies the name of the contingency currently being described by the dialog. Use the dropdown arrow to select a 
different contingency, or use the scroll buttons to navigate through the list of contingencies. 

Add Contingency 

Prepares the dialog for the addition of a new contingency to the contingency list by clearing the Contingency 
Elements list and creating temporary storage for the new item. To add a new contingency using this dialog, first type 
an unused contingency name in the Contingency Label field, and then click Add Contingency. The name you 
supply must be unique; otherwise, you will receive a warning indicating that the name you have specified is already 
used by a contingency in the list. 

Insert New Element 

Click this button to add a new action to the contingency. This will open the Contingency Element Dialog, which will 
allow you to define the new action. When you return to the Contingency Case Dialog, the Contingency Elements 
Dialog will contain the newly inserted action. 

Clear All 

Removes all actions from the contingency definition. The Contingency Elements Table will then appear blank, 
indicating that the contingency involves no associated actions. 

Rename Contingency 

Allows you to rename the selected contingency.  Clicking this button will open a dialog for entering the new name 
you w ish to use. 

Contingency Definition 

This dialog contains a Contingency Definitions Display which lists the actions that comprise the contingency.  To 
add actions to the contingency, right-click on the display and choose Insert or click on the Insert New Element 
button.  This will bring up the Contingency Element Dialog where you can define the action.  To delete an action, 
right-click on the display and choose Delete .  For more information about this display, see the Contingency 
Definitions Display. 

Define Solution Options  

Click this button to open the Contingency Solution Options Dialog.  Use this dialog to define power flow solutions 
options for use under this contingency.   

Use Specific Solution Options  

Once you have defined solution options for this contingency, check this box to enable their use. 

Click OK to save your changes and close the dialog. Click Cancel to close the dialog without saving your changes. 
Click Save to save your changes (including the addition of a new contingency) without closing the dialog (this allows 
you to keep working with the dialog). Click Delete  to remove the contingency from the contingency list. 
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Global Actions 
Global actions allow you to define a list of contingency actions that occur during ALL contingency records.   

Global actions are defined by clicking the Define Contingency Blocks and Global Actions  button on the Advanced 
Modeling tab of the Options page of the Contingency Analysis dialog.  Click on the Global Actions tab of the 
Contingency Blocks and Global Actions dialog to define Global Actions.  Adding global actions occurs in a manner 
identically to that of the Contingency Case Dialog.  Right-click in the Actions list to open the Contingency Element 
Dialog, which allows you to add contingency actions to be treated as Global actions. 
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Contingency Solution Options Dialog 
By default, the contingency analysis will use the same options as the power flow algorithm when solving each 
contingency.  You may also override these options for all contingencies, and/or for a specific contingency.  This results 
in the ability to set the power flow solution options in contingency analysis at three different levels 

1 Contingency Specific Options (see Contingency Case Dialog) 

2 Contingency Analysis Options (see Contingency Options Tab) 

3 General Power Flow Solution Options (see Power Flow Solution Options) 

When Simulator executes a particular contingency, it will first look at options specified for that contingency.  Any 
options which are defined for this contingency will be used.  Other options set as "use default" will look to the 
Contingency Analysis Options.  Again, any options which are defined for contingency analysis will be used.  Finally, 
options marked in the Contingency Analysis Options as "use default" will be set to the same setting as the power flow 
solution options. 

In order to specify options for a specific contingency, you will click on a button on the Contingency Case Dialog.  In 
order to specify options for all contingencies, you will click on a button on the Contingency Options Tab.  Both of these 
will bring up the Contigency Solution Options Dialog. 

This dialog contains many options regarding the power flow solution.  For options which are a numerical value, just 
specify a new value to use.  For options which are specified by a check-box, the check-box will have three settings: 
use options, do no use option, and use default.  For a more detailed explanation of each option see the Power Flow 
Solution Options. 

To set the values to be the same as the present power flow solution options, click the Set same as for Power Flow 
button.  To set all options back to use default, click the Clear All Settings  button. 
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Contingency Blocks 
Contingency Blocks are very similar to a Contingency Record, however no results can be associated with them.  
Contingency Blocks consist of a list of contingency actions.  The block is then given a name so that any Contingency 
Record can call on a Contingency Block.  When a contingency block is included as part of a contingency, the 
Contingency Record will incorporate all the actions from the contingency block into the actions performed by the 
contingency.   

Contingency blocks are defined by clicking the Define Contingency Blocks and Global Actions  button on the 
Options page of the Contingency Analysis Dialog.  Click on the Contingency Blocks tab of the Contingency Blocks and 
Global Actions dialog to show a display for defining Contingency Blocks.  Right-clicking in the Contingency Blocks grid 
allows you to insert a new Contingency Block.  Once you have added the new contingency block, you can begin 
adding actions to the block by right-clicking in the Contingency Definition grid to insert new actions. 

 
Once Contingency Blocks have been defined, a new Element Type, "Contingency Block" will appear on the 
Contingency Element Dialog.  This is shown to the right in the image below.  You may then add a contingency block to 
a contingency by right-clicking on a contingency in the Contingency Records list display, choose show dialog (or insert 
if you are adding a new contingency record), click on Insert New Element, and choose Contingency Block from the list 
of element types. 
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Using a contingency block is an easy way to include a set of commong actions in multiple contingency scenarios, 
without having to re-define the actions for each contingency. 
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Make-Up Power Sources 
Generator and load contingencies may cause imbalances between generated power and demand.  The default way to 
handle these imbalance is to assign them to the system slack.  However, this is probably unrealistic and, depending 
on the size of the unit or load involved, it may cause you to have convergence problems.  

To implement more local compensation for generation and load changes, use the Make-Up Power Sources Dialog.  
This dialog can be accessed by from the Contingency Element Dialog by clicking the button labeled "Make-Up Power 
Sources."  Most of the dialog is occupied by a grid that lists bus numbers and relative contributions.  This grid is a 
Case Information Display, so its behavior should be familiar.  For example, right-click on the grid to display its local 
menu. 

We shall call those buses that must compensate for the changes caused by a generator or load contingency 
compensators.  To insert a new compensator, select Insert from the grid’s local menu.  This opens another dialog, 
where you should specify the bus number of the compensator and its contribution.  Specify the contribution of the 
compensator either as a percentage or as a fixed number of MW.  If a particular contingency has multiple 
compensators, then the choice of basis for the contribution (either MW or percent) should be consistent for each.  After 
identifying the compensator, click OK.  The grid should update with your newly added compensator. 

To delete an existing compensator, select it from the grid and select Delete  from the local menu. 

Compensators account for the changes caused by a generator or load contingency by changing generation or load to 
satisfy its defined contribution.  For example, suppose compensator contributions are specified as percentages, and 
Simulator needs to compensate for 100 MW lost in a particular generation contingency.  Suppose the contingency has 
4 compensators defined as follows 

Bus Number                 Contribution 

1  20 

2  30 

3  10 

4  40 

Suppose buses 1 and 2 are load buses, and buses 3 and 4 are generators.  Then bus 1’s load will decrease by 20 
MW, bus 2’s load will decrease by 30 MW, bus 3’s generation will increase by 10 MW, and bus 4’s generation will 
increase by 40 MW.  These changes will be instituted regardless of the compensators’ operating limits or AGC status.  
In fact,  any compensating units will be set off AGC to ensure that the prevailing AGC control doesn’t distort the 
dictates of the contingency.  Furthermore, maximum MW limits on generators will not be checked. 

If a compensator has both generators and loads attached to it, the generator will take precedence.  The generator will 
function as the compensating device, and the load will be left unchanged. 
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Contingency Make-Up Sources Dialog 
Simulator allows you to specify buses that will serve as compensators to account for changes in the balance between 
generation and demand caused by generator and load contingencies.  This dialog allows you to define or adjust the 
amount of pow er supplied by a compensator.  For more information, please see Make-Up Power Sources. 
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Model Expressions 
There are two types of Model Expressions: an expression and a lookup table. 

 

Lookup Tables 

The dialog as configured when creating a lookup table appears as follows: 

 
A lookup table may be either one or two-dimensional by specifying the Lookup Type.  You then specify the Number 
of Points for each lookup dimension as well as what model variables will be used for each dimension.  Finally enter 
the values that describe the lookup table. 

Expressions 

The dialog as configured when creating an expression appears below: 
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To define the Model Expression as an expression, specify the model variables that the expression should be a 
function of.  Then enter the function description.  See Custom Expressions for more information about defining 
expressions. 

 

After some model expressions have been defined, new options will appear on the Contingency Element Dialog and on 
the Advanced Filter Dialog.   

Normally, you may only enter a constant for the comparison value on the Advanced Filter Dialog.  However, now the 
advanced filter dialog will feature a drop-down from which you can choose Expression.  After choosing Expression, 
you may enter the name of the model expression, or click the Find Button to search for the name. 

 
Similarly, normally you may only enter a constant for the Move, Set To, or Change By action types on the Contingency 
Element Dialog.  However, now you will have the option click a box saying "Model Expr."  After doing this, enter the 
name of the model expression in the Amount box, or click on the Find… button to search for a name. 
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Bus Load Throw Over Records  
The Bus Load Throw Over list display provides you with the capability to define how load at a bus should be 
transferred to a different bus if the original terminal bus becomes disconnected from the system.  This is referred to in 
Simulator as "throw over."  This tool is most useful when performing contingency analysis scenarios in which buses 
containing loads become disconnected, and you wish to analyze the impact on the system of switching the load from 
the disconnected bus to another bus that is still in service. 

Load throw over will only attempt to move the load once, from the original bus to the load throwover bus.  If the load 
throwover bus is already disconnected from the system, then the load will be treated as dropped during the 
contingency solution. 

 

NOTE: the load throwover is only used when running the contingency analysis tool to analyze contingency affects on 
the system.  Load throw over records are not used during manual solution of the power flow, even if you manually 
disconnect a bus with load and perform a load flow solution. 

 

The Bus Load Throw Over display has the following fields: 

Number, Name 

The bus number and name of the load’s terminal bus. 

Nom kV 

The nominal voltage level of the load’s terminal bus. 

Load Throwover Bus Number 

Enter the number of the bus you wish to have the load transferred to, should the original load terminal bus become 
disconnected during a contingency in the contingency analysis.  The Load Throwover Bus Name_kV field will be 
automatically populated. 

Load Throwover Bus Name_kV 

Beging entering the bus name and nominal kV (separated by a _ between the name and nominal kV) of the bus you 
wish the load to be transferred to, should the original load terminal bus become disconnected during a contingency 
in the contingency analysis.  The Load Throwover Bus Number will be automatically populated if the corresponding 
Bus Name_kV is found. 
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PSS/E Contingency Format 
Simulator can read and write parts of the contingency format used by Power Technology’s PSS/E Versions 23 through 
29.  The current version of Simulator does support all parts of this format, except it does not recognize PTI’s Automatic 
Contingency Specification flags. If you need Simulator to support these keywords, contact PowerWorld Corporation to 
express your need.  Otherwise, we recommend you make use of Simulator’s Auto-Contingency creation tool. 
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Running the Contingency Analysis 
To run the contingency analysis means to model and solve one or more contingencies from the case’s current 
contingency list. Simulator’s Contingency Analysis Dialog gives you several options for running the contingency 
analysis. You may 

 

• Run every contingency in the contingency list (except, of course, for those you have designated to skip using the 
Contingency Records Display). 

• Run a selected contingency to identify its limit violations and then leave the system in this post-contingency state. 
(Realize that prior to solving another contingency, Simulator will reset the system state to reference state.  For more 
information see Contingency Case References). 

• Run a selected contingency to identify its limit violations and keep the resulting case as the new reference point for 
further contingency analysis runs. 

To run the complete contingency list, do any one of the following: 

• Right-click on the Contingency Records Display to bring up its local menu and select Run Contingency Analysis . 

• Click the Start Run button visible from the Contingency Tab. 

• Click the Start button visible from the Summary Tab. 

 

To pause the contingency run once it has started, click either Pause Run on the Contingency Tab or Pause on the 
Summary Tab. To resume a paused contingency run, click the Continue  buttons on either the Contingency Tab  or 
the Summary Tab. Finally, to terminate a contingency run, click the Abort button on the Summary Tab. The status 
indicator will inform you of the run’s current state. 

To solve a single contingency, identify its violations, and then leave the system in this post-contingency, select the 
contingency you wish to model in the Contingency Records Display, right-click to invoke the display’s local menu, and 
select Solve Selected Contingency.  (Realize that prior to solving another contingency, Simulator will reset the 
system state to reference state). 

To solve a single contingency and set it as the reference (starting) case for further contingency analysis activity, select 
the contingency you wish to model in the Contingency Records Display, right-click to invoke the display’s local menu, 
and select Solve and Set As Reference . Simulator will model the selected contingency, flag its violations, and leave 
the resulting case in memory so your future work will affect the post-contingency system rather than the original pre-
contingency state. See Contingency Case References for more information. 

Contingency Analysis Dialog Overview 
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Contingencies Tab 
The Contingencies Tab of the Contingency Analysis Dialog provides tools for managing and simulating lists of 
contingencies. The top portion of the Contingencies Tab lists the contingency records that have been defined for the 
case. This table is called the Contingency Records Display. The contingency records display is a type of case 
information display and thus shares many of the properties and controls common to all other case information 
displays. By right-clicking on the display, you gain access to its local menu, which offers several choices. For example, 
you can insert a new contingency record by selecting Insert, or you can delete a particular contingency by selecting 
Delete . You can display the contingency case dialog corresponding to a particular contingency by selecting Show 
Dialog from the local menu. You can copy portions of the display to other applications, print the contingency list or 
save it as an HTML table, or save the records to a file in a format that Simulator can read later. You can sort the 
display’s contents by any field just by clicking on the field’s heading.  The default fields shown in the contingency 
records display are described at the bottom of this page. 

As you scroll through the records in the contingency records display, you will notice that the contents of the tables that 
occupy the middle third of the contingency analysis dialog change. These tables are the Contingency Definition 
Display and the Contingency Violations Display.   These displays show the violations and definition for the contingency 
that is selected in the contingency records display at the top of the dialog.  You may optionally hide the Contingency 
Definition Display by clicking on the X to the upper right of this display.  To show the display again, click on the O to 
reopen it.  You may change the relative width of the Contingency Definition and Violations display by moving your 
mouse over the line between the displays until your cursor changes.  Then left click and drag to modify these widths. 

When you first load a new contingency list into memory, the current status indicator will display the word Initialized. 
During a contingency analysis run, the current status indicator may take on the values Running, Paused, Aborted, or 
Finished. 

The contingency tab of the contingency analysis dialog offers several ways to run the contingency analysis. To start a 
run, you may click the Start Run button. Alternatively, you may choose Run Contingency Analysis  from the local 
menu of the contingency records display. Once a contingency analysis run has started, you may pause it at any time 
by clicking the Pause Run button, after which you may resume the run by clicking Continue . In addition to running the 
full set of contingencies, you may also choose to run just a single contingency. See Running the Contingency Analysis 
for more details. 

Several other actions related to contingency analysis are also available from the Contingencies Tab.  These are 
accessed by clicking on the Other Actions > button.  They are described on the Other Contingency Actions page. 

You may close the Contingency Analysis Dialog at any time either by clicking Close or by selecting Close from the 
local menu of the Contingency Records Display or the Contingency Violations Display. 

 

By default, the contingency records display presents the following fields: 

Label 

The name of the contingency. 

Skip 

Indicates whether Simulator should skip the corresponding contingency in performing the contingency analysis. If 
the value of the Skip field is Yes for a contingency, then that contingency will not be implemented when performing 
the contingency analysis. This is a toggleable field, which means that you can toggle its value by double-clicking the 
field. 

Processed 

Indicates whether the contingency has been analyzed yet as part of the current contingency run. 

Solved 

If the contingency has not yet been processed, which means that the contingency has not yet been implemented, 
then the value of this field is No. For contingencies that have been processed, the Solved field indicates whether the 
power flow case that resulted from the contingency could be solved to within tolerance. If the resulting power flow 
case could not be solved, you should investigate the contingency closely to determine if that contingency is indeed 
harmful to the stability of the system. 

Islanded Load 

Displays the sum of the amount of load that was islanded from the rest of the system due to the contingency.  This 
load is inaccessible from the rest of the system. 

Violations  

Identifies the number of violations caused by the particular contingency. This number represents the total number of 
contingencies (branch thermal violations + bus voltage violations + interface violations) that were caused by the 
contingency. Depending on how you have configured the reporting of Base Case violations (see Base Case of the 
Options Tab), this number may include all, some, or none of the violations that were present in the Base Case 
model. 

Max Branch % 
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Indicates the percentage overload of the worst-case branch violation. If there are no branch violations, this field will 
be blank. 

Min Volt 

Indicates the lowest bus voltage resulting from the contingency. If there are no low voltage violations, this field will 
be blank. 

Max Volt 

Indicates the highest bus voltage resulting from the contingency. If there are no high voltage violations, this field will 
be blank. 

Max Interface % 

Indicates the percentage overload of the worst-case interface violation. If there are no interface violations, this field 
will be blank. 
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Contingency Definition Display 
The contingency definition display identifies the actions that comprise the contingency selected.  This display appears 
on the Contingency Tab of the Contingency Analysis Dialog, and also on the Contingency Case Dialog.   

To add actions to the contingency, right-click on the display and choose Insert.  This will bring up the Contingency 
Element Dialog where you can define the action.  To delete an action, right-click on the display and choose Delete . 

The contingency definition display is a type of Case Information Display and thus shares many characteristics and 
controls common to all other case information displays.   

 

The Contingency Definitions Display always contains the following fields: 

Actions  

This shows a string which describes the action.  You may customize the format of the string that describes the 
contingency actions by right-clicking on the Contingency Definition Display and choosing Display Descriptions By, 
and then choosing either Name, Num, Name/Num, PW File Format by Numbers, PW File Format by Name/kV or 
PTI File Format. 

Model Criteria 

Simulator allows you to define Model Criteria, which consist of both Model Conditions and Model Filters.  These 
specify a criteria under which a contingency action would occur.  For example, you could specify that a generation 
outage only occur if the pre-contingency flow on a line is higher than a specified amount.  Normally, no Model 
Criteria will be specified, and this field will be blank.  Also, note that Model Criteria can be overridden by the Model 
Condition and Filter option on the Contingency Options Tab.  You can open a dialog to define Model Filters or 
Conditions by right-clicking on the Contingency Definition Display and choosing Define Model Criteria. 

Status  

Three options are available for this field 

• CHECK : The action will be executed only if the Model Criteria is true.  It will also be executed if no model 
criteria is specified.  This is the default setting 

• ALWAYS: The action will always be executed, regardless of the Model Criteria. 

• NEVER: The action will never by executed, regardless of the Model Criteria. 

• POSTCHECK: This action is checked AFTER the other Check and Always actions have been performed 
and the load flow solution solved.  If the criteria specified for the Postcheck action are met in the resulting 
load flow solution, then this action is taken and the load flow is again resolved.  This will recursively occur 
for all Postcheck actions until either all postcheck actions hav e been taken, or the criteria for all remaining 
postcheck actions have not been met. 

Note that the Never action allows you to disable a particular contingency action without deleting it. 

Comment 

A user-specified comment string that can be associated with this action.  While this comment is not used by 
Simulator in any way, the contingency auxiliary data files will save these comments to be loaded at a later time.  
This is provided for the user to add comments regarding the action.  For example, for an action with a Model Criteria 
you may could add a sentence explaining why the action is only performed under the specified criteria. 
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Contingency Violations Display 
The Contingency Violations Display is used to list the violations that were caused by the contingency selected in the 
Contingency Records Display.  

The contingency violations display lists all the power system elements that become violated as a result of the selected 
contingency.  If you have selected a violation, you may click on the Show related contingencies button to view all 
contingencies that cause a violation on this power system element.  Clicking this button automatically moves you to 
the Lines, Buses Interface tab, and selects the appropriate power system element. 

If the contingency selected in the Contingency Records Display resulted in no violations or has not yet been 
processed, the Contingency Violations Display will display the words None Defined. This display is a type of Case 
Information Display and thus shares many characteristics and controls common to all other case information displays. 
You can sort the list of violations by any field simply by clicking on that field’s caption.  

 

By default, the Contingency Violations Display contains the following fields: 

Category 

The type of violation that occured.  If the violation is only due to the options set in Advanced Limit Monitoring, then 
the type will start with the word "Change". 

Element 

A character string that describes the element that suffered the violation.  This can either be a branch, a bus, or an 
interface.  When the element is a branch, this string provides you with three pieces of information 

• The branch that was violated 

• The terminal of the branch which had the highest loading 

• The direction of the MW flow on this branch  

Example 1: Jamie (22) > Amy (33) CKT 1 at Amy (33) 

This means that a branch connecting Jamie(22) to Amy (33) with circuit ID 1 is violated.  The violation is at the 
Amy(33) terminal.  The > indicates that the MW flow on this line is from Jamie toward Amy. 

Example 2: Xena (55) < Harley (77) CKT 1 at Harley (77) 

This means that a branch connecting Xena (55) to Harley (77) with circuit ID 1 is violated.  The violation is at 
the Harley (77) terminal.  The MW flow on this line is from Harley toward Xena. 

Value 

Indicates the value of the violating quantity. For example, if the category of the violation is Branch Amp and the 
Value field is x, then the current on the violated element is x. 

Limit 

Identifies the limit value that was violated. For example, if the category of the violation is Branch Amp and the Limit 
field is y, then the limit on the current that may flow through the element is y. 

Percent 

The actual flow value for the element as a percentage of the limit. 

Assoc. Area Name 

Lists the areas with which the violated element is associated. If the element is a branch, Area Name identifies the 
area in which each of the branch’s terminal resides. If the element is a bus, Area Name identifies the area in which 
the bus resides. If the element is an area-to-area interface, Area Name will identify the areas that the interface ties; 
otherwise, it will read N/A. 

Assoc. Nom kV 

Identifies the maximum voltage level associated with the violated element. If the violated element is a branch, then 
Nom kV lists the nominal voltage of its higher-voltage terminal. If the violated element is a bus, then Nom kV simply 
identifies the bus’ nominal voltage. If the violated element is an interface that is made up strictly of branches, Nom 
kV lists the maximum nominal voltage of its terminals; otherwise, it will appear as -9999.9. 
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Lines, Buses and Interfaces Tab 
The Lines, Buses and Interfaces Tab is somewhat the opposite of the Contingencies Tab.  This page allows the user 
to display all the buses, lines and interfaces in the case and see how many times a violation occurred on each device 
during a run of a set of contingencies.  When a particular device is selected that had at least one violation during the 
contingency run, the two pages at the bottom give the details of the analysis for the selected device. 

The Contingencies section gives a list of all the contingencies that caused a violation on the selected device during the 
analysis.  This display is very similar to the Contingency Violations Display.  While the Contingency Violations Display 
shows the elements violated under the contingency, this display shows the contingencies that caused the violation.  If 
you then select one of the contingencies in this list, the Contingency Definition section displays the actions that took 
place during the selected contingency.  Also, when you have selected a contingency from this list, you can click the 
Show Other Violations  button.  This will change your dialog to the contingencies tab and select the contingency you 
have selected, thus allow you to see other violations caused by this contingency. 

This page provides an easier way to check the contingency results when you are concerned with the results for a 
specific device in the system.  The Lines, Buses and Interfaces Tab provides a much easier tool for this kind of 
examination, as opposed to looking through each contingency on the Contingencies Tab and trying to find each 
instance of a violation on the desired element. 
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Other Contingency Actions 
By clicking the Other Actions > button on the Contingency Tab or Line, Buses, Interfaces Tab of the Contingency 
Analysis Dialog, you have access to several actions. 

 

Delete All Contingencies 

Click this to delete all the contingencies presently stored in memory. 

Clear All Contingency Results  

Click this to clear all the results of the contingencies from memory.  This will not delete the contingencies. 

Set As Reference  

Click this to set the case presently in memory as the Reference State for contingency analysis.  For more 
information on the reference state, see Contingency Case References. 

Restore Reference  

Click this to set the case presently set the present power system back to the contingency analysis reference state.  
For more information on the reference state, see Contingency Case References. 

Combined Tables 

You can now export the "Combined Tables" of contingency information and results to either an Excel spreadsheet 
or a Simulator auxiliary file. 

Contingency Violation Table 

Choose this option to create a table containing every violation found.  The table will have the contingency name 
as the first column.  The rest of the columns are determined by the columns presently being displayed in the 
Contingency Violations Display (KAL) on the Contingencies Tab. 

Contingency Definition Table  

Choose this option to create a table containing every contingency definition.  The table will have the 
contingency name as the first column.  The rest of the columns are determined by the columns presently being 
displayed in the Contingency Definition Display (KAL) on the Contingencies Tab. 

Contingency Definition Violation Table  

Choose this option to create a tagble containing a merged list of contingency definitions and violations.  The 
table will write out the name of a contingency.  Following this will be single-indented rows containing the 
contingency definition with columns determined by the Contingency Definitions Display (KAL).  Following this 
will be double-indented rows containing the contingency violations with columns determined by the Contingency 
Violations Display (KAL). This will then be repeated for each contingency. (Note: if the Contingency Definitions 
Display is hidden, then these rows related to contingency definitions will be skipped.) 

Produce Report 

To produce a detailed report of the results of the contingency analysis, click Produce Report. This will launch a 
save window that will save the information you customized on the Contingency Analysis Options: Report Writing 
page. You will also be given the option of viewing the report in Wordpad immediately after creating the file. 

Compare Two Lists of Contingencies 

Click this to open a dialog which allow s you to specify two sets of contingency analysis results to compare.  For 
more information on this comparison, see Comparing Contingency Analysis Reports. 

Filter Results Using Limit Monitoring Settings  

Click this to filter the contingency analysis results  using the present Limit Monitoring Settings.  This action will go 
through each violation for each contingency and verify that the element that was violated is set to be monitored.  If 
the element is not set to be monitored, then Simulator will flag the violation internally as inactive .  You will then not 
be able to see these violation on any of the displays, although they will still be saved in memory until you delete 
these contingencies, or reprocess them. These violations will also not be saved when you choose to save the 
contingency results. 

Because the violations are saved in memory however, you can get them back without reprocessing the contingency 
list.  To do this, change your Limit Monitoring Settings so that those violations will be set for monitoring again.  Then 
click this option again. 

Auto-fill Blank Contingency Element Comments  

Selecting this option will fill the Comment field of the Contingency actions in the Contingency Definition table with a 
copy of the contingency action definition.  The action description itself cannot be modified, but the comment can be 
modified to be more descriptive of the action being taken, for your own reference. 

Sensitivity Calculations > 

Simulator provide the PTDF tool for calculating the impact of a MW transfer on all the transmission lines in the 
system.  The Simulatator ATC tool further extends the linearized methods by integrating linearized contingency 
analysis with the PTDF calculations.  The sensitivity calculations provided here are an extension of this.  They allow 



Printed Documentation 

418 

you to ask the question, How will each contingency-caused branch or interface violation be affected by a MW 
transfer?.  Note: this calculation is not relevant for bus violations. 

Calculate OTDFs using exisiting PTDFs  

Before executing this, you must first go to the PTDF Dialog and calculate the PTDFs for the transfer direction 
you are interested in.  These PTDF values will then be used throughout the OTDF calculation.  Click this to 
calculate OTDFs for each contingency-caused branch or interface violation.  The values calculated will be a 
measure of what percent of a transfer would appear on the branch or interface after the respective contingency 
occurs.  Realize for branch violations, that the sign of the OTDF value will be relative to the direction of the MW 
flow found during the contingency analysis (see the Element description on the Contingency Violations 
Display). 

Filter out Violations Using OTDFs  

Once you have calculated the OTDFs using the existing PTDFs, you can then filter the results by clicking on 
this.  A dialog will appear for you to enter a minimum OTDF value.  All violations that have an OTDF smaller 
than this number will be flagged as inactive .  See the note above regarding the Filter Results using Limit 
Monitoring Settings  to better understand how inactive violations are treated. 
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Comparing Contingency Analysis Results 
With previous versions of PowerWorld Simulator, users have been able to perform automated contingency analysis on 
a list of contingencies.  One could then save this list and the corresponding results in a file for viewing at a later time.  
Starting in Simulator Version 7.0, you could compare the results for two separate lists of contingencies.  This 
func tionality has been integrated into the existing Contingency Analysis Dialog.  To compare two sets of 
contingencies, do the following:  

 

• Process each set of contingencies and save the results for each list in a separate file.   

• To save a contingency list, r ight click on the list of contingencies and choose Save As > Auxiliary File.   

• Choose a name for the file, and then click Save.   

• You will then be prompted to choose options for saving the contingency list to an auxiliary 
filePowerWorldScriptFiles.  By def ault, the contingency definitions themselves are saved, along with the 
contingency options.  The optional information you may choose to save are the Limit Monitoring 
SettingsLimit_Monitoring_Settings, General Power Flow Solution OptionsPower_Flow_Solution_Options, List 
Display SettingsCase_Information_Display_Options, and Contingency 
Resultsidh_Contingency_Violations_Display.  When saving the contingency results with the file, you may also 
choose to include inactive violations.   
Inactive violations are considered violations on elements for a DIFFERENT limit than what is currently being 
monitored.  For example, a branch may have an A limit rating of 50 MVA, and a B limit rating of 100 MVA.  
Consider if the B limits are being used to report violations during contingency.  A value of 75 MVA flow on the 
branch would not be reported in the contingency analysis as a violation, considering the B limit of 100 MVA is 
being used.  However, Simulator internally will flag the element as a potential violation if the limit set used is 
switched to the A rating set.  Simulator considers these types of situations as inactive violations.  These are 
kept track of to allow the user to easily switch the rating set used for reporting violations from one set to another 
and see the results immediately, without having to re-run the entire contingency set to determine the violations 
for the new rating set.  Choosing to include the inactive violations when saving an auxiliary file maintains this 
flexibility when the contingency definitions and results are read into a case from an auxiliary file. 
You can also choose for the indentifiers used in the file to be either the bus numbers or the bus name and 
nominal kV voltage. 
Note: for comparing two lists of contingency results, you MUST save the contingency results with each of the 
two auxiliary files being compared. 

 

• Click OK to save the contingencies and the results to the auxiliary file specified. 

• Once you have two different contingency result files, right click on the contingency list and choose Compare 
Two Lists of Contingency Results .  This will bring up a dialog on which you have to specify the Contingency 
Lists you are interested in comparing.  You must specify the Controlling Contingency List and the Comparison 
Contingency List.  The definitions of these two lists are found below. 

• Click on the Browse buttons to specify the two Contingency Lists you would like to compare.  You can also 
choose to use the presently open Contingency List. 

Controlling Contingency List:  

The list that controls what is displayed on the dialog.  Only contingencies that are defined in this list will be 
displayed on the form.  Only violations that occur for contingencies in this list will appear in the Violations List 
for each contingency. 

Comparison Contingency List:  

This is the list that the Controlling Contingencies will be compared to.  Comparisons will occur for those 
contingencies in the lists that have the same CONTINGENCY NAME.  Note that contingencies in the 
Comparison list whose CONTINGENCY NAME does not match one of those in the Controlling list will not be 
displayed.  Also, violations which occur in a specific Comparison contingency that do not occur in the respective 
Controlling contingency will not be displayed. 

Example: 

A user has a power system case and a list of contingencies.  The user runs contingency analysis on this 
system for this list of contingencies.  The results are saved in a file called comparison.aux.  The user now 
changes the system state, possibly adding in a 500 MW transaction between two areas.  The contingency 
analysis is run on this new state of the system for the list of contingencies.  The results are saved in a file called 
controlling.aux.  You should define the contingency results you are more interested in viewing as the Controlling 
List because this list determines what is shown on the dialog.  In this case, we are more interested in seeing the 
violations caused when the transaction is in place, so that list is defined as the Controlling List. 

The comparison of the two sets of contingencies is now done be right clicking and choosing Compare Two 
Contingency List Results.  The file controlling.aux is set as the Controlling List and comparison.aux as the 
Comparison List. 
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Now consider a specific contingency called CTG1.  In comparison.aux, CTG1 caused an overload on LINE1.  In 
controlling.aux, CTG1 did not cause any overloads at all.  Therefore, when you have selected CTG1 on the 
dialog, the Violations List will say None Defined.  This is because the Violations List only shows violations in 
the Controlling List. 

Note: if you want to see violations in file comparison.aux which are not in controlling.aux, simply define the file 
comparison.aux as the Controlling List and controlling.aux as the Comparison List. 

 

• After clicking OK on the dialog, the contingency lists will be read from the specified files.  After Simulator has 
completed reading these files, a prompt will appear which asks, Would you like to set the dialog with default 
columns for comparing contingency lists?.  It is recommended that you choose yes so that the case information 
displays on the Contingency Dialog will automatically be set to show fields that will help you compare the the two 
lists of contingencies.  For information on the default fields used when comparing contingencies see Comparing 
Contingencies List Displays. 
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Comparing Contingencies List Displays 
When comparing two sets of contingency results, there are several additional default fields added to several list 
displays which help you compare the results.  These fields are described below for the various list displays. 

 

Contingencies Records on Contingencies Tab  

Violations  

The total number of violations for this contingency under the Controlling List. 

Comp Violations  

The total number of violations for this contingency under the Comparison List. 

New Violations  

The number of violations which occur in the Controlling List which do not occur in the Comparison List. 

Max Branch % (Max Interface %) 

The highest branch (interface) violation caused by this contingency in the Controlling List. 

Comp Max Line % (Comp Max Interface %) 

The highest branch (interface) violation caused by this contingency in the Comparison List. 

Worst Branch Violation (Worst Interface New Violation) 

The worst new branch (interface) violation 

Worst Branch Violation (Worst Interface Violation) 

This is the maximum of the following two values: [Worst Increase Violation] and [Worst New Violation - 100%] 

Min Volt (Max Volt) 

The worst violation in the controlling list. 

Comp Min Volt (Comp Max Volt) 

The worst violation in the comparison list. 

Worst LowV Violation (Worst HighV Violation) 

The worst new violation. 

Worst LowV Violation (Worst HighV Violation) 

The worst violation. 

 

Contingency Violations Display on Contingencies Tab and Contingency Violations on the Lines, Buses, 
Interfaces Tab 

Value 

The value of the violation under the controlling list. 

Comp Value  

The value of the violation under the comparison list. 

Diff Value  

The difference betw een Value  and Comp Value   

Limit 

The limit of the element in the controlling list. 

Comp Limit 

The limit of the element in the comparison list. 

Diff Limit 

The difference between the controlling limit and the comparison limit. 

Percent 

The percent violation in the controlling list. 

Comp Percent 

The percent violation in the comparison list. 

Diff Percent 

The difference between Percent and Comp Percent 
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Line/Transformer (Interface) Records on the Lines, Buses, Interfaces Tab  

Violations  

This shows the number of branch (interface) violations which occurred in the Controlling List 

New Violations  

This shows the number of branch (interface)  violations which occurred in the Controlling List, but did not occur in 
the Comparison List. 

Max % Loading Cont. 

The worst branch (interface) violation in the controlling list. 

Max % Ld Cont Comp 

The worst branch (interface) violation which occurred in the comparison list. 

Worst Increased Violation 

The worst increase in a branch (interface) violation from the comparison list to the controlling list. 

 

Bus Records on the Lines, Buses, Interfaces Tab 

Violations  

This shows the number of violations which occurred in the Controlling List 

New Violations  

This shows the number of violations which occurred in the Controlling List, but did not occur in the Comparison List. 

Max Voltage Cont. 

The worst high voltage violation in the controlling list. 

Max Voltage Cont Comp 

The worst high voltage violation which occurred in the comparison list. 

Worst Max Volt CTG Change  

The worst increase in a high voltage violation. 

Min Voltage Cont. 

The worst low voltage violation in the controlling list. 

Min Voltage Cont Comp 

The worst low voltage violation which occurred in the comparison list. 

Worst Min Volt CTG Change  

The worst decrease in a low voltage violation. 
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Options Tab 
The Options Tab enables you to control many parameters that govern how the contingency analysis flags violations, 
deals with violations that appeared in the Base Case, and documents the violations in the form of a report.  

The bulk of the Options Tab is occupied by a four-page notebook, each page of which concerns a different aspect of 
the contingency analysis. These tabs are: 

 

• Modeling 

• Advanced Limit Monitoring  

• Advanced Modeling  

• Report Writing 

• Miscellaneous  

 

Please see the corresponding help sections for assistance with each tab. Once you have finished setting the options 
for the contingency analysis, click Set Options . If, at any time, you wish to revert to the set of options that were 
defined the last time you clicked Set Options  (or, if you have never clicked Set Options , to the option settings that 
existed when the Contingency Analysis Dialog first opened), click Reset. 
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Options Tab: Modeling 
Calculation Method 

The calculation method defines how the load flow is solved during the contingency analysis.  By default, Simulator 
uses a Full AC Power Flow for each contingency.  For a large set of contingencies and a large case, this can take 
some time to complete.  Alternatively, you can now choose to solve the load flow using either Linearized Lossless 
DC or Linearized Lossless DC with Phase Shifters methods.  These two methods will both solve a set of 
contingencies much faster than the full AC load flow.  The Lossless DC methods utilize sensitivities of devices to 
calculate the load flow in a linear fashion.  The only difference between the two lossless DC methods is that the 
normal method treats all phase shifters as free-flowing, while the method with phase shifters will hold all in-service 
phase shifters at their present MW flow value. 

Limit Monitoring Settings  

Click this button to open the Limit Monitoring Settings Dialog to change the limit settings for monitored elements.  
See Limit Monitoring Settings for more details. 

For DC methods, allow amp limits by assuming a constant voltage magnitude  

If a Lossless DC calculation method has been selected from the Modeling Tab, this option will become available.  If 
checked, Simulator will allow converting MVA limits to Amp limits by assuming constant voltage magnitudes based 
on the base case full AC load flow operating point just prior to the contingency calculations. 

Retry solution using the Robust Solution Process after a contingency solution failture 

Checking this option will force the contingency analysis routine to attempt a robust solution following the failure of a 
standard Newton-Raphson solution.  The robust solution attempt does not guarantee convergence, but will attempt 
to slowly approach a convergence solution if possible. 

Use specific solution options for contingencies 

When checked, Simulator will use a different set of Solution Options when solving the contingencies defined in the 
contingency set.  To define the solution options used during the contingency analysis, click the Define 
Contingency Solution Options  button to open the Contingency Solution Options Dialog. 

Make-Up Power 

When solving a contingency, the make-up power defines how the post-contingency solution accounts for the 
change in system losses, generation, and load.  There are three options for this make-up power. 

Determine make-up using: 

Area Participation Factors specified below 

Simulator models this by creating a temporary Super Area for each island in the system (note: any area which 
spans two islands is excluded.)  The Super Area then is used to dispatch generation MW outputs in the system.  
The values specifying the CTG Make Up Gen for each area are used to determine the contribution of the make-
up power from each area.  Generators inside of an area then contribute to the area's participation according to 
their own participation factors. 

Generator Participation Factors From Entire Case Directly 

Simulator models this by creating a temporary Super Area for each island in the system(note: any area which 
spans two islands is excluded.)  The Super Area then is used to dispatch generation MW outputs in the system.  
Generators throughout each island contribute according to their participation factors. 

Same as Power Flow Case 

This just uses the area interchange options specified in the normal power flow. 
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Options Tab: Advanced Limit Monitoring 
The Identify Violations Tab allows you to shape how limit violations are detected. 

 

Never report violations if… 

This section controls the reporting of violations that should NEVER be reported.  You may specify the minimum 
change (delta) in branch flow increase, voltage change, and interface flow increase which must be met before a 
device is reported as violating a limit. 

Always report as a violation if… 

This section allows you to specify the minimum change in flow or voltage at which point any device meeting the 
minimum change requirement will ALWAYS be reported, EVEN if the actual device limit (flow or voltage) is NOT 
violated.  In other words, these options allow the reporting of large changes in flow or voltage, even if the device's 
actual limit is NOT itself violated. 

Re-reporting of base case violations  

This section controls the reporting of  Base Case violations. Because the concern of contingency analysis often is to 
identify those limitations that result directly from a particular outage or event, you may desire not to report all 
violations that were present in the Base Case with each contingency-specific set of violations. These options allow 
you to specify just how much of the Base Case violation information to report for each contingency. It gives you 
three options: 

Do not report Base Case violations  

When this option is checked, any element that was violated in the Base Case is omitted from the set of 
violations listed for each contingency. 

List all Base Case violations for all contingencies 

When this option is checked, all elements that were violated in the Base Case are included in the s et of 
violations listed for each contingency. 

Use these criteria 

When this option is checked, only those elements that were violated in the Base Case and that meet the four 
criteria listed below will be listed with the contingency-specific violations. The four criteria include: 

Minimum % increase in line/transformer flows: Only those branches that were violated in the Base Case 
whose flow has increased by at least this amount as a result of the 
contingency will be listed as contingency violations. 

Minimum per-unit decrease in low bus voltage : Only those bus voltages that were violated in the Base Case 
that have decreased by at least this amount as a result of the contingency 
will be listed as contingency violations. 

Minimum per-unit increase in high bus voltage : Only those bus voltages that were violated in the Base Case 
that have increased by at least this amount as a result of the contingency 
will be listed as contingency violations. 

Minimum % increase in interface flows: Only those interfaces that were violated in the Base Case whose 
flow has increased by at least this amount as a result of the contingency 
will be listed as contingency violations. 
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Options Tab: Advanced Modeling 
Define Contingency Blocks and Global Actions  

A contingency block stores a list of contingency actions and has a name (or label) associated with it.  A contingency 
block can then be called from a contingency record.  This allows you to define a block of common actions you wish 
to have processed during several different contingencies, and then assign the block to each contingency instead of 
constantly redefining the same actions for each contingency. 

A global action is an action that will automatically be processed as part of EACH contingency.  Thus if you have 
actions that are to be performed in every single contingency you define, you can insert it once in the global actions 
list, and Simulator will automatically use the defined action for every contingency it processes. 

Define Model Expressions  

Clicking this button brings up a list of the model expressions.  You may then insert a model expression by right-click 
on the list and choosing Insert.  This will bring up the Define Model Custom Expressions dialog. 

Define Model Conditions  

Clicking this button allows you to define model conditions. 

Define Model Filters 

Clicking this button allows you to define model filters. 

Define Bus Throw Over Records  

Clicking this button allows you to define load throw over records in the Bus Load Throw Over Records list display. 

Define Generator Maximum MW Responses in Post-Contingency 

Clicking this button opens a list of generators, with a column for entering the contingency maximum response. 

During the post-contingency power flow solution, a user may now enter a MW amount specifying the maximum 
amount of generator response from a generator.  By default, these values are blank.  If you enter a value in this 
column, then the generator response will be limited to this absolute MW response (either upwards or dow nwards). 

Note: The user may also add a column called CTG Max Response % to the generator display.  When entering data 
in this column, the CTG Max Response MW values will be set at a respective percent of the maximum MW output of 
the generator.   If a generator’s maximum MW output is less than or equal to zero, then the Maximum Response will 
always be set to zero. 

Define Generator Line Drop and Reactive Current Compensation 

Clicking this button opens a list of generators, with a column for entering line drop and reactive current 
compensation data. 

Line Drop and Reactive Current Compensation represent an alternative method for performing generator voltage 
control.  While on LDC/RCC control, the generator will vary its MVAR output in a manner that maintains the bus 
voltage at a fictitious bus that is a user-specified electrical impedance of XLDC_RCC away from the generator.  This 
is call Line Drop Compensation when the impedance specified is positive, and Reactive Current Drop 
Compensation when the impedance specified is negative. 

The impedance is specified by entering a value for XLDC_RCC and the setpoint voltage is the same as used when 
regulating a generator in the more traditional manner. A generator will perform LDC/RCC control when it meets the 
following conditions. 

• AVR = YES 

• Use LDC_RCC = YES 

Please note that if any generators at a bus are set to Use LDC_RCC, then this action will disable all traditional AVR 
control for generators at that bus.  Other generators operating on LDC/RCC control are allowed, but no traditional 
AVR. 

As a third special setting, you may also set the field "Use LDC_RCC" to "PostCTG" for use in contingency analysis.  
When a generator is set to PostCTG, then while implementing the post-contingency power flow the generator will 
change the Use LDC_RCC value to "YES" thereby activating this new voltage control method for the generator.  
After the reference state is restored in the contingency analysis however, the generator will return back to a setting 
of PostCTG. 

Post-Contingency Auxiliar y File 

The auxiliary file specified here is loaded at the start of each contingency.  In this way, very specialized post-
contingency settings can be specified.  An example use of this feature could be changing the Generator voltage 
setpoints or AVR status for the post-contingency solution or changing generator AGC status for the post-
contingency. 

Note that presently you should only enter data in the post-contingency auxiliary file that is stored with the 
contingency reference state.  Only these values will be "reset" when restoring the reference state.  In the future, 
Simulator will be updated so that an additional auxiliary file can be specified which is read when the contingency 
reference state is restored.  This auxiliary file could then undo changes that are out-side the parameters saved with 
the reference state. 
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Values presently stored in the reference state for contingency analysis are: 

Bus State  

Voltage magnitude 

Voltage angle 

Boolean stating whether any load exists at the bus (this is used because some of the contingency actions such 
as "MOVE GEN" will create a fictitious load if there is no generation at the destination bus to merge with.) 

Switched Shunt State  

in or out of service 

Nom Value MVAR 

Control Mode (FIXED/DISCRETE/CONTINUOUS) 

Nom Value MW 

Load State  

in or out of service 

Constant power MW and MVAR components of load 

Constant current MW and MVAR load, assuming one per unit voltage 

Constant impedance MW and MVAR load, assuming one per unit voltage 

mwscale 

mvrscale 

Line State  

in or out of service 

bypassed or not 

whether transformer was on control 

tap ratio 

phase shift 

Gen State  

In or out of service 

the MW output 

the MVAR output 

Maximum MW Output 

Minimum MW Output 

Voltage Setpoint 

AGC status (YES/NO) 

AVR status (YES/NO) 

Line Drop Compensation Impedance 

Line Drop Compensation Status (YES/NO/POSTCTG) 

Area State  

Unspecified MW Transactions 

MWScale 

MVRScale 

AGC Status 

Model reactive power for DC methods by… 

When you choose to use one of the Lossless DC calculation methods, you can also specify how to handle changes 
in reactive power during the calculations.  The lossless DC methods are based on the real power MW in the system, 
thus an assumption needs to be made about the reaction of the MVAr flows during the linear calculations.   

The choices are: 

Ignoring reactive power 

Reactive power is completely ignored.  This results in the MW flow only being compared to the limits of the 
elements in the system.  It is important to recognize this fact, as branch and transformer limits are usually given 
in complex power (MVA) ratings.  Thus ignoring reactive power results in comparing active power flow (MW) to 
total complex power limits (MVA.) 

Assuming constant voltage magnitude  
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One way to include reactive power in the linearized DC results is to assume the voltage magnitudes remain 
constant during the linearized DC contingency analysis.  Thus the MW flows are determined from the linearized 
calculations, and the MVAR flows are calculated from the resulting flows and constant voltage magnitudes.  
Thus you will still receive an approximate complex power flow on each element (MVA), which can then be 
directly compared to the complex power limit of the element. 

Assuming reactive power does not change  

A second way to include reactive power in the linearized DC results is the assume the reactive power 
magnitudes remain constant during the linearized analysis.  Thus the MW flows are determined from the 
linearized calculations, and the complex power flow of each element can be approximated using the calculated 
MW flows and the assumed constant MVAR flows from the base case.  This again allows the approximate 
complex flow on each element to be compared to the complex power limit of the element. 

Model Condition and Filter options  

This section allows you to choose how assumptions about Model Conditions and Model Filters are made during the 
contingency analysis.  You can specify to have each Model and Filter verified for the contingencies, or to assume 
that the Models and Conditions are either always true or always false. 
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Options Tab: Report Writing 
Simulator can produce a report that details the results of the contingency analysis (see Contingency Analysis 
Summary Tab to see how to generate the report). The Report Writing Tab allows you to control what goes in that 
report. By default, the report will identify each contingency, whether or not it could be solved, and what violations 
resulted from it. By selecting options on this tab, you can include additional information in the report. 

 

Optional Report Contents  

Case Summary 

The case summary prints the Case Description and then tallies the number of different power system 
components in the model. 

Option Settings 

If this item is checked, the report will list each of the options selec ted on the Options Tab of the Contingency 
Analysis Dialog. 

Monitored Areas, Monitored Zones 

If either of these items is checked, the report will identify the areas and/or zones in which Simulator has looked 
for limit violations, and over what voltage ranges. 

Line Flow, Interface Flow, and Bus Voltage Extremes 

If one of these items is checked, the report will list the worst-case line flows or voltages seen for each 
monitored element during the contingency analysis. None, one, two, or all three of these can be chosen at one 
time. 

Base Case Outages 

If this item is checked, the report will list the limit violations that existed in the Base Case. 

All 

Selecting this option will display all of the other options. Although all of the other options will be activated, none 
of the other options will be checked. 

 

Identify buses by 

This setting determines how the buses are listed in the data stored in the report.  You can choose to have the buses 
displayed by number or name only, or by a combination of the number and name. 

Show the actions involved in each contingency 

If this box is checked, the definition of each contingency will be included in the report. The definition of each 
contingency simply identifies the actions that were implemented as part of the contingency. 

Report only contingencies that cause violations  

Checking this option will cause only the contingencies that cause violations to be shown in the report. Any 
contingency that did not cause a violation will not be included in the report. This option is useful if you wish to limit 
the size of the contingency report. 

Report only limit type with violations for each contingency 

Checking this option will result in reporting only the contingency violations of the type checked in the Limit Type 
Violations to Include box. 

Report Inactive Violations and show all Rating Sets  

When this box is checked, all violations that are normally being ignored during the contingency analysis (for 
example, base case violations) will be written to the report.  Included with this option is the ability to show the 
different rating sets for each violated element. 

Limit Type Violations to Include  

Check the boxes of the types of violations you would like to be written to the report.  This corresponds to the option 
above labeled "Report only limit type with violations for each contingency". 

Maximum Violations of a single type to report 

Enter the value of the maximum number of violations of a single type to be written to the report. 

Create database-friendly tables 

Checking the create database-friendly tables box will create three additional files for viewing contingency results: 
FILENAME_ctgelem, FILENAME_ctgviol, and FILENAME_ctgstat where FILENAME is the name of the file where 
the main report is saved. The user can choose which symbol to use to separate the columns by choosing a 
delimiting symbol. These files can be easily imported into a database or spreadsheet program such as Access or 
Excel as delimited text files, where they can be analyzed more rigorously. These files will be automatically created 
and saved in the same folder as the main report. 
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Options Tab: Miscellaneous 
Automatically load the contingency file when you load the case 

If this option is checked, then the file will be loaded whenever you load this case.  This will work only if the 
contingency file and the case file are located in the same directory.  This option is not available to you until either 
you load a contingency file from disk or save the current list of contingencies to disk. 

Always save results with the contingency list when you save it to a file  

If this option is checked, the violation results for each contingency will also be stored in a file when the list of 
contingencies is saved to a file.  This allows for recovering the results of a contingency analysis run for a case, 
without reloading and re-running all the contingencies saved in the file. 

Save contingency analysis definitions/results in the case PWB file  

If this option is checked, the contingency definitions and any processed results will be saved with the load flow case 
in the PWB file when you save the case. 

Setting Reference Case when Contingency Analysis is Opened 

These options determine how the reference case for the contingency analysis is treated each time you re-open the 
contingency analysis.  The first time you open the contingency analysis tool, Simulator stores the current state of 
the load flow case as the reference case for the contingency analysis results.  However, each subsequent time you 
open the contingency analysis dialog in the same Simulator session, Simulator needs to know how to set the 
reference state for the case.  The choices are: 

Always set reference case to the current case 

This option will always assume that any changes you have made to the load flow case since the contingency 
analysis was last opened should be applied, and will store the current state of the load flow as the new 
reference state for the contingency analysis. 

Always use the existing contingency analysis reference case 

This option will assume that the original reference case stored when the contingency analysis tool was 
originally launched should always be the reference state for the contingency analysis.  This means that any 
changes that have been made to the load flow  case since the initial launch of the contingency analysis will be 
lost, as the contingency analysis tool will reset the load flow state to the originally stored load flow state stored 
with the first contingency analysis instance. 

Prompt the use whenever the Contingency Analysis For is opened 

When this option is checked, you will always be prompted when you re-open the contingency analysis following 
the initial instance.  You will then have the option to choose from one of the two previous settings, to either set 
the reference state to the current case, or use the existing reference case currently stored with the contingency 
analysis tool. 
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Summary Tab 
The Summary Tab of the Contingency Analysis Dialog provides additional information on the status of the contingency 
analysis run, allows you to start, pause, resume, and abort the contingency run. The top half of the Summary Tab 
charts the progress of the contingency analysis run and issues warning messages when a particular contingency fails 
to solve. The next section features counters that indicate the total number of contingencies that comprise the list, the 
number of these contingencies that have been processed thus far, the number of contingencies that failed to solve, 
and the total number of violations that have been flagged. To start the contingency analysis, click Start. To pause the 
contingency analysis, click Pause. To resume a paused contingency run, click Continue . Finally, to abort the analysis, 
click Abort. 

Contingency Analysis Options  

Auto Insert Contingencies 
Simulator allows you to automatically generate a contingency list containing branch, generator and/or bus outages. To 
accomplish this, click the Auto Insert button on the Contingency Analysis Dialog. This opens the Auto Insertion of 
Contingencies Dialog. This dialog is used to produce a contingency list automatically.  

Press the Do Insert Contingencies button to generate the contingency list. Click Cancel to abort the automatic 
contingency creation. 

 

It contains the following controls: 

Automatically generate contingencies involving a… 

The options available in this box define what to add to each automatically inserted contingency element.  You can 
choose single transmission line, transformer, transmission line or transformer, generating unit, or bus contingencies. 
Choosing on of these options results in each contingency containing only one contingency of the specific type.  You 
can also define contingencies containing multiple outages by checking the Combination of… option, and then 
specifying how many of each type of element you want considered in the contingency.  When you use the 
Combination of… option, Simulator will automatically determine all possible combinations for the element types 
specified (based on the settings in Options) and create the contingencies.  Combination contingencies do not 
currently allow the inclusion of bus contingencies. 

Options  

When Simulator auto-generates the contingency records for the element types specified, the options in this section 
will further determine which elements are included and which elements are ignored. 

Delete Existing Contingencies 

When checked, any previously existing contingency records will be deleted before any automatically created 
contingencies are inserted. 

Use Area / Zone Filters 

When checked, the elements included in the auto-generated contingencies will be only elements that are within 
areas and zones defined in the Area/Zone/Owner Filters dialog.  You may edit the Area/Zone filters by clicking 
on the button as well. 

Only include branches meeting an advanced filter 

When checked, the branches included in the auto-generated contingencies will be only branches meeting 
conditions outlined by an advanced filter.  To set the conditions to be used, click the Define Branch Filter 
button. 

Only include generators meeting an advanced filter 

When checked, the generators included in the auto-generated contingencies will be only generators meeting 
conditions outlined by an advanced filter.  To set the conditions to be used, click the Define Generator Filter 
button. 

Only include buses meeting an advanced filter 

When checked, the buses included in the auto-generated contingencies will be only buses meeting conditions 
outlined by an advanced filter.  To set the conditions to be used, click the Define Generator Filter button. 

Only include elements within X buses of bus… 

When checked, only elements that are electrically within X number of buses from the specified bus will be 
included when creating the contingencies.  For example, consider bus 1 is electrically connected to bus 2, 
which is in turn connected to bus 3.  If we specify the bus to be bus 1, and choose to include only elements that 
are within 0 buses of bus 1, then the contingency record will include the branch between buses 1 and 2, and if 
desired any generators attached to bus 1.  However the branch between buses 2 and 3, and any devices 
attached to bus 2 and 3, will NOT be included in the contingency, because bus 2 is electrically 1 bus away from 
bus 1. 

To specify the bus used, you can find the bus by using the search engine.  The search engine allows you to 
search by name or number.  If you know the bus number, choose Sort by Number, and type the bus number in 
the search box.  If you know the name of the bus, choose Sort by Name, and type the name of the bus in the 
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search box.  If you are not sure of the name of the bus, you can use wildcard characters to search through the 
list of buses until you find the desired bus. 

How to name the contingencies 

This section allows you to define how each automatically inserted contingency record will be named. 

Identify … using prefix 

These four fields allow you to set a specific prefix for generators, lines, transformers and buses so that you can 
easily determine what type or types of contingencies are modeled in the auto-generated contingency records.  
By default, the prefixes are G for generators, L for lines, T for transformers and B for buses.  However, you can 
change thes e prefixes to any character or set of characters you wish. 

Identify buses by 

This field allows you to specify whether each contingency is labeled using the bus numbers, bus names, or both 
as identifiers.  Whichever type of identifier you choose here will be combined with the defined prefixes to 
uniquely define the individual contingency elements within each auto-generated contingency record. 

Include Nominal Voltages 

This check-box is used to include the nominal voltage of the bus in the contingency label. 

Press the Do Insert Contingencies button to generate the contingency list. Click Cancel to abort the automatic 
contingency creation. 
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Loading Contingencies From a File 
Simulator can load contingency definitions from a text file. The contingencies may be specified in one of three formats 

• Simulator Auxiliary File Format (*.aux) (also see Contingency Subdata) 

• Simulator Version 5-7 Contingency File Format (*.ctg) (see the old users manual, or contact PowerWorld 
Corporation) 

•  PTI PSS/E-formatted Contingency Files (*.con).   

To load contingencies from a text file, click the Load button on the contingency analysis dialog. A dialog box will be 
provided for you to specify the file from which to load the contingency records. Specify the file type in the Files of Type 
dropdown box, and select the appropriate file. If contingency records have already been defined for the case with 
which you are working, you will be asked if you wish to delete the existing contingencies. Respond affirmatively to 
delete the existing contingencies before adding the new ones from the specified files. Otherwise, click No, and the 
contingencies loaded from the file will be appended to the already existing list. 
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Saving Contingency Records to a File 
To save the contingency records you have defined for a case, either click the Save to File button on the contingency 
analysis dialog or select Save Contingencies to File  from the local menu of the contingency records display.  

 

Simulator can save contingency definitions to a text file. The contingencies may be specified in one of three formats 

• Simulator Auxiliary File Format (*.aux) (also see Contingency Subdata) 

• Simulator Version 5-7 Contingency File Format (*.ctg) (see the old users manual, or contact PowerWorld 
Corporation) 

•  PTI PSS/E-formatted Contingency Files (*.con).  This format is used in PSS/E versions 23 – 29.   

To specify the format for the contingency file, set the Save As Type  option accordingly. 

 

Note that there are limitations when saving to the Simulator Version 5-7 format or the PTI PSS/E formatted files.   

Limitations on the Simulator Version 5-7 format 

• Does not support the actions SET or CHANGE.   

• Does not support the action MOVE, except for Loads. 

• Does not support any actions regarding an Interface 

• Does not support any actions regarding a Bus 

Limitations on the PTI PSS/E formatted files 

• Does not support any actions regarding an Interface 
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Contingency Case References 
Contingency analysis always stores a Reference State or pre-contingency state that is used throughout contingency 
analysis.  Prior to solving a contingency, this reference state is always loaded into memory, so that all contingencies 
start from a common Base Case.   

 
Defining the Reference State 

The reference state is initially defined as the power system state that exists at the moment that the first contingency 
record is defined for your system, either through loading contingencies from a file, creating them individually, or 
auto-inserting them.  To change the reference at a later time, you may choose the Set Reference  option from the 
Other Actions > button on the Contingencies Tab of the Contingency Analysis Dialog. 

During automatic processing of the contingency list, the reference state is always loaded into memory prior to the 
execution of each contingency, so that all contingencies start from a common Base Case.   Furthermore, at the end of 
the automatic processing, the system is set back to the reference state.   

The reference state is always stored in Simulator after the first instance of opening the contingency analysis form.  
Therefore, opening the contingency analysis again may result in a prompt from the program.  This prompt will ask you 
if you wish to set the contingency analysis reference state to the current state of the system (in case you have made 
changes since the last contingency analysis run), or if you wish to keep the existing contingency analysis reference 
state (which was set by previously opening the contingency analysis dialog.)  Note that if you choose the second 
option, any changes you may have made to the case outside of the contingency analysis will be lost, as the reference 
state stored with the contingency analysis tool will reset the system state to the reference state. 

 

When you solve contingencies one at a time, you may choose between the Solve Selected Contingency and Solve 
and Set As Reference  options from the Contingency Record Display's local menu.   

Solve Selected Contingency will cause Simulator to first load the reference state into memory, and then execute the 
contingency.  The system state will then reflect the power system flows of this post-contingency state.  You may then 
modify the power system in any manner you wish, but realize that prior to solving another contingency, Simulator will 
reset the system state to reference state.  The advantage of this approach is that you can implement a contingency 
and then modify the system looking for possible actions that might mitigate violations caused by this contingency.  
These modifications will then be removed as soon as you move to the next contingency. 

Solve and Set As Reference  acts the same as Solve Selected Contingency with one exception.  After executing the 
contingency, the post-contingency state is automatically set as the reference state.  As a result, all subsequent 
contingencies will use this as the Reference State. 

Fault Analysis  

Fault Analysis  

Fault analysis can only be performed when Simulator is in Run Mode.  There are four ways to start a fault analysis 
study: 

 

• From the Options/Tools  menu, select Fault Analysis … 

• From the Run Mode Toolbar, click the Fault button 

• Right click on a bus and choose Fault… to perform a fault analysis at that bus 

• Right click on a line and choose Fault… to perform a fault analysis at that point on the line 

 

All four of these options will open the Fault Analysis dialog.  If you opened the dialog by right-clicking on a bus or line, 
the fault information on that bus or line will already be filled in.  If you selected the Fault Analysis… option from the 
Options/Tools  menu or the Fault toolbar button, the information about the location of the fault will need to be 
provided. 
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Fault Analysis Dialog 

The Fault Analysis  dialog can be used to perform a fault analysis study on the currently loaded power system.  A fault 
study can only be performed while Simulator is in run mode, since the load flow must be validated and solved before a 
fault study can be calculated.  If you are observing fault analysis results in the fault analysis dialog and switch to edit 
mode, the dialog will automatically be closed and the fault analysis results will be cleared from memory. 

Simulator stores fault data in the PowerWorld binary file along with the load flow data, but by default most other load 
flow formats store fault data in separate files.  The fault data can be stored in and loaded from an external file, but if no 
fault data is present in a PowerWorld binary file or loaded from an external file before a fault analysis is run, Simulator 
will use the load flow data as default values for the analysis.  Fault data values can also be modified for specific 
devices by opening a specific device's information dialog and looking at the Fault… tab.  Devices that require 
sequence specific data for fault analysis are buses (for sequence load injections), generators, switched shunts, 
transmission lines, and transformers. 

NOTE: New in version 10! 

Phase shifts in a fault analysis calculation can be very important for calculating the correct fault currents and voltages 
throughout the system.  The phase shifts that are applied for transmission lines and transformers are taken from the 
load flow values of phase entered with each specific transmission element.  While transformers can have their 
transformer configurations specified (i.e. Delta-Wye, Grounded Wye-Delta, etc.), these configurations are NOT used to 
determine phase shift angles, ONLY to determine the proper grounding on each side of the transformer.  The phase 
shifts that are applied are taken from the load flow data phase values for the transmission elements.  If no phase shifts 
are entered in the load flow data, the fault analysis will treat all elements as having zero phase shift.  Phase shift 
values can be entered manually for each transmission element, but are also included in most load flow formats and 
will be read into Simulator when loading a load flow data file. 

Note that the bus chosen for the fault is always set to a 0 degree reference, and all other buses are shifted according 
to this reference. 

 

Fault Data 

The Fault Data tab is where the type and location of the fault are specified, and where the results of the fault analysis 
can be seen in tabular format. 

Fault Location 

Choose to perform the fault at a bus location, or at a point somewhere on a line.  If Bus Fault is selected, the only 
information needed is the bus number, which needs to be entered in the Fault Bus field.  If an in-line fault is desired, 
the from and to bus numbers, circuit ID, and location of the fault (entered in percent of total line length, measured 
from the From Bus) will need to be given.  Selecting the Fault… option from the bus or line local menus will 
automatically set up the Fault Location fields. 

Fault Type  

Choose from one of four types of fault to calculate at the fault location: 

Single Line - to - Ground Computes a single phase line - to - ground fault using a user defined ground 
fault impedance.  The phase evaluated is always referenced as phase A. 

Line - to - Line Computes a line - to - line fault, assuming an impedance of 999 + j999 to 
ground.  Phases B and C are always referenced as the faulted phases. 

3 Phase Balanced Balanced three-phase line fault - to - ground using a user-defined ground fault 
impedance. 

Double Line - to - Ground Computes a line - to - line - to - ground fault, using a user defined ground fault 
impedance. 

Current Units  

Allows you to choose to observe the fault currents in per unit current or actual Amps. 

Oneline Display 

The string grids at the bottom of the Fault Analysis  dialog will display the fault results in tabular format, but the 
results can also be viewed graphically on the oneline diagram by selecting an option from this group of options.  
Any of the three phase values can be selected for display individually, or all three phases can be viewed 
simultaneously.  Viewing all three phases of information simultaneously can result in an abundance of information 
on the diagram at one time, so selective placement of the necessary bus and line fields may need to be considered 
when planning on viewing the fault analysis results graphically on the oneline diagram. 

The fields necessary on the oneline diagram for display of the fault analysis results are: 

• Bus Voltage  and Bus Angle  fields need to be present for a bus.  When choosing to view fault analysis results, 
these two fields will be identified, and the actual load flow values will be replaced by the fault phase voltages (in 
per unit) and angles (in degrees). 
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• AC Line MW Flow and AC Line Mvar Flow  fields need to be present for a line.  These two fields will be 
identified, and the MW and Mvar values will be replaced by the fault phase current magnitudes (in Amps or per 
unit) and angles (in degrees). 

• Gen MW Output and Gen Mvar Output fields need to be present for a generator.  These two fields will be 
identified, and the MW and Mvar values will be replaced by the generator terminal fault phase current 
magnitudes (in Amps or per unit) and angles (in degrees). 

Fault Current 

Displays the magnitude and angle of the current at the fault location during the fault. 

Calculate 

Pressing this button will run the fault analysis.  In order for the results to be calculated, the power flow has to be in a 
solved state for the results to have any relevance.  Therefore the first thing performed when Calculate  is pressed is 
to solve the power flow.  You can observe this by viewing the Message Log when you run the calculation.  Once the 
power flow has been solved, then the fault analysis calculations are run and the results displayed. 

Clear  

Pressing Clear  will clear any fault analysis results currently in memory and displayed on the dialog. 

There are also five informational displays at the bottom of this dialog for showing the fault analysis calculation results: 

Buses  

Lines  

Generators 

Loads  

Switched Shunts  

 

Fault Options  

The Fault Options  tab is where an impedance to ground can be defined at the fault location, where fault data can be 
loaded from or saved to an external file, and zero-sequence mutual impedances can be viewed or changed. 

Fault Impedance  

For any of the fault types calculated, a Fault Impedance can be included.  A Resistance and Reactance can be 
entered as the path to ground of the fault, and is taken into account when calculating the fault current used to 
determine the rest of the fault values. 

Load Data / Save Data 

These two buttons allow loading from and saving to external files.  Currently the two types of files supported are 
PSS/E Sequence Data files (.seq) and PowerWorld Simulator Auxiliary files (.aux).  Either one of these formats can 
be loaded and saved. 

Zero Sequence Mutual Impedances 

Zero sequence mutual impedances can be stored and modified in the Mutual Impedance Records table.  Usually 
the zero sequence mutual impedance parameters are read in from a sequence data file.  However, it is also 
possible to insert and delete mutual impedance records from this table by right-clicking in the table and selecting 
Insert or Delete from the local menu.  When Insert or Show Dialog are chosen from the mutual impedance table 
local menu, the Mutual Impedance Record dialog will open, from which a mutual impedance record can be inserted 
or modified. 

Pre-Fault Profile  

Changing this option determines the pre-fault voltage profile to be used for the fault analysis calculations.  The pre-
fault profile selection affects the sequence Y-bus values, fault currents, and post-fault voltages. 

Profile Options 

Additional pre-fault profile options are available when the pre-fault profile selected is either Flat IEC-909 or Flat 
Classical. 

XF Turns Ratios Set to 1 If checked, all transformer tap ratios are assumed at their nominal tap position. 

Line Charging Set to 0 If checked, line charging capacitance is ignored in all calculations. 

Shunt Elements Shunt elements (bus and line shunts) can optionally be treated normally, 
ignored in the positive sequence only, or ignored in all sequences. 

IEC Parameters This option only applies to the Flat IEC-909 pre-fault profile.  The pre-fault 
voltage magnitude can be specified for each bus.  In addition, a generator 
power factor angle (in degrees) can be specified for use when generator 
currents need to be calculated based on bus voltage and power (real and 
reactive) delivered by the generator. 
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Matrices 

The Matrices  tab is where the positive, negative and zero sequence admittance matrices can be viewed for the fault.  
This tab is only visible when a fault has been calculated.  The three pages on the Matrices tab each have the same 
functionality as other Case Information displays.  The purpose of each display is to show the admittance matrix for the 
specified sequence.  One of the most important features of these matrix displays is the ability to right-click on the 
display to bring up additional display options in the local menu.  Perhaps one of the most important options on the 
local menu is the ability to export the Y-bus admittance matrix to a Matlab M file, which allows import of the matrix into 
Matlab for additional manipulation, such as inverting the matrix to get the equivalent sequence Z-bus matrix. 
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Fault Analysis Bus Records  

This dialog has the same functionality available as Case Information displays.  The purpose of this display is to 
tabulate the results of the fault analysis calculations.  By default, the phase voltage magnitudes and angles are 
displayed.  In addition, the sequence voltages and angles can also be added by modifying the display using the 
Display/Column Options dialog. 
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Fault Analysis Generator Records  

This dialog has the same functionality available as Case Information displays.  The purpose of this display is to 
tabulate the results of the fault analysis calculations.  By default, the phase current magnitudes are displayed for the 
terminal end of the generator.  The phase current angles, as well as the sequence current magnitudes and angles, can 
be added by modifying the display using the Display/Column Options dialog.  The magnitude and angle direction 
reference is always given as out of the generator and into the terminal bus. 
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Fault Analysis Line Records  

This dialog has the same functionality available as Case Information displays.  The purpose of this display is to 
tabulate the results of the fault analysis calculations.  By default, the phase current magnitudes are displayed for each 
end of the branch.  The phase current angles, as well as the sequence current magnitudes and angles, can be added 
by modifying the display using the Display/Column Options dialog.  The magnitude and angle direction reference is 
always given as out of or away from a bus.   
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Mutual Impedance Records  

The Mutual Impedance Records  table is a Case Information Display and can be customized like any other case 
information display.  The zero sequence mutual impedance records displayed in this table can be either read from a 
sequence data file, or created manually by choosing Insert… from the local menu.   

 

The common fields displayed on the Mutual Impedance Records display are: 

L1 From Bus, L1 To Bus, and L1 Ckt ID 

These fields represent the from bus number, to bus number, and circuit identifier for the first mutually coupled line. 

L2 From Bus, L2 To Bus, and L2 Ckt ID 

These fields represent the from bus number, to bus number, and circuit identifier for the second mutually coupled 
line. 

Mutual R, Mutual X 

The mutual impedance, in terms of the resistance and reactance (per unit).  The dot convention of the mutual 
impedance assumes the From bus of each line to be the dotted terminal, with the sign of the mutual impedance 
values being set according to this convention. 

L1 Mut. Start, L1 Mut. End 

The starting point and ending point of the mutually coupled portion of the first mutually coupled line.  The values are 
between 0 and 1, and represent a position on the line as a percentage of the total line length.  These fields are only 
used when evaluating an in-line fault to determine the affect of the mutual impedance on each side of the fault point 
on the line. 

L2 Mut. Start, L2 Mut. En d 

The starting point and ending point of the mutually coupled portion of the second mutually coupled line.  The values 
are between 0 and 1, and represent a position on the line as a percentage of the total line length.  These fields are 
only used when evaluating an in-line fault to determine the affect of the mutual impedance on each side of the fault 
point on the line. 
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Mutual Impedance Record Dialog 

The Mutual Impedance Record dialog can be used to modify or add zero sequence mutual impedance records to the 
sequence data for a case.  When the dialog is opened using the Show Dialog… option from the Mutual Impedance 
Records table local menu, the information for the record selected in the table will automatically be displayed.  The 
information for that record can be modified, or a different record can be selected by selecting different lines in the Line 
1 and Line 2 Identifier sections.  Note that the drop down list of  buses for the From Bus fields always contain all the 
buses in the case.  However, once the From Bus has been selected, the drop down list of the corresponding To Bus 
field will only contain bus numbers of buses that are connected to the From Bus.  If a mutual impedance record 
already exists for the lines selected, the information for that record will be displayed.  If a mutual impedance record 
does not exist for the selected lines, then the mutual impedance fields will display default values.  When the def ault 
values are changed, and either Save or OK are selected, a new mutual impedance record is added to the data. 
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Fault Analysis Load Records 

This dialog has the same functionality available as Case Information displays.  The purpose of this display is to 
tabulate the results of the fault analysis calculations.  By default, the phase current magnitudes are displayed for the 
terminal end of the load.  The phase current angles, as well as the sequence current magnitudes and angles, can be 
added by modifying the display using the Display/Column Options dialog.  The magnitude and angle direction 
reference is always given as out of the bus and into the load. 
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Fault Analysis Switched Shunt Records  

This dialog has the same functionality available as Case Information displays.  The purpose of this display is to 
tabulate the results of the fault analysis calculations.  By default, the phase current magnitudes are displayed for the 
terminal end of the switched shunt.  The phase current angles, as well as the sequence c urrent magnitudes and 
angles, can be added by modifying the display using the Display/Column Options dialog.  The magnitude and angle 
direction reference is always given as out of the bus and into the switched shunt. 

Contouring 

Contouring 

Simulator can create and animate a contour map of various system quantities, such as voltage magnitudes and 
angles, MW transactions, transmission loading, and real and reactive load.  Such displays resemble a contour map of 
temperatures like that shown on a weather forecast.  Contouring can significantly improve understanding of a large 
interconnected system, helping identify congestion pockets and Mvar-deficient regions and providing an overview of 
how power flows through the bulk power system.  

The Contour Options Dialog controls Simulator’s contouring capabilities.  To access it, click the right mouse button on 
an empty area of the oneline and choose Contouring from the resulting local menu, choose Options/Tools > 
Contouring from the main menu, or press the Contouring button from the Run Mode toolbar. 



Printed Documentation 

446 

Contouring Options  

The Contour Options Dialog allows y ou to draw contour maps of many system quantities, such as bus voltages or 
angles, transmission line and interface MVA loadings, and transmission line and interface PTDFs.  

To acces s this dialog, click the right mouse button on an empty area of the oneline and choose Contouring from the 
resulting local menu, choose Options/Tools > Contouring from the main menu, or press the Contouring button from 
the Run Mode toolbar. The Contour Options Dialog has three tabs: the Contour Type Tab, the Contour Type Options 
Tab, and the Custom Color Map Tab. 
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Contour Type  

Object 

Simulator can contour several different values.  To specify what Simulator should contour, first choose the type of 
object; the options are Bus, Line, Interface, Area, Generator or Substation.  This selection narrows the set of 
quantities that can be contoured, which is specified in the Value dropdown box. 

Note: to contour a value for a type of object, representations of that type of object must be present on the oneline 
diagram.  Choosing to contour an object type that is not represented on the diagram will result in no contour being 
drawn on the diagram. 

Value 

Select the quantity to contour from the Value dropdown box or click the Find Value button to find the desired field.  
See NOTE at the end of this help topic. 

Current Filter 

The name of the advanced filter that is currently applied to the contour. 

Define a Filter 

If you wish for the contour to be limited to only certain devices that meet specific criteria, click on this button to 
define an Advanced Filter for the contour. 

Pixel Options  

In order to optimize the speed of drawing, the user must specify the Influence Region as well as the Contour 
Resolution.  Also, when contouring line or interface objects, the number of data points used to represent that line 
must be chosen. 

No Data Color 

This setting allows you to choose the contour color around devices that have no data for the type of contour 
selected.  The choices for No Data Color are Specific Color, Color Map Percentage, and Background Color.  By 
default, Specific Color is selected and set to white.  If you wish to change the specific color to use, click on the color 
box to the right and choose a different color from the popup dialog.  If you select Color Map Percentage, the Color 
Map % field will become enabled, and you can select a value from 0 to 100.  The value you enter will associate the 
No Data Color with the color located at that percentage in the selected color map.  Lastly, if Background Color is 
chosen, the No Data Color will always be whatever color has been set as the normal background color for the 
oneline diagram. 

Draw Color Key 

Checking this box will cause the contour to draw a color key showing which colors are mapped to which values.  
You can also give the color key a title, unit label, and specify the number of digits to display in numerical values. 

Title  

Title for the color key. 

Entry Labels  

Units of the contoured value displayed on the color key. 

Label Digits to Right of Decimal 

Number of decimal places of the contoured value displayed on the color key. 

Color Map 

Choose from various predefined color maps using the color map combo-box.  A color map, along with the values 
specified, defines how values are mapped to a color on the contour image. 

If a color map showing both high and low values is desired (such as for bus voltages), use of "Blue = Low, Red = 
High" is recommended.  If a color map showing only high values is desired (such as for line flows), use of "Weather 
Radar, Nominal to High" is recommended. 

A user may also define additional color maps by going to the Custom Color Map Tab.  

Reverse Color Map Colors 

Check this check-box to reverse the colors of the selected color map, so the low color becomes the high color, and 
vice versa. 

Brightness 

Modify the brightness track bar to change the brightness of the color map. 

Use absolute value  

Check this check-box to use the absolute values of the quantity selected at the Value dropdown box (above). 

Ignore Above Max 

Check this check-box to completely ignore values above the maximum percentage.  This means that data which is 
larger than the Max % will not be used in calculating the contour image. 
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Values 

These values along with the color map define how to convert your values into a color for the contour.  The values 
are: 

Maximum  The largest value allowed in the contour.  All values above this will be mapped 
to the highest color.  This value corresponds to 100% in the color map. 

Break High This value is used by some color maps to highlight a lower limit.  This value 
corresponds to 75% in the color map. 

Nominal  This value is the nominal value for the contour.  Values around this will be 
mapped to the middle color.  This value corresponds to 50% in the color map. 

Break Low This value is used by some color maps to highlight a lower limit.  This value 
corresponds to 25% in the color map. 

Minimum The smallest value allowed in the contour.  All values below this will be mapped 
to the lowest color.  This value corresponds to 0% in the color map. 

Note: a representation of the color map is shown to the right of the values. 

Ignore Below Min 

Check this check-box to completely ignore values below the minimum percentage.  This means that data which is 
smaller than the Min % will not be used in calculating the contour image. 

Ignore Zero Values 

Check this box to completely ignore zero values in the contour. 

Save Contour Image  with Oneline  

Checking this box will allow a displayed contour to be saved with a oneline diagram.  If a contour is saved with a 
oneline diagram, the next time the oneline diagram is opened the contour will automatically be redrawn as well. 

Continuously Update Contours 

Normally contouring is only done on a snap shot of the power system state.  However, you can also set 
PowerWorld to automatically update the contour every time the display is redrawn.  In this way, an animation of the 
contour can be created.  If you would like to create this animation, simply check the Continuously Update Contours 
checkbox.  Note, however, that this will slow down the animation of the display, as the program must recalculate the 
contour at each step.  If this slows down your display too much, try lowering the contour resolution to speed it up. 

Note Regarding Values 

Contours of most values create an image where the color around a data object is primarily related to the value of 
only that object.  Some values however create "dens ity-like" contours, where the color is related to the sum of the 
data object's values nearby.  These include: 

• Bus / Load MW 

• Bus / Load Mvar 

• Bus / Load MVA 

• Bus / Cust Expr (Density) 

• Area / Pos Spin Reserve 

• Area / Neg Spin Reserve 
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Contour Type Options  

Object 

Simulator can contour several different values.  To specify what Simulator should contour, first choose the type of 
object; the options are Bus, Line, Interface, or Area/Zone.  This selection narrows the set of quantities that can be 
contoured, which is specified in the Value dropdown box.   

Value 

Then select the quantity to contour from the Value dropdown box or click the Find Value  button to find the desired 
field.  Note:  see Contour Type for more information. 

Define a Filter 

If you wish for the contour to be limited to only certain devices that meet specific criteria, click on this button to 
define an Advanced Filter for the contour. 

Current Filter 

The name of the advanced filter that is currently applied to the contour. 

Influence Region 

This track bar determines how far away each data point influences the contour image.  A larger influence region 
results in each data point influencing more of the contour at the expense of longer screen refresh times. 

Use Dynamic Influence Region 

Dynamic influence distance determines how far out the contour should go when determining which buses influence 
the contour value for a screen point.  The actual distance is the minimum of either 1) a common value for all screen 
points that depends upon user parameters [e.g., the dynamic region points value]), and now 2) the distance that 
includes the number of buses associated with the dynamic influence field.  The primary reason for this option is 
speed, particularly when zoomed in on dense portions of the display.  You should not see much impact on the 
contour itself. 

Contour Resolution 

This value determines the relative resolution of the contour.  Increasing the contour resolution increases the level of 
detail represented on the map but will lengthen screen refresh times.  Reducing the screen refresh time will yield 
less detail and shorter screen refresh times. 

Kind of Value  

This option allows you to choose to contour based on the Actual Value or the Density Value.  The Actual Value uses 
the weighted average of the data for computing the contour.  The Actual Value method is most commonly used for 
contouring in Simulator.  On occasion, the weighted average method does not work as well.  One example is 
contouring generator MW values.  If you have four buses in close proximity, each with 100 MW of generation, and 
compare the contour with a single bus with 400 MW of generation, the contour based on the weighted average will 
look drastically different, despite the amount of generation being the same in each region.  Using the Density Value 
option to do a weighted sum method will correct the disparity, and the contour around these two different groups of 
generation would look basically the same. 

Exaggerate Limit Violations by 

To cause even minor limit violations (values outside of 25-75%) to stand out prominently on your contour, check the 
Exaggerate Limit Violations by check-box.  Then adjust the sliding scale to modify how much the violations will 
stand out. 

Begin Fade Percentage  

While moving away from a data point, the data point’s value decays towards the "Fade to" Value.  The Begin Fade 
Percentage specifies when the contour starts to fade as a percentage of the largest distance for which this data 
point influences the contour. 

Fade to Value  

The value to which a data point's value fades as it moves away from its location. 
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Custom Color Map 

Color Map 

Choose from various predefined color maps us ing the color map combo-box.  A color map, along with the values 
specified, defines how values are mapped to a color on the contour image. 

If a color map showing both high and low values is desired (such as for bus voltages), use of "Blue = Low, Red = 
High" is recommended.  If a color map showing only high values is desired (such as for line flows), use of "Weather 
Radar, Nominal to High" is recommended. 

A user may also define additional color maps by going to the Custom Color Map Tab.  

Reverse Color Map Colors 

This check-box reverse the mapping of the color map, converting the colors corresponding to the high values into 
the colors for the low values, and vice-versa. 

Brightness 

Modify the brightness track bar to change the brightness of the color map. 

Make Discrete Color Map 

Check this check-box to make a discrete color map, that is without having smooth transitions between colors. 

Contour Type Values to Use 

These check-boxes signify which values from the Contour Type Values Tab are used by the Color Map.  There 
must be at least two contour type values checked. 

Color Grid 

The color grid on the right side of this page allows you to change the colors for each percentage breakpoint.  In 
addition, you can add or delete breakpoints as well. 

To change the color for a specific breakpoint, simply left-click on the color for the breakpoint you want to change.  
The Color dialog will open, and you can choose a new color for that breakpoint. 

To add a breakpoint, right-click on a breakpoint position above or below where you would like the new breakpoint 
inserted.  A popup menu will open, and you can select Add Above or Add Below, depending on where you wish the 
new breakpoint to be.  Simulator will insert the breakpoint, and will automatically set the color and percentage at the 
midpoint between the two breakpoints above and below the inserted breakpoint.  You can then click on the color to 
change it, or click on the percentage to type in a new value.  The new percentage value should be between the 
values of the adjacent breakpoints. 

To delete a breakpoint, right-click on the breakpoint you wish to delete, and choose Delete from the popup menu. 

Save As New 

To save the present color map as a new color map, click this button.  Then specify a name for the new color map. 

Save 

To save changes that have been made to the present color map, click this button. 

Rename 

To rename the present color map, click this button. 

Delete  

To delete the present color map, click this button. 

Store Color Maps in File  

To store all custom color maps in a file for loading into another case, click this button.  If you have saved any 
custom color maps with the current case, you will be prompted to choose a file name and location for saving the 
custom color maps. 

Load Color Maps from File 

If you have created custom color maps in a different case and saved them to a file, you can click this button to load 
those color maps into your current case. 

Distribution Factors 

Power Transfer Dis tribution Factors 

The Power Transfer Distribution Factor (PTDF) display is used to calculate the incremental distribution factors 
associated with power transfers between two different areas or zones. These values provide a linearized 
approximation of how the flow on the transmission lines and interfaces change in response to transaction between the 
Seller and the Buyer.  These values can then be visualized on the onelines using animated flows (see below for 
details).  The transaction for which the PTDFs are calculated is modeled by scaling the output of all generators on 
AGC in the source and sink areas in proportion to their relative participation factors.  Generators in the source area 
increase their output, while generators in the sink area decrease their output. 

An important aspect to consider in calculating the PTDF is how the losses associated with the transfer are allocated.  
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Simulator assumes that the Seller increases the output of its generators by 100% of the transfer amount, while the 
Buyer decreases the output of its generators by 100% minus any change in system losses.  In other words, the 
Buyer accounts for the entire change in the system losses.  Of course it is possible that a transfer may result in 
decreased system losses; for that case, the Buyer’s generation will be greater than 100% of the transfer.   

To Calculate the Power Transfer Distribution Factors: 

• Perform an initial Power Flow Solution. 

• In Run Mode, select Options/Tools > Power Transfer Distribution Factors (PTDFs) from the main menu to 
open the Power Transfer Distribution Factors Dialog. 

• Supply the requested information on the Power Transfer Distribution Factors Dialog and click the Calculate 
PTDFs  button.  The distribution factors are calculated and displayed for the element set of your choice in the 
table at the bottom of the dialog. 

The animated flows that appear on the oneline diagram may represent either actual flows or PTDF values.  To 
specify that the display should show distribution factors, click the button labeled Visualize PTDFs .  Once this button 
is clicked, the flow arrows on all open onelines will represent distribution factors, and the caption of the button will 
change to Visualize Actual Power Flows.  Click the button again to visualize actual power flows instead of 
distribution factors. 

Note that when calculating PTDF values for interfaces that include contingent elements, the PTDF values reported are 
actually what are referred to as an Outage Transfer Distribution Factor (OTDF).  See Line Outage Distribution Factors 
(LODFs) for more information. 
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Power Transfer Distribution Factors Dialog 

The PTDF Dialog enables you to control and to view the results of power transfer distribution factor calculations.  You 
access this dialog by selecting Options/Tools > Power Transfer Distribution Factors (PTDFs) from the main menu 
in Run Mode only.   

 

The dialog has the following options: 

PTDF Type 

This option allows you to choose to define a single direction PT DF using the Seller and Buyer Type  related fields, 
or to define multiple transfer directions between many different entities.  If you choose to use multiple directions, the 
Seller and Buyer Type  fields are replaced by the Direction Records display for view ing and defining directions. 

Seller Type, Buyer Type  

Distribution factors can be calculated for power transfers between combinations of areas, zones, super areas, 
participation groups, or to a slack bus.  Use the seller type and buyer type options to indicate the type of the selling 
and purchasing entities.  These fields are only present for single direction PTDF's. 

Seller, Buyer 

These dropdown boxes allow you to select the selling and buying entities.  Their contents are filled when you select 
the seller and buyer types.  These fields are only present for single direction PTDF's. 

Reverse Buyer/Seller 

Click this button to re-calculate PTDFs for the direction that is the reverse of the direction currently shown.  For 
example, if you have just calculated PTDFs for a transaction from area A to area B, press this button to calculate 
and display PTDFs for a transaction from area B to area A.  This option is only present for single direction PTDF's. 

Linear Calculation Method 

PTDFs may be calculated using either the full power flow Jacobian or only a portion of it.  If you select the 
Linearized AC Approximation option, the sensitivity of the monitored element’s flow will be calculated as a 
function of both its real and reactive power components to the voltage magnitude and angle of its terminal buses.  
When using the AC method, losses are included in the calculation.  Simulator assumes that the change in losses is 
taken care of by the Buyer. 

If you instead select the Lossless DC Approximation option, branch flow sensitivity is calculated by estimating the 
real power that flows through the monitored element only from the difference in angles measured across its 
terminals.  This method assumes that there are no losses.   

The Lossless DC with Phase Shifters Approximation option is similar to the Lossless DC, except additional 
constraints are placed on the calculations that assume that the change in flow across active phase-shifting 
transformers is zero. 

Calculate PTDFs  

Click on this button to update the PTDF values.  The results table will reveal the latest calculations. 

Calculate MW-Distance  

Click this button to open the MW * Distance Calculations  form.  This form allows you to calculate MW * Distance 
values for the transaction for which you calculated PTDFs.  See MW-Distance Calculations for more information. 

Increase in Losses 

This is a read-only field that indicates the change in system losses caused by the transfer from the selling area to 
the buying area.  The change is expressed as a percentage of the transfer amount.  This will only be non-zero when 
using the Linearized AC calculation method. 

Automatically Update  

If checked, the PTDFs are automatically updated every time the power flow is solved.  

Use Area/Zone Filters 

If this box is checked, then the results table at the bottom of the dialog will include only records associated with 
devices located in areas or zones included in the area/zone/owner filter set.   

Only Show Above % 

Restricts the result set to show only those PTDFs that exceed a specified value.  Many line-loading relief routines, 
for example, disregard elements having a PTDF of less than 5%. 

Visualize Actual Power Flows, Visualize PTDFs  

Select to toggle the onelines between showing the actual power flows and the PTDF flows.  Selecting this button 
changes the Flow Visualization field for all the visible onelines.  You can also change this field manually using the 
Oneline Display Options Dialog.   

Highlight Counter Flows 
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If this box is checked, then the PTDFs that are directed counter to the existing flows on the system are highlighted 
on the oneline using the Counter Flow Highlight Color.  Double click on the color to change its value.   

Tables of Results  

The tables of results occupy the bottom of the PTDF Dialog.  They are a set of case-information displays and thus 
share many characteristics common to all other case information displays.  The tables will show results for 
lines/transformers, interfaces, areas, zones, generators, and phase shifters.  The tables feature a local menu from 
which you can print, copy, or modify its records as well as view the information dialog of its associated element. You 
can also sort the area records by clicking on the heading of the field by which you want to sort. 

Lines/Transformers 

Shows the transaction distribution factors for the lines and transformers.  The following fields are shown: 

From Bus #, From Bus Name, To Bus #, To Bus Name, Circuit 

Identifiers for the transmission line or transformer. 

From % PTDF 

Distribution factor associated with the MW flow at the "from bus" end of the line or transformer, specified as a 
percentage of the transaction amount.   

To % PTDF 

Distribution factor associated with the MW flow at the "to bus" end of the line or transformer, specified as a 
percentage of the transaction amount. 

% Losses 

Shows the percentage of the PTDF assigned as losses. 

Nom KV (Max) and Nom KV (Min) 

Displays the maximum and minimum nominal voltages for the line.  This is useful for identifying transformers 
and which end of the PTDF relates to which nominal voltage. 

Interfaces 

Shows the transaction distribution factors for the interface records.  The following fields are shown: 

Interface Name  

Alphanumeric identifier for the interface. 

Interface Number 

Numeric identifier for the interface. 

% PTDF 

Distribution factor associated with the MW flow through the interface, specified as a percentage of the 
transaction amount.  A positive value indicates the transaction would result in an increase in the flow through 
the interface. 

Interface MW Flow  

Amount of real power flowing on the interface. 

Has Contingency 

Signifies if an element of the interface is violating a limit. 

Areas and Zones 

Shows the impact the transaction has on the losses for the area or zone.  The following fields are shown: 

Area/Zone Number and Name 

Number and name identifiers for the area or the zone 

Losses % 

Change in the losses in the area or zone, specified as a percentage of the transaction amount.  A positive 
number indicates that the transaction would result in increased losses in the area or zone, while a negative 
number indicates that the transaction would result in decreased losses.   

Gen Chg % 

Total change in all of the generators in area or zone, specified as a percentage of the transaction amount.  For 
areas, this field should show 100% in the selling area, and 100% minus the change in system losses in the 
buying area.   

Generators 

Shows the marginal participation of each generator in the transaction.  The following fields are shown: 

Bus Number, Bus Name, Gen ID 

Generator’s terminal bus number and alphanumeric identifier, and the id for the generator. 
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Area Number, Area Name 

Name and number of the generator’s area. 

Gen Change % 

Assumed participation of the generator in the transaction, specified as a percentage of the transaction amount.  
This value is directly proportional to the participation factor for the generator, provided the generator is available 
for AGC and is free to move in the specified direction (i.e., is not at a MW limit).  The generator’s participation 
factor and AGC status are modified on the Generator Dialog, which can be displayed by right-clicking anywhere 
in the record’s row in the table and selecting the Show Dialog option. 

Phase Shifters 

Shows the transaction distribution factors for the phase shifters.  This applies when using the Lossless DC with 
Phase Shifters calculation method.  The following fields are shown: 

From Number, From Name, To Number, To Name, Circuit 

Identifiers for the phase shifter. 

Status  

Indicates whether or not the phase shifter is in-service. 

Phase (Deg) 

The current phase angle of the transformer. 

XF Auto 

Indicates if the phase shifter is currently enabled for automatic control. 

Deg per MW 

This field indicates the amount of angle change, in degrees, that would be required to keep the flow across the 
transformer constant for a one MW transfer between the seller and the buyer. 

Tap Min, Tap Max 

The minimum and maximum tap positions for the phase shifter. 
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Line Outage Distribution Factors (LODFs) 

Line Outage Distribution Factors (LODFs) are a sensitivity measure of how a change in a line’s status affects the flows 
on other lines in the system.  On an energized line, the LODF calculation determines the percentage of the present 
line flow that w ill be show up on other transmission lines after the outage of the line. For example, consider an 
energized line, called LineX, whose present MW flow is 100 MW.  If the LODFs are found to be  

LODFs for LineX outage 

LineX  -100%  

LineY  + 10% 

LineZ  -  30% 

This means that after the outage of LineX, the flow on LineX will decrease by 100 MW (of course), LineY will increase 
by 10 MW, and LineZ will decrease by 30 MW. 

Similarly, sensitivities can by calculated for the insertion of a presently open line.  In this case, the LODF determines 
the percentage of the post-insertion line flow that will show up on other transmission line after the insertion. 

 

To calculate the LODFs: 

• Perform an initial Power Flow Solution. 

• In Run Mode, select Options/Tools > Other Sensitivities > Line Outage Distribution Factors (LODFs) from 
the main menu to open the Line Outage Distribution Factors Dialog. 

• Supply the requested information on the Line Outage Distribution Factors Dialog and click the Calculate 
LODFs  button. 

 

What else are LODFs used for? 

LODFs are used extensively when modeling the linear impact of contingencies in Simulator.  This is true for the 
calculation of PTDFs for interfaces which contain a contingent element, as well as when performing Linear ATC 
analysis that includes branch contingencies. 

When calculating "PTDF" values for interfaces that include contingent elements, the PTDF values reported are 
actually what are referred to as an Outage Transfer Distribution Factor (OTDF).  An OTDF is similar to PTDF, 
except an OTDF provides a linearized approximation of the post-outage change in flow on a transmission line in 
response to a transaction between the Seller and the Buyer.  The OTDF value is a function of PTDF values and 
LODF values.  For a single line outage, the OTDF value for line x during the outage of line y is  

OTDFx = PTDFx + LODFx,y * PTDFy 

where PTDFx and PTDFy are the PTDFs for line x and y respectively, and LODFx,y is the LODF for line x during 
the outage of line y.  More complex equations are involved when studying contingencies that include multiple line 
outages, but the basic idea is the same. 

When performing Linear ATC analysis along with calculating OTDFs, Simulator determines the linearized 
approximation of the post-outage flow on the line.  This is similarly determined as 

OutageFlowX = PreOutageFlowX + LODFx,y* PreOutageFlowY 

where PreOutageFlowX and PreOutageFlowY are the pre-outage flow on lines x and y. 
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Line Outage Distribution Factors Dialog 

The LODF Dialog enables you to control and to view the results of Line Outage Distribution Factor calculations.  You 
access this dialog by selecting Options/Tools, Other Sensitivities, Line Outage Distribution Factors (LODFs) from 
the main menu in Run Mode only.   

 

The dialog has the following options: 

Near Bus, Far Bus 

Specify the line whose status modification you would like to determine sensitivities to. 

Action 

Check Outage Sensitivities to determine sensitivities for the outage of a line. 

Check Insertion Sensitivities to determine sensitivities for the insertion of a presently outaged line. 

Liner Calculation Method 

Linearized AC 

This calculation method is not available for LODF sensitivities. 

Lossless DC 

Uses the DC power flow approximation. 

Lossless DC with Phase Shifters 

Check this to include the impact of phase shifter controllers with the Lossless DC calculation.  By checking this, 
it is assumed that operating phase shifters will maintain their control requirements after the line outage. 

Calculate LODFs  

Click this to calculate the LODFs and update the display. 

Advanced LODF Calculation 

Opens the Advanced LODF Calculation dialog for setting additional options for the calculation. 

 

LODFs Tab 

This tab contains a table showing a list of the lines in the case.  Since this table us another variety of the Case 
Information Displays, you may interact with it in a familiar manner.  Click on any of the field headings to sort by that 
field.  Right-click on the display to call up the display’s local menu.  From the local menu, you can print the violations, 
copy the violation records to the Windows clipboard for use with another application, modify the format and content of 
the listing, view the information dialog of the respective element, and view the Quick Power Flow List or Bus View 
Display. 

The default fields for the tab are as follows 

From Bus Number and Name 

"From" bus number and name. Right- clicking on either of these fields allows you to see all the flows measured at 
the "from" bus using the Quick Power Flow List or Bus View Display local menu options.  

To Bus Number and Name 

"To" bus number and name. Right-clicking on either of these fields allows you to see all the flows into the "to" bus 
using the Quick Power Flow List or Bus View Display local menu options. 

Circuit 
Two-character identifier used to distinguish between multiple lines joining the same two buses. 

%LODF 

The LODF value for the line. 

From MW, To MW 

The present MW flows on the line at the "from" bus and the "to" bus. 

From CTG MW, To CTG MW 

The projected MW flows after the change in line status on the line at the "from" bus and the "to" bus. 

Note: LODFs are always calculated using a DC power flow technique. 
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Advanced LODF Calculation Dialog 

This dialog allows you to calculate the LODFs for several different contingent lines.  Go to the Contingency Analysis 
Tool to define which contingent lines to use (all contingencies that contain a single branch outage will be used.)  Also, 
only lines that are being monitored will have their LODFs calculated.  See Limit Monitoring Settings to change which 
lines are monitored. 

 

This dialog defines how to save the Advanced LODF results to a file for importing in another program. 

Format to Save in 

You can choose to save the advanced LODF results as "Monitored Branch, Contingency" pairs for PROMOD, or as 
a matrix in a comma-delimited text file.  The comma-delimited text file is useful for loading the results  into a 
spreadsheet program. 

Only save pairs with an LODF whose absolute value is greater than 

This field allows you to filter out elements whose LODF is below a certain value. 

Only Include Monitored Branches whose MW flow increases 

This field allows you to filter out monitored elements whose MW flow did not increase in the LODF calculation. 

Maximum Columns Per Text File  

This field is important when you are saving a matrix in a comma-delimited text file.  Most spreadsheet programs 
have limits on the number of columns they can display.  The default is 256, which happens to be the maximum 
number of columns allowed in Excel. 

LODF Number Format 

You can choose to have the LODF values stored in either scientific notation, or as a specified length decimal 
number. 

File Name 

You must enter a file name and location or Browse for a file for saving the LODF data. 
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Directions Display 

The Directions Display appears in the upper-right corner of the PTDF window when you select Multiple Directions for 
the PTDF Type.  The Directions Display is a case information display that allows directions to be defined for 
performing multiple direction Power Transfer Distribution Factors.  The Directions Display allows you to insert, delete, 
and modify directions using options available from the display's local menu.  When directions are modified or inserted 
individually, the Directions Dialog will be displayed for entering the information.  In addition to individually defining 
directions, they can also be automatically inserted using the Auto Insert Directions dialog.   

 

Each record in the display shows the following default information: 

Number, Name 

A unique number and name given to the defined direction. 

Source Type, Source Name 

The name and type of the direction source. 

Sink Type, Sink Name 

The name and type of the direction sink. 

Include  

Determines if the direction is to be analyzed when calculating the multiple direction PTDF's. 

Processed 

Displays if the direction has already been processed for a multiple direction PTDF analysis. 
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Directions Dialog 

Directions are objects that are defined and used when computing a Power Transfer Distribution Factor using multiple 
directions. 

The Directions Dialog can be used to insert a new direction or to modify the information for an existing direction.  This 
dialog can be called by choosing Insert or Show Dialog from the Directions Display local menu.   

 

The options that can be set from this dialog include: 

Name of Direction 

The name for the direction.  If you are entering a new direction, you can enter a new direction name.  If you are 
modifying an existing direction, the name of the currently viewed direction will be displayed.  A drop down list shows 
a list of currently defined direction names, and choosing one from the list will display that direction's information in 
the dialog.  The up and down arrows next to the field also allow you to scroll through the list of defined directions. 

Direction Number 

If you are entering a new direction, you can put in a new direction number.  If you are viewing or modifying an 
existing direction, the direction's number will be displayed. 

Source  

Select the type of the transfer direction source.  Once the type has been selected, the advanced find list will be 
enabled, allowing you to search for the specific object or group of objects to set as the direction source. 

Sink 

Select the type of the transfer direction sink.  Once the type has been selected, the advanced find list will be 
enabled, allowing you to search for the specific object or group of objects to set as the direction sink. 

Include in list of monitored directions  

Determines if the direction is to be analyzed when calculating the multiple direction PTDF's. 
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Auto Insert Directions 

Multiple directions can be automatically inserted for PTDF studies using the Auto Insert Directions  dialog.  This 
option can be selected from the local menu of the Directions Display.   

 

The layout of the dialog is as follows: 

Type of Direction 

There are six types of directions that can be automatically defined.  Area to Slack, Zone to Slack and Injection 
Group to Slack  will define directions from areas, zones or injection groups to the slack bus of the system.  Area to 
Area, Zone to Zone  and Inj. Groups to Inj. Group will define directions from areas to other areas, zones to other 
zones, or injection groups to other injection groups. 

Delete Existing Directions  

When checked, any previously defined directions will be deleted before the new directions are automatically 
inserted.  If not checked, then automatically inserted directions will be added to the list of previously defined 
directions.  By not deleting existing directions before automatically inserting new directions, it is possible to have 
more than one direction defined with the same source and sink. 

Only Insert for Areas or Zones with Display Filters Set 

If checked, then only Areas and Zones with their Area/Zone/Owner Filters set to Yes will be used when 
automatically inserting directions. 

Starting Number, Increment By 

The Starting Number will be the first number used when automatically numbering the automatically inserted 
directions.  Each subsequent direction added will be numbered according to the Starting Number and the 
Increment By value. 

Insert Directions  

Insert Directions  will perform the automatic insertion routine for the directions, according to the defined options. 

Sensitivities 

Flow and Voltage Sensitivities 

The Flows and Voltages Sensitivities Dialog can be opened from the Options/Tools > Other Sensitivities > Flows 
and Voltages menu option in Run Mode. 

The Flows and Voltages Sensitivities Dialog shows the effect an additional injection of real or reactive power at a bus 
has on real, reactive, or complex power flow on a particular line or interface, or on the voltage of a selected bus.  The 
grid that occupies the bottom of the dialog lists each bus in the system, subject to the Area/Zone/Owner Filter settings.  
This grid is a case information display and thus shares properties and controls common to all other case information 
displays.  The P Sensitivity field indicates the effect a 1 MW increase in real power at the bus has on the flow (either 
MW, Mvar, or MVA flow, as dictated by the Flow Type  setting) or voltage on the device identified by the Device 
Identifier.  Likewise, the Q Sensitivity field indicates the effect a 1 Mvar increase in reactive power at the bus has on 
the flow (either MW, Mvar, or MVA flow, as dictated by the Flow Type  setting) or voltage on the device identified by 
the device identifier. 

Use the Device Type  control to indicate whether the sensitivities are to be calculated for a line/transformer, an 
interface, or a bus.  Use the Flow Type  control to specify the type of power flow for which the sensitivities will be 
calculated.  Use the Device Identifier fields to identify the line/transformer, interface or bus. 

Whenever you make a change to any of these settings, click Calculate Sensitivities to update the grid with the new 
sensitivities. 

The option labeled Set Out-Of-Service  allows you to approximate the sensitivities at out-of-service buses with the 
sensitivity of the closest bus.  Otherwise the out-of-service buses will display sensitivities of 0 when the sensitivities 
are calculated. 

Click Close  to close the Flows and Voltages Dialog.  



Run Mode Tools and Options 

461 

Loss Sensitivities 

The Losses Dialog can be opened from the Options/Tools > Other Sensitivities > Losses menu option. 

The Bus Marginal Loss Sensitivities Dialog is used to calculate and display the sensitivity of a real power loss 
function, PLosses, to bus real and reactive power injections.  Stated mathematically, the display calculates d PLosses/d Pi 

and d PLosses /d Qi , where Pi and Qi are the real and reactive power injections at bus i, respectively.  The display is 
available in the Run Mode by selecting Options/Tools > Other Sensitivities > Losses.   

Stated less formally, the display indicates how losses would change if one more MW or Mvar of power were injected at 
bus i.  Simulator can calculate the losses for a bus relative to losses in the bus’ island or area, to losses in a select 
group of areas, or, if the bus belongs to a super area, to losses in the bus’ super area.  How Simulator computes the 
losses is governed by the value of the Loss Function Type option.   

 

The Loss Function Type may assume one of the following six values: 

Do Not Calculate Bus Loss Sensitivities 

No Losses are calculated because a loss function is not specified. 

Each Electrical Island  

Losses are calculated with respect to the losses in bus’ island.  If the power system consists of only one island, 
losses are computed with respect to the total system losses.  

Each Area  

Losses are calculated with respect to the total losses for the area containing bus i.  This is probably  the most 
common loss function because usually one is concerned with minimizing losses for a particular area rather than for 
the entire case. 

Each Area or Super Area  

Losses are calculated with respect to the total losses for the area containing bus i if bus i does not belong to a super 
area, and with respect to the total losses for the super area containing bus i if bus i does belong to a super area. 

Areas Selected on Loss Sensitivity Form 

Losses are calculated with respect to the total losses for a group of areas, specified in the Selected Areas table.   

User-Specified 

If you select User-Specified as the loss function type, the values last calculated using a different loss function type 
will become fixed.  Thus you can force the loss sensitivities to remain constant when used in other features and 
tools of Simulator. 

In steady-state power system operation, total generation must always equal total load plus losses.  Therefore, the real 
power injection at a single bus cannot be changed arbitrarily; it must be met by a corresponding change somewhere 
else in the system so that the total power remains balanced.  In other words, the change in power injection must 
somehow be absorbed.  How the injection is absorbed depends on the Loss Function Type.  If the Loss Function Type 
is Each Island, the injection is absorbed by the island slack.  For the Each Area and Selected Areas loss functions, 
the injection is absorbed at the area tie-lines.   

The loss sensitivities are calculated by modeling an injection of power at a bus and then assuming that this injection is 
absorbed by the island slack bus.  The sensitivity then shows how much the losses (for the region of interest) increase 
when you transfer 1 MW at the injection bus to the island slack.  The "region of interest" is what was chosen as Island, 
Each Area, or Selected Areas. 

Therefore, the "absolute numbers" given by the loss sensitivity dialogs are not directly meaningful because we are 
always assuming that the absorbing point is the island slack bus.  What is meaningful is the "difference" between 
sensitivity numbers. 

Example: 

 Assume the sensitivities are calculated to be 

 Bus A Loss MW Sensitivity = -0.04 = Asens  

 Bus B Loss MW Sensitivity = -0.02 = Bsens  

 Bus C Loss MW Sensitivity = +0.03 = Csens 

Using these we c an then look at the sensitivity of generic transfers between these buses by using "superposition". 

Consider the following change in injections modeling a transfer of power from Bus A to Buses B and C. 

 Bus A injection = +10 MW = AMW 

 Bus B injection = - 6 MW = BMW 

 Bus C injection = - 4 MW = CMW 

An estimate of the change in losses can then be calculated as  

 Loss Change  = (AMW)(Asens) + (BMW)(Bsens) + (CMW)(Csens) 
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   = (+10)(-0.04) + (- 6)(-0.02) + (- 4)(+0.03) 

   = -0.4 MW 

The Bus Marginal Loss Sensitivities Dialog houses the following controls: 

Selected Areas Table  

This table is used only when the Loss Function Type  is set to Selected Areas; otherwise, it is ignored.  Left-click 
on the Include field to include or exclude areas from the loss function.   

Calculate Marginal Loss Sensitivities Button 

Once the loss function type has been specified, click this button to calculate the bus marginal loss sensitivities and 
update the Bus Marginal Loss Sensitivities table.    

Bus Marginal Loss Sensitivities Table  

This table shows the bus marginal loss sensitivities for all buses with valid Area/Zone/Owner filters.  The Bus 
Marginal Loss Sensitivities Table is a type of Case Information Display and thus exhibits features and behavior 
similar to all other case information displays.  It has a local menu from which you can choose to find out more about 
a particular bus.  You can sort records by any of the listed fields by clicking on the column headings.  The table 
contains the following fields: 

Number, Name Number and name of the bus. 

Area Number, Area Name  Number and name of the bus’ area. 

Loss MW Sens . Sensitivity of the loss function to an increase in the real power injection 
(generated power assumed positive) at the bus. 

Penalty Factors Computed penalty factor of each bus. 

MVR Sens .  Sensitivity of the loss function to an increase in the reactive power injection 
(generated power assumed positive) at the bus.  

Just Generators Marginal Loss Sensitivities Table  

This table shows the bus marginal loss sensitivities for only the generator terminal buses with valid 
Area/Zone/Owner filters.  This table is otherwise identical to the displayed values and table operation as the Bus 
Marginal Loss Sensitivities Table described above. 
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Transmission Loading Relief Sensitivities 

Transmission Loading Relief (TLR) Sensitivities may be thought of as the inverse of Power Transfer Distribution 
Factors.  Both TLR Sensitivities and PTDFs measure the sensitivity of the flow on a device to a transaction.  To 
calculate PTDFs, you specify a source group and a sink group, and Simulator determines the percentage of a single 
transfer between the source and sink that flows on each of several monitored elements.  For TLR sensitivities, you 
specify a single device, such as a transmission line, to monitor, and a group that serves either as source or as sink.  
Simulator then determines the sensitivity of the flow  on the single monitored element to many different transactions 
involving the group you specified as the source or sink.  To summarize, PTDFs express the sensitivity of many 
monitored elements to a single transaction, whereas TLR sensitivities gauge the sensitivity of a single monitored 
element to many different power transfers. 

"TLR" stands for "Transmission Loading Relief."  TLR is an industry-wide tool for managing transmission utilization to 
prevent overload situations that put the system at risk. For example, suppose a particular line is loaded beyond its 
thermal limit.  Its owner will request that a TLR program be initiated, which dictates that all transactions for which 5% 
or more of the exchanged power flows on the overloaded element be curtailed.  The TLR sensitivity tool in Simulator is 
useful for pinpointing those transactions that would be curtailed.  Suppose we use the TLR tool to determine where 
area A can purchase power from while the TLR for the overloaded element is in place.  We specify area A as the 
buyer area, identify the overloaded line, and tell Simulator to perform the calculation.  Simulator will then list the 
sensitivity of the flow on the overloaded line to power exchanges between all other generators, areas, and buses to 
area A.  Any transaction for which the sensitivity exceeds 5% would be curtailed; anything below 5% would be allowed 
to continue. 

To calculate TLR Sensitivities, select Options/Tools > Other Sensitivities > TLR Sensitivities from the main menu.  
This will open the TLR Sensitivities dialog, which will allow you to set TLR Sensitivities options and then calculate the 
sensitivities. 
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TLR Sensitivities Dialog 

The TLR Sensitivities dialog allows you to calculate Transmission Loading Relief Sensitivities for the load flow case at 
its solved load flow point.   

 

The following describes the sections of the dialog: 

Device Type  

Select whether you want to calculate the sensitivities for a transmission line/transformer, for an interface, or for 
multiple elements.  To calculate sensitivities for an interface, you must have the interface defined in the case. 

When you choose an individual line/transformer or interface, you need to specify the device by selecting it from the 
list of devices.  In this cas e you specify the From Bus, To Bus, and circuit identifier for a branch, or the interface 
name or number.  When you select the Multiple Elements option, the device selection area of the dialog changes to 
allow you to select a TLR Multiple Device Type.  The TLR results display changes accordingly in order to 
accommodate TLR sensitivities for multiple elements. 

Device Identifier 

Specify the From Bus, To Bus, and circuit identifier for a branch, or the interface name, number, and monitored flow 
direction. 

For multiple elements, specify the multiple device type.  Choices are: selected lines/transformers, selected 
interfaces, overloaded lines/transformers in the base case, overloaded interfaces in the base, overloaded 
lines/transformers during the set of contingencies, and overloaded interfaces during the set of contingencies. 

Select Lines/XFMRs  

Opens the case information display for lines/transformers.  To include a line/transformer in the TLR study, set the 
Selected? field to Yes. 

Select Interfaces 

Opens the case information display for interfaces.  To include an interface in the TLR study, set the Selected? field 
to Yes. 

# Elements  

Shows the total number of elements to be included in the TLR study. 

Transactor Type  

Specify if the sensitivities will be calculated for the transactor being the buyer or the seller. 

Transactor Object 

Specify what the transactor will be.  The choices are Area, Zone, Super Area, Slack, Injection Group, and Bus. 

TLR Sensitivities 

Specify if the next set of calculated TLR sensitivities should replace the currently calculated values, or be appended 
to the current values. 

PTDF Calculation Method 

Choose the solution method to use for calculating the sensitivities. 

Include only AGCAble Generators 

If checked, then only generators available for generation control will be included in the TLR sensitivity calculations. 

Generator, Area and Bus Sensitivities 

Displays the other devices that can be involved in a transaction with the transactor, and the resulting TLR sensitivity 
for performing a transaction with that device. 
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TLR Multiple Device Type  

The Multiple Device Type selector allows you to specify a group of elements for which Transmission Loading Relief 
(TLR) sensitivities will be calculated. The Multiple Device Type selection is accessible only when you chose the 
Multiple Elements option from the Device Type in the TLR Sensitivity Dialog.  

When you change the Multiple Device Type section, the # of Elements box changes to indicate how many elements of 
the selected type are available for TLR calculation.  

 

When you click the Calculate TLR Sensitivities button for multiple elements, the table will show a TLR column for each 
element in the set and two additional columns: 

Effective Transmission Loading Relief (ETLR) 
In the same manner as the TLR represents the MW increase in an element per MW transfer, the ETLR column in 
the Mult. Bus Sensitivity table represents the total MW increase in all the elements in the set per MW increase of 
the transaction. Let us suppose that the set contains two transmission lines: A and B and assume that for a 1 MW 
transfer from bus i to the transactor, the flow in line A increases in 0.5 MW and the flow in line B decreases in -0.3. 
Then the ETLR of bus i is +0.2 since that is the total MW increase in the elements in the set. The ETLR provides a 
measure of the simultaneous MW change in multiple elements, and thus the overall effect in flows on the element of 
the set. The ETLR is a bus field that can be included in the bus Case Information Display, used in Contouring, etc.  

Weighted Transmission Loading Relief (WTLR) 

The WTLR  column in the Mult. Bus Sensitivity table weights the sensitivities based on the flow or overload flow 
values of the element. It is a measure of the value of a certain bus to relief transmission loading. The buses with the 
highest WTLR (or lowest WTLR, depending on the transactor type) are identified as the most effective buses to 
mitigate transmission loading considering multiple elements.  The WTLR is a bus field that can be included in the 
bus Case Information Display, used in Contouring, etc.  

Selected Lines/XFMRs  

Choose this option to include in the multiple element TLR calculation those transmission lines and transformers that 
have been selected. To select a transmission line or transformers, toggle the Selected field in the Lines and 
Transformer Case Information Display to Yes. If the Selected field is not available in the information display, add 
that column to the display by right-clicking in the display and selecting Display/Column Options. The ETLR of 
selected Lines/XFMRs is the algebraic sum of the TLRs of each individual element. The WTLR uses as weight the 
current MW flow in the element.  

Selected Interfaces 

Choose this option to include in the multiple elements TLR calculation those interfaces that have been selected. To 
select an interface, toggle the Selected field in the interfaces Case Information Display to Yes. If the Selected field 
is not available in the information display, add that column to the display by right-clicking in the display and selecting 
Display/Column Options. The ETLR of the selected interfaces is the sum of the TLRs of the interfaces that have a 
limit different from zero. The WTLR uses as weight the MW flow in the interface 

Overloaded Lines/XFMRs 

Select this option to include in the multiple element TLR calculation those transmission lines and transformers that 
are overloaded in the present case based on the Limit Monitoring Settings. The list of the overloaded lines and 
transformers is available in the Limit Violations information display. It can also be sorted in the lines and 
transformers Case Information Display. The ETLR of overloaded lines and transformers is the algebraic sum of the 
individual TLRs. The WTLR for overloaded transmission lines and transformers uses as weight the MVA overload of 
each transmission line and transformer.  

Overloaded Interfaces 

Select this option to include in the multiple elements TLR calculation those interfaces that are overloaded in the 
present case based on the Limit Monitoring Settings.  The list of the overloaded interfaces can be obtained from the 
Limit Violations information display or by performing a sort in the interfaces Case Information Display. The ETLR for 
overloaded interfaces is the sum of the individual TLRs. The WTLR for overloaded interfaces uses as weight the 
MW overload of each interface.  

CTG Overloaded Lines/XFMRs  

Select this option to include in the multiple element TLR calculation those transmission lines and transformers that 
were identified as overloaded by the Contingency Analysis tool. A transmission line or transformer is included in the 
calculation if it has been overloaded at least for one contingency. The list of the lines and transformers identified as 
overloaded can be accessed from the Lines, Buses and Interfaces Tab in the Contingency Analysis Dialog.  

The ETLR of the CTG overloaded lines and transformers is the algebraic sum of the individual TLRs. The WTLR 
uses as weight the Aggregate MVA Overload of each transmission line and transformer, which is defined as the 
sum of the MVA overload in the line or transformer across the contingencies that caused a violation in that particular 
line or transformer. The Aggregate MVA Overload and a related field, the Aggregate Percent Overload of a line or 
transformer, are measures of the weakness of that transmission line on the grid. The Aggregated MVA Overload 
and the Aggregate Percent Overload are line and transformer fields that can be displayed in the Case Information 
Display, used in Contouring, etc.  
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CTG Overloaded Interfaces  

Select this option to include in the multiple element TLR calculation those interfaces that were identified as 
overloaded by the Contingency Analysis tool. An interface is included in the calculation if it has been overloaded at 
least during one contingency. The list of the interfaces identified as overloaded during contingencies can be 
accessed from the Lines, Buses and Interfaces Tab in the Contingency Analysis Dialog.  

The ETLR of the CTG overloaded interfaces is the algebraic sum of the individual TLRs. The WTLR uses as weight 
the Aggregate MW Overload of each interface, which is defined as the sum of the MW overload of the interface 
across the contingencies that caused a violation in that interface. The Aggregate MW Overload and a related field, 
the Aggregate Percent Overload of an interface are measures of the weakness of the interface. These two interface 
fields can be displayed in the Case Information Display, used in Contouring, etc.  
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Generation Shift Factor Sensitivities 

Generation Shift Factor (GSF) Sensitivities are a specific kind of TLR calculation.  GSFs always involve a transfer with 
the slack bus being the Buyer. Other than this, GSF and TLR calculations are identical . See TLR Sensitivities for more 
information. 
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PowerWorld Simulator Add-on Tools  

Chapter 12 : PowerWorld Simulator Add-on Tools  

This chapter contains information on the tools available for purchase for adding additional functionality to the Simulator 
base package. 

• Voltage Adequacy and Stability Tool (PVQV) 

• Optimal Power Flow (OPF) 

• Security Constrained OPF 

• Available Transfer Capability Analysis (ATC) 

• Simulator Automation Server (SIMAUTO) 

• Simulator Automation Server (SIMAUTO) for Simulator version 9 

Voltage Adequacy and Stability Tool (PVQV) 

PowerWorld Simulator PV/QV Overview 

Note: The PVQV option in PowerWorld Simulator is only available if you have purchased the PVQV add-on to 
the base package.  To learn more about the PVQV, please feel free to read through the information contained 
in these help files.  Contact PowerWorld Corporation for details about ordering the PVQV version of Simulator 
if you do not presently own it. 

The purpose of this portion of the help is to teach you how to use PowerWorld's voltage stability assessment tool, 
PVQV, to analyze the voltage characteristics of your system.  Since this application is currently under continuous 
development, bear in mind that certain details described here may change and thus render portions of this document 
inaccurate.  However, PowerWorld Corporation will try to clarify the implications of significant changes as they arise.  If 
you have any questions concerning the use of the product, suggestions on how to improve it, or information 
concerning program bugs that you have observed, please contact PowerWorld Corporation at info@powerworld.com. 

The PowerWorld Simulator (Simulator) is an interactive power system simulation package designed to simulate high 
voltage power system operation.  In the base package Simulator solves the power flow equations using a Newton-
Raphson power flow algorithm.  However, with the voltage adequacy and stability tool (PVQV) add-on the user can 
solve multiple power flow solutions in order to generate a PV curve for a particular transfer or a QV curve at a given 
bus.  PowerWorld Corporation also has optimal power flow (OPF), available transfer capability (ATC), and Simulator 
Automation add-ons to the base package. 

The PVQV functionality is accessed using the Voltage Stability main menu item.  The commands available from this 
menu are Refine Model, QV Curves, and PV Curces. 

The purpose of the PVQV add-on is to allow the user to monitor any system parameter while automatically increasing 
a user-defined transfer.  The PVQV module uses the Simulator built-in Newton Raphson power flow algorithm to 
accomplish this task.  After the PVQV simulation is completed, the user can choose to graph any of the monitored 
system parameters. 
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PV/QV PV Curves 

The voltage stability function of Simulator provides the ability to compute PV curves for any bus in the system.  Simply 
select Voltage Stability > PV Curves from the main menu to open the PV Curve dialog.   The PV Curve dialog allows 
you to specify the buses to be monitored, set defaults for the PV curves, and run the PV analysis. 
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PV/QV PV Curve Dialog 

The integrated PV / QV dialog contains all of the setup and controls for processing and analyzing the PV and QV 
curve analysis.  The dialog is broken down into several pages: 

Setup  

Quantities to track  

Limit violations  

PV output  

QV setup  

PV results  
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PV/QV PV Studies Dialog 

To open the PV curve dialog, select Voltage Stability > PV Curves from the main menu. This will open a dialog 
labeled "PV Studies." The PV Studies dialog allows you to manage multiple PV studies that you might define in a 
single session. To create a new study, specify a unique name in the Name text box and click Create . To use a PV 
curve study that has already been defined, select it from the Currently defined PV studies list and click Activate . To 
remove an already existing PV study, which entails freeing the memory associated with its results, select its name 
from the Currently defined PV studies list and press Destroy. 
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PV/QV Setup 

The first step in the setup process is to define the source and the sink for the study transaction.  The PV/QV tool 
expects the source and the sink to be injection groups defined by the user.  If injection groups have been previously 
created, they can be selected by clicking on the drop-down list arrow of the Source and Sink boxes.  If the injection 
groups have not been previously defined in the current case, they can be created by clicking the View / Define 
Groups  button, right-clicking on the resulting list display, and choosing Insert from the popup menu.  Alternatively, if a 
list of injection groups has been previously saved in a Simulator Auxiliary file, they can be loaded into the current case 
by again clicking the View / Define Groups button, right-clicking on the injection group list display, and choosing Load 
> Auxiliary File from the popup menu. 

Once you have the source and sink points defined, the PV study will model an increasing transfer of power from these 
source points to the sink points.  The transfer process is performed incrementally, based user specified options on 
how the transfer should vary during the solution process. 

 

Note that options can be saved to or loaded from an auxiliary file using the Save options  and Load options  buttons, 
located at the bottom of the display. 

Manage contingency list 

Clicking this button will open the contingency analysis dialog for managing or inserting contingencies to be 
processed during the PV/QV analysis.  Contingencies defined and marked for processing in the contingency 
analysis dialog will be included. 

If you wish to globally omit the inclusion of contingencies during the PV/QV analysis, you may check the box labeled 
Skip Contingencies. 

Pre-contingency solution options  

Clicking this button will open the solution / environment options, allowing you to customize the solution options prior 
to processing the PV/QV analysis. 

Run base case to completion 

Check this box if you wish to find the critical transfer point of the base case condition, in addition to the specified 
number of critical cases for the defined contingency scenarios.  By default, the PV analysis will process until the 
number of critical cases (or scenarios) as specified on the PV Results page have been found, and will halt the 
process at that point.  If the base case transfer scenario is not one of the critical cases, then checking this option 
indicates that you want the PV analysis to continue incrementing transfers for the base case condition to find the 
critical point of the base case, IN ADDITION to the number of critical cases specified. 
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PV/QV Options to Control the Transfer Increase 

These options are located in the bottom half of the "How should the system vary?" tab of the PV Study Form. 

 

Source  

Use this dropdown box to identify the source injection group.  To model an increase in transfer, generator points in 
the source injection group will increase their output, and load points will decrease their magnitude in amounts 
proportional to their participation factors.   

Sink 

Use this dropdown box to identify the sink injection group. To model an increase in transfer, generator points in the 
sink injection group will decrease their output, and load points will increase their magnitude in amounts proportional 
to their participation factors. 

Areas  

Both the source and sink dropdown boxes have a button labeled Areas  next to them. To differentiate the outputs of 
points in the source group or the sink group according to the control areas in which they reside (so that some 
control areas contribute more to the group’s transfer than others), click the corresponding Areas button. A new 
dialog box will open that features a grid containing area names and percentages.  The area names identify all the 
areas to which points of the injection group belong, and the percentages describe the portion of the transfer that 
points from each control area will contribute to the injection group’s power shift.  When this dialog first opens, the 
percentages are calculated based on the participation factors of each point in the injection group. Changing the 
percentages overrides the individual participation factors so that the actual contribution of each point is weighted by 
the proportion of the shift the point’s control area is supposed to provide. This feature is useful if you need to model 
a shift according to control area responsibilities (perhaps defined contractually), but the injection groups you are 
using come from multiple control areas. 

Initial Step Size (MW) 

This option indicates the initial rate at which the transfer will be increased with each successful iteration.  For this 
example, set its value to 100.  This tells Simulator to begin studying the transaction in 100 MW increments. 

Minimum Step Size (MW)  

Whenever Simulator fails to solve the system at a given transfer level, it will return to the previously solved transfer 
level, reduce the step size by specified factor, and then try to solve the system with the transfer incremented by the 
newly reduced step size.  The Minimum Step Size option specifies the minimum size this increment can be.  Once 
the system fails to solve when the step size is at this value, Simulator will conclude that we have come very close to 
the voltage collapse point and terminate the analysis.  So, the minimum step size essentially functions as a 
tolerance for computing the voltage collapse point.  For this example, set the Minimum Step Size to 10. 

When convergence fails, reduce step by a factor of… 

Whenever Simulator fails to solve the system at a given transfer level, it will reduce the transfer step size by the 
value specified for this option.  For this example, set this value to 2.  Therefore, Simulator will start incrementing the 
transfer in 100 MW steps.  When it reaches a transfer level that it cannot solve, it will return to the last solved 
transfer level, reduce the step size to 50 MW, increment the transfer by 50 MW, and attempt to solve the case 
again.  The next time it fails to solve, it will reduce the step size to 25 MW, and then to 12.5 MW, and finally to 6.25 
MW.  Since 6.25 MW is less than the Minimum Step Size value of 10 MW, it will instead use a final step size of 10 
MW.  Once the system fails to converge with this step size, the analysis will terminate, since it will conclude that it 
has arrived at the voltage collapse point, within the specified tolerance. 

Stop when transfer exceeds  

Provide a MW transfer limit between the source and the sink.  When the PV analysis reaches a transfer amount 
equal to this value, the PV analysis will terminate. 

How should reactive power load change as real power load is ramped? 

This option controls how reactive load should vary as real load is changed during the analysis. You can either have 
Simulator maintain the same ratio of real to reactive power load by checking "Keep the ratio between ..." checkbox, 
or you can specify a power factor at which real and reactive load should change by specifying a value for "As MW 
changes, change MVR at a power factor of…." If, for example, you specify 100 for this option, that suggests that the 
power factor for the load change should be 100%, meaning that only the real power will change. If you specify 
70.7%, the real and reactive load will be ramped by equal amounts. 

Allow only AGC units to vary 

Control areas in Simulator may practice one of three types of automatic generation control.  Then, all generators in 
the area that are, in fact, AGC-able will participate in the area's automatic generation control program.  Thus, 
Simulator distinguishes individual generating units according to whether they do or do not participate in their area's 
AGC effort.  By checking this option, you instruct Simulator to allow only those generators that are eligible to 
participate in AGC to contribute to the power transfer being studied.  For this example, we will assume that all of the 
units listed in the source injection group, regardless of their AGC status, are to be used in providing power for the 
transfer.  Thus, we will leave this option unchecked. 
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Enforce unit MW lim its 

If this option is checked, the output of any participating generating unit will be kept within its designed operating 
range of MinMW < Output < MaxMW.  When a unit is pegged at one of its limits, participation factors of the other 
points in the limited generator's injection group will be adjusted to pick up the difference.  For this example, leave 
this option unchecked.  This will allow us to analyze the capacity of the interface to support the transfer, regardless 
of the amount of reserves available. 

Do not allow negative loads  

This is the analog of the previous option for loads.  If a load is used as a source  point, it will be decreased to make 
power available for the transfer.  Checking this option will instruct Simulator to keep loads from falling below 0 MW.  
If a particular load is capped at 0 MW, participation factors for the remaining points in its injection group will be 
recalculated to make up the difference.  If you aren't using loads as source points this option is irrelevant.  Thus, it 
can be left unchecked. 

Skip contingencies 

The PV Curve tool computes PV curves for both the base topology and for any contingencies that have been 
defined, unless you check the "Skip contingencies" checkbox. If the Skip contingencies checkbox is checked, a PV 
curve will be computed only for the model in its present topology. 

Manage contingency list… 

Click the Manage contingency list… button to open the contingency analysis dialog.  This will enable you to create, 
modify, and remove contingencies from the list of configurations the PV curve tool will process. 

Run base case to completion 

The PV curve tool is designed to ramp a transfer until the prescribed number of unsolvable cases, including both 
unsolvable contingencies and an unsolvable base topology, have been found. If the requested number of 
unsolvable cases have all been identified as being associated with contingencies, the tool will not reveal how much 
a transfer can be ramped for the base topology, unless you check the "Run base case to completion" checkbox. 
Checking this checkbox forces the tool to continue to ramp the transfer until the base case can no longer be solved, 
regardless of whether the requested number of unsolvable transfer level / topology combinations have been found. 

Pre-contingency solution options … 

Click this button to bring up the Solution/Environment Options Dialog.  This will allow you to specify the solution 
options to use for solving pre-contingency cases. 
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PV/QV Quantities to Track  

This section of the PV/QV dialog allows you to define what quantities to be monitored (stored) as the transfer is 
increased.  Any unselected system parameters will not be saved.  The Quantities to Track page contains several sub-
pages that allow you to monitor different types of objects, including buses, generators, injection groups, branches, and 
interfaces.  

 

Buses 

For buses, we can monitor voltages, angles, MW load, and MVR load during the PV analysis.   In addition, you can 
specify if the QV curve should be generated for the bus, and if the sensitivity of the voltage to changes in reactive 
power (dV/dQ) should be monitored for the QV analysis.  Initially, all values in this table equal 'NO', indicating that 
we're not monitoring any bus -related quantities.  To monitor a particular quantity, double-click the corresponding 
value to toggle it to 'YES'.   

Generators 

For generators, we can monitor MW and MVAR output, and MVAR reserve.  The display operates exactly like the 
bus display.  

Groups  

The Groups  sub-page allows you to monitor the total generator MW and MVAR for the group, as well as the total 
load MW and MVAR. 

Lines / Transformers 

The Lines / Transformers sub-page allows you to monitor real, reactive, and MVA flow, in either the from-to or to-
from directions, the MW and MVAR losses, and the PTDF value on any branch.  For the flow fields, double-clicking 
on a particular entry will toggle its value from 'NO' to 'FROM-TO', and double-clicking again will toggle its value to 
'TO-FROM'.  Double-clicking the losses or PTDF value field will toggle the value between 'YES' and 'NO'. 

Interfaces 

Simulator allows you to define groups of branches that together comprise an interface.  The Interfaces sub-page 
allows you to monitor real, reactive, and MVA flow, the MW and MVAR losses, and the PTDF value on any interface 
that you have defined.  If you have not defined any interfaces, you cannot use this option. 
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PV/QV Limit Violations  

The Limit Violations page allows you to define what should be considered a violation of a monitored voltage. 

 

Identify bus voltages 

The Low Voltage  and High Voltage  options should be checked if you wish to see which of the buses are violating 
their voltage limits at the end of the PV/QV analysis.  The limits used are those defined using the limit monitoring 
settings.  To examine the limit monitoring settings, press the Limit Group Definitions button to open the Limit 
Monitoring Dialog. 

Inadequate voltage level 

This option allows you to specify at what value a monitored voltage is determined to be "inadequate".  The results of 
the PV/QV analysis will report the transfer level at which the first instance of a voltage below the inadequate level 
was detected. 

You may also choose to have the PV/QV analysis halt when it first detects the inadequate voltage.  Checking the 
box labeled Stop when voltage becomes inadequate  will force the PV/QV analysis to do so. 

If you wish for the inadequate voltage feature of the PV/QV analysis to be ignored, uncheck the box labeled Identify 
inadequate voltage . 
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PV/QV PV Output 

Simulator records the value of each monitored quantity at each transfer level. However, unless you tell Simulator 
where to write the data, it will be present only in memory.  The Output Tab allows you to designate where the data 
should be logged. 

Click the Save Results to File option to indicate that you want to write results to a file.  Then, in the adjacent text box, 
supply the complete path for the output file.  You may use the Browse button to locate the place w here you want the 
file to be written. 

In addition to recording how the monitored quantities vary with the transfer, you can instruct Simulator to save the 
entire system state at regular intervals during the analysis.  This can be helpful if you want to analyze particular 
transfer levels more closely after the analysis is complete.  To archive all system states, click the option labeled 'Save 
all states ', then, supply the directory where the states should be written, and a prefix to use in naming the state files.  
You can use this prefix to distinguish the states of different runs that might have been written to the same directory.  If 
you do decide to use this option, keep in mind that, depending on the size of your system, archiving states frequently 
can require significant disk space and delay the process.  However, it can be quite helpful if previous analyses have 
shown interesting behavior at a particular transfer level. 

You may also save only the base case for each critical contingency, or save no system states at all, by checking the 
appropriate option.   
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PV/QV PV Results  

To start the PV study, switch to the PV Results  tab, the last page of the form.  From this tab, you can control the 
progress of the run by initiating, pausing, or aborting it.  You can even reset the process to the beginning.  This tab 
also gives you a few different views of the run's output, including the ability to plot various quantities.  

To begin the PV analysis, click Run.  The Status  indicator will change from 'Inactive ' to 'Running'.  To pause the 
process at any time, click the Pause button.  Then, to restart the analysis, click Run.  To terminate the analysis at any 
time, click Abort .   

As the analysis continues, the scenario list on the Overview page will keep you informed of its progress.  Present 
step size  identifies the current size of the increment the application is using to increase the transfer.  Present 
Nominal Shift indicates the size of the transfer that was most recently solved.  

The Plot sub-page gives you access to the application's data plotting functions.  Any of the values you designated to 
monitor can be plotted using this display 

To produce a plot, follow this example procedure: 

• From the X Axis Quantity dropdown box, select 'Total Shift (MW)'. 

• For the X Axis Caption, type 'Total Transfer in MW'. 

• From the Y Axis Quantity list box, select the first four monitored bus voltages. 

• For the Y Axis Caption, type 'Bus Voltage (pu)'. 

• For the Title, type 'Voltage vs. MW Transfer for SOURCE Selling to SINK'. 

• To complete the procedure, click the button labeled Plot. 

The plot will appear in its own window.  You can produce as many plots as the memory on your system will allow.  
Right-clicking on a plot will expose a local menu with four options.  You can send the plot to your printer by clicking 
Print.  You can change the printer configuration by selecting Printer Setup.  You can save the plot as a bitmap, 
Windows metafile, JPEG, or text file by clicking Save As  and selecting the appropriate file type.  Finally, to close the 
plot window, click Close. 

Note that the plot sub-page also has an option for plotting pre-contingency values, for plotting values for specifically 
identified scenarios, and for always including the plot of the base case conditions. 



Printed Documentation 

480 

PV/QV QV Setup 

The PV curve tool stresses the system by increasing a transfer between injection groups. Eventually, the transfer is 
increased so much that the power flow can no longer be solved.  Under the assumptions of static voltage s tability 
assessment, the point at which the system becomes unsolvable is regarded as the point of voltage collapse. Voltage 
collapse tends to be a localized phenomenon associated with a lack of reactive voltage support at a bus or group of 
connected buses.  It is important to identify this group of stressed buses so that you can properly direct efforts to 
reinforce the system. QV analysis is often used to identify the buses that are most prone to a voltage collapse because 
they are close to having insufficient reactive support.   

The design of the PVQV add-on to Simulator acknowledges the important role that QV analysis plays in identifying the 
buses that are most heavily stressed by a transfer.  The approach is straightforward. First, perform a PV curve 
analysis that models a transfer from source to sink for both base and contingency topologies. This will yield a number 
of PV curves that terminate at a transfer level that causes the system to become unsolvable for each topology.  For 
each of these critical transfer level / contingency pairs, perform a QV analysis at a set of buses to try to determine 
which area or areas constitute the epicenter of the collapse.  The set of buses at which the QV analysis is performed 
can be predefined by the user and supplemented by the list of buses that have the lowest voltage magnitudes or the 
highest VQ sensitivities.  

To specify that Simulator should automatically launch a QV analysis after finishing a PV study, check the box labeled 
Automatically launch QV analysis at end of PV computation.  After the PV curve has found all the critical cases it 
has been asked to identify, it will launch the QV Curve Tool. The buses the QV Curve Tool will analyze will then come 
from two groups: those that the user has pre-selected, and those that tool automatically identified because they are 
among the lowest-voltage buses or have the highest VQ sensitivities.  To pre-select buses for the QV analysis, switch 
to the Buses sub-tab of the Quantities to track  tab and toggle the "Draw QV?" field of each bus for which you want to 
compute a QV curve to YES. Whether other buses are automatically selected in light of their voltage or VQ sensitivity 
is governed by settings stored in the QV options file. 

 

We now continue our look at the QV Setup tab of  the PV Curve Tool by describing the use of the remaining controls. 

QV options file  

Specify the name of the file that contains settings for a variety of options associated with the QV study in this text 
box. Use the Browse button to locate this file using a file dialog. Among the topics that may be addressed by the 
QV options file is whether buses should be automatically selected as buses for which to draw QV curves based on 
their voltage or VQ sensitivity. The easiest way to build a QV options file is to use the QV Curve Tool to specify the 
settings of the various options and to save these settings in a file. 

How should scenarios be handled? 

QV curves can be drawn for the selected buses either for all the scenarios that the PV tool has processed, or just 
for the scenarios for which the PV Curve Tool found an unsolvable transfer level. Select the option that describes 
how you wish the QV Curve Tool to process scenarios from this option group.  If you select the Consider just the 
unsolved scenarios  option, the QV tool will compute QV curves for the selected buses at the last transfer level at 
which each scenario was successfully solved. Otherwise, the tool will compute QV curves for the selected buses for 
each scenario at either the last transfer level at which the scenario was successfully solved or the last transfer level 
that the PV tool attempted to model. 

QV accelerator settings  

This group of controls enables you to define a voltage window over which each QV curve should be calculated.  If 
you select Do not use shortcuts; trace the entire QV curve , each QV curve will be computed over the voltage 
range specified for the bus in the QV options file. This voltage range may be specific to that bus or may be a 
window that has been defined for the entire run. If, on the other hand, you select Trace abbreviated QV curves 
using these settings…, the voltage range over which each bus’s QV curve will be computed will be customized for 
each bus according to the values you specify for Max voltage increase and Max voltage decrease.  For example, 
if a bus is currently at 0.9 per-unit voltage for a particular scenario and you specify the max voltage increase and 
decrease to be 0.1 and 0.3, respectively, then the QV curve for that bus for that scenario will be traced over the 
voltage range 0.6 pu to 1.0 pu. 
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PV/QV QV Curves 

Another voltage stability function currently included is the ability to compute QV curves for any bus in the system.  
Simply select Voltage Stability - QV Curves from the main menu to open the QV Curve dialog.   The QV Curve dialog 
allows you to specify the buses to be monitored, set defaults for the QV curves, and run the QV analysis.  These three 
topics are handled on the following pages of the QV Curve dialog: 

Buses  

Options  

Output  

Control/Results  

When you are finished, simply click Close.  The results will remain in memory as long as the case remains in memory.  
Please note that QV curve results and option settings are not saved with the case. 
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PV/QV QV Curve Buses 

To designate the buses for which you would like to calculate QV curves, toggle the Selected? field to "YES".  If you 
would like to specify specific solution parameters (min volt, max volt, and step size) for any bus, simply type the 
numbers in the appropriate cells.  If you leave any cells blank, default values will be used for those parameters.  Only 
non-default values will be shown in these cells.  If you change a value in these cells to a default setting, the cell will be 
automatically be set blank. 

Alternatively, you may type a range of bus numbers to add them to the list of buses that will have a QV curve 
calculated, or you may type the name of a bus.  Furthermore, you may load a list of buses, as well as other option 
settings, from an auxiliary data file.  To create such a file to store your option settings, press the Save Settings  button 
that appears near the bottom of the display. 

To load settings you saved previously in an auxiliary data file, click the Load Settings button.  You can search for the 
file instead of typing its name.  Once the name of the file appears in the text field, press Open to import the settings 
stored in the file. 

You also can check the box Additionally, automatically draw curves for… and then the number of lowest-voltage 
buses and highest dv/dq buses that you require. These buses will be selected from the limit group indicated in the 
field from the limit group. 
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PV/QV QV Curve Options 

The second page of the QV Curve dialog is the Options  page.  The options page contains three tabs labeled 
Solution, Output and Contingencies. 

 

Solution 

In the three text fields enclosed in the Default solution parameters group box, specify the values of voltage step 
size, minimum voltage, and maximum voltage to use when computing QV curves for buses that don’t have specific 
values set for these parameters.  

If you don’t understand the meaning of these parameters, consider how a QV curve is computed: a fictitious 
generator (i.e. voltage source) is placed at the monitored bus.  Its set point voltage is varied in steps of the specified 
size between the specified maximum and minimum voltages, and the MVAr injection at the bus is calculated and 
recorded at each step. 

To make the changes you’ve made register with QV CC, click the Set Options  button.  To restore the factory-default 
settings, click Restore Defaults . 

To set power flow solution parameters, click the Global solution options  button.  Be aware that the changes you 
make in the resulting dialog affect all power flow computations in Simulator. 

Output 

The Output tab allows you to set a location for saving the results of the QV analysis to a file.  To save the QV 
analysis to a text file, you must first check the box labeled Save data in file .  Once this box is checked, you can 
then either type in a directory location for saving the data, or click the Browse button and select a file to save as.  
You can also customize the file prefix and extension to be used when Simulator names the output files. 

Another option on the Output tab is the check box labeled Plot curves as they are computed.  When this option is 
checked, the QV curve displays will be updated and drawn during each step of the QV analysis process. 

Contingencies 

The new QVCC can calculate QV curves for the s pecified buses for both base and contingency conditions.  To 
analyze a set of contingencies, you must define the contingency set using the separate Contingency Analysis Form, 
which you can access from run mode by selecting Options / Tools – Contingency Analysis from the main menu. 

To have QVCC analyze these contingencies for each bus, check the box labeled Process each of the currently 
defined contingencies. Check the box labeled Skip base case for avoiding the computation of QV curves for base 
conditions. 
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PV/QV QV Curve Control/Results  

To perform the QV curve calculations, switch to the Control/Results  tab and press the Run button.  QVCC will 
respond by calculating QV curves for each of the specified scenarios (i.e. for each bus / contingency pair).  When it 
finishes the QV curve calculation for a scenario, it will record the critical points for the curve in a case information 
display.  These critical points include (V0, QV0), (Vmin, QVmin), (Vmax, QVmax), and (VQmin, Qmin).   

Each scenario can be identified using the bus number and name fields together with the case name field, which simply 
specifies either "BASE CASE" or the name of the contingency.  As with all case information displays, the QV Results 
case information display has a local menu that offers a number of options.  From the local menu, you can plot the QV 
curve for a scenario, record the (Q, V) pairs that comprise each curve to a text file or to an Excel spreadsheet, and 
clear the results. 

The QVCC interfac e remains active while the curves are calculated.  You can terminate the run at any time by clicking 
Stop. 
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PV/QV Refine Model 

Simulator PVQV has the ability to refine the system model to fix modeling idiosyncrasies that cause premature loss of 
convergence during the PV and QV curve studies.   This option is available from the main Voltage Stability menu. 

The user can refine the case in the following ways: 

Fix transformer taps  

If there are transformers that have Vmax and Vmin that are very close together, the power flow may have a difficult 
time converging.  This option allows the user to fix all transformer taps at their present values if their Vmax - Vmin is 
less than or equal to the user specified tolerance. 

Fix shunts  

If there are shunts that have Vmax and Vmin that are very close together, the power flow may have a difficult time 
converging.  This option allows the user to fix all shunts at their present values if their Vmax-Vmin is less than or 
equal to the user specified tolerance. 

Take units off AVR control 

If there are generators that have Qmax and Qmin that are very close together, the power flow may have a difficult 
time converging.  This option allows the user to remove these units from AVR control, thus locking their MVAR 
output at its present value, if their Qmax - Qmin is less than or equal to the user specified tolerance. 

These refinements will only be applied to those areas or zones that have the "Apply?" field set as YES in this dialog 
box. This field can be changed by right-clicking on it and selecting Toggle all to YES/NO or by double clicking on the 
field. 
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PV/QV QV Output 

The Output tab allows you to set a location for saving the results of the QV analysis to a file.  To save the QV analysis 
to a text file, specify the name of the file in the Save results in file  text box. You may click the Browse button to look 
for the path where you want to save the file.   

Another option on the Output tab is the check box labeled Plot curves as they are computed.  When this option is 
checked, the QV curve displays will be updated and drawn during each step of the QV analysis process. 

When the results are recorded and plotted, there is some question regarding how reactive power should be 
expressed. Check the option that better describes how you wish the tool to record reactive power in the When 
plotting V versus Q, treat Q as … option group. 

Optimal Power Flow (OPF) 

Overview 

PowerWorld Simulator Optimal Power Flow Overview 
Note: The OPF option in PowerWorld Simulator is only available if you have purchased the OPF add-on to the 
base package.  To learn more about the OPF, please feel free to read through the information contained in 
these help files.  Contact PowerWorld Corporation for details about ordering the OPF version of Simulator. 

The PowerWorld Simulator (Simulator) is an interactive power system simulation package designed to simulate high 
voltage power system operation.  In the standard mode Simulator solves the power flow equations using a Newton-
Raphson power flow algorithm.  However with the optimal power flow (OPF) enhancement, Simulator OPF can also 
solve these equations using an OPF.  In particular, Simulator OPF uses a linear programming (LP) OPF 
implementation.   

All of the OPF commands and options are accessed using the LP OPF main menu item.  Other commands in this 
menu are used to specify input options, see results, and store/retrieve OPF specific data into auxiliary files.   

The purpose of an OPF is to minimize an objective (or cost) function  by changing different system controls  taking into 
account both equality and inequality constraints  which are used to model the power balance constraints and various 
operating limits. 

In Simulator OPF the LP OPF determines the optimal solution by iterating between solving a standard power and then 
solving a linear program to change the system controls to remove any limit violations.  See OPF Primal LP for more 
details.   
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OPF Objective Function 
The objective of the OPF algorithm is to minimize the OPF objective function, subject to various equality and inequality 
constraints.  Since the objective of the OPF is to minimize an objective function, what objective function is used has a 
significant impact on the final solution.   

Currently two objective functions are available in Simulator OPF: Minimum Cost and Minimum Control Change.  
Minimum Cost attempts to minimize the sum of the total generation costs in specified areas or super areas.  Minimum 
Control Change attempts to minimize the change in the generation in the specified areas or super areas.   

To include an area or super area in the OPF objective function, simply change the Area AGC Status field to "OPF" on 
the OPF Area Records Display or the Super Area AGC Status field to "OPF" on the OPF Super Area Records Display.  
This gives you great flexibility in defining the OPF study.  For example you can set the OPF to minimize costs for the 
entire system, or just selected areas or super areas.    
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OPF Equality and Inequality Constraints 
In solving a constrained optimization problem, such as the OPF, there are two general classes of constraints, equality 
and inequality.  Equality constraints are constraints that always have to be enforced.  That is, they are always 
"binding".  For example in the OPF the real and reactive power balance equations at system buses must always be 
satisfied (at least to within a user specified tolerance); likewise the area MW interchange constraints.  In contrast, 
inequality constraints may or may not be binding.  For example, a line MVA flow may or may not be at its limit, or a 
generator real power output may or may not be at its maximum limit. 

An important point to note is because the OPF is solved by iterating between a power flow solution and an LP solution, 
some of the constraints are enforced during the power flow solution and some constraints are enforced during the LP 
solution.  The constraints enforced during the power flow are, for the most part, the constraints that are enforced 
during any power flow solution.  These include the bus power balance equations, the generator voltage set point 
constraints, and the reactive power limits on the generators.  What differentiate the LP OPF from a standard power 
flow are the constraints that are explicitly enforced by the LP.  These include the following constraints: 

Equality Constraints  

Inequality Constraints  
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OPF Equality Constraints 
Area MW Interchange   

The area MW interchange constraints are enforced during the LP for those areas that have an AGC Status  equal to 
"OPF" provided the area is not part of a super area that is also set on AGC.  The AGC Status  field for an area can 
be set using the OPF Area Records display, while the AGC Status  field for the super area (if any) is set using the 
OPF Super Area Records display.  Areas whose interchange is enforced during the LP do not have their 
interchange enforced during the power flow solution; during the power flow these areas are treated as though they 
were off of AGC (and hence the output of generators in that area is not varied during the power flow). 

It is perfectly acceptable to have some areas on "OPF" AGC control and to have other areas on the more traditional 
power flow area AGC such as "ED" or "Part. AGC."  The interchange for such areas is controlled during the power 
flow solution. 

Following a successful solution, marginal costs are calculated for the area interchange constraints; these values are 
displayed on the OPF Area Records display and can be contoured.    See OPF Marginal Costs for details.   

Bus MW and Mvar power balance    

Enforced during the power flow solution. Following a successful solution, marginal costs are calculated for the bus 
MW (real power) balance constraint; these values are displayed on the OPF Bus Records display and can be 
contoured.   

Generator Voltage Setpoint 

Enforced during the power flow solution.   Following a successful solution, marginal costs are calculated for the 
voltage setpoint constraint; these values are displayed on the OPF Bus Records display .  

Super Area MW Interchange  

Super area interchange constraints are enforced similar to the area constraints.  That is, super area interchange 
constraints are enforced during the LP only for those super areas that have an AGC Status  equal to "OPF."  The 
AGC Status field can be set using the OPF Super Area Records display.  During the power flow solution such 
super areas are treated as though they were off of AGC. 

Interface MW limits when treated as Equality 

Interface MW limits are enforced during the LP solution.  Interface MW limits are normally treated as inequality 
constraints (see Inequality Constraints ), however they can optionally be treated as equality constraints.  See the 
Interface Dialog for information on how to treat the limit as an equality constraint. 

Transmission Line and Transformer (Branch) MVA limits  

Branch MVA limits are enforced during the LP solution.  Branch MVA limits are normally treated as inequality 
constraints (see Inequality Constraints ), however they can optionally be treated as equality constraints.  See the 
Line Transformer Dialog for information on how to treat the limit as an equality constraint. 
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OPF Inequality Constraints 
The following classes of inequality constraints are enforced during the OPF solution.   

Generator real power limits  

Generator real power limits are enforced during the LP solution.   

Generator reactive power limits  

Generator reactive power limits are enforced during the power flow solution.   

Interface MW limits  

Interface MW limits are enforced during the LP solution.  In short, interface records are used to represent the 
aggregate flow through a number of different devices (see Interface Records<+> for details).  During the LP the MW 
flow through the interface is constrained to be less than or equal to a user specified percentage of its limit, provided 
the interface is active for enforcement.  For an interface to be active for enforcement the following three conditions 
must be met: 

• Interface enforcement must not be disabled for the case.  This field can be set from either the OPF Options 
dialog or the OPF Interface Records display.  The default is that case interface enforcement is not disabled.  
Also note that interface flow is limited to a percent of its limit as specified by the interface's Limit Monitoring 
Settings. 

• Interface enforcement must be active for at least one of the interface's areas.  Note, an interface is assumed to 
be in each area that contains at least one of its components.  This field can be set from the OPF Area Records 
display.  Note: the default is that interface enforcement is not active, so be sure to activate this if you want 
these constraints enforced. 

• Enforcement must be active for each individual interface.  This field can be set from the OPF Interface Records 
display or in the Limit Monitoring Settings Dialog.  The default is active. 

Each interface that is ac tive for enforcement is modeled as an inequality constraint, which may be either binding or 
not binding.  If the constraint is not binding then it does not impact the solution.  If a constraint is binding then it has 
an associated marginal cost of enforcement, which is shown on the OPF Interface Records display.   

Transmission Line and Transformer (Branch) MVA Limits   

Transmission line and transformer (branch) MVA limits are enforced during the LP solution.  During the LP the 
branch line flow is constrained to be less than or equal to a user specified percentage of its limit, provided the 
branch is active for enforcement.  For a branch to be active for enforcement the following three conditions must be 
met: 

• Line/Transformer enforcement must not be disabled for the case.  This field can be set from either the OPF 
Options dialog or the OPF Line/Transformer Records display.  The default is that case line/transformer 
enforcement is not disabled.  Also note that the branch flow is limited to a percent of its limit as specified by the 
branche's  Limit Monitoring Settings. 

• Branch enforcement must be active for the branch's area.  For tie-lines enforcement must be active for either 
area.  This field can be set from the OPF Line/Transformer Records display.  The default is that branch 
enforcement is not active , so be sure to activate this if you want these constraints enforced.  

• Enforcement must be active for each individual branch.  This field can be set from the OPF Line/Transformer 
Records display or in the Limit Monitoring Settings Dialog.  The default is active. 

Each branch that is active for enforcement is modeled as an inequality constraint, which may be either binding or 
not binding.  If the constraint is not binding then it does not impact the solution.  If a constraint is binding then it has 
an associated marginal cost of enforcement, which is shown on the OPF Line/Transformer Records display.    
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Determining Set of Active Inequality Constraints 
A key issue in quickly solving the OPF is for the LP to effectively determine the set of active inequality constraints.  
Currently this includes the line MVA limits and the interface MW limits.  Because the speed of the LP varies as the 
cube of the number of constraints active in the LP basis, it is extremely important to keep this number as small as 
possible.  Therefore it would be very computationally prohibitive to setup an inequality constraint for each transmission 
line and interface (except in very small systems.)  

The solution of setting up constraints only for those inequality constraints that are actually violating their limits is a 
step in the right direction, but suffers from the problem that during a solution a line may initially be violating its limit and 
then after the first iteration it is no longer violating.  However if it is not subsequently included as a constraint during 
the next iteration the solution may simply oscillate between enforcing/unenforcing this constraint.  This problem can be 
resolved by keeping that constraint in the basis even though it is no longer binding.   

However this raises a question about how to handle these constraints during future OPF solutions.  For example what 
would happen if a user solved the OPF, and then immediately resolved the OPF.  Following the first solution the 
constraint would be enforced so that it may actually be less than its limit.  However if this constraint is not included in 
the LP basis during the next solution the constraint may immediately violate during the first iteration, requiring a 
number of iterations just to return to the original initial solution.   

Simulator solves this issue by keeping track of the enforced constraints from one solution to the next.  Constraints are 
only removed from the basis if they the fall below a specified percentage of their limit.  This percentage is enterable on 
the Constraint Options page of the OPF Options Dialog.  This prevents the set of constraints in the basis from building 
up over time as a number of different system conditions (and hence constraints) are studied.  Also, at any time this set 
of constraints can be cleared using the Initialize OPF Button on the OPF Options Dialog. 

Also, the user is free to specify that a particular constraint always be included in the basis.  This is done by toggling 
the Constraint field to "Always" on the OPF Line/Transformer Records or OPF Interface Records displays.     
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OPF Unenforceable Constraints 
The goal of the LP OPF is to minimize the objective function subject to the user specif ied constraints.  However there 
is no guarantee that it is even possible to simultaneously satisfy all of the specified constraints.  In fact, it is quite easy 
to create a system in which all of the constraints cannot be enforced.  A simple example is a tw o bus system 
consisting of a single generator supplying a single load through a transmission line.  If the transmission line MVA 
rating is below the MVA of the load then it is impossible to supply this load while simultaneously satisfying the 
transmission line constraint.  In Simulator OPF such a situation is known as an unenforceable constraint.  In studying 
large systems, such as the U.S FERC 715 cases, such situations actually appear to be quite common.  Seemingly 
unenforceable constraints are often due to a lack of controls available to the LP OPF or due to faulty limits entered in 
the case.  In such cases unenforceable constraints can be corrected by making more controls available to the LP OPF 
or correcting the limits.   

Simulator OPF allows you to solve systems with unenforceable constraints by only enforcing those constraints that 
have a marginal cost below a user specified tolerance.  These tolerances are specified on the OPF Options Constraint 
Options Page.  Any constraints that have marginal costs above these values are not enforced, including any 
unenforceable constraints.  This functionality is implemented in Simulator OPF through the use of slack variables.  
Slack variables are artificial variables introduced during the LP solution in order to satisfy the constraints with the slack 
variable costs equal to the user specified values.  Then, during the LP solution the slack variables are usually removed 
from the LP basis.  The only time this does not occur is if the constraint can not be enforced with a marginal cost less 
than the specified value.  The number of unenforceable constraints are shown on the OPF Option Solution Results 
Page.    
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OPF Marginal Costs 
During any constrained minimization there is practically always a cost associated with enforcing the equality 
constraints and the binding inequality constraints.  These costs are known as the marginal costs.   

 

In Simulator OPF marginal costs are calculated for the following record types: 

Bus MW Equality Constraints  

The Bus MW marginal costs tell the incremental cost to supply one additional MW of load at the specified bus.  
These values can be viewed on the OPF Bus Records display; they can also be contoured or viewed on the one-
lines using bus fields. 

In the absence of any binding inequality constraints (such was Line MVA constraints) all of the bus marginal costs in 
an area should be identical.  Bus marginal costs can only be determined for buses that are in areas or super areas 
on OPF control.    

Area MW Equality Constraints  

The Area MW marginal costs tell the incremental cost for the specified area to import one additional MW of load 
from the system slack bus.  These values can be viewed on the OPF Area Records display; they can also be 
contoured or viewed on the one-lines using area fields.  In the absence of any binding inequality constraints the 
area MW marginal cost is identical to the bus MW marginal costs for all the buses in the area.  When there are 
binding inequality constraints this is no longer the case.  

Super Area MW Equality Constraints  

The Super Area MW marginal costs are identical to the area marginal costs except they apply to super areas rather 
than areas.   

Interface MW Constraints  

The Interface MW marginal costs tell the incremental cost of enforcing the interface MW constraints.  These values 
are only nonzero if the interface constraint is actually active (binding); they can be viewed using the OPF Interface 
Records display.   

Line/Transformer MVA Constraints  

The Line/Transformer marginal costs tell the incremental cost of enforcing the line or transformer MVA constraint.  
These values are only nonzero if the line or transformer constraint is actually active; they can be viewed using the 
OPF Line/Transformer Records display.   
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OPF Primal LP 
Select LP OPF > Primal LP to solve the OPF using the primal LP algorithm.   

In Simulator OPF the LP OPF determines the optimal solution by iterating between solving a standard power and then 
solving a linear program to change the system controls to remove any limit violations.  The basic steps in the LP OPF 
algorithm are 

• Solve the power flow  

• Linearize the power system about the current power flow solution.  Both constraints and controls are linearized.     

• Solve the linearly-constrained OPF problem using a primal LP algorithm, computing the incremental change in the 
control variables.  Slack variables are introduced to make the problem initially feasible.  That is, the slack variables 
are used to satisfy the equality and inequality constraints.  The slack variables typically have high costs so that 
during the iteration the slack variables change to satisfy the constraints.  The LP then determines the optimal, 
feasible solution for the linear problem.   

• Update the control variables and resolve the power flow. 

• If the changes in the control variables are below a tolerance then the solution has been reached; otherwise go to 
step 2. 

• Finish by resolving the power flow.   
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OPF Primal LP Single Outer Loop 
Select LP OPF > Single Primal LP Outer Loop to solve a single outer loop of the primal LP OPF algorithm.  See 
OPF Primal LP for a description of the LP OPF solution algorithm.  What this command does is just one loop through 
the algorithm (the jump back to step 2 is never executed).  Thus this command allows you to manually perform an LP 
OPF solution.  This can be helpful at times for figuring out what is going on during a particular OPF solution.   
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OPF Future Enhancements 
In this first version of Simulator OPF we have implemented the OPF functionality that will, we believe, be most useful 
to the largest number of users.  While we certainly plan on introducing additional functionality in future releases, we do 
want to be as clear as possible about what functionality is not currently provided. 

In short the current version of Simulator OPF allows users to calculate the optimal solution to a power system using 
generator real power MW outputs and phase shifters as controls, while enforcing area, super area, interface MW and 
line/transformer MVA constraints.  During the OPF solution, similar to what is done in the U.S. by the PJM interchange, 
the incremental impact of losses are not included.  Thus, as was mentioned earlier, in the absence of binding 
inequality constraints all the bus marginal costs in an area will be equal.  

Some functionality that is not included in the current version of Simulator OPF, and which we hope to include in future 
versions, include the following: 

• Enforcing bus low/high voltage magnitudes as limits 

• Including additional devices as controls, such as generator voltage setpoints, LTC transformers, switched shunts, 
dc line setpoints.   

• Allowing the optimization of different cost functions, such as maximization of social welfare.   

• Additional functionality as suggested by customers.   

We hope you have found the current version of Simulator OPF useful, and look forward to interacting with customers 
to help determine additional functionality for future versions.  

Options  

OPF Options 
The OPF Options dialog allows you to customize the OPF solution.  To display this dialog, select LP OPF > Options . 
The dialog consists of three general pages; Options, Results and LP Solution Details.   

The Options page has three tabs as well, Common Options, Constraint Options, and Control Options.    

The Results page has four tabs, Bus MW Marginal Price Details, Bus Mvar Marginal Price Details, Bus Marginal 
Controls, and Solution Summary.  

The LP Solutions Page has five tabs, All LP Variables, LP Basic Variables, LP Basis Matrix, Inverse of LP Basis, and 
Trace Solution. 

 

The dialog also has several buttons at the bottom of the display: 

OK, Cancel 

Select to close the dialog.  Selecting OK saves your changes while Cancel does not.  Note that changes are also 
saved anytime you select Solve LP OPF or Single Outer Loop.   

Solve LP OPF 

Solves the OPF using the Primal LP algorithm.  Equivalent to selecting LP OPF, Primal LP.   

Single Outer Loop 

Does a single outer loop of the Primal LP algorithm.  Equivalent to selecting LP OPF, Single Primal LP Outer Loop.   

Initialize LP OPF 

Returns the LP OPF variables to their original states. 

Print 

Prints the selected page of the dialog. 

Help 

Displays this help page.  To view help for a particular page place the cursor on the page and press the F1 key.   
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OPF Options - Common Options 
The OPF Dialog, Common Options page displays general options associated with the OPF solution.  The display 
contains the following fields: 

   

Objective Function 

Allows a choice of solving the LP using either a minimum cost or a minimum control change objective function. 

 

  Controls  

Disable All Phase Shifter Controls  

Prevents phase shifters from attempting to control devic es during the OPF solution. 

Disable All Generator MW Controls  

Prevents generators from shifting MW output during the OPF solution. 

Disable All Load MW Controls  

Prevents loads from shifting MW demand during the OPF solution. 

Disable Area-toArea MW Transaction Controls  

Prevents MW transactions between areas from being dispatched during the OPF solution. 

 

LP Options  

Maximum Number of LP Iterations  

Maximum number of allowable iterations for the LP portion of the LP OPF.  How many iterations are required to 
obtain a solution depends, among other things, upon the number of breakpoints in the control cost models.  Since 
each LP iteration can only move from one breakpoint to the next, the finer the model the more iterations required.  
However the LP is quite fast so a large number of iterations can be performed quite quickly.  Default = 1000.   

Phase Shifter Cost ($ / Degree) 

Specifies the assumed cost for moving phase shifting transformer taps away from their initial values.  The purpose 
for this fictitious cost is approximate the cost of actually changing the angle of a phase shifting transformer, and to 
avoid large changes in phase shifter angles that have very little impact on the system.  This field may be zero.  
Default = $ 0.10 / Degree. 

Calculate Bus Marginal Cost of Reactive Power 

When this option is checked, the OPF algorithm will also calculate the marginal cost of reactive power at each bus.  
Typically the result of interest from the OPF algorithm is the MW marginal cost of each bus (the LMP), but the 
MVAR marginal cost can be determined as well. 

Save Full OPF Results in PWB File 

When checked, Simulator will store the full set of results, including the LP matrix, in the PowerWorld Binary case 
file. 

Do Detailed LP Logging 

When checked, Simulator will write details on the LP algorithm solution during each pivot of the LP matrix.  This is 
useful for debugging LP solution issues when running a LP OPF solution. 

 

Power Flow Recalculation 

Resolve Power Flow 
Choose one of the options to determine how often the power flow is resolved.  The three options are, "When total 
generator MW change > than tolerance"; "After each LP solution"; and "Only at end of LP OPF".  

Total Generator Change Tolerance (MW) 

Specifies the total generator change tolerance.  The default is 500 MW. 
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OPF Options - Constraint Options 
The OPF Dialog, Constraint Options page displays options associated with the enforcement of the constraints by the 
OPF.  The display contains the following fields: 

 

Line/Transformer Constraints  

Disable Line/Transformer MVA Limit Enforcement 

Select to disable enforcement of Line/Transformer MVA constraints for the entire case.   

Percent Correction Tolerance 

Specifies a tolerance for the enforcement of line/transformer MVA flows.  The tolerance is necessary to prevent 
solution oscillations due to the non-linear nature of the actual constraints.   

Violated elements are always enforced to their limits multiplied by the MVA Enforcement Percentage.   If power 
systems were completely linear then following the LP solution the constraint would actually be equal to this value.  
However because of nonlinearities, the constraint is close to this value but usually not identical to the value.  The 
Percent Correction Tolerance is used to tell the OPF how close is close enough.  Provided all the constraints are 
violating their limits by less than the correction tolerance percentage the optimal solution is assumed to have been 
found.  You may set this value as low as you like, but setting it too close to zero may result in convergence 
difficulties.  The default is 2 percent.  

MVA Auto Release Percentage  

Specifies a MVA level at which transmission lines can be released as an OPF constraint equation if the branch MVA 
flow falls below the level specified. 

Maximum Violation Cost ($/MWhr) 

If a branch MVA limit cannot be enforced during an OPF solution, the branch will be assigned a fictitious cost of 
enforcement equal to this value.  This value is usually rather large in order to easily determine where the 
unenforceable constraint is occurring.  The default value is 1000 $/MWhr. 

Enforce Line/Transformer MW Flow Limits (Not MVA) 

Checking this box will cause Simulator to treat the limits of the transmission elements as MW limits instead of MVA 
limits.  Thus Simu lator will report violations on these elements in the OPF based on the MW flow of the element 
versus the elements rating. 

 

Interface Constraints  

Disable Interface MW Limit Enforcement 

Select to disable enforcement of Interface MW constraints for the entire case. 

Percent Correction Tolerance, MW Auto Release Percentage, Maximum Violation Cost ($/MWhr) 

These fields are equivalent to the entries described above for Line/Transformer MVA Constraints except that they 
apply to Interface MW constraints. 

Monitor/Enforce Contingent Interface Limits  

This option allows you to choose if contingency elements in interfaces should be enforced during the OPF solution.  
Even if they are not enforced, the flows on the remaining elements in the interface will be monitored.  The choices 
you have for enforcing contingency elements in interfaces during the OPF are Never, Power Flow/OPF but not 
CA/SCOPF, or All Applications including CA/SCOPF.  The reason CA (contingency analysis) and SCOPF (Security 
Constrained OPF) are singled out is because those two tools are already looking at contingency actions separately, 
outside of the interface definitions.  Therefore it may be desired to ignore the inclusion of contingency elements 
within an interface definition when using these two tools. 

 

Limit Monitoring Settings… 

This button opens the Limit Monitoring Settings dialog, which allows you to change the enforcement percentages for 
monitored elements. 
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OPF Options - Control Options 
The LP OPF Dialog, Control Options page displays options for generator control and power flow solution.  The display 
contains the following options: 

 

Generator Control Options  

Allow Commitment of Fast Start Generators 

If this option is checked, then generators designated as Fast Start generators can be turned on or "committed" if the 
OPF routine determines that doing so would reduce the overall generating costs of the system. 

See the Fast Start description in the help on OPF Generator Records for a more detailed description of the Fast 
Start option of generators. 

Allow Decommitment of Fast Start Generators 

If this option is checked, then generators designated as Fast Start generators can be turned off or "de-committed" if 
the OPF routine determines that doing so would reduce the overall generating costs of the system. 

See the Fast Start description in the help on OPF Generator Records for a more detailed description of the Fast 
Start option of generators. 

 

Modeling Generators without Piecewise Linear Cost Curves 

The following fields specify how the OPF should handle generators that are specified as having a cubic cost model.  
Because the OPF is based upon an LP implementation, all control costs must be modeled using piecewise linear cost 
curves.  These options permit an automatic conversion of cubic models to piecewise linear models.  Alternatively, you 
can very easily convert the cubic models manually using the # Cost Curve Points field on the OPF Generator 
Records display or using the generator dialog.   

Generators Cost Models  

This field specifies how generators with cubic cost models should be handled in the OPF.  The field has three 
values 

Ignore Them -  Generators with cubic cost models are Ignored during the OPF solution.  That 
is, they are considered as though their AGC status was off.  

Change to Specified Points per Curve  - A piecewise linear cost model is automatically inserted for the generator 
with a fixed number of points specified in the Total Points Per Cost Curve 
field described below.  This curve will approximate the generator's cubic cost 
model as closely as possible; the existing cubic model is not modified.  This is 
the default value. 

Change to Specified MWs per Segment - A piecewise linear cost model is automatically inserted for the generator 
such that each segment in the cost model covers the amount of MWs specified 
in the MWs per Cost Curve Se gment field described below.  This curve will 
approximate the generator's cubic cost model as closely as possible; the 
existing cubic model is not modified.   

Total Points Per Cost Curve  

Specifies the total number of segments that should be automatically inserted into the piecewise linear cost models 
for those generators that are modeled using cubic cost functions.  This is only done if the Generator Cost 
Modeling field is Change to Specified Points per Curve.  Default = 5.   

MWs per Cost Curve Segment 

Specifies the number of MWs for each segment of the piecewise linear cost models that are automatically inserted 
for those generators that are modeled using cubic cost functions.  This is only done if the Generator Cost 
Modeling field is Change to Specified MWs per Segment.  Default = 10 MW.   

Save Existing Piecewise Linear Cost Curves 

Generators that are modeled with cubic cost curves may have existing piecewise linear cost curves which  may 
have been manually entered by the user.  These curves may or may not resemble the cubic cost function.  During 
the OPF solution the existing piecewise linear cost curves are replaced with the auto-created cost curves.   If this 
option is checked then the existing piecewise linear cost curves are restored at the end of the OPF.  The default 
and recommended option is false since this allows one to view the actual cost curves used by the OPF. 

If you would like to use a particular piecewise linear cost function simply make sure that the generator is modeled 
using the piecewise linear model, which can be set on the OPF Generator Records display.     

Case OPF Options File  

This optional field is used to specify a default file name for storing OPF specific data.  The OPF specific data is 
always stored with the pwb file.  Additionally, in order to make it easy to transfer the OPF specific data between 
cases, this data may be stored in a pwo auxiliary file as well using the LP OPF, Store LP OPF Data command.  The 
Case OPF Options File  field specifies the default name for this file. 
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Modeling of OPF Areas/Superareas  

During the Initial OPF Power Flow Solution 

Choose what manner of generation control you wish to be employed in the FIRST power flow solution the OPF will 
perform, which will establish the base case load flow condition for performing the subsequent OPF generation 
dispatch. 

During Stand-Alone Power Flow Solutions  

Choose what manner of generation control you wish to be employed in all load flow solutions FOLLOWING the 
initial load flow solution.  In other words, after the LP OPF routine has determined the new generation dispatch, 
what type generation dispatch should be used during the normal load flow solution. 

NOTE: it is NOT recommended that you use Economic Dispatch in this case, although it is an available option.  The 
reason it is not recommended is that you will remove the optimal dispatch (including constraints) just determined by 
the OPF in favor of lowest cost economic dispatch, which will likely result in the re-introduction of overloaded 
elements that were corrected by the OPF dispatch in the first place. 
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OPF Options - Solution Results 
The OPF Dialog, Solution Results page displays general results from the last OPF solution.  The display contains the 
following fields, none of which can be directly changed: 

 

General Results  

Solution Start Time, Solution End Time 

The starting time and ending time of the OPF solution algorithm. 

Total Solution Time, Last Solution Status  

Time and status of the last OPF solution.   

Number of LP Iterations  

Total number of LP iterations used during the last OPF solution.  The maximum number of iterations are specified in 
the Maximum Number of Iterations field of the General Options page.   

Initial Cost Function Value  

Initial value of the OPF cost function.  During the OPF the solution algorithm seeks to minimize the cost function, 
subject to the equality and inequality constraints. 

Final Cost Function Value  

Final value of the OPF cost function. 

Final Slack Cost Value  

The slack cost value is an artificial cost that is only non-zero when there are one or more unenforceable constraints.   

Final Total Cost Value 

The addition of the final cost function value and the final slack cost value. 

Number of Buses in OPF 

This field contains the total number of buses that are in areas or super areas that are on OPF control.  Thus this 
field need not be equal to the total number of buses in the case.  Marginal costs are only calculated for buses in 
OPF controlled areas or super areas. 

Highest Bus Marginal Cost, Lowest Bus Marginal Cost, Average Bus Marginal Cost 

Highest, lowest and average marginal cost for the buses that are in OPF controlled areas or super areas. 

Bus MC Standard Deviation 

The standard deviation of the Bus Marginal Cost. 

 

Line MVA Constraints  

The Line MVA Constraints  fields present results associated with the enforcement of the line MVA constraints. 

Number of Initial Violations, MVA Sum of Initial Violations  

Total number of lines that initially exceeded their MVA limits and were eligible for enforcement by the OPF.  For 
these lines only, the MVA Sum of Initial Violations field contains sum of the absolute values of the line's actual 
MVA flow minus the line's MVA limit.   

Number of Binding Lines 

Total number of lines that are constrained to their limit value. 

Highest Line MVA Marginal Cost 

The highest Marginal Cost for an MVA change on a line. 

Number of Unenforceable Violations  

Total number of lines whose MVA flows can not be enforced by the OPF using the available controls.   

MVA Sum of Unenforceable Violations  

For all the unenforceable lines, this field contains the sum of the absolute values of the line's actual MVA flow minus 
the line's MVA limit.   

 

Interface MW Constraints  

The Interface MW Constraints  field present results associated with the enforcement of the interface MW constraints. 

Number of Initial Violations, MW Sum of Initial Violations  

Total number of interfaces that initially exceeded their MW limits and were eligible for enforcement by the OPF.  For 
these interfaces only, the MW Sum of Initial Violations field contains sum of the absolute values of the interface's 
actual MW flow minus the interface's MW limit.   



Printed Documentation 

502 

Number of Binding Interfaces 

Total number of interfaces that are constrained to their limit value. 

Highest Interface MW Marginal Cost 

The highest Marginal Cost for an MVA change on an interface. 

Number of Unenforceable Violations  

Total number of interfaces whose MW flows can not be enforced by the OPF using the available controls.   

MW Sum of Unenforceable Violations  

For all the unenforceable interfaces, this field contains the sum of the absolute values of the interface's actual MW 
flow minus the interface's MW limit.   

 

Area and Superarea Constraints  

Unenforceable Area Constraints  

Number of unenforceable area constraints.   

Unenforceable Superarea Constraints  

Number of unenforceable superarea constraints.   
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OPF Options - All LP Variables 
The OPF Dialog, All LP Basic Variables page displays the basic and non-basic variables associated with the final LP 
solution.  This page is usually only of interest to users interested in the specifics of the LP solution.  Right click any 
where in the display to copy a portion or all of the display to the Window's clipboard, or to print the results.   

 

The display lists each of the LP variables, showing the following fields for each: 

ID 

Variable identifier. 

Original Value  

The initial value of the LP variable before SCOPF optimization. 

Value 

The final value of the LP variable after OPF optimization. 

Delta Value  

The difference between the original value field and the value field. 

Basic Var 

Shows the index of the basic variables in the LP basis.  If the value is zero, the variable is non-basic. 

NonBasicVar  

Shows the index of the non-basic variable.  If the value is zero, the variable is basic.  

Cost(Down) 

The cost associated with decreasing the LP variable.  The field will show if the variable is at its max or min limit. 

Cost(Up) 

The cost associated with increasing the LP variable.  The field will show if the variable is at its max or min limit. 

Down Range  

The available range to decrease the basic variable before a new constraint is hit under a contingency condition.  

Up Range 

The available range to increase the basic variable before a new constraint is hit under a contingency condition.  

Reduced Cost Up 

The cost reduction that would be experimented if a LP variable increases.  If a constraint is at the limit, the field 
shows the change in cost of constraint enforcement.  

Reduced Cost Down 

The cost reduction that would be experimented if a LP variable decreases.  If a constraint is at the limit, the field 
shows the change in cost of constraint enforcement.  

At Breakpoint? 

Yes, if the LP variable is at a break point. 
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OPF Options - LP Basic Variables 
The OPF Dialog, LP Basic Variables page displays the basic variables associated with the final LP solution.  This page 
is usually only of interest to users interested in the specifics of the LP solution.  Right click any where in the display to 
copy a portion or all of the display to the Window's clipboard, or to print the results.   

 

The display lists each of the basic variables, showing the following fields for each: 

ID 

Basic variable identifier. 

Original Value  

The initial value of the basic LP variable before the OPF optimization. 

Value 

The final value of the basic LP variable after the OPF optimization. 

Delta Value  

The difference between the original value field and the value of the basic variable. 

Basic Var 

Shows the indices of the basic variables in the LP basis.  

Cost(Down) 

The cost associated with decreasing the basic variable.  

Cost(Up) 

The cost associated with increasing the basic variable.  

Down Range  

The available range to decrease the basic variable before a new constraint is hit under a contingency condition.  

Up Range 

The available range to increase the basic variable before a new constraint is hit under a contingency condition. 
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OPF Options - LP Basis Matrix 
The OPF Dialog, LP Basis Matrix page displays the basis matrix associated with the final LP solution.  This page is 
usually only of interest to users interested in knowing the specifics of the LP solution.  Knowing the basis matrix can be 
helpful in figuring out why a particular power system is exhibiting a particular behavior.  The rows of the basis matrix 
are the binding constraints, while the columns of the basis matrix are the basic variables.  The entries in the basis 
matrix then give the sensitivity of each constraint to each of the basic variables.  The width of the columns in the matrix 
can also be adjusted using the Column Widths  field.  Finally, right-click somewhere in the matrix to copy the matrix to 
the Window's clipboard or to print the matrix. 
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OPF Options - Bus MW Marginal Price Details 
The Bus MW Marginal Price Details page displays a grid containing the MW marginal prices computed for an OPF 
solution.  If no OPF solution has been run, the values will all be zero.   The grid used for displaying the information is a 
Case Information Display, which can be modified, sorted, printed, etc., as described in the discussion of Case 
Information Displays. 
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OPF Options - Bus MVAR Marginal Price Details  
The Bus MVAR Marginal Price Details page displays a grid containing the MVAR marginal prices computed for an 
OPF solution.  If no OPF solution has been run, or if the option to compute MVAR marginal prices has not been 
selected, the values will all be zero.   The grid used for displaying the information is a Case Information Display, which 
can be modified, sorted, printed, etc., as described in the discussion of Case Information Displays. 
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OPF Options - Bus Marginal Controls 
This display shows the sensitivities of the controls with respect to the cost at each bus.  A change in a system control 
will have the indicated effect in the marginal cost at the system buses .  Vice-versa, the marginal cost at a bus is 
affected by changes in the value of the basic variables. 
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OPF Options - Inverse of LP Basis 
The OPF Dialog, LP Basis Matrix page displays the inverse of the basis matrix.  The width of the columns in the matrix 
can also be adjusted using the Column Widths  field.  Finally, right-click somewhere in the matrix to copy the matrix to 
the Window's clipboard or to print the matrix. 

OPF Records  

OPF Area Records  
Displays OPF specific information about each area record in the case.  To show this display select LP OPF, OPF Area 
Records .  The OPF Area Records Display is a class of Case Information Display and therefore can be used in a 
manner consistent with the other case information displays.  Specific formatting options are available from the local 
menu, which can be accessed by right-clicking on any field in the display.  The columns can also be sorted by right-
clicking on the heading of the field.   

 

By default the display contains the following fields: 

Number, Name 

Area’s number, between 1 and 999, and its alphanumeric identifier, eight characters maximum. 

AGC Status  

Area's automatic generation control status.  This is the same field shown on the Area Records Display.  The field 
indicates whether or not the area's generation is changing automatically to control the area interchange.   

To be included in the OPF, this field MUST be "OPF".  The generation costs for areas that are on "OPF" control are 
included in the OPF objective function; otherwise they are not.  Note that if the area is part of a super area that is on 
AGC control, this field value is ignored.    

Double-click on the field to toggle its value. 

XF Phase 

Specifies whether phase shifting transformers in the area are available as controls.  If "Yes" then all transformers in 
the area which have their Automatic Control Active are available for control; the Automatic Control status for a 
transformer is set on the Line/Transformer Dialog.  If "No" then no transformers in the area are available for control. 

Branch MVA 

Specifies whether or not the MVA limits should be enforced for transmission lines and transformers that have at 
least one terminal in this area.  For a transmission line or transformer to be included Line/Transformer constraints 
must not be disabled on the OPF Options Dialog, and the individual line/transformer must be enabled for 
enforcement on the OPF Line/Transformer MVA Constraints display .    

Interface MW 

Specifies whether or not the MW limits should be enforced for interfaces that have at least one element in this area.  
For an interface to be included Interface constraints must not be disabled on the OPF Options Dialog, and the 
individual interfaces must be enabled for enforcement on the OPF Interface MW Constraints display. 

Load MW Dispatch 

Specifies whether or not the MW load demand in an area should be included as available for re-dispatch during an 
OPF solution.  In order for loads to be included in OPF re-dispatch, each individual load within the area must be 
available for control, and have either a fixed cost benefit or a piecewise-linear cost benefit curve provided. 

Include Marg. Losses 

Specifies whether or not marginal losses should be included for the area during the OPF solution. 

MW Marg. Cost Ave  

For an OPF solved case this field shows the average of the bus MW marginal costs for all the buses in the area.  If 
there is no congestion then all of the marginal costs should be equal.   

MW Marg. Cost St.Dev., Min., Max. 

For an OPF solved case these fields show the standard deviation of the bus MW marginal costs for all the buses in 
the area, the minimum and the maximum bus MW marginal costs.    

Report Limits  

Specifies whether or not the kV limits should be reported. 

Report Min kV, Report Max kV 

Specifies the values for minimum and maximum kV levels to report.  Defaults are 0 and 9999. 
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OPF Bus Records  
Displays OPF specific information about each bus record with a valid area/zone/owner filter.  To show this display 
select LP OPF, OPF Bus Records .  The OPF Bus Records Display is a class of Case Information Display and 
therefore can be used in a manner consistent with the other case information displays.  Specific formatting options are 
available from the local menu, which can be accessed by right-clicking on any field in the display.  The columns can 
also be sorted by right-clicking on the heading of the field.   

 

By default the display contains the following fields 

Number, Name 

Bus’s number, between 1 and 99,999, and its alphanumeric identifier, eight characters maximum.   

Area Name 

Name of the bus's area. 

MW Marg. Cost 

Marginal change in the objective function for a one MW change in the real power load at the bus.   

MVR Marg. Cost 

Marginal change in the objective function for a one Mvar change in the reactive load at the bus.   

Volt Marg. Cost 

Marginal change in the objective function for a 0.01 per unit change in the voltage setpoint for the bus.  This field is 
only valid at bus’s whose terminal voltage is controlled by one or more generators.   

Note from the developers – this field is still under construction – do not use it yet. 



PowerWorld Simulator Add-on Tools 

511 

OPF Generator Records  
Displays OPF specific information about each generator record with a valid area/zone/owner filter.  To show this 
display select LP OPF > OPF Generator Records .  The OPF Generator Records Display is a class of Case 
Information Display and therefore can be used in a manner consistent with the other case information displays.  
Specific formatting options are available from the local menu, which can be accessed by right-clicking on any field in 
the display.  The columns can also be sorted by right-clicking on the heading of the field.   

 

By default the display contains the following fields 

Number, Name 

Number and name of the bus to which the generator is attached.  The display's local menu offers you the 
opportunity to view the Quick Power Flow List and the Bus View Display for this bus.  You can also use the local 
men to view the generator's dialog.   

ID 

Alphanumeric ID used to distinguish multiple generators at the same bus. 

Area Name of Gen 

Name of the generator's area. 

AGC 

Designates whether the generator's real power output is governed by automatic generation control (AGC).  If the 
AGC field is set to Yes the generator is on AGC in the standard power flow.  When a generator is on AGC its real 
power output is varied automatically, provided the generator is part of an area or super area that is also on 
automatic control.   

In Simulator OPF the default operating mode is that only generators on AGC control are eligible to be OPF controls.  
In addition, the generator's area or super area must have AGC Status of "OPF".   However in rare instances you 
may wish to always make a generator available for control or never make the generator available for control.  This 
value is specified using OPF MW Control field. 

Fast Start 

Designates whether the generator is available as a Fast Start generator during the OPF solution process.  Fast start 
generators are another type of control available to the Optimal Power Flow solution routine.  The OPF routine can 
determine if a generator labeled as a fast start generator would be beneficial in reducing the overall system costs of 
generation dispatch.  If a fast start generator is off-line, but could reduce the cost of the system, then the OPF 
routine will turn on the generator, and increase the generator's dispatch towards optimizing the system generating 
cost.  Conversely, if a fast start generator is on-line, and the OPF routine determines that reducing the generator's 
output to 0 would reduce the total generation cost, then the OPF routine will shut off the generator. 

Generally speaking, the fast start options should only be used with units with zero Minimum MW limits.  Hence it is 
really aimed at hydro units, or small units which do not need a non-zero minimum MW output for valid operation.  
This requirement is needed because changing a unit's status is only valid in the OPF routine if it is determined that 
the unit should dispatch 0 MW to optimize the generating costs of the system. 

OPF MW Control 

Designates whether the generator's real power output should be included as a control variable in the OPF.  This 
field, which can be toggled, has three possible values: 

• "If AGCable" - Generator's control availability depends upon its AGC status. 

• "Yes" - Generator is available as a control, regardless of its AGC status. 

• "No" - Generator is NOT available as a control, regardless of its AGC status.   

Note: in order to be a control the generator must also be in an area or super area on "OPF" control.   

Gen MW 

The real power output of the generator. 

Cost Shift $/MWh, Cost Multiplier 

The cost shift and cost multiplier allow you to easily apply a shift to the cost function for the purpose of assessing 
how variations in bids impact profit.  The cost function is affected based on the following equation: 

(Original Cost Function + Cost Shift) * Cost Multiplier 

Cost $/Hr  

The total cost of the generator, including the impact of the cost shift and cost multiplier. 

MW Marg. Cost 

Tells the marginal cost, in $ / MWhr, to supply one additional MW of load at this bus.  If a generator is available as a 
control and is not at either its minimum or maximum limit or a cost model breakpoint, then the MW Marg. Cost field 
will be identical to the generator's current marginal cost.  However the usual case is for the generator to be at either 
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a limit or a cost model breakpoint so the usual situation is that the MW Marg. Cost field values IS NOT equal to the 
generator's marginal cost.   

IC for OPF 

Incremental cost of the generator at its current operating point. 

Initial MW 

The initial real power output of the generator at the beginning of the OPF solution.  You can reset the case back to 
these values by selecting the LP OPF, Restore Previous Control Settings menu item.  This menu item is only 
available following a successful OPF solution.     

Initial Cost 

The initial generator cost at the beginning of the OPF solution. 

Delta MW 

Change in the generator's real power output as a result of the OPF.   

Delta Cost 

Change in the generator's cost as a result of the OPF. 

Min MW, Max MW 

Minimum and maximum real power output of the generator.   

Cost Model 

The current cost model being used for the generator.  The field value is either "Cubic", indicating that the 
generator's operating costs are being modeled using a cubic cost function, or "Piecewise Linear", indicating the 
operating costs are being modeled using a piecewise linear cost function.  Toggle the field to change the model.  
Note that a generator may simultaneously have a cubic model and a piecewise linear model.   

Because the OPF uses a linear programming approach, the generator's operating costs are ALWAYS modeled 
using the piecewise linear model.  Generators with an existing cubic cost model are either 1) ignored as OPF 
controls, or 2) have a piecewise linear cost model automatically created from the cubic model, depending upon the 
values s pecified on the OPF Options dialog.   

# Cost Curve Points  

Shows the number of segments in the piecewise linear model.  If no piecewise linear model exists then this field is 
zero; the generator's costs are being modeled using the cubic function.  For such generators you can automatically 
setup a piecewise linear model simply by entering a non-zero value for the number of points.  A piecewise linear 
model is created that matches as closely as possible the existing cubic model.   

Fuel Type  

Specifies the fuel type of the generator, if it is known; double-click to toggle through the options.  Options are 
Unknown, Coal, Gas, Hydro, Hydro Pumped, Nuclear, Petroleum, Solar, Wind, and Other. 

Profit $/hr 

Shows the profit of the generator.  Profit is calculated using this equation:   

Profit = (GenMW * MW Marg Cost ) – [ FuelCost*( IOA + IOB * GenMW + IOC * GenMW 2  + IOD * GenMW 3 ) ] 
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OPF Interface Records  
Displays OPF specific information about the interface records in the case.  To show select LP OPF > OPF Interface 
Records.   This display is actually a page of a display showing all the potential inequality constraints in the power 
system.  The top portion of the display repeats the fields shown on the Constraint Options page of the OPF Options 
dialog.   

To view the Interface records click on the Interfaces tab.  This displays the interfaces page which is a class of Case 
Information Display and therefore can be used in a manner consistent with the other case information displays.  
Specific formatting options are available from the local menu, which can be accessed by right-clicking on any field in 
the page.  The columns can also be sorted by right-clicking on the heading of the field.   

 

By default the Interface Records page contains the following fields: 

Name 

Name of the interface. 

Monitor 

Specifies whether or not the interface MW limit is enforced in the OPF solution. 

Interface MW 

The amount of MW flow on the interface. 

MW Limit 

The interface MW limit. 

Percent 

The amount of MW flow on the interface as a percentage of the limit. 

Monitor Direction 

The direction on the interface in which the flow is being monitored. 

MW Marg. Cost $ / MWh  

The marginal cost of enforcing the limit on the interface. 

MW Unenforceable  

This field will be set to YES if the interface limit is unenforceable in the OPF solution. 

Constraint 

This field will be set to YES if the interface limit is a constraint in the OPF solution. 



Printed Documentation 

514 

OPF Nomogram Records  
This list displays OPF specific information about the nomogram records in the case.  To show the list, selec t LP OPF > 
OPF Nomograms.   This display is actually a page of a display showing all the potential inequality constraints in the 
power system.  The top portion of the display repeats the fields shown on the Constraint Options page of the OPF 
Options dialog.   

To view the nomogram records click on the Nomogram Interfaces tab.  This displays the nomogram interfaces page 
which is a class of Case Information Display and therefore can be used in a manner consistent with the other case 
information displays.  Specific formatting options are available from the local menu, which can be accessed by right-
clicking on any field in the page.  The columns can also be sorted by right-clicking on the heading of the field.   

 

By default the Interface Records page contains the following fields: 

Nomo. Name 

Name of the nomogram. 

Nomo. Seg. 

The segment of the nomogram.  Each segment of the nomogram is treated as a separate constraint in the OPF, 
and therefore is listed individually in the OPF nomogram table. 

Monitor 

This field will be set to YES if the nomogram segment is monitored during the OPF. 

Interface MW 

The total MW flow for the segment of the nomogram. 

MW Limit 

The segment MW limit. 

Percent 

The amount of MW flow on the segment as a percentage of the segment’s limit. 

Monitor Direction 

The direction on the segment in which the flow is being monitored. 

MW Marg. Cost $ / MWh  

The marginal cost of enforcing the limit on the segment. 

MW Unenforceable  

This field will be set to YES if the nomogram segment’s limit is unenforceable in the OPF solution. 

Constraint 

This field will be set to YES if the nomogram segment’s limit is a constraint in the OPF solution. 
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OPF Line/Transformer Records  
Displays OPF specific information about the line and transformer records in the case.  To show select LP OPF, OPF 
Line/Transformer Records.   This display is actually a page of a display showing all the potential inequality 
constraints in the power system.  The top portion of the display repeats the fields shown on the Constraint Options 
page of the OPF Options dialog. 

To view the Line and Transformer records click on the Line/Transformers tab.  This displays the Line/Transformer 
page which is a class of Case Information Display and therefore can be used in a manner consistent with the other 
case information displays.  Specific formatting options are available from the local menu, which can be accessed by 
right-clicking on any field in the display.  The columns can also be sorted by right-clicking on the heading of the field.   

 

By default the display contains the following fields: 

From Number, From Name, From Area Name 

Number, Name, and Area Name of the From bus. 

To Number, To Name, To Area Name 

Number, Name, and Area Name of the To bus. 

Circuit 

Circuit identifier for the branch. 

Monitor 

Specifies whether or not the branch's MVA limit will be enforced in the OPF solution. 

Max MVA 

The maximum MVA flow on the branch.  Value is determined based on the end of the branch with the higher MVA 
flow. 

% of MVA Limit (Max) 

The maximum MVA flow as a percentage of the branch MVA limit.  Value is determined based on the end of the 
branch with the higher MVA flow. 

Lim MVA 

The MVA limit for the branch. 

MVA Marg. Cost 

The marginal cost of changing the MVA flow on the branch. 

MVA Unenforceable  

This field will be set to YES if the branch limit is unenforceable in the OPF solution. 

Constraint 

This field will be set to YES if the branch limit is a constraint in the OPF solution. 
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OPF Load Records  
Displays OPF specific information about each load record with a valid area/zone/owner filter.  To show this display 
select LP OPF > OPF Load Records .  The OPF Load Records Display is a class of Case Information Display and 
therefore can be used in a manner consistent with the other case information displays.  Specific formatting options are 
available from the local menu, which can be accessed by right-clicking on any field in the display.  The columns can 
also be sorted by right-clicking on the heading of the field.   

 

By default the display contains the following fields 

Number, Name 

Number and name of the bus to which the load is attached.  The display's local menu offers you the opportunity to 
view the Quick Power Flow List and the Bus View Display for this bus.  You can also use the local menu to view the 
generator's dialog.   

ID 

Alphanumeric ID used to distinguish multiple loads at the same bus. 

Area Name of Load 

Name of the load’s area. 

AGC 

Designates whether the load’s real power demand is governed by automatic generation control (AGC).  If the AGC 
field is set to Yes the load is on AGC in the standard power flow.  When a load is on AGC its real power output is 
varied automatically during an OPF or SCOPF solution ONLY, provided the load is part of an area or super area 
that is also on OPF control.  Loads will not be dispatched if the area is on some other form of AGC control. 

In Simulator OPF the default operating mode is that only loads on AGC control are eligible to be OPF controls.  In 
addition, the load’s area or super area must have AGC Status of "OPF", and the area must have its Load MW 
Dispatch set to YES. 

MW 

The real power output of the load. 

Cost Shift $/MWh, Cost Multiplier 

The cost shift and cost multiplier allow you to easily apply a shift to the cost function for the purpose of assessing 
how variations in bids impact profit.  The cost function is affected based on the following equation: 

(Original Cost Function + Cost Shift) * Cost Multiplier 

Hourly Benefit 

The total benefit of the load, including the impact of the cost shift and cost multiplier. 

MW Marg. Cost 

Tells the marginal cost, in $ / MWhr, to reduce one additional MW of load at this bus.  If a load is available as a 
control and is not at either its minimum or maximum limit or a cost model breakpoint, then the MW Marg. Cost field 
will be identical to the load’s current marginal cost.  However the usual case is for the load to be at either a limit or a 
cost model breakpoint so the usual situation is that the MW Marg. Cost field value IS NOT equal to the load’s 
marginal cost.   

Inc. Benefit 

Incremental benefit of the load at it’s current operating point. 

Initial MW 

The initial real power demand of the generator at the beginning of the OPF solution.  You can reset the case back to 
these values by selecting the LP OPF > Restore Previous Control Settings menu item.  This menu item is only 
available following a successful OPF solution.     

Initial Cost 

The initial load cost at the beginning of the OPF solution. 

Delta MW 

Change in the load's real power output as a result of the OPF.   

Delta Cost 

Change in the load's cost as a result of the OPF. 

Min MW, Max MW 

Minimum and maximum real power demand of the load.   

# of Benefit Curve Points  
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Shows the number of segments in the piecewise linear model.  If no piecewise linear model exists then this field is 
zero.   

Profit $/hr 

Shows the profit of the load. 
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OPF Super Area Records  
Displays OPF specific information about each super area record in the case.  To show this display select LP OPF, 
OPF Super Area Records.  The OPF Super Area Records Display is a class of Case Information Display and 
therefore can be used in a manner consistent with the other case information displays.  Specific formatting options are 
available from the local menu, which can be accessed by right-clicking on any field in the display.  The columns can 
also be sorted by right-clicking on the heading of the field.   

 

By default the display contains the following fields: 

Super Area 

Alpha-numeric identifier of the super area.   

AGC Status  

Super area's automatic generation control status.  This is the same field shown on the Super Area Records display.  
The field indicates whether or not the super area's generation is changing automatically to control the super area's 
interchange. 

The super area AGC Status field always overrides the AGC Status for the individual areas, except when it is set to 
"Off AGC".   

To be included in the OPF this field MUST be "OPF".  In that case the generation costs for all the areas in the super 
area are included in the OPF objective function.  Otherwise they are only included if the super area AGC Status is 
"Off AGC" and their particular area's AGC Status is on "OPF".  Double-click on the field to toggle its value.   

Num Areas  

Number of areas in the super area.  To see the individual areas use the local menu to view the Super Area dialog.   

Include Marg. Losses 

Specifies whether or not to include marginal losses in OPF calculations for this super area. 

MW Marg. Cost Ave. 

If the super area is on "OPF" control then for a solved case this field shows the average of the bus MW marginal 
costs for all the buses in the super area.  If there is no congestion then all of the marginal costs should be equal. 

MW Marg. Cost St. Dev. 

Standard deviation of the bus MW marginal costs for the buses in the super area.   

ACE MW 

Area control error for the super area. 

Gen MW, Load MW 

Total real power generation and load in the super area.   

Total Sched MW, Int MW 

Scheduled and actual interchange real power interchange between the super area and the rest of the system.  Both 
of these fields are the algebraic summation of the scheduled and actual interchange for the areas in the super area.   

Loss MW 

Total real power losses for the super area.   

MW Marg. Cost Min, MW Marg. Cost Max 

Minimum and maximum of all the bus MW marginal costs for the buses in the super area.   

Controls  

OPF Controls 
The following classes of controls are available during the OPF solution. Note, individual classes of controls can be 
enabled/disabled for the entire case using the OPF Options dialog and for particular areas using the OPF Area 
Records display.  Also, all classes of controls have associated minimum/maximum limits which are always enforced.   

 

Generator MW output 

The generator MW outputs are the major control for controlling the MW flow in the network and for minimizing the 
objective function.  Only generators in areas or super areas that are on "OPF" control are eligible for control; 
otherwise the generator's MW output remains fixed at its initial value.  Whether a particular generator is available for 
control also depends upon the status of its AGC and OPF MW Control fields.  These fields are s et on the OPF 
Generator Records display.   

Phase shifting Transformer tap position 

Phase shifting transformers are used primarily to control the flow of real power in the network.  When phase shifting 
transformers are controlled in the OPF routine, the phase angle is allowed to move anywhere within the phase 
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angle range of the device in order to help alleviate violations on other branches in the system.  The flow on the 
phase shifter is allowed to violate the prescribed MW range given for the phase shifter, but is NOT allowed to violate 
the MVA rating of the device. 

Additionally, in order for a phase shifter to be included in the OPF solution dispatch, the XF Phase property of the 
area must be set to YES.  Each individual phase shifter also has a property for being included in the OPF control 
that must be turned on in order for the phase shifter to participate in the OPF dispatch.  This option can be set for a 
phase shifting transformer by opening its Information Dialog and checking the OPF Phase Shifter Control options on 
the OPF page of the dialog. 

Load MW Dispatch 

The load MW demands can also be included as controls for re-dispatch during an OPF solution.  The concept of 
controlling a load is generally the same as controlling a generator.  Loads can be assigned piecewise linear benefit 
curves, and included in the OPF dispatch algorithm.  Only areas whose AGC control is set to "OPF" are eligible for 
control.  Furthermore, the OPF area’s Load MW Dispatch property must also be set to YES.  Each area load that is 
to be included for OPF dispatch must have a benefit model defined, and have its Available for AGC field set to YES.  
These fields can be set in the OPF Load Records display. 
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OPF Phase Shifter Records  
Displays OPF specific information about each phase shifter record in the case.  To show this display, select LP OPF > 
OPF Phase Shifter Records  from the main menu.  The OPF Phase Shifter Records display is a class of Case 
Information Display and therefore can be used in a manner consistent with the other case information displays.  
Specific formatting options are available from the local menu, which can be accessed by right-clicking on any field in 
the display.  The columns can also be sorted by right-clicking on the heading of the field.   

 

By default the display contains the following fields: 

From Number, From Name 

The name and number of the bus at the From end of the phase shifter. 

To Number, To Name 

The name and number of the bus at the To end of the phase shifter. 

Circuit 

The circuit identifier for the phase shifter. 

OPF Control 

Specifies whether or not the phase shifter is available for control during an OPF solution. 

Area PS Control 

Specifies if automatic phase shifter control has been enabled for the area containing the particular phase shifting 
transformer.  If the area phase shifter control is disabled, all phase shifting transformers within the area will remain 
fixed at their initial settings during the entirety of the OPF solution process.  This setting overrides the individual 
automatic control settings of each phase shifting transformer within the area. 

XF Auto 

Specifies if the transformer automatic control is enabled.  If an individual transformer's automatic control is disabled, 
it will remain at it's initial settings during the entirety of the OPF solution process. 

Phase (Deg) 

The actual phase shift of the phase shifter, in degrees. 

Initial Degrees 

The initial phase angle before the OPF solution was calculated. 

Delta Degrees 

The change in the phase angle during the OPF solution. 

Tap Min, Tap Max 

The minimum and maximum tap positions allowed for the phase shifter operation. 
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OPF Restore Previous Control Settings 
Select LP OPF > Restore Previous Control Settings to restore the control settings to what they were before the last 
OPF solution.  This menu item is only available following an OPF solution.  After doing this command you will also 
need to resolve the power flow to restore the previous case.     

Examples 

OPF Example - Introduction 
As a simple example of using the OPF, consider the seven bus, three area system contained in the file B7FLATOPF 
(included with the PowerWorld Simulator).  For this case all three areas are initially on Economic Dispatch (ED) AGC 
control and hence by default would not be included in the OPF solution.  Also, the initial interchange between the 
areas is equal to zero and the generators are modeled using cubic cost functions.   

To initially solve the case using the standard power flow, select Single Solution.  The case should look like the first 
figure below. 

Now we'll modify the case to set the three areas for OPF control.  To do this, select LP OPF > OPF Area Records  to 
display the OPF Area Records display.  Toggle the AGC status for each of the three areas to change it to "OPF".  Now 
select LP OPF > Primal LP to solve the cas e using the LP OPF.  The results should look similar to the second figure 
below.  The one-line shows the hourly cost for each area and the total case hourly cost, equal to $ 16,883 / hr.   

Note that the results are very similar but not identical to the economic dispatch case.  We would expect the cases to 
be similar since for cases with no congestion the OPF solution should be (ideally) equal to the economic dispatch 
solution.  The difference between the two is because in the LP OPF the generator cost functions are converted from a 
cubic model to a piece-wise linear model using a user specified number of segments, which is 5 segments by default.  
This value can be viewed/modified from General Options page of the OPF Options display.   

Change the Total Points Per Cost Curve field to 100 and resolve.  The results are shown in the third figure below, 
which now are almost identical to the economic dispatch results.   The disadvantage though in using a large number of 
cost segments is that it degrades the performance of the LP OPF slightly on larger cases. 

 

 
B7OPF Case Solved using Economic Dispatch  
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B7OPF Case Solved using LP OPF 

 

 
B7OPF Case Solved using LP OPF with 100 Cost Segments for Generators 
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OPF Example - Marginal Costs 
Using the OPF solution from the previous page, select LP OPF, Bus Records to view the bus marginal costs and LP 
OPF, OPF Area Records to view the area marginal costs.  The results should be as shown below.   

 
Seven Bus Case Bus and Area Marginal Costs 

Note that the marginal costs for all the buses in an area are identical to the area's MW marginal cost.  This is the 
expected result for systems without any line congestion.  The area MW marginal costs are not identical.  This is 
because currently each area is indepedently enforcing its own MW interchange.  In the next example we'll jointly 
dispatch the three areas by combining them into a single super area.   
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OPF Example - Super Areas 
To jointly dispatch the three areas we'll first combine them into a single super area.  To setup the super area first 
select LP OPF > OPF Super Area Records to display the OPF Super Area Records display (alternatively you could 
also use the Case Information > Super Area  display).  To enter a new super area right click on the "None Defined" 
entry in the first row of the display to show the display's local menu.  Select Insert.  This displays the super area dialog
.  In the Name field enter a name for the new super area, "ThreeAreas."  Then select the Add New button to create a 
new super area.  To add the three areas to the new super area enter "1-3" in the New Area #'s field and then select 
Add New Areas by Number (alternatively you could select the areas from the New Area Name list).  Also, to enable 
the super area for control, set the Super Area Control Options field (AGC Status) to Optimal Power Flow (OPF.)   

Before resolving the OPF lets temporarily disable enforcement of line MVA constraints.  You can do this from the 
Constraint Options page of the OPF Options dialog.  Check the Disable Line/Transformer MVA Limit Enforcement. 

Also, now would be a good time to save the changes.  To avoid overwriting the existing B7OPF file, select File > Save 
Case As to save the case (pwb and pwd files) with a different name, say B7OPFSA (SA for super area).     

Select LP OPF > Primal LP to resolve the OPF.  The results s hould be as shown below.   

 
OPF Solution with Super Area WITHOUT Enforcing Line MVA Constraints  

With the super area the individual area interchange constraints are no longer enforced.  This permits the free 
interchange of power between the areas, resulting in an overall decrease in the total case hourly cost from $ 16,885 / 
hr to $ 16,251 / hr.  View the OPF Bus Records display to verify that all the bus marginal costs are identical, equal to $ 
17.10 / MWh.  Of course the key problem with solving the system using the super area is that now there are line 
violations.  These violations will be removed next by enforcing the line MVA constraints.   
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OPF Example - Enforcing Line MVA Constraints 
To remove the line MVA violations go back to the Constraint Options Page of the LP OPF > OPF Options Dialog.  
Uncheck the Disable Line/Transformer MVA Limit Enforcement. 

Now resolve the LP OPF, enforcing the line constraints.  The resultant solution is shown below.   

 
OPF Solution with Super Area WITH Line MVA Constraint Enforcement 

With line constraint enforcement active the OPF optimally redispatches the generation taking into account the line 
MVA limits.  However enforcing these line constraints comes at a cost.  Notice that the total case hourly cos t has 
increased from $ 16,251 / hr to $ 16,553 / hr, which is still substantially less than the $ 16,885 / hr figure we had for the 
case without the superarea. 

Enforcing the line constraints also has an impact on the bus marginal costs, shown below.   

 
Impact of Line MVA Enforcement on the Bus Marginal Costs 

The actual marginal cost of enforcing the line constraint can also be viewed on the LPOPF, OPF Line/Transformer 
MVA Records display.  The MVA Marg. Cost tells the marginal cost of enforcing the constraint, expressed in units of $ 
/ MVA / hr.  Right-click on the MVA Marg Cost field header to sort the display using this field.   
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Storing OPF Data 

Load LP OPF Data 
Select LP OPF > Load LP OPF Data to load LP OPF specific fields into the case from the specified *.pwo text file.  
Note, the LP OPF specific fields are saved with the case in the pwb file.  The pwo files should therefore only be used 
for transferring the opf specific data between cases or for the user to manually change the data using a text editor.  
Existing OPF specified data can be stored in a *.pwo text file using the LP OPF, Store LP OPF Data menu command.   
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Store LP OPF Data 
Select LP OPF > Store LP OPF Data to store LP OPF specific fields from the case into the specified *.pwo text file.  
Note, the LP OPF specific fields are saved with the case in the pwb file.  The pwo files should therefore only be used 
for transferring the opf specific data between cases or for the user to manually change the data using a text editor.  
Data can be loaded into a case from the *.pwo text file using the LP OPF > Load LP OPF Data menu command.   

Security Constrained Optimal Power Flow (SCOPF) 

Security Constrained Optimal Power Flow Overview  

Note: The SCOPF option in PowerWorld Simulator is only available if you have purchased the SCOPF and 
OPF add-ons to the base package.  To learn more about the SCOPF, please feel free to read through the 
information contained in these help files. Contact PowerWorld Corporation for details about ordering the 
SCOPF and OPF versions of Simulator. 

The optimal power flow (OPF) algorithm has the purpose of minimizing an objective function (usually total operation 
cost) by changing different system controls while meeting power balance constraints and enforcing base case 
operating limits.  The secure operation of a power system though requires that there be no unmanageable contingency 
violations, either.  Thus, the minimization of the objective function requires considering contingencies.  This is 
achieved using a security constrained optimal power flow (SCOPF) algorithm.  

During the SCOPF solution process the algorithm determines the optimal state of the system by iterating between 
solving a s tandard power flow and solving a linear program that changes the system controls to remove contingency 
violations.  

The SCOPF algorithm makes control adjustments to the base case (pre-contingency condition) to prevent violations in 
the post-contingency conditions.  If enough controls are available in the system, the solution minimizes the objective 
function and the system enforces contingency violations.  If the system does not have enough controls, then some 
violations may be persistent under certain contingencies.  Those represent unenforceable constraints, which result in 
high bus marginal costs.  

The commands and options for the SCOPF are accessed using the LP OPF > Security Constrained OPF option.  
The SCOPF function uses the OPF options defined in the OPF Options dialog and the contingency settings specified 
in the contingency analysis dialog.  Please read through the OPF and the contingency analysis help for more 
information about these settings.  We encourage you to become familiar with Simulator OPF and the contingency 
analysis tool before running SCOPF simulations.  Other commands in the SCOPF dialog are used to specify the base 
case solution process and for accessing the SCOPF results. 
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SCOPF Objective Function 

The SCOPF objective function uses the function defined in the OPF settings.  There are two objective functions in 
Simulator: Minimum Cost and Minimum Control Change.  Minimum Cost attempts to minimize the sum of the total 
generation costs in specified areas or super areas.  Minimum Control Change attempts to minimize the change in the 
generation in the specified areas or super areas.  The objective function is set up in the OPF options dialog. 

The result of the SCOPF will be different from the OPF solution because the SCOPF meets additional inequality 
constraints associated with the contingency violations. 
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SCOPF Dialog 

The SCOPF dialog allows the user to control options of Security Constrained OPF, as well as to access the 
optimization results. 

The SCOPF can be run from this dialog using the Run Full Security Constrained OPF button at the top of the form. 

There are three pages of information included in this form: 

Options 

Results  

LP Solution Details. 
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SCOPF Solution Process 

The SCOPF involves three major steps that can be solved either automatically or manually from the SCOPF control 
dialog:  

• Initialization to setup the SCOPF LP tableau and the control structures 

• Contingency analysis calculation and storage of control sensitivities associated with each contingency violation 

• SCOPF iterations, which include an LP solution and a power flow solution.  During each LP step in the LP routine, the 
algorithm enforces the newest most severe contingency violation.  After each violation is processed, all of the 
unprocessed violations are updated.  This step is crucial since often resolving the most severe violation resolves  
numerous other violations.  For instance, a single line might be overloaded in a number of contingencies: fixing the 
worst contingency fixes the others as well.  On the other hand, processing some violations may result in new 
violations.  Currently SCOPF does not check for new violations, which would require a new contingency analysis 
solution.  Care must be taken during the outer loop since the corrected violations will no longer show up as binding 
and hence will be excluded from the SCOPF LP tableau.  The contingency violations are listed in the CTG 
Violations dialog. 

The SCOPF terminates when all the contingency violations have been processed.  Note that the user can rerun the 
SCOPF by repeating the solution process if they want to verify the contingency violation enforcement at the new 
optimal operating point. 
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SCOPF Results  

The Results page of the Security Constrained Optimal Power Flow form provides information on the results of the 
latest SCOPF solution, including the contingency violations included, the marginal price details, and the marginal 
control details. 
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SCOPF Equality and Inequality Constraints  

Two general types of constraints are involved in the SCOPF solution: equality and inequality constraints.  Equality 
constraints are constraints that have to be enforced.  That is, they are always "binding".  For example in the SCOPF, 
as well as in the OPF and in the power flow, the real and reactive power balance equations at system buses must 
always be satisfied (at least to within a user specified tolerance).  In contrast, inequality constraints may or may not be 
binding.  For example, a line MVA flow under a certain contingency may or may not be at its limit. 

The SCOPF problem is solved by iterating between a power flow solution and a contingency constrained LP solution, 
some of the constraints are enforced during the power flow solution and some constraints are enforced during the LP 
solution.  The constraints enforced during the power flow are, for the most part, the constraints that are enforced 
during any power flow solution.  These include the bus power balance equations, the generator voltage set point 
constraints, and the reactive power limits on the generators.  What differentiates the SCOPF from a standard power 
flow and from the OPF are the constraints that are explicitly enforced by the LP solver.  These include the following 
constraints: 

Equality Constraints 

Inequality Constraints 
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SCOPF Equality Constraints  

The SCOPF equality constraints are the same as the OPF equality constraints: Area MW interchange, bus MW and 
Mvar power balance, Generator voltage setpoint and super area MW interchange. 
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SCOPF Inequality Constraints  

The following classes of inequality constraints are enforced during the SCOPF solution.   

Generator real power limits  

Generator real power limits are enforced during the SCOPF LP solution.   

Generator reactive power limits   

Generator reactive power limits are enforced during the SCOPF LP solution.   

Interface MW Limits  

Interface MW limits are enforced during the SCOPF solution.  Interfaces are used to represent the aggregate flow 
through a number of different devices.  During the SCOPF the MW post-contingency flow through the interface is 
constrained to be less than or equal to a user specified percentage of its limit, provided the interface is active for 
enforcement.  For an interface to be active for enforcement the following three conditions must be met: 

• Interface enforcement must not be disabled for the case.  This field can be set from either the OPF constraints dialog 
or the OPF interfaces info display.  As default, the interface enforcement is not disabled.  Note that interface flow is 
limited to a percent of its limit as specified by the interface's Limit Monitoring Settings. 

• Interface enforcement must be active for at least one of the interface's areas.  Note, an interface is assumed to be in 
each area that contains at least one of its components.  This field can be set from the OPF Area Records display.  
Note: the default is that interface enforcement is not active, so be sure to activate this if you want these constraints 
enforced. 

• Enforcement must be active for eac h individual interface.  This field can be specified from the OPF Interface Records 
display or in the Limit Monitoring Settings dialog.  The default is active. 

Each interface that is active for enforcement is modeled as an inequality constraint, which may be either binding or 
not binding.  If the constraint is not binding then it does not impact the solution.  If a constraint is binding then it has 
an associated marginal cost of contingency enforcement.  When manually solving the SCOPF one can skip a 
contingency violation associated to the interface by setting the Include field of the SCOPF CTG Violations dialog to 
No.  

Transmission Line and Transformer (Branch) MVA Limits  

Transmission line and transformer (branch) MVA limits are enforced during the SCOPF solution.  During the LP the 
post-contingency branch line flow is constrained to be less than or equal to a user specified percentage of its limit, 
provided the branch is active for enforcement.  For a branch to be active for enforcement the following three 
conditions must be met: 

• Line/Transformer enforcement must not be disabled for the case.  This field can be set from either the OPF constraints 
dialog or the OPF Line/Transformer Records display.  The default is that case line/transformer enforcement is not 
disabled.  Also note that the branch flow is limited to a percent of its limit as specified by the branch's Limit 
Monitoring Settings. 

• Branch enforcement must be active for the branch's area.  Enforcement For tie-lines must be active for either area.  
This field can be set from the OPF Line/Transformer Records display.  The default is that branch enforcement is not 
active, so be sure to activate this if you want these constraints enforced.  

• Enforcement must be active for each individual branch.  This field can be set from the OPF Line/Transformer Records 
display or in the Limit Monitoring Settings Dialog.  The default is active. 

Each branch that is active for enforcement is modeled as an inequality constraint, which may be either binding or 
not binding under contingency conditions.  If the constraint is not binding then it does not impact the solution.  If a 
constraint is binding then it has an associated marginal cost of enforcing the contingency constraint, which is shown 
on the SCOPF Bus Marginal Price Details dialog.   When manually solving the SCOPF one can skip a contingency 
violation associated to the branch by setting the Include field of the SCOPF CTG Violations dialog to No. 
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SCOPF Control 

The control dialog allows the user to manually or automatically run a SCOPF simulation and visualize the execution of 
the simulation.  The SCOPF solution process involves three steps: base case solution and initialization, contingency 
analysis, and SCOPF iterations. 

Run Full Security Constrained OPF 

Press this button to run the three steps of the SCOPF solution automatically.  The SCOPF will solve the base case 
using the selected method, will use the currently stored list of contingencies during the contingency analysis step, 
and will take the CA results and sensitivities to iterate in order to obtain the optimal solution that minimizes cost and 
enforces contingency violations.  

 

Options  

Maximum Number of Outer Loop Iterations  

Indicates the number of maximum outer loop iterations.  The outer loop iterations determines how many times the 
contingency analysis will be re-run following a successful SCOPF dispatch.  In this manner, Simulator will look for 
new violations that may occur due to the new generation dispatch.  The original violations considered will not be 
considered again, only new violations will be examined.  The presumption is that the original violations will not 
resurface.  Resolving the contingency analysis independent of the SCOPF routine after the SCOPF dispatch is 
acquired will indicate if any earlier violations resurfaced from the final iterated SCOPF dispatch. 

Consider Binding Contingent Violations from Last SCOPF Solution 

When checked, this option ensures that the contingent violations from the last SCOPF solution are included in the 
current SCOPF solution.  This option is helpful in preventing the SCOPF from hunting between having a constraint 
binding in one solution, and resolving with it not binding in a later solution because it w as previously remedied.  This 
option should generally always be checked, unless the user is sure that the previous solution has no bearing on the 
current solution, such as having made major changes to the system since the previous solution. 

Initialize SCOPF with Previously Binding Constraints  

When checked, this option results in the SCOPF solution process starts with the exact same LP tableau from the 
last solution.  This can make for fairly fast solutions (recognizing that the contingency analysis needs to be 
resolved) when the changes to the system are small.  Simulator automatically uses this option when doing multiple 
outer loops of the SCOPF.  This option allows the user to solve the outer loops (set the outer loop counter to 1) by 
repeatedly solving the SCOPF manually, potentially making modifications between solutions if desired. 

Set Solution as Contingency Analysis Reference Case 

Check this field to set the solution of the SCOPF as the contingency analysis reference. If the system has enough 
controls to remove all the contingency violations, a rerun of the contingency analysis using the SCOPF solution as 
the reference should report no branch violations. 

Maximum Number of Contingency Violations Allow Per Element 

Specify the maximum number of contingency violations that the SCOPF analysis should allow per element. 

Basecase Solution Method    

Specifies whether the solution of the base case is performed using the power flow algorithm or the optimal power 
flow algorithm.  The selection will affect the initial conditions of the system and consequently the contingency 
analysis results and the sensitivities used by the LP solver.  Currently the SCOPF does not resolve the contingency 
analysis during the optimization since this is computationally expensive.  See the SCOPF solution process for 
details. 

Handling of Contingent Violations Due to Radial Load 

It is often common when computing a security constrained OPF to have violations occur on branches due to radial 
load.  In these instances, there is no way to adjust controls to continue to serve the load, without overloading the 
serving element.  Therefore you can choose how contingent violations of this type should be handled by the 
SCOPF.  You can choose to flag them but not include them in the SCOPF, ignore them completely, or include the 
violations in the SCOPF.  Note that if you include the violations in the SCOPF, the SCOPF algorithm will not be able 
to remove the violation on the element via generation dispatch.  However, it may be able to do so if the load in 
question has a load benefit curve defined and is available for load shed dispatch in the SCOPF routine. 

DC SCOPF Options  

The DC options given for the SCOPF revolve around the treatment of Line Outage Distribution Factors (LODF) 
during the DC SCOPF solution.  You can choose to discard the LODFs when the SCOPF is finished, store them in 
memory (lost when Simulator is closed,) or in memory and in the PWB file (if saved.) 

If the LODFs have been stored and you wish to clear them (they can require quite a bit of RAM depending on the 
number of contingencies and size of the case,) you can press the button labeled Clear Stored Contingency 
Analysis LODFs . 

Number of Outer Loop Iterations  

The number of outer loop iterations required to solve the SCOPF. 
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Number of Contingent Violations  

Number of violations from the contingency analysis portion of the solution, which are used to attempt to determine 
the security constrained dispatch. 

SCOPF Start Time, SCOPF End Time 

Physical time when the SCOPF solution process started and finished. 

Total Solution Time (Seconds) 

Length of time needed to determine the SCOPF solution. 

Total LP Iterations  

Total number of Linear Programming iterations necessary to determine the SCOPF solution. 

Number of Active Contingencies 

Is the number of contingencies included in the SCOPF simulation Specific contingencies may be excluded from the 
simulation in the contingency analysis dialog by changing the skip field of a contingency to YES. The contingency 
analysis dialog can be conveniently accessed from the SCOPF control dialog. 

View Contingency Analysis Form 

Clicking this button shows the contingency analysis dialog.  

Contingency Analysis Results  

This window allows the user to monitor the details of the contingency analysis step. During contingencies, the 
outage actions, the solution of each contingency, and the solution of the CA run are reported. 
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SCOPF CTG Violations  

The contingency violations page is available from the Results tab of the Security Constrained Optimal Power Flow 
form.  The display lists the results from the latest contingency analysis run including the violations that were included 
in the SCOPF and the final error for each violation.  This dialog may change if the user reruns the SCOPF by solving 
the contingency analysis using the SCOPF solution as contingency analysis reference.  Right click any where in the 
display to copy a portion or all of the display to the Window's clipboard, or to print the results.   

 

The display shows the following fields: 

Contingency Name 

This is the contingency label.  By default single line contingencies start with an "L", single generator outages with a 
"G", and single transformer outages start with an "X".   

Category 

Currently, the SCOPF considers only branch and interface violations.  Thus, the category of the contingencies 
should be branch MVA or Interface. 

Element 

Shows information about the specific element that presented the violation.  When the violation occurs in a branch, 
this column includes the identifiers of the sending and receiving ends of the branch, the circuit, and the direction of 
the violating flow.  Since Interfaces are directed, this field will present only the interface name in the case of 
violating interfac es.  

Value 

The percentage flow that appears in the branch during the contingency prior to optimization.  If this number is larger 
than the scaled limit, the violation needs to be removed. 

Scaled Limit 

The scaled limit corresponds to the Line/Transformer Percentage specified in the limit monitoring settings dialog.  
By specifying this limit to be higher than 100% some of the contingency violations might be effectively relaxed.  
Sometimes this helps the OPF and the SCOPF obtain a feasible solution.  On the other hand, it is often required to 
analyze the performance of the system if branches would have higher ratings.  

New Value  

The percentage flow that appears in the branch during the contingency after SCOPF optimization.  If this number is 
larger than the scaled limit, the contingency violation has not been removed and it is therefore unenforceable.  If the 
value is equal to the scaled limit, then the contingency violation constraint would be binding.  If the value is smaller 
than the scaled limit, the contingency violation has been removed. 

Error  

The difference between the new value and the scaled limit.  If the error is positive, the line is unenforceable.  If the 
error is zero, the constraint is binding.  Negative errors indicate that the violations have been corrected.  

Included 

Indicates if the contingency violation was included as a constraint in the SCOPF solution. 

Marginal Cost 

Indicates the cost associated with the contingency violation.  If the constraint is unenforceable, the marginal cost is 
assigned arbitrarily as a high value in the OPF constraint options dialog.  

Unenforceable  

Indicates whether the contingency violations is unenforceable, i.e., the system has not enough controls to relieve 
the branch overload when the contingency occurs. 

Skip Violation? 

Change this field to NO if the contingency violations should not be included as a SCOPF constraint. This is 
sometimes useful in order to analyze the effect of the contingency violation in the SCOPF solution. This field may 
be toggled when doing a manual SCOPF solution. 
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SCOPF LP Solution Details  

The LP Solution Details page of the Security Constrained Optimal Power Flow  form provides inf ormation on the linear 
program solution of the SCOPF, including a list of All LP Variables, LP Basic Variables, and LP Basis Matrix.  This 
information applies to the linear programming tableau solution method. 
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SCOPF All LP Variables 

The SCOPF All LP Variables dialog displays the basic and non-basic variables associated with the final LP SCOPF 
solution.  Users interested in the specifics of the LP SCOPF can access this page to obtain internal information about 
the SCOPF solution.  To see the display, open the Security Constrained Optimal Power Flow form, click on the LP 
Solution Details tab, and access the All LP Variables page. 

Right click any where in the display to copy  a portion or all of the display to the Window's clipboard, or to print the 
results.   

 

The display lists each of the LP variables with the following fields: 

ID 

Variable identifier. 

Org. Value  

The initial value of the LP variable before SCOPF optimization. 

Value 

The final value of the LP variable after SCOPF optimization. 

Delta Value  

The difference between the original value field and the value field. 

Basic Var 

Shows the index of the basic variables in the LP basis.  If the value is zero, the variable is non-basic.  These values 
are set up after the SCOPF calculates the contingency violation sensitivities.  

NonBasicVar  

Shows the index of the non-basic variable.  If the value is zero, the variable is basic.  

Cost(Down) 

The cost associated with decreasing the LP variable.  The field will show if the variable is at its max or min limit. 

Cost(Up) 

The cost associated with increasing the LP variable.  The field will show if the variable is at its max or min limit. 

Down Range  

The available range to decrease the basic variable before a new constraint is hit under a contingency condition.  

Up Range 

The available range to increase the basic variable before a new constraint is hit under a contingency condition.  

Reduced Cost Up 

The cost reduction that would be experimented if a LP variable increases.  If a constraint is at the limit, the field 
shows the change in cost of constraint enforcement.  

Reduced Cost Down 

The cost reduction that would be experimented if a LP variable decreases.  If a constraint is at the limit, the field 
shows the change in cost of constraint enforcement.  

At Breakpoint 

Yes, if the LP variable is at a break point. 
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SCOPF LP Basic Variables 

The LP Basic Variables (from the SCOPF LP Solution Details page) displays the basic variables of the final LP 
solution.  The basic variables may correspond to controls that can be altered to minimize the objective function, or 
slack variables associated with unenforceable constraints.  Users interested in the specifics of the LP SCOPF can 
access this page to obtain internal information about the SCOPF solution.  Right click any where in the display to copy 
a portion or all of the display to the Window's clipboard, or to print the results.   

 

The display lists each LP variable with the following fields: 

ID 

Basic variable identifier. 

Org. Value  

The initial value of the basic LP variable before the SCOPF optimization. 

Value 

The final value of the basic LP variable after the SCOPF optimization. 

Delta Value  

The difference between the original value field and the value of the basic variable. 

Basic Var 

Shows the indices of the basic variables in the LP basis.  

Cost(Up) 

The cost associated with increasing the basic variable.  

Down Range 

The available range to decrease the basic variable before a new constraint is hit under a contingency condition.  

Up Range 

The available range to increase the basic variable before a new constraint is hit under a contingency condition. 
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SCOPF LP Basis Matrix 

The LP Basis Matrix page of the SCOPF LP Solution Details tab displays the basis matrix associated with the final 
SCOPF LP solution.   There is one row per constraint and one column per basic variable.  Additional columns 
summarize information associated with each constraint.  This page is usually only of interest to users interested in 
knowing the specifics of the SCOPF solution.  Knowing the basis matrix can be helpful in figuring out why a particular 
SCOPF solution exhibits a certain behavior.  The entries in the basis matrix give the sensitivity of each constraint to 
each of the basic variables.   

As any case info display in simulator, right click to see options to copy information to the clipboard and to perform 
standard windows actions, such as printing. 
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SCOPF Bus Marginal Price Details  

This display (from the SCOPF Results page) shows information about the components of the marginal cost at each 
bus. The display is relevant to see how the bus marginal cost depends on the cost of enforcing system constraints 
such as branch limits and area equality constraints.  This display is useful for indicating which constraints are 
contributing towards the determination of the marginal price at each bus. 

As any case info display in Simulator this display can be customized and the information copied, printed, and saved by 
accessing the local menu option with the mouse right click. 
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SCOPF Bus Marginal Controls  

This display (from the SCOPF Results page) shows the sensitivities of the controls with respect to the cost at each 
bus.  A change in a system control will have the indicated effect in the marginal cost at the system buses.  Vice-versa, 
the marginal cost at a bus is affected by changes in the value of the basic variables. 

The Marginal Controls page can be accessed by opening the Security Constrained Optimal Power Flow form, and 
clicking on the Results tab. 
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SCOPF Example: Introduction 

In this section we introduce an example of using the SCOPF.  Consider the seven bus, three area system contained in 
the file B7SCOPF (included with the PowerWorld Simulator).  This case is the same case used in the OPF example, 
except that the line from bus 2 to 3 has now a 100MVA rating, lines 1 to 2, 1 to 3 and 2 to 5 have a 120MVA rating, 
and all three areas are initially on OPF control.  To initially solve the case using the optimal power flow, select Primal 
LP under LP OPF.  The solution obtained is shown in Figure 1. The total case hourly cost is $ 13,372 / hr.  

We are interested in determining an optimal solution that meets security constraints under contingency conditions.  In 
order to show that the current OPF solution does not enforce contingency violations, take line 1 to 2 out of service by 
clicking in a circuit breaker.  Then solve the power flow by pressing the Single Solution button.  The result in Figure 2 
indicates that line 1 to 2 is overloaded 32%. The SCOPF algorithm will attempt to move the operating solution such 
that no contingency violation occurs in the system.  Close line 1 to 2 back in service. 

The next step is to specify the contingency conditions that the system should withstand. In order to do that, we access 
the Contingency Analysis dialog under Options/Tools .  Note that we can also access this dialog from the SCOPF 
control dialog by selecting LP OPF > Security Constrained OPF and pressing the View Contingency Analysis 
Form button on the Options  page.  The B7SCOPF case does not have contingencies associated with it.  Insert single 
line contingencies in the contingency list by pressing the Auto Insert button.  Select the option for Single 
Transmission Line  in the Auto Insert Dialog and contingency labels using only the bus numbers.  This will prompt to 
insert 11 single line contingencies corresponding to all the lines in the system.  You can close now the contingency 
analysis dialog.   

You can set the SCOPF to use the OPF solution as the base by selecting Solve base case using optimal power 
flow.   

You can now solve the SCOPF by pressing the Run Full Security Constrained OPF.  This will process the 
contingency violations and iteratively solve the LP program and the power flow equations to minimize the objective 
function and enforce equality and inequality constraints.  The solution is shown in Figure 3.  The total operating cost is 
now $ 13,409. The increase in operating cost is due to enforcing security constraints.  If a new contingency analysis is 
performed using the optimal solution as the reference, it will be found that no contingency violations occur for the 
contingencies in the list, i.e., branch flows are less than (or equal to) 100% in the post contingency condition.  Thus, 
the system meets all the specified constraints.  Y ou can analyze the SCOPF results by browsing the information in the 
SCOPF tabs.  Note that the CTG Constraints  dialog does not show unenforceable constraints, but the branch 
violation of line 2 to 5 due to the contingency 5 to 7 is now binding.  

 

 
B7SCOPF Case Solved using OPF  
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B7SCOPF Power Flow Solution with line 1-2 open 

 

 
B7SCOPF Case Solved using SCOPF: The system now meets the contingency constraints. 
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SCOPF Example: Marginal Prices 

Using the SCOPF solution from the previous page, select the Bus Marginal Price Details  from the Results  page of 
the SCOPF Dialog to view the detail of the marginal price components.  Note in the following Figure that each area 
constraint contributes equally to the marginal cost of the buses in that area.  The binding inequality constraint from bus 
2 to 5 makes further contribution to the bus marginal price of buses in area Top.  

 

 
Seven Bus Case SCOPF Bus Marginal Price Details 
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SCOPF Example: Unenforceable Constraints  

Using the same example as above, reduce the MVA rating of line 2 to 5 to 90 MVA.  The initial base case LP OPF 
solution is the same as in the previous example.  Consider the same contingency list.  When the contingencies are 
solved using the initial OPF solution as the reference, seven contingency violations need to be removed.  The CTG 
dialog after simulation is presented in the following figure. 

 

 
CTG Dialog after SCOPF Solution 

 

We note that the constraint from bus 2 to 5 under a contingency from 5 to 7 is unenforceable.  There is not enough 
system controls to enforce the contingency constraint.  A $ 1,000 / hr cost is assigned to unenforceable constraints in 
this case. The cost of not enforcing constraints can be specified in the OPF Constraint Options Dialog. 

Available Transfer Capability (ATC) Analysis  

Available Transfer Capability (ATC) Analysis  

Available Transfer Capability (ATC) analysis determines the maximum MW transfer possible between two parts of a 
power system without violating any limits.  Most often, this transfer is between two areas in the system.   For 
information on how to use the Simulator ATC tool, see Available Transfer Capability Dialog. 

 

Simulator’s ATC analysis makes use of  several tools that are available elsewhere in Simulator.  These include 

• Power Transfer Distribution Factors (PTDFs): determines the linear impact of a transfer (or changes in power 
injection) on the elements of the power system. 

• Line Outage Distribution Factors (LODFs): determines the linear impact of a line outage on the elements of the 
power system. 

• Contingency Analysis: studies the impact of a list of contingencies on the power system. 

• Limit Monitoring Settings: controls which elements of the system are monitored for limit violations. 

You do not directly use these other tools when using Simulator’s ATC analysis tool, but Simulator uses the settings 
and algorithms in the background to determine ATC.  Thus, it is helpful to be knowledgeable on their use, as it will help 
you in interpreting the output of the ATC analysis tool. 

 

Simulator provides three methods of determining the ATC for a transfer direction, which are described below. 

Single Linear Step (SL) 

The Single Linear Step approach is the most common ATC method and duplicates the ATC analysis done by many 
system reliability organizations throughout North America.  This method of ATC analysis uses only information 
about the present system state and sensitivities (mathematical derivatives) about the present system state.  These 
sensitivities are embodied in the PTDF and LODF calculations. 

Consider a transmission line with a limit of 10 and present loading of 5 and a PTDF of 10%.  The estimated 
maximum transfer without causing on overload on line is  

Transfer Limitation = (Limit – Present Loading) / PTDF = (10 – 5) / 0.1 = 50 MW 

When including contingency analysis, then OTDF (Outage Transfer Distribution Factor) and linearized estimates of 
post-contingency flows are used to determine the Transfer Limitation. 
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Transfer Limitation = (Limit – Post-Contingency Loading) / OTDF 

If we find the Transfer Limitation for every transmission branch (and interface) during each contingency, then the 
ATC is equal to the smallest Transfer Limitation.   

Note: Simulator also monitors the possibility that a transfer will reduce the flow on a line until the line reaches its 
limit for flow in the opposite direction. 

Iterated Linear Step (IL) 

The Single Linear Step is an extremely fast method for determining the ATC.  However, because it only uses 
present operating point information, controller changes are not taken into account.  The linearization assumes that 
all controllers are fixed.  The Iterated Linear Step (IL) method provides an alternative to the Single Linear Step, but 
still performs its analysis in a reasonable period of time.  The (IL) method operates as follows 

• Stepsize = ATC using Single Linear Step (Note: save this initial step size for use by the Full CTG Solution) 

• If [abs(stepsize) < Tolerance] then stop 

• Ramp transfer out an additional amount of Stepsize and resolve Power Flow  

• At new operating point, Stepsize = ATC using Single Linear Step 

• Go to step 2 

This method takes into account controller changes that occur as you ramp out to the transfer level, but still avoids 
the full simulation of contingencies. 

This method can be applied between combinations of areas and super areas, OR between two injection groups.  
Combinations of areas/superareas and injection groups are not allowed. 

Iterated Linear Step (IL) then Full CTG Solution 

If you want to absolutely test the validity of the ATC number, then you can use this method.  Be aware however, 
that this calculation method can be extremely slow.  The (IL) then Full CTG Solution method operates as follows. 

• Run Iterated Linear Step and ramp transfer out ATC Value found 

• StepSize = 10% of the initial Linear Step Size saved during the (IL) method, or 50 MW whichever is larger. 

• Run Full Contingency Analysis on the ramped transfer state 

• If there are violations then change the sign of Stepsize 

• if [abs(stepsize) < Tolerance] then Stop 

• Ramp transfer out an additional amount of Stepsize and resolve Power Flow  

• At new operating point, Run Full Contingency Analysis 

• if  [ (Stepsize > 0) and (There are Violation)]     OR  
    [ (Stepsize < 0) and (There are NO Violations)] THEN  
        StepSize := -StepSize/2  (switch direction) 

• Go to step 5 

This method can be applied between combinations of areas and super areas, OR between two injection groups.  
Combinations of areas/superareas and injection groups are not allowed. 
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Available Transfer Capability Dialog 

The Available Transfer Capability Dialog provides you an interface for performing and viewing the results of Available 
Transfer Capability Analysis.  ATC analysis is typically only done on the present power system state or scenario.  For 
information on performing analysis on multiple scenarios please see the Multiple Scenario Available Transfer 
Capability Dialog.  

To get to the ATC Dialog, go to Options/Tools > Available Transfer Capability (ATC) in the main menu.  When 
performing analysis on only one scenario the ATC Dialog has three tabs: Options , Analysis , and Result.  There are 
many settings on these tabs that will be described here.  If you have setup your analysis in a manner you would like to 
repeat in the future, click on Save Settings to save your settings in a file.  Then when you come back into the dialog at 
a later time, click Load Settings and retrieve the file containing your settings. 

 

The three tabs are described now. 

Options Tab: Common Options  

Seller Type, Buyer Type  

For the ATC Solution Method of Single Linear Step (SL), ATC can be calculated for transfers between combinations 
of areas, zones, super areas, participation groups, buses, or to a slack bus.  For other ATC Solution Methods, ATC 
can be calculated for transfers between areas and super areas only.  Use the seller type and buyer type options to 
indicate the type of the selling and purchasing entities.  

Seller, Buyer 

These dropdown boxes allow you to select the selling and buying entities.  Their contents are filled when you select 
the seller and buyer types.  You can also use Simulator’s advanced search engine to find the buyer and seller by 
clicking on the Find Seller… and Find Buyer… buttons. 

Reverse Buyer/Seller 

Click this button to reverse of the direction currently shown.  The buyer becomes the seller, and the seller the buyer. 

Linear Calculation  Method 

The ATC analysis tool can use either a Lossless DC or Lossless DC with Phase Shifters calculation method for 
obtaining the ATC results. 

If you select the Lossless DC option, branch flow sensitivity is calculated by estimating the real power that flow s 
through the monitored element only from the difference in angles measured across its terminals. 

The Lossless DC with Phase Shifters method is a modification to the lossless dc approximation that takes into 
account phase shifter operation.  It is especially useful when the ATC tool keeps reporting overloads on branches 
that obviously will not overload because of the operation of a phase shifting transformer. 

The Linearized AC method is not yet available. 

Include Contingencies 

Check this box to include contingencies previously inserted or loaded in the Contingency Analysis Tool in the 
analysis.  Note that minimizing the number of contingencies considered greatly improves solution speed as well as 
computer memory requirements for doing ATC Analysis.  Therefore, be careful in choosing which contingencies to 
use with the ATC tool. 

Report Base Case Limitations  

When checked, the ATC tool will report transfer limitations from the base case. 

Report Generation Reserve Limitations  

When checked, the ATC tool will report transfer limitations from generation reserve. 

Limit Monitoring Settings  

Click this button to open the Limit Monitoring Settings Dialog.  Note that minimizing the number of monitored power 
system elements greatly improves solution speed as well as computer memory requirements for doing ATC 
Analysis. 

Transfer Result Reporting Options  

Transfer Limiters To Save  

This value tells Simulator how many total "Transfer Limiters" to save.  Simulator will save those Transfer 
Limiters with the lowest Transfer Limitation.  An explanation of a Transfer Limiter follows 

During Linear ATC Analysis, Simulator determines the "Transfer Limitation" (See Available Transfer Capability 
Analysis) for each transmission line and interface during each contingency and the base case.  From this 
Simulator develops a list of Transfer Limiters.  A Transfer Limit contains three pieces of information 

• Transfer Limit in MW 

• Transmission branch (or interface) that causes the limit 
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• Contingency that is applied to cause the limit (if it’s a limit without any contingency applied, then the 
contingency will say "Base Case")  

Thus if we are monitoring 1000 transmission lines during 99 contingencies plus 1 base case, there would be 
100,000 Transfer Limiters calculated.  We are not concerned with all 100,000 limitations, therefore, only the 
limitations with the smallest Transfer Limit in MW are reported. 

Max Limiters per CTG 

When analyzing a long list of contingencies, the worst transfer limitations may all occur during the same 
contingency.  Set this value to limit the number of Transfer Limiters saved that are associated with one 
contingency. 

Max Limiters per Element 

Also, when analyzing a long list of contingencies, the worst transfer limitations may all be overload the same 
limiting element.  Set this value to limit the number of Transfer Limiters saved that are associated with one 
Limiting Element. 

Max MW Limitation 

This value defines the maximum transfer to report between the buyer and seller.  Simulator will compute the 
ATC analysis results until the transfer amount reaches the value in this field, and only report the results meeting 
the other reporting criteria up to this MW limitation. 

Ignore Elements with OTDFs below 

Simulator will not report Transfer Limitations for elements with OTDF values (or PTDF values if there is no 
Limiting Contingency) less than this user-specified value.  The default value is 0.5%, meaning that for 100 MW 
transfer, there would be only a 0.5 MW increase in flow on the Limiting Element. 

As described in Available Transfer Capability (ATC), the transfer limitation functions involve dividing by the 
PTDF or OTDF values for each branch or interface.  This leads to two facts: 

• The accuracy of the transfer limitation is less for lines that have very small PTDF or OTDF values.   

• A very small PTDF or OTDF value means that the transfer has very little impact on the line anyway.   

These two facts often result in Linear ATC analysis reporting inaccurate transfer limitations for lines that are 
largely unaffected by the transfer.  It is not uncommon to have a transfer limitation report an extremely negative 
transfer limit (e.g. -1.9E28 MW).  A branch which is overloaded by a very small percentage, but which has a 
very small OTDF value often causes this.  If the OTDF value is 0.001%, then a branch overloaded by 1 MW will 
result in a tranfer limitation of -100,000 MW. 

This motivates the usefulness of ignoring elements with small PTDFs. 

 

Options Tab: Define Contingencies 

This tab is the same display as the contingency analysis dialog.  See contingency analysis. 

 

Options Tab: Advanced Options  

ATC Solution Method 

Simulator provides three methods of determining the ATC for a transfer direction. 

• Single Linear Step (SL) 

• Iterated Linear Step (IL) 

• (IL) then Full CTG Solution 

These methods were described in detail in the explanation of Available Transfer Capability (ATC). 

Define Extra Monitors 

Simulators ATC tool determines the maximum amount of MW transfer between the buyer and seller.  If you 
would like to also determine the flow on additional lines or interfaces at the transfer levels determined by the 
ATC tool, then you can utilize the Extra Monitors.  Click on this button to open the ATC Extra Monitors Dialog 
which can be used to define the Extra Monitors. 

Analyze Multiple Scenarios  

Check Analysis Multiple Scenarios to perform ATC Analysis on several scenarios.  See ATC Dialog For Multiple 
Scenarios for more information on Multiple Scenario Analysis. 

Model reactive power for linear methods by… 

The linearized methods used in ATC are based only on the changes in real power MW in the system, thus an 
assumption needs to be made about the reaction of the MVAr flows during the linear calculations.  The choices are 
Ignoring reactive power, Assuming constant voltage magnitude, or Assuming reactive power does not 
change . 

For linear methods, allow amp limits by assuming a constant voltage magnitude  
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If checked, Simulator will allow converting MVA limits to Amp limits by assuming constant voltage magnitudes 
based on the base case full AC load flow operating point just prior to the ATC linear calculations. 

Transfer Calculation Options 

Transfer Tolerance  

This is the tolerance used using the Iterated Linear or (IL) then Full CTG Solution Methods.  The default is 10. 

Max. iterations  

This is the maximum number of iterations used in the Iterated Linear Step or (IL) then Full CTG Solution 
methods.  The default is 10. 

When iterating, Ignore Limiters below 

This value indicates a minimum transfer value for reporting the ATC analysis results.  Any ATC results below 
this value will not be displayed.  In general, you do not want to use this option, as you are interested in all 
transfer limitations during various contingencies.  However, sometimes you may wish to ignore ATC results 
below 0, as a negative ATC result signifies a base case overload or limitation under the given contingency 
condition, prior to any additional transfer in the defined seller to buyer direction. 

Transfer Limiters to Iterate on 

This is the number of transfer limiters to iterate on in the Iterated Linear Step or (IL) then Full CTG Solution 
methods.  The default is 1. 

Power Flow Solution Options  

This button brings up the Power Flow Solution Options Dialog. 

Define Contingency Solution Options  

Click this button to open the Contingency Solution Options Dialog. 

Use specific solution options for contingencies 

When checked, the ATC tool will use the solution options defined by pressing the "Define Contingency Solution 
Options" button for contingency analysis.  When not checked, all solutions will use the options defined by  
pressing the "Power Flow Solution Options" button. 

Enforce OPF Constraints  

This only affects the Iterated Linear or (IL) then Full CTG Solution Methods.  When include OPF Constraints is 
checked, as the solution process ramps the transfer up, it will also solve the OPF after each transfer increase. 

 

Analysis Tab 

Start Analysis  

Click this button to begin the analysis. 

Abort Calculation 

When using one of the iterative ATC Solution Methods, or while analyzing multiple scenarios, click this button to 
Abort the calculation.  Note: This does not immediately abort the solution.  Simulator must restore the system state 
before completing the abort. 

Show Log 

Click this button to show the power flow solution log. 

Restore Initial State  

This will restore the system state to the state when the dialog was first opened. 

Increase Transfer 

Click this button to increase the transfer level manually. 

 

Result Tab 

When performing ATC Analysis on a single system state, the Result Tab is visible.  The Result Tab contains a list of 
the Transfer Limiters that were found by the analysis.  See Transfer Limiters Display for more information. 
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ATC Extra Monitors Dialog 

Simulator’s ATC tool determines the maximum amount of MW transfer between the buyer and seller.  If you would like 
to also determine the flow on additional lines or interfaces at the transfer levels determined by the ATC tool, then you 
can utilize ATC Extra Monitors.  The ATC Extra Monitors Display contains a list display that lists all the ATC Extra 
Monitors defined.  This list display is a Case Information Display, and therefore has the same functionality as other 
common displays.  To insert an Extra Monitor, right-click on the list display and choose insert.  Then choose whether 
you want to monitor an interface MW flow or a Branch MW flow.  Finally choose the interface or branch you are 
interested in.  To delete an extra monitor, right-click on the list display and choose delete. 

 

The default fields shown on this display are 

ATC ExMon Desc 

This is a description of the value that is being monitored.  Presently, this is always MW flow. 

ATC ExMon Obj 

The power system element that is being monitored.  This will either be a transmission branch or an interface. 

Monitor Limit 

This is the MW limit of the element being monitored. 

Relative Monitor 

Set this to a positive value to further filter the Transfer Limitations reported on the Transfer Limiters Display.  By 
default, relative Monitor is set to none, and no additional filtering of limitations is performed.  If this value is greater 
than zero, then only Transfer Limitations which meet the following condition are included in the results. 

 

 
 

This provides a measure of how much an interface or branch is affected by the transfer relative to its MW limit. 
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Multiple Scenario Available Transfer Capability Dialog 

To perform Available Transfer Capability Analysis for several system scenarios, check Analyze Multiple Scenarios on 
the Available Transfer Capability Dialog.  When Analyze Multiple Scenarios is not checked the available tabs are 
Options, Analysis and Result, which are described in the topic Available Transfer Capability Dialog.   

 

When Analyze Multiple Scenarios is checked then the following changes occur: 

• Scenarios Tab appears 

• Results Tab appears 

• Result Tab is removed (replaced by Results) 

The other tabs remain the same, so help regarding them can be found with the Available Transfer Capability Dialog 
help.   

By defining multiple scenarios, Simulator allows you to calculate ATC values for several different power system states 
automatically.  Scenarios can be modified along three axes : 

• Line Rating/Zone Load Scenarios (weather-related scenarios) 

• Generation Scenarios (generation profiles) 

• Interface constraints 

Once you have specified these scenarios, then Simulator is able to perform ATC Analysis on every combination of 
these axes.  For example, assume you have the following: 

• 10 sets of line ratings and zones load  

• 8 sets of generation profiles 

• 3 interface constraints  

This yields a total of 10*8*3 = 240 different scenarios to calculate ATC for.  Be warned that that the more scenarios 
you analyze the longer the computer computation will take. 

The new tabs Scenarios and Results allow you to define these scenarios and view their results. 

 

Scenarios Tab 

The Scenarios Tab has three "subtabs": 

• Line Ratings/Zone Loads 

• Generator Outputs  

• Interface Ratings 

Each tab contains a list of the power system elements that will be modified during different scenarios.  This list is a 
familiar Case Information Display providing the same functionality as other displays by right-clicking to bring up the 
local menu.  To insert a new power system element into the list, right click on the list (below the headings) and choose 
Insert.   

On each tab, you may enter how many different scenarios should be defined for that kind of power system element.  
For instance if you set Generation Scenarios to 5, then list display on the Generation Tab will provide 5 columns 
labeled G0, G1, G2, G3, and G4.  Generation outputs should then be entered into each cell representing the 
generation output in each scenario. 

Line Ratings and Zone Loads are varied together when analyzing scenarios.  This was chosen because they often 
vary together as a function of the weather.  On the Line Ratings/Zone Loads tab, notice that a tab appears toward the 
bottom of the dialog that contains two options: Line Ratings and Zone Loads.  This tab toggles between the list 
displays for lines and zones. 

 

Results Tab 

Once you have defined your scenarios and started the ATC Analysis, you can switch to the Results Tab to see the 
progress that ATC Analysis is making.  The primary part of the Results tab contains a spreadsheet-like "workbook" 
display.  The three axes correspond to the three Scenarios Tabs.   

• One axis has heading labels G0, G1, … for the Generation Scenarios,  

• Another with heading labels RL0, RL1, … for the Rating/Load Scenarios,  

• A third with heading labels I0, I1, … for the Interface Scenarios.   

To change the order of these axes change Axis Order.   

To view the Transfer Limiters found under each scenario, click the Show Transfer Limiters button.  This will open a 
separate dialog that displays a list of the Transfer Limiters.  To see the Transfer Limiters for a particular scenario, click 
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on the workbook cell that represents the scenario you are interested in and the separate dialog will update 
appropriately. 

If you right click on the workbook, you will bring up a local menu containing several options.  The first several options 
are only enabled if you right click on a cell representing a scenario.  These options will perform an operation with 
respect to the Scenario: 

Take me to Scenario … 

Will make modifications to the system state to take you to the Scenario. 

Determine Transfer Limit For Scenario … 

Will calculate the ATC for the Scenario, and then take you back to the Initial State. 

Take me to the Transfer Limit For Scenario … 
Will perform ATC for the Scenario, and then ramp the transfer to this limit. 

Other options on this local menu are not related to the Scenario you have clicked on.  

Increase Transfer for Present System State  

Will increment the transfer level for the present system state by a user-defined amount. 

Return to Initial State  

Will return the system state to the Initial State. 
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Transfer Limiters Display 

The Transfer Limiters Display appears on the Result Tab of the Available Transfer Capability Dialog or as a separate 
window when performing Multiple Scenario Available Transfer Capability Analysis.  This display shows the results of 
ATC Analysis. 

The display contains four different tabs: All Limiters, Branch Limiters, Interface Limiters, and Nomogram Interface 
Limiters.  The All Limiters tab shows a list of all the transfer limitations found.  This includes limitations on branches, 
interfaces, areas, zones, etc…  The Branch Limiters Tab only shows those limitations with a transmission line or 
transformer as the limiting element.  The limiting element description for the Branch Limiters tab is replaced by the bus 
numbers and names of the limiting element.  The Interface Limiters Tab only shows those limitations with an interface 
as the limiting element.  The limiting element description is replaced by the name of the interface. The Nomogram 
Interface Limiters Tab only shows those limitations with a nomogram interface as the limiting element. The limiting 
element description is replaced by the name and segment of the nomogram interface. 

Lastly, a Contingency Definition Display is also available at the bottom of the Result Tab.  This list will display the 
defined contingency that caused the selected limitation from one of the three pages of limiters. 

 

The fields that are included on this display are 

Transfer Limit 

Shows the Transfer Limit in MW for the Limiting Element during the Limiting Contingency.  This value depends on 
the ATC Solution Method Used. 

Single Linear Step (SL) 

Only one Linear ATC step is performed.  The Transfer Limitation values are those found during this step. 

Iterated Linear Step (IL) 

The Linear ATC method is iterated during this method.  The Transfer Limiters shown are those found during the 
final step performed.  The actual Transfer Limitation values are the values found at the last step plus the 
accumulated amount the transfer has been ramped.  The Transfer Limitation(s) that were used when iterating 
are highlighted in cyan. 

Iterated Linear Step (IL) then Full CTG Solution 

The Transfer Limiters shown are those found during the last contingency analysis step that found violations.  
The Transfer Limitation values equal the accumulated amount the transfer was ramped.  Note that when 
performing the Full CTG Solution, negative ATC values will not be probed, so the Transfer Limit will appear as 
0 if there are violations in the Initial State. Any Transfer Limiters that result in unsolvable contingencies are 
solved with the Single Linear step (SL) and are highlighted in yellow. 

Limiting Element 

Shows a text description of the limiting element 

Limiting CTG 

Shows the name of the limiting contingency 

% OTDF 

This is the OTDF (or PTDF if the Limiting CTG is Base Case) on the Limiting Element for the transfer direction that 
is being studied.  In other words, this is a linear estimate of the percent of the transfer that will appear on the 
Limiting Element if the Limiting CTG occurs.   

Note: For Iterated Linear, this is the PTDF or OTDF at the last Linear Iteration.  When using Full CTG Solution 
Method, this is not calculated and will appear as 0 for all Limiters. 

Pre-Transfer Value Estimate  

If a contingency is not included in the Limiter, this is equal to the Initial Value.  When a contingency is included in 
the Limiter, this is the linear estimate of the post-contingency flow before any transfer occurs.  See Available 
Transfer Capability Analysis.   

Note: For Iterated Linear, this is the estimate at the last Linear Iteration.   When using (IL) Full this is not calculated 
and will appear as 0 for all Limiters. 

Limit Used 

This is the value of the Limit being used by the ATC for the Limiting Element during the Limiting CTG.  It reflects 
what is specified in Limit Monitoring Settings. 

Simulator Automation Server (SIMAUTO) 

Simulator Automation Server 

The PowerWorld Automation Server is only available to customers who have purchased the SimAuto add-on for 
PowerWorld Simulator.  The PowerWorld Simulator Automation Server is intended for enabling a PowerWorld 
customer with the ability to access PowerWorld Simulator functionality from within a program written externally by the 
user.  The Simulator Automation Server acts as a COM object, which can be accessed from various different 
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programming languages that have COM compatibility.  Examples of programming tools with COM compatibility are 
Borland Delphi, Microsoft Visual C++, Microsoft Visual Basic, and Matlab, just to name a few.  For more 
information on COM Objects and Automation Servers, see the help for Microsoft Windows. 

The Automation Server of Simulator works very well in combination with Simulator Script Commands and Auxiliary 
Files.  It is beneficial to become familiar with these topics when considering using the Simulator Automation Server. 

Note that previous users of SimAuto in Version 9 will need to update their function calls to SimAuto functions.  
PowerWorld Corporation found it absolutely necessary to change the function calls for SimAuto, in order to remedy 
irreconcilable problems when using SimAuto with some programming languages.  The documentation provided should 
provide adequate help on the changes needed, but as always, if any questions arise, please contact PowerWorld 
Corporation for more information. 

Starting Simulator Automation Server 

Installing Simulator Automation Server 
Installing the Simulator Automation Server requires no additional steps beyond installing PowerWorld Simulator as 
normal.  When a version of PowerWorld Simulator containing the Simulator Automation Server is installed on your 
computer, the install program automatically adds the information needed by the Simulator Automation Server to the 
registry. 

If for some reason the registration fails, be sure you have the SimAuto add-on for Simulator and you have either run 
the application on the computer or run the command pwrworld / regserver at the command line. If instead you would 
like SimAuto to un-register itself as a COM object, run the command pwrworld /unregserver at the command line. 
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Including Simulator Automation Server Functions 
Before you can access the functions  defined by the Simulator Automation Server when writing the code for your 
external program, you must first include the library of functions defined for the Simulator Automation Server.  This kind 
of library is referred to as a Type Library, which describes the available functions in a manner that can be interpreted 
by different programming languages.  Importing a Type Library from another program is usually fairly simple, but the 
procedure does vary depending on the programming tool you are using.  Please see the help for your programming 
tool of choice on how to import a Type Library or COM functions from another program. 

 

Examples 

The following examples are just a few specific examples for certain programming media.  The procedure may be 
different for other programming media not listed.  In addition, a procedure given for a certain type of programming 
media may be one variation from several possible procedures for accomplishing the same task. 

Borland Delphi 

• Install the version of PowerWorld Simulator with the Simulator Automation Server included. 

• In Delphi, choose Import Type Library… from the Project menu. 

• In the list of libraries, search for and choose pwrworld Library. 

• If pwrworld Library is not in the list, click Add.  Find and choose the Pwrworld.exe f ile from the PowerWorld 
Simulator directory, and click Open. 

• You should see the class name TSimulatorAuto in the list of Class names. 

• Click Install to include the PowerWorld Simulator Type Library. 

Microsoft Visual Basic for Applications  

• No additional tasks are necessary 

• Importing Type Library still works (See Including Functions for version 9). 

Microsoft Visual C++ 

• Install the version of PowerWorld Simulator with the Simulation Automation Server included. 

• Add #import "…\powerworld.exe" in your external program code, using the full path to the PowerWorld 
Simulator executable program. 

• Add using namespace pwrworld in your external program code. 

Matlab v.6.5 r.13 

• No additional tasks are necessary. 
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Connecting to Simulator Automation Server 
Once the Type Library or COM functions have been included in your programming environment, the Simulator 
Automation Server can be handled as any other object in your code.  The method for assigning and connecting to the 
Simulator Automation Server can vary depending on the programming environment used, but the idea is basically the 
same.  You define a variable in your program to point to the server object, which is called SimulatorAuto.  If the Type 
Library was imported properly, you should have full access to the SimulatorAuto object and its defined functions.  
Again, the procedure for creating the object and connecting to SimulatorAuto may vary for different programming 
languages.  Check the help for your programming environment on connecting to COM or Automation servers. 

 

Examples 

The following examples are just a few specific examples for certain programming media.  The procedure may be 
different for other programming media not listed.  In addition, a procedure given for a certain type of programming 
media may be one variation from several possible procedures for accomplishing the same task. 

Borland Delphi 5 

• Add pwrworld_TLB to the uses section of your unit. 

• Declare a variable globally or as part of another object: A : ISimulatorAuto 

• Initialize the variable: A := nil 

• To connect to the Simulator Automation Server, create the connection: A := CoSimulatorAuto.create  

• Perform function calls to the Simulator Automation Server: Output := A.SomeFunction(parameters) 

• To close the connection to the Simulator Automation Server, remove the reference by again setting: A := 
nil 

Microsoft Visual Basic for Applications  

Early Binding: 

• To connect to the Simulator Automation Server, create the connection initializing the variable: 

Dim A as New pwrworld.SimulatorAuto 

Late Binding: 

• Declare a variable globally or as part of another object or function: Dim A As Object 

• To connect to the Simulator Automation Server, create the connection: 

Set A = CreateObje ct("pwrworld.SimulatorAuto") 

Both Early and Late Binding: 

• Perform function calls to the Simulator Automation Server: Output = A.SomeFunction parameters 

• To close the connection to the Simulator Automation Server, remove the reference: Set A = Nothing 

• If Type Library was imported, connection can also be achieved as in version 9 (See Connecting to 
Simulator Automation Server in version 9). 

Microsoft Visual C++ 

• Declare a variable globally or as part of another object or function: IsimulatorAutoPtr *A 

• Declare a variable globally or as part of another object or function: CLSID clsid 

• Declare a variable globally or as part of another object or function: HRESULT hr 

• Obtain the class identifier (clsid) with the following command: 

hr = CLSIDFromProgID(L"pwrworld.SimulatorAuto", &clsid) 

• Initialize variable A: A = new IsimulatorAutoPtr 

• To connect to the Simulator Automation Server, create the connection: 

hr = A>CreateInstance(clsid, NULL, CLSCTX_SERVER) 

• Perform function calls to the Simulator Automation Server: Output = A.SomeFunction(parameters) 

• To close the connection to the Simulator Automation Server, release the reference: 

hr = A>Release() 

Matlab v.6.5 r.13 

• To connect to the Simulator Automation Server, create the connection: 

A = actxserver(‘pwrworld.SimulatorAuto’) 

• Perform function calls to the Simulator Automation Server: Output = A.SomeFunction(parameters) 

• To close the connection to the Simulator Automation Server, delete the connection: delete(A) 
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Simulator Automation Server Functions  

PassingData to the Simulator Automation Server 
Passing Data to the Simulator Automation Server 

All data to the Simulator Automation Server is  passed by value rather than by reference (in pointer terminology, this 
corresponds to sending data instead of pointer to data; in Microsoft Visual Basic®, this corresponds to sending data 
ByVal instead of ByRef).  This makes the marshalling of data between client software and the COM object much 
easier. 

 

No Optional Parameters 

There are no optional parameters for any of the Simulator Automation functions.  All functions must be called with 
every argument filled. 
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Getting Data from the Simulator Automation Server 
The Output Structure 

Every function called on the SimulatorAuto object returns the same value, Output, which has a well-defined structure. 

Output is of type VARIANT, and is an array of VARIANT’s.  Output is zero-indexed. 

The first element always contains any errors occurring during execution.  For those functions returning more than one 
element in the Output array (e.g. ListOfDevices), explanation is provided below when discussing the specific method. 

 

Error Handling 

As mentioned above, the first item in the Output VARIANT array, Output[0], contains any errors occurring during the 
function’s execution.  If no errors occurred during the function’s execution, Output[0] will be set to an empty BSTR 
(string) represented in most languages by either ‘’ or "". 

 

Error Format 

If an error string is returned, it will be in the following format: 

[method name]: [error_explanation] 

e.g. RunScriptCommand: Error occurred processing script command – check command syntax 
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Simulator Automation Server Functions 
The follow ing list of functions is currently available once the SimulatorAuto object is set in your code.  Check the help 
sections on these functions to see more detail on the particular function. 

ChangeParameters  

CloseCase  

GetParametersSingleElement  

GetParametersMultipleElement  

GetParameters (for compatibility with version 9) 

ListOfDevices  

OpenCase  

ProcessAuxFile  

RunScriptCommand  

GetFieldList  

SaveState  

LoadState  

SaveCase  

SendToExcel  

WriteAuxFile  
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ChangeParameters Function 
Sample Code  

The ChangeParameters function allows you to set a list of parameters for a specific object in a case loaded into the 
Simulator Automation Server.  In addition to changing parameters for objects, this function can also be used to set 
options for some of the Simulator tools, such as ATC and OPF.  This function is identical in setup to the 
GetParametersSingleElement function, with the exception that the Values array must contain a value for each field 
variable given in the ParamList array. 

 

Function Prototype  

ChangeParameters(ObjectType, ParamList, Values) 

 

Parameter Definitions  

ObjectType : String The type of object you are changing parameters for. 

ParamList : Variant A variant array storing strings (COM Type BSTR).  This array stores a list of 
PowerWorld object field variables, as defined in the section on PowerWorld 
Object Fields.  The ParamList must contain the key field variables for the 
specific device, or the device cannot be identified. 

Values : Variant A variant array storing variants.  This array can store any type of information 
(integer, string, etc.) in each array position.  A value should be passed for each 
field variable given in the ParamList.  The Values array must contain the key 
field values for the specific device, or the device cannot be identified. 

 

Output 

ChangeParameters only returns the first element in Output, the error string. 

 

Notes 

The ParameterList and Values arrays must be the same size, as each parameter must have a corresponding 
value to be assigned. 
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ChangeParameters Function: Sample Code 
Borland® Delphi 

Var ParamList, ValueList : OLEVariant 

 

// Set ParamList up to modify the maximum number of iterations  

// and the system base for the power flow simulations 

ParamList := VarArrayCreate([1,2], varOleStr); 

ParamList[1] := 'MaxItr'; 

ParamList[2] := 'SBase'; 

 

// ValueList is setup with 41 and 410 for MaxItr and SBase, 

// respectively  

ValueList := VarArrayCreate([1,2], varOleStr); 

ValueList[1] := 41; 

ValueList[2] := 410; 

 

// Make the ChangeParameters call 

Output = SimAuto.ChangeParameters('Sim_Solution_Options', _ 

         ParamList, ValueList) 

 

Microsoft® Visual Basic for Applications  

' Set ParamList up to modify the maximum number of iterations  

' and the system base for the power flow simulations 

Dim ParamList As Variant 

ParamList = Array("MaxItr", "Sbase") 

 

' ValueList is setup with 41 and 410 for MaxItr and SBase, 

' respectively  

Dim ValueList As Variant 

ValueList = Array(45, 90) 

 

' Make the ChangeParameters call 

Output = SimAuto.ChangeParameters("Sim_Solution_Options", _ 

         ParamList, ValueList) 

 
Matlab® 

% Set ParamList up to modify the maximum number of iterations 

% and the system base for the power flow simulations 

ParamList = {'MaxItr' 'Sbase'}; 

 

% values is setup with 41 and 410 for MaxItr and SBase, 

% respectively 

values = [41 410]; 

 

% Convert the values matrix to a set of cells for passing 

% through the COM interface 

ValueList = num2cell(values); 

 

' Make the ChangeParameters call 
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Output = SimAuto.ChangeParameters('Sim_Solution_Options', _ 

         ParamList, ValueList) 
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CloseCase Function 
Sample Code  

The CloseCase function is used to close a load flow case loaded in the Simulator Automation Server.  This function 
should be called at some point after the OpenCase function. 

 

Function Prototype  

CloseCase() 

 

Parameter Definitions  

No parameters are passed. 

 

Output 

CloseClase returns only one element in Output—any errors which may have occurred when attempting to 
close the case. 
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CloseCase Function: Sample Code 
Borland® Delphi 

Output := SimAuto.CloseCase(); 

 
Microsoft® Visual Basic for Applications  

Output = SimAuto.CloseCase() 

 

Matlab® 

Output = SimAuto.CloseCase 
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GetFieldList Function 
Sample Code  

The GetFieldList function is used to find all fields contained within a given object type. 

 

Function Prototype  

GetFieldList(ObjectType) 

 

Parameter Definitions  

ObjectType : String The type of object for which the fields are requested. 

 

Output 

GetFieldList returns two elements of the Output array.  The first element, as with the other functions, returns 
any errors that might have occurred.  The second element of the Output array contains an n x 4 array of 
fields.  The layout of this array is virtually identical to the output obtained by going to Help -> Export 
Object Fields.  The first column, corresponding to the (n,0) column in the field array, specifies which fields 
are key fields for the object.  The second column, (n,1), contains the internal name of the field.  The third 
column, (n,2), contains the type of data stored in the string (e.g. String, Integer, Real).  The fourth column, 
(n,3), contains the display-friendly name of the field. 
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GetFieldList Function: Sample Code 
Microsoft® Visual Basic for Applications  

Dim objecttype As String 

 

' Object type to obtain 

objecttype = "branch" 

 

' Make the GetField call 

Output = SimAuto.GetFieldList(objecttype) 

 

Matlab® 

% Object type to obtain 

objecttype = 'branch'; 

 

% Make the GetField call 

Output = SimAuto.GetFieldList(objecttype); 
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GetParametersSingleElement Function 
Sample Code for Delphi  Sample Code for VB  Sample Code for Matlab  

The GetParametersSingleElement function is used to request the values of specified fields for a particular object in the 
load flow  case.  For returning field values for multiple objects, you can use a loop to make repeated calls to the 
GetParametersSingleElement function, and pass the object and desired field information for each object.  This function 
is identical in setup to the ChangeParameters function, with the exception that the Values array will be updated with 
the values for the field variables defined in ParamList. 

 

Function Prototype  

GetParametersSingleElement(ObjectType, ParamList, Values) 

 

Parameter Definitions  

ObjectType : String The type of object you are changing parameters for. 

ParamList : Variant A variant array storing strings.  This array stores a list of PowerWorld object 
field variables, as defined in the section on PowerWorld Object Fields.  The 
ParamList must contain the key field variables for the specific device, or the 
device cannot be identified.  The remaining field variables in the array define 
which values to retrieve from Simulator. 

Values : Variant A variant array storing variants.  This array can store any type of information 
(integer, string, etc.) in each array position.  Values must be passed for the key 
field variables in ParamList, in the same array position.  The remaining field 
positions in the Values array should be set to zero. 

 

Output 

GetParametersSingleElement returns both the first element in Output—containing any errors occurring during 
execution of the function—and a second element in Output. The second element returned in the Output 
structure is a one dimensional array containing the values corresponding to the fields specified in ParamList. 

The Output structure of GetParametersSingleElement is shown in the following figure. 
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GetParametersSingleElement Function: Sample Code Borland® Delphi 
// This example retrieves some parameters for bus 2 of the loaded 

// case, using the GetParametersSingleElement function, as well as 

// the old GetParameters function 

 

procedure TMainForm.RunGPSEClick(Sender: TObject); 

var 

  Output : OLEVariant; 

  FieldBusArray, ValueBusArray  : OLEVariant; 

  i : Integer; 

begin 

  // Declares fields array to be sent to Excel 

  FieldBusArray := VarArrayCreate([1,5], varOleStr); 

  FieldBusArray[1] := 'pwBusNum'; 

  FieldBusArray[2] := 'pwBusname'; 

  FieldBusArray[3] := 'pwBusKVVolt'; 

  FieldBusArray[4] := 'pwBusPUVolt'; 

  FieldBusArray[5] := 'pwBusAngle'; 

  ValueBusArray := varArrayCreate([1,5],varOleStr); 

  ValueBusArray[1] := 2;  // To get parameters for bus 2 

  ValueBusArray[2] := 0; 

  ValueBusArray[3] := 0; 

  ValueBusArray[4] := 0; 

  ValueBusArray[5] := 0; 

 

  // Gets parameters with GetParametersSingleElement function 

  Output := SimAuto.GetParametersSingleElement('bus', FieldBusArray, ValueBusArray); 

  if (string(Output[0]) <> '') then 

    StatusBar1.Panels[1].Text := 'Error: ' + string(Output[0]) 

  else 

  begin 

    StatusBar1.Panels[1].Text := 'Parameters got.'; 

    Memo1.Lines.Add('== GetParametersSingleElement =='); 

    Memo1.Lines.Add('Value : Output[1][i]'); 

    for i := VarArrayLowBound(Output[1],1) to VarArrayHighBound(Output[1],1) do begin 

      Memo1.Lines.Add(FieldBusArray[i] + ' : ' + string(Output[1][i])); 

    end; 

    Memo1.Lines.Add(''); 

  end; 

 

  // Gets parameters with old function GetParameters 

  Output := SimAuto.GetParameters('bus', FieldBusArray, ValueBusArray); 

  if (string(Output[0]) <> '') then 

    StatusBar1.Panels[1].Text := 'Error: ' + string(Output[0]) 

  else 

  begin 

    StatusBar1.Panels[1].Text := 'Parameters got.'; 

    Memo1.Lines.Add('== GetParameters =='); 

    Memo1.Lines.Add('Value : Output[1][i]'); 
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    for i := VarArrayLowBound(Output[1],1) to VarArrayHighBound(Output[1],1) do begin 

      Memo1.Lines.Add(FieldBusArray[i] + ' : ' + string(Output[1][i])); 

    end; 

    Memo1.Lines.Add(''); 

  end; 

end; 
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GetParametersSingleElement Function: Sample Code Matlab®  
% This example loads all buses in the case, and then gets 

% some parameters of the last bus in the list 

 

% validcase is a global variable – check case is open 

if validcase  

  % Gets all buses in the case 

  output = simauto.ListOfDevices('bus',''); 

  if ~(strcmp(output{1},'')) 

    disp(output{1}) 

    validbusarray = false; 

  else 

    % Puts the buses in row vector busarray  

    for i=size(output{2}{1},1):size(output{2}{1},2) 

      busarray(i,1) = output{2}{1}(i);  

    end 

    disp('Succesful ListOfDevices') 

    disp(busarray) 

    validbusarray = true; 

  end 

end 

 

% validbusarray is a global variable – check buses are loaded 

if validcase & validbusarray  

  % Gets parameters for last bus of busarray  

  fieldarray = {'pwbusnum' 'pwbusname' 'pwbusvolt' 'pwbusangle'}; 

  valuearray = [busarray(size(busarray,1)) '0' '0' '0']; 

  valuelist = num2cell(valuearray); 

  output = simauto.GetParametersSingleElement('bus',fieldarray,valuelist); 

  if ~(strcmp(output{1},'')) 

    disp(output{1}) 

  else 

    % Puts the buses in row vector busparam 

    paramlist = transpose(output{2}); 

    for i=size(paramlist,1):size(paramlist,2) 

      busparam(i,1) = paramlist(i);  

    end 

    disp('Succesful GetParameters for Bus') 

    disp(fieldarray) 

    disp(busparam) 

  end 

end 
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GetParametersSingleElement Function: Sample Code Microsoft® Visual Basic for 
Excel 

Private Sub btnGetParametersSingleElement_Click() 

Dim objtype, filter As String 

Dim xlWB As Excel.Workbook 

Set xlApp = Excel.Application 

 

' Checks connection and open case 

' SimAuto and caseopen are global variables 

If Not SimAuto Is Nothing And caseopen Then 

  objtype = "bus" 

  Dim fieldArray As Variant 

  fieldArray = Array("pwBusNum", "pwBusName", "pwBusKVVolt", _ 

                     "pwBusPUVolt", "pwBusAngle") 

  Dim ValueArray As Variant 

  ValueArray = Array(1, 0, 0, 0, 0) 

  output = SimAuto.GetParameters(objtype, fieldArray, ValueArray) 

    If output(0) <> "" Then 

      DisplayErrorMessage output(0) 

    Else 

      DisplayMessage "Succesful GetParametersSingleElement" 

      ' Prepares additional worksheet 

      Set xlWB = xlApp.Workbooks.Add 

      ' Copies list of devices in worksheet 

      With xlWB 

        Sheets("sheet2").Activate 

        Sheets("sheet2").Name = "GetParametersSingleElement" 

        With Sheets("GetParametersSingleElement") 

          Dim i As Integer 

          Range(Cells(1, 5), Cells(200, 7)).Clear 

          Cells(1, 1) = "List of Devices for " + objtype + ":" 

          ' Setup fields as subheader 

          For i = LBound(fieldArray) To UBound(fieldArray) 

            Cells(2, i + 1) = fieldArray(i)  

          Next i 

          ' Determine number of fields retrieved 

          Dim lowfld, highfld As Integer 

          lowfld = LBound(output(1), 1) 

          highfld = UBound(output(1), 1) 

          DisplayMessage "Number of Fields: " + Str(lowfld) + Str(highfld) 

          For i = lowfld To highfld 

            Cells(j + 3, i + 1) = output(1)(i) 

          Next i 

        End With 

      End With 

    End If  

End If  

End Sub 
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GetParametersMultipleElement Function 
Sample Code for Delphi  Sample Code for VB  Sample Code for Matlab  

The GetParametersMultipleElement function is used to request the values of specified fields for a set of objects in the 
load flow case.  The function can return values for all devices of a particular type, or can return values for only a list of 
devices of a particular type based on an advanced filter defined for the loaded case. 

 

Function Prototype  

GetParametersMultipleElement(ObjectType, ParamList, FilterName) 

 

Parameter Definitions  

ObjectType : String The type of object you are changing parameters for. 

ParamList : Variant A variant array storing strings.  This array stores a list of PowerWorld object 
field variables, as defined in the section on PowerWorld Object Fields.  The 
ParamList must contain the key field variables for the specific device, or the 
device cannot be identified.  The remaining field variables in the array define 
which values to retrieve from Simulator. 

FilterName : String The name of an advanced filter defined in the load flow case open in the 
Simulator Automation Server.  If no filter is desired, then simply pass an empty 
string.  If a filter name is passed but the filter cannot be found in the loaded 
case, the server will default to returning all objects in the case of type ObjType. 

 

Output 

GetParametersMultipleElement returns a set of nested arrays containing the parameter values for the device 
type requested.  The number of arrays of values returned depends on the number of fields in ParamList. 

The Output structure of GetParametersMultipleElement is shown in the following figure. 

 

 
 

As you can see, to access the first parameter value for the first device, Output[1][0][0] would be the correct 
array index. For example, the bus number for the first bus would be stored at Output[1][0][0] after calling 
Output = GetParametersMultipleElement('Bus',fieldarray, ''), and assuming that we have 
fieldarray = Array(pwBusnum, pwBusName). 
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GetParametersMultipleElement Sample Code Borland® Delphi 
// This example retrieves some parameters for all buses of the 

// loaded case, using the GetParametersMultipleElement function 

 

procedure TMainForm.RunGPMEClick(Sender: TObject); 

var 

  FieldBusArray : OLEVariant; 

  i,j : Integer; 

begin 

  // Declares fields array to be sent to Excel 

  FieldBusArray := VarArrayCreate([1,5], varOleStr); 

  FieldBusArray[1] := 'pwBusNum'; 

  FieldBusArray[2] := 'pwBusname'; 

  FieldBusArray[3] := 'pwBusKVVolt'; 

  FieldBusArray[4] := 'pwBusPUVolt'; 

  FieldBusArray[5] := 'pwBusAngle'; 

 

  // Gets parameters with Multiple Element function 

  Output := SimAuto.GetParametersMultipleElement('bus', FieldBusArray, ''); 

  if (string(Output[0]) <> '') then 

    StatusBar1.Panels[1].Text := 'Error: ' + string(Output[0]) 

  else 

  begin 

    StatusBar1.Panels[1].Text := 'Parameters got.'; 

    Memo1.Lines.Add('== GetParametersMultipleElement =='); 

    Memo1.Lines.Add('Value : Output[1][i][j]'); 

    for i := VarArrayLowBound(Output[1],1) to V arArrayHighBound(Output[1],1) do begin 

      for j := VarArrayLowBound(Output[1][i],1) to VarArrayHighBound(Output[1][i],1)  

      do begin 

        Memo1.Lines.Add(FieldBusArray[i] + '(' + IntToStr(j) + ') : ' +  

                        string(Output[1][i][j])); 

      end; 

    end; 

    Memo1.Lines.Add(''); 

  end; 

end; 
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GetParametersMultipleElement Function: Sample Code Matlab®  
% This example loads all buses in the case, and then gets 

% some parameters of such buses  

 

% validcase is a global variable – check case is open 

if validcase  

  % Gets all buses in the case 

  output = simauto.ListOfDevices('bus', ''); 

  if ~(strcmp(output{1},'')) 

    disp(output{1}) 

    validbusarray = false; 

  else 

    % Puts the buses in row vector busarray  

    for i=size(output{2}{1},1):size(output{2}{1},2) 

      busarray(i,1) = output{2}{1}(i);  

    end 

    disp('Succesful ListOfDevices') 

    disp(busarray) 

    validbusarray = true; 

  end 

end 

 

% validbusarray is a global variable – check buses are loaded 

if validcase & validbusarray  

  % Gets parameters for all buses  

  fieldarray = {'pwbusnum' 'pwbusname' 'pwbusvolt' 'pwbusangle'}; 

  output = simauto.GetParametersMultipleElement('bus', fieldarray,' '); 

  if ~(strcmp(output{1},'')) 

    disp(output{1}) 

  else 

    % Puts the buses in matrix busesparam 

    paramlist = transpose(output{2}); 

    for i=size(paramlist,1):size(paramlist,2) 

      for j=size(paramlist{i},2):size(paramlist{i},1) 

        busesparam(j,i) = paramlist{i}(j); 

      end 

    end 

    disp('Succesful GetParametersMultipleElement') 

    disp(fieldarray) 

    disp(busesparam) 

  end 

end 
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GetParametersMultipleElement Function: Sample Code Microsoft® Visual Basic 
for Excel 

Private Sub btnGetParametersMultiple_Click() 

Dim objtype, filter As String 

Dim xlWB As Excel.Workbook 

Set xlApp = Excel.Application 

 

' Checks connection and open case 

' SimAuto and caseopen are global variables 

If Not SimAuto Is Nothing And caseopen Then 

  objtype = "bus" 

  filter = "" 

  Dim fieldArray As Variant 

  fieldArray = Array("pwBusNum", "pwBusName", "pwBusKVVolt", _ 

                     "pwBusPUVolt", "pwBusAngle") 

  output = SimAuto.GetParametersMultipleElement(objtype, fieldArray, filter) 

  If output(0) <> "" Then 

    DisplayErrorMessage output(0) 

  Else 

    DisplayMessage "Succesful GetParametersSingleElement" 

    ' Prepares additional worksheet 

    Set xlWB = xlApp.Workbooks.Add 

    ' Copies list of devices in worksheet 

    With xlWB 

      Sheets("sheet2").Activate 

      Sheets("sheet2").Name = "GetParametersSingleElement" 

      With Sheets("GetParametersSingleElement") 

        Dim i, j As Integer 

        Range(Cells(1, 5), Cells(200, 7)).Clear 

        Cells(1, 1) = "List of Devices for " + objtype + ":" 

        ' Setup fields as subheader 

        For i = LBound(fieldArray) To UBound(fieldArray) 

          Cells(2, i + 1) = fieldArray(i) 

        Next i 

        ' Determine number of fields retrieved 

        Dim lowfld, highfld As Integer 

        lowfld = LBound(output(1), 1) 

        highfld = UBound(output(1), 1) 

        ' Determine number of objects retrieved 

        Dim lowobj, highobj As Integer 

        lowobj = LBound(output(1)(lowkeyf), 1) 

        highobj = UBound(output(1)(lowkeyf), 1) 

        DisplayMessage "Number of Fields: " + Str(lowfld) + Str(highfld) 

        DisplayMessage "Number of objects: " + Str(lowobj) + Str(highobj) 

        For i = lowfld To highfld 

          For j = lowobj To highobj 

            Cells(j + 3, i + 1) = output(1)(i)(j) 

          Next j 

        Next i 
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      End With 

    End With 

  End If  

End If  

End Sub 
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GetParameters Function 
This function is maintained in Simulator version 10 for compatibility with Simulator version 9. This function is replaced 
by GetParametersSingleElement. See also GetParametersMultipleElement. 
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ListOfDevices Function 
Sample Code for Delphi  Sample Code for VB  SampleCode for Matlab  

The ListOfDevices function is used to request a list of objects and their key fields from the Simulator Automation 
Server.  The function can return all devices of a particular type, or can return only a list of devices of a particular type 
based on an advanced filter defined for the loaded case.  This function is best used in conjunction with a looping 
procedure and the ChangeParameters or GetParametersSingleElement functions to process a group of devices. 

 

Function Prototype  

ListOfDevices(ObjType, filterName) 

 

Parameter Definitions  

ObjType : String The type of object for which you are acquiring the list of devices. 

FilterName : String The name of an advanced filter defined in the load flow case open in the 
Simulator Automation Server.  If no filter is desired, then simply pass an empty 
string.  If the filter cannot be found, the server will default to returning all objects 
in the case of type ObjType. 

 

Output 

ListOfDevices returns a set of nested arrays containing the key field values for the device type requested.  
The number of arrays of values returned depends on the object type selected.  For instance, buses have only 
one key field (the bus number) so calling ListOfDevices for buses will return only one array of values —the bus 
numbers.  On the other hand, calling ListOfDevices for branches will return three arrays of values—the "From" 
bus, "To" bus, and ID—for each branch in the case meeting the specified filter. 

The arrays containing the key field values for each device are arranged as shown in the following figure. 

 

 
 

As you can see, to access the first key field value for the first device, Output[1][0][0] would be the correct 
array index. For example, the bus number (which is the bus key field) for the first bus would be stored at 
Output[1][0][0] after calling Output = ListOfDevices('Bus', ''). 
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ListOfDevices Function: Sample Code for Borland® Delphi 
Sample Code  

// Runs Available Transfer Capability Routine 

// Executes ATC Calculations among all areas 

// and sends results to Excel 

procedure TMainForm.RunATCClick(Sender: TObject); 

var 

  i, j, LowB, HighB : Integer; 

  ValuesAreaArray : OLEVariant; 

begin 

  // Obtain all the areas 

  Output := SimAuto.ListOfDevices('area', ''); 

  if (string(Output[0]) <> '') then 

    StatusBar1.Panels[1].Text := 'Error: ' + string(Output[0]) 

  else 

  begin 

    ValuesAreaArray := Output[1][0]; 

    LowB := VarArrayLowBound(ValuesAreaArray, 1); 

    HighB := VarArrayHighBound(ValuesAreaArray, 1); 

    // Executes loop 

    for i := LowB to HighB do 

      for j := LowB to HighB do begin 

        if (i <> j) then begin 

          // Runs ATC calculations  

          OutputATC := SimAuto.RunScriptCommand('entermode(atc); ' +  

                       'atcdetermine([Area ' + IntToStr(ValuesAreaArray[i]) +  

                       '], [Area ' + IntToStr(ValuesAreaArray[j]) + '])'); 

          if (string(OutputATC[0]) <> '') then 

            StatusBar1.Panels[1].Text := 'Error: ' + string(OutputATC[0]) 

          else begin 

            // Sends ATC results to Excel 

            Output := SimAuto.SendToExcel('transferlimiter', '', 'all'); 

            if (string(Output[0]) <> '') then 

              StatusBar1.Panels[1].Text := 'Error: ' + string(Output[0]) 

            else 

              StatusBar1.Panels[1].Text := 'ATC calculations done.'; 

          end; 

        end; 

      end; 

  end; 

end; 
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ListOfDevices Function: Sample Code for Matlab® 
Sample Code  

%A list of branches is desired, without using any filter 

DeviceType = 'Branch'; 

FilterName = ''; 

%Execute the ListOfDevices command 

Output = SimAuto.ListOfDevices(DeviceType,FilterName); 

%If the first cell in SimAutoOutput ~= '', then that means an error 

%occurred. 

if ~(strcmp(SimAutoOutput{1},'')) 

  disp(SimAutoOutput{1}) 

else 

  %Otherwise, no errors.  Display the branch information. 

  disp('ListOfDevices successful') 

   

  %Devicelist1 contains the From: bus number 

  %Devicelist2 contains the To: bus number 

  %Devicelist3 contains the Bus identifier 

  devicelist1 = double(transpose(SimAutoOutput{2}{1})); 

  devicelist2 = double(transpose(SimAutoOutput{2}{2})); 

  devicelist3 = SimAutoOutput{2}{3}; 

 

  %If the device list is greater than 25, don't bother attempting to 

  %display it on the screen. 

  if (size(devicelist1,1) > 25)  

    disp('Device list exceeds 25; use ''devicelist'' to manage list of devices') 

  else     

    %Otherwise, display the branches' information. 

    disp(DeviceType) 

    disp('From/To/Identifier') 

    for counter = 1:size(devicelist1,1) 

      %num2str converts the numbers within devicelist1 and 

      %devicelist2 to strings for output with disp().  the char() 

      %function is called on devicelist3's members because the 

      %SimAuto object returns a character array (as opposed to a 

      %properly Matlab-format string) and this array must be 

      %converted to a Matlab-format string. 

      disp([num2str(devicelist1(counter)) ' ' ... 

           num2str(devicelist2(counter)) ' ' ... 

           char(devicelist3(counter))])  

    end 

  end 

end 
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ListOfDevices Function: Sample Code for Microsoft® Visual Basic for Excel 
Sample Code  

Private Sub DisplayMessage(ByVal SentText As String) 

    TextBox.Text = TextBox.Text + SentText + vbCrLf + vbCrLf  

End Sub 

 

Private Sub btnListOfDevices_Click() 

Dim objtype, filter As String 

Dim xlWB As Excel.Workbook 

Set xlApp = Excel.Application 

 

' Checks connection and open case 

' SimAuto and caseopen are global variables 

If Not SimAuto Is Nothing And caseopen Then 

  objtype = "branch" 

  filter = "" 

  output = SimAuto.ListOfDevices(objtype, filter) 

  If output(0) <> "" Then 

    DisplayMessage output(0) 

  Else 

    DisplayMessage "Succesful List Of Devices" 

    ' Prepares additional worksheet 

    Set xlWB = xlApp.Workbooks.Add 

    ' Copies list of devices in worksheet 

    With xlWB 

      Sheets("sheet1").Activate 

      Sheets("sheet1").Name = "ListOfDevices" 

      With Sheets("ListOfDevices") 

        Dim i, j As Integer 

        Range(Cells(1, 5), Cells(200, 7)).Clear 

        Cells(1, 1) = "List of Devices for " + objtype + ":" 

        Cells(2, 1) = "From Bus Num" 

        Cells(2, 2) = "To Bus Num" 

        Cells(2, 3) = "ID" 

        ' Determine number of key fields retrieved 

        Dim lowkeyf, highkeyf As Integer 

        lowkeyf = LBound(output(1), 1) 

        highkeyf = UBound(output(1), 1) 

        DisplayMessage "Number of Key Fields: " + Str(lowkeyf) + Str(highkeyf) 

        ' Determine number of objects retrieved 

        Dim lowobj, highobj As Integer 

        lowobj = LBound(output(1)(lowkeyf), 1) 

        highobj = UBound(output(1)(lowkeyf), 1) 

        DisplayMessage "Number of objects: " + Str(lowobj) + Str(highobj) 

        For i = lowkeyf To highkeyf 

          For j = lowobj To highobj 

            Cells(j + 3, i + 1) = output(1)(i)(j) 

          Next j 

        Next i 
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      End With 

    End With 

  End If  

End If  

End Sub 
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LoadState Function 
Sample Code  

LoadState is used to load the system state previously saved with the SaveState function.  Note that LoadState will not 
properly function if the system topology has changed due to the addition or removal of the system elements. 

 

Function Prototype  

LoadState() 

 

Parameter Definitions  

No parameters are passed. 

 

Output 

LoadState returns only one element in Output—any errors which may have occurred when attempting to 
execute the function. 
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LoadState Function: Sample Code 
Microsoft® Visual Basic for Applications  

' Make the LoadState call 

Output = SimAuto.LoadState() 

 

Matlab® 

% Make the LoadState call 

Output = SimAuto.LoadState(); 
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OpenCase Function 
Sample Code  

The OpenCase function will load a PowerWorld Simulator load flow file into the Simulator Automation Server.  This is 
equivalent to opening a file using the File -> Open menu in Simulator. 

 

Function Prototype  

OpenCase(FileName) 

 

Parameter Definitions  

FileName : String The name of the PowerWorld Simulator case file to be loaded into the 
Simulator Automation Server.  This string includes the directory location and full 
file name.   

 

Output 

OpenCase returns only one element in Output—if the file cannot be found or an error occurs while reading the 
file. 



Printed Documentation 

588 

OpenCase Function: Sample Code 
Borland® Delphi 

Output := SimAuto.OpenCase('c:\simauto\examples\b7opf.pwb'); 

if (string(Output[0]) <> '') then  

  StatusBar1.Panels[1].Text := 'Error: ' + string(Output[0]); 

else 

begin 

  StatusBar1.Panels[1].Text := 'Open Case successful.'; 

  // Perform activities with opened case 

end; 

 
Microsoft® Visual Basic for Applications  

Output = SimAuto.OpenCase("c:\simauto\examples\b7opf.pw b") 

If output(0) <> "" Then 

  MsgBox(output(0)) 

Else 

  ' Perform activities with the opened case 

End If  

 

Matlab® 

Output = SimAuto.OpenCase('c:\simauto\examples\b7opf.pwb') 

%If the first cell in Output ~= '', then that means an error 

%occurred. 

if ~(strcmp(Output{1},'')) 

  disp(Output{1}) 

else 

  %Otherwise, no errors.  Perform activities. 

  disp('Open Case successful') 

end 
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ProcessAuxFile Function 
Sample Code  

The ProcessAuxFile function will load a PowerWorld Auxiliary file into the Simulator Automation Server.  This allows 
you to create a text file (conforming to the PowerWorld Auxiliary file format) that can list a set of data changes and 
other information for making batch changes in Simulator 

 

Function Prototype  

ProcessAuxFile(FileName) 

 

Parameter Definitions  

FileName : String The name of the PowerWorld Auxiliary file to be loaded into the Simulator 
Automation Server.  This string includes the directory location and full file 
name. 

 

Output 

ProcessAuxFile returns only one element in Output—any errors which may have occurred when attempting to 
load the file. 
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ProcessAuxFile Function: Sample Code 
Microsoft® Visual Basic for Applications  

Dim filename As String 

 

' Setup name of aux file to run 

filename = "c:\b7opf_ctglist.aux" 

 

' Make the processAuxFile call 

Output = SimAuto.ProcessAuxFile(filename) 

 

Matlab® 

% Setup name of aux file to run 

filename = 'c:\b7opf_ctglist.aux'; 

 

% Make the processAuxFile call 

Output = SimAuto.ProcessAuxFile(filename); 
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RunScriptCommand Function 
Sample Code  

The RunScriptCommand function is used to execute a list of script statements.  The script actions are those included 
in the script sections of the Auxiliary Files.  If an error occurs trying to run a script command, an error will be returned 
through EString. 

 

Function Prototype  

RunScriptCommand(Statements) 

 

Parameter Definitions  

Statements : String The block of script actions to be executed. Each script statement must end in a 
semicolon.  The block of script actions should not be enclosed in curly braces. 

 

Output 

RunScriptCommand returns only one element in Output—any errors which may have occurred when 
attempting to load or run the auxiliary file. 
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RunScriptCommand Function: Sample Code 
Microsoft® Visual Basic for Applications  

Dim scriptcommand As String 

 

' Set script command to cause Simulator to enter Run Mode 

scriptcommand = "EnterMode(RUN)" 

 

' Make the RunScriptCommand call 

Output = SimAuto.RunSCriptCommand(scriptcommand); 

 

' Set script command to cause Simulator to perform a single, 

' standard solution 

scriptcommand = "SolvePowerFlow(RECTNEWT)" 

 

' Make the RunScriptCommand call 

Output = SimAuto.RunSCriptCommand(scriptcommand); 

 

Matlab® 

% Set script command to cause Simulator to enter Run Mode 

scriptcommand = 'EnterMode(RUN)'; 

 

% Make the RunScriptCommand call 

Output = SimAuto.RunSCriptCommand(scriptcommand); 

 

% Set script command to cause Simulator to perform a single, 

% standard solution 

scriptcommand = 'SolvePowerFlow(RECTNEWT)'; 

 

% Make the RunScriptCommand call 

Output = SimAuto.RunSCriptCommand(scriptcommand); 
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SaveCase Function 
Sample Code  

The SaveCase function is used to save a case previously loaded in the Simulator Automation Server using the 
OpenCase function.  The function allows you to specify a file name and a format for the save file. 

 

Function Prototype  

SaveCase(FileName, EString, FileType, Overwrite) 

 

Parameter Definitions  

FileName : String The name of the file you wish to save as, including f ile path. 

FileType : String A string indicating the format of the written case file.  An empty string will return 
an error.  The following list is the currently supported list of string identifiers and 
the file types they represent. 
 
"PTI23"  PTI version 23 (raw) 
"PTI24"  PTI version 24 (raw) 
"PTI25"  PTI version 25 (raw) 
"PTI26"  PTI version 26 (raw) 
"PTI27"  PTI version 27/28 (raw) 
"PTI29"  PTI version 29 (raw) 
"GE"   GE PSLF (epc) 
"IEEE"   IEEE common format (cf) 
"PWB70"  PowerWorld Binary version 7.0 (pwb) 
"PWB"  PowerWorld Binary (most recent) (pwb) 

Overwrite : Boolean A Boolean value which indicates whether to overwrite a file if FileName already 
exists.  If Overwrite is set to false and the file specified by FileName already 
exists, SaveCase will return an error message and do nothing to the file. 

 

Output 

SaveCase returns only one element in Output—any errors which may have occurred when attempting to save 
the case. 
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SaveCase Function: Sample Code 
Microsoft® Visual Basic for Applications  

' Save the case as a PWB file 

Output = SimAuto.SaveCase("c:\b7opfcopy.pwb", "PWB", true) 

 

' Save the case as a PTI file 

Output = SimAuto.SaveCase("c:\b7opfcopy.raw", "PTI", true) 

 
Matlab® 

% Setup name of PWB file to write 

filenamepwb = 'c:\b7opfcopy.pwb'; 

  

% Setup name of PTI file to write 

filenamepti = 'c:\b7opfcopy.raw'; 

 

% Make the SaveCase call for the PWB file 

Output = SimAuto.SaveCase(filenamepwb, ‘PWB’, true); 

 

% Make the SaveCase call for the PTI file 

Output = SimAuto.SaveCase(filenamepti, ‘PWB’, true); 
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SaveState Function 
Sample Code  

SaveState is used to save the current state of the power system.  This can be useful if you are interested in comparing 
various cases, much as the Difference Flows feature works in the Simulator application. 

 

Function Prototype  

SaveState() 

 

Parameter Definitions  

No parameters are passed. 

 

Output 

SaveState returns only one element in Output—any errors which may have occurred when attempting to 
execute the function. 
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SaveState Function: Sample Code 
Microsoft® Visual Basic for Applications  

' Make the SaveState call 

Output = SimAuto.SaveState() 

 

Matlab® 

% Make the SaveState call 

Output = SimAuto.SaveState(); 
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SendToExcel Function 
Sample Code  

The SendToExcel function can be called to send data from the Simulator Automation Server to an Excel spreadsheet.  
The function is flexible in that you can specify the type of object data you want to export, an advanced filter name for a 
filter you want to use, and as many or as few field types as desired that are supported by the type of object.  The first 
time this function is called, a new instance of Excel will be started, and the data requested will be pasted to a new 
sheet.  For each subsequent call of this function, the requested data will be pasted to a new sheet within the same 
workbook, until the workbook is closed. 

 

Function Prototype  

SendToExcel(ObjectType, FilterName, FieldList) 

 

Parameter Definitions  

ObjectType : String A string describing the type of object for which your are requesting data. 

FilterName : String The name of an advanced filter which was previously defined in the case 
before being loaded in the Simulator Automation Server.  If no filter is desired, 
then simply pass an empty string.  If a filter name is passed but the filter cannot 
be found in the loaded case, no filter is used. 

FieldList : Variant This parameter must either be an array of fields for the given object or the 
string "all". As an array, FieldList contains an array of strings, where each string 
represents an object field variable, as defined in the section on PowerWorld 
Object Variables.  If, instead of an array of strings, the single string "all" is 
passed, the Simulator Automation Server will use predefined default fields 
when exporting the data. 

 

Output 

SendToExcel returns only one element in Output—any errors which may have occurred when attempting to 
execute the function. 
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SendToExcel Function: Sample Code 
Microsoft® Visual Basic for Applications  

Dim FieldList As Variant 

 

' Setup fieldlist to send the bus number, gen id and gen agc to Excel 

FieldList = Array("pwBusNum", "pwGenID", "pwGenAGCAble") 

 

' Make the SendToExcel call 

' By specifying the parameter FieldList, only the three fields  

' for each generator will be returned 

Output = SimAuto.SendToExcel("gen", "", "FieldList") 

 

' Sending the string "all" instead of a fieldlist array  

' writes all predefined fields to the Excel spreadsheet 

Output = SimAuto.SendToExcel("gen", "", "all") 

 

Note:  This function call will send the values of the fields in FieldList to an Excel workbook for all the generators in 
the load flow case.  If a filter name had been passed instead of an empty string, Simulator would have located and 
used a pre-defined advanced filter and applied it to the information if it was found.  

 

Matlab® 

% Setup fieldlist to send the bus number, gen id and gen agc to Excel 

fieldlist = {'pwBusNum' 'pwGenID' 'pwGenAGCAble' }; 

 

% Make the SendToEx cel call 

Output = SimAuto.SendToExcel('gen', '' , FieldList); 

 

% Sending the string 'all' instead of a fieldlist array  

% writes all predefined fields to the Excel spreadsheet 

Output = SimAuto.SendToExcel('gen', '', 'all'); 

 

Note:  This function call will send the values of the fields in FieldList to an Excel workbook for all the generators in 
the load flow case.  If a filter name had been passed instead of an empty string, Simulator would have located and 
used a pre-defined advanced filter and applied it to the information if it was found.  



PowerWorld Simulator Add-on Tools 

599 

WriteAuxFile Function 
Sample Code  

The WriteAuxFile function can be used to write data from the case in the Simulator Automation Server to a 
PowerWorld Auxiliary file.  The function is flexible in that you can specify the type of object data you want to export, 
an advanced filter name for a filter you want to use, and as many or as few field types as desired that are supported by 
the type of object.  In addition, you can specify a new file name for each call to WriteAuxFile, or you can specify the 
same file name and append the data to the file. 

 

Function Prototype  

WriteAuxFile(FileName, FilterName, ObjectType, EString, ToAppend,  FieldList) 

 

Parameter Definitions  

FileName : String The name of the PowerWorld Auxiliary file you wish to save. 

FilterName : String The name of an advanced filter which was previously defined in the case 
before being loaded in the Simulator Automation Server.  If no filter is desired, 
then simply pass an empty string.  If a filter name is passed but the filter cannot 
be found in the loaded case, no filter is used. 

ObjectType : String A string describing the type of object for which your are requesting data. 

ToAppend : Boolean If you have given a file name of an auxiliary file that already exists, then the file 
will either be appended to or overwritten according to the setting of this 
parameter.  If ToAppend is False and the file already exists, WriteAuxFile will 
return an error message and do nothing to the file. 

FieldList : Variant This parameter must either be an array of fields for the given object or the 
string "all". As an array, FieldList contains an array of strings, where each string 
represents an object field variable, as defined in the section on PowerWorld 
Object Variables.  If, instead of an array of strings, the single string "all" is 
passed, the Simulator Automation Server will use predefined default fields 
when exporting the data. 

 

Output 

WriteAuxFile returns only one element in Output—any errors which may have occurred when attempting to 
execute the function. 
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WriteAuxFile Function: Sample Code 
Microsoft® Visual Basic for Applications  

Dim FieldList As Variant 

Dim auxfilename As String 

 

' Setup FieldList to send the bus number, gen id and gen agc  

FieldList = Array("pwBusNum", "pwGenID", "pwGenAGCAble") 

 

' Aux file to write to 

auxfilename = "c:\businfo.aux" 

 

' Make the WriteAuxFile call 

' By specifying the parameter FieldList, only the three fields  

' for each generator will be returned 

Output = SimAuto.WriteAuxFile(auxfilename, "", "gen", true, FieldList) 

 

' Sending the string "all" instead of the FieldList array  

' writes all predefined fields to the Excel spreadsheet 

Output = SimAuto.SendToExcel(auxfilename, "", "gen", true, "all") 

 

Note:  This function call will send the values of the fields in FieldList to an auxiliary file for all the generators in the 
load flow case.  If a filter name had been passed instead of an empty string, Simulator would have located and used a 
pre-defined advanced filter and applied it to the information if it was found.  

 
Matlab® 

% Setup FieldList to send the bus number, gen id and gen agc  

fieldlist = {'pwBusNum' 'pwGenID' 'pwGenAGCAble' }; 

 

% Aux file to write to 

auxfilename = 'c:\businfo.aux'; 

 

% Make the WriteAuxFile call 

Output = SimAuto.WriteAuxFile(auxfilename, '', 'gen', true, FieldList); 

 

% Sending the string 'all' instead of the FieldList array  

% writes all predefined fields to the .aux file 

Output = SimAuto.WriteAuxFile(auxfilename, '', 'gen', true, 'all'); 

 

Note:  This function call will send the values of the fields in FieldList to an auxiliary file for all the generators in the 
load flow case.  If a filter name had been passed instead of an empty string, Simulator would have located and used a 
pre-defined advanced filter and applied it to the information if it was found.  

Simulator Automation Server Properties 

Simulator Automation Server Properties 
The following list of parameters is currently available once the SimulatorAuto object is set in your code.  Check the 
help sections on these properties to see more detail on the particular property. 

ExcelApp  

CurrentDir  

ProcessID  
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ExcelApp Property 
Sample Code  

The Simulator Automation Server has the ability to send data from Simulator to an Excel spreadsheet using the 
SendToExcel.  By default, the Simulator Automation Server starts an instance of Excel the first time one of the above 
functions is called.  Each subs equent call to these two functions will then send data to the same instance of Excel, 
until it is manually closed by the user.  The ExcelApp property allows the user to gain access to the instance of Excel 
used by the Simulator Automation Server from within its own code.  Thus the user can write code to manipulate the 
external instance of Excel.  In addition, the ExcelApp property can be set by the user’s code, meaning that the user 
can initialize an external instance of Excel from within their own code and set the ExcelApp property to their external 
instance of Excel.  Simulator itself is limited to starting only one instance of Excel on its own, but with the ExcelApp 
property allowing you to set the instance of Excel that Simulator uses on the fly, you can generate multiple instances 
of Excel within your code, and handle setting the ExcelApp property of the Simulator Automation server to the desired 
Excel instance depending on the data you want to send to Excel. 

The ExcelApp property is a variable of type Variant that returns the pointer to an object representing the external 
instance of Excel. 

ExcelApp : Variant 

To gain access to the external instance of Excel stored in the ExcelApp property, you first need to initialize a variable 
as an object.  The follow ing are a couple of examples in Borland Delphi and Microsoft Visual Basic. 

 

Examples 

Borland Delphi 5 

• Var MyExc : TObject 

• MyExc = SimAuto.ExcelApp {Makes the connection to the external instance} 

• {Perform activities with the Excel instance} 

• MyExc.Quit {Closes the external instance if called; do not call if you wish the instance to remain open} 

• MyExc.Free {Removes the connection to the external instance} 

Microsoft Visual Basic 

• Dim MyExc As Variant 

• Set MyExc = SimAuto.ExcelApp {Makes the connection to the external instance} 

• {Perform activities with the Excel instance} 

• MyExc.Quit {Closes the external instance if called; do not call if you wish the instance to remain open} 

• Set MyExc = Nothing {Removes the connection to the external instance} 
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ExcelApp Property: Sample Code 
Microsoft® Visual Basic for Applications  

Dim ExcelObject As Variant 

If Not (IsEmpty(SimAuto.ExcelApp)) Then 

  Set ExcelObject = SimAuto.ExcelApp 

  ExcelObject.DisplayAlerts = False 

  ExcelObject.Quit 

Else 

  MsgBox("Attempted to obtain Excel COM object from " + _ 

        "Simulator, but there is not one open.") 

End If  

 

Matlab® 

MATLAB is currently unable to handle COM object properties returning COM objects themselves, such as the 
ExcelApp property of Simulator. 
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CurrentDir Property 
Sample Code  

The CurrentDir property of the Simulator Automation Server allows you to retrieve or set the working directory for the 
currently running SimulatorAuto process.  This is most useful if using relative filenames (e.g. "relativename.aux" 
versus "C:\Program Files\PowerWorld\Working\abosultename.aux") when specifying files. 
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CurrentDir Property: Sample Code 
Microsoft® Visual Basic for Applications  

' Display the current directory 

MsgBox(SimAuto.CurrentDir) 

 

' Set the current directory to c:\ 

SimAuto.CurrentDir = "c:\" 

 
Matlab® 

% Display the current directory 

disp(SimAuto.CurrentDir) 

 

% Set the current directory to c:\ 

SimAuto.CurrentDir = 'c:\'; 
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ProcessID Property 
Sample Code  

The ProcessID property of the Simulator Automation Server allows you to retrieve the process ID of the currently 
running SimulatorAuto process, as can also be seen through the Task Manager in Windows® NT 4, 2000 and XP.  
This information can be useful if a forced shutdown of the SimulatorAuto  object is needed, as all calls to the 
SimulatorAuto object are synchronous.  This means the SimulatorAuto object will not be destroyed until all calls, no 
matter the time of execution, have completed. 
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ProcessID Property: Sample Code 
Microsoft® Visual Basic for Applications  

' Display the process ID 

MsgBox(SimAuto.ProcessID) 

 

Matlab® 

% Display the process ID 

disp(num2str(SimAuto.ProcessID)) 

PowerWorld Object Variables 

PowerWorld Object Variables 
The ability to access power system data for different objects through various Simulator Automation Server Functions is 
based on variables defined in Simulator that can be referred to as Object Field Variables.  Each object (i.e. bus, 
generator, etc.) can have numerous fields associated with it.  Each of these fields, in turn, has a variable associated 
with the field to enable access to the field for the purpose of acquiring or changing data.  For example, the 
GetParametersSingleElement function has a parameter called ParamList, which is intended to store a list of Object 
Field Variables for a particular type of object.  When the function is called, the Simulator Automation Server will return 
the values associated with each particular field variable for the type of object specified.  These field variables allow for 
complete flexibility by the user in specifying as many or as few fields for a particular object when acquiring or changing 
data. 

Examples of Field Variables 

PWBusGenMW 

PWBusNum  

 

Simulator has literally hundreds of parameters spanning numerous types of device and option specifications.  Rather 
than list all of the field variables and the value they represent in this help file, we have enabled Simulator to 
automatically generate a text file containing the field variables and a description of what value the variable represents.  
PowerWorld Corporation highly recommends that you examine this list.  To generate this text file, run PowerWorld 
Simulator and access the Help menu.  Choose the option Export Object Fields…  Specify a file name and location 
for saving the file, and click Save.  Simulator will save out the field variables, the type of variable (string, integer, etc.), 
and a description of the value the field variable represents, with key fields for different objects marked with an asterisk.  
The field variables will also be split into sections based on the type of object they are valid for.  Note that the same 
field variable may be available for more than one object, but that the value represented by the field variable might vary 
for different objects. 

Examples of Field Variables in Listing 

PwBusGenMW Real 'Bus Gen MW' 

* PwBusNum Integer 'Bus Number' (* denotes key field in text file) 

ATC_MaxLimElements Integer 'Max # Limiting Elements' 

 

The last note on the Object Field Variables is that some of the object field variables are reused for more than one 
value for an object.  For example, a transmission line has "from" and "to" buses associated with the line.  Rather than 
have separate field variables for values at each terminal bus, the same field variable is used for both, with a colon 
followed by a number appended to the variable to signify which bus the value represents.  As an example, consider 
the field variable for bus per unit voltage, which is PWBusPUVolt.  Since there are two buses per line, the "From" bus 
voltage would be represented as PWBusPUVolt:0, and the "To" bus voltage would be represented as 
PWBusPUVolt:1.  The enumeration of the field variables always starts with 0 for the first instance.  You may note that 
in the text file of field values that you don't see any field variables with :0 appended to them.  Since we did not want 
you to have to alway s append the :0 on all field variables, the default for a field variable with no appended :# is 0.  
Thus you would only need to be concerned with appending the :# for field variables that require a number greater than 
0. 

Simulator Automation Server (SIMAUTO) (version 9) 

Simulator Automation Server (version 9) 

NOTE:  The function calls for version 9 of SimAuto have become obsolete in version 10.  The reason for the 
change was due to problems that arose with the structure of the functions in certain programming languages.  
The function structures have been modified for version 10 of Simulator.  If you have code written that uses 
version 9 SimAuto function structures, it is fairly straightforward to convert the function calls  from version 9 
to version 10.  Please see the updated section on the Simulator Automation Server for version 10.  If you still 
have questions, please contact PowerWorld Corporation. 
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The PowerWorld Automation Server is only available to customers who have purchased the SimAuto add-on for 
PowerWorld Simulator.  The PowerWorld Simulator Automation Server is intended for enabling a PowerWorld 
customer with the ability to access PowerWorld Simulator functionality from within a program written externally by the 
user.  The Simulator Automation Server acts as a COM object, which can be accessed from various different 
programming languages that have COM compatibility.  Examples of programming tools with COM compatibility are 
Borland Delphi, Microsoft Visual C++, and Microsoft Visual Basic, just to name a few.  For more information on 
COM and Automation servers, see the help for Microsoft Windows. 

The Automation Server of  Simulator works very well in combination with Simulator Script Commands and Auxiliary 
Files.  It is beneficial to become familiar with these topics when considering using the Simulator Automation Server. 

Starting Simulator Automation Server 

Installing Simulator Automation Server (version 9) 
Installing the Simulator Automation Server requires no additional steps beyond installing PowerWorld Simulator as 
normal.  When a version of PowerWorld Simulator containing the Simulator Automation Server is installed on your 
computer, the install program automatically adds the information needed by the Simulator Automation Server to the 
registry. 
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Including Simulator Automation Server Functions (version 9) 
Before you can access the functions defined by the Simulator Automation Server when writing the code for your 
external program, you must first include the library of functions defined for the Simulator Automation Server.  This kind 
of library is referred to as a Type Library, which describes the available functions in a manner that can be interpreted 
by different programming languages.  Importing a Type Library from another program is usually fairly simple, but the 
procedure does vary depending on the programming tool you are using.  Please see the help for your programming 
tool of choice on how to import a Type Library or COM functions from another program. 

 

Examples 

The following examples are just a few specific examples for certain programming media.  The procedure may be 
different for other programming media not listed.  In addition, a procedure given for a certain type of programming 
media may be one variation from several possible procedures for accomplishing the same task. 

Borland Delphi 5 

• Install the version of PowerWorld Simulator with the Simulator Automation Server included. 

• In Delphi 5, choose Import Type Library… from the Project menu. 

• In the list of libraries, search for and choose pwrworld Library. 

• If pwrworld Library is not in the list, click Add.  Find and choose the Pwrworld.exe file from the PowerWorld 
Simulator directory, and click Open. 

• You should see the class name TSimulatorAuto in the list of Class names. 

• Click Install to include the PowerWorld Simulator Type Library. 

Microsoft Visual Basic 

• Install the version of PowerWorld Simulator with the Simulator Automation Server included. 

• In VB, choose References… from the Tools  menu.  Find and choose pwrworld Library from the list of 
references. 

• If pwrworld Library is not in the list, click Browse.  Change the file type to *.exe, find and choose the 
Pwrworld.exe file from the PowerWorld Simulator directory, and click Open. 

• Click OK to install the Simulator Type Library reference. 

Microsoft Visual C++ 

• Install the version of PowerWorld Simulator with the Simulation Automation Server included. 

• Add #import "…\powerworld.exe" in your external program code, using the full path to the PowerWorld 
Simulator executable program. 

• Add using namespace pwrworld in your external program code. 
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Connecting to Simulator Automation Server (version 9) 
Once the Type Library or COM functions have been included in your programming environment, the Simulator 
Automation Server can be handled as any other object in your code.  The method for assigning and connecting to the 
Simulator Automation Server can vary depending on the programming environment used, but the idea is basically the 
same.  You define a variable in your program to point to the server object, which is called SimulatorAuto.  If the Type 
Library was imported properly, you should have full access to the SimulatorAuto object and its defined functions.  
Again, the procedure for creating the object and connecting to SimulatorAuto may vary for different programming 
languages.  Check the help for your programming environment on connecting to COM or Automation servers. 

 

Examples 

The following examples are just a few specific examples for certain programming media.  The procedure may be 
different for other programming media not listed.  In addition, a procedure given for a certain type of programming 
media may be one variation from several possible procedures for accomplishing the same task. 

Borland Delphi 5 

• Add pwrworld_TLB to the uses section of your unit. 

• Declare a variable globally or as part of another object: A : ISimulatorAuto. 

• Initialize the variable: A := nil. 

• To connect to the Simulator Automation Server, create the connection: A := CoSimulatorAuto.create . 

• Perform function calls to the Simulator Automation Server: A.SomeFunction(parameters). 

• To close the connection to the Simulator Automation Server, remove the reference by again setting: A := 
nil. 

Microsoft Visual Basic 

• Declare a variable globally or as part of another object or function: Public A As SimulatorAuto. 

• To connect to the Simulator Automation Server, create the connection: Set A = New SimulatorAuto. 

• Perform function calls to the Simulator Automation Server: A.SomeFunction parameters. 

• To close the connection to the Simulator Automation Server, remove the reference: Set A = Nothing. 

Microsoft Visual C++ 

• Declare a variable globally or as part of another object or function: IsimulatorAutoPtr *A. 

• Declare a variable globally or as part of another object or function: CLSID clsid. 

• Declare a variable globally or as part of another object or function: HRESULT hr. 

• Obtain the class identifier (clsid) with the following command: hr = 
CLSIDFromProgID(L"pwrworld.SimulatorAuto", &clsid). 

• Initialize variable A: A = new IsimulatorAutoPtr. 

• To connect to the Simulator Automation Server, create the connection: hr = A>CreateInstance(clsid, 
NULL, CLSCTX_SERVER). 

• Perform function calls to the Simulator Automation Server: A.SomeFunction(parameters). 

• To close the connection to the Simulator Automation Server, release the reference: hr = A>Release(). 

Simulator Automation Server Properties 

Simulator Automation Server Properties (version 9) 
The following list of parameters is currently available once the SimulatorAuto object is set in your code.  Check the 
help sections on these properties to see more detail on the particular property. 

ExcelApp  
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ExcelApp Property (version 9) 
The Simulator Automation Server has the ability to send data from Simulator to an Excel spreadsheet using the 
SendToExcel.  By default, the Simulator Automation Server starts an instance of Excel the first time one of the above 
functions is called.  Each subsequent call to these two functions will then send data to the same instance of Excel, 
until it is manually closed by the user.  The ExcelApp property allows the user to gain access to the instance of Excel 
used by the Simulator Automation Server from within their own code.  Thus the user can write code to manipulate the 
external instance of Excel.  In addition, the ExcelApp property can be set by the user’s code, meaning that the user 
can initialize an external instance of Excel from within their own code and set the ExcelApp property to their external 
instance of Excel.  Simulator itself is limited to starting only one instance of Excel on its own, but with the ExcelApp 
property allowing you to set the instance of Excel that Simulator uses on the fly, you can generate multiple instances 
of Excel within your code, and handle setting the ExcelApp property of the Simulator Automation server to the desired 
Excel instance depending on the data you want to send to Excel. 

The ExcelApp property is a variable of type Variant  that returns the pointer to an object representing the external 
instance of Excel. 

ExcelApp : Variant 

To gain access to the external instance of Excel stored in the ExcelApp property, you first need to initialize a variable 
as an object.   

 

The following are a couple of examples in Borland Delphi and Microsoft Visual Basic. 

Examples 

Borland Delphi 5 

• Var MyExc : TObject 

• MyExc = SimAuto.ExcelApp {Makes the connection to the external instance} 

• {Perform activities with the Excel instance} 

• MyExc.Quit {Closes the external instance if called; do not call if you wish the instance to remain open} 

• MyExc.Free {Removes the connection to the external instance} 

Microsoft Visual Basic 

• Dim MyExc As Object 

• Set MyExc = SimAuto.ExcelApp {Makes the connection to the external instance} 

• {Perform activities with the Excel instance} 

• MyExc.Quit {Closes the external instance if called; do not call if you wish the instance to remain open} 

• Set MyExc = Nothing {Removes the connection to the external instance} 

Simulator Automation Server Functions  

Simulator Automation Server Functions (version 9) 
The following list of functions is currently available once the SimulatorAuto object is set in your code.  Check the help 
sections on these functions to see more detail on the particular function. 

ChangeParameters  

CloseCase  

GetParameters  

ListOfDevices  

LoadContingencies  

OpenCase  

ProcessAuxFile  

RunScriptCommand  

SaveCase  

SendToExcel  

WriteAuxFile  
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ChangeParameters Function (version 9) 
The ChangeParameters function allows you to set a list of parameters for a specific object in a case loaded into the 
Simulator Automation Server.  In addition to changing parameters for objects, this function can also be used to set 
options for some of the Simulator tools, such as ATC and OPF.  This function is identical in setup to the 
GetParameters function, with the exception that the Values array must contain a value for each field variable given in 
the ParamList array. 

ChangeParameters(tObjectType, ParamList, Values, EString) 

 

Parameter Definitions  

TobjectType : String The type of object you are changing parameters for.  No default. 

ParamList : Variant A variant array storing strings.  This array stores a list of PowerWorld object 
field variables, as defined in the section on PowerWorld Object Fields.  The 
ParamList must contain the key field variables for the specific device, or the 
device cannot be identified.  No Default. 

Values : Variant A variant array storing variants.  This array can store any type of information 
(integer, string, etc.) in each array position.  A value should be passed for each 
field variable given in the ParamList.  The Values array must contain the key 
field values for the specific device, or the device cannot be identified.  No 
Default. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 

Example  

ChangeParameters("gen", [pwBusNum, pwGenID, pwGenAGCAble], [1, "1", "Yes"], EString) 

This function call will change the AGC Status of bus number one, generator ID number 1, to "Yes", meaning 
the generator will be included in AGC if it's area is on AGC control. 
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CloseCase Function (version 9) 
The CloseCase function is used to close a load flow case loaded in the Simulator Automation Server.  This function 
should be called at some point after the OpenCase function.  An error will be returned through the EString parameter if 
an error occurred while trying to close the case. 

CloseCase(EString) 

 

Parameter Definitions  

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 
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GetParameters Function (version 9) 
The GetParameters function is used to request the values of specified fields for a particular object in the load flow 
case.  For returning field values for multiple objects, you can use a loop to make repeated calls to the GetParameters 
function, and pass the object and desired field information for each object.  This function is identical in setup to the 
ChangeParameters function, with the exception that the Values array will be updated with the values for the field 
variables defined in ParamList. 

GetParameters(tObjectType, ParamList, Values, EString) 

 

Parameter Definitions  

TobjectType : String The type of object you are changing parameters for.  No default. 

ParamList : Variant A variant array storing strings.  This array stores a list of PowerWorld object 
field variables, as defined in the section on PowerWorld Object Fields.  The 
ParamList must contain the key field variables for the specific device, or the 
device cannot be identified.  The remaining field variables in the array  define 
which values to retrieve from Simulator.  No Default. 

Values : Variant A variant array storing variants.  This array can store any type of information 
(integer, string, etc.) in each array position.  Values must be passed for the key 
field variables in ParamList, in the same array position.  The remaining field 
positions in the Values array can initially be filled with either empty strings or 
zeroes, as the values will be replaced when the function is processed.  No 
Default. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 

Example  

GetParameters("gen", [pwBusNum, pwGenID, pwGenAGCAble], ValArray = [1, "1", ""], EString) 

This function call will return the AGC Status of bus number one, generator ID number 1, in the ValArray 
variable.  Note that the generator bus number and ID had to be passed into the function, while the remaining 
field could be assigned an empty string.  If the bus number and ID had not been passed, an error would have 
been returned since Simulator would not be able to identify a generator.  With a valid bus number and ID for 
the generator, the ValArray variable would have returned an array of the following format: ValArray = [1, "1", 
"Yes"]. 
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ListOfDevices Function (version 9) 
The ListOfDevices function is used to request a list of objects and their key fields from the Simulator Automation 
Server.  The function can return all devices of a particular type, or can return only a list of devices of a particular type 
based on an advanced filter defined for the loaded case.  This function is best used in conjunction with a looping 
procedure and the ChangeParameters or GetParameters functions to process a group of devices. 

ListOfDevices(tObjType, EString, filterName, objList1, {objList2}, {objList3}) 

 

Parameter Definitions  

TobjType : String The type of object for which you are acquiring the list of devices.  No default. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 

FilterName : String The name of an advanced filter defined in the load flow case open in the 
Simulator Automation Server.  If the filter cannot be found, the server will 
default to returning all objects in the case of type TobjType. 

ObjList1 : Variant This parameter must be assigned a variable declared as a Variant.  The 
Simulator Simulation Server will return a variant array filled with the first key 
field for the devices of type TobjType.  This parameter is required for all types 
of devices. 

ObjList2 : Variant This parameter may be optional.  For device types that only have one key field, 
you can omit passing a variable for this parameter.  If the device type 
requested has two or more key fields, then this parameter must be assigned a 
variable declared as a Variant.  The Simulator Simulation Server will return a 
variant array filled with the second key field for the devices of type TobjType. 

ObjList3 : Variant This parameter may be optional.  For device types that have one or two key 
fields, you can omit passing a variable for this parameter.  If the device type 
requested has three key fields, then this parameter must be assigned a 
variable declared as a Variant.  The Simulator Simulation Server will return a 
variant array filled with the third key field for the devices of type TobjType. 

Example  

ListOfDevices("gen", EString, "", objList1, objList2) 

This function call will return a list of all generators in the load flow case.  By passing an empty string as the 
filter name, Simulator will not use an advanced filter before returning the generator key fields.  Since 
generators have two key fields, bus number and ID, it was required to pass two variant array variables to 
receive the key fields.  Each generator in the case would have its bus number returned in objList1 and ID in 
objList2.  The corresponding bus number and ID are stored in the same index position in the two arrays.  If 
only one variant array, objList1, had been passed in this instance, an error would have been returned stating 
more arrays were necessary.  If the third variant array, objList3, had been included, Simulator would have still 
returned the key fields in objList1 and objList2, and would have returned objList3 as an empty variant. 
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LoadContingencies Function (version 9) 
The LoadContingencies function can be used to read a set of predefined contingencies from a PowerWorld Auxiliary 
Contingency file.  Thus once you have defined a set of contingencies in Simulator and saved the list to a PowerWorld
 Auxiliary file, you can specify the filename with this function and the Simulator Automation Server will load the 
contingencies into memory. 

LoadContingencies(fileName, EString, {tAppend}) 

 

Parameter Definitions  

Filename : String The name of the PowerWorld Auxiliary file containing the defined 
contingencies.  If the file cannot be found, and error will be returned through 
EString. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 

TAppend : Boolean This parameter is optional.  If you have more than one list of contingencies in 
separate files, you can append the lists together in the Simulator Automation 
Client by passing the Boolean value True in this parameter.  The default if not 
passed is False, meaning any existing contingencies in the Simulator 
Automation Client would be cleared prior to loading the new list. 

Example  

LoadContingencies("c:\my files\ctgfile.aux", EString, True) 

This function call will load a previously created list of contingencies that was saved in the PowerWorld 
Auxiliary file format.  The file name string identifies the location and name of the auxiliary file.  By passing the 
value True in the optional parameter tAppend, Simulator will read the list of contingencies and add them to 
any existing contingencies already loaded in Simulator.  Contingencies in the list existing list with the same 
name as contingencies in the appending list will be replaced by the records in the appending list. 
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OpenCase Function (version 9) 
The OpenCase function will load a PowerWorld Simulator load flow file into the Simulator Automation Server.  If an 
error occurs trying to open the case, an error message will be returned through EString. 

OpenCase(filename, EString) 

 

Parameter Definitions  

FileName : String The name of the PowerWorld Simulator case file to be loaded into the 
Simulator Automation Server.  This string includes the directory location and full 
file name.  If the file cannot be found or an error occurs while reading the file, 
an error message will be returned through EString. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 
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ProcessAuxFile Function (version 9) 
The ProcessAuxFile function will load a PowerWorld Auxiliary file into the Simulator Automation Server.  This allows 
you to create a text file (conforming to the PowerWorld Auxiliary file format) that can list a set of data changes and 
other information for making batch changes in Simulator.  If an error occurs while processing the auxiliary file, an error 
message is returned through EString. 

ProcessAuxFile(filename, EString) 

 

Parameter Definitions  

FileName : String The name of the PowerWorld Auxiliary file to be loaded into the Simulator 
Automation Server.  This string includes the directory location and full file 
name. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 
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RunScriptCommand Function (version 9) 
The RunScriptCommand function is used to execute a list of script statements.  The script actions are those included 
in the script sections of the Auxiliary Files.  If an error occurs trying to run a script command, an error will be returned 
through EString. 

RunScriptCommand(Statements, EString) 

 

Parameter Definitions  

Statements : String The block of script actions to be executed. Each script statement must end in a 
semicolon.  The block of script actions should not be enclosed in curly braces. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 

Example  

RunScriptCommand("Entermode(PowerFlow); SolvePowerFlow;", EString) 

This function call will switch to the PowerFlow submode and then will solve the power flow of the present 
case. 
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SaveCase Function (version 9) 
The SaveCase function is used to save a case previously loaded in the Simulator Automation Server using the 
OpenCase function.  The function allows you to specify a file name and a format for the save file.  If an error occurs 
while trying to save a case, an error message is returned through EString. 

SaveCase(fileName, EString, {fileType}, {Overwrite}) 

 

Parameter Definitions  

fileName : String The name of the file you wish to save as, including file path.  No default. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 

fileType : String This parameter is optional.  If you desire to save the case in a format other than 
the current PowerWorld Binary (pwb) format, you must specify the type of 
format in this parameter as a string.  If the parameter is not passed, the format 
type defaults to the most recent version of PowerWorld binary (pwb) file.  If a 
string is passed for this parameter, it must at least be the "PWB" string.  An 
empty string will return an error.  The following list is the currently supported list 
of string identifiers and the file types they represent. 
 
"PTI23"  PTI version 23 (raw) 
"PTI24"  PTI version 24 (raw) 
"PTI25"  PTI version 25 (raw) 
"PTI26"  PTI version 26 (raw) 
"PTI27"  PTI version 27 (raw) 
"GE"   GE PSLF (epc) 
"IEEE"   IEEE common format (cf) 
"PWB70"  PowerWorld Binary version 7.0 (pwb) 
"PWB"  PowerWorld Binary (most recent) (pwb) 

Overwrite : Boolean This parameter is optional.  If you do not want to overwrite a file with the same 
name as passed in filename, you must specify this parameter as False.  Default 
is True. 
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SendToExcel Function (version 9) 
The SendToExcel function can be called to send data from the Simulator Automation Server to an Excel spreadsheet.  
The function is flexible in that you can specify the type of object data you want to export, an advanced filter name for a 
filter you want to use, and as many or as few field types as desired that are supported by the type of object.  The first 
time this function is called, a new instance of Excel will be started, and the data requested will be pasted to a new 
sheet.  For each subsequent call of this function, the requested data will be pasted to a new sheet within the same 
workbook, until the workbook is closed.  If an error oc curs while trying to send data to Excel, an error message is 
returned through EString. 

SendToExcel(tObjectType, filterName, EString, {tFieldList})  

 

Parameter Definitions  

tObjectType : String A string describing the type of object for which your are requesting data.  No 
Default. 

filterName : String The name of an advanced filter which was previously defined in the case 
before being loaded in the Simulator Automation Server.  If no filter is desired, 
then simply pass an empty string.  If a filter name is passed but the filter cannot 
be found in the loaded case, no filter is used.  Default is an empty string. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 

TFieldList : Variant This parameter is optional.  A variant array of strings, where each string 
represents an object field variable, as defined in the section on PowerWorld 
Object Variables.  If no array is passed, the Simulator Automation Server will 
use predefined default fields when exporting the data. 

Example  

SendToExcel("gen", "", EString, [pwBusNum, pwGenID, pwGenAGCAble]) 

This function call will send the values of the fields in tFieldList to an Excel workbook for all the generators in 
the load flow case.  If a filter name had been passed instead of an empty string, Simulator would have located 
and used a pre-defined advanced filter and applied it to the information if it was found.  By specifying the 
fields in the optional parameter tFieldList, only the three field values for each generator will be returned.  If the 
optional parameter tFieldList had been omitted, Simulator would have returned internally defined default 
information for the generators. 
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WriteAuxFile Function (version 9) 
The WriteAuxFile function can be used to write data from the case in the Simulator Automation Server to a 
PowerWorld Auxiliary file.  The function is flexible in that you can specify the type of object data you want to export, 
an advanc ed filter name for a filter you want to use, and as many or as few field types as desired that are supported by 
the type of object.  In addition, you can specify a new file name for each call to WriteAuxFile, or you can specify the 
same file name and append the data to the file.  If an error occurs while trying to write the auxiliary file, an error 
message is returned through EString. 

WriteAuxFile(fileName, filterName, tObjectType, EString, {tAppend},  {tFieldList}) 

 

Parameter Definitions  

FileName : String The name of the PowerWorld Auxiliary file you wish to save.  No default. 

filterName : String The name of an advanced filter which was previously defined in the case 
before being loaded in the Simulator Automation Server.  If no filter is desired, 
then simply pass an empty string.  If a filter name is passed but the filter cannot 
be found in the loaded case, no filter is used.  Default is an empty string. 

tObjectType : String A string describing the type of object for which your are requesting data.  No 
Default. 

EString : Variant This parameter must be assigned a variable declared as a Variant.  This 
parameter is for a return value only, and will assign the passed variable a string 
representing an error that may have occurred in the Simulator Automation 
Server.  If no error occurred, the EString variable will return an empty string. 

TAppend : Boolean This parameter is optional.  If you have given a file name of an auxiliary file that 
already exists, then the file will either be appended to or overwritten according 
to the setting of this parameter.  If the parameter is not passed, the Simulator 
Automation Server assumes false. 

TFieldList : Variant This parameter is optional.  A variant array of strings, where each string 
represents  an object field variable, as defined in the section on PowerWorld 
Object Variables.  If no array is passed, the Simulator Automation Server will 
use predefined default fields when exporting the data. 

 

Example  

WriteAuxFile("c:\my files\myauxfile.aux", "", "gen", EString, False, [pwBusNum, pwGenID, 
pwGenAGCAble]) 

This function call will send the values of the fields in tFieldList to a PowerWorld Auxiliary file for all the 
generators in the load flow case.  If a filter name had been passed instead of an empty string, Simulator would 
have located and used a pre-defined advanced filter and applied it to the information if it was found.  By 
specifying the fields in the optional parameter tFieldList, only the three field values for each generator will be 
returned.  If the optional parameter tFieldList had been omitted, Simulator would have returned internally 
defined default information for the generators.  Since the tFieldList optional parameter was included, the 
tAppend optional parameter also had to be included, even though it's default value is already False. 

PowerWorld Object Variables 

PowerWorld Object Variables (Version 9) 
The ability to access power system data for different objects through various Simulator Automation Server functions is 
based on variables defined in Simulator that can be referred to as Object Field Variables.  Each object (i.e. bus, 
generator, etc.) can have numerous fields associated with it.  Each of these fields, in turn, has a variable associated 
with the field to enable access to the field for the purpose of acquiring or changing data.  For example, the 
GetParameters function has a parameter called ParamList, which is intended to store a list of Object Field Variables 
for a particular type of object.  When the function is called, the Simulator Automation Server will return the values 
associated with each particular field variable for the type of object specified.  These field variables allow for complete 
flexibility by the user in specifying as many or as few fields for a particular object when acquiring or changing data. 

 

Examples of Field Variables 

PWBusGenMW 

PWBusNum  

 

Simulator has literally hundreds of parameters spanning numerous types of device and option specifications.  Rather 
than list all of the field variables and the value they represent in this help file, we have enabled Simulator to 
automatically generate a text file containing the field variables and a description of what value the variable represents.  
PowerWorld Corporation highly recommends that you examine this list.  To generate this text file, run PowerWorld 
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Simulator and access the Help menu.  Choose the option Export Object Fields…  Specify a file name and location 
for saving the file, and click Save.  Simulator will save out the field variables, the type of variable (string, integer, etc.), 
and a description of the value the field variable represents, with key fields for different objects marked with an asterisk.  
The field variables will also be split into sections based on the type of object they are valid for.  Note that the same 
field variable may be available for more than one object, but that the value represented by the field variable might vary 
for different objects. 

 

Examples of Field Variables in Listing 

PwBusGenMW Real 'Bus Gen MW' 

* PwBusNum Integer 'Bus Number' (* denotes key field in text file) 

ATC_MaxLimElements Integer 'Max # Limiting Elements' 

 

The last note on the Object Field Variables is that some of the object field variables are reused for more than one 
value for an object.  For example, a transmission line has "from" and "to" buses associated with the line.  Rather than 
have separate field variables for values at each terminal bus, the same field variable is used for both, with a colon 
followed by a number appended to the variable to signify which bus the value represents.  As an example, consider 
the field variable for bus per unit voltage, which is PWBusPUVolt.  Since there are two buses per line, the "From" bus 
voltage would be represented as PWBusPUVolt:0, and the "To" bus voltage would be represented as 
PWBusPUVolt:1.  The enumeration of the field variables always starts with 0 for the first instance.  You may note that 
in the text file of field values that you don't see any field variables with :0 appended to them.  Since we did not want 
you to have to always append the :0 on all field variables, the default for a field variable with no appended :# is 0.  
Thus you would only need to be concerned with appending the :# for field variables that require a number greater than 
0. 
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Auxiliary Script/Data Files 

Chapter 13 : Auxiliary Script/Data Files 

Auxiliary Script and Data files are used to automatically change data and control the Simulator in a batch mode 
fashion.   

This chapter covers the following: 

• Overview of A uxiliary Script and Data Files, including how they are created and loaded in Simulator 

• Auxiliary Script section format 

• Auxiliary Data section format 
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Auxiliary Files 

PowerWorld has incorporated the ability to import data from data sources other than power flow models into 
PowerWorld Simulator.  Simulator has always had the ability to import supplemental data into a power flow model, but 
this facility was limited to ten or twelve native data formats targeted to specific applications for which the data had to 
have a precise format.  The extensions described in this help document provide a more versatile interface to data from 
non-power-flow sources. 

In addition to developing auxiliary data formats, a script language was also developed.  The script language and 
auxiliary data formats are incorporated together.  This format is described in this help document. 

Script/Data files are called auxiliary files in Simulator.  An auxiliary file may be comprised of one or more DATA or 
SCRIPT sections.  A DATA section provides specific data for a specific type of object.  A SCRIPT section provides a 
list of script actions for Simulator to perform.   

 

These sections have the following format: 

SCRIPT ScriptName1 

{ 

script_statement_1 

   . 

script_statement_n 

} 

 

DATA DataName1(object_type, [list_of_fields], file_type_specifier) 

{ 

data_list_1 

   . 

data_list_n 

} 

 

DATA DataName2(object_type, [list_of_fields], file_type_specifier) 

{ 

data_list_1 

   . 

data_list_n 

} 

 

SCRIPT ScriptName2 

{ 

script_statement_1 

   . 

script_statement_n 

} 

Note that the keywords SCRIPT or DATA must occur at the start of a text file line.  Auxiliary files may contain more 
than one DATA or SCRIPT section.  These sections always begin with the keyword DATA or SCRIPT.  DATA sections 
are followed by an argument list enclosed in (  ).   The actual data or script commands are then contained within curly 
braces { }. 
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Script Command Execution Dialog 

The Script Command Execution dialog provides a location for the user to enter script commands manually, or to load 
auxiliary files containing Script and/or Data sections previously defined. 

 

Loading Auxiliary Files 

The first feature of the Script Command Execution dialog is that it provides a location to load previously defined 
auxiliary files for the currently loaded case.  The Auxiliary File  menu provides a location for loading an auxiliary file, 
or simply validating that the Script and/or Data sections of an Auxiliary file are correctly formatted in the file. 

The Quick Aux option allows you to open the Quick Auxiliary Files dialog for creating a list of auxiliary files to be 
opened and processed en masse. 

Lastly, you can export the Simulator recognized objects and object fields using the Export Field Names option.  
You can export the field names to a text for or to Excel. 

Running Script Commands  

The second feature of the Script Command Execution dialog is that you can run script commands manually.  To run 
a script command, type the command into the display, and press the Execute  button.  Note that if the Execute on 
ENTER key option is checked, the command will also be processed when ENTER is pressed.  Note that similar to 
script command syntax in the Script section of auxiliary files, script commands must be ended with a semi-colon (;) 
in the Script Command Execution dialog as well.   

You can enter multiple script commands to be processed in sequence in this display.  To do so, you must unc heck 
the option Execute on ENTER key.  Then you can press enter after each script command to move to the next line 
and enter another command.  Use the Execute  button to process the sequence of script commands. 

If you are running a sequence of script commands and wish to abort the run, use the Abort button. 

If you wish to view the message log while script commands are processing, open the log using the Show Log 
button. 
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Quick Auxiliary Files Dialog 

The Quick Auxiliary Files dialog can be accessed from the Quick Aux Files menu option of the Script Command 
Execution dialog.  This dialog gives you a location for creating a list of auxiliary files to be processed en masse for the 
currently loaded case. 

Using the Define  option of the Quick Aux Files menu, the Quick Auxiliary Files dialog will open.  Use this dialog to 
Add previously defined auxiliary files to the list of files to be processed.  You can rearrange the order of the files by 
selecting a file and using the up and down arrows on the right to move the selected file within the list, or you can sort 
them alphabetically using the Sort button.  To remove an auxiliary file from the list, use the Delete  button. 

Once the list of auxiliary files to process is complete, press the Execute  button to process the list of auxiliary files. 

 

 

Script Section 

Script Section 

The SCRIPT section begins with a left curly brace and ends with a right curly brace. 

 

SCRIPT ScriptName 

{ 

script_statement_1 

script_statement_2 

   . 

   . 

   . 

script_statement_n 

} 

Scripts may optionally contain a ScriptName.  This enables you to call a particular SCRIPT by using the LoadScript 
action. After the optional name, the SCRIPT section begins with a left curly brace and ends with a right curly brace.  
Inside of this, script statements can be given.   

 

In general, a script statement has the following format: 

Keyword(arg1, arg2, ...); 

• Statement starts with a keyword. 

• The keyword is followed by an argument list which is encompassed in parentheses ( ).   

• The arguments are separated by commas. 

• If an single argument is a list of things, this list is encompassed by braces [ ]. (eg. SetData) 

• Statements end with a semicolon. 

• Statements may take up several lines of the text file.   

• You may put more than one statement on a single text line. 

Those familiar with using Simulator will know that there is a RUN and EDIT mode in Simulator.  Some features  in 
Simulator are only available in one mode or the other.  This functionality will be preserved in the script language, but 
additionally a feature called a submode  will be used. 

Submodes limit what script commands can be called.  Only those commands available to the submode can be 
executed.  To switch submodes, use the EnterMode (mode or submode) script command. 

You will always be in one of the submodes when executing a script.  By default, when a script is initially started, you 
will be placed in the RUN, POWERFLOW submode.   

Script General Actions  

Script General Actions 
The following actions are available to you regardless of the Mode or SubMode: 

 

RenameFile   ("oldfilename", "newfilename"); 

CopyFile ("oldfilename", "newfilename"); 

DeleteFile ("filename");  
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LoadAux  ("filename", CreateIfNotFound); 

LoadScript ("filename", ScriptName); 

LoadData ("filename", DataName, CreateIfNotFound); 

   

SelectAll (objecttype,  filter); 

UnSelectAll (objecttype,  filter); 

Delete (objecttype,  filter); 

   

SaveData ("filename", filetype, objecttype, [fieldlist], [subdatalist], filter); 

   

SetData (objecttype, [fieldlist], [valuelist], filter); 

CreateData (objecttype, [fieldlist], [valuelist]); 

ChangeData (objecttype, [fieldlist], [valuelist], filter); (NOT AVAILABLE YET) 

   

NewCase;   

OpenCase ("filename"); // assumes to open as PWB 

OpenCase ("filename", openfiletype); 

  PWB 

  GE 

  PTI 

  IEEECF 

SaveCase ("filename"); // assumes to save as PWB 

SaveCase ("filename", savefiletype); 

  PWB, PWB5, PWB6, PWB7 

  PTI23, PTI24, PTI25, PTI26, PTI27, 

  GE 

  IEEECF 

EnterMode (mode or  submode); 

 EDIT CASE 

 RUN POWERFLOW 

  CONTINGENCY  

  ATC 

  FAULT 

  PV 

  QV 

LogClear;   

LogSave ("filename", AppendFile); 

  YES or NO 

LogAdd ("string");  

LogAddDateTime ("string", IncludeDate, IncludeTime, IncludeMilliseconds); 

  YES or NO YES or NO YES or NO 

   

SaveYbusInMatlabFormat ("filename", IncludeVoltages); 

  YES or NO 

SaveJacobian ("Jacfilename", "JIDfilename", filetype, JacForm); 

   M R 

   TXT P 

SetParticipationFactors (Method, ConstantValue, ForGensWithin); 

 MAXMWRAT  [Area num] 
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 RESERVE  [Zone num] 

 CONSTANT value SYSTEM 

   DISPLAYFILTERS 

GenForceLDC_RCC (filter);  

DirectionsAutoInsert (Source, Sink, DeleteExisting, UseDisplayFilters, Start, Increment); 

 AREA AREA YES or NO YES or NO value value 

 ZONE ZONE     

 INJECTIONGROUP INJECTIONGROUP     

  SLACK     

   

 

RenameFile("oldfilename", "newfilename"); 

Use this action to rename a file f rom within a script. 

"oldfilename"  : The present file name. 

"newfilename" : The new file name desired. 

 

CopyFile("oldfilename", "newfilename"); 

Use this action to copy a file from within a script. 

"oldfilename"  : The present file name. 

"newfilename" : The new file name desired. 

 

DeleteFile("filename"); 

Use this action to delete a file from within a script. 

"filename"  : The file name to delete. 

 

LoadAux("filename", CreateIfNotFound); 

Use this action to load another auxiliary file from within a script. 

"filename"  : The filename of the auxiliary file being loaded. 

CreateIfNotFound : Set to YES or NO.  YES means that objects which can not be found will 
be created while reading in DATA sections from filename.  If this 
parameter is not specified, then NO is assumed. 

 

LoadScript("filename", ScriptName); 

Use this action to load a named Script Section from another auxiliary file.  This will open the auxiliary file denoted by 
"filename", but will only execute the script section specified. 

"filename"  : The filename of the auxiliary file being loaded. 

ScriptName : The specific ScriptName from the auxiliary file which should be loaded. 

 

LoadData("filename", DataName, CreateIfNotFound); 

Use this action to load a named Script Section from another auxiliary file.  This w ill open the auxiliary file denoted by 
"filename", but will only execute the script section specified. 

"filename"  : The filename of the auxiliary file being loaded. 

DataName : The specific ScriptName from the auxiliary file which should be loaded. 

CreateIfNotFound : Set to YES or NO.  YES means that objects which can not be found will 
be created while reading in DATA sections from filename.  If this 
parameter is not specified, then NO is assumed. 

 

SelectAll(objecttype, filter); 

Use this to set the selected property of objects of a particular type to true.  A filter may optionally be specified to 
only set this property for objects which meet a filter. 

objecttype  : The objecttype being selected. 
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filter : There are three options for the filter: 

SelectAll(obje cttype);  : No filter specified means to select all objects of this type.   

SelectAll(objecttype, "filtername");  : "filtername" means select those that meet the filter. 

SelectAll(objecttype, AREAZONE);  : AREAZONE means select those that meet the area/zone filters. 

 

UnSelectAll(objecttype, filter); 

Same as SelectAll, but this action sets the selected properties to false. 

 

Delete(objecttype, filter); 

Use this delete objects of a particular type.  A filter may optionally be specified to only delete object which meet a 
filter. 

objecttype  : The objecttype being selected. 

filter : There are four options for the filter: 

Delete(objecttype); : No filter specified means to delete all objects of this type.   

Delete(objecttype, "filtername"); : "filtername" means delete those that meet the filter. 

Delete(objecttype, AREAZONE); : AREAZONE means delete those that meet the area/zone filters. 

Delete(objecttype, SELECTED); : SELECTED means delete those objects whose selected field is set to 
YES. 

 

SaveData("filename", filetype, objecttype, [fieldlist], [subdatalist], filter); 

Use this action to save data in a custom defined format.  A filter may optionally be specified to save only object 
which meet a filter. 

"filename" : The file to save the data to 

filetype : AUX (or AUXCSV): save as a space-delimited (or comma-delimited) 
auxiliary data file. 

objecttype : The objecttype being saved. 

[fieldlist] : A list of fields that you want to save. 

[subdatalist] : A list of the subdata objecttypes to save with the  

filter : There are four options for the filter: 

SaveData(…); : No filter specified means to save all objects of this type.   

SaveData(…, "filtername"); : "filtername" means save those that meet the filter. 

SaveData(…, AREAZONE); : AREAZONE means save those that meet the area/z one filters. 

SaveData(…, SELECTED); : SELECTED means save those objects whose selected field is set to YES. 

 

SetData(objecttype, [fieldlist], [valuelist], filter); 

Use this action to set fields for particular objects.  If a filter is specified, then it will set the respective fields for all 
objects which meet this filter.  Otherwise, if no filter is specified, then the keyfields must be included in the field list 
so that the object can be found. 

objecttype  : The objecttype being set. 

[fieldlist] : A list of fields that you want to save. 

[valuelist] : A list of values to set the respective fields to. 

filter : There are four options for the filter: 

SetData(…); : No filter specified: set data only for the object described by the [fieldlist] 
and [valuelist] parameters.   

SetData(…, "filtername");  : "filtername": set data for all objects that meet the filter. 

SetData(…, AREAZONE); : AREAZONE: set data for all objects that meet the area/zone filters. 

SetData(…, SELECTED);  : SELECTED: set data for all objects whose selected field is set to YES. 

 

CreateData(objecttype, [fieldlist], [valuelist]); 

Use this action to create particular objects.   Note that the key fields for the objecttype must be specified. 

objecttype  : The objecttype being set. 
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[fieldlist] : A list of fields that you want to save. 

[valuelist] : A list of values to set the respective fields to. 

 

NewCase; 

This action clear out the existing case and open a new case from scratch. 

OpenCase("filename", OpenFileType); 

This action will open a case stored in "filename" of the type OpenFileType; 

"filename" : The file to be opened. 

OpenFileType : An optional parameter saying the format of the file begin opened is.  If 
none is specified, then PWB will be assumed.  It may be one of the 
following strings:  
PWB, PTI, GE, IEEECF. 

 

SaveCase("filename", SaveFileType); 

This action will save the case to "filename" in the format SaveFileType. 

"filename" : The file name to save the information to. 

SaveFileType : An optional parameter saying the format of the file to be saved.  If none is 
specified, then PWB will be assumed.  It may be one of the following 
strings: 

PWB, PWB5, PWB6, PWB7 

PTI23, PTI24, PTI25, PTI26, PTI27 

GE 

IEEECF 

 

EnterMode(mode or submode); 

This action will tell Simulator what mode or submode to enter before performing the next script command. 

SubMode : The submode to enter.  A parameter stating what submode to put the 
program in.  Options available are CASE, POWERFLOW, 
CONTINGENCY, ATC, FAULT, PV, QV.  One may also put in RUN or 
EDIT which will place the program in the POWERFLOW or CASE 
respectively. 

 

LogClear; 

Use this action to clear the Message Log. 

 

LogSave("filename", AppendFile); 

This action saves the contents of the Message Log to "filename". 

"filename" : The file name to save the information to. 

AppendFile : Set to YES or NO. YES means that the contents of the log will be 
appended to "filename".  NO means that "filename" will be overwritten. 

 

LogAdd("string…"); 

Use this action to add a personal message to the MessageLog. 

"string…" : The string that will appear as a message in the log. 

 

LogAddDateTime("string…", IncludeDate, IncludeTime, IncludeMilliseconds); 

Use this action to add a personal message to the MessageLog, including the posting date/time. 

"string…" : The string that will appear as a message in the log. 

IncludeDate : Set to YES or NO. YES means that the date will be added after the string 
specified.  If this parameter is not specified, then YES is assumed. 

IncludeTime : Set to YES or NO. YES means that the time will be added after the date. If 
there’s no date, then it will be added after the string specified.  If this 
parameter is not specified, then YES is assumed. 
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IncludeMilliseconds : Set to YES or NO. YES means that the time including milliseconds will be 
added after the date or string specified. This is valid only if the 
IncludeTime is set to YES.  If this parameter is not specified, then YES is 
assumed. 

 

SaveYbusInMatlabFormat("filename", IncludeVoltages); 

Use this action to store the power system bus admittance matrix (Ybus) in a text format that can be easily read into 
other programs such as MATLAB®. 

"filename" : The file name to save the information to.  The Ybus data is stored using 
the MATLAB sparse matrix format in the matrix Ybus. 

IncludeVoltages : Set to YES or NO. YES means that the bus voltages are also stored but in 
the vector V. 

 

SaveJacobian("filename", IncludeVoltages); 

Use this action to store the power flow Jacobian in a text format that can be easily read into other programs such as 
MATLAB®. 

"Jacfilename" : The file name to save the Jacobian data to.  The Jacobian is stored using 
the MATLAB sparse matrix format in the matrix Jac. 

"JIDfilename" : The file name to save the text identifier information to.  This information is 
used to translate the bus numbering convention used in the Jacobian and 
Ybus files with the actual bus number and name in the case. 

filetype : A parameter saying the format of the file to be saved.  It may be one of the 
following strings:  

M: MATLAB .M Format. 

TXT: ASCII format. 

JacForm : Specifies the form of the Jacobian.  It may be one of the following strings: 

R: Rectangular form 

P: Polar form. 

 

SetParticipationFactors(Method, ConstantValue, ForGensWithin); 

Use this action to define the participation factors for multiple generators. 

Method : The formula used to calculate the participation factors for each generator.  
It may be one of the following strings:  

MAXMWRAT: The participation factor for each generator is set to the generator’s maximum MW capability. 

RESERVE: The participation factor for each generator is set to the generator’s reserve power, so that each 
generator participates in proportion to how much it has left to contribute. 

CONSTANT: The participation factor for each generator is set to the same specified value. 

ConstantValue : The value used if CONSTANT method is specified.  If CONSTANT 
method is not specified, enter 0 (zero). 

ForGensWithin : The set of generators to which the participation factors will be assigned.  It 
may be one of the following settings: 

[Area num]: For all the generators in area num.  

[Zone num]: For all the generators in zone num.  

SYSTEM: For all the generators in the system regardless of their area or zone affiliation.  

DISPLAYFILTERS: For just the generators whose display filter criteria evaluates to true. 

 

GenForceLDC_RCC(filter); 

Use this action to convert the voltage setpoint for Line Drop and Reactive Current Compensation (LDC/RCC) for 
multiple generators. 

filter : There are four options for the filter: 

GenForceLDC_RCC; : No filter specified means to convert voltage setpoint for LDCC/RCC on 
all the generators of the system. 

GenForceLDC_RCC ("filtername"); : "filtername" means to convert voltage setpoint for LDCC/RCC on those 
generators that meet the filter. 
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GenForceLDC_RCC (AREAZONE); : AREAZONE means to convert voltage setpoint for LDCC/RCC on those 
generators that meet the area/zone filters. 

GenForceLDC_RCC (SELECTED); : SELECTED means to convert voltage setpoint for LDCC/RCC on those 
generators whose selected field is set to YES. 

 

DirectionsAutoInsert(Source, Sink, DeleteExisting, UseDisplayFilters, Start, Increment); 

Use this action to automatically insert multiple directions for PTDF studies. 

Source, Sink : The type of object used as the source/sink of the directions.  Currently, 
only the following types of directions can be automatically defined:  

AREA   SLACK : Directions from areas to slack bus of the system. 

ZONE   SLACK : Directions from zones to slack bus of the system. 

INJECTIONGROUP   SLACK :  Directions from injection groups to slack bus of the system. 

AREA   AREA : Directions from areas to other areas of the system. 

ZONE   ZONE : Directions from zones to other zones of the system. 

INJECTIONGROUP   INJECTIONGROUP : Directions from injection groups to other injection groups of the 
system. 

DeleteExisting : Set to YES or NO.  YES means that previously defined directions will be 
deleted before the new directions are automatically inserted.  NO means 
automatically inserted directions will be added to the list of previously 
defined directions.  If this parameter is not specified, then YES is 
assumed. 

UseDisplayFilters : Set to YES or NO.  YES means that only Areas and Zones with their 
Area/Zone filters set to YES will be used when automatically inserting 
directions.  NO specifies all Areas and Zones will be used to automatically 
insert directions regardless of their Area/Zone filters.  If this parameter is 
not specified, then NO is assumed. 

Start : Integer value that specifies the first number used when automatically 
numbering the automatically inserted directions.  If this parameter is not 
specified, then 1 is assumed. 

Increment : Integer value that will be used as increment in numbering the subsequent 
automatically inserted directions.  If this parameter is not specified, then 1 
is assumed. 

Script Edit Mode Actions  

Script Edit Mode Actions 
The following script commands are available during the Case submode of Edit mode: 

 

Equivalence; 

DeleteExternalSystem; 

SaveExternalSystem("filename", Savefiletype, withties); 

Scale (scaletype, basedon, [parameters], ScaleMarker); 

  LOAD MW [P,Q] BUS 

  GEN FACTOR [P] (means constant pf) AREA 

  INJECTIONGROUP   ZONE 

  BUSSHUNT  [P, +Q, -Q]  

Move ([elementA], [destination parameter]);  

  [GEN numA idA] [numB idB]  

  [LOAD numA idA] [numB idB] // NOT AVAILABLE YET 

  [BRANCH numA1 numA2 cktA] [numB1 numB2 cktB] // NOT AVAILABLE YET 

Combine ([elementA], [elementB]);  

  [GEN numA idA] [GEN numB idB]  

  [LOAD numA idA] [LOAD numB idB] // NOT AVAILABLE YET 

  [BRANCH numA1 numA2 cktA] [BRANCH numB1 numB2 cktB] // NOT AVAILABLE YET 

    

SplitBus ([element], NewBusNumber, InsertBusTieLine, LineOpen); 
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 [BUS num] num YES or NO YES or NO 

MergeBuses (NewBusNumber, filter); 

 num  

TapTransmissionLine ([element], PosAlongTheLine, NewBusNumber, ShuntModel, TreatAsMSLine);

 [BRANCH numA1 numA2 cktA]; Value in % num LINESHUNTS YES or NO 

    CAPACITANCE  

      

InterfacesAutoInsert (Type, DeleteExisting, UseDisplayFilters, Prefix, Limits); 

 AREA YES or NO YES or NO "string" AUTO 

 ZONE    ZEROS 

     [value1, … value 8] 

 

Equivalence  

This action will equivalence a power system.  All options regarding equivalencing are handled by the Equiv_Options 
objecttype.  Use the SetData() action, or a DATA section to set these options prior to using the Equivalence() 
action.  Also, remember that the property BusEquiv must be set true for each bus that you want to equivalence. 

 

DeleteExternalSystem 

This action will delete part of the power system.  It will delete those buses whose property BusEquiv must is set 
true. 

 

SaveExternalSystem("filename", SaveFileType, WithTies) 

This action will save part of the power system to a "filename".  It will save only those buses whose property 
BusEquiv must is set true.   

"filename" : The file name to save the information to. 

SaveFileType : An optional parameter saying the format of the file to be saved.  If none is 
specified, then PWB will be assumed.  My be one of the following strings: 
PWB, PWB5, PWB6, PWB7 
PTI23, PTI24, PTI25, PTI26, PTI27 
GE 
IEEECF 

WithTies : An optional parameter.  One must specify the file type explicitly in order to 
use the WithTies parameter. Allows one to save transmission lines that tie 
the a bus marked with BusEquiv as false and one marked true.  This must 
be a string which starts  with the letter Y, otherwise NO will be assumed. 

 

Scale(scaletype, basedon, [parameters], scalemarker); 

Use this action to scale the load and generation in the system.    

scaletype : The objecttype begin scaled.  Must be either LOAD, GEN, 
INJECTIONGROUP, or BUSSHUNT. 

basedon: MW: parameters are given in MW, MVAR units. 
FACTOR: parameters a factor to multiple the present values by. 

[parameters]: These parameters have different meanings depending on ScaleType.   

LOAD: [MW, MVAR] or [MW].  If you want to scale load using constant power factor, then do not specifying a 
MVAR value.  

GEN: [MW]. 

INJECTIONGROUP: [MW, MVAR] or [MW] .  If you want to scale load using constant power factor, then do not 
specifying a MVAR value. 

BUSSHUNT: [GMW, BCAPMVAR, BREAMVAR].  The first values scales G shunt values, the second value 
scales positive (capacitive) B shunt values, and the third value scales 
negative (reactive) B shunt values. 

scalemarker: This value specifies whether to look at an element’s bus, area, or zone to 
determine whether it should be scaled. 

BUS: Means that elements will be scaled according to the BusScale 
property of the element’s terminal bus.  
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AREA: Means that elements will be scaled according to the BGScale 
property of the element’s Area.  Note that it is possible for the area of a 
load, generator, or switched shunt to be different than the terminal bus’s 
area. 

ZONE: Means that elements will be scaled according to the BGScale 
property of the element’s Zone.  Note that it is possible for the zone of a 
load, generator, or switched shunt to be different than the terminal bus’s 
zone. 

OWNER: Means that the elements will be scaled according to the 
BGScale property of the element’s Owner. 

 

Move([elementA], [destination parameters]); 

NOTE:  THIS ACTION IS ONLY AVAILABLE FOR GENERATORS. 

Use this action to move a generator, load, or transmission line.   

[elementA] : the object that should be moved.  Must be one of the following formats. 

[GEN busnum id] 

[LOAD busnum id] 

[BRANCH busnum1 busnum2 ckt] 

[destination parameters] : These parameters have different meanings depending on object type of 
the element.   

GEN: [busnum  id] 

LOAD: [busnum  id]   

BRANCH: [busnum1  busnum2  id] 

 

Combine([elementA], [elementB]); 

NOTE:  THIS ACTION IS ONLY AVAILABLE FOR GENERATORS.   

Use this action to combine two generators, two loads, or two transmission line.  Note that elementA and elementB 
must be of the same object type.  You can not combine a BRANCH and a LOAD. 

[elementA] : The object that should be moved.  Must be one of the following formats. 

[GEN busnum id] 

[LOAD busnum id] 

[BRANCH busnum1 busnum2 ckt] 

[elementB] : The object that element A should be combined with.  Must the same 
format as for elementA. 

 

SplitBus([element], NewBusNumber, InsertBusTieLine, LineOpen); 

Use this action to transform one bus into two connected buses. 

[element] : The bus that should be split.  Must be of the following format: 

[BUS num] 

NewBusNumber : The number of the new bus resulting from the split.  Must be unique, that 
is, it cannot be a number that identifies another number in the case. 

InsertBusTieLine Set to YES or NO.  YES means to insert a very low -impedance bus tie 
between the bus to split and its offspring. The new branch will have an 
impedance of 0.0000 + j0.0001 ohms.  NO means that no bus tie will be 
inserted.  If this parameter is not specified, then YES is assumed. 

LineOpen Set to YES or NO.  YES means that the bus tie should be inserted as an 
open branch.  NO means that the bus tie will be inserted as a closed 
branch.  This options is valid only if InsertBusTieLine is set to YES.  If this 
parameter is not specified, then NO is assumed. 

 

MergeBuses([element], filter); 

Use this action to merge a set of buses into a single bus. 

[element] : The number of the new bus resulting from the merging.  It should be a 
number of a bus that is part of the set of buses to be merged, or it should 
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be unique, meaning that it cannot be a number that identifies another 
number in the case.  Must be of the following format: 

[BUS num] 

filter : There are four options for the filter: 

MergeBuses(…); : No filter specified means to merge all the buses of the system. 

MergeBuses(…, "filtername"); : "filtername" means to merge those buses that meet the filter. 

MergeBuses(…, AREAZONE); : AREAZONE means to merge those buses that meet the area/zone filters. 

MergeBuses(…, SELECTED); : SELECTED means to merge those buses whose selected field is set to 
YES. 

 

TapTransmissionLine([element], PosAlongTheLine, NewBusNumber, ShuntModel, TreatAsMSLine); 

Use this action to insert a bus at some location along an existing transmission line. 

[element] : The transmission line to tap.  Must be of the following format: 

[BRANCH busnum1 busnum2 ckt] 

PosAlongTheLine : The value that indicates the point where the new bus is to be inserted 
relative to the location of the nearest of the two buses in terms of a 
percentage of the total line length  This value controls how the 
impedances of the new lines are set, as the impedance of each section 
will equal the section’s corresponding percentage length multiplies by the 
impedance of the original line. 

NewBusNumber : The number of the new bus resulting from the tapping.  Must be unique, 
that is, it cannot be a number that identifies another number in the case. 

ShuntModel : The way  the original charging capacitanc e of the line is reassigned.  The 
choices are: 

LINESHUNTS: The original charging capacitance is reassigned as line shunts at the original terminal bus ends 
of the two new line segments.  The charging capacitance of the two new 
branch elements will be set to 0. 

CAPACITANCE: The original charging capacitance of the line is converted approximately using percentage 
entered as PosAlongTheLine.  In other words, the original capacitance will 
be scaled and assigned to the new segments as charging capacitance. 

The default ShuntModel is LINESHUNTS. 

TreatAsMSLine : Set to YES or NO.  YES means to force the status of the two new line 
sections to be controlled in unison.  NO means that the two new lines will 
be controlled independently of each other. 

 

InterfacesAutoInsert(Type, DeleteExisting, UseDisplayFilters, Prefix, Limits); 

Use this action to automatically insert a group of interfaces.  The new of the new interfaces defaults to "Area1-
Area2" or "Zone1-Zone2" with an optional Prefix. 

Type : The type of interfaces to insert.  Choices are: 

AREA: Area-to-area interfaces join adjacent areas (those that share at least one tie line). 

ZONE: Zone-to-zone interfaces join adjacent interfaces (those that share at least one tie line). 

DeleteExisting : Set to YES or NO.  YES means that previously defined interfaces will be 
deleted before the new interfaces are automatically inserted.  NO means 
automatically inserted interfaces  will be added to the list of previously 
defined interfaces.  If this parameter is not specified, then YES is 
assumed. 

UseDisplayFilters : Set to YES or NO.  YES means that only Areas and Zones with their 
Area/Zone filters set to YES will be used when automatically inserting 
interfaces.  NO specifies all Areas and Zones will be used to automatically 
insert interfaces regardless of their Area/Zone filters.  If this parameter is 
not specified, then NO is assumed. 

Prefix : An optional prefix of up to three characters.   Use this prefix to avoid 
duplicating names, particularly when some of the areas or zones have the 
same name.  If this parameter is not specified, then "" is assumed. 

Limits  : Specifies the way the interfaces rating are set.  Choices are: 

AUTO: The interface rating is calculated based on the ratings of the components included in the interface. 

ZEROS: All the interface limits are set to zero. 
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[value1, …, value8]: The set of rating values to be used for the interfaces.  The eight values must be specified, 
separated by commas. 

The default parameter is ZEROS. 

Script Run Mode Actions  

Script Run Mode Actions 
The following script commands are available during any of the submodes of Run Mode: 

 

CalculatePTDF   ([transactor seller], [transactor buyer], LinearMethod); 

  [AREA num] [AREA num] AC 

  [ZONE num] [ZONE num] DC 

  [SUPERAREA "name"] [SUPERAREA name] DCPS 

  [INJECTIONGROUP "name"] [INJECTIONGROUP name]  

  [BUS num] [BUS num]  

  [SLACK] [SLACK]  

CalculatePTDFMultipleDirections (StoreValuesForBranches, StoreValuesForInterfaces , LinearMethod); 

 YES or NO YES or NO AC 

   DC 

   DCPS 

CalculateLODF  ([BRANCH nearbusnum farbusnum ckt], LinearMethod); 

CalculateTLR  ([flowelement], direction,  [transactor], LinearMethod);

  [INTERFACE "name"] BUYER same as above for PTDFs SELLER

 [BRANCH nearbusnum farbusnum ckt]    

CalculateVoltSense  ([BUS num]); 

CalculateFlowSense ([flowelement], FlowType); 

  [INTERFACE "name"] MW 

  [BRANCH num1 num2 ckt] MVAR 

MVA 

CalculateLossSense  (FunctionType); 

 NONE 

 ISLAND 

 AREA 

 AREASA 

 SELECTED 

 

CalculatePTDF([transactor seller], [transactor buyer], LinearMethod); 

Use this action to calculate the PTDF values between a seller and a buyer.  You may optionally specify the linear 
calculation method.  Note that the buyer and seller must not be same thing.  If no Linear Method is specified, 
Lossless DC will be used. 

[transactor seller] : The seller (or source) of power.  There are six possible settings: 

[AREA num] 

[ZONE num] 

[SUPERAREA "name"]  

[INJECTIONGROUP "name"]  

[BUS num] 

[SLACK] 

[transactor buyer] : The buyer (or sink) of power.  There are six possible settings, which are 
the same as for the seller. 

LinearMethod : The linear method to be used for the PTDF calculation.  The options are: 

AC: for calculation including losses. 

DC: for lossless DC. 



Auxiliary Script/Data Files 

637 

DCPC: for lossless DC that takes into account phase shifter operation. 

 

CalculatePTDFMultipleDirections(StoreValuesForBranches, StoreValuesForInterfaces, LinearMethod); 

Use this action to calculate the PTDF values using multiple directions.  Only directions with the field INCLUDE set to 
YES will be analyzed when calculating the multiple direction PTDF’s.  You may optionally specify the linear 
calculation method.  If no Linear Method is specified, Lossless DC will be used. 

StoreValuesForBranches : Set to YES or NO.  YES means that the PTDF’s for lines/transformers will 
be stored. 

StoreValuesForInterfaces : Set to YES or NO. YES means that the PTDF’s for interfaces will be 
stored. 

LinearMethod : The linear method to be used for the PTDF calculation.  The options are: 

AC: for calculation including losses. 

DC: for lossless DC. 

DCPC: for lossless DC that takes into account phase shifter operation. 

 

CalculateLODF([BRANCH nearbusnum farbusnum ckt], LinearMethod); 

Use this action to calculate the Line Outage Distribution Factors (or the Line Closure Distribution Factors) for a 
particular branch.  If the branch is presently closed, then the LODF values will be calculated, otherwise the LCDF 
values will be calculated.  You may optionally specify the linear calculation method as well. If no Linear Method is 
specified, Lossless DC will be used. 

[BRANCH nearbusnum farbusnum ckt] : The branch whose status is being changed. 

LinearMethod : The linear method to be used for the LODF calculation.  The options are:  

DC: for lossless DC. 

DCPC: for lossless DC that takes into account phase shifter operation. 

Note: AC is NOT an option for the LODF calculation. 

 

CalculateTLR([flow element], direction, [transactor], LinearMethod); 

Use this action to calculate the TLR values a particular flow element (transmission line or interface).  You also 
specify one end of the potential transfer direction.  You may optionally specify the linear calculation method.  If no 
Linear Method is specified, Lossless DC will be used. 

[flow element] : This is the flow element we are interested in.  Choices are: 

[INTERFACE "name"] 

[BRANCH nearbusnum farbusnum ckt] 

direction : the type of the transactor. Either BUYER or SELLER. 

[transactor buyer] : the transactor of power.  There are six possible settings. 

[AREA num] 

[ZONE num] 

[SUPERAREA "name"] 

[INJECTIONGROUP "name"] 

[BUS num] 

[SLACK] 

LinearMethod : The linear method to be used for the calculation.  The options are: 

AC: for calculation including losses. 

DC: for lossless DC. 

DCPC: for lossless DC that takes into account phase shifter operation. 

 

CalculateVoltSense([BUS num]); 

This calculates the sensitivity of a particular buses voltage to real and reactive power injections at all buses in the 
system. (Note: this assumes that the power is injected at a given bus and taken out at the slack bus). 

[BUS num] : The bus to calculate sensitivities for. 

 

CalculateFlowSense([flow element], FlowType); 
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This calculates the sensitivity of the MW, MVAR, or MVA flow of a line or interface to real and reactive power 
injections at all buses in the system. (Note: this assumes that the power is injected at a given bus and taken out at 
the slack bus). 

[flow element] : This is the flow element we are interested in.  Choices are: 

[INTERFACE "name"] 

[BRANCH num1 num2 ckt] 

FlowType : The type of flow to calculate this for.  Either MW, MVAR, or MVA. 

 

CalculateLossSense(FunctionType); 

This action calculates the sensitivity of a real power loss function, PLosses, to bus real and reactive power 
injections.  Stated mathematically, this action calculates d PLosses/d Pi and d PLosses/d Qi , where Pi and Qi are 
the real and reactive power injections at bus i, respectively.  Stated less formally, this action indicates how losses 
would change if one more MW or Mvar of power were injected at bus i. 

FunctionType : Specifies how the losses are computed.  Choices are: 

NONE: No losses are calculated because a loss function is not specified. 

ISLAND: Losses are calculated with respect to the losses in bus’ island.  If the power system consists of only 
one island, losses are computed with respect to the total system losses.  

AREA: Losses are calculated with respect to the total losses for the area containing bus i.  This is probably the 
most common loss function because usually one is concerned with 
minimizing losses for a particular area rather than for the entire case. 

AREASA: Losses are calculated with respect to the total losses for the area containing bus i if bus i does not 
belong to a super area, and with respect to the total losses for the super 
area containing bus i if bus i does belong to a super area. 

SELECTED: Losses are calculated with respect to the total losses for a group of areas whose selected field is 
set to YES.   

 

In addition to the general run mode actions, there are specific actions for the following submodes: PowerFlow, 
Contingency, ATC, Fault, PV and QV. 
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Script PowerFlow Submode Actions 
The following actions are specific to the Run Mode submode PowerFlow: 

 

DoCTGAction([contingency action]); 

SolvePowerFlow(SolMethod, "filename1", "filename2", CreateIfNotFound1, CreateIfNotFound2); 

SolvePrimalLP("filename1", "filename2", CreateIfNotFound1, CreateIfNotFound2); 

SolveFullSCOPF(BCMethod, "filename1", "filename2", CreateIfNotFound1, CreateIfNotFound2); 

ResetToFlatStart(FlatVoltagesAngles, ShuntsToMax, LTCsToMiddle, PSAnglesToMiddle); 

DiffFlowSetAsBase; 

DiffFlowClearBase; 

DiffFlowMode (diffmode); 

  PRESENT 

  BASE 

  DIFFERENCE 

OPFWriteResultsAndOptions ("filename"); 

 

DoCTGAction([contingency action]); 

Call this action to use the formats seen in the CTGElement subdata record for Contingency Data.  Note that all 
actions are supported, except COMPENSATION sections are not allowed. 

 

SolvePowerFlow(SolMethod, "filename1", "filename2", CreateIfNotFound1, CreateIfNotFound2); 

Call this action to perform a single power flow solution.  The parameters are all optional and specify a conditional 
response depending on whether the solution is successfully found.  If parameters are not passed then default 
values will be used. 

SolMethod The solution method to be used for the power flow calculation. The 
options are: 

RECTNEWT: For Rectangular Newton-Raphson method. 

POLARNEWTON: For Polar Newton-Raphson method. 

GAUSSSEIDEL: For Gauss-Seidel method. 

FASTDEC: For Fast Decoupled method. 

DC: For DC method. 

ROBUST: For ROBUST method. 

The default method is RECTNEWT. 

"filename1" The filename of the auxiliary file to be loaded if there is a successful 
solution.  You may also specify STOP, which means that all AUX file 
execution should stop under the condition.  Default Value is "". 

"filename2" The filename of the auxiliary file to be loaded if there is a NOT successful 
solution.  You may also specify STOP, which means that all AUX file 
execution should stop under the condition.  Default Value is "". 

CreateIfNotFound1 Set to YES or NO.  YES means that objects which can not be found will 
be created while reading in DATA sections of filename1.   Default Value is 
NO. 

CreateIfNotFound2 Set to YES or NO.  YES means that objects which can not be found will 
be created while reading in DATA sections of filename2.   Default Value is 
NO. 

 

SolvePrimalLP("filename1", "filename2", CreateIfNotFound1, CreateIfNotFound2); 

Call this action to perform a primal LP OPF solution.  The parameters are all optional and specify a conditional 
response depending on whether the solution is successfully found.  If parameters are not passed then default 
values will be used. 

"filename1" The filename of the auxiliary file to be loaded if there is a successful 
solution.  You may also specify STOP, which means that all AUX file 
execution should stop under the condition.  Default Value is "". 
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"filename2" The filename of the auxiliary file to be loaded if there is a NOT successful 
solution.  You may also specify STOP, which means that all AUX file 
execution should stop under the condition.  Default Value is "". 

CreateIfNotFound1 Set to YES or NO.  YES means that objects which can not be found will 
be created while reading in DATA sections of filename1.   Default Value is 
NO. 

CreateIfNotFound2 Set to YES or NO.  YES means that objects which can not be found will 
be created while reading in DATA sections of filename2.   Default Value is 
NO. 

 

SolveFullSCOPF (BCMethod, "filename1", "filename2", CreateIfNotFound1, CreateIfNotFound2); 

Call this action to perform a full Security Constrained OPF solution.  The parameters are all optional and specify a 
conditional response depending on whether the solution is successfully found.  If parameters are not passed then 
default values will be used. 

BCMethod The solution method to be used for solving the base case.  The options 
are: 

POWERFLOW – for single power flow algorithm. 

OPF – for the optimal power flow algorithm. 

Default Value is POWERFLOW. 

"filename1" The filename of the auxiliary file to be loaded if there is a successful 
solution.  You may also specify STOP, which means that all AUX file 
execution should stop under the condition.  Default Value is "". 

"filename2" The filename of the auxiliary file to be loaded if there is a NOT successful 
solution.  You may also specify STOP, which means that all AUX file 
execution should stop under the condition.  Default Value is "". 

CreateIfNotFound1 Set to YES or NO.  YES means that objects which can not be found will 
be created while reading in DATA sections of filename1.   Default Value is 
NO. 

CreateIfNotFound2 Set to YES or NO.  YES means that objects which can not be found will 
be created while reading in DATA sections of filename2.   Default Value is 
NO. 

 

ResetToFlatStart (FlatVoltagesAngles, ShuntsToMax, LTCsToMiddle, PSAnglesToMiddle); 

Use this action to initialize the Power Flow Solution to a "flat start."  The parameters are all optional and specify a 
conditional response depending on whether the solution is successfully found.  If parameters are not passed then 
default values will be used. 

FlatVoltagesAngles Set to YES or NO.  YES means setting all the voltage magnitudes and 
generator setpoint voltages to 1.0 per unit and all the voltage angles to 
zero.   Default Value is YES. 

ShuntsToMax Set to YES or NO.  YES means to increase Switched Shunts Mvar half 
way to maximum.   Default Value is NO. 

LTCsToMiddle Set to YES or NO.  YES means setting the LTC Transformer Taps to 
middle of range.   Default Value is NO. 

PSAnglesToMiddle Set to YES or NO.  YES means setting Phase Shifter angles to middle of 
range.   Default Value is NO. 

 

DiffFlowSetAsBase; 

Call this action to set the present case as the base case for the difference flows abilities of Simulator. 

 

DiffFlowClearBase; 

Call this action to clear the base case for the difference flows abilities of Simulator. 

 

DiffFlowMode(diffmode); 

Call this action to change the mode for the difference flows abilities of Simulator.   

diffmode : String that starts with ‘P’ changes it to PRESENT 
String that starts with ‘B’ changes it to BASE 
String that starts with ‘D’ changes it to DIFFERENCE 
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OPFWriteResultsAndOptions("filename"); 

Writes out all information related to OPF analysis as an auxiliary file.  This includes Limit Monitoring Settings, 
options for Areas, Buses, Branches, Interfaces, Generators, SuperAreas, OPF Solution Options. 
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Script Contingency Submode Actions 
The following actions are specific to the Run Mode Submode Contingency: 

 

CTGSolveAll; 

CTGSolve("ContingencyName"); 

CTGSetAsReference; 

CTGRestoreReference; 

CTGProduceReport("filename"); 

CTGWriteResultsAndOptions("filename"); 

CTGAutoInsert; 

CTGCalculateOTDF( [transactor seller], [transactor buyer], LinearMethod); 

 [AREA num] [AREA num]  AC 

 [ZONE num]  [ZONE num]  DC 

 [SUPERAREA "name"] [SUPERAREA "name"] DCPS 

 [INJECTIONGROUP "name"] [INJECTIONGROUP "name"] 

 [BUS num]  [BUS num] 

 [SLACK] [SLACK] 

 

CTGSolveAll; 

Call this action to solve all the contingencies which are not marked skip. 

 

CTGSolve("ContingencyName"); 

Call this action solve a particular contingency.  The contingency is denoted by the "Contingency Name". 

 

CTGSetAsReference; 

Call this action to set the present system state as the reference for contingency analysis. 

 

CTGRestoreReference; 

Call this action to reset the system state to the reference state for contingency analysis. 

 

CTGProduceReport("filename"); 

Produces a text-based contingency analysis report using the settings defined in CTG_Options. 

 

CTGWriteResultsAndOp tions("filename"); 

Writes out all information related to contingency analysis as an auxiliary file.  This includes Contingency Definitions, 
Limit Monitoring Settings, Contingency Results, Solution Options, CTG Options as well as any Model Criteria that 
are used by the Contingency Definitions. 

 

CTGAutoInsert; 

Automatically generates a contingency list using the settings defined in CTG_Options. 

 

CTGCalculateOTDF([transactor seller], [transactor buyer], LinearMethod); 

This action calculate OTDFs for each contingency-caused branch or interface violation.  The values calculated will 
be a measure of what percent of a transfer would appear on the branch or interface after the respective contingency 
occurs.  Realize for branch violations, that the sign of the OTDF value will be relative to the direction of the MW flow 
found during the contingency analysis. 

The parameters will be used to calculate the PTDFs for the transfer direction you are interested in.  These PTDF 
values will then be used throughout the OTDF calculation.  Note that the buyer and seller must not be same thing.  
If no Linear Method is specified, Lossless DC will be used. 

NOTE: All the parameters are optional.  If they are not specified, then the existing PTDFs will be used. 

[transactor seller] : The seller (or source) of power.  There are six possible settings: 
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[AREA num] 

[ZONE num] 

[SUPERAREA "name"]  

[INJECTIONGROUP "name"]  

[BUS num] 

[SLACK] 

[transactor buyer] : The buyer (or sink) of power.  There are six possible settings, which are 
the same as for the seller. 

LinearMethod : The linear method to be used for the PTDF calculation.  The options are: 

AC: for calculation including losses. 

DC: for lossless DC. 

DCPC: for lossless DC that takes into account phase shifter operation. 
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Script ATC Submode Actions 
The following actions are specific to the Run Mode Submode ATC: 

 

ATCDetermine   ([transactor seller], [transactor buyer]); 

  [AREA num] [AREA num] 

  [ZONE num] [ZONE num] 

  [SUPERAREA "name"] [SUPERAREA name] 

  [INJECTIONGROUP "name"] INJECTIONGROUP name] 

  [BUS num] [BUS num] 

  [SLACK] SLACK] 

ATCRestoreInitialState; 

ATCIncreaseTransferBy  (amount); 

ATCTakeMeToScenario  (RL, G, I); 

ATCDetermineFor  (RL, G, I); 

ATCWriteResultsAndOptions ("filename"); 

 

ATCDetermine([transactor seller], [transactor buyer]); 

Use this action to calculate the Available Transfer Capability (ATC) between a seller and a buyer.  Note that the 
buyer and seller must not be same thing.  Other options regarding ATC calculations should be set using a DATA 
section via the ATC_Options object type. 

[transactor seller] : The seller (or source) of power.  There are six possible settings  

[AREA num] 

[ZONE num] 

[SUPERAREA "name"] 

[INJECTIONGROUP "name"] 

[BUS num] 

[SLACK] 

[transactor buyer] : The buyer (or sink) of power.  There are six possible settings which are 
the same as for the seller. 

 

ATCRestoreInitialState; 

Call this action to restore the initial state for the ATC tool. 

 

ATCIncreaseTransferBy(amount); 

Call this action to increase the transfer between the buyer and seller. 

 

ATCTakeMeToScenario(RL, G, I); 

Call this action to set the present case according to Scenario RL, G, I. 

 

ATCDetermineFor(RL, G, I); 

Call this action to determine the ATC for Scenario RL, G, I. 

 

ATCWr iteResultsAndOptions("filename"); 

Writes out all information related to ATC analysis as an auxiliary file.  This includes Contingency Definitions, Limit 
Monitoring Settings, Solution Options, ATC Options, ATC results, as well as any Model Criteria that are used by the 
Contingency Definitions. 
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Script Fault Submode Actions 
The following actions are specific to the Run Mode Submode Fault: 

 

Fault ([BUS num],  faulttype, R, X); 

Fault ([BRANCH nearbusnum farbusnum ckt], faultlocation, faulttype,  R, X) ; 

   SLG   

   LL   

   3PB   

   DLG   
 

Fault([Bus num, faulttype, R, X]); 

 

Fault([BRANCH nearbusnum farbusnum ckt], faultlocation, faulttype, R, X]); 

Call this function to calculate the fault c urrents for a fault.  If the fault element is a bus then do not specify the fault 
location parameter.  If the fault element is a branch, then the fault location is required. 

[Bus num] : This specifies the bus at which the fault occurs. 

[BRANCH nearbusnum farbusnum ckt] : This specifies the branch on which the fault occurs. 

Fault location :  This specifies the percentage distance along the branch where the fault 
occurs.  This percent varies from 0 (meaning at the nearbus) to 100 
(meaning at the far bus) 

Faulttype : This specified the type of fault which occurs.  There are four options: 

SLG: Single Line To Ground fault 

LL: Line to Line Fault 

3PB: Three Phase Balanced Fault 

DLG: Double Line to Group Fault. 

R, X : These parameters are optional and specify the fault impedance.  If none 
are specified, then a fault impedance of zero is assumed. 
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Script PV Submode Actions 
The following actions are specific to the Run Mode Submode PV: 

 

PVCreate ("name", [element source], [element sink]); 

  [INJECTIONGROUP "name"] [INJECTIONGROUP "name"] 

PVSetSourceAndSink ("name"); [element source], [element sink]); 

  [INJECTIONGROUP "name"] [INJECTIONGROUP "name"] 

PVRun ("name"); 

PVClearResults ("name"); 

PVStartOver ("name"); 

PVDestroy ("name"); 

PVWriteResultsAndOptions  ("filename"); 

RefineModel (objecttype, filter, Action ForWhichValue); 

 AREA  TRANSFORMERTAPS  

 ZONE  SHUNTS  

   OFFAVR  

 

PVCreate("name", [elementSource], [elementSink]); 

Call the function to create a PV study with "name" as identifier.  You may optionally specify the source and sink 
elements for the study transaction. 

"name" : String that identifies the PV study to be created. 

[element source] : The source of power for the PV study.  There is only one possible setting: 

[INJECTIONGROUP "name"]  

[element sink] : The sink of power for the PV study.  There is only one possible setting, 
which is the same as for the source. 

 

PVSetSourceAndSink("name", [elementSource], [elementSink]); 

Call the function to specify the source and sink elements to perform the PV study called "name". 

"name" : String that identifies the PV study for which the source and sink elements 
are to be assigned to. 

[element source] : The source of power for the PV study.  There is only one possible setting: 

[INJECTIONGROUP "name"]  

[element sink] : The sink of power for the PV study.  There is only one possible setting, 
which is the same as for the source. 

 

PVRun("name"); 

Call the function to start the PV study called "name". 

"name" : String that identifies the PV study. 

 

PVClearResults("name"); 

Call the function to clear all the results of the PV study called "name". 

"name" : String that identifies the PV study. 

 

PVStartOver("name"); 

Call the function to start over the PV study called "name".  This includes clear the activity log, clear results, restore 
the initial state, set the current state as initial state, and initialize the step size. 

"name" : String that identifies the PV study. 

 

PVDestroy("name"); 

Call the function to destroy the PV study called "name". 
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"name" : String that identifies the PV study. 

 

PVWriteResultsAndOptions("filename"); 

Call this action to save all the PV results and options in the auxiliary file "filename". 

 
RefineModel(objecttype, filter, Action, Tolerance); 

Call this function to refine the system model to fix modeling idiosyncrasies that cause premature loss of 
convergence during PV and QV studies. 

objecttype  : The objecttype being selected. 

AREA 

ZONE 

filter : There are three options for the filter: 

RefineModel(…, "", …);  : No filter specified means to select all objects of this type.   

RefineModel(…, "filtername", …);:  "filtername" means select those that meet the filter. 

Action : The way the model will be refined.  Choices are: 

TRANSFORMERTAPS Fix all transformer taps at their present values if their Vmax – Vmin is less 
than or equal to the user specified tolerance. 

SHUNTS Fix all shunts at their present values if their Vmax – Vmin is less than or 
equal to the user specified tolerance. 

OFFAVR Remove units from AVR control, thus locking their MVAR output at its 
present value if their Qmax – Qmin is less or equal to the user specified 
tolerance. 

Tolerance : Tolerance value. 
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Script QV Submode Actions 
The following actions are specific to the Run Mode Submode QV: 

 

QVRun ("filename", InErrorMakeBaseSolvable); 

  YES or NO 

NOTE: The QV study is always performed on selected buses. 

QVWriteResultsAndOptions ("filename"); 

RefineModel (objecttype, filter, Action ForWhichValue); 

 AREA  TRANSFORMERTAPS  

 ZONE  SHUNTS  

   OFFAVR  

 

QVRun("filename", InErrorMakeBaseSolvable); 

Call the function to start a QV study for the list of buses whose SELECTED? field is set to YES. 

"filename" : This specifies the file to which to save a comma-delimited version of the 
results.  

InErrorMakeBaseSolvable : This specifies whether to perform a solvability analysis of the base case if 
the pre-contingency base case can not be solved.  If not specified, then 
YES is assumed. 

 

QVWriteResultsAndOptions("filename"); 

Call this action to save all the QV results and options in the auxiliary file "filename". 

 
RefineModel(objecttype, filter, Action, Tolerance); 

Call this function to refine the system model to fix modeling idiosyncrasies that cause premature loss of 
convergence during PV and QV studies. 

objecttype  : The objecttype being selected. 

AREA 

ZONE 

filter : There are three options for the filter: 

RefineModel(…, "", …);  : No filter specified means to select all objects of this type.   

RefineModel(…, "filtername", …);:  "filtername" means select those that meet the filter. 

Action : The way the model will be refined.  Choices are: 

TRANSFORMERTAPS Fix all transformer taps at their present values if their Vmax – Vmin is less 
than or equal to the user specified tolerance. 

SHUNTS Fix all shunts at their present values if their Vmax – Vmin is less than or 
equal to the user specified tolerance. 

OFFAVR Remove units from AVR control, thus locking their MVAR output at its 
present value if their Qmax – Qmin is less or equal to the user specified 
tolerance. 

Tolerance : Tolerance value. 

Data Section 
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Data Argument List 

The DATA argument list identifies what the information section contains.  A left and right parenthesis "(  )" mark the 
beginning and end of the argument list.   

The file_type_specifier parameter distinguishes the information section as containing custom auxiliary data (as 
opposed to Simulator’s native auxiliary formats), and indicates the format of the data.  Currently, the parser recognizes 
two values for file_type_specifier: 

(blank) or AUXDEF  Data fields are space delimited 

CSV, AUXCSV, or CSVAUX  Data fields are comma delimited 

 

The object_type  parameter identifies the type of object or data element the information section describes or models.  
For example, if object_type  equals BUS, then the data describes BUS objects.  Below is a list of many of the object 
types recognized by Simulator: 

Area DCTransmissionLine PartPoint 

ATC_Options Direction PVCurve_Options 

ATCExtraMonitor Equiv_Options QVCurve_Options 

ATCGeneratorChange Filter ReactiveCapability 

ATCInterfaceChange Gen Scale_Options 

ATCLineChange InjectionGroup Schedule 

ATCScenario Interface Shunt 

ATCZoneChange InterfaceElement Sim_Environment_Options 

BidCurve Limit_Monitoring_Options Sim_Misc_Options 

Branch LimitSet Sim_Simulation_Options 

Bus LimitViol Sim_Solution_Options 

ColumnInfo Load StudyMWTransactions  

Condition LoadScale Substation 

Contingency ModelCondition SuperArea 

Ctg_Options ModelFilter TransferLimiter 

CTGElement MSLine Transformer 

CustomExpression MWTransaction XFCorrection 

DataGrid OPF_Options Zone 

 OwnerObject  

 

The list of object types Simulator’s auxiliary file parser can recognize will grow as new applications for the technology 
are found.   Within Simulator, you will always be able to obtain a list of the available object_types by going to the 
main menu and choosing Help > Export Object Fields .   

The list_of_fields  parameter lists the types of values the ensuing records in the data section contain.  The order in 
which the fields are listed in list_of_fields  dictates the order in which the fields will be read from the file.  Simulator 
currently recognizes over 800 different field types, each identified by a specific field name.  Because the available 
fields for an object may grow as new applications are developed, you will always be able to obtain a list of the 
available object_types by going to the main menu and choosing Help > Export Obje ct Fields .  Certainly, only a 
subset of these fields would be found in a typical custom auxiliary file.  In crafting applications to export custom 
auxiliary files, developers need concern themselves only the fields they need to communicate between their 
applications and Simulator.  A few points of interest regarding the list_of_fields  are: 

• The list_of_fields  may take up several lines of the text file.   

• The list_of_fields  should be encompased by braces [  ]. 

• When encountering the PowerWorld comment string ‘//’ in one of these lines of the text file, all text to the right 
of this is ignored.   

• Blank lines, or lines whose first characters are ‘//’ will be ignored as comments. 

• Field names must be separated by commas. 

 

Example DATA Argument List 

DATA (BUS, [BusNomKV, Bus,  // comment here 

   ABCPhaseAngle:1,  ABCPhaseAngle:2,  ABCPhaseV,  ABCPhaseV:1,  
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   // comments allowed here to 

 

   // note that blank rows are ignored 

   AreaNum, BusAngle, BusB, BusCat, BusEquiv, BusG,  

   BusGenericSensV, BusKVVolt, BusLambda, BusLoadMVA, // more comment 

   BusLoadMW, BusLongName]) 

One general note regarding the field names however.  Some field names may be augmented with a field location.  
One example of this is the field LineMW.  For a branch, there are two MW flows associated with the line: one MW flow 
at the from bus, and one MW flow at the to bus.  So that the number of fields does not become huge, the same field 
name is used for both of these values.  For the from bus flow, we write LineMW:0, and for the to bus flow, we write 
LineMW:1.  Note that fieldnames such as LineMW:0 may simply leave off the :0. 
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Data Key Fields 

Simulator uses certain fields to identify the specific object being described.  These fields are called key fields.  For 
example, the key field for BUS objects is BusNum, because a bus can be identified uniquely by its number.  The key 
fields for GEN objects are BusNum and GenID.  To properly identify each object, the object’s key fields must be 
present.  They can appear in any order in the list_of_fields  (i.e. they need not be the first fields listed in 
list_of_fields ).  As long as the key fields are present, Simulator can identify the specific object.  By going to the main 
menu and choosing Help > Export Object Fields  you will obtain a list of fields available for each object type.  In this 
output, the key fields will appear with asterisks *. 
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Data List 

After the data argument list is completed, the Data list is given. The data section lists the values of the fields for each 
object in the order specified in list_of_fields .  The data section begins with a left curly brace and ends with a right 
curly brace.  A few points of interest regarding the value_list: 

• The value_list may take up several lines of the text file.   

• Each new data object must start on its own line of text. 

• When encountering the PowerWorld comment string ‘//’ in one of these lines of the text file, all text to the right 
of this is ignored.   

• Blank lines, or lines whose first characters are ‘//’ will be ignored as comments. 

• Remember that the right curly brace must appear on its own line at the end of the data_list. 

• If the file_type_specifier is CSV, the values should be separated by commas.  Otherwise, separate the field 
names using spaces. 

• Strings can be enclosed in double quotes, but this is not required.  You should however always enclose strings 
that contain spaces (or commas) in quotes.  Otherwise, strings containing commas would cause errors for 
comma-delimited files, and spaces would cause errors for space-delimited formatted files. 

Data SubData Sections  

Data SubData Sections 
The format described in the Data Section works well for most kinds of data in Simulator.  It does not work as well 
however for data that stores a list of objects.  For example, a contingency stores some information about itself (such 
as its name), and then a list of contingency elements, and possible a list of limit violations as well.  For data such as 
this, Simulator allows <SubData>, </SubData> tags that store lists of information about a particular object.  This 
formatting looks like the following: 

 

DATA (object_type,  [list_of_fields], file_type_specifier) 

{ 

value_list_1 

    <SUBDATA subobject_type1> 

      precise format describing an object_type1 

      precise format describing an object_type1 

      . 

      . 

      . 

    </SUBDATA> 

    <SUBDATA subobject_type2> 

      precise format describing an object_type2 

      precise format describing an object_type2 

      . 

      . 

      . 

    </SUBDATA> 

value_list_2 

   . 

   . 

   . 

value_list_n 

} 

Note that the information contained inside the <SubData>, </SubData> tags may not be flexibly defined.  It must be 
written in a precisely defined order that will be documented for each SubData type.    
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Data ColorMap 
ColorPoint 

A colorpoint is simply described by a real number (between 0 and 100) and an integer describing the color written 
on a single line of text 

cmvalue  cmcolor (Example: 100  56648) 

cmvalue : Real number between 0 and 100 (minimum to maximum value). 

cmcolor : Integer between 0 and 16,777,216.  Value is determined by taking the red, 
green and blue components of  the color and assigning them a value 
between 0 and 255.  The color is then equal to red + 256*green + 
256*256*blue. 

 

Example  

<SUBDATA ColorPoint> 

  // Value Color 

  100.0000 127 

   87.5000 255 

   62.5000 65535 

   50.0000 8388479 

   37.5000 16776960 

   12.5000 16711680 

    0.0000 8323072 

</SUBDATA> 
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Data Contingency 
CTGElement 

A contingency element is described by up to four entries.  All entries must be on a single line of text. 

 

"Action"   "ModelCrite ria"   Status   //comment  

Action : String describing the action associated with this element.  See below for 
actions available. 

ModelCriteria : This is the name of a ModelFilter or ModelCondition under which this 
action should be performed.  This entry is optional.  If it is not specified, 
then a blank (or no criteria) is assumed.  If you want to enter a Status, 
then use must specify "" as the ModelCriteria. 

Status : Three options  
    CHECK: perform action if ModelCriteria is true. 
    ALWAYS: perform action regardless of ModelCriteria. 
    NEVER: do not perform action. 
This entry is optional.  If it is not specified, then CHECK is assumed. 

Comment : All text to the right of the comment symbol (//) will be saved with the 
CTGElement as a comment. 

 

Possible Actions: 

Calling of a name ContingencyBlock 

CONTINGENCYBLOCK | name 

Calls a ContingencyBlock and executes each of the actions in that block. 

Transmission Line or Transformer outage or insertion 

BRANCH | bus1# bus2# ckt | OPEN 

    | CLOSE 

Takes branch out of service, or puts it in service. 

Series Capacitor Bypass or In Service 

SERIESCAP | bus1# bus2# ckt | BYPASS 

     | INSERVICE 

Interface outage or insertion 

INTERFACE | name | OPEN 

   | CLOSE 

Takes all monitored branches in the interface out of service, or puts them all in service 

Bus outage causes all lines connected to the bus to be outage 

BUS | bus# | OPEN 

Takes all branches connected to the bus out of service.  Also outages all generation, load, or shunts 
attached to the bus. 

Generator, Load, or Switched Shunt outage or insertion 

GEN | bus# id | OPEN 

LOAD | bus# id | CLOSE 

SHUNT | bus# 

Takes a generator, load, or shunt out of service, or puts it in service. 

Generator, Load or Switched Shunt movement to another bus  

GEN | bus1# | MOVE_PQ_TO | bus2# | value | MW 

LOAD | | MOVE_P_TO |   | PERCENT 

SHUNT | | MOVE_Q_TO | 

Use to move generation, load or shunt at a bus1 over to bus2.   

Generator, Load or Switched Shunt set or change a specific value 

GEN | bus#  | SET_P_TO | value | MW 

LOAD | | SET_Q_TO | | PERCENT 

SHUNT | | CHANGE_P_BY | 
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   | CHANGE_Q_BY | 

Use to set the generation, load, or shunt at a bus to a particular value.  Also can use to change by a 
specified amount. 

Injection Group set a specific value 

INJECTIONGROUP | name | SET_P_TO | value | MW 

       | PERCENT 

Use to set the MW generation/load in an injection group to a particular value. 

Injection Group change a specific value 

INJECTIONGROUP | name | CHANGE_P_TO | value | MW 

       | PERCENT 

       | MWOPENCLOSE 

       | PERCENTOPENCLOSE 

Use to change the MW generation/load in an injection group by a particular value.   Note that MW 
and PERCENT OPTIONS will change each point in the injection group by a value in proportion to the 
participations factors of the group.  MWOPENCLOSE and PERCENTOPENCLOSE will modify points 
in the injection group by closing or opening points in the group in order of descending participation 
factors until the total change greater than or equal to the requested change has been achieved. 

Make-Up Power Compensation. 

Only valid immediately following a SET, CHANGE, OPEN or CLOSE  action on a Generator, Shunt or 
Load. This describes how the change in MW or MVAR are picked up by buses throughout the 
system. The values specify participation factors  

COMPENSATION 

bus#1   value1 

bus#2   value2 

... 

END 

Example: 

<SUBDATA CTGElement> 

  // just some comments  

  // action                      Model Criteria   Status    comment 

  "BRANCH 40821 40869 1  OPEN" "" ALWAYS  //Raver - Paul 500 kV 

  "GEN 45041 1  OPEN" "" ALWAYS  //Trip Unit #2 

  "BRANCH 42702 42727 1  OPEN" "Line X Limited"  CHECK   //Open Fern Hill  

  "GEN 40221 1  OPEN" "Interface L1"    CHECK   //Drop ~600 MW 

  "GEN 40227 1  OPEN" "Interface L2"    CHECK   //Drop ~1200 MW  

  "GEN 40221 1  OPEN" "Interface L3"    CHECK   //Drop ~600 MW  

  "GEN 40227 1  OPEN" "Interface L3+"   CHECK   //Drop ~1200 MW 

</SUBDATA> 

 

LimitViol 

A LimitViol is used to describe the results of a contingency analysis run.  Each Limit Violation lists six values: 

ViolType  ViolElement  Limit  ViolValue PTDF PTDF 

ViolType : One of five values describing the type of violation  
BAMP: branch amp limit violation. 
BMVA: branch MVA limit violation. 
VLOW: bus low voltage limit violation. 
VHIGH: bus high voltage limit violation. 
INTER: interface MW limit violation. 

ViolElement : This field depends on the ViolType.   
for BAMP, BMVA: "bus1#  bus2# ckt violationbus#" 
for VLOW, VHIGH: "bus1#" 
for INTER: "interfacename" 

Limit : This is the numerical limit which was violated. 
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ViolValue : This is the numerical value of the violation. 

PTDF : This field is optional.  It only makes sense for interface or branch 
violations.  It stores a sensitivity of the flow on the violating element during 
in the base case with respect to a transfer direction   This must be 
calculated using the Contingency Analysis Other Actions related to 
Sensitivities. 

OTDF : This field is optional.  It only makes sense for interface or branch 
violations.  It stores a sensitivity of the flow on the violating element during 
this contingency with respect to a transfer direction.  This must be 
calculated using the Contingency Analysis Other Actions related to 
Sensitivities. 

Example: 

<SUBDATA LimitViol> 

  BAMP "1  3  1  1  FROMTO"   271.94031   398.48096   10.0   15.01   // Note OTDF/PTDF 

  INTER "Right-Top"   45.00000   85.84451   // Note OTDF/PTDF not included 

</SUBDATA> 

 

Sim_Solution_Options  

These describe the power flow solution options which should be used under this particular contingency.   The 
format of the subdata section is two lines of text.  The first line is a list of the fieldtypes for Sim_Solution_Options 
which should be changed.  The second line is a list of the values.  Note that in general, power flow solution options 
are stored at three different locations in contingency analysis.  When implementing a contingency, Simulator gives 
precendence to these three locations in the following order: 

• Contingency Record Options (stored with the particular contingency) 

• Contingency Tool Options (stored with CTG_Options) 

• The global solution options 
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Data ContingencyBlock 
CTGElement 

This format is the same as for the Contingency objecttype, however, you can not call a ContingencyBlock from 
within a contingencyblock. 
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Data CTG Options 
Sim_Solution_Options  

These describe the power flow solution options which should be used under this particular contingency.   The 
format of the subdata section is two lines of text.  The first line is a list of the fieldtypes for Sim_Solution_Options 
which should be changed.  The second line is a list of the values.  Note that in general, power flow solution options 
are stored at three different locations in contingency analysis.  When implementing a contingency, Simulator gives 
precendence to these three locations in the following order: 

• Contingency Record Options (stored with the particular contingency) 

• Contingency Tool Options (stored with CTG_Options) 

• The global solution options 
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Data Filter 
Condition 

Conditions store the conditions of the filter.  Each condition is described by one line of text which can contain up to 
five fields. 

 

Variablename      condition      "value"      ("othervalue")      (fieldopt) 

Variablename : It is one of the fields for the object_type specified.  It may optional be 
followed by a colon and a non-negative integer.  If not specified, 0 is 
assumed. 

  Example: on a LINE, 0 = from bus, 1 = to bus 

           Thus: LineMW:0 = the MW flow leaving the from bus 

                     LineMW:1 = the MW flow leaving the to bus  

Condition : Possible Values Alternate1 Alternate2 Requirements 

 between ><   requires other value 

 notbetween ~><   requires other value 

 equal = == 

 notequal <> ~= 

 greaterthan > 

 lessthan < 

 greaterthanorequal >= 

 lessthanorequal <= 

 contains 

 notcontains 

 startswith 

 notstartswith 

 inrange 

 notinrange 

value : The value to compare to.   

 For fields associated with strings, this must be a string 

 For fields associated with real numbers, this must be a number. 

 For fields associated with integers, this is normally an integer, except 
when the Condition is "inrange" or "notinrange".  In this case, value is a 
comma/dash separated number string. 

(othervalue) : If required, the other value to compare to. 

(FieldOpt) : Optional integer value with following meanings. 

 0 - strings are case insensitive, use number fields directly  

     (0 is the default value if not otherwise specified) 

 1 - strings are case sensitive, take ABS of field values 

Example: 

DATA (FILTER, [objecttype, filtername, filterlogic, filterpre]) 

{ 

BUS "a bus filter" "AND" "no" 

   <SUBDATA CONDITION> 

      BusNomVolt  >  100 

      AreaNum   inrange  "1-5 , 7 , 90-95" 

      ZoneNum   between 

   </SUBDATA> 

 

BRANCH "a branch filter" "OR" "no" 

   <subdata CONDITION> 
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      BusNomVolt:0  > 100    // Note location 0 means from bus 

      BusNomVolt:1  > 100    // Note location 1 means to bus 

      LineMW:0      > 100 1  // Note, final field 1 denotes absolute value 

   </SUBDATA> 

} 
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Data Gen 
BidCurve 

BidCurve subdata is used to define a piece-wise linear cost curve (or a bid curve).   Each bid point consists of two 
real numbers on a single line of text: a MW output and then the respective bid (or marginal cost). 

Example 

<SUBDATA BidCurve> 

  // MW   Price[$/MWhr] 

  100.00  10.6 

  200.00  12.4 

  400.00  15.7 

  500.00  16.0 

</SUBDATA> 

 

ReactiveCapability 

Reactive Capability subdata is used to the reactive capability curve of the generator.   Each line of text consists of 
three real numbers: a MW output, and then the respective Minimum MVAR and Maximum MVAR output 

Example 

<SUBDATA ReactiveCapability> 

  // MW        MinMVAR   MaxMVAR 

    100.00    -60.00         60.00 

    200.00    -50.00         50.00 

    400.00    -30.00         20.00 

    500.00      -5.00           2.00 

</SUBDATA> 
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Data MultiSectionLine 
Bus 

A multi section line’s subdata contains a list of each dummy bus, starting with the one connected to the From Bus of 
the MultiSectionLine and proceeding in order to the bus connected to the To Bus of the Line. 

Example 

//----------------------------------------------------------------------------------------------------------- 

//  The following describes a multi-section line that connnects bus  

//    2  -  1  -  5  -  6  -  3 

//------------------------------------------------------------------------------------------------------------ 

DATA (MultiSectionLine, [BusNum, BusName, BusNum:1, BusName:1, 

                                         LineCircuit, MSLineNSections, MSLineStatus] ) 

{ 

2 "Two" 3 "Three" "&1" 2 "Closed" 

   <SUBDATA Bus> 

     1 

     5 

     6 

   </SUBDATA> 

} 
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Data InjectionGroup 
PartPoint 

A participation point is used to describe the contents of an injection group.  Each participation point lists six values: 

PointType   PointBusNum   PointID   PointParFac   ParFacCalcType   ParFacNotDynamic 

PointType : One of two values describing the type of violation: 
GEN: a generator 
LOAD: a load 

PointBusNum : The bus number of the partpoint. 

PointID :  The generator or load id for the partpoint. 

PointParFac : The participation factor for the point. 

ParFacCalcType : How the participation point is calculated.  There are several options 
depending on the PointType. 

 Generators: SPECIFIED, MAX GEN INC, MAX GEN DEC, or MAX 
GEN MW 

 Loads: SPECIFIED, or LOAD MW 

ParFacNotDynamic: Should the participation factor be recalculated dynamically as the system 
changes. 

 

Example : 

<SUBDATA PartPoint 

  "GEN"    1   "1"       1.00   "SPECIFIED"         "NO" 

  "GEN"    2   "1"       5.00   "SPECIFIED"         "NO" 

  "GEN"    4   "1"   104.96   "MAX GEN INC"    "NO" 

  "GEN"    6   "1"     50.32   "MAX GEN DEC"  "YES" 

  "GEN"    7   "1"   600.00   "MAX GEN MW"    "NO" 

  "LOAD" 2   "1"        5.00   "SPECIFIED"         "NO" 

  "LOAD" 5   "1"    130.00   "LOAD MW"         "NO" 

  "LOAD" 6   "1"    200.00   "LOAD MW"         "YES" 

</SUBDATA> 



Printed Documentation 

664 

Data Interface 
InterfaceElement 

An interface’s subdata contains a list of the elements in the interface.  Each line contains a text description of the 
interface element.  Note that this text description must be encompassed by quotation marks.  There are five kinds of 
elements allowed in an interface.  Please note that the direction specified in the monitoring elements is important. 

"BRANCH num1 num2 ckt"  Monitor the MW flow on the branch starting from bus num1 going to bus 
num2 on the branch this branch. 

"AREA num1 num2" Monitor the sum of the tie line MW flows from area num1 to area num2. 

"ZONE num1 num2" Monitor the sum of the tie line MW flows from zone num1 to zone num2. 

"BRANCHOPEN num1 num2 ckt" When monitoring the elements in this interface, monitor them under the 
contingency of opening this branch. 

"BRANCHCLOSE num1 num2 ckt" When monitoring the elements in this interface, monitor them under the 
contingency of closing this branch. 

For the interface element type "BRANCH num1 num2 ckt", an optional field can also be written specifying whether 
the flow should be measured at the far end.  This field is either YES or NO. 

 

Example  

<SUBDATA InterfaceElement 

  "BRANCH   8    9   1"   NO   // monitor the flow from bus 8 to bus 9 on this branch 

 

  "BRANCH   12   33   1"   YES   // monitor the flow from bus 12 to bus 33 on branch 

                                                   // measurefarend is set to true, therefore, we are  

                                                   // monitoring the MW flow that arrives at bus 33 

 

  "AREA    2   1"       // monitor tie line flow from area 2 to area 1 

  "ZONE   66   53"       // monitor tie lines flows from zone 66 to zone 53 

  "BRANCHOPEN   5   6   1"   // doe monitoring after branch opens 

  "BRANCHCLOSE   7   10   1"   // doe monitoring after branch closes 

</SUBDATA> 
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Data ModelCondition 
Condition 

ModelConditions are the combination of an object and a Filter.  They are used to return when the particular object 
meets the filter specified.  As a results, the subdata section here is identical to the Condition subdata section of a 
Filter.  See the description there. 
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Data ModelFilter 
Mode lCondition 

A Model Filter’s subdata contains a list of each ModelCondition in the it.  Because a list of Model Conditions is 
stored within Simulator, this subdata section only stores the name of each ModelCondition on each line. 

 

Example  

<SUBDATA ModelCondition> 

  "Name of First Model Condition"  

  "Name of Second Model Condition"  

  "Name of Third Model Condition"  

</SUBDATA> 
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Data Owner 
Bus 

This subdata section contains a list of the buses which are owned by this owner. Each line of text contains the bus 
number. 

Example 

<SUBDATA Bus> 

   1 

  35 

  65 

</SUBDATA> 

 

Load 

This subdata section contains a list of the loads which are owned by this owner.  Each line of text contains the bus 
number followed by the load id. 

Example 

<SUBDATA Load> 

    5 1  // shows ownership of the load at bus 5 with id of 1 

  423 1 

</SUBDATA> 

 

Gen 

This subdata section contains a list of the generators which are owned by this owner and the fraction of ownership.  
Each line of text contains the bus number, followed by the gen id, followed by an integer showing the fraction of 
ownership. 

Example 

<SUBDATA Gen> 

  78 1  50  // shows 50% ownership of generator at bus 78 with id of 1 

  23 3  70 

</SUBDATA> 

 

Branch 

This subdata section contains a list of the branchs which are owned by this owner and the fraction of ownership.  
Each line of text contains the from bus number, followed by the to bus number, followed by the circuit id, followed by 
an integer showing the fraction of ownership. 

Example 

<SUBDATA Branch> 

  6  10  1  50  // shows 50% ownership of line from bus 6 to 10, circuit 1 

</SUBDATA> 
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Data DataGrid 
ColumnInfo 

Contains a description of the columns which are shown in the respective data grid.  Each line of text contains four 
fields: VariableName,   ColumnWidth,   TotalDigits,   DecimalPoints  

Variablename : Contains the variable which is shown in this column. 

ColumnWidth : The column width. 

TotalDigits : The total digits displayed for numerical values. 

DecimalPoints : The decimal points shown for numerical values. 

 

Example  

DATA (DataGrid, [DataGridName]) 

{ 

   BUS  

   <SUBDATA COLUMNINFO> 

     BusNomVolt   100   8   2 

     AreaNum           50   8   2 

     ZoneNum          50   8   2 

   </SUBDATA> 

 

   BRANCHRUN 

   <subdata COLUMNINFO > 

      BusNomVolt:0  100   8   2 

      BusNomVolt:1  100   8   2 

      LineMW:0          100   9   3  

   </SUBDATA> 

} 
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Data ATCScenario 
TransferLimiter 

This subdata section contains a  list of the TransferLimiters for this scenario.  Each line contains fields relating one 
of the Transferlimiters.  The fields are writen out in the following order: 

 

Limiting Element : Contains a description of the limiting element.  The possible values are 

   "PowerFlow Divergence" 

   "AREA num" 

   "SUPERAREA name" 

   "ZONE num" 

   "BRANCH num1 num2 ckt" 

   "INJECTIONGROUP name" 

   "INTERFACE name" 

Limiting Contingency : The name of the limiting contingency. If blank, then this means it’s a 
limitation in the base case. 

MaxFlow : The transfer limitation in MW. 

PTDF : The PTDF on the limiting element in the base case (not in percent). 

OTDF : The OTDF on the limiting element under the limiting contingency. 

LimitUsed : The limit which was used to determine the MaxFlow in per unit. 

PreTransEst : The estimated flow on the line after the contingency but before the 
transfer in per unit. 

MaxFlowAtLastIteration : The total transfer at the last iteration in per unit. 

IterativelyFound : Either YES or NO depending on whether it was iteratively determined. 

 

Example  

<SUBDATA TransferLimiter > 

  "BRANCH 40767 42103  1" "Contin"  2.84 -0.0771 -0.3883 -4.35 -4.35 -0.01 "-55.88" YES 

  "BRANCH 42100 42321  1" "Contin"  4.42  0.1078  0.5466  6.50  5.64  1.57 " 22.59" NO  

  "BRANCH 42168 42174  1" "Contin"  7.45 -0.0131 -0.0651 -1.39 -1.09  4.60 "-33.31" NO  

  "BRANCH 42168 42170  1" "Contin"  8.54  0.0131  0.0651  1.39  1.02  5.69 " 26.10" NO  

  "BRANCH 41004 49963  1" "Contin"  9.17 -0.0500 -0.1940 -4.39 -3.16  6.32 " 68.73" NO  

  "BRANCH 46403 49963  1" "Contin"  9.53  0.0500  0.1940  4.46  3.16  6.68 "-68.68" NO  

  "BRANCH 42163 42170  1" "Contin" 10.14 -0.0131 -0.0651 -1.39 -0.92  7.29 "-15.58" NO  

</SUBDATA> 

 

ATCExtraMonitor 

This subdata section contains a list of the ATCExtraMonitors for this scenario.  Each line contains three fields 
relating one of the ATCExtraMonitors.  The first field describes the ATCExtraMonitor which this subdata 
corresponds to.  The second and third variables are the initial value and sensitivity for this extra monitor for the 
scenario.  An option fourth field may be included if we are using one of the iterated ATC solution options.  This field 
must be the String "ATCFlowValue". 

Monitor Description : Contains a string describing which monitor this belongs to. 

Initial Value : Contains the value for this extra monitor at the last linear iteration. 

Sensitivity : Contains the sensitivity of this monitor. 

ATCFlowValue : A string which signifies that a block will follow which stores a list of flow 
values for specified transfer levels.  Each line of the block consists of two 
values: Flow Value (flow on the monitored element) and a Transfer Level 
(in MW).  The block is terminated when a line of text that starts with ‘END’ 
is encountered. 

Example  

<SUBDATA ATCExtraMonitor> 

  "Interface<KEY1>Left-Right</KEY1>"                                              40.0735     0.633295 
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  "Branch<KEY1>2</KEY1><KEY2>5</KEY2><KEY3>1</KEY3>"    78.7410     0.266589  

</SUBDATA> 



Auxiliary Script/Data Files 

671 

Data Schedule 
LoadScale  

This subdata section contains a list of load schedule points.  Each line of text contains two values, the time and the 
load multiplier. 

 

Example  

<SUBDATA LoadScale> 

    0  1.0 

  35  1.5 

  65  1.2 

</SUBDATA> 
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Data SuperArea 
SuperAreaArea 

This subdata section contains a list of areas within each super area.  Each line of text contains two values, the area 
number followed by a participation factor for the area that can be optionally used. 

 

Example  

<SUBDATA  SuperAreaArea> 

    1               48.9 

    2               34.2 

  25               11.2 

</SUBDATA> 
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PowerWorld Simulator Project Files 

Chapter 14 : PowerWorld Simulator Project Files 

PowerWorld Project Files provide the user an easy way consolidate and manage files from any application, including 
PowerWorld binary and display files. 

This chapter covers the following: 

• Overview of PowerWorld Simulator project files 

• PowerWorld Project initialization script 

• Creating a new project file 

• Opening an existing project 

• Associating project files with simulator 

Overview 

Overview of PowerWorld Simulator Project Files 

Performing a simulation using PowerWorld Simulator sometimes requires using a number of different files.  In addition 
to the case file that stores the model of the system, there may be one or more oneline diagrams depicting various 
regions of the system.  These oneline diagrams might feature document links that connect to files that were created 
using other applications, as well as oneline links, which open other oneline diagrams when they are clicked.  For these 
links to function properly, the documents and oneline displays to which they connect must be available.  A simulation 
might also employ a template file that is used to load in a predefined set of solution, environment, and display options.  
Furthermore, the simulation might make use of data stored in auxiliary data files to supplement the data stored in the 
case file.  Finally, a simulation might utilize a script file to perform some automated sequence of tasks, or even to 
display a movie of system conditions.  Having to deal with so many files may make it difficult to transfer the case to 
another computer, or to share the model with a colleague.  PowerWorld Simulator Project files provide a solution. 

PowerWorld Simulator Projects have the extension *.pwp.  A project serves as a container for all the files that might 
comprise a simulation, including the case file, one or more oneline diagrams, a script file, one or more auxiliary data 
files, and a case template, as well as any other support files you may wish to include.  A project is actually a 
compressed file archive that is compatible with the widely available PKZip and WinZip file compression utilities.  It is 
strongly recommended, however, that you work with project files strictly within the PowerWorld Simulator environment, 
as Simulator can automatically perform the file compression and extraction functions and process the contents of the 
included files in a single step. (Note:  Simulator performs file compression and extraction using software components 
available from http://www.cdrom.com/pub/infozip/ and http://www.geocities.com/SiliconValley/Orchard/8607/ 
main.html). 
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PowerWorld Project Initialization Script 

Included in every project file is an initialization script file called OPENPWB.SCP.  This is a special type of PowerWorld 
script file that is used to unload the contents of the project that are used in the simulation.  This file must begin with the 
keyword "INITIALIZATION" and terminate with the keyword "END".  Between these two lines, OPENPWB.SCP 
identifies the name of the case, any oneline diagrams that should be opened immediately, a template file (if any), a 
script file (if any), and one or more auxiliary data files (if any) to open and read into memory after extracting the files.  
The file might also contain the keyword "AUTOSTART", indicating that the simulation of the system described by the 
project file should commence immediately after it is read into memory.  The OPENPWB.SCP is generated for you 
automatically when you save a new project file.  Here is an example that loads the case B7FLAT.PWB (in PowerWorld 
binary format) along with oneline diagram B7FLAT.PWD, the template B7FLAT.PWT, the script B7FLAT.SCP, and the 
auxiliary file B7FLAT.AUX, and then starts the simulation immediately after all contents are extracted and read: 

 

INITIALIZATION 

CASE PWB B7FLAT.PWB 

ONELINE B7FLAT.PWD 

TEMPLATE B7FLAT.PWT 

SCRIPT B7FLAT.SCP 

DATAFILE B7FLAT.AUX 

AUTOSTART 

END 

 

Again, all projects must contain the file OPENPWB.SCP.  If a project does not contain this file, an error message will 
be shown.  Simulator automatically includes an OPENPWB.SCP file with every project it creates.  Therefore, unless 
you try to create a project file outside of Simulator, you will not have to worry about this requirement. 
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Associating Project Files With Simulator 

PowerWorld Simulator can automatically open and load the contents of a project if the proper file associations have 
been made.  When Simulator is installed on a computer, it registers the file extension *.pwp in the Windows registry.  
Then, whenever you double-click on an icon for a project file or download a project file from a web site, Simulator will 
start, extract the contents of the project file, and read them into memory.  The power system will then be displayed 
exactly as the author of the project file intended it to be displayed. 

If the file association is somehow destroyed (i.e. Windows no longer recognizes that *.pwp files should be associated 
with and opened by Simulator), you can re-establish the association manually using the following procedure: 

 

• Open Windows Explorer. 

• Select View, Folder Options from Explorers main menu. 

• Switch to the tab labeled "File Types." 

• Click the button labeled "New Type." 

• For "Description of Type," specify "PowerWorld Project." 

• For "Associated Extension," specify "PWP". 

• For "ContentType (MIME)," specify "application/powerworld_project." 

• For "Default Extension," specify ".PWP". 

• Under "Actions," click the button labeled "New." 

• Specify the "Action" as "open." 

• Specify the "Application used to perform action" as the path to the Simulator executable file, followed by a space 
and the string "%1" (including the quotation marks).  For example, if the path of the PowerWorld Simulator 
executable is "c:\program files\PowerWorld\pwrworld.exe," then you should specify the following string: 
   c:\program files\PowerWorld\pwrworld.exe "%1" 

• Click OK to close the Action dialog. 

• Click OK to complete the definition of the file association. 

 

The *.pwp file type will now be recognized on your system as being associated with PowerWorld Simulator.  Again, 
you will need to perform this procedure only if the association somehow gets removed. 

Creating a Project File 

Creating a New Project File 

Creating a new project file in Simulator is fairly simple.  First, make sure that the case for which you want to create the 
project is open in Simulator, as well as any oneline diagrams  that you wish to open automatically whenever the user 
opens the project.  Then select File > Save As Project from the main menu.  This opens the Create Project Dialog, 
which you can use to specify the contents of the project file.  When you click OK on the Create Project Dialog, the files 
you identified will be compressed into a single file, along with the project initialization script that tells Simulator how it 
should import the contents of the project. 
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Create Project Dialog 

The Create Project Dialog enables you to create a new PowerWorld Simulator Project by specifying the files that 
should be included in the project.  To open the Create Project Dialog, select File > Save As Project from the main 
menu.  When it opens, the dialog will automatically include the case file, all open oneline diagrams, all documents and 
onelines linked to the display by document links and oneline links, the current case template file, and the current script 
in its list of files to add to the project.  You can then use this dialog to add files to or delete files from the list of project 
contents. 

 

The Create Project Dialog features the following controls: 

Case 

Identifies the name of the case file that is currently open in Simulator.  The case file may be in PowerWorld binary 
format, in PTI Version 23 - 29 .raw format, or in GE PSLF .epc format.  You cannot change this field, because it 
must be set to whatever case is currently open. 

Open these oneline diagrams automatically 

Lists the names of the oneline diagrams that will automatically open whenever a user opens the project file.  This is 
also a read-only control and lists the names of all oneline diagrams that are currently open in Simulator.  Therefore, 
before you start to create a project using the Create Project dialog, make sure that only those oneline diagrams you 
wish to open automatically with the project are currently open in Simulator. 

Apply this template  

Identifies a case template file that should be applied automatically when the project is open.  Case templates store 
predefined sets of solution, environment, and display options.  Including a template in a project ensures that the end 
user will see the Simulation exactly the way you see it on your computer.  If your environment is set up to use a 
default template, the name of the default template will automatically appear in this text box.  To specify a different 
template file, either type its full path in the text box, or press the adjacent Browse button to search for it on your 
machine. 

Use this script file  

Identifies a script file that should be opened automatically when the project is open.  Scripts are text files that 
contain commands in PowerWorld's scripting language that Simulator interprets to perform a predefined set of tasks 
during the simulation.  If a script file is in use when you try to create the project, its name will automatically appear in 
this text box.  To specify a different script file, either type its full path in the text box, or press the adjacent Browse 
button to search for it on your machine. 

Load data from auxiliary files 

Lists the auxiliary data files that should be automatically read when the project is open.  A uxiliary data files are text 
files that contain data that supplement or supersede the information in the case file.  You may include as many 
automatically loading auxiliary data files in the project as you like.  To add an auxiliary file to the project contents, 
click the adjacent Add button and locate the file on your machine.  To remove an auxiliary file from the list, select it 
and click the adjacent Remove button. 

Also include these files 

Lists any other files you may wish to include in the project.  Use this control to include supplementary documents, 
pictures, or even other PowerWorld project files, in the project.  To add a file to the contents, click Add a File.  To 
remove a file from the list, select it and press the adjacent Remove button. 

Automatically start the simulation after opening the project 

Check this button to cause Simulator to start the simulation immediately after opening the project.  This saves the 
user who opens the project the step of switching to run mode and clicking Simulation > Play from the main menu.  
This option is particularly effective, for example, if you want to display a "movie" of system conditions when the 
project is open.  By including a script file in the project that tells Simulator how to modify the system and view over 
time, you create a project that, when opened or downloaded, animates the scenario you are trying to model. 

Save this project as  

Identifies the name of the project that should be saved.  By default, the project name is the same as that of the case 
except that it has the extension "pwp".  To specify a different name, either type it directly in the text box, or click the 
adjacent Browse button and specify the full path. 

When you have finished specifying the contents of the project file, click the OK > Save the Project button.  If you wish 
to cancel the operation without creating the project, click Cancel. 

Opening a Project File 

Opening an Existing Project 

To open an existing PowerWorld Simulator Project file, select File > Open Project from the main menu, and select the 
name of the project you wish to open.  Alternatively, you may select File > Open Case from the main menu, change 
the Files of Type setting to "PowerWorld Project (*.pwp)," and select the project you wish to open.  Simulator will 
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extract the contents of the project file and input the information it needs to display the case, oneline diagrams, and 
other associated files. 
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Web Publishing 

Chapter 15 : Web Publishing 

Simulator presents several tools for saving a variety of data in a web-friendly format.  You can save images as jpeg 
files, and all case information displays can be saved as HTML tables.  You c an then integrate these files into a single 
web document using Simulator’s HTML editor.  Finally, you can upload the HTML document, together with any 
necessary attachments, to your web server. 

This chapter covers the following: 

• Web Publishing Overview  

• Saving Case Information Displays as HTML Tables 

• Saving Images as JPEGs 

• PowerWorld Simulator’s HTML Editor 

• The Publish to Web Dialog Box 
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Web Publishing Overview 

The best way to use the web publishing functionality is to follow these steps: 

• Save all case information display contents you wish to publish on the web to separate HTML files.  See Saving 
Case Information Display Contents as HTML Tables for details. 

• Save all oneline diagrams and strip charts you wish to publish as jpeg files.  See Saving Images As Jpegs for 
details. 

• Launch the web publishing editor by selecting File, Publish to Web from the main menu.  Use its tools to add 
content to either an existing document or a brand new document.  You can insert the HTML code produced by 
saving the case information displays as HTML tables using the editor, and you can add links to the images you 
have saved as jpegs to the document, as well. 

• Upload the main document, together with any attachments, to your web server using Simulator's built in ftp 
functionality. 

Saving HTML Pages in Simulator 

Saving Case Information Display Contents as HTML Tables 

Simulator's Case Information Displays allow you to save their contents as HTML tables for display on the world-wide 
web.  To do this, right-click on any row of the table and select Save As HTML from the resulting local menu.  This 
brings up the Table Format Dialog.  Set the various table formatting options and click OK.  Then, select the name of 
the file to which to save the HTML code.  Finally, if a region of the table was selected, you will be asked if you want to 
save just the selected region as HTML.  Indicate Yes to convert just the selected portion of the table, or click No to 
write the entire table as HTML. 
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HTML Table Format Dialog 

The Table Format Dialog allows you to set various formatting options for HTML tables.  This form is invoked when you 
try to save a Case Information Display as HTML and when you try to insert a new table using Simulator's HTML editor. 

 

The Table Format Dialog is divided into two tabs, Table Properties and Table Elements . 

 

Table Properties 

This tab allows you to specify values for options that govern the appearance of the table as a whole.  Here you can 
specify the following properties: 

Border Weight 

The thickness of the border to draw around each cell.  Specify 0 to suppress the drawing of a cell border. 

Horizontal Cell Spacing 

The spacing to employ between cells that neighbor each other horizontally. 

Vertical Cell Spacing 

The spacing to employ between cells that neighbor each other vertically. 

Table Width 

The width of the table.  If the Percent checkbox is checked, the width specifies the horizontal dimension of the table 
relative to the object that contains it on the screen. 

Caption 

The table title that will be printed directly above it on the web page. 

 

Table Elements  

These options control how the data will be centered in each cell.  Choices include: 

Horizontal Alignment 

Controls how the text in each cell should be positioned horizontally.  The default value is Left, but you may also 
choose to center or right-justify the data in each cell. 

Vertical Alignment 

Controls how the text in each cell should be positioned vertically.  The default value is Middle, but you may also 
choose to align the text with the top or bottom edges of the cell. 

If any of the numeric entries (Border Weight, Horizontal Cell Spacing, Vertical Cell Spacing, Table Width) are left blank 
or zero, your browser will employ its def ault settings for these values in rendering the table on the screen. 
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Saving Images as Jpegs  

Simulator can save oneline diagrams, bus view displays, and strip charts as jpeg images.  To save a oneline diagram 
or bus view display as a jpeg, select File > Export Oneline  from the main menu.  This brings up the save file dialog 
where you can specify file type from the dropdown menu.  Choose jpeg, type the file name, and press save.  This 
brings up the resolution screen where you decide the picture's resolution.  Adjust the resolution control to specify the 
compression ratio at which to save the diagram as a jpeg.  The greater the resolution you specify, the larger the 
resulting file will be.  Click Save to save the image or click Cancel to terminate the process without saving the image 
as a jpeg. 

To save a strip chart as a jpeg image, right-click on the background of the strip chart and select Save As Jpeg from 
the resulting local menu.  Specify the compression/resolution in the Jpeg Options Dialog.  Click Cancel to terminate 
the process, or click Save  to save the jpeg to a file whose name you specify. 

Editing HTML Pages 

HTML Editor 

To compose a web page using Simulator's HTML editor, select File > Publish to Web from the main menu.  This 
opens the PowerWorld HTML Editor.  The editor provides basic web page formatting functionality.  It is not intended to 
compete with commercial packages that offer this as one of their primary functions, but it does give you tools for 
writing simple HTML pages that integrate the various resources you have produced using Simulator. 

The web editor's window is divided into two sections.  A set of command buttons occupies the left third of the display, 
and the HTML code for the document you are creating is shown in the text editor occupying the rest of the window.  
Use the command buttons to add HTML tags to the document at the current cursor location.  The command buttons 
are divided into several groups. 

 

Title  

Press the title button to specify a title for the web page.  The title must be specified in the head section of the page. 

Heading1 through Heading 5 

Simulator's HTML editor allows you to apply formatting for five different heading styles.  The actual appearance of 
each heading style depends on your browser's settings.  The Heading 1 and Heading 3 styles are generally used to 
format main section and subsection headings, respectively. 

Character Formatting 

Use the Bold, Italic, Underline, Plain, Font Color, and Font Size buttons to apply various formatting styles to 
portions of your document's text. 

Comment 

Specify the comment text using the Comment command button. 

Links and Images 

To insert a hypertext link into the web document, click the Link  button.  This brings up the HTML Link Properties 
Dialog.  To insert an image into the document, click the Image  button.  This brings up the HTML Image Properties 
Dialog.  Fill out the requested information to add the link or image to the main document. 

Page Spacing 

Use the Break , Paragraph, Rule , and Center buttons to define the spacing of text in the document.  Break inserts 
a hair line break; paragraph identifies a new paragraph, Rule  inserts a straight line that spans the screen to 
separate different portions of the document, and Center centers the text horizontally on the screen. 

List 

The next three command buttons allow you to specify elements of either numbered or bulleted lists.  Use the List 
(1,2,3) button to define a numbered list, and use the List (*) button to define a bulleted list.  This creates the list's 
skeleton.  You can then fill the list skeleton with one or more list items by clicking the Element button. 

Table  

The four buttons in the Table section allow you to create a table from scratch.  To define the table, click the Table 
command button.  This brings up the Table Format Dialog, which allows you to specify the border weight, horizontal 
cell spacing, vertical cell spacing, table width, and caption.  To have the browser employ its default settings in 
drawing the table, leave these options blank or set them to zero. 

To insert a header row for the table, click the Header command button.  This brings up the Table Format Dialog, 
which allows you to specify the vertical and horizontal positioning of the text in the header row. 

To insert a row in the body of the table, click the Row command button.  This brings up the Table Format Dialog, 
which allows you to specify the vertical and horizontal positioning of the text in the body row. 

Finally, to insert data into the table, click Cell.  This brings up the Table Format Dialog, which you can use to control 
the vertical and horizontal placement of text in the cell. 
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In defining the vertical and horizontal positioning of table text, cell-specific settings take precedence over row -
specific settings.  If no cell-specific settings are provided, however, those of the corresponding row are applied. 

 

In addition to composing a web document from scratch, you can also load an existing document or insert text from an 
existing document into your new document.  Choose File > Load from the editor's main menu to select an existing 
HTML document to load into the editor window.  To insert code from another document at the current cursor location in 
the document you are creating (say, for example, to insert the html code for a table you created from a case 
information display), select File > Insert from the editor's main menu and select the file whose contents you wish to 
insert. 

To save your new web document to your hard drive, click File > Save  from the editor's main menu, and specify the file 
name you desire.  To see how your document appears in your system's default browser, choose File > Test from the 
editor's main menu.  (If you have not already done so, you will be asked to save the document locally before the test 
will begin.) 

To publish the document on your web server, choose File > Publish from the editor's main menu.  If you have not yet 
saved the document to your hard drive, you will first be asked to save it.  After that, Simulator will open the Publish to 
Web Dialog.  Use this dialog to set up and launch the transfer of the new document and its attachments (if any) to your 
web server.   

To exit the web publishing editor, click File > Close from its main menu. 
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HTML Link Properties Dialog 

To insert a hypertext link in the web document, click the Link  button on the HTML Editor.  This brings up the HTML 
Link Properties Dialog, which sports the following fields: 

 

Descriptive Text 

Specifies the text of the label on which the user will click. 

Web Address 

Specifies the destination address of the link; that is, the address of the location to which the hypertext is linked. 

Upload This Local Copy 

If the web page to which the document is linked resides on your local drive and you wish to send it to the web 
server along with the main document, check the Upload This Local Copy checkbox.  Then, in the adjacent text box, 
specify the full local path of the linked document.  Use the Browse button to find the document on your local drive if 
you would like.  Also, specify whether the linked document is ASCII or Binary. 

 

Click OK to finish inserting the hypertext link in the document you are composing.  Click Cancel if you do not wish to 
add the link to the page. 
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HTML Image Properties Dialog 

To insert an image into the document, click the Image command button on HTML Editor.  This brings up the HTML 
Image Properties Dialog, which requests the following information: 

 

Image Address 

Specify the web address of the picture you want to display. 

Upload This Local Copy 

Check this box to identify a file on your local PC that contains the image you are trying to insert.  Provide the full 
local path of the image file in the adjacent text box.  Use the Browse button to find the file on your local drive if you 
would like. 

Width, Height, Border Size, Vertical Spacing From Text, Horizontal Spacing From Text 

Use these controls to specify various display parameters for the image.  Specify any value as zero if you would like 
to employ the browser's default setting for that option in rendering the image. 

Alignment 

Defines how the image will be aligned relative to the surrounding text. 

 

Click OK to finish inserting the link to the image in the document you are composing.  Click Cancel if you do not wish 
to add the image to the page. 

Publishing Pages to a Web Server 

Publish to Web Dialog 

The Publish to Web Dialog allows you to send the document you have created using Simulator's HTML Editor, along 
with any attachments, to your web server.  This dialog has two tabs, one labeled Documents , and the other labeled 
Server. 

The Documents Tab identifies the document to upload and its attachments.  It contains the following controls: 

 

Local Path 

Identifies the location of the document you have just written on the local drive. 

Full URL 

Specifies the full URL to assign to the page.  The full URL is used to determine where on the web server to place 
the document.  Therefore, be sure to include the base address of your web server in the Full URL specification.  For 
example, if the page you have created is to be accessed from the PowerWorld website using the name mydoc.htm, 
specify the full URL path as http://www.powerworld.com/mydoc.htm. 

Attachments  

The Publish to Web Dialog provides a table identifying the other documents that are to be sent along with the main 
document.  These other documents might include web pages that are linked to the main document you are 
uploading, or they might be images.  To add an attachment to the attachments list, click the Add New  button and fill 
out the Define New Attachment form.  To delete an attachment from the list, click on the row of the attachment you 
wish to delete and click the delete key on your keyboard.  To toggle the data type of an attachment listed in the 
Attachments table, double-click on the attachment's Type column.  To toggle whether or not a specific column 
should be uploaded to the server, double click on the attachment's Upload column.  To use the set of attachments 
associated with a previously published document, click the Load Attachments From File  button.  This will allow 
you to select a file identifying the attachments defined as part of a previous web publishing exercise.  Such files are 
stored automatically w ith a .met extension whenever you upload a document to the web. 

 

The Server Tab allows you to specify several parameters concerning how your web server is configured and 
accessed.  The Server Tab hosts the following controls: 

 

User ID, Password 

Specify the user ID and corresponding password with which you access your web server's documents directory. 

Hostname 

Indicate the machine name of your web server.  Alternatively, you may specify the server's IP address. 

Port 
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Supply the number of the port on which the server will be listening for incoming documents.  If you do not know this 
information, your best bet is to leave this field blank. 

Base URL and Corresponding Directory 

The base URL is the base, or root, address of your website.  This address corresponds to the root of the directory 
structure in which your site's web documents are stored, which is specified using the Corresponding Directory field.  
Be sure to specify the full path of the Corresponding Directory.  The main document's full URL, the remote host's 
base URL, and the remote host's corresponding directory are used together to determine where to place the 
document you are uploading and its attachments.  For example, suppose the new document's desired URL is 
www.powerworld.com/cases/today.htm.  Furthermore, suppose the base URL for my web server is 
www.powerworld.com, and that the root directory for storing HTML documents on this server is /my/web/directory.  
Then, you should specify www.powerworld.com as the server's base URL, and /my/web/directory as the host's 
corresponding directory.  As a result, the new document will be uploaded to the remote host that it will be placed in 
the remote host's /my/web/directory/cases directory.  In other words, a new document will be created on the remote 
host called /my/web/directory/cases/today.htm.  If any part of the remote path does not exist, Simulator will attempt 
to create it. 

 

To upload the document to the server, click the Upload button.  The text box in the lower right corner of the dialog will 
document what transpires during the communication with the remote server.  When the file transfer is complete, a log 
identifying whether the main document and its attachments were transferred successfully and, if not, the reason for the 
failure. 

To abort the web publishing activity, click Cancel.  To close the dialog box at any time, click Close.  
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Defining New Web Attachments  

Web attachments are files that you want to send to the web server with the master document you have composed 
using Simulator's HTML Editor  Attachments might be jpeg images or other web pages to which the master document 
will link.  The Publish to Web document lists your master document's attachments in a grid labeled Attachments .  To 
add a new web attachment to this list, click the Add New button.  This brings up the Define New Attachment Dialog, 
which requests the following entries: 

 

Local Path 

The local path locates the document or file on your local drive.  Use the Browse button to search for the attachment 
if you would like. 

Desired WWW Address 

The address by which the attachment will be accessed over the world-wide web.  Be sure to provide a complete 
URL in this box (including the server's base address) so that Simulator can determine in which directory on the host 
to place the attachment. 

Data Type  

Identify the attachment's data as being either ASCII or binary. 

 

Click OK to add the new attachment, or click Cancel to close the dialog without adding the attachment. 
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Web Publishing Status  

The Web Publishing Status Dialog documents whether the Simulator was able to transfer each of the files that 
comprise the web document you are publishing to your web server.  Each line of the text box displayed on the Web 
Publishing Status Dialog lists the web address the document will have if it has been uploaded successfully, whether 
or not it was uploaded successfully, and, if not, the reason for the failure.  Any document that was not uploaded 
successfully will likely appear as an invalid link to browsers of your site.  To remedy this, try to address the problems 
(which may be related to network errors, bad directory file names on either the local or remote machine, or something 
else), and then try uploading the files again. 
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Tutorials  

Chapter 16 : Tutorials  

This chapter contains tutorials on building a new case in Simulator and starting from an existing case in Simulator.  
They were originally created for use from the on-line help, although they can be used in text format as reproduced 
here. 

Creating a New Case 

Creating a New Case    Page 1 of 14 

This procedure describes how to create a simple power system model using PowerWorld Simulator.  This procedure 
was developed for use with version 8.0 of the package.  If you have an earlier version, please contact PowerWorld 
Corporation at info@powerworld.com for information on upgrading, or visit the website at http://www.powerworld.com.   

To begin, double-click on the PowerWorld Simulator icon.   This starts Simulator.  Simulator is used to create new 
cases, modify existing cases, and (of course) simulate power systems.  In this example, we will build a new case from 
scratch.  To create a case from an existing power flow case instead, please see Creating a Case from an Existing 
Power Flow File.   

To create a new case, select the File  > New Case from the main menu, or click the Open Simulation Case  
button on the File Toolbar.   The screen background will turn white, the default background color for new PowerWorld 
oneline diagram.  Oneline diagrams are used in power system analysis to represent the actual three-phase power 
system using a single line to represent each three-phase device. 
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Inserting a Bus    Page 2 of 14 

The most important component of the power system model is the bus.  Buses are used to represent junction points in 
the power system where a number of devices are connected together.  In building a power system model using 
Simulator, you will draw buses onto the oneline diagram, attach devices such as generators and loads to the buses, 
and connect different buses together with transmission lines and transformers. 

Inserting buses on the oneline diagram is very easy: 

• Select Insert > Bus  from the main menu, or select the Bus   button on the Insert Toolbar.  This prepares 
Simulator to insert a new bus. 

• Left-click on the oneline background at the location where you want to place the new bus.  This invokes the Bus 
Option Dialog (pictured below). 

• Use the Bus Option Dialog Box to specify the name, size, orientation, area, zone, and nominal voltage of the bus, 
as well as the load and shunt compensation connected to it. 

• Click OK on the Bus Option Dialog to finish creating the bus and to close the dialog.  After the dialog box closes, the 
new bus will appear on the oneline at the location you specified.   

 
 

For example, let’s add a bus to the new case.  Select Insert > Bus from the main menu and click somewhere in the 
middle of the display.  The Bus Options Dialog will open, inviting you to enter information about the bus.  The Bus 
Number fields will automatically display ‘1’.  Simulator requires that each bus have a unique number.  For 
convenience, we will just accept the default value.  In the Bus Name field, enter a name for the bus with up to eight 
characters.  For this example, enter ONE.  Next, check the System Slack Bus field, which is located toward the bottom 
of the Bus Information Tab.  The Slack Bus is a modeling construct that ensures that the power system has enough 
generation to meet the load.  In other words, the slack bus "picks up the slack" caused by system losses.  For now, we 
will just leave the remainder of the fields with their default values.  Click on the OK button at the bottom of the dialog to 
insert the bus.  You should now see a single horizontal line in the middle of the oneline; this is your first bus.   
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Inserting a Generator    Page 3 of 14 

Next we are going to attach a generator to the bus.  Generators may be inserted by following a procedure that is very 
similar to the one used for inserting a bus: 

• Select Insert > Generator from the main menu, or click the Generator  button on the Insert Toolbar. 

• Left-click the bus on the oneline diagram to which you want to attach the generator.  This brings up the Generator 
Option Dialog (pictured below). 

• Using the Generator Option Dialog, specify the new generator’s unit identifier, display size, orientation, MW output 
and limits, reactive power limits, setpoint voltage, and cost model. 

• Select the orientation of the generator; this is the direction in which the generator will extend from the bus. 

• Click OK on the Generator Option Dialog to finish creating the generator and to close the dialog.  After the dialog 
box closes, the new generator will appear on the oneline attached to the bus on which you clicked in step 2. 

• Check the Anchored checkbox so that when you move the bus around the oneline the generator will move with it. 

 
 

Follow this procedure to attach a generator to the slack bus, bus 1.  When the generator option dialog box appears, 
simply accept the default fields.  The oneline diagram should resemble the one shown below. 
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Saving the Case    Page 4 of 14 

To save the work that we have done so far, select File > Save Case from the main menu, or click on the Save Case 

 button.  Before the case is saved, Simulator validates the case to make sure that it does not contain any errors.  
Results from this validation are displayed in the Message Log display, usually shown in the lower right-hand corner of 

the display.  If the log is not visible, simply click the Log  button on the Program Toolbar.  Since we have not 
yet named the case, the Save As dialog is displayed.  Enter the filename and select OK.  By default the case is saved 
using the PowerWorld Binary format  (*.pwb).  When saving the case in the future, you will not have to reenter its 
name.  Simulator also asks you to supply a name for saving the oneline diagram we have been drawing.  The oneline 
diagram files have a default extension of *.pwd, which identifies them as PowerWorld Display files.  Supply the same 
name as you gave to the cas e.  Note that, because the case and the oneline are stored in separate files, multiple 
onelines can be assigned to the same case, and the same oneline can be used by many cases.   
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Entering a Second Bus with Load    Page 5 of 14 

To enter the second bus, select Insert > Bus from the main menu or click the Bus  button on the Insert Toolbar.  
Then click on the oneline diagram somewhere to the right of the first bus.  The Bus Options Dialog will open (pictured 
below).  Leave the bus number at the default value of 2, and enter the name TWO for the bus.  We also want to model 
a 200 MW, 100 MVR load at the bus.  To accomplish this, switch to Attached Devices tab and, under the Load 
Summary Information heading, click the button labeled Add or Edit Bus Load.  Enter 200 in the MW Value  field and 
100 in the Mvar Value field.   Click OK to close the load dialog.  Click on the OK button at the bottom of the dialog to 
insert the bus.  

 
 

At this point, the oneline diagram does not show the load at bus 2, even though it is represented in the power system 
model (you can confirm this by right-clicking on bus 2, selecting Bus Information Dialog from the resulting local menu, 
and inspecting the Load Summary Information fields again).  To draw the load on the oneline diagram, select Insert > 

Load from the main menu, or select the Load  button on the Insert Toolbar. Now, left-click the mouse near the 
right edge of this bus. You should immediately see the Load Options dialog box (pictured below), whose Constant 
Power MW and MVR fields confirm that the load is 200 MW and 100 MVR.  In addition to constant power loads, 
Simulator also allows the modeling of voltage dependent load. 
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{  

 

The Orientation field determines the orientation of the symbol when it is drawn on the oneline.  Check the Up entry to 
make the load point up.  Also, verify that the anchored box is checked.  By anchoring the load to the bus, the load 
moves anytime you move the bus.  Then click on the OK button to insert the load.  A circuit breaker symbol is 
automatically included with each load.   

Now, try moving bus 2.  To do this, click somewhere on the bus (not on the load). Holding down the left mouse, move 
the bus (this is known as "dragging").  The load should move as well, because it is anchored.  To reposition the load 
on the bus, simply click on the load, and then drag it (holding the left button down) to a new position on the bus.   

The oneline diagram should now resemble the one shown below. 
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Inserting a Transmission Line    Page 6 of 14 

To connect the two buses together, we will now insert a transmission line between them.  The procedure for inserting 
a transmission line involves the following steps: 

• Select Insert > Transmission Line  from the main menu, or click the Transmission Line  button on the Insert 
Toolbar. 

• Left-click at the point where you want the new line to originate.  This point is usually located on one of the proposed 
line’s terminal buses. 

• Without holding down the mouse button, drag the mouse.  You will notice that a line segment connected to the point 
of origin will follow your mouse movements.  Transmission lines and transformers are drawn as a series of line 
segments.  To terminate a line segment, simply click the left mouse button.  To begin drawing the next line 
segment, simply move the mouse again.  Each time you click the mouse to terminate a line segment, a new vertex 
is defined for the line.  These vertices may later be moved or deleted to reshape the line.  To create curved lines, 
hold the left mouse button down while dragging. 

• To terminate the final line segment comprising the line (and thus conclude drawing the line), double click the left 
mouse button at the point where the line should terminate.  The termination point is usually the line’s other terminal 
bus.  The Transmission Line/Transformer Dialog will appear (shown below). 

• Specify the new line’s parameters using the Transmission Line Dialog and click OK.  The new transmission line will 
appear on the oneline. 

 
 

We will now insert a transmission line between buses 1 and 2.  Select Insert > Transmission Line  from the main 
menu, and click at the point on bus 1 at which you would like the line to start.  This begins the process of inserting the 
line. Move the cursor upwards a short distance and then click the left mouse button to terminate the first segment. 
Then move the mouse horizontally until the cursor is above bus two and click the left mouse button to define the 
second segment.  Finally, move the cursor down to the location on bus 2 where you would like to attach the line and 
double-click.  You should immediately see the Transmission Line/Transformer Dialog.  The dialog should already 
contain a 1 in the From Bus Number field and a 2 in the To Bus Number Field.  The Resistance, Reactance, and 
Capacitance fields are used to enter the per unit parameters associated with the line. The Capacitance field contains 
the total per unit charging capacitance for the line.  Enter a 0.02 in the Resistance field, 0.08 in the Reactance field 
and 0.1 in the Capacitance field.  The MVA Rating field contains the MVA rating for the line; enter a value of 1000.  

If the dialog did not contain a ‘1’ in the From Bus Number field and/or a ‘2’ in the To Bus Number field, you probably 
did not have the cursor directly on the bus when you were drawing the line.  Simply enter the correct bus numbers.   
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Finally, click the OK button to insert the transmission line. 

By default, the transmission line is anchored to both terminal buses.  If you try to move bus 2, the transmission line 
should move with it.   
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Inserting a Line Flow Pie Chart on a Transmission Line     Page 7 of 14 

When the line is drawn it automatically has a line flow pie chart included.  You can include additional line flow pie 

charts by clicking on the Line Flow Pie Chart  button and then clicking near a line.  The Line/Transformer Flow 
Pie Chart dialog box appears (shown below); make sure that the From Bus and To Bus have the correct numbers, that 
the MVA rating is correct, and that Anchored is checked; you may change the size of the pie chart by typing in a value 
or using the arrows.   

 
 

Color and behavior of pie charts are set in the Oneline Display Options; right-click anywhere in the background of the 
oneline, select Oneline Display Options from the pop-up menu, and then select the Pie Charts tab (pictured below). 
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Inserting Circuit Breakers     Page 8 of 14 

We will now place circuit breakers on the line.  (If the line already has circuit breakers at each end, then Simulator has 
been instructed to insert circuit breakers automatically.  You can configure this option from the Default Drawing 
Options Dialog).  Circuit breakers are used to control the status of the line.  Click somewhere on the line near bus 1.  

Then select Insert > Circuit Breaker from the main menu, or select the Circuit Breaker  button and then click 
on the line near bus 1.  You should immediately see the Circuit Breaker Options dialog (shown below) with the From 
Bus and To Bus fields correctly set to ‘1’ and ‘2’.  If they are ‘0’, enter the correct value. Set the Size field to ‘1’ (you 
can either enter a 1, or use the spin arrows in change the value).  Click the OK button to insert the circuit breaker. 

 
 

In Simulator, the location of the circuit breaker does not matter, because changing the status of the circuit breaker 
changes the status of the entire line.  However, since most transmission lines have circuit breakers at each end, we 
will also place a circuit breaker near bus 2.  To accomplish this, just repeat the above process near bus 2.   

Save your case.  Your oneline should now look similar to the one below. 
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Inserting a Transformer     Page 9 of 14 

To insert a transformer we first need to insert a bus at a different voltage level.  Insert a new bus in the bottom of the 
oneline, named THREE, and enter 69 KV for its nominal voltage in the Bus Options dialog box.  Now, insert a 
transformer between buses 2 and 3.  Either go to Insert, Transformer in the main menu, or select the Insert 

Transformer  button.  Click on bus 3, and then draw a line to bus 2 as you did for a transmission line.  The 
Transmission Line/Transformer Options dialog box will appear.  Again, type values of 0.02 for Resistance, 0.08 for 
Reactance, and 0.10 for Charging.  Now, select the Transformer Control tab (shown below).  Enter 2 for the Off-
nominal Turns Ratio (because 138 ÷ 69 = 2), and leave the other fields at their default values.   

{  

 

Click the OK button, and the transformer should appear on the oneline.  Repeat this procedure to add a transformer 
between buses 1 and 3, and then add a 100 MW, 50 MVAR load to bus 3, as you did earlier at bus 2.  Your oneline 
should now resemble the one shown below. 
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Inserting a Switched Shunt     Page 10 of 14 

Switched shunts usually consist of either capacitors to supply reactive power (in MVAR) to the system, or reactors to 
absorb reactive power.  The switched shunts are represented by a number of blocks of admittance that can be 
switched in a number of discrete steps.  If at least one block is in service, the shunt is said to be online.  The shunt’s 
corresponding circuit breaker can be used to determine and to toggle the switched shunt’s status.  To insert a 
switched shunt at bus 3, either select Insert > Switched Shunt from the main menu, or select the Switched Shunt 

 button.  Click near bus 3, and the Switched Shunt Options dialog box appears (pictured below).  Verify that the 
bus number is 3; if it is not, change it.  Enter 10 for the nominal MVAR, and leave the other fields at their default 
values. 

 
 

Your oneline should now  look like the one below. 
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Inserting Text, Bus and Line Fields    Page 11 of 14 

We are almost ready to run our FIRST case.  However, before we do that, we are going to enter a few informational 
fields directly on the oneline so that we can see what is going on in the system more easily.  First, we will add a title to 
the diagram.  Select Insert > Text from the main menu to bring up the Text Object Dialog.  Type the string "First Case" 
and click OK.  To make the text look more like a title, we will do some quick formatting.  Select Format > Font to 
change the font.  This displays the Font Tab of the Format Selection Dialog.  Make the font size 26, and change the 
font color blue.  To change the text background color, select Format > Line/Fill, which summons the Line/Fill Options 
Tab of the Format Selection Dialog.  Check the Use Background Fill box to give the text a white background, and then 
click OK.  Finally, if you would like to move the text, simply left click on it and drag it to the new location.   

Next, we will add several fields that display bus -related quantities.  To add fields to the display of a particular bus, 
follow this procedure: 

 

• Right-click on the bus to bring up the bus’ local menu. 

• Select Add New Fields Around Bus  from the local menu.  This opens the Insert Bus Fields Dialog (pictured below).  
Select a position where you would like to add the new field and click OK.  You may add up to 8 fields per bus. 

 
 

• This opens the Bus Field Options dialog (shown below); designate the fields to add in the selected position and click 
OK.   
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• Click OK.  The specified bus fields will be added to the oneline diagram. 

 

For this example, we will add a Bus Voltage Magnitude field to each bus. By default, Simulator has inserted the bus 
names, generator and load MW and MVAR, and switched shunt MVAR.  First, right click on bus 1 and select the Add 
New Fields Around Bus option, which brings up the Insert Fields dialog.  Because Bus 1 is horizontal, the possible 
positions for the fields we will be adding are shown in the diagram located in the bottom right half of the dialog.  We 
will insert the voltage field in position 5.  Use the combo boxes to assign the Voltage field to position 5, and press OK.  
The voltage field appears on the oneline diagram around bus 1 in the position we specified.  Repeat this same process 
for buses 2 and 3.  If necessary, you may move fields manually with the mouse.   

Next, we will insert fields showing the power flow on the transmission line.  Right-click on the line between buses 1 
and 2 and select the Add New Fields Around Line option to bring up the Insert Fields Dialog.  Assign MW Flow to 
position 3 and MVAR Flow to position 4, and MW Flow to position 9 and MVAR Flow to position 10.  Click OK to add 
the fields to the oneline.  Follow the same procedure for the lines between buses 2 and 3, and 1 and 3. You may need 
to move the newly inserted fields with the mouse to improve their appearance.  At this point, your first oneline diagram 
should resemble the one shown below. 
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Solving the Case    Page 12 of 14 

We are now ready to solve the case.  First we need to enter the Run Mode.  To do this, simply click on the Run Mode  
button on the Program Toolbar.  Note that, if the case has validation errors, a warning will appear.  You will need to 
rectify the problems before you can enter Run Mode.  To start simulating the case, simply select Simulation > Play.  
Alternatively, to perform just a single Power Flow Solution, click the Single Solution  button on the Program Toolbar. 
Your case should look similar to the case shown below.  If it does, congratulations!  You have completed building your 
first case.   

 
 

Try clicking on the load circuit breaker to toggle the load’s status.  A solid red circuit breaker indicates that it is closed, 
a hollow green box indicates it is open.  While the simulation is running, click on the circuit breakers and note the 
nearly instantaneous change in system flows.   If the Log window is visible, you will get a "backstage" view of what 
Simulator is doing.  Feel free to close the log.  To re-open the log, click the Log  button on the Program Toolbar. With 
the load circuit breaker closed, try clicking on one of the circuit breakers for the transmission line between buses 1 and 
2. 

Congratulations, you’ve just blacked-out your case! 
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Adding a New Area    Page 13 of 14 

Next, we will create a second operating area for the case. Large interconnected systems usually have a number of 
control areas, with each control area responsible for the operation of a particular part of the system.  Often, a single 
control area corresponds to a single owner (such as an investor-owned utility), but it is not unusual for a single control 
area to have more than one owner.  Control areas are connected to neighboring areas through tie lines.  A tie line is a 
transmission line that has one end in one control area and the other end in another.  The total amount of power flowing 
out of a control area is the algebraic sum of the power flowing out on all the area’s tie lines.  Each control area is 
responsible for procuring enough power to meet its own load plus losses.  The control area can get this power either 
by generating it itself, or by buying it from another area.  This ability to buy and sell power (i.e., power transactions) is 
one of the principal advantages of interconnected operation.   

To create another control area, go back to editing by clicking the Edit Mode button.  Right click on bus 3 and select 
Bus Information Dialog from the dropdown menu.  In the Area Number field enter ‘2’; in the Area Name field enter 
‘TWO’.  Entering a number for an area that does not already exist automatically creates a new area.   

To verify that the case now has two areas, select Case Information > Case Summary from the main menu.  The 
Case Information displays allow you to view the entire case using non-graphical displays.  The Case Summary  dialog 
(shown below) shows the number of buses, generators, lines/transformers, and control areas in the case.  You cannot 
modify any of these values.   

 
 

Now we will make sure that both of the control areas are initially set as being on automatic generation control (AGC).  
AGC insures that the generation in the area is equal to the load plus losses plus and scheduled transactions.  Select 
Case Information > Areas .  The Area display (pictured below) provides a convenient summary of all the control areas 
in the case.  Similar displays exist for buses, generators, lines/transformers, etc.   

 
 

Right-click anywhere on the record for the first area and select the Show Dialog option. The Area Display Dialog is 
shown (as below).  Change the Area Name to ‘ONE’ and set the AGC Status to ED Control.  Select SAVE to save this 
information.  Next click on the up arrow next to the right of the Area Number field.  This displays the Area Record 
dialog for the next area.  Set the AGC Status to ED Control, and select OK to save your changes and close the dialog.  
Close the Area Records display as well.   
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Case Customization    Page 14 of 14 

Simulator allows you to customize your case in a number of different ways.  We will touch on just two of these options 
in this section.   

For example, suppose we want to prescribe how the load should vary over the course of the simulation.  To 
accomplish this, first switch back to Edit Mode, and then select Case Information > Other > Load Variation 
Schedules from the main menu.  The Load Schedule display will appear.  Use the Load Schedule display to define 
how load should vary over time.  These prescriptions are stored as records, which may then be associated with a 
particular area or areas to govern how the load changes in those areas during the simulation.  At this time, no load 
schedules exist, and you will thus have to define one.  Right-click in the Load Schedules display and select insert from 
the dropdown menu.  The Load Schedule Dialog appears (shown below).  Designate the Schedule Type as Daily.  
Then, edit the table that lists time points and corresponding load scales such that the load scale is 1.000 at hour 0, 0.8 
at 06:00, 1.3 at 12:00, 2.0 at 18:00, and back down to 1.000 at hour 24:00.  This load schedule might approximate a 
control area’s typical summer load variation, with peak load occurring in the late afternoon.  Then click the Save 
Record As button to save the schedule with name Area1Daily.  Click OK. 

 
 

Then, to associate the Area1Daily load schedule w ith Area 1, choose Case Information > Areas  from the main menu.  
Right-click on the record corresponding to area 1 and select the Show Dialog option.  In the resulting Area Information 
Dialog, go to the Options tab, and designate the load schedule as Area1Daily (pictured below).  Then, when you 
restart the simulation, you will find that load in area 1 will vary according to the Area1Daily load schedule.  The same 
load schedule can be applied to the other area in the case, or you may define a new load schedule. 
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As another example of customization, we will explore how to change the animation of power flows.  Select the 
Animated Flows Tab of the Oneline Display Options  Dialog by selecting Options/Tools > Oneline Display from the 
main menu.  Check the Show Animated Flows  box and the Use Fill Color box.  Then select the Change Fill Color 
button.  Select a greenish color.  Then choose OK to close the Color dialog and OK again to close the Oneline Display 
Options Dialog.  Save the case and again start the simulation in the Run Mode, by clicking on Simulation > Play 
Case. You should see the power flowing down the line.  Notice that the load in area 1 is changing and that the 
generation changes as well to maintain the balance between supply and demand. 

Starting with an Existing Case 

Starting with an Existing Case Page 1 of 15 

This procedure describes how to create a power system model from an existing power flow file using PowerWorld 
Simulator.  This procedure was developed for use with version 8.0 of the package.  If you have an earlier version, 
please contact PowerWorld Corporation at info@powerworld.com for information on upgrading, or visit the website at 
http://www.powerworld.com. 

This tutorial assumes that you have at least some familiarity with PowerWorld Simulator.  If you need a more general 
introduction, please see Creating a New Case tutorial.   

PowerWorld cases can easily be created from existing power flow cases stored in PTI version 24, PTI version 23, and 
IEEE common format.  Simulator provides a static model of a power system.  For some studies this model is sufficient.  
For other studies the model can be augmented by adjusting generator cost information, the reactive capability curve, 
the time variation of the load, and the PowerWorld case options. 

To begin, double-click on the PowerWorld Simulator icon.  This starts Simulator.  In this example we will be building a 
case from an existing power flow file. 
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Loading an Existing Power Flow File  Page 2 of 15 

Once Simulator has been started, set Simulator to Edit Mode by clicking on the Edit Mode button on the Program 

Toolbar.  Select the File > Open Case from the main menu, or select the Open Case  button on the File Toolbar.  
An Open dialog box will appear on the screen.  To select a power flow file, click on the Type of File field in the lower 
left hand corner of the dialog box.  A list of file formats will appear.  Choose the appropriate format, and the available 
files of the type selected will appear in the box above Type of File .  Choose the desired file from the list of available 
files and select OK.  In this example, we will be building a oneline for the 3990 bus MAIN 1998 summer case saved in 
PTI version 23 format as mdb98s.raw.  When prompted to create a oneline, select ‘yes’.  Your display should 
immediately turn white.  This shows the blank background upon which you will be drawing the oneline diagram for your 
case.  Onelines are used in power system analysis to represent the actual three-phase power system using a single 
line to represent each three phase device.  The information from the power flow file is now accessible to Simulator. 
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Case Information Displays  Page 3 of 15 

Simulator presents many different Case Information Displays to provide a text-based view of the case.  For example, 
to view or modify the description of the case, selec t Case Information > Case Description from the main menu.  The 
Case Description Dialog should appear, showing the text description of the power flow case.  In PowerWorld, this 
text description may be arbitrarily long.   

You can also obtain a case summary by selecting Case Information > Case Summary from the main menu.  The 
summary dialog will appear.  It provides a summary of the case and of the total case load and generation.  None of the 
fields in this dialog can be changed, as they are intended for informational purposes only. 

The Area/Zone Filters information display is another important article.  The Area/Zone/Owner Filters feature restricts 
the contents of other case information displays to certain areas or zones.  This is particularly useful for large cases.  
Open the Area/Zone Filters display by selecting Case Information > Area/Zone Filters from the main menu, or use 
the Area/Zone Filters button on the Options/Info Toolbar.  As with all Case Information Displays, you can click on a 
column heading to sort the list on a particular field; click on that same column heading again to reverse the sort order.  
To change a particular area’s area/zone filter status, simply left-click on the area’s area/zone filter status field.  To 
change the filter status for all areas in the case, right-click on the display to bring up its local menu (all case 
information displays have a local menu), and select either Toggle All Yes or Toggle All No. For our example, set all 
areas to ‘no’ except WUMS. 

Another important text-based display is the Power Flow List.  The power flow list shows the complete power flow 
information for all areas whose area/zone filter is set to ‘yes’.  To display the power flow list, select Case Information 
> Power Flow List.  The power flow list has other options that can be accessed by right-clicking anywhere on the list.  
If you wish to view more details about a particular device, you can do so by holding down the Ctrl key and left-clicking 
on the device.  To move through the list of buses, you can use the arrow keys or the scroll bar.  If you are viewing a 
particular bus and you wish to view a bus connected to it, double-click on the line connecting the two buses to view the 
flows at the other bus.  Note that some of the transmission lines have a circuit identifier of ‘99’.  Whenever a ‘99’ is 
used for an identifier, it usually means that the transmission line is an equivalent line. 

A shorter version of the power flow list can often be more useful.  Such a display is offered by the Quick Power Flow 
List.  The Quick Power Flow List is similar to the power flow list except that it shows flows at individual buses or a set 
of buses, regardless of area/zone filter settings.  You can view flows at any bus in the case.  To display the quick 
power flow list, select Case Information > Quick Power Flow List from the main menu, or press the Quick Power 

Flow List  button on the Options/Info Toolbar.  Identify the buses of interest In the Bus Number field by entering 
the number of either a single bus, a set of buses separated by commas, or a range of buses specified using a hyphen.  
Again you can double-click to move to a desired bus, or choose Show Object Dialog from the display’s local menu to 
see the information dialog for any object. 
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Solving the Case  Page 4 of 15 

To solve the power flow case we have been using in this example, press the Single Solution button on the Program 
Toolbar.  You may wish to show the Message Log before you solve the case so as to monitor the solution process.  
When you choose to perform a Single Solution, the application automatically switches to Run Mode if it is not already 
there.  The system has initial mismatches because of voltage truncation in the power flow file.  The case should 
converge quickly, perhaps in 2 or 3 iterations.  After the single solution has been performed, Simulator now has the 
solved power flow in memory, and you are ready to build the oneline. 

It is not necessary that the power flow case be solved before you create the oneline.  However, we recommend that 
you solve the existing case first to make sure that it is valid. 
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Building Onelines  Page 5 of 15 

PowerWorld Simulator makes the power system case easier to analyze by presenting results visually using a oneline 
diagram.  You do not need to represent every bus in the power flow model on the oneline, for a oneline diagram need 
be created only for the desired portion of a system under study.  Simulator can automatically link the constructed 
oneline diagram to the existing power system model.  The following sections of this tutorial will discuss placing various 
visual components onto a oneline diagram.  In all of the following sections the actions described will relate to the 
aforementioned MAIN example. 
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Entering a Bus  Page 6 of 15 

The most important component of the power system model is the bus.  Buses are used to represent junction points in 
the power system where a number of devices connect together.  To build a oneline diagram, you draw the buses, 
attach devices such as generators and loads to the buses, and connect the buses together with transmission lines and 
transformers. 

To begin entering devices onto the blank oneline, you must first switch to Edit Mode.  If you are not already in Edit 
Mode, switch back to Edit Mode now.  Show the Quick Power Flow List and move it towards the bottom of the screen.  
Show bus 39820 by typing that number in the Bus Number field.  Select Insert > Bus  from the main menu, or click 

the Bus  button the Insert Toolbar.  Click on the oneline towards the top center to define the point at which the 
new bus will be added.  The Bus Information Dialog will appear.  In the Bus Number field enter 39820.  Select Find 
by Number to view the bus information.  You should see the information appear in the Bus dialog fields that 
corresponds with the MAIN power flow case.  Select OK to place the bus.  The bus should now appear on your 
screen.   

If it has not already been done for you automatically, add a bus field identifying the new bus’ number immediately to 
the left of the new bus.  To do this, click on or to the left of the display object that represents bus 39820 and select 

Insert > Field, Bus  from the main menu.  Alternatively, click the Bus Field  button on the Insert Toolbar.  The 
Bus Field Options Dialog will appear for you to fill out.  Designate the type of field as Bus Number and close the dialog.  
Simulator will add a text object showing the bus number at the point where you had clicked.   

Repeat this procedure to place buses 39881 and 39821 on the oneline, along with their bus numbers. 
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Automatic Line Insertion  Page  7 of 15 

Transmission lines between buses can be inserted manually by choosing Insert > Transmission Line  from the main 

menu or pressing the Transmission Line  button on the Insert Toolbar, clicking on the beginning bus, and 
tracing a line to the ending bus.  Vertices may be defined along the way by clicking the mouse on the diagram where 
vertices should appear.  However when creating a case from an existing power flow file, you also have the option to 
insert transmission line display objects automatically.  To do this, select Insert > Auto Insert > Lines from the main 
menu in Edit Mode.  Accept the default options and click OK.  The lines joining the visible buses on the display are 
automatically added, along with circuit breakers and pie charts, provided those options are set.  Simulator will draw 
only transmission lines that link buses that have already been drawn on the oneline diagram.  If you add another bus 
to the diagram, you can again auto-insert lines, and Simulator will only insert lines that are not already present on the 
display. 
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Panning and Zooming Page 8 of 15 

Two features of Simulator are indispensable when you have a large, detailed oneline:  panning and zooming.  To pan 
from side to side or up and down, either use the arrow keys or the scrollbars on the sides of the oneline.  To zoom in 
or out of the oneline, hold the Ctrl key down and press the up arrow to zoom in and the down arrow to zoom out.  For 
the example, pan up and insert buses 39819 and 39841, again with bus analogs showing their numbers.  Again use 
Insert > Auto Insert > Lines to add the transmission lines. 
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Adding Background  Page 9 of 15 

Sometimes you may wish to insert background elements on a oneline such as bodies of water or state lines to convey 
geographic location.  To show static background elements on the oneline, select Insert > Background Graphic > 
Background Line , or click the Background Line  button on the Insert Toolbar.  Click on the diagram to start the 
background line and to add segments.  Double click to terminate the background line.  If you wish to fill in the area 
inside the background line or change the background line’s color, select the background line and choose Format > 
Line/Fill from the main menu and make the appropriate choices in the resulting dialog.  You may wish to experiment 
now with drawing background lines or objects and with adding fill color. 
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Simulating the Case  Page 10 of 15 

Once you have constructed a oneline diagram showing the area of interest, you can simulate the case.  Simulator 
cannot only show the magnitude and direction of flows on transmission lines, but it can also animate them.  To 
configure the animated flows, switch to Edit Mode and choose Options/Tools > Oneline Display from the main 
menu.  Select the Animated Flows Tab  of the resulting dialog box.  Check the Show Animated Flows check box to 
enable the animated flows at run time.  This dialog box also allows you to change the size, density, and fill color of the 
animated flows for easier visualization.  At this point, just click OK.  Next, save your case by selecting File > Save  from 

the main menu or by pressing the Save   button on the File Toolbar.  If you have not already saved the case, a 
Save As dialog will prompt you to select a name.  Both the oneline diagram and the case will use this name.   

To perform the simulation, switch to Run Mode and select Simulation > Play or Simulation > Restart from the main 
menu.  You should now see Simulator modeling the 3990-bus case. 
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Run-time Object Dialogs  Page 11 of 15 

While the simulation ensues, you might want to view or change some study parameters.  To do this, first pause the 
simulation so that you will not lose any simulation time while you are viewing or adjusting the parameters.  (Note that 
you do not have to pause the simulation to tweak parameters.  You can adjust anything in the case while the 
simulation runs, too.)  Then, right-click on any of the objects on the display.  This will bring up the run-time dialog for 
the object.  Many of the parameters on this dialog can be modified, and the new settings will take effect when the 
simulation is restarted. 
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Oneline Local Menu   Page 12 of 15 

Several options are available at run time from the oneline diagram’s local menu.  To call up the menu, right-click on an 
empty portion of the oneline to display.  The local menu will appear. Use it to print the oneline, save it as a metafile, or 
copy it to the clipboard.  You can also find a particular bus on the oneline, access panning and zooming options, set 
oneline display options, view information about the power system area in which you clicked, create a contour plot, and 
use the difference flows activity, all from the oneline local menu. 
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Area  Records   Page 13 of 15 

Often, system data is most conveniently displayed by area.  To view the Area Records Display, select Case 
Information > Areas from the main menu.  The resulting display summarizes information about all the areas in the 
case.  You can sort the entries by clicking on the column labels. 
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Limit Violations     Page 14 of 15 

You can view a report of limit violations by selecting Case Information, Limit Violations from the main menu.  A 
display showing bus voltage violations, line/transformer violations and interface violations will appear.  If the Use Area 
/ Zone Filters on List Displays  is checked, then the displayed violations will correspond only to areas whose Shown 
field is set to Yes on the Area/Zone/Owner Filters display. 

If you wish to see more information on a bus that appears in the violation list, right-click on the bus number and select 
Quick Power Flow List from the resulting local menu.  If the case information display is set to refresh automatically, the 
list of bus voltage violations will update as new violations occur.   
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Other Case Information Displays     Page 15 of 15 

In addition to the few displays discussed in this tutorial, Simulator offers many other case information displays.  In 
most cases, you can view information about buses, generators, lines, transformers, loads, and zones simply by right-
clicking on the object in question and choosing the appropriate option from the object’s local menu.  The best way to 
become more familiar with the displays and the information contained in them is simply to play with a Simulator case 
and oneline.  Simulator’s interface has been designed to be simple and intuitive.  If you run into problems, the On-line 
Help should prove helpful. 
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