Introduction to PowerWorld Simulator: Interface and Common Tools

16: Contouring and Advanced Visualization

PowerWorld Corporation

2001 South First Street
Champaign, Illinois 61820
+1 (217) 384.6330

support@powerworld.com
http://www.powerworld.com
Contouring and Advanced Visualization

- Contouring
  - Underlay your oneline with an image
  - Detailed examples covered
- More Advanced Features will be demonstrated
  - Geographic Data Views
    - Auto-created geographic data visualization
  - Emphasis of Display Objects
    - Make specific objects standout on your oneline
  - Dynamic Formatting
    - Allows for Conditional Dynamic Formatting of Onelines and Case Information Displays
  - Geographic Information System (GIS) Support
    - Reading ESRI Shapefiles (*.shp/*.dbf/*.shx groups)
    - Writing and reading KML files (used by Google Earth)
    - Read existing coordinate data
Contouring Visualization
Contouring Visualization

- What is Contouring used for?
- Using the Contour Options Dialog
- Examples
  - Bus Voltage Magnitudes
  - Line MVA Percentage Loadings
  - Line PTDFs
  - Many more...
- Recommendations on using Contouring
Uses of Contouring

• Analyze large amounts of information all at once
• Get an overview at a glance
• Monitoring data
• Presenting data
Contour Options Dialog

- Contour Options Dialog is used to control the contouring used on an oneline.
- Note: Contouring is available in Run Mode and Edit Mode.
- Contour Options Dialog can be viewed by:
  - Contouring option on oneline local menu
  - Onelines ribbon tab ➔ Contouring
Contour Options Dialog - Contour Type Left Side

Select object type to contour. Only object types currently present on the oneline will be displayed.

Select the value you want to contour

Used for doing “line contours”

Recalculate does the same thing as OK, but does not close the dialog.
Contour Options Dialog - Contour Type Right Side

Choose the Color Map you want

Set the brightness of the colors

Define the range of values in the color map

How to interpret the color map values
Contour Options Dialog - Interpretation

• Options for interpreting the Contour min, max, break high, break low, and nominal values

• Fixed Values (Default)
  – Use user input values
  – User input values have the same units as the contoured quantities

• Dynamic Values
  – Automatically determine min, max, nominal, etc.
  – Max = maximum data point value
  – Min = minimum data point value
  – Nominal = Average data point value
  – Break high = (Max+Average)/2
  – Break low = (Min+Average)/2
Contour Options Dialog - Interpretation

• Standard Deviations
  – Calculate mean, standard deviation
  – Put all values in terms of standard deviations away from the mean
  – User input values for min, max, etc are used with units of standard deviation (stdev)

• Percentiles
  – Sort data points from lowest to highest
  – Give the greatest data point a value of 100
  – Give the smallest data point a value of 0
  – User input values are used with units of percent (pct)
Contour Options Toolbar

• Select the contouring drop-down to show the same options available in the dialog.
Contour Options Dialog - Contour Type Options

- Area of influence about each contoured point
- Dynamic contouring adjusts influence region according to density of data points
- If Use Fade To Value is checked, then
- Percentage at which contour begins to fade towards the Fade To Value
- Set contour resolution
- Using Graphics Processing Unit can greatly speed up contouring. Option will automatically be disabled if graphics card cannot handle contouring acceleration.
Contour Type

• Specify the type of display object that should be used for contouring
• Specify the value of the respective object to use
• Specify an Advanced Filter... to reduce what is contoured.
Values

• These define the values used in the color maps. (The color key displays the values)

<table>
<thead>
<tr>
<th>Value</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum</td>
<td>Red</td>
</tr>
<tr>
<td>Break High</td>
<td>Yellow</td>
</tr>
<tr>
<td>Nominal</td>
<td>Green</td>
</tr>
<tr>
<td>Break Low</td>
<td>Cyan</td>
</tr>
<tr>
<td>Minimum</td>
<td>Blue</td>
</tr>
</tbody>
</table>

(all values above are mapped to dark red)

(all values below are mapped to dark blue)
Color Maps

- Simulator offers several default Color Maps
- For contours for which both low and high values are of significance (such as Bus Voltages) the following color maps are recommended

Blue = Low, Red = High

Reverse Colors To get this
Color Maps

- For contours for which only high values are significant, Radar Map High Limits is recommended.

- For contours for which only low values are significant, Radar Map Low Limits is recommended.
Discrete Color Maps

- Simulator also comes with several discrete color maps.
- Some examples are shown below.
Draw Color Key

• Checking Draw Color Key tells Simulator to draw a “color key dialog” along with the contour

• The color key dialog looks like:
Contour Resolution

- Sets the resolution of the contour
- High means a better picture with more computation time required
- Low means a “grainy” picture with less computation time
Influence Region

• Controls how large the “influence distance” is for a data point.

Influence Region Small

Influence Region Large

Note: These images are using the **Fade To Value**
Fade To Value

• As a value’s influence moves away from the actual data point, the value “fades” to a user-specified value.
  – The same data is contoured in the figures below with different Fade To Values
  – Nominal, Maximum, Minimum
Use Fade To Value

- Uncheck the **Use Fade To Value**
  - Same picture as previous slide but we are no longer fading
Kind of Value: Actual Value

- Actual Value (Weighted Average) and Actual Value (Only Closest) both attempt to visualize the values of particular points.

**Weighted Average** creates a gradient by weighting colors by their distance from data points.

**Only Closest** creates a color based only on the value of the closest data point.
Kind of Value: Density of Values

- Density of Values causes the colors on the contour to represent a Weighted Sum
- Useful when you want the following two situations to be equivalent
  - 1 bus with 600 MW of load
  - 6 buses next to each other with 100 MW of load each
Kind of Value: Density of Values

- When using this option, the Influence Region has a great impact on the contour image created
  - Increasing the Influence Region, will cause the “sum” to be taken over a larger number of data points which will increase the values shown in the contour.
**Data Points Per Line**

- Specifies the number of points used to represent a line in the contour algorithm

- Data Points Per Line = 3

- Data Points Per Line = 15
Continuously Update Contours

- Sets Simulator to regenerate a contour each time the system is updated.
- You can animate the contour by checking this
- Note: Because Simulator must now calculate the contour at each time step, this may slow down the simulation
  - Try reducing the resolution to speed up the animation
Custom Color Maps

- Set range of color map
- Shows custom color map as changes are made
- Create custom color maps designed to show any contoured values highlighted in a specific manner
Color By...
Percentage

- Color by Percentage takes the Value and maps it to a Percentage using the Maximum,... Minimum Values specified on the first tab
  - The percentage is then mapped to a color using the Color Map
  - Advantage: Color Maps can be reused
    - Bus Per Unit Voltage, Marginal Cost, anything can use same
  - Disadvantage: You can only specify 5 values that map to specific colors
Color By... Value

- Color By Value removes the intermediate percentage
  - Value is mapped directly to Color using the Color Map
  - Advantage: You can be more precise with your coloring
    - You want to color bus objects by AREA Number using 20 specific colors
  - Disadvantage: You can’t easily reuse the Color Map.
Defining the Color Map

• “Percentages” map to values defined on Contour Type Tab.

Abs Max = 100%
Lim Max = 75%
Nominal = 50%
Lim Min = 25%
Abs Min = 0%
Bus Voltages in TVA at 161 kV
Line MVA Flow Percentage in the Eastern Interconnection
Power Transfer Distribution Factors (PTDFs)
Marginal Prices in PJM for 2:00 PM on August 20, 1999

Average $28.47
Standard Deviation 2.71
Recommendations for Contouring

- Task-specific displays
  - Make your onlines so that they only convey one idea
  - For instance, don’t show line pie charts on a bus voltage display. This creates clutter.
Voltage Contouring

- Sometimes run into strange contours due to LTCs.
- To avoid this, create onelines that only have one voltage level’s buses displayed
  - Can create a different oneline for each voltage level if desired
Geographic Data Views

• Allow quick creation and formatting of graphical representations of devices
  – Buses, generators, loads, switched shunts, transmission lines, substations, areas, zones, super areas, and injection groups

• Longitude and latitude coordinates must be specified with bus and/or substation records to place objects geographically on a display
Geographic Data Views

• Data field values used to format objects based on different attributes
  – Line Thickness, Line Color, Fill Color, Total Area, Rotation Angle, Rotation Rate, Visibility

Options for creating available from the Case Information Toolbar under the Geo menu

• Geographic data view objects can be added to existing or new onelines
Geographic Data Views

- Geographic Data View Styles contain the set of options that dictate how a Geographic Data View object will look
  - Multiple objects will use the same style
  - Styles are dependent on the type of object being displayed
Geographic Data Views: Customization Dialog
Geographic Data Views

Represents selected generators’ maximum Mvar increase
Emphasis of Display Objects
Emphasis of Display Objects

- Emphasis of Display Objects
  - Make specific objects standout on your oneline
  - Builds on the Select by Criteria abilities
  - Combines this with the use of graphical *alpha blending* which merges two images together
  - To get to this
    - Go to the **Options** ribbon tab and select **Oneline Display Options** and click **Emphasis Filter** on **Display Options** page
Select by Criteria Dialog for choosing what to emphasize

- Selecting what to emphasize works just like Select by Criteria

Choose all Transmission Line Objects

Click Add/Modify Filter to define an Advanced Filter called Add Branches >50%
Example image using the b7flat.pwb case and diagram

Lines above 50% loading are emphasized

Vary the amount of emphasis
Dynamic Formatting

• Allows for Conditional Dynamic Formatting of Onelines and Case Information Displays

• Builds on existing features: Select by Criteria AND Advanced Filtering

• Go to the Onelines ribbon tab and select **Dynamic Formatting**, then pick which of the two levels of formatting you want
  – With the Case: **Case Info / All Views and Onelines**
    • Can apply to case information displays, bus views, sub views, and ALL onelines
  – With Individual Oneline: **Active Oneline**
    • Will apply to only a single oneline
Dynamic Formatting Dialog: Case Info / All Views And Onelines

Choose Object Type

Choose an Advanced Filter

Choose the screen objects this should apply to or case information

Temporarily make the formatting not active

You can also FORCE an object to be visible

Choose Format Attributes

Choose Context Objects

Choose fields

Choose Fields to apply to for some kinds of objects

Only some attributes apply to case information displays
Dynamic Formatting Dialog: Active Oneline

- For an active oneline formatting, it’s the same, except that it only applies to this oneline.

Specify whether the oneline makes use of the dynamic formatting defined with the case.
Example Formatting of Lines Loaded above 50% in Pink

Lines above 50% loading are thick and pink
Dynamic Formatting Priority

• You can specify several dynamic formatting choices.
• It is possible that they will “conflict” with one another.
• A priority must be specified.
  – Specific oneline dynamic formats always have priority over case dynamic formats
  – Within the individual class, you must click the Set Format Priority... Button to give a priority order.
Dynamic Formatting Lookup Tables

Lookup tables allow the definition of a table of field values and corresponding characteristic values. For this example, bus object line color will change based on the value of the per unit voltage magnitude.

- Color if field value is less than the lowest defined value in the table
- Must check Use Lookup
Geographic Information System (GIS) Support
Geographic Information System Support

• Geographic Information System (GIS) Support
  – Reading ESRI Shapefiles (*.shp/*.dbf/*.shx groups)
    • To open a shapefile go to the Onelines ribbon tab and select GIS Tools → Insert GIS Data from Shapefile
  – Additional options under Onelines → GIS Tools
• Click on **Read in Shapefile** to import the Shapefile contents into Memory
• Use the **Modify** tab to modify the x/y coordinate of shapes
• Use the **Identify** tab to assign identifier for display auxiliary files and link supplemental data
• Use **Format** tab to modify the colors and format of the shapes
• **Shape List** tab lists all of the objects in the file and their corresponding attributes
• Click **Transfer Shapes to Oneline**... to place shapes on the oneline
GIS Shapefile Data Dialog: Modify Tab

- If Shapefile is specified in Longitude/Latitude Coordinates, Convert to a map projection
- You may also modify the XY data by shifting or scaling it.
Specify identifying string to use for uniquely identifying objects in display auxiliary file

Link to supplemental data to provide identification for filtering, dynamic formatting, Select by Criteria, and custom hints
• Modify the format of all the objects by choosing new attributes and clicking the button
• You may color using a Color Map if one of the data columns from the *.dbf file can be mapped accordingly
Finally, if you want more control, modify the attributes of the shapes directly.

- Specify the Format of each shape
- Data from *.dbf file
- Info from *.shp file
Example GIS Shapefile: Reading a Radar Image

A Weather Precipitation Radar Image on a Oneline
Combining GIS and Emphasis: Transmission System Emphasized

A Weather Precipitation Radar Image on a Oneline Transmission System Emphasized
Combining GIS and Emphasis: Weather Radar Emphasized

A Weather Precipitation Radar Image on a Oneline

Weather Radar Emphasized
KML Export and Import

• KML is the file format supported by geographical software such as Google Earth
• Simulator can write to KML files
  – Specify what objects and fields to export - small files are better
  – These files can be opened and viewed in Google Earth
• Simulator can read from KML files
  – The key fields must be correctly specified
  – Reads in one-line display object locations and format, does not modify fields of power system objects
  – Example, intended use of this feature:
    • Create KML files with Simulator
    • Modify objects, save as a new KML file, import back in
    • Ex., routing transmission lines, placing substations
KML Export and Import

- Onelines must have a valid map projection
  - Objects must be associated with a latitude and longitude
  - You can use the **Populate Lat,Lon with Display X,Y** tool
- Key fields are exported by default to allow you to read your files back in
  - Icons and placemarks with information appear for different object types
  - Objects are emphasized when mouse is over them

**Recommendations**
- It seems to be easier to work with several small KML files instead of one large file
- Use filters, and limit what object types and fields you export and import

**For more information about KML, see Google’s KML Reference:**
KML Export

On the **Onelines** ribbon tab, choose **GIS Tools** → **Export Oneline as KML**

- Click to save as a KML file. A prompt will ask you where to save.
- Optionally, add extra fields to export
- Object types supported by KML Export

Select what to Export

- **Transmission Line** (All Object Types)
- **Substation**
- **Area**
- **Zone**
- **Network**
- **Bus**
- **DC Transmission Line**
- **Generator**
- **Load**
- **Switched Shunt**
- **Three-Winding Transformer**
- **Transformer**
- **Transmission Line**
Viewing Exported KML Files

Oneline created in Simulator

Oneline objects exported to Google Earth

A dialog will appear when the export is complete
Viewing KML Placemarks

In the KML file, folders appear for each exported object type under the “PW Case Display Information” header.

A placemark is created for each object with a description and a table of fields.
Importing from KML

Ex: Move substation to new location and save it as a KML file.
Importing from KML

- Import to any oneline
- Objects can be linked or unlinked
- Importing can create objects

Ex: Importing the moved substation

Ex: Importing transmission lines to a new oneline
Additional GIS Tools

- Export Oneline as Shapefile
  - Create shapefile containing a single type of display object from a oneline display
- Great Circle Distance
  - Calculate the distance between two points of longitude, latitude
- Measure Lines
  - Measure the distance between points on the display by drawing a line connecting them
- Populate Lon,Lat with Display X,Y
  - Populate the Longitude and Latitude fields of buses and substations with location of the corresponding object on the oneline display
- Display shapefile database information with object created from shapefile
  - Right-click on object and select local menu option Show Shapefile Fields
Blank Slide