Introduction to PowerWorld Simulator: Interface and Common Tools

I5: Data Aggregation using Areas, Zones, Interfaces, Super Areas, Injection Groups

PowerWorld Corporation

2001 South First Street
Champaign, Illinois 61820
+1 (217) 384.6330
Aggregation of Data

- Areas and Zones
- Interfaces
  - Flowgates, Cutplanes, and Paths can be defined as interfaces
- Nomograms
- Bus Pairs
- Super Areas
- Injection Groups
- Substations
- Difference Flows to compare different cases
  - values in the case (loads, gen MW outputs, etc...)
  - Also compare the topology of the case
- Owners, Balancing Authorities, and Data Maintainer
Area and Zone Records

• Area and Zone definitions are part of standard power system case text formats
• Each bus is assigned to exactly one area
• Each bus is assigned to exactly one zone
• Generators, Shunts, and Loads are normally assigned to the same area as their terminal bus
  – However, they may also be given their own area and zone designation
Area and Zone Layouts

- Areas and Zones do NOT have to be contiguous
- Zones are often “sub-areas”, but this is NOT required. They can overlap as shown below
  - Areas (thick lines)
  - Zones (shaded/nonshaded)
  - A single area may consist of multiple zones, while a single zone can include buses from multiple areas
What are Areas and Zones For?

• Areas and Zones
  – Provide summary data about a group of power system elements (total load, generation, losses, etc...)
  – Provide way to filter data (Area/Zone filters)
  – Limit Monitoring Settings for Area/Zone
  – Toggle settings for equivalencing, scaling, etc...

• Areas ONLY (control settings)
  – Ability to perform automatic generation control (AGC)
  – Ability to specify MW transfer between areas
  – Ability to toggle control settings across a group of elements
    • AGC, Generator AVR, Shunts, Transformers
  – Ability to enable OPF/SCOPF constraint enforcement
Assigning Area and Zone Designations

• To create a new Area or Zone
  – Open Model Explorer and choose Network → Buses or open the Bus Dialog and assign an existing bus to a new Area/Zone number; OR
  – Select Insert… from the local menu (right-click) in Area Records or Zone Records; OR
  – Auxiliary files or Copy/Paste from Excel

Enter a new number to create a new Area

<table>
<thead>
<tr>
<th>Number</th>
<th>Name</th>
<th>Area Num</th>
<th>Area Name</th>
<th>Nom kV</th>
<th>PU Volt</th>
<th>Volt (kV)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>One</td>
<td>4</td>
<td></td>
<td>138.00</td>
<td>1.00000</td>
<td>143.9</td>
</tr>
<tr>
<td>2</td>
<td>Two</td>
<td>1 Top</td>
<td></td>
<td>138.00</td>
<td>0.99269</td>
<td>136.9</td>
</tr>
<tr>
<td>3</td>
<td>Three</td>
<td>1 Top</td>
<td></td>
<td>138.00</td>
<td>1.00000</td>
<td>138.0</td>
</tr>
<tr>
<td>4</td>
<td>Four</td>
<td>1 Top</td>
<td></td>
<td>138.00</td>
<td>1.00665</td>
<td>138.9</td>
</tr>
<tr>
<td>5</td>
<td>Five</td>
<td>1 Top</td>
<td></td>
<td>138.00</td>
<td>1.04000</td>
<td>143.5</td>
</tr>
<tr>
<td>6</td>
<td>Six</td>
<td>2 Left</td>
<td></td>
<td>138.00</td>
<td>1.04000</td>
<td>143.5</td>
</tr>
<tr>
<td>7</td>
<td>Seven</td>
<td>3 Right</td>
<td></td>
<td>138.00</td>
<td>1.04000</td>
<td>143.5</td>
</tr>
</tbody>
</table>
Moving Bus Zones and Creating New Zones via the Zone Dialog

- Buses can be assigned individually to zones using the Bus dialog.
- Groups of buses can be moved to different zones using the Zone Information dialog.
- The Zone Information dialog is available by right-clicking on the zone name on the Zone Records display.
Edit Mode Zone Information Dialog

Zone number

List of all buses in the zone

To move a group of buses to a new zone, set the new zone number here

Then click to move the selected buses
Run Mode Zone Dialog

- Use combo box and/or arrows to view other zones.
- Tells range of AGC generation in zone.
- Zones can have tie-lines, but AGC on zones is not allowed.
- Can also set new zone numbers here.
Interface Definition

- Interfaces are groupings of branches and sometimes other elements
- The sum of the flows on these elements can then be monitored in the analysis tools
- Common interfaces are the grouping of tie lines between areas, and groupings of lines between important parts of the system.
- Interfaces can be used to model several commonly described groupings of lines
  - Flowgates – term used in the Eastern United States
  - Cut-Planes – term used in the Western United States
  - Paths – term used in the state of California
  - Nomograms – Used throughout the industry
Interface Records

• Interface records can be used to show flows between areas and/or zones.

• Interface records showing area to area flows can be automatically inserted by
  – Open Model Explorer and choose Aggregations → Interfaces to display interface records
  – Select Interface records → Auto Insert Interfaces from the local menu to display Auto Insertion of Interfaces Dialog
Interface Records

Right-click and select **Interface records** → **Auto Insert Interfaces**

Select either **Area to Area**, or **Zone to Zone** flows
Defining Custom Interface Records

• Open Model Explorer and choose **Aggregations → Interfaces** to view the Interface display.

• Right-click and select **Insert** to add a new interface.

• The Interface Dialog is shown.

• We’ll set up an interface showing flow on two parallel lines.
Monitored Interface Dialog

- Change Interface Name: *Top Export*
- Modify Interface Limit A (MW): *400*
- Click **Insert New Element** button to add a new Interface Element
  - Type: *Line/Transformer*
  - Near: 2 (Two)
  - Far: 6 (Six) CKT 1
- Repeat For
  - Type: *Line/Transf.*
  - Near: 5 (Five)
  - Far: 7 (Seven) CKT 1
Interface Element Type

- **Line/Transformer**
  - Monitor the flows on a line (direction is important!)
- **Area to Area, and Zone to Zone**
  - Monitor the sum of the flows on all tie lines
- **Line Open/Close Contingency**
  - When defining these, it means that all monitoring on this interface is done after this Line Open/Close contingency
- **DC Line**
  - Monitor the flow on a DC Line
- **Injection Group, Generator, Load**
  - Monitor the output of a group of generators or loads
  - Allows you to put a limit on the sum of outputs
- **MS Line**
  - Monitor the flow on a multi-section line
- **Interface**
  - Monitor the flow/output of another interface
  - *Be careful not to create circular references*
Monitored Interface Dialog

- **Interface Name**
- Add a new element to the interface
- Lists all elements in interface. Right-Click and Choose **Show Dialog** to modify
- Use spin button to view other interfaces
- Set weighting of individual elements
- Add or delete interfaces

Add New Interface
Delete Interface
Find Interface
Limits (MW)
Limit A
Limit B
Limit C
Limit D
Limit E

Monitoring Direction
- FROM → TO
- TO → FROM
- Monitor Both Directions

Non-contingent MW Flow Contribution
Contingent MW Flow Contribution
Total MW Flow
PTDF Value (%)
Interface Element Weightings

• Right-click on the list of elements and choose Display/Column Options
• Add the columns Weighting and Pre-Weight Flow
• This allows your interface to monitor the weighted sum of flows instead of the pure sum
• This will be used extensively with Nomogram Definitions
Nomograms

• Nomograms allow definition of 2-dimensional limit spaces using 2 interfaces
Nomograms

• Open Model Explorer and choose **Aggregations → Nomograms** to bring up a list of Nomograms

• Right-click and choose **Insert…** to bring up the Nomogram Dialog for adding a new Nomogram

• A nomogram is defined by
  – Interface A
  – Interface B
  – A set of breakpoints
    • Breakpoints MUST create a “convex” region

• Nomogram limits can be used in ATC, contingency analysis, and OPF/SCOPF
Interfaces are defined the same as before

Define Interface A

Define Interface B

Specify Breakpoints

Graphical representation of the breakpoints; operating region may span 4 quadrants
Nomogram Interfaces

• For each nomogram, Simulator creates a list of *nomogram interfaces* which are managed internally
  – This is done by using element weightings based on Interface A, Interface B, and the Breakpoints
  – “number of breakpoints minus 1” nomogram interfaces are made
• The “monitoring” will then occur for each nomogram interface level.
  – Everywhere you see references to interfaces you will now also see references to nomogram interfaces
Nomogram Interfaces

• Once you have defined a Nomogram, then the **Aggregations → Nomogram Records** tab will have a second sub-tab that lists the Nomogram Interfaces
  – Note: you can not edit Nomogram Interfaces directly. You must modify the Nomogram itself instead
  – Nomogram Interfaces are identified by their Nomogram Name
    • Nomogram Segment
Bus Pairs

- Bus Pairs can be used to compute voltage angle differences between buses.

From Bus and To Bus define the Pair

Present Angle Difference
Area/Zone/Interface
Oneline Graphics

- Oneline diagrams traditionally contain information regarding individual power system elements (buses, lines, generators, etc...)
- Simulator also allows you to create diagrams based off the aggregate data objects
Area Fields

• Area fields can be added to onelines to show a number of area fields.

• Area fields can also be used to specify base transactions.

Area fields are inserted in Edit Mode from the Draw ribbon tab, choosing Field ➔ Area Field

• By default, area fields are linked to the area associated with the closest bus on the oneline.
Area Field Dialog

- Anchor the field to the area object so that both can be moved together; include units suffix.
- Use combo box to select an area or entire case.
- Other Area Number Required for certain field types.
- AGC Status can be toggled on the oneline.

Area number 0 (zero) represents the whole system!
Area Field Example

• Add several area fields to the B7FLAT case
  – Area Name
  – Area MW Flow to Other Area (or case)
  – Scheduled Flow to Other Area
  – Load Schedule Multiplier
  – AGC Status
B7FLAT with Area Fields

Scheduled MW flows

Text fields

Left-click to toggle AGC in Run Mode

Area fields
Area, Zone, and Super Area Objects

- Separate oneline object types for Areas, Zones, and Super Areas

- On B7FLAT case
  - From the File Menu, select **New Oneline** to make a new oneline
  - Add area objects for each of three areas
  - From the File Menu, select **Save Oneline** to save the oneline. Use b7flata for the name.

- Zone and Super Area objects are similar
Right-click on object, then select Information Dialog... for the Area Display Options.

Same procedure for zones or super areas.
Area or Zone Palette

- Similar to the Bus Palette, you can also bring up an Area or Zone Palette.
  - On the **Draw** ribbon tab, select **Show Insert Palette For Zones** (or Areas).

![Zone Palette for Midwest.pwd](image-url)
Interface Fields

• Several types of objects are used to display interface data on the oneline
  – Interface Objects: like transmission lines
  – Interface Fields: like line fields
  – Interface Pie Charts: like line flow pie charts
Auto Insertion of Interface Objects

- Interface objects can be auto inserted (just like line objects).
- In edit mode, from the **Draw** ribbon tab, select **Auto Insert → Interfaces**.
- Allows insertion of interfaces and pie charts.
- Interfaces are automatically anchored to area/zone objects.
Auto Insertion of Interface Objects

Example interface object showing flow from Top area to Left area.

Set default pie chart size.

Select OK to auto insert the interface objects.
With Interface/Area Fields

Text field and area field

Pie charts require that interface limits be defined

Right-click on object to view area dialog

Animated flows can be shown
Super Areas

• Super areas are groupings of individual areas; analogous to an area being a grouping of individual buses

• Super areas can be used to control several areas together

• Open Model Explorer and choose Aggregations → Super Areas to see the Super Area Records
  – Right-click and select Insert...
  – Super Area Dialog is displayed with default name assigned to the new super area
Super Area Dialog

Control for Super Area; this control overrides all individual area control settings unless on No Super Area Control.

Add by name or add by numbers.

Areas already included.
Super Area Dialog

Area Interchange Information

Super area summary information
Super Area ED Control for B7Flat Case
Injection Groups

- Represents grouping of injections of power
  - Loads
  - Generators
  - Switched Shunts
  - Other Injection Groups (be careful of circular references)
- Useful for defining more specific groups of sources and sinks in many tools
  - Especially useful for ATC, PVQV tools; also for Sensitivities (PTDF, TLR, etc...)
  - Also useful for general reporting, e.g. make an aggregation of generators and show the sum of their output
Injection Groups

• Open Model Explorer and choose Aggregations → Injection Groups
  – Right-click, select Insert...
  – Injection Groups Dialog is displayed with default name assigned to the new injection group
  – Right-click in the Participation Points grid and Insert elements into the injection group or click Insert Points

• Auto Insertion also available from the local menu in Model Explorer
Injection Groups

Add loads, generators, shunts, or other injection groups

Choose how to determine the participation factor for each element

Click to Add

Elements already in the injection group

Elements available for adding
Injection Group Participation Points

• Injection Groups are made up of “Participation Points” which have two main attributes
  – Reference to a generator, load, switched shunt, or another injection group
  – Participation factor
    • Note: this participation factor is independent of the generator object’s participation factor

• When you create a participation point, you can define the initial participation factor for the point using various methods.
  – This is depicted on the following slide
Injection Group Participation Points: Participation Factors

• For a generator, the choices for participation factor are shown to the right
  – Specify particular value
  – Use generator’s participation factor
  – Base on positive reserve (Max – Present MW)
    • All units will hit their maximum at same time
  – Base on negative reserve (Present – Min)
    • All units will hit their minimum at same time
  – Base on MW capability (Max MW)
  – Use Custom Floating Point Field

• Recalculate Factors Dynamically
  – Normally the participation factor will only be calculated at this time.
  – Check this box to automatically recalculate the factors EVERY TIME they are used
  – This way, if you use the injection group with a different case or different system state it will still be what you intend.
Injection Group Display Objects

- You can also insert display objects which represent Injection Groups.
- On the **Draw** ribbon tab, choose **Aggregation** → **Injection Group**.
- Click on the oneline where you would like to place the injection group.
- Display objects show the generation and load which exist inside the group.

![Image showing 767.94 MW Generators and 360.00 MW Load]
Substations

- Some substations in a power system have a large number of buses in them
  - Large power stations
  - Other important places in a power system
- Traditional Power System Cases do not have any reference to which “substation” a bus is inside (but this is changing)
- Simulator allows you to define this relationship and then create substation-based diagrams

27 Grand Coulee Buses are placed in a single substation
Creating Substations

- To create a new Substation
  - Make sure you’re in Edit Mode (for all methods)
  - Open **Network → Buses** in the Model Explorer or open the Bus Dialog and assign an existing bus to a new Substation number; OR
  - Select **Insert**... from the local menu (right-click) in Substation Records; OR
  - Auxiliary files or Copy/Paste from Excel

Enter a new number to create a new Substation.
Substation Display Objects

- You can also insert display objects which represent Substations
- From the **Draw** ribbon tab, choose **Aggregation → Substation**
- Click on the oneline where you would like to place the injection group
- Note: You can also auto-insert transmission lines between Substation objects

Symbols indicates whether Generation, Load, or Shunts exist inside the substation

Name of Substation

Number of buses which are assigned to the substation
Difference Flows

• Simulator allows two different power system cases to be simultaneously loaded
  – Present Case
  – Base Case

• Difference flows allow viewing of either case or of the differences between the cases

• Changes in status are shown using OPEN/CLOSED fields (present case status listed first)
Difference Flows Dialog

• The Difference Flows dialog is used to control which case is being viewed.

• The Difference Flows dialog can be viewed by either
  – **Difference Flows** option on oneline local menu
  – **Difference Flows** on the **Tools** ribbon tab
Difference Flows Dialog

Select to set present case as the base case and enable the other options.

Select to change which case is being viewed.

Once base case has been set, its values cannot be changed.

Clears the base case from memory.

The difference flows options affect the onelines AND the case information displays.
Load Increased by 20%

Load increased by 20 percent in the top area

Click to change view

Viewing the Current Case
All fields now show the difference between the present case and the base case.

Case Information Displays also show differences.

You can NOT change values in the difference mode!
Difference Flows: Change Mode

- Shows the present values of quantities that are different in the present case than in the base case.
- Quantities that are equal (within tolerance) in both cases are blank.
Comparing Two Different Case Files

- Simulator only allows one case to be open at a time.
- When you open a case, all information about the previously opened case is removed, with one exception
  - The Difference flows information is kept
- Thus to compare two cases, you
  - Open case #1, and go to Run Mode
  - Open Difference Flows and choose Set Present as Base Case
  - Open case #2
  - Open Difference Flows and change to Difference Case
Topological Comparison of Cases

- On the **Tools** ribbon tab, choose **Difference Flows** → **Present Topological Differences from Base Case** ...

  Go to folders for detailed lists

  ![Image of topological differences summary]

  Set tolerances for different fields for use in **Change Mode**

  Columns show the number of new, removed elements

  **New**: elements in the present case which are not in the base case

  **Removed**: elements not in the present case which were in the base case

  **Both**: element in the present case and the base case
Topological Differences: Elements Removed Tab

- **Removed → Network → Branch** provides a list of branches in the Base Case that are not found in the Present Case.

- **Link Status**: provides reason they were not found in the Present Case.
Owners

- Like Areas and Zones:
  - each Bus is assigned to exactly one Owner
  - Gens/Loads/Shunts typically belong to the Owner as their terminal Buses, but they may be assigned to different ones
  - Can be used to select objects for System Scaling
- Generators, Shunts, and Branches may have multiple owners with associated ownership percentages
- Can be used Case Information Display filtering (Area/Zone/Owner/DataMaintainer Filters)
Balancing Authority

• Like Areas and Zones:
  – each Bus is assigned to exactly one Balancing Authority
  – Gens/Loads/Shunts typically belong to the Balancing Authority as their terminal Buses, but they may be assigned to different ones

• Balancing Authority is used primarily for aggregation of quantities like total generation/load
Data Maintainer

• Designate entities responsible for maintaining the input data for objects in the model
  – Provides contact information: name, email, phone number
  – Some features allow a user to write out only the data that belongs to a particular DataMaintainer

• Can be used for Case Information Display filtering (Area/Zone/Owner/DataMaintainer filters)
  – enable first in Simulator Options → Case Information Displays