Introduction to PowerWorld Simulator: Interface and Common Tools

I1: The PowerWorld Simulator Case Editor
Background
PowerWorld Simulator

• User-friendly and highly interactive power system analysis and visualization platform.

• Integrates many commonly performed power system tasks
  – Contingency Analysis, Time-Step Simulation, OPF, ATC, PVQV, Fault Analysis, SCOPF, Sensitivity Analysis, Loss Analysis, Transient Stability, GIC

• Designed to operate on Microsoft Windows XP/2003/Vista/2008/7/8 platforms
PowerWorld Simulator History

- Version 1.0 created in May 1994 at the University of Illinois Urbana-Champaign by Professor Thomas Overbye (Ph.D.)

- Impetus for early versions was to teach power system operation to non-technical audiences.
PowerWorld Simulator History

• PowerWorld Corporation was formed in 1996 with the goal of further developing and commercializing the Simulator tool.

• Simulator version 18:
  – Virtually unrecognizable from the early versions of the software.
  – Has evolved into a powerful power system analysis and visualization environment capable of solving very large systems.
Training Goals

• Provide a better understanding of how to use PowerWorld Simulator for power system analysis and visualization.

• Provide techniques for building good power system models and show how these techniques can be used to analyze system issues.
Training Goals

• Primary Goal: Make you aware of the capabilities of Simulator
  – We are frequently asked to add features to Simulator that are already available.
  – We want you to make the most of our software.
The PowerWorld Simulator Case Editor
Overview

• Simulator seamlessly integrates two functions once commonly separated in power flow software:
  – Graphical power system case editor
  – Power Flow package with many related analysis tools:
    • Contingency Analysis, Time-Step Simulation, Sensitivity Analysis, Loss Analysis, Fault Analysis, OPF, PVQV, ATC, SCOPF
  – Also, Transient Stability and Distributed Computing have recently become available
Starting Simulator

- On start-up, click File on the ribbon to access the File Menu.
Ribbon Interface

- Menus are integrated in the Ribbon interface
Ribbon Interface

- Selecting a menu item from the Ribbon reveals a set of task-specific buttons
  - Previous Slide shows the Case Information ribbon tab
  - Change to the Tools ribbon tab

- Interface is simplified by presenting only the buttons relevant to the selected menu item.
Ribbon Interface: Quick Access Toolbar

• Frequently-used buttons may be added to the Quick Access Toolbar, which is always visible
• Right click on button to add, then select Add to Quick Access Toolbar
Modes of Operation

• The graphical power system case editor and the power flow package are implemented in Simulator’s two distinct modes:
  – Edit Mode
  – Run Mode
Edit Mode

• Tasks
  – Create new power flow cases
  – Modify existing cases

• Abilities
  – Cases can be modified either graphically or via text displays
Run Mode

- Stand alone power flow
- Power flow analysis tools and sensitivities
  - Contingency Analysis
  - Time-Step Simulation
  - Optimal Power Flow (OPF)
  - PV and QV Curve Tools (PVQV)
  - Available Transfer Capability (ATC)
  - Security Constrained OPF (SCOPF)
  - Sensitivity Analysis
  - Loss Analysis
  - Fault Analysis
  - Transient Stability
  - Geomagnetically Induced Current (GIC)
Edit Mode

• Used to create a new case or modify an existing case.
• Use the Ribbon buttons to switch between modes.
• You can switch to Edit Mode at just about any time during a simulation.
• The tools and techniques of Edit Mode will be introduced by creating a new power flow case and by modifying an existing case.
Creating a New Case

Click the **File Menu**, then select **New Case**.

- Mode is automatically switched to Edit.
- Prompted to save any existing case.
- Display then turns to default oneline background color.
- Case may be built by graphically placing objects on the oneline.
Entering a bus

- Click anywhere on the oneline and select the **Draw** ribbon tab.
- In order to insert a bus, select **Network → Bus**
- Select point on screen.
- **Bus Options** dialog is displayed
  - set bus number to 1
  - set bus name to **ONE**
  - check **System Slack Bus** field
  - select **OK**
Bus Options Dialog

Each electrical island needs a slack bus for power balance (pick up “slack”)

Select **OK** to save changes AND close the dialog

Used to customize oneline appearance

Used to cancel bus insertion or changes
Entering a Generator

Select **Network ➔ Generator** from the **Draw** ribbon tab.

- Click on desired bus.

- **Generator Options** dialog is displayed
  - Enter 0 in the **MW Output** field of the **MW and Voltage Control** tab
  - Make sure **Anchored** box is checked
  - Click **OK** to accept default values of remaining fields
Generator Dialog

- Terminal bus number and name.
- Used to customize display appearance.
- Voltage/reactive power control fields.
- Status
- Cost models
- Rotor shape
Oneline Diagram
Saving the Case

To save the work done so far, select **Save Case**, from the **File Menu**.

- Before case is saved, validation is run to make sure there are no errors.

Validation results are displayed in **Message Log** display. To view the message log, click on **Log** button in the **Tools** ribbon tab.
Default Save Case Formats

• The power flow case itself is saved using the PowerWorld Binary format (*.pwb).
• The oneline is saved using the PowerWorld Display format (*.pwd).
• Saving the oneline information in a separate file allows using:
  – Multiple onelines with the same case
  – A single oneline with different cases
Entering a Second Bus

Again select the **Draw** ribbon tab, **Network → Bus**
Click to the right of the bus ONE

- Set bus name to **TWO**
- To model a load, select **Attached Devices** tab, click
  **Add or Edit Bus Load**, set **Constant Power MW** to **200**
  and **Constant Power Mvar** to **100**.

Select **Network → Load** to enter a load symbol

- Set **Orientation** to **up**
- Ensure **Anchored** box is checked
Moving Oneline Objects

• To reposition bus 1, left-click on the bus. Then, while holding down the left mouse button, drag the bus to the desired location.
  – Note that all attached (and anchored) objects move with the bus.
  – Individual objects such as generators and loads can be repositioned similarly.

• To reposition the entire oneline, click on the diagram (not on a specific object) and drag.
Moving Oneline Objects

• Keyboard shortcuts
  – Left-click on and select object(s) to move
  – Shift-arrow keys (up, down, left, right) move in small steps
  – Shift-Page Up moves object(s) up in larger steps
  – Shift-Page Down moves object(s) down in larger steps
  – Shift-Home moves object(s) left in larger steps
  – Shift-End moves object(s) right in larger steps
Panning Keyboard Shortcuts

• Pan Up
  – Up Arrow key
  – Page Up key pans quickly

• Pan Down
  – Down Arrow key
  – Page Down key pans quickly

• Pan Left
  – Left Arrow key
  – Home key pans quickly

• Pan Right
  – Right Arrow key
  – End key pans quickly
Zooming

• **Zoom** ribbon group under the **Onelines** ribbon tab
  – Zoom in and out buttons
  – Rectangular zoom selector
  – Zoom percentage
• **Mouse wheel zooming**
  – Enable Mouse Wheel Zooming option on Simulator Options dialog, Oneline page
• **Zoom In**
  – Ctrl-Up Arrow key
  – Ctrl-Page Up key zooms in quickly
  – Ctrl-Alt and use left mouse button to select region on which to zoom in
• **Zoom Out**
  – Ctrl-Down Arrow key
  – Ctrl-Page Down key zooms out quickly
  – Ctrl-Alt and use right mouse button to select region on which to zoom out
Undo Oneline Actions

• Accidental edits on oneline diagram can be undone
• Found on **Draw** ribbon tab
• Does not work with Case Information Displays
• Does not affect changes to power flow case
Undo Oneline Actions

- Oneline actions are stored in system memory
- Memory limit for undo action can be adjusted in the Options ribbon tab → Simulator Options → Environment page
Drawing Grid

• An invisible drawing grid helps align oneline objects. By default, all objects snap to this grid.
• Hold done the ALT key while moving an object to temporarily disable “snap-to-grid”.
• To enable/disable the grid:
  – Select the Options ribbon tab → Oneline Display Options
  – See Snap Options to Grid field on the Grid/Highlight Unlinked page.
Entering a Transmission Line

Transmission lines are drawn as a series of line segments

• To enter a transmission line between buses 1 and 2
  – Select the **Draw** ribbon tab, **Network → Transmission Line**.
  – Click on bus 1. This begins process of inserting the line.
  – Move cursor to desired location, then left-click to enter a segment, double-click on terminal bus to end.

• **Note**: Clicking and dragging mouse when drawing transmission lines is usually NOT recommended. This will produce a curved line with many segments.
Entering a Transmission Line

- After double-clicking, **Transmission Line/Transformer Options** dialog is displayed
  - **From** and **To Buses** and **Circuit** are set automatically
  - Set **Series Resistance** to 0.02
  - Set **Series Reactance** to 0.08
  - Set **Shunt Charging** to 0.1.
  - Set **Shunt Conductance** to 0.
  - Set **Limit A (MVA)** rating field to 400.
  - select **OK**
Terminal buses are usually set automatically.

Line status

Line parameters

Simulator allows eight different limits

Terminal buses are usually set automatically.

Line status

Line parameters

Simulator allows eight different limits
Modifying Line Routing

• After selecting a line, handles appear at each vertex
  – The cursor changes to a “cross-hair” symbol when moved over a handle.
  – Click and drag to move the vertex

• To add a vertex, hold down the Ctrl key and left-click at the desired insertion point

• To delete a vertex, hold down the Ctrl key and left-click on the vertex
Adding Circuit Breakers

- Circuit breakers are used to indicate status of lines and transformers (not true breaker representation).
- Location of circuit breaker on the line does not matter. Typically one at each end, automatically inserted.

To Insert, select **Indication → Circuit Breaker**, then click on desired location on transmission line. Verify the **Near Bus** and **Far Bus** values are correct

Save the case.
Two Bus Case
Text Fields

Descriptive text fields can be added to the oneline by selecting **Background → Text** from the **Draw** ribbon tab.

- Enter text *First Case* towards top of oneline

- **To change font and background color of text fields:**
  - Select the text field
  - Select the **Format** button
  - Change the font to blue, 26 point and the background to white.
Bus Fields

- Bus fields show information about bus devices, including loads and generators.

  Fields can be entered automatically, or manually. Choose **Field** in the **Draw** ribbon tab.

- Can choose type of field, digits to right and left of decimal, and whether or not it is anchored.
Line Fields

Line fields show information about transmission lines and transformers.

- For line fields, flow is always specified at an end of the transmission line or transformer.
- End is normally determined automatically by insertion point.
- Just like Text Fields, Bus and Line fields can be formatted using the options in the **Formatting** ribbon group.
Solving the Case

• To solve the case, click on Run Mode.
• Only permitted to change to Run Mode if there are no errors. Note that a system slack bus must be set.

• To animate the simulation, go to the Tools ribbon tab and select the Play button in the Power Flow Tools ribbon group.

• If not visible, click on Log to see a “backstage” view of the power flow solution.
Case Options

- To modify animated line flows, select the **Onelines** ribbon tab → **Oneline Display Options**. In the Dialog:
  - click on the **Animated Flows Page**
  - check **Show Flow Symbols**
  - check **Use Fill Color**
  - click on **Actual MW Fill Color**
  - select a light green color
  - select **OK**
Three Bus System Control

• To demonstrate how Simulator can be used to control a system, switch back to **Edit Mode** and add the following:
  
  – A third bus with 400 MW/200 Mvar of load and 300 MW of generation
  
  – Transmission lines joining bus 1 to bus 3, and bus 2 to bus 3. Use the same line parameters as bus 1 to bus 2 line \((R = 0.02, X = 0.08, B = 0.1)\)
Three Bus System Control

• Select the **Case Information** ribbon tab → Aggregations → Areas.

• Change **AGC Status** to *Part. AGC* by double-clicking on the field.

• Go back to the **Run Mode** and again select the **Tools** ribbon tab, **Play** button.

• Click on the circuit breakers to change their status; note how flows redistribute.
Three Bus System Oneline

Animated flows

Slack bus generator labeled “Slack”

Pie charts indicate the percentage MVA loading

Click on circuit breakers to toggle status

Generator rotor is voltage angle
Inserting Pie Charts

• Pie charts are usually automatically inserted.

For manually inserting, select the Draw ribbon tab, Pies/Gauges → Line Flow Pie Chart. Then click on the line midpoint.

• The pie charts are used to graphically indicate the percentage loading of each line.
Simulator Online Help Files: Case Sensitive

• Move your cursor over one of the generator objects on the oneline diagram.
• Press F1 key.
• This will bring up the online help for Simulator and take you to the help regarding that particular object.
• Try this for loads, lines, etc...
• This will also work for
  – Object Dialogs
  – Case information displays
  – and everywhere throughout Simulator
Drawing Defaults: Formatting FUTURE Oneline Display Objects

• In Edit Mode, select the Options ribbon tab → Default Drawing.

• Changes made here affect only FUTURE oneline display object insertions, not EXISTING objects.

• Click the Field Positions tab choose how fields are automatically inserted around an object.

• Position columns appear in grid. Double-click a position field to choose the type of field to display, or use the Field Positions diagram to set displayed fields.
Color Coding and Drawing Values

Field Positions tab sets text fields automatically inserted (next slide)

Set a default font size for all new text fields

Object default drawing values for kV range

Set Default Font

Use the default font size for new text fields (ignore object-specific sizes)

Recommended Multi-kV Level Defaults

Recommended Single-kV Level Defaults

kV Range and Color

<table>
<thead>
<tr>
<th>kV Range</th>
<th>Color</th>
<th>Font Size</th>
<th>Thickness</th>
<th>DB Size</th>
<th>PB Size</th>
<th>XFRMR Color</th>
<th>Line Gauge Color</th>
<th>Stub Size</th>
<th>Stub Space</th>
<th>Unit Highlight Color</th>
<th>Unit Highlight Magnification</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 &gt;600.00</td>
<td>Green</td>
<td>50</td>
<td>2</td>
<td>70.00</td>
<td>4.00</td>
<td>4.00</td>
<td>4.50</td>
<td>NO</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>2 &gt;400.00</td>
<td>Red</td>
<td>40</td>
<td>2</td>
<td>50.00</td>
<td>4.00</td>
<td>3.30</td>
<td>3.70</td>
<td>NO</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>3 &gt;300.00</td>
<td>Red</td>
<td>30</td>
<td>1</td>
<td>30.00</td>
<td>3.00</td>
<td>2.50</td>
<td>3.00</td>
<td>NO</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>4 &gt;200.00</td>
<td>Red</td>
<td>20</td>
<td>1</td>
<td>15.00</td>
<td>2.00</td>
<td>2.00</td>
<td>2.00</td>
<td>NO</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>5 &gt;100.00</td>
<td>Black</td>
<td>15</td>
<td>1</td>
<td>8.00</td>
<td>1.50</td>
<td>1.30</td>
<td>1.50</td>
<td>NO</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>6 &gt;0.00</td>
<td>Black</td>
<td>10</td>
<td>1</td>
<td>3.00</td>
<td>1.00</td>
<td>0.30</td>
<td>1.00</td>
<td>NO</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>
Auto Field Insertion
Click the Field Positions Tab

Type of fields being modified

Click on Positions to Add or Change Field Type Displayed
Formatting EXISTING Oneline Display Objects

• Default Drawing Values only allow you to change the default appearance of FUTURE display objects

• To change the format of EXISTING display objects, make use of the following features:
  – Selecting Multiple Objects
  – Formatting of Selected Objects
Selecting Multiple Objects

• Multiple oneline objects can be selected by different mechanisms:
  – Individually by left-clicking on objects while holding down Shift key
  – Using the Select buttons to select all objects in a region, available in the Select ribbon group under the Draw ribbon tab.
    • Hold Shift-Ctrl and drag with the left mouse button to select area that encompasses desired objects
    • Hold Shift-Ctrl and drag with the right mouse button to select area that encompasses desired objects and to retain currently selected objects
  – Using Select by Criteria, available in the Select ribbon group under the Draw ribbon tab.
Select by Criteria Dialog

Check the specific object types to select. Object types with multiple possibilities are marked with ->, and will open an additional selection window when checked.

Click OK to select all objects on oneline meeting specified criteria.

Criteria sets may be saved for easy re-use.

Objects can either be selected for entire case, or by specific areas/zones/ layers and by voltage level.
Select by Criteria: Choosing specific fields

- Clicking in a specific object opens new dialogs with more detail. Example: Bus Fields.
Choose specific Areas, Zones, or Screen Layers

- Choose the Tabs and check what you want
Use Advanced Filtering in Conjunction with Select By Criteria

- Click on the type of object you’re interested in and click Add/Modify Filter... (or just double-click on the Filter column)

[Diagram of the Select by Criteria Dialog]

- Double-click Dialog appears
Formatting Selection

- After selecting objects in Edit Mode
- Go to the **Formatting** ribbon group under the **Draw** ribbon tab, and choose **Format**
- You can also right-click on a selection and choose **Format**
Format Selected Object: Line/Fill

Line Information

Background Color Information
Oneline Diagram Enhancements: Resize/Rotate Objects

- Ability to resize and rotate oneline objects easily with your mouse.

- Green Circle: Rotation Point
- Gray Square: For looks only
- Black Square: Resize Handle
Screen Layers

• Add oneline objects to layers for customized views. Select the Onelines ribbon tab → Layers to create or modify screen layers
• Assign objects to layers using the Levels/Layers button on the Formatting ribbon group on the Draw ribbon tab
Object Oneline Display Levels

- Objects are shown on oneline using four different stack levels, base, background, middle and top.
- By default, different types of objects can have different levels. For example, transmission lines are level middle, while circuit breakers are level top.

  Stack level can be changed by first selecting an object, then using the Levels/Layers button on the Formatting ribbon group under the Draw ribbon tab.
Format Selected Object: Level/Layers

Change Stack Level

Layers

Fonts and Pie Charts can be set so that they only resize between particular zoom levels

Set these values to force a display object to not move or resize
Bring To Front / Send To Back

• What is shown on top is first governed by the stack level
• Objects within the same stack level can be moved relative to one another. Go to the Draw ribbon tab and choose the Bring to Front or Send to Back buttons from the Formatting ribbon group.
Size of an object can be changed.

Setting an object as immobile will prevent you from moving the object by dragging it with the mouse.

Objects such as generators have an orientation which may be changed.
Format Selected Object: Font

Font Information:
- Font Name
- Size
- Effects
  - Bold
  - Underline
  - Italic
  - Strikeout
- Font Color
- Rotation Angle

Color and Rotation Angle:
- Preview
- Make Default
Format Selected Object: Field

- Field Information
- Change how the field looks: digits, decimal and suffix
Multiple Object Selection Examples

- Open B7FLAT.pwb case
  - Select Yes when asked to save current oneline and case.

Use Select by Criteria on the Formatting ribbon group on the Draw ribbon tab to:
  - change the size of all the line flow pie charts
  - make all the MW flow line fields green
Apply Default Draw Values to Selection

• Another way to quickly change a large number of objects is to do the following
  – Select the objects you want to form using Shift-clicks or Select by Criteria
  – Right-Click on the Selection
  – Choose Apply Default Draw Values
  – Dialog at the right comes up
Applying the format of one object to another: Copy Format

- Select a group of oneline objects and then click the button Copy Format
  - This will copy all the attributes that are the same across the selected objects
  - For example: If all objects have a fill color (suppose they are RED), then it will copy this. But if some objects are RED while others are BLUE, it will not copy this attribute.
Paste Format

• After you have chosen to Copy Format, then the Paste Format button will be enabled.
• Now select another group of objects to apply the copied formatting to and click the Paste Format button
  – Only attributes that were the same across the copied selection will be enabled.
  – Check the attributes you would like to paste and click OK
Oneline and Document Links

• Create a link to another oneline by selecting the **Draw** ribbon tab, **Background** button ➔ **Oneline Link**
  – Clicking on this word will open up the other oneline

• Any file can be linked and its associated application will automatically open.
  – This means that power point files or word documents or spreadsheets can all be linked
Adding Pictures to the Oneline

To include pictures, such as bitmaps, JPEGs, or metafiles, on the oneline, select the **Draw** ribbon tab, **Background** button → **Picture**.

– Use Open Picture Dialog to find desired picture
– Dialog provides a preview window

• You can also use the Window’s Clipboard to copy objects from other programs, such as a graph from a spreadsheet or image from web.
Example: Company Logos