Application of Composite Load Models in the Power Flow

PowerWorld Client Conference
June 19, 2018

Gordon Comegys
gcomegys@ieee.org
Outline

• Description of feature
• Potential applications
• Example of past study result
• Instructions for a study
• Appendix - text for aux files
• Interactive Demonstration
# Description of Feature

<table>
<thead>
<tr>
<th>Background – development events in 2011-12</th>
<th>Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Composite load model for transient stability studies implemented in WECC cases</td>
<td>• Replaces the load objects with a distribution equivalent</td>
</tr>
<tr>
<td>• PowerWorld includes model using static parameters from the dynamic data records</td>
<td>• Includes</td>
</tr>
<tr>
<td>• Time Step Simulation tool enhanced to model</td>
<td>• step down transformer</td>
</tr>
<tr>
<td>• capacitor switching cut-in/cut-out voltage settings and time delays</td>
<td>• Voltage regulator</td>
</tr>
<tr>
<td>• transformer tap change time delays for first and subsequent tap changes</td>
<td>• Distribution line</td>
</tr>
<tr>
<td>• Motor parameters for static constant impedance, constant current, and constant power calculated for power flow application</td>
<td>• End use motor loads, electronic load, and ZIP static loads</td>
</tr>
<tr>
<td></td>
<td>• Excellent Simulator Help description (search for keyword “composite”)</td>
</tr>
</tbody>
</table>
Composite Load Model Potential Applications

- **Without Time Step Simulation**
  - Test failed solutions in contingency analysis with composite load model
    - If successful solution, the condition likely represents load area voltage stability limit exceeded condition developing over several minutes
    - System condition stable for the first 30 seconds
- **With Time Step Simulation tool**
  - Fast simulation of voltage instability scenario over timeframe of 5-20 minutes
  - Determine mitigating cut-in/cut-out voltage and time delay capacitor relay settings
    - Through trial and error, find threshold settings to reverse uncontrolled voltage decline
    - Settings to prevent hunting
    - Settings to minimize overvoltage effects at end user loads after system restoration
  - Determine effective undervoltage load shedding locations and settings
  - Fast multiple simulations to explore assumption sensitivities
Example of Past Study
Excerpt from ColumbiaGrid Past Study Documentation
Excerpt from ColumbiaGrid Past Study

- The system load restores close to the original after about a minute
- This is an indication the conditions do not exceed the voltage stability limit at that time point
- Notice before that time how the load begins to successfully restore, but then declines
- These are intermediate conditions that exceed the voltage stability limit, until capacitors switch in and bring it out of the condition
Preview of some setting changes unique to this application

- Disable Transformer Tap Control if Tap Sens. is the Wrong Sign (Normally Check This)
Switched Shunts and Transformer fields unique to this application
PNNL tool creates composite load model records, or use WECC case dyd file

Load model data tool

The tool generates load composition model in PSLF (.dyd) and PSSE (.dyr) formats.

Version history
Version 1.0
Supports PSLF18 and PSSE dynamic records

Version 1.1
Support of PSLF19 Long ID is added
Download LMDT version 1.1

Version 2.0
1. New analytical functions
2. New advanced user interface

Version 2.1
3. Multiple presets can be stored in the configuration file
4. Support PSSE CMLDBLU2 model

Version 2.2
(last update 2/27/2018)
5. Support PSLF CMPLDVG; PVD1 and DER_A (needs more testing)

Download LMDT version 2.2

LMDT 2.0 PowerPoint presentation (with step by step instruction)
Instructions For “Create Composite Load Model”

1. Optional for validation – fill bus custom float fields with base case load MW and MVAR quantities (File 1 in appendix)
2. Load WECC case dyd file, or create the composite load dyd records with PNNL Load Modeling Tool
3. In edit mode, click on Tools>Modify Case>Create Composite Load Model
4. Solve
5. Change motor loads to constant impedance, constant current, and constant power (File 2 in the appendix).
6. Solve
Instructions For Time Step Simulation Case Setup (aux file for steps 1-4 is File 3 in appendix)

1. Create a “No Contingency” contingency (use specific solution options, set to same as PowerFlow, set to zero the “min pu voltage for constant power load” and min pu voltage for constant current load”), set LDC_RCC to “PostCTG” and solve this selected contingency.

2. In Simulator Options>Power Flow Solution>Advanced Options, uncheck the “Disable Transformer Tap Control if Tap Sens. is the Wrong Sign”

3. In Transformer Controls case info display:
   a. Display Transformer>Time Step Simulation>Model Tap Delay
   b. toggle all “XF auto” to “No”
   c. filter case info “From Name” for string contains “Low Side” and toggle “XF auto” to “Yes” and Model Tap Delay to “Yes” for these transformers.
   d. optional: change default 15 seconds to 2 seconds for Transformer>Time Step Simulation>Next Move Delay Below and Next Move Delay Above
   e. Solve

4. Open Time Step Simulation (TSS) tool

5. Insert TSS time points for 1 second increments and set quantities to be monitored (instructions in Simulator help).

6. Insert TSS script command to simulate contingency

7. Run the Time Step Simulation and plot selected quantities
Sensitive Composite Load Model Assumptions to Investigate

- Distribution voltage regulator tap delays
  - Default is 30 seconds for the first delay (common) and 15 seconds for subsequent delays (varies widely).
  - Investigate actual field settings, or model worst case 2 second tap change delay after initial 30 second delay
  - Some long distribution lines have two voltage regulators, effectively giving twice the range (40% instead of 20%). Test sensitivity by increasing the range.
  - Base case starting tap might optimistically limit remaining boost range. Can be test by increasing the tap range.

- Load composition
  - The model parameters rely on data submitters correct climate zone and feeder type (PSLF load longID).
  - Confirm accuracy
  - If detailed composition is known, the PNNL LMDT provides user customization
Appendix - Text for aux files (copy and paste from these slides)

File 1- Optional for validating composite load model matches original bus load before conversion. To be applied before creating the composite load model

```
DATA (Filter, [ObjectType,FilterName,FilterLogic,FilterPre,Enabled],yes)
{
  "Branch" "CMPLDW TX Low Side" "AND" "NO" "YES"
  <SUBDATA Condition>
    BusName contains "Low Side"
  </SUBDATA>
}
DATA (CustomFieldDescription, [ObjectType,CustomType,CustomMaxOfType,CustomFieldCaption,CustomHeaderCaption],Yes)
{
  "Bus" "Floating Point" 2 "OriginalLoadMW,OriginalLoadMVR" "OriginalLoadMW,OriginalLoadMVR"
}
SCRIPT
{
  SetDATA(Bus,[CustomFloat:OriginalLoadMW,CustomFloat:OriginalLoadMVR],["@BusLoadMW","@BusLoadMVR"],All);
}
DATA (BGCalculatedField, [WhoAmI,ObjectType,VariableName,BGCalcFieldOperation,BGCalcFieldUseAbsolute,
  BGCalcFieldBlankEntries,FilterName,ObjectType:1,FilterLogic,FilterPre,Enabled],Yes)
{
  "CMPLDW_Tx_MW" "Branch" "LineMW:1" "Sum" "NO" "As Zeros" "YES" "Branch" "AND" "NO" "YES"
  <SUBDATA Condition>
    _UseAnotherFilter meets "CMPLDW TX Low Side"
  </SUBDATA>
  "CMPLDW_Tx_MVR" "Branch" "LineMVR:1" "Sum" "NO" "As Zeros" "YES" "Branch" "AND" "NO" "YES"
  <SUBDATA Condition>
    _UseAnotherFilter meets "CMPLDW TX Low Side"
  </SUBDATA>
}
DATA (DataGrid, [DataGridName,BGDisplayFilter,CaseInfoRowHeight,NonDefaultFont,FontName,
  FontStyle,SOFontSize,FontColor,VariableName,ConditionType,FilterName,
  ViewZoomLevel,FrozenColumns,RemoveTrailingZeros])
{
  "Bus" "YES" 13 "NO" "Segoe UI" 8 0 "High To Low" 100.000-1 "NO"
  <SUBDATA ColumnInfo>
    "BusNum" 75 8 2
    "BusName" 75 8 2
    "AreaName" 75 8 2
    "BusNomVolt" 75 8 2
    "CustomFloat" 75 8 2
    "CalcField" 75 8 2
    "CustomFloat:1" 75 8 2
    "CalcField:1" 75 8 2
  </SUBDATA>
```
File 2 (4 slides) – modify the constant MVA motor loads to ZIP parameters based on the paper “Application of the WECC Composite Load Model for use in Powerflow Studies” by James Randall (IEEE PES General Meeting July 2013)

```
DATA (CustomFieldDescription, [ObjectType,CustomType,CustomMaxOfType,CustomFieldCaption,CustomHeaderCaption],,Yes)
{
"Load" "Floating Point" 2 "OriginalSMW,OriginalSMVR" "OriginalSMW,OriginalSMVR"
"Load" "String" 1 "MotorSubType" "MotorSubType"
}
SCRIPT
{
UnselectAll(Filter);
UnselectAll(CustomExpression);
}
DATA (Filter, [ObjectType,FilterName,FilterLogic,FilterPre,Enabled,Selected],,yes)
{
"LoadCharacteristic_MOTOR_CMP" "A1" "AND" "NO" "YES" "YES"
<SUBDATA Condition>
  Lfm about 0.75 0.00001
  TSRa about 0.04 0.00001
  TSLs about 1.8 0.00001
  TSlp about 0.12 0.00001
  TSLpp about 0.104 0.00001
  TSTpo about 0.095 0.00001
  TSTppo about 0.0021 0.00001
  TSD about 0 0.00001
</SUBDATA>
"LoadCharacteristic_MOTOR_CMP" "A2" "AND" "NO" "YES" "YES"
<SUBDATA Condition>
  Lfm about 0.85 0.00001
  TSRa about 0.01 0.00001
  TSLs about 3.1 0.00001
  TSlp about 0.20 0.00001
  TSLpp about 0.165 0.00001
  TSTpo about 0.80 0.00001
  TSTppo about 0.0026 0.00001
  TSD about 0 0.001
</SUBDATA>
"LoadCharacteristic_MOTOR_CMP" "B0" "AND" "NO" "YES" "YES"
<SUBDATA Condition>
  Lfm about 0.75 0.00001
  TSRa about 0.03 0.00001
  TSLs about 1.8 0.00001
  TSlp about 0.19 0.00001
  TSLpp about 0.140 0.00001
  TSTpo about 0.200 0.00001
  TSTppo about 0.0026 0.00001
  TSH about 0.50 0.00001
  TSD about 2 0.001
</SUBDATA>
```
"LoadCharacteristic\_MOTOR\_CMP"  "B1"  "AND"  "NO"  "YES"  "YES"
<SUBDATA Condition>
Lfm about 0.85 0.00001
TSRa about 0.01 0.00001
TSLs about 3.1 0.00001
TSLp about 0.20 0.00001
TSLpp about 0.165 0.00001
TSTpo about 0.800 0.00001
TSTppo about 0.0026 0.00001
TSH about 1.00 0.00001
TSD about 2 0.001
</SUBDATA>

"LoadCharacteristic\_MOTOR\_CMP"  "C0"  "AND"  "NO"  "YES"  "YES"
<SUBDATA Condition>
Lfm about 0.75 0.00001
TSRa about 0.03 0.00001
TSLs about 1.8 0.00001
TSLp about 0.19 0.00001
TSLpp about 0.140 0.00001
TSTpo about 0.200 0.00001
TSTppo about 0.0026 0.00001
TSH about 0.15 0.00001
TSD about 2 0.001
</SUBDATA>

"LoadCharacteristic\_MOTOR\_CMP"  "C1"  "AND"  "NO"  "YES"  "YES"
<SUBDATA Condition>
Lfm about 0.85 0.00001
TSRa about 0.01 0.00001
TSLs about 3.1 0.00001
TSLp about 0.20 0.00001
TSLpp about 0.165 0.00001
TSTpo about 0.800 0.00001
TSTppo about 0.0026 0.00001
TSH about 0.2 0.00001
TSD about 2 0.001
</SUBDATA>

"Load"  "A1"  "AND"  "NO"  "YES"  "YES"
<SUBDATA Condition>
CustomString = "A1"
</SUBDATA>

"Load"  "A2"  "AND"  "NO"  "YES"  "YES"
<SUBDATA Condition>
CustomString = "A2"
</SUBDATA>

"Load"  "B0"  "AND"  "NO"  "YES"  "YES"
<SUBDATA Condition>
CustomString = "B0"
</SUBDATA>
<table>
<thead>
<tr>
<th>Load</th>
<th>CustomString</th>
<th>1phaseACmotor</th>
<th>BusName contains</th>
</tr>
</thead>
<tbody>
<tr>
<td>B1</td>
<td>&quot;A1&quot;</td>
<td>&quot;B1&quot;</td>
<td>&quot;MD&quot;</td>
</tr>
<tr>
<td>C0</td>
<td>&quot;A2&quot;</td>
<td>&quot;C0&quot;</td>
<td>&quot;MD&quot;</td>
</tr>
<tr>
<td>C1</td>
<td>&quot;A3&quot;</td>
<td>&quot;C1&quot;</td>
<td>&quot;MD&quot;</td>
</tr>
<tr>
<td>1phaseACmotor</td>
<td>&quot;A4&quot;</td>
<td>&quot;MD&quot;</td>
<td>&quot;MD&quot;</td>
</tr>
</tbody>
</table>

### SaveDataWithExtra

- CSVNOHEADER, LoadCharacteristic_MOTOR_CMP, [BusNum, LoadID], ["A1", ["CustomString", ["A1"]]
- CSVNOHEADER, LoadCharacteristic_MOTOR_CMP, [BusNum, LoadID], ["A2", ["CustomString", ["A2"]]
- CSVNOHEADER, LoadCharacteristic_MOTOR_CMP, [BusNum, LoadID], ["B0", ["CustomString", ["B0"]]
- CSVNOHEADER, LoadCharacteristic_MOTOR_CMP, [BusNum, LoadID], ["B1", ["CustomString", ["B1"]]
- CSVNOHEADER, LoadCharacteristic_MOTOR_CMP, [BusNum, LoadID], ["C0", ["CustomString", ["C0"]]
- CSVNOHEADER, LoadCharacteristic_MOTOR_CMP, [BusNum, LoadID], ["C1", ["CustomString", ["C1"]]

### SetData

- `Load:1` "A1_MW_Z" ".24606*x1/x2^2" CustomFloat:OriginalSMW "YES" "BusPUVolt" "YES" "NO" "Yes"
- `Load:2` "A1_MW_I" ".52725*x1/x2" CustomFloat:OriginalSMW "YES" "BusPUVolt" "YES" "NO" "Yes"
- `Load:3` "A1_MW_S" "1.28139*x1" CustomFloat:OriginalSMW "YES" """" """" "Yes"
- `Load:4` "A2_MW_Z" ".07673*x1/x2^2" CustomFloat:OriginalSMW "YES" """" """" "Yes"
- `Load:5` "A2_MW_I" ".17484*x1/x2" CustomFloat:OriginalSMW "YES" "BusPUVolt" "YES" "NO" "Yes"
- `Load:6` "A2_MW_S" "1.09811*x1" CustomFloat:OriginalSMW "YES" """" """" "Yes"
- `Load:7` "B0_MW_Z" ".1149*x1/x2^2" CustomFloat:OriginalSMW "YES" """" """" "Yes"
- `Load:8` "B0_MW_I" ".28307*x1/x2" CustomFloat:OriginalSMW "YES" "BusPUVolt" "YES" "NO" "Yes"
- `Load:9` "B0_MW_S" ".83138*x1" CustomFloat:OriginalSMW "YES" """" """" "Yes"
- `Load:10` "B1_MW_Z" ".0947*x1/x2^2" CustomFloat:OriginalSMW "YES" """" """" "Yes"
- `Load:11` "B1_MW_I" ".21097*x1/x2" CustomFloat:OriginalSMW "YES" "BusPUVolt" "YES" "NO" "Yes"
- `Load:12` "B1_MW_S" ".88373*x1" CustomFloat:OriginalSMW "YES" """" """" "Yes"
- `Load:13` "C0_MW_Z" ".10186*x1/x2^2" CustomFloat:OriginalSMW "YES" """" """" "Yes"
- `Load:14` "C0_MW_I" ".2549*x1/x2" CustomFloat:OriginalSMW "YES" """" """" "Yes"
"Load:15" "C0_MW_S" "0.84696*x1" "CustomFloat:OriginalSMW" "YES" "NO" "YES" "Yes"
"Load:16" "C1_MW_Z" "-0.08035*x1/x2^2" "CustomFloat:OriginalSMW" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:17" "C1_MW_I" "1.8034*x1/x2" "CustomFloat:OriginalSMW" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:18" "C1_MW_S" "0.89991*x1" "CustomFloat:OriginalSMW" "YES" "NO" "NO" "Yes"
"Load:19" "A1_MVR_Z" "1.75272*x1/x2^2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:20" "A1_MVR_I" "-1.86768*x1/x2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:21" "A1_MVR_S" "1.11496*x1" "CustomFloat:OriginalSMVR" "YES" "NO" "NO" "Yes"
"Load:22" "A2_MVR_Z" "3.5462*x1/x2^2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:23" "A2_MVR_I" "-6.39174*x1/x2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:24" "A2_MVR_S" "3.84564*x1" "CustomFloat:OriginalSMVR" "YES" "NO" "NO" "Yes"
"Load:25" "B0_MVR_Z" "1.87233*x1/x2^2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:26" "B0_MVR_I" "-2.3714*x1/x2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:27" "B0_MVR_S" "1.49097*x1" "CustomFloat:OriginalSMVR" "YES" "NO" "NO" "Yes"
"Load:28" "B1_MVR_Z" "3.00723*x1/x2^2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:29" "B1_MVR_I" "-5.29939*x1/x2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:30" "B1_MVR_S" "3.29216*x1" "CustomFloat:OriginalSMVR" "YES" "NO" "NO" "Yes"
"Load:31" "C0_MVR_Z" "1.88558*x1/x2^2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:32" "C0_MVR_I" "-2.93865*x1/x2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:33" "C0_MVR_S" "1.51307*x1" "CustomFloat:OriginalSMVR" "YES" "NO" "NO" "Yes"
"Load:34" "C1_MVR_Z" "3.04242*x1/x2^2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:35" "C1_MVR_I" "-5.36992*x1/x2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:36" "C1_MVR_S" "3.3275*x1" "CustomFloat:OriginalSMVR" "YES" "NO" "NO" "Yes"
"Load:37" "D_MVR_Z" "26.25874*x1/x2^2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:38" "D_MVR_I" "-44.51456*x1/x2" "CustomFloat:OriginalSMVR" "YES" "NO" "BusPUVolt" "YES" "NO" "Yes"
"Load:39" "D_MVR_S" "19.25582*x1" "CustomFloat:OriginalSMVR" "YES" "NO" "NO" "Yes"

}
File 3 – optional file useful for preparing the case for to apply the Time Simulation Tool with the composite load model (doesn’t include preparing settings for specific capacitor switching)

```plaintext
DATA {Filter, [ObjectType,FilterName,FilterLogic,FilterPre,Enabled],Yes} 
{
  "Branch" "CMPLDW Low Side" "AND" "NO" "YES" 
  <SUBDATA Condition> 
    BusName contains "Low Side" 1 
  </SUBDATA> 
} 
DATA {Contingency, [CTGLabel,Include,CTGIgnoreSolutionOptions],Yes} 
{ 
  "NoContingency-Set-LDC-RCC" "NO" "YES" 
} 
SCRIPT 
{ 
  SetDATA {Gen, [GenUseLDCRCC],["PostCTG"],All}; 
  SetDATA {Shunt,[AutoControl],["No"],All}; 
  SetDATA {Sim_Solution_Options, [SEODisableXFTapControllIfSensWrongSign,MinVoltILoad,MinVoltSLoad],["NO",0,0]}; 
  SetData{Branch, [XFAuto],["No"],All}; 
  CTGSolve("NoContingency-Set-LDC-RCC"); 
  SetDATA {Branch,[XFAuto,MoveDelay:2,MoveDelay:3],["Yes",2,2],"CMPLDW Low Side"}; 
} 
```